« first day (2086 days earlier)      last day (2960 days later) » 

7:18 PM
@Zacharee1 Not a web developer
so no, not really
only enough to "get by" in debugging some things
The API can be accessed with PHP, but I'd need help integrating that with the JS
... why?
if it can be accessed by PHP, why use JS at all?
So I can write the elements to the page
idk how with PHP and I barely figured it out with JS
7:20 PM
sounds like you want static HTML then
what are we doing?
'cause I can promise you the answer is not PHP :P
@Seth he needs to make API + JS + PHP working together
@ThomasW. well the elements are changing
and he says the API can be PHP-accessed
If I could have the JS read a returned PHP value somehow?
7:21 PM
@Zacharee1 are you saying JS can't interact with the API at all?
because right now it's just reading the what JQuery returns
It can, but it has the API keys exposed to the world
Why are you doing this server side?
Right now, you can go to x-p-w.tk/servers.html and see the stats below the tiles
Any ideas on my question?
The data is gotten with JQuery, and then JS interprets and filters it
It works, but the JQuery function has private data that could be used to delete files on the servers without a login
7:24 PM
It turns out Classical music + VM = slow and crashing computer. :D
jQuery has no server side access, so if jQuery can access the server you have waaaay more problems then accessing an API.
It's accessing a remote API
well I'd hope the API is remote.. Why would it be local?
And the Classical music carries on playing after I close the tab... :D
7:27 PM
That's Beethoven version of "Can't stop, won't stop"
damn wildcards, blew up my system.
Is this already spammy or just a not really great answer? askubuntu.com/a/787430/367990
Don't play with wildcards, kids -^
They are not your friend :/
Linux-style sex-ed : " Abstain form wildcards "
haha...any ideas on fixing it though?
7:32 PM
well, what command did you run
Q: Recovering uninstalled packages

Abhishek BhatiaI did sudo apt-get purge *pulse* ; sudo apt-get purge skype; dpkg -r skype; Issue: Now I can't login into kde. It doesn't show the kde bootscreen. Any ideas? I can still use CLI with Ctrl+Alt+F7.Is there anyway I can know exactly what I uniinstalled? What I have tried: sudo apt-get instal...

Doesn't apt ask confirmation before doing things?
I'm asking again, is this spam or not? askubuntu.com/a/787430/367990
I was in a hurry. :/
7:34 PM
It's pretty much advertising a specific site, but I think the OP did not mean to spam.
@AbhishekBhatia look into /var/log/apt/history.log , find the entry with your exact command, see what packages were removed , try to reinstall those or at least those you suspect to be cause of the issue
@ByteCommander As is ,it's just low quality post , it doesn't even contain a link
i left a comment on that by the way
> ... The web site for Packer is packer.io, and ...
@Tim what's the list ?
They're all dupes
7:39 PM
we have an upgoat
@Serg I'm supposed to be Downgoat actually but I accidentally flipped myself upside-down
can I ask git questions here?
You probably used a wildcard
Sure ask
not a guarantee we can answer tho
@Upgoat depends on the nature of them, but for the most part you can
So I have master branch with commit history:


and I have develop branch with history (y-z is the same as in the master branch):


I want the structure to be (as in develop is not a bunch of commits ahead of master as their HEAD is the same):

  master:            y-z
  develop: a-b-c-d-e-y-z

where z-y are aligned, but git thinks it's:

  master:  y-z
  develop: a-b-c-d-e-y-z
any ideas on how to address?
Does it matter until you merge them? And then it will sort itself out?
7:42 PM
because now when I merge them, every change is a conflict. It get's annoying when I have lots and lots of commits.
@Zacharee1 Where'd you go?
Hi I have a question can you guys help?
I see
@Pablo try
I want to use "return key" but in my keyboard is "enter" too
any way to change it?
So your develop branch's history goes back to before master
Enter = Return
7:43 PM
same key, two different names
@BharadwajRaju yeah, pretty much.
ah ok
hey but when I hit "enter/return" on terminal
just closes
what command was running when you pressed enter?
when temrinal asks for return
Do you have exit typed out before?
7:45 PM
I think it was sudo apt-get install steam
Try with a VT: Ctrl+Alt+F1
@Pablo let me guess when you start steam you get a message that your steam is outdated right tinue and that you shall press ENTER to continue ?
@Serg Thanks for the suggestion! This is the command bpaste.net/show/ab679eb59a31. Can you please suggest how to proceed now.
trying it
@AbhishekBhatia now for everything in the 'Remove:', install them
7:47 PM
Also maybe delete answer to that? Not sure...
@Abhi I see you have kde-baseapps-bin removed there,and you said your kde is not loading . maybe that's the cause ? sudo apt-get install kde-baseapps-bin
@Pablo open a terminal with ctrl+alt+t and use the following lines to fix your steam
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libpcre.so.3{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libpcre.so.3.12.1{,.disable}
Looks like lots of KDE has been removed
@BharadwajRaju how can I automate that, right now I am doing tail -n 100 /var/log/apt/history.log and then finding the command for the date.
sudo apt install --reinstall kubuntu-desktop should install most of them
7:51 PM
@Serg Unable to locate package kde-baseapps-bins
No s at the end of bin
@ByteCommander well that answer is correct but more than low quality
@Videonauth no, we can still salvage most data
^ that.
See the Q linked as dupe.
well good luck trying to guide someone who's so insecure that he simply installs something over his existing install through a data rescue where 50-90% are most likely gone anyways
7:56 PM
Need to review 14 more LQ posts tomorrow to get that golden Steward badge
Too bad I already used up my limit for today.
@Videonauth are you referring to me :p?
Let me greet you, my dear Vorlon! (@Fabby)
@Zacharee1 I've never needed jquery in my entire life!
@AbhishekBhatia No
7:57 PM
I hope you're in your after-work hours now?
@Fabby Don't say that at SO
@AbhishekBhatia nope tho this askubuntu.com/questions/787468/…
Is there anyway I convert this(bpaste.net/show/d12d8ba30909) to a bash script that installs all the package?
@ByteCommander Just a quick in-and-out... I was looking up the difference between a SAN director and a SAN switch and fell on a Q in Serverfault...
Any regex expert?
7:58 PM
I haven't gone out of house since the day i came back , no that i am out of smokes, i need to go get em. Anxiety !!!!
@BharadwajRaju Meh, why not?
I wanna stay in my room
They love jQuery to death.
@Videonauth oh sorry, I have been doing stupid stuff myself lately. :)
@Serg :) It's fabulous, but very tiring... Started this morning at 09:30 and am still busy...
7:59 PM
@BharadwajRaju Advanced yes, but expert? Not sure. What's your question?
Also, I haven't driven my car in a long time . . .anxiety++
Studying the EMC Connectrix family...
@BharadwajRaju D: jQuery?
in The Nineteenth Byte, Apr 25 at 3:15, by Downgoat
jQuery is horrible
@Fabby what's that ?
@Serg Shall I come over and lkick your butt?
8:00 PM
@Fabby please do, i need buttkicking lately, since my gf is not around
@Serg SAN switches/directors and connectors and interfaces.
@Serg GF???? Woohoo!
jQuery is awesome.
@Seth It's a good source code sample library...
@Fabby yes, that's a long story , but i'll tell you all about it at some point. Maybe once i set up the damn qtox ?
@ByteCommander Help @AbhishekBhatia out, this comment
8:01 PM
@Serg I have the opposite problem: GF is AROUND! ;)
@Upgoat Isn't downgoat supposed to say jQuery is horrible?
@Fabby lucky you !!!
@Fabby :p i envy you both somehow
@Seth :/
@Fabby we need to hook up @Videonauth
8:02 PM
@Videonauth :D :thumbsup:
but for now im in other troubles
How can I make sure the DNS servers in my settings are being used?
@BharadwajRaju Me? When getting SMSes when pinged? No way! :P
@TheBrownOne nslookup [enter]
@TheBrownOne nslookup ? dig ? whois ?
8:04 PM
maybe traceroute too?
@Seth ಠ_ಠ use vanilla js, it's objectively better.
@BharadwajRaju Yup...
@TheBrownOne nslookup - will tell you the DNS servers it will use
and unless anything is relying on its own implementation of a DNS query which would then use a specified server in a hard-coded way, it should inherit from the system
@CᴏɴᴏʀO'Bʀɪᴇɴ I agree, VanillaJS is a very lightweight library
the other way to do it is firewall any other DNS lookups
8:06 PM
tcpdump too ?
Eh, I found a better way. Just go to a website that should be blocked and see :P
. . . ..
My work blocks unwanted traffic through a DNS service
what if your DNS also blocks that site ?
I set my DNS servers to Google, and now nothing is blocked :D
8:06 PM
I don't even need to SSH tunnel now.
@BharadwajRaju @AbhishekBhatia This should work:
Sorry, too long to paste as message.
@Serg brb, calling my goat herd to trample you :P
8:07 PM
gone with the wind
I'm off: Conference call in 20 minutes...
nice seeing you again Fabby !
@CᴏɴᴏʀO'Bʀɪᴇɴ It tastes crunchy.
pastebin.com/EakwL0UQ @AbhishekBhatia @BharadwajRaju I hope I did not forget to remove anything...
8:09 PM
My work is really bad at blocking things :P
@ByteCommander thanks why did you add Remove there?
@Fabby We'll talk friday i hope :)
Good question.
Blindly trusting imperfect regexes.
Q: Install specific version of packages during patching

CppLearnerLet say right now I am comfortable doing a monthly patch process. I would patch systems in development in week 1, and perhaps week 3 I am patching production servers. I want to install versions which have been tested in development. Can I do that with unattended/upgrade command?

8:14 PM
@Fabby You have a girlyfriend?
Meanwhile <--- this guy finally learned how to use the damn js script for tabulating the results
Thanks guys
it worked
moving up, mr. W.
8:16 PM
@Upgoat jQuery
@Serg Yeah lucky for me is, that all above 200 votes will get distqualified because they made me cry ;)
@ByteCommander thanks but doesn't work. It shows E: unable to locate package 0-plugins-bad ...
@Serg Were you gonna play with me?
@Videonauth O_o i amm above 204, noooooooooo
@TheBrownOne I was , but then i took the arrow to the knee
@AbhishekBhatia pastebin.com/EWfFRgpm Revised version.
8:17 PM
im just kidding
@Zacharee1 I'd call my goat herd to trample you but they haven't arrived back yet, just wait a minute :P
Seriously though, i will probably play next time @TheBrownOne PM me the address of your server via hangouts mkay ?
@ByteCommander in exact 5 days I'll have my steward badge on the LQ queue
@Serg Can do
8:19 PM
223 upgoats and -19 downgoats . . . All I want to ask those 19 people is . . . .why,just why . . . .
( probably because yolo that's why )
@Serg I also have -19 downgoats, but only 188 upgoats.
Life is unfair.
@ByteCommander i think we pissed off the same ppl lol
Maybe when the elections are over, I'm going to post a meta question, asking for constructive critic and what people think I could do better in the next election i.e. why they voted for someone else...
I really wonder why im not already out of the race
Might be interesting to learn.
8:25 PM
+1 , wanna do the same
tats a great idea
Not sure if 3 separate but same posts are that good. Maybe we should write one together?
But that would make answering harder....
No, forget what I just said.
the lag of my laptop is real again
@AbhishekBhatia Did the second revision of that huge apt-get command work btw?
and for no reason at all youtube started looping
8:29 PM
lagging loops or looping lags?
and it all seems to be due to my input method
or looping laags laags looüüs looüing lags ?
Poor Sergiy...
fcitx seems to be working fine for some time, then it just starts eating up my CPU
I don't know if that's some form of bug or whatever
@ByteCommander @Serg @BharadwajRaju Thanks so much!!!! It works now. Is there anything else I do should apart from the installing the removed packages(bpaste.net/show/ab679eb59a31)? One thing I didn't get, why did remove install packages?
@ByteCommander Yes!!
8:33 PM
@AbhishekBhatia apt-get remove cowsay+ will install cowsay while apt-get install cowsay- will remove it.
@AbhishekBhatia probably because removing packages makes Ubuntu switch default of some sort to next available package , but that package requires some dependeencises. Just a guess
Using + and - suffixes in apt-get install and apt-get remove commands, you can change the action for a single package.
@Serg Don't think so.
Nautilus added a feature ??? gasp !!!
They finally made a move
8:37 PM
@serg is there an import os; os.sed.... ? if yes how to use it
os.sed ? No , there's nothing like that
@Videonauth you're trying to call sed from python ?
yeah kinda
You can use import subprocess, subprocess.Popen( . . .) . . . can't say full command off the top of my head
it's complex
let's see . . . pydoc subprocess
@ByteCommander Oh thanks! And the other packages it removed that didn't have pulse in their name are dependencies?
We can do something like subprocess.call( [ "sed" , "-n" , "3p" , "/etc/passwd"
] )
8:42 PM
mhmmm at least no need to reinvent the wheel every time i want to do something what can be doe through bash
Or you try this twistedmatrix.com/documents/13.2.0/core/howto/process.html. Gives you more control over the called process.
@TheBrownOne whatsmydns.net
@Videonauth thing is , calling external program from python is a bit fuzzy . Usually the smart way is to have a function to which you pass a string (command) and it will do it for you
I have draft for that in my other disk, but not on this one
>>> subprocess.call([ "sed","-n","3p","/etc/passwd" ])
This is the easiest
yeah doesn#t run away if you find it just sent me a pink from my help box and paste it in there
The twisted approach is better, you can handle errors etc.
8:45 PM
Maybe I should do it as a blog : "Adventures of a python n00b ; practical ways to mess up your scripting "
im happily contribute lol
Holy crap, actual useful feedback, what? I'll do that, when I next have time. I'll survive. Without content, this site won't. — Jacob Gadikian 17 mins ago
O.o What the actual frack
lol and i thought i have two sleeping pills taken and writing BS but this tops it still

« first day (2086 days earlier)      last day (2960 days later) »