« first day (2086 days earlier)      last day (2929 days later) » 

4:00 PM
wait
it's on my side
 
user139252
Alright
 
Use this config instead:
{
	"listen": {
		"sftp": 2422,
		"rest": 8443
	},
	"urls": {
		"download": "http://pp.x-p-w.tk/auth/remote/download",
		"install": "http://pp.x-p-w.tk/auth/remote/install-progress"
	},
	"ssl": {
		"key": "https.key",
		"cert": "https.pem"
	},
	"basepath": "/home",
	"keys": [
		"8fbd5b4c-2419-4032-8dce-ded4a7a31be3"
	],
	"upload_maxfilesize": 100000000,
	"docker":  false
}
 
user139252
4:12 PM
Alright, we won't be bugging you guys in here with this bologna anymore.
 
Thanks
 
user139252
@jokerdino @mateo @zacharee1 up for C.A.H.?
 
distracted with JS rn
 
user139252
We're literally doing nothing at work today.
 
after dinner, sure.
~20-25min
 
user139252
4:15 PM
Sounds good.
 
2
A: ps aux | grep with a dot

Florian DieschI guess you have a file named selenium.jar but no file called selenium in your current folder. If you run ps aux | grep [s]elenium.jar the shell will try to replace [s]elenium.jar with matching files names from the current folder. If there is a file called selenium.jar that will match and ...

Correct me if i am wrong, but that seems not right.
Grep is supposed to filter stdin not files when input is a pipe
 
@AbhishekBhatia Hi ! :) Do you have another application running which is using the microphone or the speakers ?
Hi @Serg my friend ! :) How are you doing today ?
 
@Serg It's not grep that does that, it's the shell. If you have a file called selenium.jar in the current directory, [s]elenium.jar will be expanded to selenium.jar by the shell before it is passed to grep.
 
@cl-netbox yes kwave works for the mic. (OS-Kubuntu 16.04, kde 5.6.4)
 
Which is precisely what pgrep is for. Why people insist on parsing ps is beyond me.
 
4:32 PM
@AbhishekBhatia disconnect every app from the sound devices quit skype and open it again ... does it work now ?
 
@cl-netbox thanks for the reply, how can I ensure I have disconnected every app?
 
@cl-netbox @Serg see elections chat
 
@Serg @cl-netbox let's take that to the election room
 
@AbhishekBhatia quit everything else completely (closing is not enough) to test whether it works ... :)
 
@terdon ohai :)
 
4:36 PM
Yo!
 
Hi terdon ! :) good afternoon :)
 
Hi @ThomasW. ! :)
@terdon checking ... never been in this room :)
 
@cl-netbox hello!
 
@cl-netbox yes, but how can I know what is linked to sound/audio. Anything in the background running. ps -aux| grep audio ?
 
4:39 PM
@terdon I keep forgetting you have diamondmod so you get to move things around chat between rooms
heh
 
>:)
 
@AbhishekBhatia the thing is that skype linux version is very old and sometimes doesn't want to recognize the sound hardware ... unfortunately ...
 
@cl-netbox oh, it is 4.3. Any workaround if possible. :)
 
@AbhishekBhatia no idea ... sorry ... many users are having this problem - which webcam do you use ?
 
@cl-netbox the inbuilt on my HP laptop. Skype mentions it as HP Truevision HD.
 
4:47 PM
@terdon
can you please explain this ? paste.ubuntu.com/17369342Serg 9 secs ago
 
threads?
 
@Serg What am I looking at? The fact that there are multiple chromium instances?
That's one per tab.
 
@AbhishekBhatia aha this can be the root cause ... purge skype completely ... maybe a reinstall will help ... make sure that you also purge all dependencies (including x86) that were installed alongside ... there are a lot ! Maybe this solves the problem ... hopefully ! :)
 
@terdon Plus any corresponding threads
 
Aye
 
4:49 PM
i've noticed that 'top' likes to mix them in there
compared to htop
:P
 
@terdon no, you're looking at exactly the same thing OP of that question was doing , searching for process line with some string .
 
@cl-netbox sudo apt-get purge *skype*?
 
htop does but colors em ;)
 
I just replaced [s]elenium with [c]hromium
 
@Serg Yes, and getting results. I don't see what the problem is.
What were you expecting?
 
4:50 PM
@terdon in OP's question it returns nothing, why then do I get results ?
 
what does [] do? don't you specify a range with it? what is it's point here?
 
@AbhishekBhatia yes and check in /var/log/apt/history.log for all the dependencies ... it is a bunch of them ... purge them too ! :)
 
In regex it's supposed to be letter s (or letter class) followed by elenium
 
14
A: grep - why do brackets in grep pattern remove the grep process from ps results?

StefanWhen you run ps -ef | grep string, grep is displayed in the output because string matches [...] grep string. But, when you run ps -ef | grep [s]tring the line isn't displayed, because grep translates [s]tring to string, while ps outputs [...] grep [s]tring, and that doesn't match string

 
user136984
The review queue has gone down by a huge amount recently...
 
4:53 PM
@ParanoidPanda cough mod elections cough
 
@terdon thanks
 
user136984
Last week it was at something like 1000 and now it's at 200...
 
user136984
:D
 
@ParanoidPanda look up
 
@terdon that also seems to contradict Florian's answer and doesn't mention no filenames and expansion by shell
 
user136984
4:54 PM
Up? How far up? :D
 
Hello @ParanoidPanda - good evening ! :)
 
Yay, 200 points today!
\o/
 
oO
 
@Serg Ah, right. Dunno, simplest guess is that the OP doesn't actually have a running instance of selenium.
 
@cl-netbox sudo cat /var/log/apt/history.log | grep skype gives nothing. I had installed from .deb
 
4:56 PM
boo
 
@ByteCommander Congrats ! :) zero here ! :)
 
if you didn't use apt it might not show up there
 
He @Rinzwind
 
Heya
 
@cl-netbox Given the recent events, I have to suppress my compassion for you...
 
4:58 PM
@terdon I'll dig around , because that answer doesn't seem right to me. I do like yours however
 
looks over to his industrial-sized box of chocolate covered coffee beans, and starts thinking he needs more caffeine
 
@Serg Well, he's quite right in that if there is a matching file, then it's the file name and not [s]elenium that will be passed to grep.
 
@AbhishekBhatia you shouldn't do this ... you should have installed it from the repositories ... it is in canonical partners ... so no chance to find them :(
 
define "industrial-sized" o.O
 
@cl-netbox If skype is purged, autoremove will still reflect the deps being not needed
case in point:
 
4:59 PM
@AbhishekBhatia : You can find the most of them with dpkg --get-selections | grep i386
 
I have a debian file, foobar-daemon.deb. It depends on about 50 perl libraries.
 
@Serg your thing about chromium is completely different. Florian (and myself) both ignored that the OP claims to get no output, so he won't understand what you're asking him to explain. Also, since the OP accepted it, he probably does get output.
 
dpkg -i foobar-daemon.deb
Errors: dependencies missing
apt-get -f install
... [deps install, `foobar-daemon` package installs configures] ...
later...
apt-get purge '*foobar-daemon*'
apt-get autoremove
[removes now-not-needed deps]
quite used to this in my tesitng VMs too :)
 
I've created a file in my dir [c]hromium
still get the same result
 
That won't make a difference.
 
5:01 PM
@ByteCommander Thank you so much !!!
 
The point is that the [c] will protect you from seeing grep chromium in the output.
 
Then what's Florian talking about ? Isn't his whole point is that if there is file in your cwd with the same name , it will be passed to grep ?
 
@Serg He's talking about this:
$ ls *
ls: cannot access '*': No such file or directory
$ ps aux | grep [t]elegram
terdon  6236  0.0  1.4 1720864 243956 tty2   Sl+  May26   8:47 /usr/bin/telegram-desktop --
$ touch telegram
$ ps aux | grep [t]elegram
terdon  6236  0.0  1.4 1720864 243956 tty2   Sl+  May26   8:47 /usr/bin/telegram-desktop --
terdon 19372  0.0  0.0  10776  2216 pts/10   S+   20:04   0:00 grep --color telegram
So, in an empty directory, grep [t]elegram only returns the actual program. As soon as I create a file called telegram, grep is no longer seraching for [t]elegram but for telegram so grep itself also appears in the output.
 
Is there anyone here who knows JS? @Rinzwind are you still here?
 
Ah , so shell replaces the regex with actual filename ?
 
5:08 PM
@cl-netbox bpaste.net/show/3481a3063c18 how can I check what to remove?
 
@Serg Yes. But it's a glob, not a regex. the shell expands the glob before passing it to grep which, had the shell not already expanded it, would have treated it as a regex. Just to simplify a little :P
Here, set -x should help:
 
@terdon am I right that ZSH will error with [f]oo ?
 
@ThomasW. Dunno. Hang on, let me check
 
because i'm testing, and I use ZShell ;)
and it fails
 
Works here.
 
5:09 PM
That makes sense now , with touch chromium it gives the same result as in your example
 
[overlord /home/teward/tmp/tmp]% ls *
zsh: no matches found: *
[overlord /home/teward/tmp/tmp]% ps aux | grep [f]oo
zsh: no matches found: [f]oo
shrugs
TBH if i'm going to do globby search patterns I put em in single quotes, anyways, but meh
 
Comment removed, Florian's answer upgoated . . .
 
Ah, OK. It worked here because I had a matching file. OK, that means that zsh complains when a glob doesn't match anything. It should work if you quote the regex so it's passed directly to grep.
 
@ThomasW. Your username is "overlord"? o.O
 
@ByteCommander no that's the hostname
 
5:11 PM
@ByteCommander Well, someone is expecting to win the election! :P
 
lol
 
Not much of a difference...
 
@ByteCommander my laptop has been called 'overlord' since it became the central management hub for my network at my apartment
literally has access to everything on the 'net
so... 'Overlord'
:)
username's still teward
at least it's a better name than the computer that I leave vulnerable to attack via a tarpit
can't say that name here though :P
 
I used to use bird names for my hostnames
eagle, hawk, etc
 
5:13 PM
One of mine is called wolf-pack, the other AlkaliMetal.
 
@Serg I have several domains on there so heh
different name patterns, different domain sections
 
I planned to install Kali on the second one, obviously...
 
there's a section of my network for internal.hellnet.io
 
@ByteCommander Kalifornia would be much more fun
 
different types of hell creatures from DOOM 3 are the naming pattern there :)
 
5:14 PM
Welcome to the hotel "Kalifornia" . . .
 
I've used so many things. The Catalan word for night, the names of two spices, the greek word for box (the machine I'm writing this on is a box*), a fictional strip club from The Sopranos. You name it...
 
@ThomasW. That's where you punish hackers that dare to try to sneak in?
 
@terdon only two constants on all my equipment:
 
@AbhishekBhatia this is what I meant ... a bunch ... do you have any other 32-bit application installed ?
 
overlord is my personal laptop with access to all
archangel is my Kali box that overwatches everything via nessus
 
5:15 PM
lol
 
I could name one weeping-angel (Doctor Who)...
 
and '[censored string of expletives]' is the name for my 'vulnerable' tarpit trap box
 
lol
 
Seems like I'm mainly missing additional hardware before I should think of additional creative names...
 
and the domain it's 'under' isn't much nicer ;)
@ByteCommander hypervisors are fun.
name the VMs everything from A to Z
 
5:17 PM
I'm also currently only having 2 VMs on my notebook.
One of them is an Android-x86 system which refused to boot right from the installation.
 
i have two 'server' boxes on my home net (and 17 VPSes offsite)
those two server boxes are hypervisors
all the machines I used to run are now virtualized
I think around 28 virtual machines now is where I'm at across both hypervisors
 
Sounds reasonable to virtualize them
 
@terdon how's this idea : OP runs process as java -jar selenium.jar , right ? So why not use ps -C "java" -o args | grep selenium ?
We're gonna limit output of ps only to the java processes
so no grep will show up
 
@AbhishekBhatia you know most of the packages came with skype ... but I also see adobeair ... to be on the safe side purge skype only and check whether a reinstallation of the base product helps ... but I assume it won't
 
@Serg Yes, probably. Or you could spare yourself the trouble and use pgrep -f selenium
 
5:22 PM
@cl-netbox Skype, the never dying evil... :P
 
@terdon well that's my specialty - skinning cats in multiple ways
 
:)
 
Poor cats.
This makes me want to play CaH again though.
 
adminx@L455D:~$ skin.sh | cat -A
Anybody would be willing to play cards against hoomanity ?
 
(@Zacharee1 @TheBrownOne CaH ^?)
 
5:25 PM
bye
 
no @ByteCommander :(
 
See ya netbox !
 
@cl-netbox Seeya
Well, if nobody wants to play, I'll have to go on bashing the LQ queue...
 
And if no-one is going to volunteer to be our third player, I'll probably go read the prep book Comptia Linux+ . . . and my gf's texts for her English exam . . .
 
@Serg good luck on Linux+ :P
 
user139252
5:29 PM
@ByteCommander Yeah, I've got a game open and ready for people
 
user139252
One minute
 
@ThomasW. Thanks ! I would be even luckier if I had your brains , but unfortunately the science is not advanced enough where we can download knowledge form one head to the other
 
lol
the data in my head is encrypted in a way that wouldn't be able to be processed anyways
 
@ByteCommander Welp , looks like we got our third player after-all (? )
 
@Serg one day it might happen
 
5:30 PM
Wooohoooo!
 
@jokerdino that's be so cool ! I'd instantly download tesla's brain . . . .and maybe Linuses . . .
 
most probably Trump's.
 
oh hellnaw !!!
 
@jokerdino I don't think we'd download his.
 
5:31 PM
Trumps brain should be locked away and never shown to the public
 
probably take /dev/zero and dump it to his if brain-copy tech existed
 
@ThomasW. it would be bundled along with Java update.
 
@ThomasW. I like that idea
if [ "$CANDIDATE" = "Trump"  ];then
   sudo shred /home/admin/voting-ballot.txt
fi
 
user139252
@ByteCommander @Serg @jokerdino @Zacharee1 @terdon pyx-1.pretendyoure.xyz/zy/game.jsp#game=3
 
user139252
Password is: TheBatman
 
5:34 PM
Terdon and Jokerdino are joining as well?
 
user139252
I dunno, figured I'd ping him and see :P
 
terdon is probably at work, i doubt he is joining
Well, imma go smoke real quick, ping me when everyone is freddy ready
 
Actually, say what you want but you can't be an absolute idiot and still be as rich as Trump.
 
Are you really sure about that?
 
@jokerdino define idiot
 
@JacobVlijm Trump
4
 
user136984
@jokerdino: Just because he knows how to get money and is good in that one area, that doesn't mean he's actually good at anything else... He wants to nuke Europe for god sake...
 
@jokerdino inheriting an empire build by smart parents
that's how you can
 
@Serg and somehow none of those genes will be passed down?
He knows what he is doing and that is to play people's insecurities and fears.
 
5:39 PM
@jokerdino maybe he doesn't notice his genes, or ignoring :)
 
user139252
@Serg I think we're all ready.
 
@jokerdino I'm not a biomedical major , so i wouldn't know. But that's a frequent example in our very imperfect world
@TheBrownOne 3 minutes plz
 
user139252
You won't be skipped if you're late.
 
user139252
You're the czar, anyway :P
 
Oo
 
5:43 PM
Just wait until he becomes Mr President and we will know of his mysterious ways.
 
@terdon what do you know of rsync/scp and extreme CPU usage
 
@ThomasW. Not much. I've used both, of course, but have never had CPU issues with them. Compression?
 
@terdon on the target machine eating up 400% CPU and hanging the VM it's copying to when prior rsyncing never had the issue?
 
@TheBrownOne Looks like fun but I can't play now. I'll join you next time.
 
i ruled out compression 'cause I didn't turn it on
 
user139252
5:45 PM
Sounds good.
 
I did `sudo apt-get purge *pulse* ; sudo apt-get purge skype; dpkg -r skype;`
Now I can't login into kde. It doesn't show the kde bootscreen. Any ideas? I can still use CLI with Ctrl+Alt+F7.
@cl-netbox okay something weird happened. ^
 
@AbhishekBhatia *pulse* is going to be extremely broad
like insanely though, and can torch things
so you may have damaged your system with that step
 
any fixes? I have CLI, I can reinstall stuff
 
o/ @mateo
 
user139252
Mateo!
 
5:57 PM
Is there anyway I can know exactly what I uniinstalled?
I can access the shell from Ctrl+Alt+F7
@ThomasW. True, should have thought of that!
 
@AbhishekBhatia Try apt-cache show *pulse*
 
@terdon So, then install everything with pulse?
 
@Zacharee1 nope dinner :=)
 
tsk ;p
 
@AbhishekBhatia Depends on what you want and what you removed. Yes, running sudo apt-get install '*pulse*' should bring back everything you removed but it will probably also install all sorts of crap you don't want. Just check the output of the apt-cache command and try and figure out which packages you need, if possible.
This, however, is probably a good time to be posting a question on the site.
 
user136984
6:10 PM
By the way, anyone know where I am in terms of the primaries?
 
user139252
Last place.
 
user136984
Thanks. :D
 
10th
 
user136984
Oh, well that's nice that it's still there.
 
user136984
I don't think that it looks like there are many below me who are going to go above me so hopefully it will be fine...
 
user136984
6:14 PM
Well, I will stay in at least 10th hopefully. :D
 
user136984
It would be sad if I didn't even make it into the actual elections even though my chances of winning look slim from what I can see here...
 
18 ahead of 9th so
 
@terdon Still doesn't work
@terdon I posted a question with all details, please check if possible. :)
 
@AbhishekBhatia links are nice :)
 
0
Q: Recovering uninstalled packages

Abhishek BhatiaI did sudo apt-get purge *pulse* ; sudo apt-get purge skype; dpkg -r skype; Issue: Now I can't login into kde. It doesn't show the kde bootscreen. Any ideas? I can still use CLI with Ctrl+Alt+F7.Is there anyway I can know exactly what I uniinstalled? What I have tried: sudo apt-get instal...

 
6:59 PM
@ThomasW. do you know PHP?
 

« first day (2086 days earlier)      last day (2929 days later) »