« first day (1965 days earlier)      last day (2860 days later) » 

4:01 PM
That would net you somewhere between 1-3k I think
My new language is coming along nicely! I'm able to start implementing it in itself.
@bkul Link?
@Fatalize Sure, one moment.
4:17 PM
@bkul zzzZZZ
sorry sorry
There's no documentation at the moment.
4:39 PM
My blog has one article, but 500 readers per month o.O
What is it about?
The article is about WSL
Has about ~45 readers per day since one day after publishing.
wait it's "oo-bun-too" not "you-bun-to"?
and did you make this graphic in powerpoint? o_o
or was that microsoft
ಠ_ಠ they still have the spell checker red underline
4:45 PM
Yeah, that amused me, too.
@Quill Yeah, I'll take a look at your unit testing because I have no idea on how to chai :|
@Quill yeah
> More posts on WSL will come.
Didn't say when :P
"This seems good, but it will be bad. Eventually."
Actually Docker is now natively supported in Windows Hyper-V containers. So that's probably next.
4:51 PM
What is Docker?
@LeakyNun Not even that, just shifting each symbol one step to the left. Like abaabab... -> baabab...
@Quill ಠ_ಠ you forgot this
@Quill and this one which is just good in general
@CᴏɴᴏʀO'Bʀɪᴇɴ You really don't now?
@mınxomaτ No, I don't.
4:54 PM
I did not know about Docker either until just now.
what should be the syntax for constructing a class?
I don't like new foo() because that seems hard to parse
@Upgoat Do you mean defining a class, or constructing an instance of the class?
I don't see what would be simpler
4:57 PM
@Zgarb constructing an instance of a class
Just drop the new?
@TimmyD Cool. I didn't know how useful it would be, I just thought it was neat.
@Zgarb but then that would be function syntax
@Upgoat Constructors are function
that's true :/ but I don't like that syntax.
idk, I'll think of something
5:04 PM
@Upgoat variable <- Foo()
If you want to distinguish between functions and constructors, require one to start with an uppercase char and the other with lowercase.
no, that's too cheesy
@Upgoat Foo(params) foo;
same as declaring a variable but with params after the class name
(or no params just the parenthesis if there are none)
no parentheses => just a declaration
llooks too much like C
5:07 PM
@Upgoat foo((params)) :P
@Zgarb but (params) is a valid expression unfortunetly
C doesn't even have classes
yeah, but you see this pretty often in C where the var is at the end: typedef struct {} goat;
@Upgoat Oh right, and it probably can be semantically different from params
Foo foo = Foo{...}
5:09 PM
How about foo:(params) or :foo(params) or foo'(params)
Foo foo = ~Foo()
like C++ destructors, assuming you can't call destructors
@Zgarb Yeah, I was considering those but : is range operator
btw, for the switch thing, a possible snag would be 1, 2:3 : 4
I think I might just do new and have it do a check if it's a class and all
Well, use some other non-alphanum char that doesn't have another meaning yet. Assuming you have one, of course.
5:12 PM
@CᴏɴᴏʀO'Bʀɪᴇɴ oh shit :| this : operator is causing lots of problems
@Zgarb maybe unary *
@Upgoat just re-assign it to something else :P
@CᴏɴᴏʀO'Bʀɪᴇɴ to what though? ._.
use @ or _, it's useless
@Fatalize _ is for properties
@Fatalize Probably gonna use @ for some special literals
maybe x $ y could be range
5:14 PM
ew no :P
%? #? ~?
idk, it's just really odd. Like I've never seen it before
@Upgoat Do classes always have exactly one constructor?
I could try .../.. but that would require spaces around the numbers, so 1 .. 5 which some people may not like
@Zgarb yeah
at least they're resolved to one
5:15 PM
The poll has ended a few hours ago!
No result.
;_; cheddar without semicolons doesn't work
As such, I have to ask @Upgoat in the zyabinVI beta room for help on creating a new project.
(Upgoat, you will come there, won't you?)
project idea: finish Cheddar
@Fatalize This is not a zyabinVI project idea.
@zʏᴀʙiɴ101 I have to do some work finishing cheddar
5:17 PM
@Upgoat Okay, so I should expect you in the room in a few days, okay?
I'll try :)
CheddarPropertyToken {
  Code: 'foo::bar',
  Index: 3,
   [ CheddarVariableToken { Code: 'foo::bar', Index: 3, _Tokens: [Object] },
     '-1': 'undefined::' ],
  Type: Symbol(Property) }
I borked something bad :|
I get you. Parsing isn't fun
:: ????
and then you complain about my thing looking like C
that's casting operator
String::123 -> "123"
5:19 PM
@Fatalize s/C/C++/
@CᴏɴᴏʀO'Bʀɪᴇɴ Unless you use parsec!
@Fatalize ._. type::variable
@Upgoat I know it's C++, but you complain about my thing looking like C
@Upgoat here's a report on the Cheddar REPL:
`print` is transparent: prints *and* returns the string.

Comments return `Symbol(KEY_NOT_FOUND)`.

String formatting does not work.

`1__2345` crashes the interpreter.

            throw err;

TypeError: Cannot read property 'length' of undefined
    at CheddarExec.exec (/home/ubuntu/workspace/cheddar/dist/interpreter/exec.js:53:29)
    at Interface.<anonymous> (/home/ubuntu/workspace/cheddar/dist/cli/repl.js:60:24)
    at emitOne (events.js:77:13)
    at Interface.emit (events.js:169:7)
@Upgoat yeah I got it, but it looks... dubious
5:20 PM
@zʏᴀʙiɴ101 oh god
`[1, 2, 3, 4]` prints these tokens:

[ CheddarExpressionToken { Code: '[1, 2, 3, 4]', Index: 2, _Tokens: [ [Object] ] },
  CheddarExpressionToken { Code: '[1, 2, 3, 4]', Index: 5, _Tokens: [ [Object] ] },
  CheddarExpressionToken { Code: '[1, 2, 3, 4]', Index: 8, _Tokens: [ [Object] ] },
  CheddarExpressionToken { Code: '[1, 2, 3, 4]', Index: 11, _Tokens: [ [Object] ] } ]
@Zgarb I don't even know what I just read ... o_o
i dunno what's wrong here, @zʏᴀʙiɴ101 post these on GH so I can plan on fixing them :3?
keep the code to the github issues page and link us
Here's the public C9 workspace where I test Cheddar: ide.c9.io/schas002/cheddar
"public" "Please sign in"
5:23 PM
as opposed to private, where you can't access it.
@Upgoat you deleted your blog??
@CᴏɴᴏʀO'Bʀɪᴇɴ no I moved it to blog.vihan.org
Question: Why does 10^(log(2)*n)=2^n?
It looks like it should be 2*10^n
(log is base 10 in this instance)
x^(y*z) != x^y * x^z
Because it's the same as (10^log(2))^n, and 10^log(a) == a when the logarithm is in base 10.
5:33 PM
Oh, facepalm
Question 2: log(10^a+10^b) is effectively max(a,b), right?
if it is, then I'm happy
I mean, the 10^max should dominate
If a == b, you get log(2)*a
I know that
But say when a != b
@LegionMammal978 Roughly, yes
(I use natural log, base there)
5:39 PM
(is there a closed form expression for the exact value which doesn't calculate the exponents themselves? a and b are large in my scenario)
the exact value of max?
The exact value of log(10^a+10^b)
Why are you doing this instead of just using max? It won't be faster I don't think
I mean it's just one branch
For extra accuracy, not writing a program here ;) (although it probably doesn't matter)
5:49 PM
@LegionMammal978 a + log(1 + 10^(b-a)) has a smaller exponent, if a and b are close.
Oh well
(For the record, the final result was ~10^10^10^3.29)
That is not a small number.
That is a big number.
@Upgoat You now have one more bug to fix! :D
why :D ???
@LegionMammal978 0.5*a*sgn(a-b)+0.5*b*sgn(b-a)+a/2+b/2
5:54 PM
Hello @HelkaHomba!
cheddar> foo::bar
CheddarPropertyToken {
  Code: 'foo::bar',
  Index: 9,
   [ '::',
     CheddarVariableToken { Code: 'foo::bar', Index: 3, _Tokens: [ 'foo' ] },
     CheddarVariableToken { Code: 'foo::bar', Index: 9, _Tokens: [ 'bar' ] } ],
\o/ casting parsng worked fisrt try
@LegionMammal978 or 0.5*(a+b+sqrt(a^2+b^2))
Can someone confirm that 1080p60 and 720p60 are the only quality settings available for youtu.be/KyBJhwJG1jQ
confirmed it's probably still processing the other qualities
that and auto
also holy shit your computer is good enough to record in 1080p 60 fps
5:56 PM
@HelkaHomba yes
please give me your computer
@HelkaHomba does minecraft have goats yet
@HelkaHomba I confirm.
@quartata I guess but it's been 8+ hours :s
but thanks guys
@Upgoat No. But maybe I'll name a sheep Vihan and pretend
:D good enough 10/10
you can flip stuff upsidedown right?
5:58 PM
Pretty sure Project Zulu and Mo Creatures both have goats
@Upgoat yes with a name tag named Dinnerbone
name this sheep Downgoat :D
We'll see :P
Can't, has to be named Dinnerbone to be rendered upside down
oh yeah
@HelkaHomba That's why I didn't watch it more than a minute and a half earlier - was too slow to load. That does seem odd to me, so I expect it should be resolved sooner or later.
5:59 PM
@quartata -1 0/10 writing angry letter to mineecarft ;-;
I mean, I could write a plugin to make it work for the name Downgoat if you really wanted
But since it's not a goat anyways why settle for less
@El'endiaStarman Sorry :/ I did upload in 4k (upsampled for reason in description) but I would have thought the lower res ones would be there by now.
@quartata you can use texture pack though, right to make it goat?
@Upgoat Sure but they'll still drop mutton and wool
6:01 PM
I suppose resource packs can rename things now
hmm lemme see
@Upgoat you should make a kanban.
Yeah, the item names are just in a regular Java resource bundle
(for Cheddar)
@zʏᴀʙiɴ101 a wat
@zʏᴀʙiɴ101 what is it with you and exotic project management anyways :P
I don't think Downgoat has to worry about his little Cheddar factory workers not knowing what to do
6:03 PM
my factory workers are goats so it's hard enough as-is
@Upgoat a kan-ban.
Kanban is a method for managing knowledge work with an emphasis on just-in-time delivery while not overloading the team members. This approach presents all participants with a full view of the process from task definition to delivery to a customer. Team members pull work from a queue. Kanban in the context of software development can mean a visual process-management system that tells what to produce, when to produce it, and how much to produce - inspired by the Toyota Production System and by Lean manufacturing. == Overview == David Anderson was among the first to formulate the Kanban Method for...
how does this apply to programming
> Kanban in the context of software development can mean a visual process-management system that tells what to produce, when to produce it, and how much to produce - inspired by the Toyota Production System and by Lean manufacturing.
That's for when you have thousands of people you know
I'm ok with download script
cheese takes time to age so its not really possible
6:05 PM
@LeakyNun Well congrats, I don't think I can match (let alone beat) that.
But a kanban board may be as easy as To Do | Doing | Done.
schas002:~/workspace $ time cheddar <<< "print 1+2+3+4+5+6+7+8+9+0"

real    0m0.369s
user    0m0.280s
sys     0m0.060s
O_o cheddar is slow
then again about speed:
3 mins ago, by Upgoat
cheese takes time to age so its not really possible
$ time perl <<< "print 1+2+3+4+5+6+7+8+9+0"
real	0m0.094s
user	0m0.001s
sys	0m0.006s
Alright, now do time python <<< "print 1+2+3+4+5+6+7+8+9+0".
$ time python -c "print 1+2+3+4+5+6+7+8+9+0"

real	0m0.008s
user	0m0.008s
sys	0m0.000s
6:10 PM
schas002:~/workspace $ time python <<< "print 1+2+3+4+5+6+7+8+9+0"

real    0m0.189s
user    0m0.012s
sys     0m0.020s
@quartata oh shit damn
looks like part of the problem is the workspace is slow as shit
llama@llama:~$ cat > kajigger.c
#include <stdio.h>
int main() {
    printf("%d\n", 1+2+3+4+5+6+7+8+9+0);
llama@llama:~$ gcc kajigger.c
llama@llama:~$ time ./a.out
./a.out  0.00s user 0.00s system 0% cpu 0.001 total
PS C:\Tools\Scripts> measure-command{1+2+3+4+5+6+7+8+9+0}

Days              : 0
Hours             : 0
Minutes           : 0
Seconds           : 0
Milliseconds      : 8
Ticks             : 88491
TotalDays         : 1.02420138888889E-07
TotalHours        : 2.45808333333333E-06
TotalMinutes      : 0.000147485
TotalSeconds      : 0.0088491
TotalMilliseconds : 8.8491
Logical, as the workspace has only 512 MB and no way to change that.
@quartata maybe you should install cheddar so this stuff can be accurately compared ;)
6:11 PM
It needs Node, right?
if you have linux it'll doesn't if you have windows yeah
$ time python3 pytek_main.py -c "\print(1+2+3+4+5+6+7+8+9+0)"
enter  - <pRoot>
enter  - <pFunction print>
enter  - <pOperator +>
finish - <pInteger 1>
next   - <pOperator +>
enter  - <pOperator +>
finish - <pInteger 2>
next   - <pOperator +>
enter  - <pOperator +>
finish - <pInteger 3>
next   - <pOperator +>
enter  - <pOperator +>
finish - <pInteger 4>
next   - <pOperator +>
enter  - <pOperator +>
finish - <pInteger 5>
next   - <pOperator +>
enter  - <pOperator +>
finish - <pInteger 6>
next   - <pOperator +>
ha ha
@Upgoat Accurate comparisons? Pshaw. :p
@quartata And that's with all the printing.
@El'endiaStarman hehe
@TimmyD I would have tried Cheddar but:
/dev/fd/63: line 1: syntax error near unexpected token `newline'
/dev/fd/63: line 1: `<!DOCTYPE html>'
@Upgoat I think you're doing it wrong
6:17 PM
um wat
I suspect it's sending me a 404
what command are you doing to install
The one on the Github
make sure you're doing: sh <(curl -fsSL cheddar.vihan.org/i/nix/cheddar)
(that's the one on the website)
you should update the readme
6:18 PM
yeah, I'll do that in the next merge
oh god your website is way too web 2.0
well at least I wouldn't have been able to tell this was made by a goat
./bin/install: line 14: : command not found
I don't think you're cd-ing into the install directory first
6:20 PM
Web 2.0++
no I am
cdrtmpdir="cdrtmp-`date +%s`"
sudo git clone github.com/cheddar-lang/Cheddar.git $cdrtmpdir
echo "Configuring installation..."
sudo chmod -R 777 $cdrtmpdir/
cd $cdrtmpdir   # Notice this line
>_> it just worked on ubuntu and centos @quartata what OS are you on?
I'll just install it by hand screw this
@Upgoat Oh wait, it's not that
It's the grunt
Oh, I know why.
You should really make it not require sudo; make them authenticate as root themselves
Just remove every instance of sudo
6:24 PM
nah, people then think imma hack their computer
too much inconvinence
I'm one of those people who thinks sudo is the spawn of the devil and refuses to use it
:| okay... will remove in next release
As a result I ran this as root and sudoing messes up my path meaning it can't find npm
I'm not sure you need to worry about "inconvenience" in an install for an experimental esoteric programming language.
6:25 PM
Ooh, gets better and better
Warning: Task "install" not found. Use --force to continue.
>_> wat
you know I could just run this directly
you really don't need this exotic install process, it's just a js file
Error: Cannot find module '/home/quartata/cdrtmp-1466101146/src/cli/repl.js'
it's clearly named as repl.es6
that's not..
Oh shit, you gotta Babel it first. That's why you have Grunt
imvery confused
6:27 PM
@Upgoat I just ran node cheddar.es6 directly
i dont think you can do that
you'll have to run cheddar.js in the dist/ dir
Guess I'll feed these to Babel by hand and rename the files
@quartata what OS are you on?
@Upgoat Right, but Grunt is the worst build tool I've ever seen
nvm i take this statement back
6:28 PM
@Upgoat ubuntu
wat, works fine on c9 ubuntu
maybe manually install node (LCS) & npm
Eh, forget this. Just time the thing locally and tell me the time so I can make fun of you
@Upgoat I did
I'm using my own build of node
oh okay
little out of date
Anyways the problem is most likely in Grunt
oh you're not on node LCS i think
6:30 PM
@Upgoat This isn't really a stock Ubuntu per se
if you have realpath or GNU readlink then it should work fine
what's node -v and npm -v?
6:44 PM
@Zgarb So the equilibrium is when every symbol is the same, like aaa...?
@Dennis Why you give up so fast.
How many rep do you need to protect a question? I'm too lazy right now to search for the list
@Bálint I believe it's 5k iirc
And why is it better, than leaving it like thast?
7:03 PM
Protecting questions rarely makes sense on PPCG. However, common problems on SO and SU tend to attract Thanks, your answer helped me. or I'm having the same problem. "answers", so protecting it shields it from new users.
@LeakyNun It's rather hopeless with my current approach, but I'll take a look later.
@Dennis but sometimes very popular questions get lots lf answers by new users who don't read the rules etc.
@Dennis The 34->32 golf made me feel so stupid.
Before I post to MSE about chat notifications, would anyone like to say something in this room without pinging me?
7:19 PM
Perfect. Thank you :P
@trichoplax What are you going to post?
@flawr Finer control of chat notifications. I'll link from here when I post
@LeakyNun I even put without in italics... :P
7:21 PM
@trichoplax ill bet 50 rep itll go ignored by SE
It seems like selecting "visible room" from the Sound notifications menu (speaker symbol at top right) causes notifications for all posts (pinging or not) from all rooms that are open in a tab, regardless of whether it is the active tab.
As soon as I want to monitor activity the room goes silent...
Look, I posted 3 out of the latest 4 posts...
can someone post something?
@LeakyNun Yay - posts without pings. That was just what I needed and confirms I get a noise from this room even when viewing a different room
All done now - you don't have to be silent anymore... :P
7:39 PM
@LegionMammal978 Gray for America, grey for England.
A mnemonic I learned some time ago that has been quite useful to me.
I wonder if that works for Australia
More like "grey" if you're not incorrect
HA, gottem
@trichoplax Australian English is closer to British English than American English, probably since they gained independence more recently.
What's the 256th character of the extended ASCII table (the one with the charcode of 255)?
@LegionMammal978 i did wrong answer i did grey when i write gray
7:40 PM
@Bálint fileformat.info/info/unicode/char/00ff/index.htm 'LATIN SMALL LETTER Y WITH DIAERESIS' (ÿ)
@LeakyNun Another site says it's the nbsp
@Bálint Which site?
I wonder what the S in ASCII stands for...
@Bálint It's ÿ in Unicode, NBSP in CP437
So, wich is the original?
7:43 PM
In word processing and digital typesetting, a non-breaking space (" ") (also called no-break space, non-breakable space (NBSP), hard space, or fixed space) is a space character that prevents an automatic line break at its position. In some formats, including HTML, it also prevents consecutive whitespace characters from collapsing into a single space. In HTML, the common non-breaking space, which is the same width as the ordinary space character, is encoded as &nbsp; or &#160;. In Unicode, it is encoded as U+00A0. Non-breaking space characters with other widths also exist. == Uses and variations... ==
I'm not a characterset expert
@LeakyNun One that uses CP437 (e.g., asciitable.com)
@LegionMammal978 CP437 is not unicdoe
@El'endiaStarman Pretty sure it's grey for America, gray for England.
i trust asciitable.com. that's the one i use
7:44 PM
@LeakyNun Was saying that a site stating that it is NBSP is using CP437
@Poke nobody's saying it's wrong
A new windows build is here (XX366). It takes a long time to install, so keep an eye on your active hours to prevent unexpected restarting.
@LeakyNun just adding my 2 cents.
@Bálint Well, CP437 was used by DOS...
@LegionMammal978 Alright.
7:44 PM
Q: Adjust notification settings per chat room

trichoplaxAt the top right of a chat room, just above the room title, there is a speaker icon. Clicking on this icon brings up the settings for "Sound notifications": Currently, a change to this setting affects all chat rooms. Selecting "visible room" means that an audio notification is given for any ac...

@flawr This ^
Can someone create me a RegEx, withc matches a single comma, but not multiple?
@Bálint (?<!,),(?!,)
It can't use look before
That's my problem with it
@Bálint ^,$|^,[^,]|[^,],$|[^,],[^,]
@LeakyNun Thank you
7:47 PM
@Bálint Note that it will also match the surrounding characters
That's a problem
I hate how javascript doesn't support lookbefore
@Bálint ^(,)$|^(,)[^,]|[^,](,)$|[^,](,)[^,] capture groups 1 to 4 (or 0 to 3 if you suck)
@Bálint solution: don't use regex
I need to split a string at every comma, but if you have 2 commas, it needs to match the second one
@Bálint (^|[^,]),(?!,)
7:49 PM
@trichoplax My first reflex was to close the popup in the image=)
So pretty much every comma, wich doesn't have a comma after it
Wait, that can be done with a negative lookahead
@flawr I almost did that myself, even though I posted it... Especially as the mouse pointer changes when hovering over the image
@Bálint what exactly is the task you're trying to accomplish?
7:52 PM
@Bálint Are relevant commas always followed by a space?
@Upgoat That's not that complicated
@Bálint This works with your last description but not your first
Yeah, I didn't express myself well enough
@trichoplax American Standard Code for Information Interchange
A: Convert UTF-8 string with only 8 bits per character

BálintYou can get the ASCII value of a character with .charCodeAt(position). You can split a character into multiple characters using this. First, get the char code for every character, by looping trough the string. Create a temporary empty string, and while the char code is higher than 255 of the cur...

This is why I needed it
@TimmyD I know - it was a joke because of the argument that was going on over what ASCII 255 is :)
ASCII doesn't have 255
It's 0-127
extended ASCII does, but then it's dependent upon implementation
Oh, I see you guys have already covered that.
7:59 PM
@TimmyD Yes they did specify extended, but it just amused me that it's still called "Standard"

« first day (1965 days earlier)      last day (2860 days later) »