« first day (2726 days earlier)      last day (118 days later) » 

I was wondering when I started using pfSense, because mine runs from the flash drive and there's no permanent logs.
Then I remembered Root Access is my brain log.
May 7 '17 at 14:30, by That Russian Guy
Like, I went to sleep yesterday at 5 am because I WAS BUILDING PFSENSE WITH 2 ROUTERS AND 1 MINI ITX PC BECAUSE I THOUGHT IT WAS FUN
There, I'm using it since may '17.
I just have to check my power bills from before and after.
 
@JourneymanGeek Next time use a Cat IV Meter :) - Category IV: used on locations where fault current levels can be very high, such as supply service entrances, main panels, supply meters, and primary over-voltage protection equipment
 
@DavidPostill I use it for small, 12v or less electronics.
for high voltage, at worst, I use a test pen
 
Bob
@DavidPostill CAT IV is way, waaaaaaaaaaaaaaaaaaaaay overkill
 
@Bob I was joking ;)
 
Bob
12:05 AM
the correct answer is usually CAT III 300V
possibly CAT II 300V depending on what you're testing
@ThatBrazilianGuy your current CPU has a TDP of 17W
assuming full load (and an SSD), you'd probably only draw ~25W-30W at the wall
A modern Atom or Celeron NUC might bring that down to 10W but probably isn't worth the cost unless your electrocity is very expensive
as far as performance, you'll probably find worse single-thread and better overall (multithreaded): cpubenchmark.net/…
The Celeron NUC-likes are something like 110USD base, but storage and RAM costs extra
The Atom NUC-likes can be found for 80-90USD with 32GB of eMMC storage and 2 GB of RAM
 
> aaaaaaaaaaaaaaaaaaaaa
lol
 
12:38 AM
@Bob No HDD, no SSD, average 5% CPU use.
But it uses one of those:
How's this part called?
I suppose it spends some power itself for its fan at the very least
 
@ThatBrazilianGuy A power supply (PSU)?
 
I could just turn off both the mini-ITX and the extra AP and save more money, but it would be so... ungeeky .______.
@DavidPostill Is this called a PSU as well?
I know what it is and what it does and the name in Portuguese, just not in English
Damn I forgot what I had came here to pick up, my wife's going to be mad, I said it wasn't gonna take long
 
@ThatBrazilianGuy Yes.
 
1:08 AM
Hey folks! Can someone with more power than me look at the comments here: superuser.com/questions/1287665/thinkpad-t410-keeps-crashing
The first comment is from someone who is not the original poster and states, “Can anyone give me troubleshooting steps to isolate the problem?” and then right after the the original poster states, “So please give me some more specific information how to change the question.” Huh? Sock puppetry or something?
 
@JakeGould I dunno, his comment seems to suggest that he meant to put that part of his comment in quotes, as if to suggest what could have been said by the question.
 
Very different user profiles. This is bizarre...
Tim_Stewart, West Grove, PA, United States
100 4
supersquirrel, Berlin, Deutschland
1 1
 
@MichaelFrank no real evidence of socking
 
@JourneymanGeek Yea, I wouldn't have suspected it.
 
shrug lets blame it on odd phrasing and Tim trying to rephrase the question to fit
 
1:15 AM
I mean, that's exactly what he said in his last comment... sooo.....!
 
 
1 hour later…
2:33 AM
fun part about TFA. My google and Steam accounts are authenticated through my broken phone and I don't have backup activation codes cause I'm a neep
also, since @Bob complains about it - CCNA still does ip address classes, tho the CCNA routing and switching class I'm on apparently does IPV6
(got bored + need certs + government subsidises this one a fair bit)
 
Bob
2:50 AM
@JourneymanGeek If I had a dollar for every question about "class B private addresses" I've seen...
@JourneymanGeek Heh. I still haven't bothered with TFA for precisely that reason.
Well, that and it's really not much more secure than a nice random 20-char password :P
In fact, it can be less secure, if only because it's so easy to lose (availability is an important aspect of security) and the recovery processes are usually pretty susceptible to social engineering.
 
@JourneymanGeek Okay! Thanks!
 
Bob
KeeOTP (and keepass2android supports it too) has looked interesting, but ... I'd just be saving the secret in the same password DB anyway.
 
3:15 AM
mmmm
 
nnnn
 
Bob
3:34 AM
well, shit
a train crashed
 
3:49 AM
@Bob !
Looks like it didn't stop at the end of the line in time...
 
Bob
yea
weird one
 
4:18 AM
@JourneymanGeek After I saw a comment on Reddit, I started taking screenshots of the TFA QR codes and saving them on keepass
 
@ThatBrazilianGuy 0_0
@Bob @ThatBrazilianGuy in theory there's ways to recover this
in practice, eh, going to get that phone fixed anyway
 
Which is why I use 2fa that works via sms as well as app
 
@Bob DLLs. I use Linux. Does It work with keepass on Mono?
@JourneymanGeek It's so simple and genius at the same time!
 
I just use Enpass, which is apparently feature-equivalent to Keepass now (well, with keeotp) but proprietary
@ThatBrazilianGuy "DLL" is the file extension used on all platforms for pure IL libraries for .NET/Mono, so it could
 
4:23 AM
@FMLCat I don't seem to remember steam having that option
I THINK I can revoke it and install it on my spare device but.... ugh to that too
 
the code is C# so it might be pure IL
 
@FMLCat Until someone intercepts your SMSs using that roaming technology which I forgot the name. Or steals your SIM card.
What's "pure IL"?
 
@ThatBrazilianGuy considering how much shit is tied to phones these days, a lost sim card could be pretty bad
and if my phone was lost, rather than broken recovery and reinstall would be an option
 
@ThatBrazilianGuy IL is the Intermediate Language, the platform-independent bytecode of .NET/Mono (Mono just being a reimplementation of the .NET standards and APIs), so if something is pure IL, it'll run on any processor architecture and any operating system that implements .NET properly
 
its postpaid so I could trivially get a new sim and probably buy a new phone
 
4:26 AM
@JourneymanGeek Yeah, I'm trying to untie a few. Already untied Google. Tried Facebook but they REALLY like knowing my phone number.
 
so don't assume that all .dll files must necessarily be Win32 native code
 
(but ugh, I like my op3, and the op4t has the dumb fingerprint scanner at the back
@ThatBrazilianGuy I need to move whatsapp to my prepaid number ;p
 
Fuck WhatsApp.
 
shrug
My mom uses it
 
> 1.3.1 (Bug fix)

Fixed incompatibility with *nix systems. Requires clearing the plugin cache for plgx files.
 
4:28 AM
It doesn't even let you edit messages.
 
also actually handy for some other things
 
looks like KeeOtp is compatible with Mac/Linux
 
EVERYONE uses it here.
 
but any workplace that uses it needs to die in a fire
 
Billboards here display Whatsapp numbers.
@Bob Hm and how I get it to run on Android?
 
Bob
4:30 AM
@ThatBrazilianGuy keepass2android supports KeeOTP secrets
 
Natively?
 
Bob
As opposed to non-natively?
 
no plugins needed, I mean
 
Bob
keepass2android doesn't support plugins at all, sooooooooooooooo
 
I installed it from Google Play and can't find TOTP on its interface.
 
Bob
4:36 AM
I should say, it doesn't have a public plugin API
 
AOMedia Video 1 (AV1) is an open, royalty-free video coding format designed for video transmissions over the Internet. It is being developed by the Alliance for Open Media (AOMedia), a consortium of leading firms from the semiconductor industry, video on demand providers, and web browser developers, founded in 2015. It is the primary contender for standardization by the video standard working group NetVC of the Internet Engineering Task Force (IETF). The group has put together a list of criteria to be met by the new video standard. It is meant to succeed its predecessor VP9 and compete with HEVC/H...
 
Bob
@ThatBrazilianGuy it's not supposed to have one
iirc it recognises secrets stored by traytotp/keeotp and just displays them when you open an entry
 
welp. Doing something a bit odd - installing openSUSE into an external SSD via VirtualBox, using raw disk access. The intent is to make the drive bootable on any system with UEFI.
I have my doubts this will work, but it might just function.
EFI is enabled in the VM.
 
Might work actually
not the oddest bootable system I've seen tho ;p
 
Bob
4:53 AM
eh
UEFI is easy
you don't even really need to run an installer
partition it right and just extract the files to the location
 
Create ESP, write bootloader to correct location.
 
Bob
(though, that's even easier cause debootstrap. which I still haven't found a RHEL equivalent for...)
oh my
 
lol
 
@Bob 0_0
 
5:18 AM
Interesting. It boots bare-metal on Astaroth but not on the Bifrons netbook (which seems to have some weird issues with UEFI booting from USB).
 
@Bob lol he threw away his CPU
 
...okay. Enabling the CSM on that Lenovo worked.
...and we have a kernel panic.
> This should not happen!! Data will be lost
...USB communication issues? Trying again with USB 2.0.
Kernel oops from the EXT4 driver:
> Delayed block allocation failed for inode [...] at logical offset [...] with max blocks 1 with error 121
Looks like it does not like changing hardware.
 
@Ramhound Hold your horses. The user's activity on other sites suggests a compromised account.
 
well it is spam
but i didn't flag spam it yet
 
Or maybe not - the user might be misguided.
Be advised that your answer strongly resembles spam. Please add some details to your answer, including more details about the product in question. — bwDraco 22 secs ago
I cannot confirm it as spam.
 
@Bob How does this work? Is this an instance on your server?
FWIW, I've run openSUSE for many years on various kinds of hardware.
 
Bob
@bwDraco github.com/yudai/gotty running in an opensuse 42.3 container in lxd in ubuntu 16.04
basically, I got bored
I think I gave that instance write privs, so you can do stuff on it
(possibly including meltdown/spectre, idk)
did this before ... half a year ago?
 
I'd love to learn to do this.
 
Bob
@bwDraco which part?
 
@Bob LXD in Ubuntu Server.
 
Bob
6:13 AM
@bwDraco oh, it's easy on ubuntu...
 
I'd have to learn an unfamiliar distro, though, and new tools...
 
Bob
apt install lxd, lxd init, lxc launch images:opensuse/42.3 foo
but I personally prefer debian
which makes lxd less straightforward :P
apt install snapd, snap install lxd, lxd init, ...
@bwDraco pretty sure a snap copy of lxd works in opensuse too
 
docker run opensuse:42.3
 
Bob
@bwDraco meh, I've never really liked docker
 
Just a moment...
 
Bob
6:18 AM
lol
lxd (and snap) aren't too happy about nesting
it's doable but mildly annoying
 
root@li650-40:~ # docker create -it opensuse:42.3 bash
062a047b7453530bc390af93e35ff62f4be3b8b9ffa8d843513ffad758be9c0a
root@li650-40:~ # docker start -ai 062
bash-4.3#
 
6:38 AM
A lot of commands, even stuff like tar and wget, are missing, but fortunately, zypper is there.
 
6:54 AM
@Bob I really wish the lx brand of SmartOS were more compatible with Linux apps so I could just use that for everything
 
Bob
@allquixotic I probably jsut need to turn on the allow nesting option :P
but this is a throwaway container anyway
 
ugh. converting between binary and octal is vagyely kicking my arse
 
Docker container with openSUSE 42.3.
Built from this Dockerfile:
FROM opensuse:42.3

EXPOSE 8080

RUN cd /root && \
    zypper -n in wget tar && \
    wget github.com/yudai/gotty/releases/download/v1.0.1/… && \
    tar xf gotty_linux_amd64.tar.gz
 
Bob
I still remember when I first looked at docker as a possible OpenVZ replacement
I think that was the time I came upon a slide deck from the docker CEO ... where he flat out said they don't give a rat's arse about security and of course root inside the container is insecure and you shouldn't do that
I think that was the point where I got permanently discouraged from ever touching anything docker (the software, and the company) has had a hand in
 
Container shut down.
Hmm... Docker's design forces containers to be run as root, which increases the risk of a privilege escalation attack.
 
Bob
7:12 AM
@bwDraco Ah, yes. The good ol' insecure-by-default-but-you-can-secure-it approach.
I think I might call it "XP-style-security"
That said, I'm sure LXD isn't particularly secure either
And it has the downside of being rather Ubuntu-centric
(technically not, but it's certainly best supported there)
@bwDraco iirc systemd won't run insider docker either?
 
I am still a novice, just running the commands with the arguments I'm finding. I have yet to fully understand how to use Docker.
 
Bob
*shrug*
LXD is certainly designed more for the purpose (of running an OS contanier)
docker's never really made that their goal
 
HELLOOOOOOOOOOOOOOOOOOOOOOOOOOO
 
Bob
suppose it depends what you want
I personally prefer OS containers - application containers are just a tad too opaque
 
hi rahul
 
Bob
7:20 AM
(see also: recent issues with snapd)
 
where have you been
@Bob same :D
 
Bob
@allquixotic probably finding a new girlfriend :P
4
 
@allquixotic Was hospitalized, then went out of town to live in a monastery-thingy for a fortnight and then school reopened and now I have to organise this event after which I have exams
So it's been and is going to be a busy few months
 
Bob
@rahuldottech O_O what happened?
 
@Bob Appendicitis
 
Bob
7:22 AM
oof
 
@Bob I MET A GIRL!
4
 
Bob
feeling better now?
 
@Bob I'm perfect now :)
 
Bob
@rahuldottech ...well now, that's not news :P
@rahuldottech good to hear!
 
@Bob Yep. I hear you've been having a war with symantec?
 
7:23 AM
@rahuldottech holy crap
monastery? to get away from parents?
 
@rahuldottech You're homeless?
I don't quite understand your situation with your parents. Care to explain?
Also, a little bit of playing around with Docker.
 
AmEx historically is accepted at less places.. Visa is probably most universally accepted. Mastercard of late has been better, but AmEx is really the laggard
they've somewhat made up for that with newer tech in the 2010s though
 
Discover's acceptance isn't ideal, either.
 
7:43 AM
Nowadays you can buy a cheap credit card reader for an iDevice, sign up with Square, and get all of these cards in minutes: squareup.com/help/us/en/article/5085-accepted-cards
 
@allquixotic Does India have monasteries?
@JourneymanGeek Oh, it gets worse. Microsoft documentations actually define a "pilot ring", a small group of computers chosen as the metaphorical guinea pigs for testing latest updates to software. Apparently, doing such experiments on humans isn't against the Geneva convention.
 
Bob
8:05 AM
@allquixotic visa and mastercard are equal here. amex is rare-ish outside of the larger stores
@allquixotic meh... nfc is standard here :P
though phones to read would be unusual - there's some really nice terminals
 
@Bob we use the physical contact chips mostly, with the magnetic stripe being very much a legacy tech
 
Bob
@allquixotic even the chip is rare outside of eftpos (debit)
almost all tap
@allquixotic I've not seen these yet but afr.com/technology/…
these are fairly common though: delimiter.com.au/2012/07/17/…
but the older ingenico stuff is still more common
 
8:24 AM
@FleetCommand Yes. They are called Ashrams :)
Traditionally, an ashram (sometimes also ashrama or ashramam) is a spiritual hermitage or a monastery in Indian religions. == Etymology == The wording ashram (Sanskrit: आश्रम, Sanskrit pronunciation: [aːɕɽəmə]) comes from the Sanskrit root śram- (श्रम्) which means "to toil". According to S. S. Chandra, the term means "a step in the journey of life". In contrast, according to George Weckman, the term ashram connotes a place where one strives towards a goal in a disciplined manner. Such a goal could be ascetic, spiritual, yogic or any other. == Overview == An ashram would traditionally, but not...
 
@Bob As @allq mentioned, we use chip-and-signature for credit card purchases and chip-and-PIN for debit card transactions.
 
8:46 AM
@bwDraco Do you not have contactless readers yet?
If it's under 30 UKP I just wave my bank card over the machine for a debit transaction ...
Every so often Rarely (usually with a purchase in a new place) I might be asked to enter my PIN (as a security measure).
 
Bob
@DavidPostill limit's 100 here
 
@Bob The retailers are trying to get the limit increased here.
> Currently, the maximum a customer can spend in a contactless transaction is £30, but more than half of retailers want to see the limit increased. One in five retailers think the limit should be £100.

The limit was lifted to £30 in September 2015, and was previously £20.
 
I read somewhere it was due to go upto £50 'soon' but that was a few months ago, and it hasn't happened yet it seems
 
Bob
9:05 AM
@DavidPostill of course the issue is always fraud
 
Happy Birthday @DavidPostill
 
@Burgi Thanks :)
 
9:30 AM
Anyone else notice a big increase in Google Pages/Maps results when searching "book title pdf" recently?
 
no
 
9:46 AM
"book title pdf"? Am I supposed to replace "book title" with an actual title like "Harry Potter and the Mudblood Prince"?
 
Sure, if that's what you're looking for.
 
more or less yes
cough
@MichaelFrank there's better ways to do that.
 
What's with the "more or less" and the coughing? Did I say something wrong?
 
lol
there's not many reasons one "book title pdf"s
Its like "linux live cds" for biblophiles ;p
 
Well, unless you are talking about a Linux Live CD that runs a copy of EndNote...
 
9:50 AM
Anyway, turns out Amazon had the book I was looking for for $3 on Kindle. shrug
But not before I visited a bunch of random locations in the middle of the South Atlantic ocean with names like "DOWNLOAD FREE PDF OF book title"
All on Google Maps.
 
0_0
This I actually need to see for lols
 
one sec
A sample, although this one is somewhere between NZ and Australia by the looks
 
Or, it's just a map bookmark without any location data...
 
10:30 AM
o_O
 
10:42 AM
lol wut.
 
That was pretty much my reaction ha
 
11:00 AM
Is it just me, or does anyone else also experience this in Windows 10 1709? I am pretty sure it didn't appear in Windows 10 1703.
 
why is your start menu vertical?
 
I have a lot of horizontal screen estate and not much vertical. It is 1920×1080 anyway.
And since apps add so many toolbars and stuff, the vertical estate is really strained.
I remember having an HP Mini netbook with a 1024×576 screen. Docking the taskbar to one side was a must back then.
 
what thing are you questioning btw
 
1
A: Why did the population of Descartes, France increase by so much in the 1960's?

GrahamThey started thinking more, therefore there were more of them.

._.
Well played
 
@djsmiley2k You do see a chopped off dialog box near the bottom, don't you?
 
11:08 AM
ah that thing, right
yeah that's not happened to me.
 
Are you using Windows 10 1709 with a vertical taskbar?
 
nope
 
@djsmiley2k Well, then. That's why. This occurs only on 1709 and if the task bar is docked to the right. And of course, two users must be logged in at the same time. (Or else this warning is irrelevant.)
 
nice
 
Hehe. If you were looking for something mildy hurtful, you nailed it.
Now, the funny thing is: I reported it to Microsoft and included two screenshots but they are not showing.
 
11:47 AM
@ThatBrazilianGuy That's why it's 2fa
Stealing my SIM card wouldn't do much since it has a PIN code on it (and they wouldn't know which one it was), intercepting my SMS over the air would still require knowing my password. By which time you're probably talking about a three-letter government agency and I'm fucked anyway.
 
 
1 hour later…
1:08 PM
yawn
wtf?
 
Bob
 
Ave
@djsmiley2k you might want to modflag that
 
1:26 PM
@Ave i did
v.weird
 
Ave
no, I mean
 
@Bob ahhhhhhhh hands.
 
Ave
the message
 
Oh right
 
I got you covered
 
1:27 PM
ty @BenN
nuke the whole thing @BenN
 
zap
 
@djsmiley2k troll
shrug
 
Bob
@allquixotic (@bwDraco): zeta.systems/blog/2018/01/22/…
~1.5%
 
Bob
1:40 PM
Sausages. #SydneyTrains
The response from the official twitter account's pretty good too :P
 
@Bob Oh, so you met the invisible man?
I can still his hand though. The invisibility spell must be wearing off.
I find most of vandals very unimaginative. But recently, there has been one that changed all instances of PowerShell to PowersHell.
 
1:56 PM
I think my treat rewarding behavior for my cat is a skinner box (operant conditioning chamber): if she's in my room pawing at my arm, I don't give her a treat, but when she's out in the hallway laying down being a good girl, I bring her treats
now whenever I walk by the hallway she's laying there looking at me like, "I'M BEING A GOOD GIRL!!! TREATS????"
 
Well, that's better than Microsoft's stack ranking system, if anything... ;)
 

« first day (2726 days earlier)      last day (118 days later) »