« first day (1468 days earlier)      last day (2095 days later) » 

12:03 AM
@Ramesh I feel for anyone who is forced to talk to a computer program to find out if he is right. What kind of university is that, I wonder?
 
@FaheemMitha the question in it's current state looks ok.
 
@Patrick from where you got that image? might as well avoid that as the plage
 
@Braiam It's unfortunately a very common program in school. I forget the name of it though
 
@Patrick, +1 to your answer but still I do not want to uv the OP.
Anyways, I reversed the dv.
 
@Ramesh I can understand that. After all the op didn't fix the question, we did.
 
12:15 AM
@Patrick exactly.
 
slm
We used one when I was taking a introductory class to analog circuit designing. It was a maddening experience b/c the s/w required you to put in the exact answer to several decimal places which was completely ridiculous
 
Your answer, "43.12" is incorrect. The correct answer is "43.120"
 
@Braiam Heh, i like that.
 
slm
@Patrick and it only let you have 10 tries for an A
ppl would ration the tries out over days
and each student had unique data so you couldn't ask joe what he got for #4 8-)
 
12:27 AM
similar experience here, except we had a question pool. So each student got 40 out of 60 questions or so, and in random order. So it was still possible to consult others.
 
I had an second hand experience with said programs
it wanted you to write "it is" instead of "it's"...
 
ETS makes lots of money inflicting not dissimilar experiences on people.
 
the sad part is that the one I was helping told me to write exactly as the answers book said, which I considered ridiculous, since you are supposed to learn something, not just being a parrot
 
@Braiam yes, that's often what education is reduced to. The West is bad enough. Places like India tend to be worse.
 
slm
anyone know the name of the s/w that is shown in the screenshot from that pathnames Q?
 
12:38 AM
seems to be called "Matrix"
in Tavern on the Meta on Meta Stack Exchange Chat, 16 hours ago, by Infinite Recursion
SE should send them rubber ducks as swag
 
That page mentions Sobells "A Practical Guide to Linux"
Actually a pretty nice book. I have it. Or did.
 
I'm almost suggesting that on meta...
 
slm
12:57 AM
wow so if you search for uli101 you'll find the labs spread around but this site has the A'ers available for purchase
it's discussed in this Canadian forum
 
1:47 AM
1
Q: Perl plugins don't work on my rxvt-unicode!

r004I wanted to add some features to my urxvt so I changed my .Xresources file. for the global effect of plugins I copied them all to /usr/lib/urxvt/perl. but still no multi tab, clickable link or changing the font size on the fly. The keymap hassle is active too. Urxvt.perl-lib: /usr/lib/urxvt/perl...

"put on hold as off-topic" ... "a problem that can't be reproduced"
what?
It is reproducable. And it was closed after the user posted the solution.
 
urxvt is very picky about its Xresources.
 
slm
@Patrick - Those types of Q's are often closed w/ that reason.
It's a typo
 
Meh, I can somewhat go with that. But it also seems likely that someone else might run into the issue, and thus the solution would be helpful.
 
slm
And it'll be here when they do 8-)
 
Is it a typo when It's systematic as well? Meaning it wasn't just mistyped once, it was the whole config
Maybe. It's only 1 point away from meeting this rule:
The system will automatically delete closed (not as a duplicate), unlocked questions with zero or negative score having no upvoted or accepted answers or pending reopen votes, that were closed 9 or more days ago and haven't been edited in the past 9 days.
 
slm
1:56 AM
There I UV'd the A, so it's safe 8-)
It had an UV already on theQ so it was safe anyways. BTW I UV'd the Q before to protect it from that already.
 
Yeah, thinking about it more, I still disagree with the close. While the description of the close reason mentions typos (and very briefly at that), the primary purpose is in bold, "can't be reproduced".
 
slm
That's the default choice when you go through the close reasons
 
Yes, but you're a mod. If you're on the fence, you shouldn't vote.
 
slm
Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers.
I wasn't on the fence, I found that to be a useless Q, since the file was laden w/ typos to start w/
 
oh, pardon. I misread "default" with "difficult"
 
slm
2:00 AM
Halos fixed it but it was still a broken config file, so in this case is of no value. I get what you're saying but the existence of this is a double edged sword. Others may stumble and find a bogus file and try it while others may be saved by it's A
How many times have you read something on the internet only to find out that it's been supplanted but the owner never bothered to update their content. This is very much like that to me and I would've rather seen it just go away.
@Patrick - the close reasons are laden with compromises, IMO. Unclear to me is a cop-out but that's the option that best fits often times.
 
I would also ask this, what is accomplished by closing it? If the answer isn't going to be deleted. It's been solved, so nobody else is going to answer it. So what is gained?
 
slm
I also might have a different view of closings than most. I view closings as a timeout bench that Q's can be put into until they're brought up to snuff, once they're in good shape, then they can be A'ered. Also I think more ppl should spend time A'ering + fixing the Q, but that does not happen all too often.
My $0.02, is that by closing it we're marking its value as marginal so when future ppl traipse over it they'll know that the community has said that this Q is 1) so-so and 2) the answers to it may not be all that correct or valuable.
closing it also cuts it off from anyone that's already here from wasting any further cycles on it too
 
@slm Isn't that what voting is for?
as in points, not closing
 
slm
there are many signals that a Q&A gives the reader as they view it. Voting is def. a higher signal but the close is lesser so.
 
 
8 hours later…
10:40 AM
 
slm
10:54 AM
@Braiam - set
 
 
3 hours later…
2:04 PM
@Ramesh you have both
> cat file1 file2 | sort | tee >(>file3) >(cat file3)
and
> cat file1 file2 | sort | tee file3
in your post on that A
you only need the second
and your other command
> cat file1 file2 | sort > file3 | cat file3
 
@casey, yeah. I was listing out all the options.
 
should be
> cat file1 file2 | sort > file3 ; cat file3
the pipe is meaningless there
@Ramesh is that first one even an an option?
 
@casey, all of the options I tried worked.
So I was listing them.
I would add yours as well to the answer.
 
yes, but that bit at the end >(cat file3) does nothing
try the command with and without
and the decoration of >(>file3) is rather redundant when file3 works alone
so it reduces minimally to the second form and the additions in the complicated form don't add anything
 
@casey, I have cleaned up fair amount of the options that are useless.
 
2:09 PM
its better now
 
Now, I have only 2 options listed.
cat file1 file2 | sort > file3; cat file3
cat file1 file2 | sort | tee file3
 
you could also do without cat with something like
% sort <file1 <file2 >file3 ; cat file3
or
% sort <file1 <file2 | tee file3
note that that works in zsh
but I dont think bash likes multiple input redirection
 
@casey, ok. In bash it considers only file2
 
so perhaps not an addition worth using
:)
 
well zsh offers it.
I tested in zsh and it works. I will add to the answer. :)
 
3:04 PM
don't we have a question about sudo and shell builtins?
 
Hi guys.
I hit 10k yesterday. The 49th user to do so on this site.
 
slm
congrats!
 
how i make this code to work in Perl?
$ perl -00pe 's/(^[^\n"]*"[^"\n]*)\n((?1))/\1 \2/g' m
090033ec82b13639,CPDM Initiated,Logistical,"There corrected.",Gul Y Serbest,Urology
090033ec82ae0c07,Initiated,NA,"To   local testing
Rohit  3 to 4.",Julienne B Orr,Oncology
090033ec82b35fd0,Externally Initiated,NA,regulatory agency requests,Kenneth A Lord,Oncology
 
@slm Thanks.
 
But it works in the demo site.
 
slm
3:14 PM
seems like a SO Q not a U&L @AvinashRaj
 
:-)
 
slm
@Braiam dunno
 
@Gnouc Hi..
 
slm
3:34 PM
@AvinashRaj - he's changed his username
Here: cuonglm
 
@Braiam thanks for the correction. Fixed.
@Braiam I didn't know POSIX mandated an executable version of cd. Interesting if true.
 
3:52 PM
the POSIX definition only says what is expected of cd, not that it should be included as binary pubs.opengroup.org/onlinepubs/9699919799/utilities/cd.html
 
@FaheemMitha congrats.
 
@AvinashRaj: What do you want with your example?
 
@Ramesh Thanks. Looks like you're up next. Or possibly @Braiam.
 
I am so used to gnouc. Why did you change @cuonglm?
 
Only 10 users over 25k. That's quite a small number.
 
4:00 PM
@cuonglm i have to append this Rohit 3 to 4.",Julienne B Orr,Oncology line to the previous one.
 
And only 2 over 100k. :)
 
expected output:
090033ec82b13639,CPDM Initiated,Logistical,"There corrected.",Gul Y Serbest,Urology 090033ec82ae0c07,Initiated,NA,"To local testing Rohit 3 to 4.",Julienne B Orr,Oncology
090033ec82b35fd0,Externally Initiated,NA,regulatory agency requests,Kenneth A Lord,Oncology
 
@slm, do you have any timeframe to overtake gilles now?
 
slm
never @Ramesh 8-)
 
Indeed. And hardly anyone from Asia or South America among the high rep crowd. And one person from Africa.
@Ramesh Trying to catch up to Gilles don't see like a good prescription for sanity.
 
4:02 PM
@Ramesh: My name is Cuong, full name LE Manh Cuong. Gnouc is only a nick name.
 
@FaheemMitha yeah. I have seen people active in SO. But sadly, they are not interested in sharing their knowledge to others.
@cuonglm yeah I know. But still I am so used to Gnouc. Probably if you plan on having another name, you could have Gnouc :)
 
@AvinashRaj: It's hard for me to understand the requirement. Can you make it a question on site or pasting some where with your input, the logic and the expected output?
 
@cuonglm It is a question. Probably on SO.
 
slm
@FaheemMitha his inventory of A'ers becomes too large to work against. He's got 5k+ A'ers that generate 100+ reps a day for him even if he does nothing. So even if I were to keep my daily @ 230 it would take me ~1000 days to catch him. And he's rarely idle, so his daily efforts are still netting him 100-150+ on avg. additional rep, so it's basically impossible to catch him.
I'm more interested in this point in helping others and in learning to be a good moderator
 
@slm well, you should become a professor :)
 
slm
4:12 PM
being a mod requires different skills then being a top A, and this is what I've been focusing on + in expanding my horizons in learning new technologies
 
slm
@Ramesh - I'm as much a professor as I need to be here.
 
@cuonglm i just want to combine the lines where only one double quotes exists..
 
@FaheemMitha Hey, cool! I missed that, well done!
 
@terdon Thanks.
@slm Agreed.
@slm That's really what this site is about. That, and getting one's own questions answered.
 
4:16 PM
well after @terdon and @slm became mods, I hardly notice anything pending in the review queues :)
 
@Ramesh That's mostly @slm. I do most of my janitorial stuff on the questions themselves.
 
slm
@FaheemMitha the competition is fun and def. keeps ppl motivated but at the end of the day he's vastly more knowledegable about things than I, and so I'll continue to learn new things myself and contribute to the site where I have more knowledge or a wilingness to learn about Q's as they come up.
 
@terdon well @slm is the Jon skeet of U & L SE.
 
@slm That sounds like a good attitude. I'm not really into competition myself, at least not of this variety.
 
slm
hardly
 
4:19 PM
Jun 5 at 16:45, by terdon
The way I see it, Stephane is some kind of mythical, magical creature, Gilles is a wizard and slm is a human paladin.
2
 
slm
gilles and stephane are way more knowledgeable of things than I. Yes was going to get that quote
that's very true.
 
The rest of us are regular humans or dwarves and the like :)
 
slm
And in working w/ Patrick I've been surprised that he's as knowledgeable as Gilles in things but isn't as active here.
 
@slm yeah that's true. I second that.
 
@slm Yeah, I've seen that in his answers. Hell, apart from me, everyone else on the top few rep slots are professional *nix people/*nix programmers who have been doing this type of thing for decades.
 
slm
4:20 PM
So one lesson I've re-learned is that even though a person may have a lower rep, don't sell them short. We have many individuals who are extremely bright and knowledgeable and may just not be able or willing to help out here to show that.
 
@terdon that's what makes you special.
 
@Ramesh I knew there was something :)
 
The way I see you is "master of all trades" :)
 
@Ramesh, @terdon, @slm: I have never considered high rep is important. I have a high rep but I know my knowledge is not good as many others.
 
slm
your knowledge is excellent in awk and perl from what I've seen
 
4:24 PM
@cuonglm you have an excellent knowledge on many things dude :)
 
slm
I think the main attribute that matters that we all have in common is that we are bothered when we don't full understand how things work under the hood, to the point where we'll spend hours analyzing it and contemplating why something is the way that it is.
 
@cuonglm I'm with @slm on this. You come up with some really cool perl one liners.
 
slm
@cuonglm - I've had to take many of your A'ers and play with them to understand how things work.
I never would've even considered using Perl via the command line the way you have.
I think the biggest issue many of us have is in asking Q's
 
If I even become half as good as you guys, I would consider myself lucky enough :)
 
slm
We're so used to figuring things out for ourselves that we rarely think to ask things as Q's.
 
4:29 PM
@slm, @terdon: I thinks it's based on your choice. You can have cool one liner in whatever you're goot at. Like mikeserv with sed, glenn jackman with awk and of course, Stephane for almost all things :)
 
slm
very true
not sure how many of you saw the conversation from last night. Patrick brought up the Q that included the screenshot w/ the student asking about how to move a file using relative paths
we've fixed that Q and patrick A'ered it but that whole thing was still bugging me today
 
@Ramesh: Try your best and it will be success. I'm still learning everyday beside my work.
 
Patrick did good work on that Q. My effort on it collapsed after the comments I left in the other A
 
@slm: Can you give me the question link?
 
slm
@casey - he A'ered it
I"m looking
 
4:33 PM
@slm hes, the OP just needs to go back and accept his A
 
1
Q: How can I copy a file from another directory to the current one?

user88022I have this problem as part of a school assignment: NOTE: In case it's hard to read in the image above, here's the directory tree: $ tree . `-- sample_dir1 `-- sample_dir |-- admin |-- cambridge | |-- cafeteria | |-- library | `-- security ...

 
on face value it sounds like a bad Q, until you realize he's doing it right, just not within the constraints of idiotic testing software
 
slm
6
A: How can I copy a file from another directory to the current one?

PatrickThe problem you're running into seems to be with your homework program. From your comment on the other answer, you tried: cp ../cambridge/security/parking ./parking2 This is a perfectly valid command in a normal shell. However the issue is likely that your testing program doesn't want the ./ ...

 
@slm seems like a waste of time and effort to me, frankly.
Extensive question cleanup in this kind of context.
 
slm
The part that's been bugging me is the treatment of this user
 
4:35 PM
@FaheemMitha the effort imho was warranted after the comment exchange in the early A
 
slm
He asked a valid Q, but on the surface it wasn't well asked
 
he got a really bad reception
 
slm
yeah that's the part that's been bugging me
on the surface it seemed as though he was trying to get us to do an assignment for him
 
@slm oh, you were upset about his treatment?
 
slm
If you see some of the deleted comments
 
4:36 PM
sometimes people overreact. it comes with the territory.
 
slm
I've also cleaned up the comments there quite a bit too
 
@FaheemMitha if you are reading the comments now, someone cleaned them up
they were less friendly originally
 
slm
> What is this, some kind of preschool test?
That had a +1
 
If it's the Zombie Apocalyse, you tend to shoot from the hip. Similarly, in a Q/A site, you tend to see clueless morons everywhere.
 
that one, but also the "you are misusing cp and doing this completely wrong!" on the first A
 
4:38 PM
@casey I believe you.
 
slm
@casey - yeah I edited that comment too
 
@Gilles about that dupe, your answer is basically the same as mine: export XAUTHORITY. Why isn't it a dupe?
 
@FaheemMitha that was my instinct until it became clear he was trying to use a valid command, he was just being too verbose for the testing software
 
slm
Patrick brought it up here and Gilles too was like "nuke it"
 
@casey Sure. My point is, a certain amount of misunderstanding is inevitable. No point beating oneself up about it.
 
slm
4:39 PM
I eventually moved the text of the Q out of the image and reopened it
 
@slm Gilles is busy trying to be in 10 places at once. I don't think he was really paying attention.
 
@FaheemMitha oh, I'm not beating myself up about it. Both the OP and the author of the first A acknowledged my comments to them :)
 
slm
yeah agreed
 
Do you all agree with Gilles that this is not a dupe?
2
Q: Create a notification on the screen initiated by root

rubo77I would like to give out a notification on screen by a script that is running by root on Ubuntu 14.04. I tried this: #!/bin/bash MAINUSER=$(cat /etc/passwd|grep 1000|sed "s/:.*$//g") su $MAINUSER -c 'notify-send "starting some scan... "' #.... su $MAINUSER -c 'notify-send "scan finished "' wh...

 
slm
I'm just making sure that we're doing a good job of making the site accessible to those that aren't knowledgeable
 
4:40 PM
@casey Not you personally. I'm speaking generally. You're one of the people least likely to overreact, I think.
 
@FaheemMitha my wife might disagree with you :)
 
@casey :-)
Well, over here, anyway.
 
@casey Yes but that goes for everyone's wife. Or husband for that matter. Comes with the relationship.
 
@terdon indeed
 
slm
@terdon - the bit about notify-send seems to be the difference maker when I looked at the 2
I'd be apt to reopening it
 
4:46 PM
@slm Go for it. I don't know enough about dbus to judge. I just saw that my solution (which works for me but not for the OP so far) is basically the same as Gilles's A on the dupe so I figured it was a valid duplicate.
 
@terdon but I was answering a different question
AFAIK rubo needs DBUS_SESSION_BUS_ADDRESS, not DISPLAY+XAUTHORITY
but I haven't tested
 
slm
@Gilles - that sounds correct, I recall another Q&A with that solution as well.
 
@Gilles I know and I thought it wasn't a dupe at first either. But then I decided it was since the basic question seemed to be "How do I run a GUI app when logged in as another user" and exporting $XAUTHORITY is the answer as far as I know. As I was saying, I don't know dbus enough to judge whether it's significantly different.
@Gilles It works for me without them.
 
slm
3
A: notify-send not working under ssh

slmI think you're confusing the various technologies and how they work. I wouldn't expect that the notification daemon from one system could send messages via SSH. Setting the $DISPLAY is how X11 sends the output from an application to another for displaying purposes, but the notify-send is sending ...

I show how to do it over SSH, should be similar
 
@slm yes, thanks
you should close as a dupe of that
 
slm
4:51 PM
ok
 
So why does it work for me then?
I used the exact script from my answer (export XAUTHORITY="~$MAINUSER/.Xauthority`), drop to a tty, log in as root and run the script.
I then go back to my X session and the notification appears.
 
and does it stop working if you define XAUTHORITY to not point at that file?
 
Maybe it works different on Ubuntu?
 
@Gilles Yes. Let me check again but it did last time.
 
@rubo77 the principles are the same, but the locations involved may be different (and in particular may be non-default, so that you need to set the environment variables)
 
4:53 PM
Ah. No, it doesn't.
 
For DISPLAY there's no default. For XAUTHORITY, the default is ~/.Xauthority, so if your distribution/login method uses that, you don't need XAUTHORITY set.
For DBus, I don't know.
 
Huh. @rubo77 my apologies.
 
I found this: ubuntuforums.org/…
but it is a bit too high for me
 
half-way to RV steward, yeah!
 
@Gilles so, I just saw that exporting XAUTHORITY makes no difference but why does the notification appear regardless? I just logged out/logged in again to clear any vars and this script gave me a notification when run from a tty as root:
#!/usr/bin/env bash
sleep 5;
export DISPLAY=:0;
MAINUSER="$(awk -F: '$3==1000{print $1}' /etc/passwd)"
su $MAINUSER -c 'notify-send "starting rkhunter scan... "'
 
slm
4:55 PM
@Anthon - impressive
 
Also:
$ xhost
access control enabled, only authorized clients can connect
SI:localuser:terdon
SO dbus is completely independent of this apparently.
 
the content of ~/.dbus may matter
 
I have a couple of cookies. Presumably, su terdon reads them I guess.
 
no, su terdon doesn't read any of this. But notify-send might.
 
̉And because I run it as terdon, it reads the right ones. OK. So why would it not work for rubo I wonder?
 
5:01 PM
I think most comments by @Alex are obsolete here now? unix.stackexchange.com/questions/162492/…
 
I confirm that on my Ubuntu 14.04, env -i /usr/bin/notify-send foo doesn't work but env -i DBUS_SESSION_BUS_ADDRESS=$DBUS_SESSION_BUS_ADDRESS /usr/bin/notify-send foo works
I don't know why it works for you without it
 
that looks strange with ` =`
 
is dropbox a good place to put random public tarballs? alternative suggestion appreciated.
 
echo $DBUS_SESSION_BUS_ADDRESS
unix:abstract=/tmp/dbus-Ur9q5vwald
 
@rubo77 zsh notation, I edited my message to use standard stuff
 
5:05 PM
which message?
 
@rubo77 the chat message with the ` =` that had you puzzled
 
@Gilles I get the same behavior on Gentoo
 
it's a zsh thing for "$(command -v cat)"
 
ah now I see... I tried it, I coied your message and put it into my root guake window, but no notification here
 
VirtualBox, KVM and all virtualization techniques use qemu in the behind scenes?
 
5:09 PM
@Ramesh i do not think that is a true statement
 
doesn't work if I run that as root though. I have to run notify-send as the target user.
and then it works, with only DBUS_SESSION_BUS_ADDRESS in the environment.
 
@casey so are they different?
 
@Gilles I still don't understand what that should do. can you post that as answer? I have to eat now, se you later, and thatnks
 
@rubo77 slm already did, on the duplicate
I'm just confirming that his answer works for me
 
5:29 PM
Sorry.
 
6:02 PM
given an ssh private/public pair, can i test a passphrase without actually running ssh?
27
A: How can I test my ssh-keys locally without a server

sransaraThis should work: ssh-keygen -y

 
slm
6:41 PM
Do we want this Q here?
0
Q: What are the advantages of using Named Pipes/Domain Sockets?

LukePSo I am working on a project which involves a Python back end and a JavaScript Front end, but there is also some PHP acting as the middle man between the two and serving up the web pages. I know it is possible to get rid of the PHP entirely, in favor of Python, but I am working in a group under...

 
7:02 PM
@slm it could work but it's really about programming, it belongs on Stack Overflow
 
slm
I know
I left the OP a comment asking if we could cut the PHP/Python bits out and just ask the Q what are the advantages of named pipes/sockets over temp. files.
that's a little biased to being an opinion Q but might work here
 
 
3 hours later…
9:47 PM
Reposted. Types of credit cards was specified in the post earlier, I guess you were not paying much attention to the description. 80% of the System Admins I encounter make mistakes due to their high level of self-confidence and sometimes weak attention to detail. — cryc0s 6 hours ago
I have half a mind to call him on his sampling methods... nah... flags
 
10:03 PM
@Gilles Cheeky.
 
@Gilles Is he seriously *itching because he removed information from his question, and the provided answer didn't cover the information that was removed?
 
@Patrick dunno. I predict an interesting time for him if he encounters a conscientious PCI auditor.
 
/me reads the question to see what evil he's doing
 
@Patrick scrubbing what looks like credit card data, which is fine
but if he needs to ask that, what are the chances that he isn't doing something wrong elsewhere?
 
slm
Why hasn't this been closed?
 
10:11 PM
true, and I don't imagine PCI auditors are going to be fond of that data being in a file in the first place. There should be nothing to scrub
 
@Patrick the input needn't be a file
 
slm
Find out what website he's building this for so we can avoid it
 
@slm because it's answerable
 
@Gilles While this is true. I'd bet you it is
 
slm
@Gilles hacker Q's are not off-topic 8-). So if we tell the guy how to do it are we not culpable?
 
10:16 PM
0
Q: What has priority - owner/user vs group permission?

humanityANDpeaceI have just run into the case in which the owner-group of a file has more permissions than the owner-user of a file. user1@pc:/tmp$ ls testfile -l ----rw---- 1 user1 user1 9 Okt 16 13:16 testfile Since the user user1 has no permissions to to read the file I get this user1@pc:/tmp$ cat testfi...

I'm sure I've answered that before but I can't find it. Don't we have a dupe?
 
slm
2
A: Linux File Permissions Enforce Order

Gilles The thing is, I always thought these permissions collapse on each other, starting with the most general one (other -> group -> user). If it was the case then “other” permissions would apply to everyone. In other words, if o=rwx who cares what the persmissions for group and user are? Th...

that looks like our A
 
@slm thanks, vtc'ed
and I edited the sucky title of the old q
 
slm
I saw
hasn't this Q been answered enough yet?
0
Q: Bash error: "[y command not found"

Lyall JohnsonI am trying to get this script to function correctly but I get ./passmark.sh line 7: [y command not found. Here is my script #!/bin/bash # A simple script to ask a user for a pass mark and then display a grade # the grade will be either an A, B, C, D or F # CONT=y echo while [$CONT = "y" ] do ...

is there a good Q&A for "I forgot spaces in my square brackets"
 
I'm sure there is. Whoever finds it please add it to the tag wiki.
that and unix.stackexchange.com/questions/159941/… are the only ones I can find with the tag
there's unix.stackexchange.com/questions/117438/… but it's a bit different, it's asking why the syntax is that way. It can't be the canonical question but it should be linked from that.
I'm picking unix.stackexchange.com/questions/134472/… as the canonical
 
slm
10:33 PM
That's the best I can find too
meanwhile..another looming disaster
-1
Q: Create a list of directories

MJAI have a list of names in a text file (list.txt) I want to create a list of folders for the names included in that file. I wrote the following script, but it doesn't work and I don't know what is wrong: #!/bin/tcsh for name_id in `cat <path to list.txt>/list.txt` ; do mkdir <name_id>${name_id} ...

 
10:55 PM
0
Q: Installing oh-my-zsh without git

user72394How can I install oh-my-zsh from master on the machine behind firewall and without git and internet access?

is this really on-topic?
it seems that the question isn't about installing oh-my-zsh, but about finding the “download” button on the web page
 
Hi! How is it possible to delete all files in the folder blah/ who have a "last access date" older than 1 week ?
 
@Basj search on the site, I'm sure I've answered that before
 
@Gilles I have this : serverfault.com/questions/122824/… but this is for "modified since", but here i would like "last access date"
 
@Basj -anewer instead of -newer
assuming your system records access times, modern Linux systems usually don't
 
@Gilles oh really? How to know if my FS stores access times ?
 
11:03 PM
storing atimes means that reading from a file causes a write
 
@Gilles yes, how to know if this happens?
 
it was found to be a non-negligible performance hit in I/O-heavy systems
 
@Gilles oh true, I can image.
 
check if the mount options include something containing atime
you can test by creating a non-empty file, reading it and checking if the atime gets updated
 
I see : /dev/sda3 on /home type ext4 (rw,relatime,data=ordered)
 
11:05 PM
echo hello >foo; sleep 2; cat foo; ls --full -u foo; sleep 2; cat foo; ls --full -u foo
@Basj relatime is the default, so atimes are only stored if they're different from the mtime
so no, in general
Under relatime, a file's atime is only written if some program first explicitly made it different from the mtime
 
ls --full -u foo doesn't show the seconds, but only hrs:min
I can see -rw-r--r-- 1 root root 6 Oct 17 01:06 foo : it was updated by the cat :)
 
weird, do you have an alias for ls?
 
but how to know if this date/time provided by ls -full -u is the last access times or modified date ?
@Gilles idk, it's a fresh Debian 7.5 install
 
you should be seeing nanoseconds
try LC_ALL=C ls --full -u foo
 
@Gilles not displayed...
-rw-r--r-- 1 root root 6 2014-10-17 01:06:59.525048476 +0200 foo
and now, let's cat foo ... Now it gives :
 
slm
11:10 PM
Ahh...move this Q to the main site please!
 
There you go, your locale is probably buggy and forcing a time format without s or ns. I don't know how to fix that.
@slm yes, once we figure out what the question is
 
slm
8-)
close this one?
0
Q: My Ubuntu won't recognize the command ./configure

RaynorI have recently purchased a computer off of my sister that she wiped and loaded with Linux. Now that I have it, I have no idea what I'm doing and need some help. I have been trying to install Unity Web Player, and the process was fine, until one of the commands I entered was not recognized. That ...

 
Why is ls --full-time giving a different time than ls --full-time -u ?
ls --full-time -u
-rw-r--r-- 1 root root 6 2014-10-17 01:06:59.525048476 +0200 foo
ls --full-time
-rw-r--r-- 1 root root 6 2014-10-17 01:05:47.819127316 +0200 foo
 
@Basj because the atime was recorded
 
11:27 PM
I was looking for duplicates for unix.stackexchange.com/questions/162586/…
any preference among the following? Should some be closed as dupes?
17
Q: how to glob every hidden file except current and parent directory

lesmanaI want to glob every hidden file and directory, but not the current (.) and parent directory (..). I am using bash. Observe current behaviour: $ ls -a . .. ...a ...aa ..a ..aa .a .aa .aaa a $ echo * a $ echo .* . .. ...a ...aa ..a ..aa .a .aa .aaa I would like .* to behave like this...

37
Q: How do you move all files (including hidden) in a directory to another?

Cory KleinHow do I move all files in a directory (including the hidden ones) to another directory? For example, if I have a folder "Foo" with the files ".hidden" and "notHidden" inside, how do I move both files to a directory named "Bar"? The following does not work, as the ".hidden" file stays in "Foo"....

7
Q: What's the best way to count the number of files in a directory?

rahmuIf parsing the output of ls is dangerous because it can break on some funky characters (spaces, \n, ... ), what's the best way to know the number of files in a directory? I usualy rely on find to avoid this parsing, but similarly, find mydir | wc -l will break for the same reasons. I'm working ...

Wow, most 1-year-olds don't write as well as Shakespeare
 
slm
11:42 PM
Your A on the 2nd one is the one I'd close dups to
 
@slm done
 
slm
@Gilles - thanks
 

« first day (1468 days earlier)      last day (2095 days later) »