« first day (2327 days earlier)      last day (1296 days later) » 

8:31 AM
@DavidCarlisle ;-)
 
 
2 hours later…
10:23 AM
MOAR CAKE TODAY
 
10:35 AM
@PauloCereda Greedy!
 
@CarLaTeX /shares cake
 
@PauloCereda <3
 
@CarLaTeX <3
I am a good duck.
 
@PauloCereda Very good!
 
@CarLaTeX yay
 
10:41 AM
@cfr See here: tex.stackexchange.com/q/358562/101651, that's what I intended for tikz squashing of the text...
 
11:07 AM
@JosephWright No meeting for me today: graduation committee at the same time and unfortunately I'm supposed to listen to the presentations.
 
@JosephWright we should assign all actions to @egreg in his absence.
 
@DavidCarlisle ooh
 
11:55 AM
@egreg Cool
@DavidCarlisle Also cool
 
@JosephWright should we add make all latex packages work in amstex to the agenda?
 
12:19 PM
 
@PauloCereda @egreg will be proud of you
 
@DavidCarlisle :)
 
@PauloCereda Are you going to eat that?
 
@egreg no. :)
 
@FrankMittelbach name from the past:-) github.com/ho-tex/oberdiek/issues/23
@PauloCereda you still have time to edit that to say yes
 
12:22 PM
@DavidCarlisle ooh
 
12:59 PM
@DavidCarlisle Ah. That's where the sudden interest for amstex comes from. But I hope you won't spent to much time on it ;-)
 
1:17 PM
@UlrikeFischer David has a lot of Minecraft farms to harvest. :)
 
@PauloCereda minecraft and pokemon go are so last year
 
@DavidCarlisle What do we have now? Nintendo Switch? :)
 
@PauloCereda farming simulator and scrap mechanic :-)
 
@DavidCarlisle ooh :)
 
 
1 hour later…
3:33 PM
I have a debugging challenge for you. The ams classes has issues with reqno + empheq, I can reduce it to the following MWE. Can anyone come up with an idea why the \everydisplay setting causes empheq to not display eq numbers. I cannot quite figure out how to debug this.
\documentclass{article}
\makeatletter
\def\fullwidthdisplay{\displayindent\z@\displaywidth\columnwidth}
\edef\@tempa{\noexpand\fullwidthdisplay\the\everydisplay}
\everydisplay\expandafter{\@tempa}%<-- bad ???
\makeatother
\usepackage{empheq}
\begin{document}
\begin{empheq}{align}
A
\\
B \label{h}
\\
C
\end{empheq}
\end{document}
Interesting hint, empheq redefines \measure@, if one ask it to typeout the value of \displaywidth, then you always get the same value when \everydisplay\expandafter{\@tempa}, is used. If that code is deactivated, one get two different values (the first being 8192pt)
 
@daleif empheq uses \displaywidth all over the place, is it expecting it to be changed in everydisplay? why can't you set it earlier, eg at the start?
 
@DavidCarlisle I'm not setting it, amsart.cls is setting it like this. The above is the simplest MWE I could make without using amsart.
I'm guessing that it resets \displaywidth everything time display math is entered. Where does the normal value of 8192 come from?
 
3:52 PM
@DavidCarlisle: Hi! I guess that this comment refers to an—ahem!—“undocumented feature” concerning pdfremotestartview that I reported some times ago: do I guess correctly?
 
@daleif tex-the-program sets \displaywidth based on the current \hsize and \displayindent
 
@DavidCarlisle Thanks, I’ll have a look as soon as I can. Bye!
 
@GustavoMezzetti It's exactly the code you suggested (unless I copied it incorrectly:-)
 
@DavidCarlisle I gathered as much, was looking through tex by topic. Interestingly this bug only appear if the eqnos are on the right, ams default is left, so probablt have not seen them before.
If I change \def\fullwidthdisplay{\displayindent\z@\displaywidth\columnwidth} to \def\fullwidthdisplay{\displayindent\z@\displaywidth\hsize}, things work again. hmm
 
@daleif makes sense presumably empheq has reduced teh effective column side to add its border
 
4:01 PM
@DavidCarlisle I'll look at it again tomorrow.
 
@DavidCarlisle Yes, indeed, I’ve just checked it!
 
4:53 PM
Quaaaaaaaaaaaaack
Let's break the silence a bit. :)
 
5:05 PM
@GustavoMezzetti thanks, there are a couple more open issues that I might try to sneak in but I need to do an update to hyperref soon (before the next latex release)
 
@PauloCereda I've been typing up meeting minutes
 
@JosephWright oh no
 
@PauloCereda Also reaching rep cap for a pretty trivial answer
 
@JosephWright link please. :)
 
15
A: How can I typeset Greek letters in siunitx?

Joseph WrightYou need to disable the parser for anything that is not a number: \documentclass{article} \usepackage{siunitx} \begin{document} \SI[parse-numbers = false]{\alpha}{\radian} \end{document}

 
5:08 PM
@JosephWright upvoted. :)
 
@PauloCereda Eight more days at 200 needed for Legendary ...
@PauloCereda That's OK: already rep capped
 
@JosephWright OK, I had refrained from voting, so you are my target in the next few days. :)
 
@PauloCereda I'm not really fussed: I decided a long time ago that it was largely better to let others take the low-hanging fruit
@PauloCereda I do like to do the siunitx questions though
 
@JosephWright :)
 
@PauloCereda In any case, it's hard to predict what will get upvoted
 
5:10 PM
@JosephWright In the dark alley, I ran from questions. :)
 
@PauloCereda otherwise known as s@ri@l v@ting:-)
 
@DavidCarlisle That is of course not allowed
I'm reasonably sure that at some point I'll get to 150 days at 200 rep simply based on the fact that I get to the rep cap from time to time
 
@DavidCarlisle :)
 
@JosephWright of course. But anyway he's too busy with his thesis to vote too often
 
@JosephWright lalalalala can't hear you
I am a real duck, not a robot.
 
5:13 PM
@PauloCereda As you know, votes are for questions/answers not for the person posting them
 
@JosephWright exactly, but there's an indirect consequence to both question and answer. :)
 
5:31 PM
@PauloCereda remind me what do gitter and gitlab do that github doesn't (I think I get gitter mail because of something you set up but I don't recall using it)
 
@DavidCarlisle Gitter is the chat thingy. You are in the arara and L3 chatrooms. Gitlab is the former Gitorious website, which is basically a DIY version of GitHub.
 
@PauloCereda and should I concerned that they just joined up, if I haven't really used either
 
@DavidCarlisle no, do not worry. :)
 
@PauloCereda phew
 
@DavidCarlisle not my fault
@DavidCarlisle oh I see what you mean, I got the email.
@egreg: I watched a video talk by Michael Sipser, one of my favourite authors on formal languages (he's actually a mathematician), and he used Comic Sans in his entire talk. /sigh
 
5:41 PM
@PauloCereda Mike from Gitter?
 
@Johannes_B Yes, that bloody bastard.
 
@Johannes_B LOL
 
@PauloCereda I love Green Wing
 
@Johannes_B :)
 
5:55 PM
@PauloCereda AAAAAAARGH!
 
@egreg Very depressing, to say the least. :)
 
6:48 PM
Submitted my first primary author paper today. So I can stop bugging @JosephWright for a little while.
 
@Canageek Congrats, and good luck too! :)
 
@PauloCereda Thanks
11 pages for the main manuscript at 11 pt type, double column. 114 citations. 9 crystal structures.
 
7:13 PM
@Canageek 11 pages! that's ten times longer than @PauloCereda's thesis.
 
@DavidCarlisle oy
 
@PauloCereda I gave you the benefit of the doubt, I could have said eleven times longer
 
@DavidCarlisle <3
@DavidCarlisle That would be more accurate I'd rather not comment on such matters.
 
@Canageek :)
 
WHY ARE ENGLISHMEN SO TALL
 
7:26 PM
@PauloCereda Not everyone in the picture is that tall
 
@JosephWright ooh :)
 
@JosephWright if I want to use seasons in biblatex, do I need to specify them in the date or does it know January is in the winter based on localisation?
 
@PauloCereda being North of the equator helps
 
@DavidCarlisle Does \rotatebox help?
 
@PauloCereda anyway define tall (If you want to be English we need an answer in feet and inches)
 
7:30 PM
@DavidCarlisle oh no
@DavidCarlisle don't you even start, you guys use the metric system
Or @JosephWright's siunitx is a lie. :)
Metrication in the United Kingdom is the process of introducing the metric system of measurement in place of imperial units in the United Kingdom. Metrication in the United Kingdom remains equivocal and varies by context. Most of government, industry and commerce use metric units, but imperial units are officially used to specify journey distances, vehicle speeds and the sizes of returnable milk containers, beer and cider glasses (though fresh milk is often still sold in multiples of pints, with the metric equivalent also marked). Imperial units are also often used informally to describe bo...
Oh no
 
@StrongBad I think out-of-the-box you'd have to do it by hand
 
@PauloCereda metric system is for work no one knows their height in metres
 
@PauloCereda Ah, but Brexit is coming
 
@DavidCarlisle oh my
@JosephWright oh no
@DavidCarlisle And I don't know my height in feet and inches. :)
 
@DavidCarlisle I tried to learn my weight in stone, but people looked at me funny.
 
7:32 PM
@StrongBad ooh
 
@PauloCereda Was talking to a Canadian yesterday: forgot they use US units, so told him my weight in stone and pounds, and in kilograms, but he didn't know either: had to translate to pounds only (10st 7lb = 65 kg = 147 lb)
 
@JosephWright Oh my!
@DavidCarlisle: found it: I am 5ft 9in. :)
 
@PauloCereda taller than some in that picture I'd guess
 
@JosephWright so you use stone? The east midlands seemed to rely mostly on metric
 
@DavidCarlisle I am actually very short considering today's standards. :)
 
7:37 PM
@StrongBad May be my age, of course: I'm 39
 
@StrongBad for weights of people, almost everyone does.
 
@StrongBad sticks and stones can break heights... :)
 
@DavidCarlisle My PhD student (mid-20s from London) uses only metric
 
@JosephWright children, what do they know
@StrongBad which bit of the east midlands were you in?
 
@DavidCarlisle Skrilex oh
 
7:39 PM
@JosephWright how do you run context mkii? is it made by default in texlive?
 
I was in Nottingham. The unit I really miss is a proper pint. Not only is American beer crappy, there is so little of it.
 
@StrongBad The county of my birth:-)
 
@StrongBad ooh there was a sheriff in there
@DavidCarlisle o.O
 
@PauloCereda yes there was. I lived next door to the castle off of Maid Marian Way.
 
@DavidCarlisle texexec <name>
 
7:44 PM
aha I remember now:-)
 
@DavidCarlisle we had this discussion once. I thought you were from leicestershire.
 
@StrongBad nope born in Southwell, lived in Mansfield (15 miles North of Nottingham) from a few weeks old until I went to University
$ texexec file

resolvers       | trees | analyzing 'home:texmf'sh: ruby: command not found

mtxrun          |
mtxrun          | This script needs 'ruby' which seems not to be installed.
mtxrun          |
@JosephWright I'm sure it didn't require that when I last ran it ^^ :-)
 
@DavidCarlisle MkII has always needed Ruby in my time
 
@JosephWright hmm wikipedia says "Ruby was conceived on February 24, 1993. " I thought it was newer than that, perhaps I did have it back then
 
8:12 PM
@DavidCarlisle Will depend on the system you were using: I can use MkII here on my Mac without issue but not at work (at least not without installing Ruby)
 
8:22 PM
Also, if anyone knows the person that writes mhchem my group is in agreement that fixing it running into the margines and manually adding linebreaks is a problem. So if anyone wants to tell the maintainer to add automatic line breaking, or write an alternative that does, I'm pretty sure we'll love you forever
I should talk with the person who does chemformula about that
 
@Canageek Breaking formulas is a tricky one
 
@JosephWright That is what I thought, then someone pointed out that it isn't that hard if you use the brackets as a guide.
 
@JosephWright sunos I'd guess
 
@Canageek Perhaps: my experience is this is quite tricky (and some of the cases you see in the published literature are a bit ropey)
@DavidCarlisle Pass on Ruby there!
 
Hard Example: [nBu4N]2[(UO2)2(µ-η2:η2-O2)(NO3)2(µ-Au(CN)2)2]

But the most obvious break is obvious:
[nBu4N]2 [(UO2)2(µ-η2:η2-O2)(NO3)2(µ-Au(CN)2)2]

Then [nBu4N]2 [(UO2)2 (µ-η2:η2-O2) (NO3)2 (µ-Au(CN)2)2] right? All based on brackets
(I picked that as hard mode, since it is one of the most complex ones I've seen)
 
 
1 hour later…
9:28 PM
@JosephWright vvvvv ?
I'm not sure if we have a standard function in L3 to return the catcode of a token as a number... — David Carlisle 43 secs ago
 
@DavidCarlisle Indeed we don't: the plan has been I think to try to move toward symbolic stuff
 
@UlrikeFischer didn't like my use of latex3
 
@DavidCarlisle I'm hurt :-( I only tried to help. And I still don't understand why a catcode 12 char in the first argument of \tl_map_inline:nn has a different catcode in the body. It's unexpected ;-)
 
9:57 PM
@UlrikeFischer you are not looking at the catcode of the token at all. if you print out the\catcode`a and it says 11 it doesn't tell you that was a catcode 11 a, it tells you that if you parsed an a with the current settings you would get a catcode 11 token.
@UlrikeFischer because catcode`a is just another way of writing \catcode97 it does not inspect the token.
 
10:10 PM
@DavidCarlisle ah, you are right. I was somehow thinking that I look at the current concrete token.
 
10:26 PM
@egreg Enjoy your first set of minutes?
 
 
1 hour later…
11:41 PM
@JosephWright Not yet. Just came back he me after dinner with my high school mates
 

« first day (2327 days earlier)      last day (1296 days later) »