« first day (2822 days earlier)      last day (1218 days later) » 
00:00 - 20:0020:00 - 21:00

12:00 AM
When you get back from your smoke break I'll be doing laundry for a bit. But I have a question. The last bounty I lost I had upvoted the guy who won. Is that normal? In the current bounty where I'm Wayyyy behind in points I also upvoted the leader. Wonder if I'm just too generous with voting?: askubuntu.com/questions/1041674/… I actually think my answer is way simpler and better.
 
fab-root@fab-ux-predator:~
$ sudo apt install peek
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package peek
 
1. `sudo add-apt-repository ppa:peek-developers/stable`
2. `sudo apt-get update`
3. Then rinse, repeat :D
gotta grab laundry ... BRB
 
@WinEunuuchs2Unix One less vote for him, one more for you. Lemme add a comment too!
@WinEunuuchs2Unix I need to sleep!
2AM and meeting at 09:00
Good night! Drop by on a Friday-evening...
 
12:20 AM
0
Q: How can I list all files which will be installed by an APT package?

JayjayyyThis is similar to How can I generate a full listing of the files installed by a package? However, I haven't installed the package, yet. I wanted to list all files which will be installed by APT package xorg. In other words: all files which will be installed when I type apt install xorg. However...

 
 
4 hours later…
3:52 AM
@SergiyKolodyazhnyy If you can give me a start and an end message I'll see what I can do.
 
hm
Did that work?
.... did I just break the room?
 
Looks like it jg
but I don't see a message that explains what happened lol
 
I AM SO SORRY
 
oh I do after reloading.
 
ok looks better now
 
3:54 AM
@JourneymanGeek much better
merci
I'm still awarding nbounty tho
 
4 messages moved to Recycle Bin
not a problem
 
But probably I'll avoid the chat for a while
 
Cause I've been having one of those weeks, as @Seth might attest ;)
 
actually, I uh, haven't really been paying much attention to the site lately :(
got a lot of nastiness happening IRL right now
 
@Seth oh, not here XD
 
3:56 AM
oh ok lol
 
mostly out of band chat actually
+ I've been keeping a few non SU folk filled in on the matchmaking thing, and the related drama lol
 
@Seth Understandable. Sorry to ping you, just first Mod that came to mind. So ugh....maybe take it as compliment ?
 
have we had out of band communication? I know that seems like a silly question but I seriously have been forgetting things minutes after recently.
 
@SergiyKolodyazhnyy Never be afraid to ping me :)
 
3:57 AM
SU does. Some of our users are a wee bit uncomfortable with certain CM initiatives
and there's some stuff I'd rather not talk about on default public chat
 
ah. Yeah there's been a lot of stuff happening at SE lately. I've just been too distracted IRL to pay much attention. That and I usually am not a big fan so I kinda avoid it too if I'm already dealing with IRL garbage.
 
yup
The funny thing is, we're completely unaffected
We've always had an alt chat (first gitter, now we do matrix)
 
speaking of garbage, the new side panel on SO isn't my favorite feature
 
I like it actually
 
I don't like it much either.
 
4:01 AM
I actually think they should go further and throw a link to chat there
 
How's matrix though? Seems interesting.
 
Oh, I have a large screen
@Seth its a bit odd to set up, but once it is, works well
also.
Do. not. ever. join #matrix on the main server on your own homserver
@Seth architecture is cool. It works very well as a distributed chat system
 
@JourneymanGeek That's good to hear.
 
Its more of a nice swap for IRC or jabber tho
 
@JourneymanGeek Oh?
 
4:02 AM
@Seth default install uses a sql3 db
(and the migration script to postgres was borked)
if you connect to the channel, the scrollback and user numbers... kinda pegs a processor at 100% at the server for a few hours
Its better with postgres, and if you're running a server, its a better idea
 
4:26 AM
@JourneymanGeek That's not surprising considering sql3, as you said.
 
Err sqlite3
 
right. I knew what you meant :)
 
4:47 AM
7 messages moved to Recycle Bin
There we are
 
 
2 hours later…
6:38 AM
Trick question: How do you use echo to print only “-n” followed by newline?
$ echo -- -n
-- -n
 
7:04 AM
@dessert echo '-n '
 
@Videonauth that’s cheating, there’s a space we don’t want!
 
:p
but it works
 
the solution is:
$ echo -ne -n\\n
-n
(or quoted in any other way of course)
I wonder why echo doesn’t recognise --
 
7:23 AM
Is it intentional that TLDP is so close to TLDR?
 
 
4 hours later…
10:54 AM
0
Q: Problems booting debootstrapped image (no DHCP network)

Chrisi'm having the problem getting a DHCP ip from the network on an ubuntu image i created with debootstrap. What I did: First i created a system using debootstrap sudo debootstrap --variant=minbase --arch=amd64 bionic /tmp/src Then I customize that system for my needs and create a squashfs file...

 
11:11 AM
0
Q: Why is there a call to `clear_console` in `~/.bash_logout`?

JayjayyyWhen I log in with the same user on tty1 and tty2 and start an X server session on tty1 - as soon as I log out of tty2, the X server session on tty1 crashes. This seems to be a known bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=834270 https://groups.google.com/forum/#!topic/linux.deb...

 
 
2 hours later…
1:10 PM
Ubuntu 16.04 ships with bash 4.3 while 18.04 comes with bash 4.4. I’m wondering, what did they change? Apparently a lot: tiswww.case.edu/php/chet/bash/NEWS
> Command and process substitutions now turn off the `-v' option when
executing, as other shells seem to do.
> All builtin commands recognize the `--help' option and print a usage
summary.
> Bash does not allow function names containing /' and =' to be exported.
> GLOBIGNORE, the pattern substitution word expansion, and programmable
completion match filtering now honor the value of the `nocasematch' option.
> Executing the rhs of && and || will no longer cause the shell to fork if
it's not necessary.
> The `local' builtin takes a new argument: `-', which will cause it to save
and the single-letter shell options and restore their previous values at
function return.
and the list goes on and on, didn’t even get to “New Features in Readline” yet…
 
1:44 PM
1
Q: Open multiple instances of a given application

AtralbI am using Ubuntu (Ubuntu 16.04.4 LTS 64-bit) with the Gnome desktop environment. I am new to the OS (2 months). My issue is that in the Activities menu, when searching for and selecting a software, if an instance of that software is already open, clicking on it won't open a new instance (new wi...

 
 
1 hour later…
3:01 PM
@Fabby well that's just a side effect of my brand of 'crazy' :)
 
3:55 PM
@dessert trick answer: you don't echo, and use printf instead :p
 
@SergiyKolodyazhnyy I just knew you would say that! :D
still I don’t get why echo makes it so difficult, it would be so simple if it would just recognise --
 
@dessert I don't think it's echo, but the POSIX specs. Or th But I do agree that -- would be a nice addition.
ok, I'll just send message without finishing editing, that's fine, too
 
@SergiyKolodyazhnyy I hope you got well after yesterday? ;P
Did you raise this bounty intentionally? Either way I greatly revised my answer there, just in case.
 
@dessert Currently alright, having coffee. Couldn't fall asleep for long time though, because of headache and lowerback.
@dessert Em....that was done while I was drunk, but it's 100% serious. I'll get it awarded in 9 hours.
 
4:16 PM
that would really boost my reputation earned through bounties :)
 
5:10 PM
anyone interested in a steam key for 'shadowrun returns deluxe'?
@seth @NathanOsman ^
got it for free on humble bundle but it seems i already have this version
just in case i get this key quit before you guys are able to respond
 
@Videonauth I don't think that's something I would play, but thank you for offering :)
 
well its a game which runs natively on linux :)
i just was not thinking far enough and claimed a key and realized then that i already have it
 
That's nice! I'm glad more developers are writing for Linux now. Steam really helped that out,
 
0
Q: 'ip route show' showing network interface linkdown and not getting dhcp ip on the kvm guest machine

MukundaI am having this issues for long time, I am not able to fix this issues. Would someone please help me to resolve this network problem. I have two different network vendors NIC is attached with the kvm host, management port is getting dhcp ip but SmartNIC interface nfp_p0 and nfp_p1 showing linkd...

 
5:50 PM
@Seth yes indeed, even major titles meanwhile
like deus ex mankind divided and rise of the tomb raider and tomb raider 2013, mad max etc etc
 
6:42 PM
0
Q: git and ssh-over-fuse not working anymore

Jhon BYakaI have few repos that i use from remote machine over ssh. Last time i used them in prev year and all works flawlessly. But today when i'm try - i got errors fatal: write error: Operation not supported fatal: index-pack failed Destination dir connected via Nemo through gvfsd-fuse (path looks li...

 
6:53 PM
Hi I need help with lsb on Ubuntu 18.04
I need version 3.0. Can't be newer.
 
7:06 PM
do you mean the linux standard base support package lsb, @ArtfulAardvark?
yeah 3.0 is beyond old, and you can't get it to function on 18.04
because LSB is no longer supported anywhere in later Ubuntu(s)
why do you need LSB 3.0? Or are you talking about another LSB?
 
@ThomasWard it's because my college requires 3.0 for the internet
Newer versions won't work
 
then your college is doing it wrong
 
They have little Linux support
 
what in god's good earth could they be running that needs Linux Standard Base support from a 2.x series kernel timeline
 
I could try 4.0 from the 12.04 repos
 
7:11 PM
I'm confused
 
@ArtfulAardvark you'll break a lot with that
 
why would you need LSB to connect to the internet?
 
@TheWanderer you don't
 
TIL what LSB stands for :)
 
For signing into the network
 
7:11 PM
do they have some sort of binary to log in?
 
They give a binary
 
they're idiotic then
 
and should be shot (figuratively)
 
7:12 PM
do you really need LSB to run a binary?
 
@TheWanderer to install maybe
 
Well theirs yeah
 
not to run
 
have you tried it @ArtfulAardvark?
 
I tried the bionic version
 
7:12 PM
@ArtfulAardvark then they're doing it wrong, and that application won't work. Try running it without lsb
 
how old is this software? oO
 
@ArtfulAardvark LSB support was yanked in 17.10
 
I did
Won't let me
 
@dessert 2006ish if LSB is a specific age
@ArtfulAardvark ask them what type of network authentication is in use
 
error?
 
7:13 PM
if i'ts WPA2 enterprise then they're idiots, you can configure that in standard network manager
without LSB
 
do you have a copy of this binary you could share?
 
Ethernet
 
802.1X is a thing too
and that can be done in network manager too.
if they're using some other authentication mechansim
then you're Out Of Luck because LSB doesn't work in later Ubuntus
 
is there any other way to do it besides a VPN?
 
Error the keyboard is Glitching on stack exchange I can't see what I'm typing
 
7:14 PM
in fact all that LSB has since Artful IIRC is lsb_release which is just a toolkit to get the current release.
 
@ArtfulAardvark meta.stackexchange.com
 
I meant rrrrr
Ughhh frustrating
Lemme try the wifi with a USB adapter
 
give us the binary
 
0
Q: To run tomcat application in apache2 server using ssl

Jitendra PatwaI have a apache2 configure ubuntu server which is running html code and running fine in the browser. On the same server I configured apache tomcat server to run Java restapi application on PORT 8080, and also it was running well in the HTTP on PORT 80. But when I added ssl files to apache2 conf f...

 
@ThomasWard strangely, if I do apt install lsb in 18.04 it wants me to install alien, rpm and ncurses as well
so it does exist
 
7:16 PM
@TheWanderer i know it exists, I didn't say it worked properly :P
lsb is old.
 
@TheWanderer did you see discord messages :) ?
 
The wifi auth uses the same .bin
 
yeah @Videonauth
@ArtfulAardvark give us the damn bin lol
 
cool :)
 
7:17 PM
@ArtfulAardvark upload the binary somewhere
share the link
since you're not actually giving us the error code, we'll have to get it ourselves
 
Ok 1 sec
Signing into desktop with mobile Hotspot
hihi
uploading bin
also i'm going to copy what the directions say on the site: it says lsb 3.0 compatible
Linux
Downloading

Download and Save the Agent

Enter your user name, password, and any other required information. Then click Download or Continue.
You are prompted to save the agent. Save the agent to a place on your computer that is easy to locate.

Installing/Running

To use the Dissolvable Agent on a Linux OS, you must first change the Permissions on the Dissolvable Agent, then run it. The Dissolvable Agent only supports a Linux OS if it is LSB 3.0 compliant. If your OS is not LSB 3.0 compliant, the Agent alerts you. The following explains the registration process:
 
LSB 3.0 compatible doesn't necessarily mean that it needs to be LSB 3.0
the Linux OS bits it identifies doesn't mean it's after 3.0 of the LSB binary, it could be checking Kernel-level things
 
ohh ok. well the version of lsb from the repos didnt work.
 
and if it's stuck at 3.0 compatibility we're actually talking obscenely old LSB and LInux, because 2006 was, what, some really really REALLY ancient kernel version
also, instead of copying the directions is there a reason you can't share us the link to the site?
 
No LSB modules are available.
Bradford_Dissolvable_Agent.bin :: LSB 3.0 or higher not found. Please install the appropriate LSB packages.
Gtk-Message: 15:22:56.598: GtkDialog mapped without a transient parent. This is discouraged.
@ThomasWard you need to be on the actual network to download
 
7:24 PM
it's looking for LSB Modules
 
@ThomasWard @TheWanderer
 
those would be in the Kernel, and there's no LSB in the Ubuntu core system bits since... oh god as long as I've been using it.
 
that's the .bin file.
@ThomasWard so what do u think I should do?
 
LOL this is a shell script!
opens in a text editor and dissects
 
sure.
i thought .bin was binary
 
7:26 PM
extensions mean jack squat in Linux :P
 
lolol gotcha :P
 
@ArtfulAardvark try this
 
i can have a Linux executable with a .jpg extension that you can execute on the command line and it'll do things.
 
connect to the network
 
7:26 PM
ewww
 
thewanderer if i connect right now i'll have no internet and will be disconnected from here
 
set your DNS to 8.8.8.8
 
@TheWanderer they have the binary in ASCII mode
 
i'm on mobile hotspot right now.
 
@ThomasWard what is this, 1980?
 
7:27 PM
how do I set dns?
 
it's in the network manager
 
@TheWanderer I know, it's stored as binarycode in the script.
 
ok. i'm on ubuntu MATE btw if that helps.
i called up the help desk and they dont support linux -_- lol
 
wow Gedit does NOT like that encoding @ThomasWard
 
no it doesn't.
I'm using nano and vim which don't care lol
 
7:28 PM
it won't even display a window
 
@ArtfulAardvark give me one moment, I might have an altered version you can attempt.
 
I'm using Kate now
 
k.
@thom
oops
@ThomasWard cool :P
 
the hell is Mozilla Seamonkey?
@art first three chars will ping
 
@TheWanderer the best browser =)
 
7:29 PM
lemme grab my laptop and put it to the stackexchange chat
@The rly? lol
 
@ArtfulAardvark i'll give you a link you can use to download this
 
wait, this is a binary
with a script
wtf
 
3 mins ago, by Thomas Ward
@TheWanderer I know, it's stored as binarycode in the script.
 
@TheWanderer it's actually a script with Binary-embedded data
 
same thing
 
7:31 PM
SeaMonkey is a free and open-source Internet suite. It is the continuation of the former Mozilla Application Suite, based on the same source code, which itself grew out of Netscape Communicator and formed the base of Netscape 6 and Netscape 7. SeaMonkey was created in 2005 after the Mozilla Foundation decided to focus on standalone projects such as Firefox and Thunderbird. The development of SeaMonkey is community-driven, in contrast to the Mozilla Application Suite, which until its last released version (1.7.13) was governed by the Mozilla Foundation. The new project-leading group is called the...
 
I can't even properly open it with ASCII
 
FOSS and beautiful, I used it for years :>
 
0
Q: Wine 1.5.5 SAI crashes in PlayOnLinux

AngeryLinuxUserUbuntu 18.04, 32-bit architecture I was trying to install an app (Paint Tool Sai) through PlayOnLinux, but Wine crashes each time I try to run it. Here's what the debugger writes: Running wine-1.5.5-SAI sai.exe (Working directory : /home/alika/.PlayOnLinux/wineprefix/PaintToolSai/drive_c/Paint...

 
@dessert so this script was made in 2005
 
i basically just commented out where it goes into its error message bits
and left the rest alone
 
7:33 PM
1 sec switching comps
 
@ThomasWard yeah, still a .binary ;)
 
gottdammit
its trying to give me norton antivirus on the windows oml lol
 
@dessert well that's what the MIMEType says
 
I'm setting it up on my windows 10 then i'll try the script.
 
kruzifixnocheins
 
7:35 PM
@ArtfulAardvark you should really just try switching your DNS first
 
if you go into CLI and do file path then blah
@ArtfulAardvark uhm
@ArtfulAardvark what do you mean by 'setting it up on my windows 10'
and what does Windows 10 have anything to do with this?
 
the college wifi
so i can connect to stackexchange chat there.
 
i'm confused
 
XY?
 
i'm on mobile hotspot rn on my desktop that runs linux.
 
7:36 PM
@ArtfulAardvark this is a tiny file you can download it via your mobile hotspot
 
$ ls -alh
total 1.7M
drwxrwsr-x 2 teward www-data 4.0K Jun 21 19:32 .
drwxrws--- 7 teward www-data 4.0K Jun 21 19:32 ..
-rw-rw-r-- 1 teward www-data 1.7M Jun 21 19:32 Bradford_Dissolvable_Agent.bin
 
i downloaded
 
ahhh i see
i can't read, and you aren't being clear ;)
also i'm tired so blah
 
@ArtfulAardvark nm-connection-editor
click whatever connection you're using, click the Settings gear
go to IPv4 Settings
change the Method to DHCP Addresses Only
put 8.8.8.8 in the DNS
 
7:38 PM
oops script error
 
here
ok i'm trying in a sec.
 
@ThomasWard you're a script error
 
@ArtfulAardvark hang on a moment with my script
i need to fix it
 
@ThomasWard ik
i was just going to say that lol
the syntax error "fi" unexpected
 
try what I said in the meantime
 
7:40 PM
do what TheWanderer suggested
 
and see what happens
while I fix things
thomas-ward.net/data/… - there I renamed it slightly too :P
 
how do i get to my network manager? i was on edit connections
@TheWanderer
 
follow what I said
 
7:44 PM
oops i made another error
 
@TheWanderer under additional dns servers?
i'm in the "editing wired connection 1"
 
you need to change the method to DHCP Addresses Only, like I said
and then add it under the DNS field
 
ok @TheWanderer done
now try to browse the web?
 
yep
 
@TheWanderer still requires network login
 
7:47 PM
alright
 
@ThomasWard still working on it?
 
yeah but debugging it
the way they wrote this script makes it unusable
 
ok.
thanks
I appreciate it
 
@ThomasWard can't you just run the binary?
it looks like all the script does is check for LSB and set the default browser
 
@TheWanderer need it to write the binary first
the script also dumps the code to the binary file
 
7:51 PM
wat
ew
why
 
EWWWWWWWWWWW the binary is a SysVInit that requires LSB to run. AND it's a 32-bit executable with dynamic links.
whoever wrote this needs to die.
@ArtfulAardvark sorry to say that I don't think you can get this working on 18.04
 
hmmmmm
 
or any Ubuntu or Linux actually
because NOTHING uses LSB 3.0
and no modern OS uses LSB modules
 
wow
hmm :/ that's fun
 
which means again whoever wrote this wrote it so ancient and obsolete
 
7:56 PM
wow
:/
you think there's any getarounds to get it to work?
 
@ArtfulAardvark zero.
 
@ThomasWard they have an EXE for windows systems
the .bin is what they hand Linux users.
 
@ArtfulAardvark EXE for Windows.
that doesn't help
because that won't run properly in Wine either so it won't solve the problem.
 
ik
well yeah
 
zero solutions.
 
7:58 PM
:/
that's sad
 
00:00 - 20:0020:00 - 21:00

« first day (2822 days earlier)      last day (1218 days later) »