« first day (2359 days earlier)      last day (952 days later) » 

Aw, beat me to it :P
 
So I just tried the AIDE app, and wow, it's horrible!. Constant pop-ups asking you to pay $10 for the full version, it won't even let you save files unless you pay! Immediate uninstall.
Know any decent IDE apps for Android @NathanOsman?
 
Android Studio is what I use.
 
Right, that's what I use on my desktop, but I mean an actual Android application that's an IDE
 
@AskUbuntuMeta Wow. RIP 12.04.
 
2:07 AM
On another note as 12.04 enters EOL, 17.04 enters BOL
 
@AndroidDev The only one I've ever tried is the one you just mentioned.
 
@NathanOsman I'm guessing you had a similarly bad experience?
 
It was just too awkward.
If Java brings my desktop to its knees, think of what it will do to my poor phone.
...on a screen one-eighth the size.
 
@NathanOsman do you know how to use Inkscape?
 
@Zacharee1 A little bit.
 
2:09 AM
do you know how to import paths?
 
Import? From where?
 
@NathanOsman What's funny though is that phones nowadays have QHD resolution and my 23" monitor is only 1080p
 
clipboard maybe
 
@AndroidDev Yes, that is a bit ironic. And my phone does have 6 GB of RAM...
 
I just need something that will subtract one path from another
so I get a path-shaped "hole"
 
2:11 AM
@Zacharee1 Select first path, hold , select second, +
 
how do I add paths though?
 
Where are the paths?
 
I manually edited an SVG with the path I wanted, but it'd be nice not to have to do that
in plain text inside Android XML vectors
 
Oh... that.
Android vector images aren't the same as SVGs, I don't think.
 
no but the path data is
I was able to import one path
by pasting the path data into an SVG
 
2:12 AM
Ah, can't you just open the SVG in Inkscape then?
 
but there has to be a way to paste one in in the XML editor
 
@NathanOsman You know, it's really sad how many good quality free apps there are on the play store. If you want a good, free app without ads, I guess you just have to make it yourself :(
 
@Zacharee1 I haven't used that, unfortunately.
 
blegh
 
@AndroidDev I've made a couple :D
 
2:14 AM
how do I 1:1 resize at least?
 
@Zacharee1 ...and I don't know that either :(
I don't use Inkscape that much.
 
this program is worse than GIMP
 
Hey, Gimp isn't so bad. I wrote part of it.
 
It's good, but it's complex
I have no idea how to do the simplest thing in Inkscape at all
 
If you ever figure out how the "snap to..." functions work, let me know :P
 
2:16 AM
lol
 
@NathanOsman You have a lot of people complaining that there aren't any camera settings for ChronoSnap :)
 
shift isn't selecting them both
 
@AndroidDev Yeah, it's one of those things I've been meaning to get to but haven't had the time yet.
 
@NathanOsman Is it open source? Maybe I could make a few commits :)
 
2:19 AM
@AndroidDev What are the pixel dimensions for QHD?
 
2560x1440
@NathanOsman do you at least know how to center one layer on another?
 
Gah! @Zacharee1 Beat me to it!
 
@Zacharee1 That, I do know
 
oh good
you're useful after all :p
 
2560x1440 has been out for a few years rigth? It's 4 k that's supposed to be the next covettied thing
 
2:20 AM
Lol!
 
@Zacharee1 + + opens the page you need.
 
@AskUbuntuMeta rip
@NathanOsman danke
wtf is this
 
@Zacharee1 Now it depends if you want them centered relative to each other, the page, the selection, etc.
 
each other
 
So change "relative to" to "last selected" or "first selected".
 
2:21 AM
hey, it works!
the path thing is still not working though
 
^-- then click these two
 
yup
centered and such
 
Great.
 
just this subtract isn't working
 
Yeah, that one is hard to use.
Couple of quick checks... are they both paths?
 
2:23 AM
yes, but in separate layers
 
Oh. Layers.
Don't know if that makes a difference...
 
well it doesn't work
and if I put them under the same layer, I can't see the second path
why couldn't LG just have made this vector one path in the first place?
well, these vectors
I have to edit like 8
 
@NathanOsman Huh, maybe I'll downlaod it and poke around. Methinks it needs a bit UI eye candy :)
 
@AndroidDev I agree :D
@AndroidDev I also have an Android app for NitroShare but it's in private alpha at the moment.
It too will be ad-free and open source.
 
@NathanOsman I can't find where you define the capture resolution: github.com/nathan-osman/chronosnap/blob/master/app/src/main/…
 
2:30 AM
@AndroidDev I don't think it does.
It just uses the default.
Hence the problem :D
 
@NathanOsman Oh, uhhh, okay then :D
 
why is the bigger path hiding the smaller one, no matter where it goes?
 
Try selecting them in a different order.
 
no I can't even see the smaller path in the first place
I tried putting them in the same layer
it just disappears on screen
 
@NathanOsman Hmm, well I think the first thing to do is have a live preview of the camera
 
2:40 AM
I agree.
 
OK I re-imported the paths
now they're right next to each other
but I can't subtract
omg
it worked!
 
o_O
yet it doesn't seem to have
it's just a solid color in Android
oh derp
 
Want me to take back the happy guy?
 
I guess it'd help to actually paste the path data....
uhhhhh
why is it so big
 
2:52 AM
hi
 
hi
did you get your snow day?
 
@WinEunuuchs2Unix hell no...I got 3 out of my four building with no internet service for 2 days though!
 
that's a drag
 
@TheXed someone tripped over a wire again? :D
 
YESSSSS
IT WORKS
WOOOOO
 
2:55 AM
I already pasted the happy guy.
Sorry, you don't get him twice.
 
darn
now my day is ruined
RUINED
SOB
 
Let me see what else I have.
 
it's 11PM, shut up :p
 
@NathanOsman actually it was basically the western side of Illinois...
 
How's that?
 
2:57 AM
old Donald Duck is creepy
there appears to be some sort of innuendo there...
 
Easter is coming...
And before I forget, Happy Pi Day everyone.
 
hue
my cat is being weird
and in other news, it's winter
oh no....
<path android:fillColor="#ffffffff" android:pathData="M31,31m-31,0a31,31 0,1 1,62 0a31,31 0,1 1,-62 0" />
    <path android:fillColor="#ff000000" android:pathData="M49,35.5l0,2l-2,-0.4l0,-2z" />
    <path android:fillColor="#ff000000" android:pathData="M49,33.4l0,2.1l-2,-0.4l0,-2.6z" />
    <path android:fillColor="#ff000000" android:pathData="M49,31.5l0,1.9l-2,-0.9l0,-1z" />
    <path android:fillColor="#ff000000" android:pathData="M49,31.4l0,0.1l-2,0l0,1l-13,-5.7l0,-0.1l2,0l0,-1z" />
    <path android:fillColor="#ff000000" android:pathData="M49,37.5l-14,-2.7l0,-2l12,2.3l0,2z" />
why did LG do that?
the first three are the same line...
and using Union, those 2billion paths turn into 1...
2 down, 4 to go
@Zanna? o_O
oh thank god
this one is only two paths
methinks the LG designers got lazy
 
3:29 AM
Could be...
 
well most of these toggles are two paths: background and shape
the rest are, well you saw my paste
there are about 5 paths in there just to draw squares
alright
vectors modified
now it's time to do some Java and Smali
yay...
@KazWolfe how do I define a base16 integer in Java?
or do I just write the decimal equivalent of 0xff?
oh wait
this is using a text input...
 
The 0x00 syntax works for hexadecimal numbers.
 
so I can do int test = 0xff?
and that would be equal to const/16 v1, 0xff
 
@Zacharee1 yes.
 
MJB
Hi all, i was looking at my answer to a question, but i'm getting a different result than people who've tested it. It involves altering 1 line in .zshrc. I think there might be differences per distro. Could anyone help me test? askubuntu.com/a/23631/9656
 
3:36 AM
That will be equal to decimal value 255.
 
thanks
that's what I need
this function takes in the values separate, which makes sense
but that means I need to make three Settings keys
 
3:51 AM
@MJB Do I put both commands in .zshrc?
 
MJB
@luk3yx Yes, if you don't have it allready, pls add the inc_append_history and share_history.
 
can someone buy me another GPU?
 
MJB
The way I tested it: Open a few screens (screen/dvtm/tmux) 'echo "testting screen 1" ' at every open session. Every teststring should be visible at every other session.
 
MJB
I've only tested Debian stable and Arch.
 
3:56 AM
@NathanOsman perfect
blegh
why is QuickTools so unstable?
 
@MJB I did echo "testing screen 1" on one screen, however history doesn't show it on the others.
 
MJB
@luk3yx, what distro are you running?
 
@MJB Ubuntu MATE 16.04 LTS 64-bit.
 
"Invalid reg index of 8" wat
 
MJB
@luk3yx, could you give me a zsh version? Also, what did you use to open different terminals?
 
4:04 AM
I tried both the normal terminal emulator and byobu-tmux.
I am using zsh 5.1.1 (x86_64-ubuntu-linux-gnu)
 
MJB
@luk3yx, thanks, i'll be trying that in a WM.
 
@MJB Okay.
 
MJB
@luk3yx, oops, meant VM.
 
@MJB You can edit posts.
If I upvote this question, would it seem as if I support 12.04's EOL?
 
MJB
@luk3yx I know, i'd like to add which distro's or version's zsh support which settings (if that makes any sense).
 
4:13 AM
What is the Raiders of the Lost Downboat room for?
 
@Zacharee1 not really no
 
wat
 
Not really here
 
@luk3yx It's the abandoned questions cleanup.
 
4:28 AM
@NathanOsman is 0x255 technically valid?
 
Well, yes, but it isn't decimal value 255.
It's decimal value 597.
 
shoot
eh, I'll just use an if statement
 
If you want 255, just put 255 :P
The 0x prefix signifies a hexadecimal number.
@KazWolfe JUST THE PERSON I WAS LOOKING FOR.
Do you know if there's a method for retrieving the rooms a user is in?
 
well I want to account for inputs of both 00-ff and 0-255
 
@Zacharee1 What is "23"?
 
4:37 AM
?
 
On phone. One sec.
 
It's both a valid hexadecimal number and a valid decimal number.
 
ok
 
So how can you know which one was intended?
 
New shirt has correct spelling.
 
4:38 AM
\o/
 
@NathanOsman idk
I'll just accept hex
 
You could write that hex numbers must be prefixed by 0x.
Then it would be unambiguous.
 
That's what I was thinking
 
@Seth, the front --^
 
Gradle is so finicky in build time
sometimes it's half a second
sometimes it's 5 minutes
 
4:43 AM
@NathanOsman, https://chat.stackexchange.com/users/thumbs/1345.
Check the rooms element
>>> json.loads(requests.get("https://chat.stackexchange.com/users/thumbs/1345").text)['rooms']
[{'name': 'Room for Nathan Osman and RPi Awesomeness', 'id': 49120, 'activity': 471, 'last_post': 1488944602}, {'name': 'Ask Ubuntu General Room', 'id': 201, 'activity': 100137, 'last_post': 1489552740}, {'name': 'Sandbox', 'id': 1, 'activity': 1648, 'last_post': 1489552534}]
 
> java.lang.NumberFormatException: For input string: "android.support.design.widget.TextInputLayout{a67d1d3 V.ED..... ........ 0,0-446,179 #7f0e00af app:id/red_qt_val}"
wat
 
@Zacharee1 that does not look like a number.
 
I guess this doesn't work: int red = Integer.parseInt(redString);
 
i think you need to get the integer from redString which i assume is a textbox
 
oh shoot
DERPDERPDERP
maybe I should go to bed
I know what I did
I am King Derp
bow to me
 
4:51 AM
@KazWolfe thanks!
 
@NathanOsman You are not to bang your head against desk.
 
[ SmokeDetector | MS ] Bad keyword in body, blacklisted website in body, blacklisted website in title, link at end of body, pattern-matching website in body, +1 more: www.supplementoffers.org/nuvella/ by summercoat on askubuntu.com
 
@NathanOsman Integer.parseInt() isn't happy with 0x00
 
31
Q: How to convert a hexadecimal string to long in java?

user405398I want to convert a hex string to long in java. I have tried with general conversion. String s = "4d0d08ada45f9dde1e99cad9"; long l = Long.valueOf(s).longValue(); System.out.println(l); String ls = Long.toString(l); But I am getting this error message: java.lang.NumberFormatException: For i...

@Zacharee1 ---^
 
eyy
Integer.decode worked!
 
4:56 AM
@KazWolfe sweet!
 
yeah, they fixed it but the data is still old
(number of people)
 
They really require a lot of server stuff that I don't have right now though so I won't be finishing it. After a basic IP/domain then you need an SMTP server.. as you know.
 
who knows, you might get a newer shirt with updated data
do you want an ipv6 box to play around with?
 
On second thought.. @NathanOsman would hectane work on IPv6?
I've got $150 AWS credit.. I just need a cheap credit card that won't kill me if something happens
 
you can use python's http.server for web
 
4:59 AM
Not really looking forward to configuring postfix or similar though
 
yeah, i understand lol
i'm not sure why hectane wouldn't work on ipv6
 
@KazWolfe me either
@KazWolfe O_O
 
0
Q: Where should I ask questions on x3270 emulator(z/Os)?

laminoThis is a topic that you don't see often. I want to know where it is appropriate to ask questions regarding this topic, since it's not Linux-related. However, I'm running the emulator on Ubuntu and would want to copy my remote files over, which I don't know how to do. Where do I have a better c...

 
I feel so accomplished lol
maybe it's because it's 1AM
 
 
1 hour later…
6:11 AM
@Seth I think so?
I'm not at all 100% sure on that.
I can't come up with any reason why it wouldn't work.
@Seth You can also set alerts on AWS if your bill goes higher than a certain amount.
 
6:23 AM
In fact, I think you can set alerts on DO as well.
 
6:52 AM
1
Q: How to share screen between Centos 7 and Ubuntu 14?

dev ツI am using Remina Remote Desktop Client to share screen between ubuntu machines. But I did not find Remina in centos.

 
7:10 AM
Poor answer, link in username askubuntu.com/a/893179/295286
 
I just downvoted and deleted voted - not sure it's flaggable
 
> "The patent on S3 Texture Compression expires on October 2, 2017."
\o/
Seven more months to go.
As for MP3, December 31, 2017.
 
7:27 AM
WHY oh WHY keep people tagging cli questions version specific...
 
7:47 AM
because they don't know any better :)
 
So I get this back from one of the chat URLs:
{
    id: 201,
    name: "Ask Ubuntu General Room",
    last_post: 1489562799,
    activity: 100149
}
Anybody have any guesses what the activity field is for?
 
fun stuff?
 
¯\_(ツ)_/¯
 
@Zanna yeah, that must be it of course.
 
@NathanOsman looks like the number of messages you have in this chat
 
8:02 AM
@JacobVlijm sorry, crappy non-answer, downvote
 
Haha, yeah, it's an answer.
 
8:13 AM
I feel the same and enjoy moaning about it, I knew it was not a question asking for an answer haha
how can I copy a file from /foo to /bar in 14.04?
 
or in 14.08? :)
 
what actually gets my goat is when people add the entire output of lsb_release -a and uname -a to their post
I know I am just really grumpy
but the redundancy hurts my eyes
 
:)
Yeah. I was just decompressing for removing the n-th useless version tag.
 
8:30 AM
good job ^_^
I can't access these images :/ askubuntu.com/questions/235863/…
 
Me neither. dead links...
 
8:45 AM
even on wayback... on the homepage I get 403
 
9:07 AM
Does stock Android have screen-off gestures?
 
9:27 AM
0
Q: Extremely high memory usage Android studio and emulator

Marius KaunietisAfter upgrading Android Studio to 2.3, I've encountered extremely high memory usage. Previously, I would keep my pc(including Android studio and emulator) on for several weeks, and RAM usage would stay below 12GB. However, after upgrading to 2.3, it takes about 6 hours of work until system runs o...

 
 
1 hour later…
10:37 AM
@NathanOsman dont think so :P
 
Hello :)
@Thijser Good morning ! :) I checked your bug report and saw that nobody confirmed the bug so far ... did the other users you mentioned yesterday forget to do it ? They should do it soon, because otherwise the developers won't start looking into it. :)
 
1
Q: How to install package with -t option from ppa

BahamutI'am running ubuntu xenial in virtualbox. I bound some PPAs in my System with apt-pinning. An Example cat /etc/apt/preferences.d/xbmc # Apt-pinning für ppa:xbmc Package: * Pin: origin ppa.launchpad.net Pin-Priority: 50 How can I install kodi with apt install -t something kodi LANG=C ap...

 
11:09 AM
@jokerdino genius ^_^
I am going to edit that when I get back. Thank you!
 
What is the Ubuntu Server's default firewall?
iptables?
 
I think ufw
 
12:00 PM
Can't believe. AU pulled this answer for a VLQ review audit. Um, yeah.
 
12:28 PM
Hi. Anyone has any idea why is this - use nvidia-prime to select igpu over dgpu from config-prime-select-intel-all - selected in Adittional drivers. Or even what it is?
 
12:45 PM
@anonymous2 I can! it is a post by @terdon :=D
 
@Rinzwind Yes, that was like the second thing I noticed about it. First thing I noticed was its length. Then I started reading and thought, "This has got to be a review audit, there's nothing else it could be.
 
see http://askubuntu.com/a/661924/15811 for instance
You need to start a program and select it
@anonymous2 post by Terdon are always suspicious. He isn't a Ubuntu user :=D
 
@Rinzwind Serious?
 
lol
 
He must at least be a Linux or at very least a Unix user?
 
12:48 PM
he uses debian or arch
 
@Rinzwind Ah.
 
yeah he is an U+L mod :D
 
@Rinzwind Yeah, I know.
Double mod-ship.
Not as bad as Rory Alsop.
He's got 7 diamonds beside his name.
 
:D
that's a lot
 
@Rinzwind Admittedly, some of them are on beta sites, which generally take less work, but still... a fellow has to sleep sometime.
 
1:21 PM
oli
 
... aint here :=)
 
Rinzy ! :)
 
Boxy!
we also have an Anony! today :=D
 
@Rinzwind what is that ? :D
 
see 7 lines above this oen
 
1:24 PM
aha ... hahaha
 
bbl. vpn kills internet
 
@saveit You invited me to another room ... I'm there ! :)
@saveit If you don't post something, there won't be a conversation ! :)
@saveit Okay, I left the other room, when you want something from me - just ping me ! :)
 
1:56 PM
Hi I need help in spark mapr streaming
Can any one help me in this
 
2:32 PM
@Zacharee1 Thanks for the recommendation! With some equalizing they're good given the relatively low price. They also block out external noise quite well. I still prefer my Samson SR850 over-ear headphones even though they're far bulkier.
 
you got em?
 
I like them too
they do better than the $150 B&0 earbuds I got with my phone (for free)
 
Is Brainwavz one of those brands that copy popular name-brand headphone models to make much cheaper no-frills versions of them with roughly the same audio quality?
That's what Samson does to AKG.
 
@DavidFoerster yup
they do a apparently very good clone of the old version of my favourite headphones ever
(Fisher audio FA003)
 
2:39 PM
The headband of the Samson version is made of on of the cheapest suitable plastic materials I've seen for this kind of stuff (compared to (faux) leather), but as long as I retain a think layer of hair between it and my scalp I don't care.^^
 
The velour on the ear cushions is actually not that bad even though it could be much better. Apparently they're compatible with AKG's cushions which are relatively cheap as replacement parts.
 
( fischeraudio.com/shop/fa-003-ti is the newer model, and essentially, you can, in theory swap out any of the parts on rhe m5 or the old fa003 with the new model
 
I should really get around to reinstall the dedicated sound card that I have lying around since I rediscovered it in my supplies box over a year ago…
 

« first day (2359 days earlier)      last day (952 days later) »