« first day (2627 days earlier)      last day (1284 days later) » 

12:04 AM
Smali has an IntelliJ plugin
12:58 AM
^--- I made a thing
I call this piece of art "Coke Zero gets spilled".
Don't forget to subscribe to m— oh oops, wrong site
1:22 AM
@NathanOsman I like it! The name is good.
1:39 AM
Q: How to make Linux safer (spoof)?

SuperChargedHoeHow do I make the latest version of linux, Ububtu 16 temporary? meaning I want everything to be changed on each reboot (hardware ID, HDD ID, mac address local ip address, etc). I am okay with booting from a USB, without installing the OS. Maybe If I "try" linux, without installing it, it would ch...

1:54 AM
Q: Struggling with always restart the networking

J.DoeFor the moment, each time I restart my computer and login, I need to run sudo su echo -e "nameserver\nnameserver" > /etc/resolv.conf service networking restart To make a long story short, yesterday my internet connection worked perfectly fine. This morning I wasn't able to loa...

4 hours later…
5:40 AM
Q: MediaTek USB wireless network interface card not being recognised by Ubuntu Server

Jacob CollinsI bought this wireless network interface card for my new Ubuntu powered server, and it works fine with by Windows 10 laptop. However, It isn't being picked up as a wireless interface card on my Ubuntu server. Here is the output of sudo dmesg, after plugging it in: [ 653.209304] usb 2-1.4: new...

2 hours later…
8:10 AM
Q: /var/log/auth.log permissions

IanPudneyI've noticed that unlike most logs, /var/log/auth.log isn't world-readable. What sensitive data is logged to auth.log that would make it have these more-restricted permissions? (I'm trying to determine if making it world-readable is safe). This is on Ubuntu 14.

8:24 AM
Q: sda:sda1 keeps showing up in dmesg

김승재dmesg logs is 'filled with' the following : [613051.997981] sdf: sdf1 [613052.068773] sdf: sdf1 [613352.060804] sdc: sdc1 [613653.176468] sdc: sdc1 This just continues on and on about every 300 seconds(only sdc and sdf is shown). Any reasons why this might be happening? It makes reading d...

Hey, it is possible to delete my message totally? please?
good morning
good morning
Benny there i no further action to be taken there, it is deleted and only high reputation members can see it, the mod's I think cant to more as that as well.
oh, ok, thanks
8:30 AM
and it can be seen by you obviously
if you for example want to see all your posts who got deleted over the time you can use "deleted:1" in the Ask Ubuntu search. but this will only show you your own deleted posts.
searched for:
give me
640,366 results
lol , i have only 2 or 3 deleted messages
but if i search like this:
user:538619 deleted:1
it's good, thanks for this information :D
9:21 AM
Hey guys any chance someone can help me with apache timeout error on ubuntu here?
output of journalctl -xe and service apache2 status ?
apache status running
only happens on ssl
is i restart it works
but stops after a minute
do you have the port open for ssl connections? (i.e. 443) ?
i think so as its been working for months
just stopped yesterday but we have lots of traffic
no apache log errors
when it stops can you take a journalctl -xe then
9:24 AM
must i run that in terminal?
before it crashes or only after?
well before it crashes it makes less sense or does it? would a crash or error be caught in a log before it happened? :)
ok my bad
here is the report
-- Subject: Session 148 has been terminated
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/multiseat
-- A session with the ID 148 has been terminated.
Dec 08 09:23:54 audimiddleeast.com do-agent[1440]: 2017/12/08 09:23:54 Checking for newer version of do-agent
Dec 08 09:23:55 audimiddleeast.com do-agent[1440]: 2017/12/08 09:23:55 No repository update available
Dec 08 09:25:40 audimiddleeast.com sshd[25614]: Received disconnect from port 33156:11: [preauth]
err. you have root login by ssh activated?
9:28 AM
yes i can login with sh
mhmm then this reveals nothing
ive tried everything
and you sure the service hangs up?
i wonder how i can debug this
apache still works just domain gets timed out
when i read this domain name i take now a wild guess youre running on a load balancer?
9:32 AM
not yet, havent set up load balancer
you could try a traceroute to see where it times out
ok thanks i will try that
$ traceroute audimiddleeast.com
traceroute to audimiddleeast.com (, 64 hops max
  1  2,659ms  2,242ms  2,116ms
  2   *  *  *
  3  13,450ms  10,026ms  9,221ms
  4  22,812ms  21,006ms  18,785ms
  5  39,976ms  52,729ms  18,160ms
  6  16,871ms  15,861ms  16,458ms
  7  20,614ms  18,657ms  18,834ms
  8  42,276ms  57,599ms  38,922ms
  9  41,984ms  39,860ms  39,958ms
you can ignore hop no 2
sorry im noob but do hops imply that its down, unavailable
means it doesn't respond, in case hop 2 is my provider gateway, it never responds so i can tell you that you can ignore it
13 and 15 could be a problem
9:36 AM
ok i see, is it maybe apache limiting amount of connections? or wonder why it never responds
can be possible but apache can serve already a good amount of traffic
for me the page just loaded
but is still loading, means that somehow the connection is very slow
yes it should look like that, if i load a non https domain on the same server it loads fine
all i can say it took a long time for that little amount of data to transfer and im sitting here on a 120 Mbit download connection
this should have shown up in split seconds
yes there is alot of content but only visible on mobile
if u scale to mobi u will see
now it is quick again
sec another traceroute
seems hop no 13 is the culprit
15 now responded properly
9:43 AM
not too sure
do you know where i can fix this?
you could only fix this if hop no 13 is within your own network but my guess it isnt, do a traceroute from your place to check if the 4th hop from the bottom times out or where it times out
ok thanks so much man
13 and 15 time out on my side continously, 15 shows up sometimes
ok i will sort it out maybe its my hosting company
since i was able to determine the IP of hop no 15 i can use whois to see who it is
9:46 AM
Thanks man have a good day
NetRange: -
NetName:        DIGITALOCEAN-16
NetHandle:      NET-138-197-0-0-1
Parent:         NET138 (NET-138-0-0-0-0)
NetType:        Direct Allocation
Organization:   DigitalOcean, LLC (DO-13)
RegDate:        2016-01-26
Updated:        2016-04-12
Ref:            whois.arin.net/rest/net/NET-138-197-0-0-1
maybe contact them
Thanks for the instant help, life saver
10:19 AM
Hey, I'd like to edit my .bashrc so that every single command executed gets piped to smth, do you guys if that is possible at all?
10:49 AM
@M.Becerra Do. Not. Do. That!
While it might be possible, it sounds like a horrible idea and a classic XY problem. What are you actually trying to do? What would you pipe to? What if the command expects input?
Q: How to pipe any command given to the shell?

M. BecerraI'd like to edit my .bashrc so that every command executed on the shell is piped to something, for example: $ sudo apt update _________________ < sudo apt update > ----------------- \ ^__^ \ (oo)\_______ (__)\ )\/\ ||----w | || || I hav...

11:13 AM
@dessert Oh man. What a horrible thing to do. . .
Clever though.
@terdon What I propose should be harmless i any case, however if I understand OP correctly he doesn't want the actual command to be executed… setting BASH_COMMAND="" with trap unfortunately didn't work.
@dessert I thought the OP did want it executed. And yes, what you suggested does indeed seem to be harmless (and I upvoted). Absolutely horrible, mind you, but harmless :)
Stéphane Chazelas once coded this for me:
insert() { perl -le 'require "sys/ioctl.ph"; ioctl(STDIN, &TIOCSTI, $_) for split "", join " ", @ARGV' -- "$@" ;}
auto_enter() { bind $'"\u200b":"\1'$1'\5"'; PROMPT_COMMAND="insert $'\u200b'" ;}
@dessert If Stéphane did it, I have absolutely nothing to add.
auto_enter inserts a string after every prompt, e.g. "man " – you can have a terminal tab just for manpages where you never need to type "man " this way :)
Well I wonder if we can change that anyhow…
But first it's lunchtime – hasta luego.
11:37 AM
Q: Password: chsh: PAM: Authentication failure

WeakarTrying to run RUN chsh -s /bin/bash www-data (dockerfile) i tried to change it to /bin/zsh but still doesn't work. Docker file is too long, there is the offical repository with the file https://hub.docker.com/r/alexcheng/magento2/~/dockerfile/ Result : Password: chsh: PAM: Authentication ...

6 hours later…
5:27 PM
Q: starting nginx - command not found

StrawHatI can't start nginx for some reason; I have done the following The server is opensuse Installed http://nginx.org/download/nginx-1.0.5.tar.gz extracted the folder run ./configure make make install the nginx have been extracted to /usr/local/nginx/sbin where I can see the nginx.. But when I ...

Protip: Abusing bash's DEBUG signal virtually guarantees a “Nice answer” badge: askubuntu.com/questions/983041/…, askubuntu.com/questions/984357/…
@dessert HNQ probably helps too :)
5:57 PM
Q: Ping is not working when arm architecture is emulated

Shreya pohekarI am Running Ubuntu on virtual box and emulated arm architecture (debian-armel) on it using qemu . But the ping is not working . Both the Ubuntu and emulated machines have got same ip Can anyone suggest a solution? Thank you in advance

Q: How can I prevent i2c-designware blocking Ubuntu GNOME on a Dell Inspiron 15 3552?

Wolfgang JeltschI installed Ubuntu GNOME 16.04.3 on a Dell Inspiron 15 3552 recently. This laptop came with Ubuntu 14.04 pre-installed; so it should be compatible with Linux in general. When running Ubuntu GNOME 16.04.3 for a while, the system stops responding to the mouse, a bit later it stops responding to th...

anyone here firm with python and using remmina?
@KazWolfe youre firm with python right? can you read through this last edit and check if this last edit makes sense overall? askubuntu.com/posts/512069/revisions
k gimme a sec
yeah it's valid
david actually forgot it when he copied it from the github
@Videonauth You can just follow the github link: github.com/peppelinux/remmina_password_exposer/blob/master/…
simply had this tab open since this morning, it was an edit suggestion i skipped because of that uncertainty but i wasn't going as far as checking the github
1 hour later…
7:22 PM
@Zanna Why did you remove VTR from the list?
because I have never seen it. Add it back if you like
actually, it seems like you pulled a lot of descriptive information from the list. /shrug
It's rare, but it it used around here. Not too much, but I have seen it and done it.
@Zanna That's a bad reason to remove something?
It was used extensively at one time.
What's “VTR” supposed to mean?
^- !
vote to resolve. Usually used when asking someone to upvote an answer so the system marks a question as answered.
7:27 PM
It's rare, and is sort of vote manipulation but it has its uses.
YMMAAPD should be YMMVAPD, am I right?
It's generally bad form to request a VTR but there are places where it helps.
refrains from replying
I have finished arranging the post alphabetically, removing things that seemed obsolete, and adding things that happened to cross my mind. Please fix it as you see fit
It's hard to see what you removed :/
7:33 PM
point @Seth to the obvious tool to use for that :meta.askubuntu.com/posts/3671/revisions
@Videonauth yeah but look at rev 66. You can't tell what was removed and what was just moved around a little
I removed VTR, NARQ (not a real question) and TL (too localised). And a duplicate "brb", I think :)
@NathanOsman Why does IE even exist? Everytime I find something cool on CSS there's a 90% chance that IE is possibly the only one that does not support it -.-
@Zanna OK. VTR is the only one of those that is still applicable.
OK, I will put it back
7:37 PM
@IanC Just don't support it then.
Everyone should be moving to Edge at the very least.
Q: Question about routing - two interfaces in Ubuntu

Marcin ZdunekOn my Ubuntu server machine I got two network interfaces (two network cards): auto eno1 iface eno1 inet static address mask post-up ip route add dev eno1 src table rt2 post-up ip route add default via dev eno1 table rt2 post-up ip rule ad...

@NathanOsman Anyone should move to Ubuntu and drop that MS crap ;)
Ubuntu needs to drop Systemd.
Everything does.
@NathanOsman I'm considering it, but maybe because it's a portfolio I should try to make it at least show "ok" on IE too
7:40 PM
I was going to use position: sticky;, until I read it is not supported on IE. I can come up with some JS to simulate the CSS property though
or just use sticky on the browsers that support it and leave the nav-bar static on IE
That's it! Use the fancy fast CSS, but load down the IE version with JS. That'll teach 'em
@Zanna thx
@Videonauth amem to that
7:41 PM
'Twas the night before Christmas And all through the kernel Not a module was failing Not even the journal When out of the blue There arose such a panic I checked the logfile and B͋͊̃̅̇͋ina̋͑̑̓̑r̸̆͌͝y͆ l̆o͌̍̑͆͑̀͂̐g͂͒̿filȇ̜̔͜͝ͅs ã̉r͓̅͋̂̒͘͜ë́͑͗̔ ḙ̷̦̔̉͟v̴̛̞̇̐̐̅̀͠il̴̑̐̎̏͏͚ #systemd
@Seth lol I'll make it the slowest JS script ever!
@IanC make sure to use lots of unnecessary libraries.
(PS @KazWolfe I have "Voted to Resolve" literally thousands of questions)
@Zanna btw, I'm looking at this: askubuntu.com/questions/984221/… it got a good answer. maybe we should just ignore the windows part and move on
brb, have to go do some errands!
7:44 PM
@Seth I guess we can pretend that comment never happened :S
@IanC sorry I didn't reply to you yesterday - Oli was asking for some output and I didn't want to push it off the page. I could have handled that better :) I made some black beans today with fresh corn and sweet potatoes :)
Being in this room still makes my heart rate act like I'm running uphill. Feel free to ping me if needed.
7:59 PM
How long exactly is the grace period where I can change or even remove an edit to a post? Is it the same amount of time one has to retract an up-/downvote?
in chat?
@Zanna Nothing wrong with VTRs. It's a healthy part of the site. It's just that asking for them (especially for your own posts) is sometimes in bad taste.
No, I meant on the website.
uhm not shure about the exact time in which you can edit a post again and it counts into the same revision, its not very long, something between 2-5 minutes max
8:39 PM
Hello guys, have someone experienced problem with 17.10 login authentificate error ? Everytime i click on my user screen freezes. Searched all forum and no solution.
trying to fix this all day, no result :) any help would be appreciated
have you tried logging in in a tty?
i can login in terminal, only gui fails
did the log files reveal anything specific?
i can, which log should i check ? :)
maybe /var/log/auth.log (needs root to read)
8:47 PM
do you need photo or should i copy it somehow ?
you could pastebinit
well, i dont know how to pastebin from console :)
thats easy
ok, step by step
sudo apt install pastebinit
i will try to uplaod to ftp
done, installed
is this a fresh install?
8:53 PM
i had this running for half year, and today upgraded release
do you care about any logs actually present?
if yes now would be the time to backup them if you need them
no, there is no any sensitive info
ok lets nuke them
@Zanna Don't worry! That sounds really good, though I'm not a big fan of sweet potatoes. I like the regular cooked potato, but I don't like the sweet one or any of them mashed :p
sudo find /var/log -type f \( -name "*.1" -o -name "*.gz" -o -name "*.old" \) -delete
8:55 PM
@Zanna What do you mean?
sudo find /var/log -type f -exec truncate -s 0 {} \;
@IanC I find it a bit stressful to visit this room. But anyone can ping me if they need me. Or find me in the other rooms where I hang out
when you have done those two commands, restart the machine, try to log into the GUI and when it fails switch to a TTY and cat /var/log/syslog | pastebinit and cat /var/log/auth.log | pastebinit then you can copy/type the adresses here
@IanC I guess I like sweet things that are not too sweet, so I like sweet potato and sweetcorn and fruits, but not sugarcane
9:00 PM
@Zanna oh, I see, where else do you hangout on SE? I'm usually here or rarely on SO C chat because it isn't as active there
@IanC I wondered about that too, now I believe Zanna's hangout zone is the review queues ;)
@Zanna I don't know why exactly I don't like sweet potatoes, but I have this weird rule about sweet and salted food. I don't like mixing them, like sweet pizza, chocolate croissant. Maybe my head thinks potatoes are supposed to be salted and I dislike them being sweet lol
haha ok... but what about salted caramel
I think I never had it
only the regular sweet caramel, is it really like melted sugar with salt?
I hang out in the Downboat for moderation-related stuff on Ask Ubuntu, the Island for anything bailed from the boat or off topic in the boat (usually overly long technical discussion not directly related to moderation, but it could be anything!)
I am always in those rooms whenever I'm online.
9:05 PM
syslog: http://paste.ubuntu.com/26141816/
auth.log http://paste.ubuntu.com/26141819/
@IanC pretty much, maybe with some fatty coconut cream goodness in there
@Videonauth Does pastebinit default to paste.ubuntu.com?
@dessert yep
@Videonauth I like it. Oh wait, I can use something from the list…
people chat about random stuff on those moderation chats or strictly mod stuff?
9:08 PM
Wait for it…
@Zanna I could taste it someday, I'm trying to be more open minded about those sweet/salted mixes, though I usually dislike them haha
TIL about pastebinit! :D
pastebinit is awesome
does anyone know if there's a way to make pastebinit include the command you ran?
@Zanna How about a wrapper function which just tees to echo?
@IanC it's OK if people talk about random stuff in the Downboat, because we just move it to the Island where nothing is off-topic :)
@dessert I saw a question like this... but I was wondering if pastebinit just has a flag or something to save fiddling around
9:11 PM
No, wait, it doesn't work that way.
I guess we like fiddling around with shells though, or we probably wouldn't be here :)
@JustasPukys did you let the GUI login run into freeze before changing to tty?
only reboot helps after freeze
Q: Direct output from a command to a file including the original command, AND print in terminal

shaneohWhen running some tests, I need to run a series of commands. It would be extremely useful to me, and save me a lot of time, if there was a way to do all of these things: Run the command I need to run Redirect all the output from the command to a specified file Include the original command in th...

9:13 PM
it do not freeze while i click on user
@JustasPukys mhmm can you check if you can switch to a tty when the GUI freezes?
@dessert yeah, I didn't find one there either, but sometimes there is some sekrit knowledge
@Videonauth i have tried. i cant, nothing works
@Zanna I wonder if there are any high rep users without a golden bash or command-line or scripts tag badge…
yeah, Eliah Kagan
for one
9:14 PM
i can post video
nah doesnt help i would need the logs from that exact moment you have sent it to a freeze
i see console during the freeze, its like loop, trying to repeat command, dot flashing very fast
@Zanna cool, might show up someday to check the chatroom then! But I'm finding it hard to keep really active on any room, my free time has been a bit narrowed last couple weeks
maybe i can enable debugging for more information ?
I'm a bit lost here right now, maybe you write a comprehensive question on Ask Ubuntu and include the logs and so on into it (you can skip the log nuke commands i posted earlier)
9:18 PM
there was similar questions, but none of solutions helped
@IanC sure, always nice to see you :) hope you get some more chill time soon (unless you're loving being busy, in which case, long may it continue!)
@JustasPukys include those links too for those answers which did not help and describe what did not work and so on
imgur.com/a/yB3rv this is what i see during the freeze, right after clicking on user
@dessert a version of your function worked :)
this is what I did:
$ both(){ (echo \$ "$@" && "$@") | pastebinit ;}
$ both uname -r
@Zanna What function again?
Ah, this one – well, it's an easy task in fact…
9:21 PM
@Videonauth ty for help, i will try to create ticket :)
Thanks! It's always pleasant talking to you too :)
It's being alright to have a tighter schedule, considering I'm trying to explore some new stuff work related. As long as there's always time for surfing it's all good!
@dessert hmm. Well, thanks for the useful function!
@Zanna It's a pleasure! :)
I named my version pasteboth() and added it to my .bashrc
(Obviously I already upvoted your answer before, just in case you're thinking "wow she finds it useful enough to use herself but doesn't even upvote")
(going afk)
@Zanna On second thought “both” is a really bad name for a function: The function name should describe its action as clear as possible. I suggest rather “commandpaste”, “fullpaste” or (if you find it useful enough to make it the default) just “paste”.
9:33 PM
paste is a command that does something else :)
@Zanna Don't worry, I don't care for votes. After all they are a measure for posts, not for people.
pasteboth expresses my thought
@Zanna Well of course, if you can remember its use it's fine this way. ;)
@Zanna Plus I already hit the cap for today, so a vote wouldn't change anything regarding my rep anyway…
@dessert indeed :) and people can vote however they want. But insofar as there is a way we are supposed to vote, I think we are supposed to upvote useful posts, so I wouldn't want to set a (IMHO) bad example by appearing not to bother to upvote useful posts. If that makes any sense
9:49 PM
Happy 8th of December, y'all:
Q: Troubleshooting keyboard shorcut issues 16.04

natralI am currently having trouble setting up some keyboard shortcuts, specifically the 'super' key. I am using Linux Mint Mate 18.2 and when used on its own the super key opens my menu bar. Here I can search for apps, shutdown, etc. However I wish to use my super key for other shortcuts but none s...

what's on the 8th of December? Only heard of the Feast of the Immaculate conception
heard = just researched on google lol
Nothing is on the 8th :P
That's why there's a doge in a Darth Vader costume.
Because it doesn't make any sense :D
@UbuntuQuestionsonU&L vimeo.com/240410540
TBH - all I wanted was an excuse to post that picture.
9:55 PM
man, I wanted to talk to you later about hosting, to get an idea on some cheap but alright servers, but I have to go out kind of quickly right now
so see you all later! Happy dog on a vader costume day!
It's just 20 days to Linus Torvalds birthday…
@NathanOsman Hej, it's Nicki Minaj's birthday! The pic almost matches…
10:18 PM
*spits out sandwich*
By golly, you're right!
Yes, the resemblance is stunning!
@IanC Sure! Bottom line - if you don't mind a datacenter in France, Scaleway is your cheapest bet. Otherwise, DigitalOcean.

« first day (2627 days earlier)      last day (1284 days later) »