« first day (2626 days earlier)      last day (2360 days later) » 

12:15 AM
@Terrance as I understand, he wants to unzip each zip file to a directory with the same name as the original ZIP
so for example, helloWorld.zip --> [folder]helloWorld/
@AndroidDev Hmmm, I don't see that in there that OP wants it extracted to a folder. I am thinking of VTC as unclear.
Or maybe I read it as they want to rename the files as they are extracted from the zip as the name of the zip file.
1:10 AM
@Terrance I can't tell either.
When I read it I thought he meant recursively unzipping the file!
Whatever it is, I don't think it is obtainable as I am not aware of anyway for 7z to rename files while they are extracted. I really am not sure though. I am confused.
1:46 AM
@Terrance I can't tell if he himself know exactly what he wants to do, but maybe he wants to put the name of the zip file where the file was extracted from as a prefix to identify it?
like "mylittlepony.7z" -> "mylittlepony-poney1.jpg"?
@DanielSank In Ubuntu?!
@Terrance maybe a script could create a temporary folder where the files would be extracted, then rename every file on that folder to "zipfilename-" + original name. I'm about to go to work so I can't really write the script at the moment, but seems feasible. Maybe not as cleanly as if 7z had a prefix argument :p
loop would look something like:
> Create folder with an unique name
> Loop through zip files
> Extract zip file to created folder
> Use find to rename all files on created folder
> Move the files back to the destination folder
> Repeat until there are no more zip files
> Delete the created folder
2:10 AM
well, going for the graveyard shift here, see yall later!
2:21 AM
@Seth Ah, I was mistaken. Pardon me.
I had simply somehow caused, via unknown key presses, a pdf reader to rotate 90 degrees.
@DanielSank No worries. I was going to say, I know Windows 10 does that but I'm pretty sure Ubuntu does not.
@DanielSank Ah
@Seth As my colleague likes to say "...and thus the computer completes it's proof that the user is an idiot."
@DanielSank haha, that's a good saying. I'm going to steal it :P
Please do. My buddy will be pleased.
@Seth here, it's this guy.
Thanks for sharing!
3:06 AM
who are you???? — Smile 12 mins ago
O_o well, um . . . that's not a response I expected to receive to my answer
I might have scared them with my 1337 bash skills :X
3:25 AM
Q: How to combine columns of two files, remove duplicates, and fill in missing lines

Dylan GirodatI have two separate files that I would like to combine. Each have 7 columns as such: 1 10 6 0.02 A 45 0.17 1 15 6 0.03 A 67 0.17 2 33 6 0.10 A 23 0.17 and 1 10 6 0.04 B 87 0.17 1 12 6 0.12 B 93 0.17 2 33 6 0.08 B 45 0.17 I would like to combine column 1 and 2 of each files while removin...

3 hours later…
6:05 AM
good morning
Er . . . technically night for me
anyway, smoke
My sleeping patterns are so messed up I wonder if they'll ever be normal again.
I don't think having kids is going to help with that either :P
6:32 AM
hello guys, this is a nice place.
1 hour later…
8:11 AM
I like askubuntu.com
Q: Service stops Automatically

XameerI have installed artifactory and its running fine on and aws instance, but when I disconnect the service stops automatically, I'm starting the service as service artifactory start What I need is that the service needs to be up all the time when "instance is running".

1 hour later…
9:37 AM
Q: Skype doesn't start anymore

ka3akSkype always started and logged in automatically after PC start. But today it didn't happen. Instead of this Skype login window popped up and I was asked to enter my credentials. I entered them, the login window disappeared, but nothing else happened. I didn't see the usual things after that like...

10:17 AM
@dessert If it's ok with you, I'd rather reply in here so we don't end up with an extended discussion on the post. But it's about this question: https://askubuntu.com/questions/984047/correcting-path-setting-in-profile-file#comment1582980_984047

But this is how I see it. If someone else comes to Ask Ubuntu and asks:

> In `profile` there's a line: `. "$HOME/.bashrc"i`, should the `i` be there?

I would rather that question as a duplicate of the question linked above. Having an accidental `i` in files is pretty common, due to the way `vim` works.
@Dan What do you mean by saying
> Having an accidental i in files is pretty common, due to the way vim works.
If you think you know where the i came from you should ask OP and edit the question accordingly, currently this question is next to useless IMO.
To edit files in vim, you need to press i to go into insert mode. It happens quite a few times with me to press i without noticing that I was already in insert mode.
@dessert I won't disagree with this, but not everyone knows bash, for some beginners this could be very helpful
@Dan Then this is a duplicate of a question explaining that! Did you find one? If not, would you add one?
@dessert I haven't looked, to be honest. I need to go out for a couple of hours. Maybe it's better to get other people opinions as well first.
10:35 AM
Q: Ubuntu 16.04: Erroneously executed `mv` with `~/*` as target and can't understand the outcome

Daniel FWhile wanting to upgrade MongoDB from 3.4 to 3.6 I went into the /etc/apt/sources.list.d directory. From there I wanted to move the mongodb-org-3.4.list and mongodb-org-3.4.list.save files to my home directory. I first executed a mv mongodb-org-3.4 ~/*. For some reason I managed to move the wild...

@dessert I don't see why it is a dupe of the one you suggested. They don't even seem related. One is asking about a specific character in the declaration of their path but the dupe is a general question about changing path.
2 hours later…
12:15 PM
@dessert thanks for editing my post to add syntax highlighting! Particularly important in that case
12:45 PM
@Zanna Thought so too, you're welcome. :)
I hope this question gets a good answer instead of being closed as a dupe
the advice in comments is helpful, but I would really like to know how ubiquity decides how to partition. I use that option every time and I get a different scheme and labelling in every version of Ubuntu
@Zanna Agreed. That doesn't seem like a dupe. I pushed it out of the close queue.
1:19 PM
good morning!
@IanC good afternoon to you too :)
@Videonauth it's almost afternoon here anyways, so I'll take it haha
how are you doing?
14:20 here
fine and you? how goes your adventure in CSS going along?
@Videonauth it's going fine, the part that comes after the website is ready is what's being a little trickier
the filling it with content part?
1:23 PM
no, the selling/giving it part lol
Sitting back in your Aeron chair and raking in that dot-com-bubble cash?
next time I make a website for someone with a portfolio filling goal it will be for some nonprofit organization
at least I'll feel like it's going for a greater good and be more comfortable if things don't go the way I expected them to
hey @Zanna, long time no see! How are things going there?
bom dia! Things are pretty good, thanks :) Hope it's the same for you
it's all good around here too :)
1:30 PM
are you on your folks town?
yes, but it makes little difference when you barely leave the house XD
until this month I was cycling quite a lot, which was nice. I find cycling in London scary, and never had anywhere keep my bike. Now it's too cold. Otherwise, it's nice to have someone to cook for!
Was it a bit dangerous because of traffic to cycle on London?
That's nice! So you are good cooking? :)
I'd probably never dare to try to cook for my parents, my mother sets the standards quite high and I kind of suck cooking, it's good enough for me because I'm pretty much alright with eating dull food, but they'd probably dislike it a lot haha
except for one or other plate that I manage to do a bit better, like tun fish risotto
1:47 PM
@IanC yes, imho it's a dangerous city for cycling. I did some cycling there when I was doing a class, before I moved there. I used to take my bike on the train, cycle across town, and back to a hostel by the station to get the train home in the morning. But the motorists just seem not to care whether they kill you
@IanC I like cooking... I usually like what I cook. I can't claim to be good at it haha
@IanC my mum isn't keen on cooking, so she's happy to let me. But my dad has told me to stop cooking for him now because everything I make is too spicy
I loved eating out in Brazil. I could totally eat rice and beans and greens every day
so England has some idiot drivers too? Thought that was a thing of ours! :p
I have to use a bicycle often for surfing, and on places where there are not a exclusive bike lane I've to watch out
@Zanna usually people don't use a lot of spicy seasoning and pepper there right? I usually like it, maybe not a lot when it gets too extreme haha
haha yeah England has plenty of inconsiderate drivers. I sometimes thing getting behind the wheel of a motor vehicle causes a person to suddenly be 100% convinced they are in the right about everything and that everyone else is an annoyance to be swept aside by any means necessary
I'm not eating beans that often, I don't have a pressure pan that works with my oven :/
I only eat it on my parents, when I buy some food out or when I buy frozen beans, which are not very healthy I guess..
@Zanna that sounds a lot like here. I've never been in England but I always believed people were more considerate than most drivers here, maybe they are but still not considerate enough :p
2:02 PM
@IanC Well in "traditional" English food people only use salt and pepper, but we have appropriated and adapted to various degrees recipes from other cultures... my dad likes to eat all day breakfast (vegetarian), mushroom omelette, mum's Italian-influenced dishes. I guess I feel like the food is just boring without spices. Even when I think it's not spicy, my dad thinks it is. But he's also on a low-salt regime at the moment, so that's another reason he wants to prepare his own food
@IanC I don't have any pressure cooker; I just cook beans and dal etc in a saucepan. A pressure cooker would be very helpful for me. But the kitchen is pretty cluttered already... Frozen beans should be healthy for you, only maybe a little less so for the environment, I think :)
Any AMD graphics users here on a recent release? Could you post a screenshot of the Additional Drivers pane from Software & Updates?
This thing, but with the choices for AMD cards.
@Zanna mushroom omelette sounds nice! That's something I never tried before :)
actually I don't know many vegetarian dishes
I accidentally ate soy hamburgers on college once, but I didn't like it much.. They weren't well tempered, so maybe that was it. I heard if you use the right seasoning they can get much better!
@Zanna I could do it once in a while, but it probably takes a lot of extra time to get them ready without a pressure cooker, wouldn't be able to do it often
oh, I guess the bean itself isn't the issue on those frozen bean dishes, but they usually put a lot of salt and some conservants on it, so the sodium gets a bit high. I don't have a lot of salt in my diet so it's ok to eat it sometimes, but it would be better to have some fresh homemade beans :p
3 hours later…
5:13 PM
@terdon this needs to go onto U&L askubuntu.com/q/984133/295286
@Smile Sorry, I was sleeping when you were in chat. So what did you mean ?
@SergiyKolodyazhnyy That question seems on-topic to me, because they want to configure the Ubuntu-provided GRUB to boot another OS. I've commented to request clarification just in case (and also to further explain why it appears to be on-topic). Unless I'm missing something big, we should not migrate that to Unix & Linux. (cc @terdon)
@EliahKagan I don't think there's any Ubuntu involved at all. What makes you think there is? The OP said they removed Windows and replaced it with GhostBSD
Ah! Yes, I see. Crap.
Oh well, it's gone now.
My bad.
Because this is Linux, not BSD:
smit@smit-Aspire-5742:~$ sudo update-grub
[sudo] password for smit:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.13.0-17-generic
Found initrd image: /boot/initrd.img-4.13.0-17-generic
Found linux image: /boot/vmlinuz-4.13.0-16-generic
Found initrd image: /boot/initrd.img-4.13.0-16-generic
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
@Oli I have a machine with AMD graphics integrated on the MB... not sure if that counts
But, I would like to take this opportunity to ask everyone again to please use flags for this sort of thing instead of pinging mods in chat. That way, maybe a more alert mod would have dealt with it and have realized that it was fine where it was.
5:24 PM
@terdon I'm not sure what the best thing is to do now. If they're happy with it being on Unix & Linux then it could stay there. If they prefer it go back to Ask Ubuntu then it could be migrated back and reopened. I think that commenting to ask them is the best course in this situation.
@EliahKagan Well, I could close it on U&L which would reject the migration and bring it back. On the other hand, if there's some BSD-specific tweak that's needed here, it's likelier to find an answer on U&L.
Hmm, poking around with the chrome inspector in here and when I send a message, it also sends something called an fkey.... is that to authenticate maybe?
Yeah. I wouldn't bring it back if the OP doesn't have a preference. I think it may be best to let them know that the migration can be undone if they prefer it, though.
@EliahKagan good catch. Clarity was 0 in that question, though
@EliahKagan They have an account on both sites. leave them a comment, if you like, but I don't see much point. The question probably is better off at U&L since the OP has already done the normal steps you'd do to get grub to see a Linux installation. I'm thinking it might benefit from someone with BSD knowledge.
5:29 PM
@terdon Did use a flag, with OP repeatedly talking about ghostBSD and no indication of Ubuntu anywhere, I was sure it's gonna get closed anyway
Does anybody know if very old first class stamps in the UK have any sort of expiry date? I don't think that they do. But someone mentioned that they might. These are from when the EU was still the EC and Poland hadn't yet joined. So a while back.
@terdon I think I'll just leave the comment I had posted (immediately before the migration took effect, so you may not have seen it) for a while. If they reply to it or edit the post to indicate they want it migrated back, then I'd suggest doing that. Otherwise, it probably means they're at least okay with the migration.
@SergiyKolodyazhnyy That's odd. I don't see one. Caching, I guess.
@EliahKagan Fair enough
Interesting. When a message gets starred it pops up in the network activity, but normal messages don't
I think the output of lsb_release -d to find out what Ubuntu release provided GRUB2 may still be helpful, anyway.
5:31 PM
Or at least any idea about sending post within the EU? Can you send to any EU country with just the one stamp or do I need to do something special with it?
Is this related to Brexit?
Just kidding.
@Videonauth Oh, cool.
@ParanoidPanda I found this, though I don't know if it applies to your situation. (I just don't know much of anything about the postal system in the UK.)
@ParanoidPanda ususally it is enough th have the right amount of stamps on it yes, uk priority should be enough for sending to other EU countries, but you could ask in a local post office to be sure
Hey guys I found the location of the ping sound :D cdn-chat.sstatic.net/chat/se.mp3
5:36 PM
@EliahKagan: Thanks! That's great! Exactly what I needed! :)
@Videonauth: I think I will. :)
Since we're already talking about ghostBSD, it's actually pretty cool distro
Should I try it out? It's based on FreeBSD and focused on desktop use, right?
5:43 PM
@EliahKagan Yes, definitely give it a shot. Focused on desktop, uses Mate as desktop, fairly stable. I had it virtual box for couple months already.
Btw, I looked at OP's screenshot. I think they didn't install it properly. ghostBSD uses zfs, and in screenshot it shows some unknown filesystem
Hehe, screwing around with the CSS in here is fun :D
The only thing that I don't quite like about BSD is that you have to look at dmesg to find out total installed ram or sysctl output. Or top. /proc is also been deprecated on FreeBSD for a while
but that's a minor thing
@AndroidDev yep if you code that right in a greasemonkey/tampermonkey script you might be able to make complete user themes for SE chatrooms
"What is the object oriented way of getting rich?" "Inheritance."
@Videonauth Or extending another class . . . aka making copycat franchise
5:53 PM
Well, I figured out how TheWanderer made his dark theme...
That's just so... FAT!!!
:D :D :D
6:03 PM
I just found it sort of randomly in an article.
It's not fat, it's fluffy :p
@SergiyKolodyazhnyy: Feathery actually ;P
Or maybe he has fluffy feathers?
6:05 PM
You mean the one in the cute little white hat?
Doesn't look all that fat.
Unless you meant phat.
Dat pope is dope, hiz phat
Sigh, alright, not gonna make too many jokes about pope
gotta go get my F in class, bye guys
@SergiyKolodyazhnyy good luck
6:29 PM
TIL this exists: bashrcgenerator.com
@Seth doesn't work for me
Firefox says it can't connect
Try again. I assumed it had SSL.
@Seth Why though? The PS1 syntax is so painless to use! Simple, elegant and intuitive!
the sarcasm is strong with this one xD
Yeah. Right.
@Seth :)
6:35 PM
Yeah really everybody should have SSL with Letsencrypt
I mean it's free after all
I'm having a moment of this:
All long help threads should have a sticky globally-editable post at the top saying 'DEAR PEOPLE FROM THE FUTURE: Here's what we've figured out so far ...'
I have an issue where wifi only works when ethernet is plugged in. And the only other report of this problem I could find is:
Q: Wireless driver working as ethernet? (ubuntu 11.04)

Leonardo RaeleI haven't very affinity with Networking/LAN, so I do not quite understand what's going on with my wireless driver, that's why I came here for help. My drive does not find any working wireless connection until I plug a network cable in. If I do this, it find working wireless connections and even i...

same issue on same ubuntu version?
but same issue, yes.
-> Wireless card has "Link encap:Ethernet"
-> wifi only works when ethernet cable is plugged in
@Avery ifconfig output?
6:46 PM
@Avery I could change the OP's name to DenverCoder9, if you like. Dunno how helpful that would be though.
can you be more specific? When you say "wireless only works" do they still operate like two different systems? Can you change wireless networks?
@Seth as I ssh over network I've no idea
@Avery (that's not a virus or anything, that's my hastebin instance)
also, hehe, that was interesting. By sending my message from an HTTP request I got to see what the actual lag time between sending a message and it popping in is
You have a point to point interface with the same MAC as the wireless interface. That's interesting.
Know anything about that?
6:49 PM
Do you use any sort of phone tethering?
when I use nmtui it only lists connections on the p2p one
@Avery You mean you are ssh'ing into this system?
however it fails to connect to the wireless networks
@Seth yes
are you on the latest version of raspbian?
6:50 PM
@AndroidDev errrrrrrrrrrrrrr
silently does apt upgrade
@Avery giggles
Hmm, I wonder what would happen if I sent a message using a different fkey?
but I don't have anybody else's fkey
wlan0 Link encap:Ethernet HWaddr b8:27:eb:92:11:54
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
@Avery what IP are you ssh'ing into? or
6:54 PM
Now you have mine.
on a roll today terdon
@Seth Yeah, it's almost 21:00 and I'm still working. Does wonders for my head, that :)
@Seth both of them stop working when I remove ethernet cable. I'm not quite dumb enough to say "ssh over ethernet stops working when I remove ethernet cable".
@terdon ugh. I can imagine. I hope you're getting payed good overtime.
6:55 PM
@Seth Nah. But nobody told me to keep at it, so I can't complain. I just wanted to finish something. Plus, I work from home so. . .
@Avery Can you be more specific please. "stop working" is really vague. How do you know? What are you trying? Do you have a monitor plugged in or is it headless?
@Avery Anything interesting in dmesg when you pull the cable?
@terdon Oh. haha, that complicates things :P
My bet is on that p2p interface
I updated, will try again now. I'll check dmesg during that, after that will try a kernel update.
I've got to run. I suggest a post on main.
6:59 PM
@Seth I SSH in to the device through ethernet IP, I connect to wifi with uh, basically I do ifup wlan2 (I put wifi info in /etc/network/interfaces), I close that ssh session, ssh through wifi IP, try typing something, remove ethernet cable, observe that typing something no longer works.
@Avery Ok. Those are important details. Your interfaces config is important too.
> [ 98.710417] ADDRCONF(NETDEV_CHANGE): wlan2: link becomes ready
[ 98.715846] wlan2: associated
[ 156.250215] PHY: gmac0-0:00 - Link is Down
[ 163.250218] PHY: gmac0-0:00 - Link is Up - 100/Full
nothing notable in dmesg
Right, will try out updating kernel.
7:27 PM
Q: Linux Mint VMware Player 14 with MacOs guest resolution switching to HiDPI

Peter PetersonPreface: Linux Mint 18.3 VMWare Player 14 MacOS HighSierra (as guest OS on vmware) Latest Darwin VMTools installed Native monitor resolution 1920x1080 Issue: When changing the VM's window size, if it gets any bigger than 1024x768 the guest OS automatically switches to HiDPI resolution m...

7:46 PM
7:56 PM
KDE pls
I can shut down and reboot now
But sleep takes around 7 minutes
That's... not normal.
8:12 PM
@NathanOsman that's exactly what you said before :D
I can't debug it though
I'm being consistent.
because if I open the laptop again, I'm in some sort of zombie state where I can't run commands or open programs, but the mouse and keyboard still work
but if I leave it long enough, it's asleep
What does dmesg tell you?
when and where and how
@NathanOsman so I was playing around with trying to send a chat message through OkHttp from a desktop program and the response was Response{protocol=http/1.1, code=404, message=Not Found, url=https://chat.stackexchange.com/chats/1/messages/new} any ideas?
but that's the URL that Chrome's inspector shows
8:21 PM
@AndroidDev This was a POST request or GET?
Sounds like auth is missing then.
I set the cookies and the fkey
Oh wait.
That's right.
8:22 PM
    type: 'POST',
    url: 'https://chat.stackexchange.com/chats/1/messages/new'
^--- running that results in a 500 error
but I'm getting 404
(Which is expected given that it's missing its payload.)
@AndroidDev Right - that's the weird part.
Let me try this in Incognito.
400 Bad Request in Incognito.
Still can't get a 404 error.
That's extremely weird.
wait wait wait, I managed to get a 400
MediaType mediaType = MediaType.parse("application/text; charset=UTF-8");
but I get 404 with MediaType mediaType = MediaType.parse("application/x-www-form-urlencoded; charset=UTF-8");
but that's but but but that's what Chrome's inspector shows...
application/x-www-form-urlencoded is the correct Content-Type.
so then why does it give 404 when putting in the wrong type gives 400?
8:29 PM
I have no idea.
Chat is really picky about what it accepts.
@TheWanderer I'm no expert on sleep ( in fact I lack sleep) but it sounds like some process is blocking it, maybe even network manager. Do dmesg right after you resume and see what it says. Otherwise, just avoid suspend altogether
I'm almost certain wpa_supplicant is the issue
 function messageActionById(e,t,s,i,n){s||(s={}),$.ajax({"type":"POST","url":"/messages/"+e+"/"+t,"data":fkey(s),"success":function(e){i?i(e):"ok"!=e&&n&&n(e||GENERIC_ERROR)},"dataType":"json","error":function(e,t){var s="error"==t?409==e.status?e.responseText:GENERIC_ERROR:t;i?i(s):n&&n(s)}})}
@NathanOsman is that the code that is supposed to send messages to the chat?
8:45 PM
hehe, Chrome let's you copy the POST request as a CURL command!
now that's cool!
nevermind, I now think that function Ct() is where the magic is happening, not sure how though :p
in Sandbox, 21 secs ago, by Android Dev
this was sent from OkHTTP in Java
@NathanOsman You were right, I had screwed up the cookies
It works now?
This is nice music:
And you should see their other stuff, most of their drummers are like 12-14 and they are really amazing professionals.
sooo what URL does the websocket reside at?
9:15 PM
I am very confused
somehow the line endings for my Android Manifest got changed to Windows
and APKTool didn't even mind
That's windows for ya.
I'm using Ubuntu
Windows is broken, remember?
Gotta love CRLF.
9:44 PM
So what?
So what are
So what are we
So what are we doing
So what are we doing with
9:49 PM
So what are we doing with our
So what are we doing with our posts?
I love the beauty of the text as it grows :P
I was going to say lives, but that works too :P
I am cooking ham today.
I am also writing an article.
@NathanOsman It looks likes half a christmas tree
(Not about cooking ham though.)
9:50 PM
Is there somebody here who has an answer to that?
Q: How does "less" switch to the text, then back to the prompt?

wjandreaWhen I run less on some file, the prompt goes away, and I get the contents of the file on screen. Then when I press q, it goes back to the prompt. I think less does this by saving the current terminal buffer, opening a new buffer, outputting the file into the new one, then when closed, discarding...

@NathanOsman aw
@dessert Look at the source
1 hour later…
10:53 PM
Q: Can I install Ubuntu Studio on a Chromebook?

taffy146Self-explanatory question. Just curious, seeing as how it's a "creative" OS, I don't know how functional it could be on Chromebook. Just, more of a "what all can I do with this?" kind of thing.


« first day (2626 days earlier)      last day (2360 days later) »