« first day (2113 days earlier)      last day (1293 days later) » 

3:00 AM
Imma bash my chips
53 days until laser surgery!
O_o
 
i should be writing my thesis sooo
procrastination is a bitch
 
@J.Ferreira woah profancy
 
oops I thought that since you are men you were not prudes
 
what?
that's a little sexist, or are you being sarcastic?
 
I can be sexist I am a woman
 
3:04 AM
uhm
 
@J.Ferreira masters or phd thesis?
 
masters
 
Wha... Qt5LinguistToolsConfig.cmake is in the libqt5help-devel package... why???
 
wut
 
@J.Ferreira good luck writing
 
3:08 AM
it's more a work of patience unfortunately, i guess, but thanks
 
3:19 AM
What do you need from me?
 
too late
 
Sorry. I have a life
 
you do?
 
Yes. An unpaid intern's life
Slave labor but I get to choose my own projects
 
Yey, I haz de scriptz
Final question is, do I post it as gist or upload to my repo
 
3:33 AM
probably repo
 
^_^ OK , will do
@NathanOsman may I haz a python question ?
 
0
Q: Services (web, remote login, console, but not ping) crashing after upgrade

Topological SortI just did an upgrade to my Ubuntu box. It upgraded, but now the machine, within hours (maybe less) of booting, is unreachable by ssh, by web browser, and even the console is blank... but I know it's still running, because it's responding to ping. I had to do a hardware reset, twice, to get it ...

 
@Serg Yes.
 
@NathanOsman I'm spawning something with subprocess.Popen Question is : how do I detach it and let the script exit ?
 
D: nitroshare crashed
 
3:43 AM
You mean keep the process running and let Python exit?
@Edity unpossible!
 
it happened
nothing is unpossible
exited without any error code
 
@NathanOsman yup , same as nohup command &>/dev/null &
 
Couldn't you just use nohup as the command passed to Popen?
@Edity On which OS?
 
windows
 
And what was the error?
"NitroShare has stopped working?"
 
3:45 AM
no error codes
exited without anything happening
 
The icon disappeared?
 
yes
the process to
 
That's odd.
You sure you didn't accidentally quit it?
 
O_o
yep
 
What were you doing when that happened?
Performing a transfer?
 
3:46 AM
yp
yup*
 
What does the other end say?
 
and then...
"Nitroshare- Boomtech has left the server"
 
Well, that's to be expected.
So let me try to understand exactly what happened.
 
and now...
 
Which machine was sending the files - the one that crashed?
 
3:48 AM
its saying "outdated version"
yes
so theres my problem
 
Outdated? Are you using NitroShare 0.2 on one of the machines???
 
nop
 
That's the only version that displays that message...
 
@NathanOsman Yeah, I nohupped the command , but the script doesn't exit . . . probably waits for stdout ?
 
i haven't updated because I don't know how.
very odd
@NathanOsman make a "if your nitroshare crashes" section of your readme on github..
 
3:50 AM
@Serg I guess I would need to see the script.
@Edity On Windows?
 
yes
haw do I update
 
Just uninstall and download the version on the website.
 
New idea for nitroshare: make a check for updates button.
off to playing on my gaming PC
bai
 
I used to have that feature.
But it was a real pain.
 
oh
 
3:52 AM
Because NitroShare runs on so many different platforms.
 
welp see you in 2 hours
 
Okay.
 
jk
lol
i can chat while playing
a good pain in the penci;
 
@NathanOsman Nevermind , found it . . . it was indeed waiting for stdout
 
Oh good.
 
3:53 AM
@NathanOsman i will update, and let you know how it goes
 
Alright.
 
13.3 MB ?!?
 
It contains all of Qt and the ANGLE EGL=>DirectX compiler.
So 13 MB seems pretty fair.
 
i see
guess what I'm playing
 
I give up.
 
3:59 AM
:P
 
Tell me what genre.
 
fantacy
idk
its league of legends :P
 
League of Legends (abbreviated LoL or just League) is a multiplayer online battle arena video game developed and published by Riot Games for Microsoft Windows and OS X. The game follows a freemium model and is supported by microtransactions, and was inspired by the Warcraft III: The Frozen Throne mod, Defense of the Ancients. In League of Legends, players assume the role of an unseen "summoner" that controls a "champion" with unique abilities and battle against a team of other players or computer-controlled champions. The goal is usually to destroy the opposing team's "nexus", a structure which...
il chat when i die
its fun
 
I've really gotten into this game lately: maniaplanet.com/shootmania
 
4:08 AM
shootmania i see
 
So many different gameplay modes.
 
ok
 
Note for the future. Never use your ex-gf name in passwords . . . .if you ever break up , it will be painful typing in that password each time
 
why would anyone do that
besides serg
 
ikr
we lost D:
@Serg a little too late?
 
4:24 AM
[ SmokeDetector ] Link at end of body, pattern-matching website in body: Top 5 Fast Creating Secrets Introduced by marionwesley on askubuntu.com
 
Sort of , I guess
 
At least you didn't get a tattoo with her name :D
 
Jacuzzi Pump???
We're getting outdoor pool spam now?
 
better than augmentation of certain body parts
 
4:29 AM
hello darkness my old freind
 
@edwinksl I guess so.
 
0
Q: How to import a large and complex csproj into MonoDevelop 5.10 with Ubuntu 16.04 and the ASP.NET addin?

FrankI would like to know how to import a large and complex csproj into MonoDevelop 5.10 with Ubuntu 16.04 and the ASP.NET addin I tried this method recently , http://stackoverflow.com/questions/9220290/open-a-csproj-with-monodevelop, "where we create a new empty solution and then copy your proje...

 
4:47 AM
@Zacharee1 remember that russian dude ?
0
A: Interactive "open with" dialog mod?

SergScript Intro This script allows choosing a file, selecting an application from file selection dialog, open user selected file with that application, and optionally setting that same application as default. This script is meant to be added to Nautilus as right click option. Installation The ...

@NathanOsman that's the script I was asking about ^ Already got it working , posted, git-ed , etc
 
Looks good.
 
[ SmokeDetector ] Bad keyword in body, bad keyword in title, link at end of body, link following arrow in body, pattern-matching website in body: Skin Care Best Anti Aging Cream? by Boarandre on askubuntu.com
 
@edwinksl Learned that from @JacobVlijm :D
 
so professional, people might think you get paid to do this
 
4:59 AM
I wish I was . Maybe some day my answers can make good impression on a future employer :)
 
well it can't possibly harm
 
"Serg doesn't use Perl, can't hire him."

— Nobody Ever
 
5:13 AM
[ SmokeDetector ] Link at end of body, link following arrow in body, pattern-matching website in body: Hyper Tone Excel For those who want? by robertyilkens on askubuntu.com
 
@NathanOsman updating solved the problem
 
I thought it would :)
 
:D
 
@NathanOsman No , more likely it will be " You don't have enough experience "
 
5:49 AM
[ SmokeDetector ] Bad keyword in body, link at end of body, pattern-matching website in body: Reduce Snoring Sounds with SnoreFIX by justiafreese on askubuntu.com
[ SmokeDetector ] Bad keyword in body, bad keyword in title, link at end of body, pattern-matching website in body: Allegro Anti Aging Cream by user567320 on askubuntu.com
 
tim to play paper mario
 
Tim doesn't like paper or mario
 
;p
 
Hi @Serg, nice! if a may do a few suggestions: If you use zenity, you can simply use:
try:
    [zenity command here]
except subprocess.CalledProsessError:
    do this
else:
    do that
If it will exit non zero, "this" is done
Also:
p = subprocess.Popen(cmd, shell=True, stdout=subprocess.PIPE)
...is kind op old fashioned, that's what we have
subprocess.check_output()
for. finally, if you run a programm or simple command to run an application, simply:
subprocess.Popen()
...will throw out the command, while:
subprocess.call()
will wait for it to finish. if you use the first one, but not like via run.sh, it should work.
shell=True
is not the nicest to use :)
 
6:07 AM
@JacobVlijm so Popen just spawns the process and moves on to the next line in code, correct ?
 
@Serg exactly
 
OK , I'll edit that into the code.
 
anyone knows how to update directx?
 
@edwinksl I suspect he did it on purpose to get attention :)
 
6:12 AM
definitely got mine :)
 
@edwinksl he also got a "gest" account now :)
 
[ SmokeDetector ] Bad keyword in body, blacklisted username, link at end of body, pattern-matching website in body: for reinforcing the measure. Solidifies a combo of three utilising ahead by Mullinjuriya on askubuntu.com
 
Oops, having issue ,
  File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1340, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
 
IRC is so useless these days.
 
[ SmokeDetector ] Bad keyword in body, bad keyword in title, link at end of body, pattern-matching website in body: Is EF13 Muscle Supplement safe? by Susanmatsuza on askubuntu.com
 
6:15 AM
raise child_exception
@Serg you have children?
 
@JacobVlijm I have a girlfriend, but we haven't had sex if that's what you mean
 
raise child_exception
...is what I meant :)
 
I forgot shell=True
now it werks
 
[ SmokeDetector ] Bad keyword in title, blacklisted website in body, link at end of body: Become A Muscle man With Ripped Rx No2 Blast by rikeinsmilrie on askubuntu.com
 
....If you use python -like commands, you shouldn't need:
shell-True
 
6:18 AM
@JacobVlijm what would be example of use that try . . .except . . . with zenity ? Do you have any answers where you've used it ?
 
Let me see...
 
game over!
 
try:
    arg = get('zenity --entry --entry-text "30 30 30 30" --text "border left, right, top, bottom" --title "Screenshot margins"').strip().split()
except:
    pass
else:
    time.sleep(0.5)
    # frontmost window pos
    frontmost = [l.split()[4] for l in get("xprop -root").splitlines() if "ACTIVE_WINDOW(WINDOW)" in l][0].replace(",", "")
    frontmost = frontmost[:2]+"0"+frontmost[2:]
    f_data = [l.split() for l in get("wmctrl -lG").splitlines() if frontmost in l][0][2:6]
    # extent
from here: askubuntu.com/questions/578728/… for example @Serg
...I see I need to edit (improve) that one though due to new insights...
...and the except should be "except subprocess.CalledProcessError" what was I thinking?
 
@JacobVlijm you could improve it even further with zenity --forms dialog , where you can have separate text box for each option ( top,bottom , left,right )
 
6:33 AM
@Serg right! I once made a Gtk version, but never uploaded it to LP
 
Hello guys
May I ask a question?
 
you may ask , but we're not guaranteeing an answer
 
I'm trying to mod a game, and I need to replace this string of text in 60 files. The string is " f_RequiredInitialSpace="1" ". I tried some common tools
but they erase all text after this string and I don't want that
I'm using the this open source tool : findandreplace.codeplex.com
and I search using f_RequiredInitialSpace=".*"
then I replace for f_RequiredInitialSpace="1" . But all text after it is erased for some reason. Is there any tool or something easy that I can use do that?
Each file has a different number between the " " so take that into consideration.
 
OK , so you have line that starts like f_RequiredInitialSpace= ( whatever that is ) and you want to change it to f_RequiredInitialSpace="1"
Correct ? @Freedo
 
Yeah
Idk how to say this clearly but it's not a line for every string. They are mixed with other text
 
6:43 AM
so basically remove the dot?
 
A example :
b_Graminivore="true" b_Radicivore="true" b_Folivore="true" s_KeeperEatType="Terrain_Branches" b_LargeAnimal="true" b_SubstratePileEater="true" b_TroughEater="true" b_MetalTroughEater="true" b_FoodDishEater="true" s_KeeperDrinkType="FoodDish_Water" f_adoptRemoveTime="0" f_adoptRarity="80" s_Zoopedia="zoopedia:zoopedia_Ankylosaurus:entry" f_RequiredInitialSpace="480" f_RequiredAdditionalSpace="80" p_PursuitBallNode="0 -3 180"
 
sed -i 's;f_RequiredInitialSpace=.*;f_RequiredInitialSpace="1";g' FILENAME
oh , wait
Yeah, that could work
Just give list of files to that command
 
they are in a folder. it's 60 different files
can I put the path on FILENAME?
 
0
Q: lost folder from /mnt and recovering

Ruwan RanganathI'm running Ubuntu 14.04.2 LTS (GNU/Linux 3.13.0-48-generic x86_64) on Amazon AWS. I had a folder "foo" in the /mnt and after few modification I had to recover to previous backup of the instance . after restore "/mnt/foo" folder is missing , however when I tried "locate foo" it showed me on in ...

 
> "And no, it’s not a VirtualBox session running in seamless mode; it’s the real Unity desktop running on Windows 10 using the Windows Linux Subsystem (WLS) that’s available to developers running the latest builds of Microsoft’s OS." - OMG! UBUNTU!, This Is the Unity Desktop Running On Windows 10
2
 
6:49 AM
@Freedo you want to change all the files in that folder ? Or are there some files you don't wanna change ?
@blade19899 yup , saw that today . Awesome, but at the same time . . . .WTF
 
@Serg Why would anyone want this to work on Windows.
 
@blade19899 developers . . . Also , Window's probably is trying to say "Heeey, why would you want to switch from our OS to Linux, when we have Linux right there !!! "
 
7:05 AM
@Serg eh, still a bit of a hack, and works the same way you did with colinux
user image
4
 
@serg
@Serg all files
 
@Freedo btw recursively or in a flat dir?
 
flat dir. only have the files i want to change on it
 
ok, imma sketch up something
Something like that. Make sure to adjust stuff according to your needs
Also , run it first without -i option in sed , see if that does help
@Freedo frankly speaking, it would be better if you posted an actual question on the site , instead of doing everyting in chat
 
@Serg thanks so much! I'll open a linux box here to try it
Would that work on cygwin?
 
7:21 AM
@Serg As all files are in the same dir, can't you just omit the "find" and use a * glob for sed?
 
@Freedo I think it would, but not sure. I use Ubuntu typically, so don't have Cygwin to test this on at the moment
@ByteCommander You probably could . I personally just don't like using glob
 
Yeah, why doing it the simple way...
;-)
 
have we not established serg is a masochist
 
# find... while loop, requires find (-print0) and shell (read -d) extensions.
 # Fails on Cygwin; in while loops, filenames ending in \r \n and \n look =.
 # Variable values may be lost unset because loop may run in a subshell.
 find . -print0 | while IFS="" read -r -d "" file ; do ...
   COMMAND "$file" # Use quoted "$file", not $file, everywhere.
 done
@Freedo won't work on Cygwin
 
find is a tool sent from the heavens.
 
7:24 AM
It sure is !
 
find(1) is an extremely useful command for shell scripts, but it's very poorly understood. This is due in part to a complex syntax (perhaps the most complex of all the standard Unix commands that aren't actually programming languages like awk); and in part to poorly written man pages. (The GNU version's man page didn't even have examples until late 2006!)
 
Mails are oldskool. KDE devs use true telepathy to communicate.
@edwinksl Yup, it took me a while to get the grip on it.
 
Here is one of my most used find fu.
 
@ByteCommander @edwinksl but once you get grip of it, you can do a lot of fun stuffz with et
 
7:27 AM
This is a find in files command:
> find /var/log/ -type f -exec grep -IiE '(error|warning|failed)' --color=auto {} \; -print
 
Nice
 
@Serg Yup, but I still use sudo updatedb && locate more often, it's usually faster if you really search a file by its name.
 
grep --color=auto -iR 'error\|warning\|failed' /var/log
@blade19899
 
^ that.
 
Sort of the same
 
7:30 AM
And grep --color=auto should already be aliased to grep in Bash.
 
@ByteCommander it is aliased in my .mkshrc but it doesn't get colorized if I have custom args there
Ooops, nevermind , it's not aliased there
 
what is mkshrc?
Don't you use bash?
$ grep grep .bashrc
    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
 
@ByteCommander it's rc file for mksh shell . . . .And yes, I use mksh as my interactive shell. Although I do write bash scripts :)
 
And what does mksh do what Bash does not do?
 
hello o/
 
7:34 AM
nothing special , it's kind of between ksh and bash in features . It misses some features
@edwardtorvalds that was fast
 
MirBSD Korn Shell...
 
@ByteCommander I have multiple servers, not all the same distro., not all the same bash version.
 
0
Q: Remove component from remository

IlyI have debian repository like this: repo1 -distrib1 -main -contrib -disctrib2 -main -contrib How can I remove component contrib from all disctributions?

 
7:36 AM
I have two ethernet cable connected to my computer I want to use internet from second cable but I cant what to do to set second ethernet as default?
 
@Serg Speaking of Korn:
(music starts at 0:20)
 
oops there is a spelling mistake in this video :-p
 
@Serg I didn't worked for some reason on my ubuntu
Could be because I opened the terminal inside the folder already so I didn't used /path
?
 
@Freedo Then use . (single dot) instead to reference the current directory.
 
7:41 AM
who got selected to be AU moderator?
 
But yeah, Korn are awesome
@edwardtorvalds terdon and ThomasW.
 
@Freedo well it shouldn't matter , because you provide full path to directory anyway. What's the actual directory path that you have there ?
 
is there any command line way to set preferred netowrk?
 
@Freedo the question is easy, but should really be posted as a question
 
7:49 AM
@Serg Currently listening to this web radio station: 91.250.77.9:8220 (can be entered as streaming URL in Rhythmbox).
 
@ByteCommander rockhaus radio ?
 
This is when I need to find a php fiel that might be using php shorttags, on a server that does not support those.
> find /var/www/html/ -type f -name "*.php" -exec grep -ni "<?=" --color=auto {} \; -print
 
@Serg Exactly. It's a German station.
 
Freakin subprocess.check_call doesn't read last parts of zenity's command list
duck !
 
@blade19899 grep -R --include '*.php' -ni '<?=' /var/www/html
 
8:04 AM
I am so confused
Now it doesn't list .desktop files
what the duck is going on ??
 
@Serg because of the ' and " you mean?
 
try:
 79         filepath = subprocess.check_call(
 80                    [ 'zenity', '--file-selection',
 81                    '--file-filter="*.desktop"',
 82                    '--filename="/usr/share/applications/"' ] )
 83     except subprocess.CalledProcessError:
 84         sys.exit(1)
@JacobVlijm This opens in my git repository folder
 
@ByteCommander grep feels slightly faster then find.
 
@Serg yeah, the fiddling around with the quotes :) I remember that's why I used "/bin/bash -c "command", to get rid of having to think about it :)
bad, very bad... but easy
Why not use check_output() btw?
 
@Serg @JacobVlijm Seen askubuntu.com/q/797614/367990 already?
 
8:10 AM
@ByteCommander yeah, I don't have a bright idea yet :(
 
@JacobVlijm could use that one too , but i am trying to catch exception that would be raised if user closes or cancels the dialog
 
check_output() does
 
@JacobVlijm use that shutter script that you mentioned earlier. Probably you could take a screenshot of screen relative to the screen
current screen i mean
 
@Serg we think alike, bet then?
 
Here is something grep can't do:
> find /var/www/html/uploads/ -type f -exec du -hs {} \; | sort -rh | head
 
8:13 AM
@JacobVlijm hehe, i am just throwing out a suggestion
 
Find the top ten largest files in a folder.
You can add -name "*.mp3" to be specific.
 
@Serg He, we could make it appear as a notification, updated once per 10 secs :)
 
yeah, grep cannot do file size check , kek
@JacobVlijm use pynotify and put screen shot as icon ? Hm, could be done .
would need to dig documentation on pynotify though
 
Why does gedit not open with the specified geometry?
I run 'gedit -g "800x600+0+0"', but it always opens with the last window size, not the specified one.
The offset (+0+0) is applied though, only the window size is ignored.
 
@Serg I guess Freebee is not posting a question...
 
8:23 AM
kek , Freebee
 
...Frodo
 
@JacobVlijm About that preview question. How about using xdotool to temporarily switch to viewport OP wants and then teleport back ? Wouldn't that count as simple preview ?
 
@Serg we might get claims is het is epileptic :)
 
hmm , yeah , that might be problematic
 
8:29 AM
Annoying isn't it?
 
Eh, there's people with special needs in the world. we gotta deal with that
 
8:55 AM
@AndroidDev Yeah, please don't ping mods for things the community can deal with. If you've voted or flagged to close, there's no reason to call in a mod.
 
9:12 AM
@JacobVlijm any luck with that viewport screenshot question ? shutter -s doesn't let me take screenshot of what's not on the currently active viewport :/
 
9:23 AM
@Serg yeah, I don't see it happen...
 
hmm here the OP solved their problem and edited to include the solution instead of Answering Their Own Question askubuntu.com/questions/783587/… I left a comment but they have not visited for a loooong time
 
@JacobVlijm shutter actually does have option for capturing compiz workspaces though, but what it does is also switch workspace, capture, then switch back :/
 
@Zanna If they don't you can just post the answer yourself. Remove it from the OP and post it as a CW answer.
 
Dammit, I keep pressing A to append like I do in vim . . . except Ia m doing it on AskUbuntu while writing answer
 
@Serg And for that, we don't need Shutter :)
 
9:27 AM
@JacobVlijm gnome-screenshot can capture specific geometry ?
 
hmm, I'm not sure what to google - and wondering if someone could please point me in the right direction (very new ubuntu user). I've connected to a redshift database, and am trying to copy some information from the redshift database to my ubuntu machine. However, I'm getting the following error...
Copy (Select * From appt_booking_info limit 10) To '/home/sean/Documents/postgres_data/test.csv' With CSV delimiter ',';
ERROR: syntax error at or near "("
LINE 1: Copy (Select * From appt_booking_info limit 10) To '/home/se...
I'm not sure if this is an issue with ubuntu (permissions?)
or with redshift (my copy command is incorrect...)
 
       -a, --area
              Grab an area of the screen instead of the entire screen.
 
@Zanna I read on your profile that you are a vegan?
 
@Serg ^ two floors up
 
@JacobVlijm yup, but that switches to using pointer, and no specific geometry , right ?
 
9:31 AM
Ah, sorry, but there are other ways, I once used scrot+imagemagick to get an area on Lubuntu, worked way faster then all other ways I know
4
A: Taking screenshot of a specific area from the command line

Jacob VlijmIn Lubuntu, you can do exactly what you want: take a screen shot from the command line with the command: scrot_extended 100 100 400 400 using the script below. The four arguments are <x>, <y>, <width>, <height>. I didn't have the chance (yet) to test it in Lubuntu 12.04, but it seems unlikely...

 
@terdon thanks :) I'll keep an eye on it and make a CW if nothing changes today
@andrew.46 yep, it's not a lie, I am vegan
 
@Zanna May I ask why?
 
more ways for cat skinning
 
9:50 AM
@Zanna Then there are 2 of us in the room :)
Always good to meet a fellow believer...
 
@terdon certainly you may and I will answer
1. I don't think it is good to kill creatures without need & I consider modern agricultural practices in my own country to include torture of animals
2. animal agriculture had a large carbon footprint (larger than all transport globally)
3. it is beneficial for health to eat a plant based diet (according to research & my experience)
@andrew.46 :) <3
 
@Zanna OK. But those are reasons to be vegetarian, not vegan. (And 3 is far, far from certain, but never mind).
Do you eat bread, for example?
(Feel free to ignore me, I've just never been able to understand veganism and I'm curious)
 
@terdon I think being an (ethical) vegetarian makes little sense, considering the practices of the dairy industry. Dairy cows are tortured in my opinion, and male calves are usually killed at birth...
 
guy
 
9:57 AM
I rarely eat bread... why do you ask this, particularly?
 
@Zanna yeast. I always wonder where people draw the line. What constitutes an "animal". How about chicken eggs? Say free range chicken eggs collected by your grandmother from the hens in her back yard. Would those be OK?
 
@terdon yeast is not an animal, it's fungi (not in animal kingdom: 5 kingdoms = animals, plants, fungi, protoctista, prokaryotes (bacteria)). It is a single celled organism far less complex than any plant. It does not have a central nervous system and cannot experience distress :)
 

« first day (2113 days earlier)      last day (1293 days later) »