« first day (2112 days earlier)      last day (1361 days later) » 

12:04 AM
Does anyone know how to get analog loopback working with Intel audio?
I have a piano connected via line-in and I have loopback enabled in alsamixer but I can't hear anything.
Audacity can record the audio and I can play it back.
But no live loopback.
 
ah the fun of trying to run something in a container that is root that dosn't have sudo, and everything making assumptions about the environment...
 
docker container?
 
libertine
so far I have been able to edit out the "sudo" and checks for being root in the scripts ;)
It probably won't work, but I'm installing this on my ubuntu tablet - github.com/MycroftAI/mycroft-core
although I'm not sure if the container can access the mic in any way?
huh
it double posted, then I deleted one of the messages, both gone?
 
it shows one gone
 
strange
I saw two for a sec...
 
12:18 AM
javascript
 
anyway, saying it might just work if sound was made to work
 
12:31 AM
might need a sd card, running out of spase with these containers
 
0
Q: how to configure WIFI on debian (wpa_supplicant and WICD)

Jenia IvanovI installed Debian and found that WICD doesn't when connecting to my WIFI. Specifically, it says Validating Authentication and finally not connected at the bottom of the WICD window. So after a long battle I changed /etc/network/interfaces to this: # This file describes the network interfaces a...

 
@NathanOsman something like alsaloop commandline tool
 
Wut.
Here's the two commands that got it working:
sudo alsactl kill quit
sudo alsactl init
Super weird.
 
huh
needed to be restarted?
aw, looks like this script is compiling stuff... this will take awhile
 
12:52 AM
o/ hi chat
 
aw
guess it isn't close enough to a real system...
 
what up serg
 
1:09 AM
hmm getting a gpu lockup in ubuntu (latest ver) any suggestions?
 
what gpu?
 
graphics card lockup
might be because of amd... O_o
for ubuntu's sake amd
FOR UBUNTU'S
mmm, drunklisious.
 
@edwinksl @Serg without telling me the solution, can you look at my script and tell me what i do wrong syntactically? paste.ubuntu.com/19035637
 
1:24 AM
i got a MemoryError when i ran your code
 
yeah and pycharm outputs only the adress of the genrator object to me
uh i guess that list is a bit big
mhmmmm seems I have to try a different approach
is there a sizeof function in python ?
 
len?
 
na, in c++ sizeof returns the bytes for a data type
example: typeof(int) returns 4
think i simply need another approach
 
@ParanoidPanda I'm in tears
and the subtle Linux product placement, nice
 
1:45 AM
yep the sieve runs into MemoryError, I guess its simply to big
 
These Angry Birds Toons are great
 
anyways the script as well does not return a full list of prime factors of the smaller number
so its wrong anyways
 
guys, can I get the sha256 fingerprints using ssh-keygen?
I need to compare the one I got with a sha256 fingerprint :/
 
2:01 AM
@Videonauth. Can't point out what is wrong but consider using sieve of Eratosthenes. There's plenty of solutions online. I'll keep looking at it, but my Mind isn't clearest right niw
 
well it is a sieve of erastotenes and then i try to factorize
but for the number i want to calculate i run out of memory
 
ooo, this could be a game changer:
guess what that is
 
A cable clip ?
 
hm
maybe not what I though it was
 
what is it ?
 
2:10 AM
a bag sealer
 
well i wasn't far of with my guess :P
 
I was thinking it was to press down on ziplock's, looks more like it will hold a rolled bag
we will see...
if it isn't I will have some chip bag clips, and will have to design my own because I'm not really seeing anything existing what I want to do
although this would be the next step up - associatedbag.com/… was really wanting something hand-held and inexpensive
 
mhmmm for what use you want it ?
 
closing many bags ;)
 
ok sec
images-eu.ssl-images-amazon.com/images/I/… and a firm surface is the quickest
its normaly meant for tapestry
 
2:26 AM
not bad - some have tried a spatula, but it is also food safety so needs to be something more purpose built
anyway getting off topic ;) but thanks for the help
 
ah ok, well when have we been really on topic in here ?
 
true
 
as long im on the site not often ;)
@serg i found a solution but it is not very elegant
just looked through the solutions posted
 
so, was kind of thinking something like this:
hold like tongs and slide through
 
2:32 AM
if you have a 3d printer print it out and test it if it works
 
that is the other problem
I might think it out and send a few to shapeways though
 
:) well there you got me in a field i know really lots about, im a trained cnc technican
:)
 
cool
 
rapid prototyping ot 3d printing i think is the pastest way to test if a design works
 
yeah, I need to get at least a makerbot or something one day
 
2:36 AM
and cheaper as if you produce it on the conventional way
 
the 3d-doodler is nice for fixing some things, it might work for this project if I make something similar to that pic
I have one of those
maybe use some existing flat pieces for the important part ;)
 
._.
Roll up the bag top + rubber band works ;p
 
yeah, I think everyone else is going full on heat sealed...
If I do make one I'll put some ubuntu stickers on it to be somewhat on topic when pictures are in here ;p
 
that thing is trending on my facebook too
 
3:13 AM
0
Q: Help needed with Raid 5 that was working OK

AndrewMy parents had a Netgear RN 104 that stopped working properly, they messed with some settings, messed it up and gave it to me to fix. It has 4 x 4tb drives in Raid 5. I've used mdadm before to recreate a very simple Raid array, so I connected all 4 drives to my computer, installed mdadm in Ubuntu...

 
Prototype so far:
Complete with Ubuntu logo ;)
Looks like it will work with some tweaks
 
3:48 AM
what is that ?
 
something I'm trying to make
to close zip bags
 
Where is the proper place in the filesystem for a Python web application?
/opt? /var/[app]? Something else?
 
I found some in /usr/local/lib
but I don't think that is proper as far as I can remember
 
@NathanOsman why not in /usr/bin ?
 
That's for executable files.
Not web applications.
 
3:59 AM
I think they want stuff in opt now
sublime is there
 
ubuntu people
 
I'm not worried about them :D
I want to do the correct thing according to the FHS.
 
119
Q: What is the best place to install user apps?

citadelgradOccasionally I am installing application with something other than apt-get or the Package Manager. What is the "best practice" location for installing user apps? (/usr/bin/, /usr/local/bin/, /opt/, etc)

 
Yes, but this is a web application.
There are no executable files.
It's just Python scripts.
 
4:03 AM
slap a desktop file in there ;)
 
It's for Docker, not a snap :D
 
4:14 AM
This is hilarious.
So they uploaded the code for the Apollo 11 mission to GitHub: github.com/chrislgarry/Apollo-11
2
 
@NathanOsman who do you run it as?
 
And this bug is full of gold: github.com/chrislgarry/Apollo-11/issues/3
3
@JourneymanGeek The web app or the Apollo 11 source code?
 
I tend to stick em in the home directory of a user I create to run it
@NathanOsman yes,
The former
 
It's running as root.
(It's in a Docker container.)
 
er. eww eww eww.
oh
 
4:15 AM
Yeah, no I don't generally run stuff as root :D
 
still ewwish.
 
But it's okay in Docker since the container is isolated from the host.
It's like a lightweight VM.
 
but its a docker container, who gives a shit? ;p
@NathanOsman but if someone gains control of the docker container...
or something.
 
The container filesystem is readonly.
If someone compromises it, I just restart the container. Bam. Everything is the way it was before.
 
AFAIK user has to be in docker group to do anything, Right?
 
1
Q: How to Configure CGI in Ubuntu?

user5499177I am very new to Apache in Ubuntu. I recently installed Apache2 on Ubuntu and I am trying to configure CGI. I added the following lines in apache2.conf file: ScriptAlias /cgi-bin/ /home/router/cgi-bin/ <Directory /home/router/cgi-bin/> Options ExecCGI AddHandler cgi-script cgi pl

0
Q: Dual boot Linux on Windows 10

ToneLaRosaI just burned Ubuntu 16 to a CD. Is this considered dual booting since I can go back and forth to Windows and Ubuntu?

 
matt damon needs to be saved!
PR needs to get merged asap
 
Look what whois google.com brought up
   Server Name: GOOGLE.COM.SUCKS.FIND.CRACKZ.WITH.SEARCH.GULLI.COM
   IP Address: 80.190.192.24
   Registrar: COREHUB, S.R.L.
   Whois Server: whois.corehub.net
   Referral URL: corehub.net
there's whole bunch of domains like that
 
5:06 AM
[ SmokeDetector ] Bad keyword in title, link at end of body, link following arrow in body, pattern-matching website in body: The Simplest Way To Create Chest Muscle? by Perreatdre on askubuntu.com
 
5:16 AM
lol how did you encounter them in the first place
 
5:30 AM
@edwinksl I just . . . . typed whois google.com . . . .It basically looks up all registered domains and apparently there are some funny domains registered that start with google.com
I am actually going to be working on a script that will generate info on all IP address that has established connection with my laptop
Just in case I ever wanna find out who's looking at my p0rn
On a side note, anybody has a laptop ? I need helpz testing somezing
find /sys/devices/  -type f -iname "type" -exec grep -l -i 'battery' {} 2> /dev/null +
 
Heya! o/
 
\o hello mr. BC
 
   Server Name: GOOGLE.COM.SPAMMING.IS.UNETHICAL.PLEASE.STOP.THEM.HUAXUEERBAN.COM
   IP Address: 211.64.175.67
   IP Address: 211.64.175.66
   Registrar: GOOGLE INC.
   Whois Server: whois.google.com
   Referral URL: domains.google.com
 
i haz lappy
 
We should link to that one from now on ^
 
5:38 AM
/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT0/type
@Serg
 
(does not work though)
 
@ByteCommander yeah, i saw that one , lol'able domain
@ByteCommander do you have a laptop ?
 
[ SmokeDetector ] Bad keyword in title, link at end of body, link following arrow in body, pattern-matching website in body: Building Muscle Tissue Quickly Without Steroids? by ClintMckaye on askubuntu.com
 
   Server Name: GOOGLE.COM.LOLOLOLOLOL.SHTHEAD.COM
   IP Address: 123.123.123.123
   Registrar: CRAZY DOMAINS FZ-LLC
   Whois Server: whois.crazydomains.com
   Referral URL: crazydomains.com
xD
And that IP address...
 
5:40 AM
Notbad.png , trolling level over 9000
@ByteCommander find /sys/devices/ -type f -iname "type" -exec grep -l -i 'battery' {} 2> /dev/null +
Does that give you only one file name ?
 
ARGV
I'm attacked by a fly.
 
fsck
 
sudo smack_that
 
Getting out the fly swatter for a counterstrike... >:/
 
wait, that came out wrong XD
 
5:42 AM
Hm?
$ find /sys/devices/ -type f -iname "type" -exec grep -l -i 'battery' {} 2> /dev/null +
/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:18/PNP0C09:00/PNP0C0A:00/power_supply/BAT0/type
 
i am confuciused
 
To many PNP... folders for my taste...
 
Well, I have to use those thingies, because in /sys/class directory there's waaaay to many symlinks and it breaks find command
I think i'm going to post another version of that battery script , to automate finding the BAT device, because it can either be BAT1 or BAT0 , but i probably will do it in python , to make it moar challengang
 
i don't understand why noobs keep having /usr/local/bin/python. do they really need to install their own pythons? :/
 
@edwinksl it has to be installed on Windoze so they probably assume they need to do the same on Ubantu
 
[ SmokeDetector ] Link at end of body, pattern-matching website in body: With this particular one-time by user566911 on askubuntu.com
[ SmokeDetector ] Manually reported answer: Envy 4500 printer not scanning by user231054 on askubuntu.com
 
serg is always right :)
 
[ SmokeDetector ] Manually reported answer: Envy 4500 printer not scanning by SEO Ganesh on askubuntu.com
 
lol SEO
 
#SergIsRight
3
Meawhile, today I am lurking on 2ch.hk/b/ , it's russian chan site
Aaaand watching videos about deep web :p
 
6:09 AM
so basically just a regular night in colorado
 
basically , yes
 
i wonder if how the number of bash scripts written by serg compares with number of python scripts written by jacob
 
probably I'm lagging behind, since Jacob has been on this site for 3 years, way before i came around
Also, he slightly wins in quality.
 
6:36 AM
0
Q: nvidia-prime doesn't disable intel video card

datafile4Elementary OS Freya (ubuntu 14.04 x64), nvidia-355 proprietary driver from ppa:graphics-drivers/ppa. cat /proc/acpi/bbswitch returns 0000:01:00.0 OFF When in nvidia-settings Intel enabled. But powertop returns 100,0% PCI Device: NVIDIA Corporation GF119M [GeForce 610M] I tried ...

0
Q: How to make display all the environmental stored in my unix?

Ganesh DogiparthiIs there any command to display all the Environmental variables stored in my unix?

 
10.04 ._.
 
@Serg @Serg, I just coincidentally read that. I think we are both creative persons, but with you the priority is more towards being creative. People write according their personality. Your priority is finding new ways, which you do. On a sub consious level you accept the fact that every now and then a script might not be totally practical, for the sake of the new found method(s).
With me the balance is slightly different. Different, but you cannot say which is better. Both are needed. This is my honest opinion.
 
Very interesting . I never considered creativity as my strong trait, but to some extend you're right - I like finding new ways of doing things.
 
6:58 AM
-3
Q: Is there an operating system named Linux

jaihow can install xampp in Linux ubuntu 15.10 with 32 bit operating system

 
Jos
guys, what is a bash command that does exactly nothing?
Let's say I have a script if [[ xxx ]] then echo foo else echo bar but I decide I don't want to see foo, only bar. I can't just comment out "echo foo" or bash will complain.
I could do echo foo > /dev/null but there must be something more elegant for this situation.
 
You're looking for :
It basically same as true
DIR:/xieerqi|01:03|skolodya@ubuntu:
$ :

DIR:/xieerqi|01:03|skolodya@ubuntu:
$ true

DIR:/xieerqi|01:03|skolodya@ubuntu:
$
Or just reverse your if statement
 
Jos
Yep, that works
 
What is xxx supposed to be ?
a string ?
 
Jos
it's a string comparison, yes
checking if the router is there.
Thanks. Didn't know that : was a valid command. Of sorts.
 
7:05 AM
You can do something like this
if [[ "$USER" != "admin" ]] ;then  echo  "Not admin" ; fi
Not admin
 
Jos
Sure
 
[ SmokeDetector ] Bad keyword in body, pattern-matching website in body: Why Academic Essay Writing Is Very Important To The Students? by Barryd Pearce on askubuntu.com
 
8:01 AM
Congratulations on reaching 2K rep, @Zanna!
 
thanks ^_^
I lost some rep last night from going over the limit :( but a random upvote on a old answer pushed me over 2k at 14 minutes past UTC midnight ^_^
 
@Zanna if you mean the 200 rep ber day limit, it's not lost, it just rolls over to the next day
 
@Serg @Zanna I am afraid not, if you go over 200, it is lost :( accepts and bounties are excluded however.
 
@Serg oh really? I didn't get it yet... counting the upvotes from yesterday, some has gone missing
thanks @JacobVlijm :) I better read meta SE to find out the reason for this limit
 
@Zanna ask Seth or another mod to review your profile. At least in my case, I never lost upvotes, they just arrive next day :p
 
8:12 AM
@Zanna it is obvious, the site wants people to mature on the site before they have power by rep.
 
( by never lost , i mean the 200 rep limit , i did loose a lot during the Great June Purge )
 
@Serg That must have been a recalculation because of downvotes
...The 200 (excluded accepts and bounties) stands.
 
@JacobVlijm thank you for explaining, it is clear
 
8:25 AM
Does anybody know a better alternative to the command below for exactly matching a multiline block (content of file1) in file2?
grep -aof <(tr '\n' '\0' < file1) <(tr '\n' '\0' < file2) | tr '\0' '\n'
I'm talking about this question on U&L.
 
@ByteCommander grep is probably not the most suitable tool since that's a line matching utility , let me see what i can do with awk , and i'll let you know
 
@Serg There is already an awk answer: awk -v RS="$(<file1)" '{print RT}' file2
No idea what that does though.
Okay, tank time!
 
@ByteCommander it does kind of the same as what I had in mind . . . assign the contents of file1 as record separator variable. Then prints RT which is record terminator
 
Sounds AWKward.
(had to use that opporTUNAty)
 
There's no PUNishment for that
 
8:33 AM
I better go drive some tanks now...
... while listening to heavy metal on the web radio of course.
 
@ByteCommander found better solution with grep , but i cannot read it from filie
i mean file1
 
Tell me?
 
@ByteCommander pcregrep
 
$ grep -Pzo "A B\nC D\nE F"  file2.txt
A B
C D
E F
well , maybe -P was overkill
 
But you must read from the file.
 
8:41 AM
that's my main problem !
 
@Serg That will match the entire file though, as long as the pattern is found, the whole file will be printed.
 
well, that . . .results in this:
grep -zo "$( cat  file1.txt)"  file2.txt
A BE FA BC DE FG HG H
@terdon well that file is multi-line and it prints out things properly i , it doesn't print the whole file
 
@Serg No, it doesn't. I completely missed the -o
 
my big problem is how can i read pattern from file :/
@terdon any idea on how can i turn A B\nC D\n into A B\\nC D\\n ?
 
$ perl -pe 's/\n/\\n/' file
A B\nC D\nE F\nG H\n
@Serg ^^
 
8:55 AM
@terdon Why perl and not simply sed?
 
@ByteCommander because:
$ sed 's/\n/\\n/' file
A B
C D
E F
G H
 
@ByteCommander sed works on lines , so it's a bit more messy
 
You need to do some acrobatics to do that with sed
$ sed ':a;N;$!ba;s/\n/\\n/g' file
A B\nC D\nE F\nG H
So not very "simply" with sed at all.
Egad but I hate sed syntax.
 
that didn't help , by the way
 
Oha.
What about sed -z?
 
8:59 AM
@Serg I didn't really expect it to. I was wondering why you wanted that.
@ByteCommander Oh, true, GNU sed can do that. Still, it's no simpler or faster than perl
 
I have perfectly nice working grep solution for multi-line match, problem is that i cannot get pattern from file !
 
(or if he's asleep, FREE FLAGS!)
 
@JourneymanGeek poof
As in "gone" (to avoid confusion)
 
understood ;p
 
9:11 AM
There's always pcregrep:
$ pcregrep -Mf file2 file
A B
C D
E F
@Serg @ByteCommander ^^
 
Must be installed first though.
I prefer on-board tools.
 
well , ain't nothing to do here . Show's over folks
 
@ByteCommander True. Also, that one won't actually work. It takes each line as a separate pattern.
 
9:25 AM
:-/
 
welp, my solution goes out the window i guess
i cant read damn file1 into pattern
 
@Serg this might be it:
$ grep -Pzo "$(perl -pe 's/\n/\\n/g' file1)"  file2
A B
C D
E F
G H
 
@terdon doesn't work for me :/ no output
 
9:40 AM
@Serg What are your input files?
 
$ cat -A file
file1.txt  file2.txt
$ cat -A file1.txt
A B$
C D$
E F$
G H$
$
file2.txt is same as OP's
Two newlines
that's it!
 
What are all those $ doing there?
Oh, cat -A
And yes, the two newlines would do it
 
@terdon posted the answer with honorary mention :)
 
Cool :)
No need to mention the catch, that's no catch, it's normal. If the contents of file1 aren't present in file2, they won't be found. That the extra characters happen to be invisible to humans is irrelevant.
 
nah, it's better be mentioned, otherwise someone will be back saying "This doesn't work" and I'll be thinking well why it's not right if the file is correct. . .
it's 3:49 AM . . . i said i won't be staying up tonight . . .
gosh
 
9:56 AM
0
Q: When I 'improve [an] edit' suggested by a <2k user, do they still get +2 reputation?

ZannaAs of today I am allowed to review suggested edits ^_^ I'm reading lots of posts here to help me do a good job. I can be absent-minded and I'm certainly not immune to typos, bad formatting decisions, or omissions myself, but when reviewing I am doing my best to be focused and critical, so I am ...

 
@AskUbuntuMeta yes
but how did you get 2k? I don't remember you being that close to the milestone.
 
thanks! is that a pointless question? should I just delete it?
how did I get 2k... lots of work-avoidance yesterday!
 
Don't have to delete the question. I don't think many people would actually know the answer.
Work on Sunday? SadFace
 
@Zanna Well done!
I guess... ;)
 
@terdon thanks! @jokerdino it's the crunch, 4 more days and I can resume my life from suspend :)
 
10:13 AM
Ah. hang in there.
 
:)
 
10:34 AM
@ThomasW. Have you ever read this book and what would your suggestion be on getting or not getting it . I mean, is it going to be generally beneficial for learning python via pentesting book ?
 
0
Q: Warning because addgroup tries to create an already existing user group

Huw EvansI am trying to run the command dpkg --configure -a in order to fix dpkg so I can apt-get programs. I get the error addgroup: The group 'systemd-journal' already exists as a system group. Exiting. This apparantly coresponds to the following bug. https://bugs.launchpad.net/ubuntu/+source/syst...

 
11:05 AM
@Serg How well do you know Python? That book is for the intermediate-level - if you don't know Python then the book won't help (mind you I haven't read the book)
 
@ThomasW. been doing data structures ( stacks, linked lists, dijkstra's algorithm,etc ) , some scripts here and there on AU . I don
I don't quite know my level tbh
But I am looking for ways to bump the level up
5:10 AM
 

« first day (2112 days earlier)      last day (1361 days later) »