« first day (1770 days earlier)      last day (1660 days later) » 

10:00 PM
@ParanoidPanda Maybe you can put 14.04 on yours and test!
:P:P:P
do the above command and give me the last line of output.
 
@Serg No change after sudo aptitude reinstall apt and reboot... :-(
 
@ByteCommander He's gone for a smoke...
 
Im here
 
Ha! >:)
 
On mobile and smoking
 
10:02 PM
@Serg that's what it looks like to me, but I'm unsure!
@Serg :D:D:D
 
So I guess we won't finish that issue today any more?
 
As the bloody panda is super-slow, I'm going for a smoke
 
But it seems to successfully load the package indexes, but does not complete any other task...
 
Panda try pkill apcid and then sudo service acpid restart
 
Because I can still run apt-get upgrade, install, ...
 
user136984
10:03 PM
@Fabby: The last line of output is: [ 10.744314] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input7
 
user136984
There was quite a lot of output though.
 
@ByteCommander so only update gives you trouble ?
 
Yeah, it's a tricky issue. I don't have any ideas
 
user136984
@Serg: There was no output, so it seemed successful.
 
10:06 PM
so can you suspend now ?
 
user136984
@Serg: But doesn't seem to have changed much, if anything.
 
user136984
Nope.
 
:/
 
Okay, then thanks to all and good night.
 
user136984
@ByteCommander: Goodnight! :)
 
10:07 PM
good night @ByteCommander sorry, couldn't help much today
 
I'm going to bed and hope that when I'm waking up again tomorrow, the whole problem turned out as a bad dream... :-/
See you!
 
@ByteCommander Good night...
 
wtf ! I bought a pack of camels yesterday and its gone !
I did share with my mother, but . . . .really ? whole pack ?
 
@ParanoidPanda ok, now close the lid, wait 2 seconds and open the lid again and type:
dmesg | grep --ignore-case acpi
 
man, I need to quit
 
10:09 PM
@Serg Don't we all?
;-)
 
O_O
 
@ParanoidPanda and then give me the output after ine:
[ 10.744314]
(that is with a bigger number then above)
@Serg I'm suspecting he's not getting any ACPI events...
Now I'm just trying to find out why...
once we know that, we can sort out the problem...
 
@Fabby is there a way to find out boot parameters ? maybe he's got acpi=off there
 
user136984
@Fabby: [ 10.744314] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input7
 
@Serg It's SystemD... Of which I have experience level: 0
 
10:13 PM
Yes, found it cat /proc/cmdline
@ParanoidPanda do cat /proc/cmdline real quick, what does it say ?
 
He said "quick"! :P
 
well , , , , he's a panda after all . . .
 
user136984
bash: /proc/cmdline: Permission denied
 
sudo !
 
:D:D:D
 
10:15 PM
actually sudo !!
 
now hes going to type sudo !! :D
 
@Fabby oh I've seen it, ever see Son of Frankenstein?
 
@Mateo No! Any good?
 
user136984
 
@Fabby @Mateo Ha, try reading the actual book by Mary Shelley
 
user136984
10:17 PM
 
user136984
@Serg: sudo: /proc/cmdline: command not found
 
I had to read that book when my english was terrible in high school, like year after I came to the US.
 
@ParanoidPanda sudo cat /proc/cmdline
copy-paste --------------^
 
@ParanoidPanda sudo cat /proc/cmdline. You just need to read that file
 
Hrm maybe I got the title wrong
 
user136984
10:18 PM
BOOT_IMAGE=/vmlinuz-3.19.0-25-generic root=/dev/mapper/ubuntu--gnome--vg-root ro
 
dammit
 
So that's not it...
 
I meant "Young Frankenstein"
 
user139252
sudo pet cat
 
That one is awesome
 
10:19 PM
@HeatherBrown man woman
 
user136984
So?
 
@Fabby that would break, since man woman is too large of a file
 
@ParanoidPanda Well, my hunch is right!
You're not getting any ACPI events...
 
user136984
Ah... So what do I do about that?
 
@Serg try typing it in a terminal...
@ParanoidPanda Shut up and let me think??? ;-)
 
10:20 PM
I know, no manual for woman. But what if that existed ?
 
user139252
@Serg Women would actually be happy.
 
@HeatherBrown :D :D :D
@ParanoidPanda Actually, @Serg gave me an idea...
do a:
 
I did ? oO
 
Oli
Some times I just scroll over this tab but sometimes I catch a glimpse of something that makes me double-take. What on earth is going on in here? Lazy pandas, petting cats and manning women? What?
3
 
sudo cat /etc/acpi/events/lid
@Oli :D :D :D
@Oli What version of Ubuntu are you running?
@HeatherBrown and you?
 
Oli
10:22 PM
@Fabby 14.04
 
@Oli Good man! Stable!
 
@Oli in a nutshell, we're trying to fix Paranoid Panda's acpi problem while throwing in *nix jokes
 
user139252
@Fabby At work, 14.10(they don't know what EOL means here). At home, 15.04
 
@HeatherBrown Where are you now???
 
user139252
Work.
 
10:23 PM
Damn!
 
user139252
Need me to SSH into home for something?
 
- Make sandwich. -What ? No, do it yourself. - sudo make sandwich. -What kind of bread ?
 
Thanks anyway...
@HeatherBrown Not yet...
 
user136984
@Fabby: cat: /etc/acpi/events/lid: No such file or directory :)
 
@ParanoidPanda ls /etc/acpi
 
10:25 PM
23
Q: Any funny *nix one-liners?

Stefan This question is left open because it was historically allowed, but it is not considered a good, on-topic question for this site and would be closed if asked today. More info: http://unix.stackexchange.com/faq I saw a t-shirt reading 'anything you say gets piped to /dev/null', not incre...

I'm just gonna leave that there
 
user136984
@Oli:
 
user136984
 
@HeatherBrown do you have time to SSH into 15.04 and do a:
ps -alx | grep --ignore-case acpi
 
user136984
@Fabby:
 
user136984
> asus-keyboard-backlight.sh events powerbtn.sh undock.sh
> asus-wireless.sh ibm-wireless.sh tosh-wireless.sh
 
10:26 PM
@ParanoidPanda OK...
@ParanoidPanda Could you execute the command I asked Heather to do again as well, so I don't have to scroll up?
 
user136984
It all worked before, so why did my lid thing suddenly stop working though?
 
user136984
Ok
 
user136984
> 1 0 67 2 0 -20 0 0 rescue S< ? 0:00 [acp_thermal_pm]
> 1 0 465 2 0 -20 0 0 rescue S< ? 0:00 [ktpacpid]
> 0 0 974 1 20 0 4396 1508 poll_s Ss ? 0:01 /usr/sbin/acpid
> 0 1000 10658 5359 20 0 16140 2008 pipe_w S+ pts/1 0:00 grep --color=auto --ignore-case acpi
 
user139252
1     0    67     2   0 -20      0     0 rescue S<   ?          0:00 [acpi_thermal_pm]
1     0  1109     1  20   0   4372  1660 poll_s Ss   ?          0:00 acpid -c /etc/acpi/events -s /var/run/acpid.socket
0  1000  3675  3660  20   0  15948  2228 -      R+   pts/0      0:00 grep --color=auto --ignore-case acpi
 
user139252
Is that how it should look?
 
10:29 PM
@HeatherBrown Do you know anything about systemd?
 
user139252
@Fabby Enough that I disabled it because it didn't like my laptop.
 
if yes, can you help @ParanoidPanda change his settings so his acpi daemon starts up just like yours?
(very similar to 14.04)
 
user139252
Using upstart instead
 
Okay...detecting eye movements in OpenCV is not simple at all.
 
@HeatherBrown Ah!
back to square 1.
@ParanoidPanda So:
 
user136984
10:30 PM
Why has it suddenly stopped functioning though? Is it a bug?
 
My original hunch is right...
you've got a problem in acpi...
 
user136984
Yes, now what to do about it? :)
 
and you need to solve that...
So I've pointed you in the right direction...
Problem determination is 50% of the solution!
so now go solve it!
 
Oli
@RPiAwesomeness Movements might not be too hard but gaze tracking (eg "what is the user looking at?") is really hard.
 
@ParanoidPanda RTFM SystemD
 
10:32 PM
@GeorgetheDev what is my favorite color?
 
@Mateo I don't know.
 
user136984
@Fabby: Do you think that this could be a bug in ACPI causing this?
 
user136984
@GeorgetheDev: What is my favourite type of cute?
 
and get some help from someone that has SystemD installed and set it to the same as him/her/it
 
@GeorgetheDev hello
 
10:32 PM
@Serg Howdy!
 
@GeorgetheDev how are you ?
 
@ParanoidPanda Oh, and as you've got an IBM ThinkPad...
 
@GeorgetheDev what's the time ?
 
@Serg The current time is Tue, 04 Aug 2015 22:33:47 GMT.
 
user136984
@Fabby: Why is it not what it should be in the first place? And why did it suddenly just go wrong? Do you think that there is a bug somewhere?
 
10:33 PM
Find someone with 15.04 and a ThinkPad!
 
user136984
That might be difficult...
 
Advertisement could help , perhaps ?
 
@ParanoidPanda My hunch is you tinkering too much!
 
Ooo, I have an old thinkpad, back when it was still IBM
Maybe two?
 
@ParanoidPanda Ah! that is called "root cause analysis"
 
user139252
10:35 PM
It's Lenovo now. I don't like Lenovo. They bought Motorola from Google.
 
@ParanoidPanda and that gets done after the problem is solved!
(and that normally takes more time then actually solving the problem)
Listen to an old fart for once...
Problem determination and root cause analysis are hard...
 
user136984
@Fabby: Could it just be a loose wire?
 
@ParanoidPanda get a newer computer those are long past...
 
problem solving is easy!
 
user136984
Also, I haven't changed my machine that much, so I don't think that it is that...
 
10:37 PM
@ParanoidPanda It can be a micro-meteoroid strike,
a cosmic ray
a buffer underrun
 
But the last one I saw had a loose chip I had to solder back in place, does it rattel when you shake it?
 
a mini blmack hole
@Mateo :D :D :D
That's a good one!
I have to remember that!
 
user136984
@Mateo: It squeaks when I shake it... :D
 
@ParanoidPanda so you're looking much better before you asked me a question then before...
 
O_o that can't be a good sign
 
10:39 PM
I can't give you a definite answer BUT:
1/ you know how to problem solve yourself better now if you use my approach in the future
2/ you know that ACPI events don't generate keystrokes (Duh!)
3/ You know your problem lies in ACPI
the rest is up to you now!
Good enough?
 
user136984
Well, it has at least solved half of my problem...
 
user136984
@Fabby: So I thank you very much! :)
 
user139252
@ParanoidPanda It's my butterflies. I release a bunch of them over a local river, their flapping wings changed the ripple patterns in the water, which changed the way the light reflected off of it in such a manner that the amount of light radiation increased in your home just enough to burn out one of the wires.
 
@ParanoidPanda :D Just saw your edit! :P ;-)
 
user136984
@HeatherBrown: All the magic powers of chaos theory! :D
 
user136984
10:44 PM
@Fabby: :)
 
user136984
Does it actually ping you or something if I put @Fabby in a post?
 
user136984
Because I have always wondered about that...
 
@HeatherBrown I hope they weren't storm butterflies!!! ;-)
 
So get 30 random people in a room and more often than not 2 people will share the same birthday.
 
@ParanoidPanda No, I had the page still open in a tab and it said "an edit was made, click to reload..."
 
10:47 PM
@Fabby could acpi_listen help diagnose the issue ?
 
user136984
Right...
 
@Serg maybe... I'm not qualifies to solve his problem as I don't know enough about SystemD...
I'm not a god! I'm just a Vorlon!
>:)
 
well, i'm not qualified either, just trying to throw out ideas here
 
Nearly 01 AM here...
@Serg throw all you want!
(just not in my direction!)
I've tried and I know my limits!
I've only been using Linux for nearly 2 years now?
 
1.5 years here
actually, is there a way to find on when a system was installed ?
 
10:51 PM
@Serg January 2014.
 
user139252
time since install please computer
 
80
Q: How can I tell what date Ubuntu was installed?

lxtipsis there a command which will output the date that ubuntu (or any distribution) was installed?

sudo dumpe2fs /dev/sda1 | grep 'Filesystem created:'
dumpe2fs 1.42.9 *(4-Feb-2014)*
(just upvoted 2nd answer)
That was when I installed 12.04
 
Note: this file is not present in a chroot created by debootstrap. — Nathan Osman 10 secs ago
So the accepted answer isn't perfect.
 
What accepted answer?
 
user136984
Well, thanks guys for all the help that you have given me tonight, it has been greatly appreciated and at least I now know what is going wrong! :)
 
user136984
10:57 PM
@NathanOsman: I am off to bed now, but please do ping me with your penguin pics when you get time to get them. :)
 
user136984
Goodnight everyone! :)
 
@ParanoidPanda See you later.
 
@ParanoidPanda Another 3 minutes before you turn back into a pumpkin!
2
go to bed!
Quickly!
;-) Good night!
I'm off too!
 
user136984
:)
 
@ParanoidPanda Sigh! Another useless message of mine starred just because it was funny to ParanoidPanda :P
 
10:59 PM
@Fabby March 25 2014
Not even half year
oO
 
I was 1.75 months earlier then you!
Why did you switch?
туалет! Скоро повернусь!
 
@Fabby Honestly, I don't know. My classes in university weren't going that good. In fact, my standing in university is very bad. Other students seemed to be getting somewhere. In fact my cousin was running Ubuntu and kali , which 3 years ago didn't tell me anything. So I was in a kind of frustrated mood, like 'either something going to happen now, i'm going to learn something new , or fail miserably' and I guess I wanted to change my life and catch up with my cousin, become a smart guy
Before that I failed C programming class 2 times. With Ubuntu and nano and gcc passed it with blazing A, even wrote a program to read pids of processes in /proc folder as final project. Java class ? got C there, but if i didn't let my hands down on one of the homeworks, i could have easily had A there
 
Ah... Well, good on you!
 
Funniest thing is that I wrote program during exam in cygwin, and since our uni uses visual studio, i copied code over there. But Visual Studio complained about scanf ! Later i learned that Visual Studio developers for some reason stated scanf is unsafe and you have to add override option to the line above #include. Good thing my professor was cool and allowed me to use cygwin.
@Fabby and you ? what brought your attention to Ubuntu ?
 
:D
I didn't want to shell out money to Micro$oft for a computer that someone gave me...
 
11:08 PM
Hehe, one of the most common reasons :D
 
I got a computer where I had to choose languages when installing and neither of the installed languages was Engllish...
So I called M$
and told them I wanted an English version, that I didn't install anything and asked them where I should download it...
and they told me to call the manufacturer...
and the manufacturer told me to call M$
So I called M$ again, told them who I was and what I did and stuff, but the GM that I knew from years before had just quit the local subsidiary to go on retirement...
and no one knew who I was any more...
So I told them I was going to switch to Linux...
and they gave me a heads-up!
:D:D:D
Back at the time when the M$ Knowledge base was just starting up...
... they would credit people with the articles they wrote...
and I had quite a few good articles in there!
But then they abolished the practice and removed all names...
I had a few of their support techs that used to call me when they had a very difficult problem that they knew was unsolvable...
>:)
@Serg The good, old days!
 
@ParanoidPanda ^--- there you go
 
@NathanOsman Is that George standing on a sofa? or is that your wallpaper behind him?
@blade19899: look who's having a sleepless night!
;-)
 
Well , Microsoft always been somewhat of a ruthless tyrant in the computer and business world, so no surprise there. But only while Bill Gates was by the steering wheel of the company
 
@Fabby Yeah I know
Playing God Of War 2. on pcs2 emulator
Works awesome
Canonical's roadmap. 16.04 better be a legendary Distro!
 
11:19 PM
Is it even in beta yet ?
 
@Serg No!
 
@Serg No.
 
@NathanOsman If it's wallpaper: you've got excellent taste...
Anyway...
I'm off...
 
Donwloading Kingdom Hearts II, Metal Gear Solid 2: Sons of Liberty for PS2, to play it via PCSX2
 
Ineed my beauty sleep
 
11:21 PM
@Fabby lol
 
@blade19899 ;)
 
Firefly was an awesome series!!!!
 
@Fabby even Vorlons need sleep ?
 
@Serg To keep up the appearance of a "normal" life-form...
 
@Fabby No, it's a wooden board with a special cover over it :P
And the "sofa" is actually the carpet.
 
11:23 PM
@NathanOsman Ah... I'll undo the upvote then! ;-)
 
>:)
@NathanOsman It's till a cool picture, but that special cover having been your wallpaper would have been:
AWESOME
mmh... didn't george do figlets?
@GeorgetheDev figlet awesome!
 
@NathanOsman so what commands does George respond to, besides hello, goodbye, and time ?
 
Good night all!
Good night all
@GeorgetheDev what is my favourite restart?
 
@Fabby Your favorite restart is none.
 
11:28 PM
@Fabby gn, sleep well my friend
 
@Serg they're not really documented anywhere.
But you can sort of get some idea from the source code.
 

« first day (1770 days earlier)      last day (1660 days later) »