« first day (1771 days earlier)      last day (1635 days later) » 

12:18 AM
Hot dammit win7 ! Where's my ps aux | grep , when i need it !
I can do tasklist , but how do i grep stuff >_<
 
@Oli No, it's not dreadful. It just takes a fair bit of doing. I've got a project idea, but it doesn't require gaze tracking, just movement.
@Fabby Wait, can you teach him stuff? Like @GeorgetheDev My favorite OS is Linux?
 
You sure can.
@GeorgetheDev what is my favorite color?
 
@NathanOsman Your favorite color is blue.
 
@GeorgetheDev What is my favorite color?
 
@RPiAwesomeness I don't know.
 
12:24 AM
@GeorgetheDev My favorite desktop is Unity
 
@GeorgetheDev My favorite color is Orange
@GeorgetheDev What is my favorite color?
 
@RPiAwesomeness Your favorite color is Orange.
 
Whoa :D
Cool
 
@GeorgetheDev what is my favorite desktop
 
@Mateo Your favorite desktop is Unity.
 
12:24 AM
;)
 
@NathanOsman Is the code on GitHub?
 
look up to the last github link @RPiAwesomeness
 
Aha
Thank you @GeorgetheDev
 
@RPiAwesomeness You're welcome!
 
@NathanOsman You should have him set up in his own room so people can go and mess with the different things
 
12:27 AM
I already have.
He's in the Sandbox.
 
did he put him in the sand box too?
 
@GeorgetheDev ping xkcd.com
 
ping: unknown host http:
 
huh, got that wrong
guess you need to put the full address?
 
12:30 AM
@Mateo Just the domain.
 
ah
 
@GeorgetheDev ping google.com
 
PING google.com (216.58.192.46) 56(84) bytes of data.
64 bytes from nuq04s30-in-f46.1e100.net (216.58.192.46): icmp_seq=1 ttl=58 time=2.43 ms
64 bytes from nuq04s30-in-f46.1e100.net (216.58.192.46): icmp_seq=2 ttl=58 time=2.51 ms
64 bytes from nuq04s30-in-f46.1e100.net (216.58.192.46): icmp_seq=3 ttl=58 time=2.50 ms
64 bytes from nuq04s30-in-f46.1e100.net (216.58.192.46): icmp_seq=4 ttl=58 time=2.50 ms

--- google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
 
In other news, I got the SDK installed! cc @Mateo
\o/
 
yay
did you hear back on entering?
 
12:39 AM
Not yet :P
But I can still follow the tutorial
 
hrm, want to join my team? I'm going to be busy in two weeks
 
Well, sure. Once I go through the tutorial I'd be glad to help :)
Gives me a greater chance of winning anyways :D
I wonder, can you enter on a team & by yourself?
 
yeah, there were catagories
oh, you mean both
 
not bad
 
12:42 AM
Seriously. It's better than my desktop >.<
When these come back I want to get one: sellout.woot.com/offers/…
Other than the fact that it lacks a numpad
 
yeah, blue are the best
wish they made laptops with switches...
that would be insane
 
Someone did, MSI I think.
Full MX Brown keyboard
 
@RPiAwesomeness "up to two apps/scopes"
 
The thing's massive
So team + personal. Cool
 
so I think you could
 
12:48 AM
IF they approve it :P
You'd think I'd have received an reply by now :P
 
0
Q: Move files that are 7 days or older, cronjob

yayuI want to move some log files that are 7 days or older to another folder and then delete those files after another week. I'm using logrotate to create a new log file every 2 hours in a folder. I believe I made this correct: 0 0 * * * find /var/log/test/*.log -mtime +7 -exec mv {} /var/log/test/...

 
so I'm going to keep plugging away at features on mine, and if you get in, maybe you would have a better perspective on getting wiki images into it, if not don't worry
plus my code is interesting - I bet there are things that could be done better
 
o/ @Mateo
 
yo @hbdgaf
anything interesting, more the same?
 
a little of all. it looks like my store mgr is losing his job b/c the market manager has it in for old stores. progress doesn't count if it's not perfect. you don't get a better manager - counts progress as progress instead of "not perfect yet is wrong" etc etc. looks like my never there person hung themselves though, so that's mixed bag. other bits are mixed too, but you see what i mean. some good some bad.
 
12:56 AM
@Mateo Can I have a link to the code? I wouldn't mind checking it out now
 
I had part on github, I think that was mostly working, still had all the tutorial names in place...
 
What tutorial did you follow?
Because I'm having trouble following this one
 
@RPiAwesomeness that one is better than the weather one
 
Really? So, what do I do?
 
but I think the ifixit one was nice
 
12:59 AM
@RPiAwesomeness don't feel bad. most tutorials don't get me to engage. they're either too general or too specific mostly. so, i just don't engage.
 
that was a video if i remember
which is more like what you would find normally in scopes
a list of articles
 
So, basically what you do is set up the scope, then clone the repo the tutorial provides into the project directory?
Got 6 minutes on the emulator download
 
I think the repo is the finished scope
then it walks through from the start changing the default weather scope into soundcloud
 
OOoooh. I think I get it now.
You enter the code as it is shown. The blank files are later on.
Awesome.
 
let me find that video too, I think it was part of uds one year...
 
1:04 AM
Is a struct similar to a Python list?
 
A struct is just a struct. It's more similar to a class than a list. It's sort of a list of attributes, but a struct is more of a defined possibly list of pointers to multiple variable tyoes, so not a list.
 
Ah. So it stores Pointers instead of objects themselves
 
@RPiAwesomeness In Python, a list can contain pretty much anything.
A struct on the other hand has a well-defined structure (list of members and their types).
 
Something tells me I should finish learning C++ before tackling this :(
 
It could do either. It could contain entire data or just pointers to data.
I know I'ld write it as all pointers and setup and teardown with no struct members that aren't pointers, but that would be more pythonic and less C++ mindest. You could do it either way.
 
1:08 AM
@RPiAwesomeness youtube.com/…
 
@Mateo When you created an emulator did it go blank for a bit before showing the device?
Because I told it to create one but it finished downloading and now it's back to the blank screen.
Tab window thing
 
I actually run the scopes in the desktop thing
never actually setup an emulator...
 
Oh, how do you do that?
Hey, that guy is using the Numix theme like moi
 
it should just have as an option on the newer ubuntu
 
Just click run?
 
1:12 AM
it will have a computer icon, and say desktop for the kit
 
Yup
I think I'm not going to be able to do this :( I think I need to learn more C++ and I'm going to be really busy over the next 2 weeks :(
Sure hope they do another one of these...
 
then yeah, try the run, but make sure you aren't on the unit tests
that might have selected by default...
I barely know any C++ ;p
 
Aha! There we go
I was on unit tests >.>
Well, I'm sure going to try.
 
yeah, I should file a bug for that or something, it is a common pitfall
 
Awesome. Now that I have it working I'm excited to get going :D
 
1:15 AM
hit the big play button -> blarg errors! things are broke? -> ...........
 
But I have to study goat anatomy and ADDA score cards :P
Or whatever those things are
ADGA
 
ABBA?
 
i think it was an adgaf play on hdgaf.
 
@Mateo ADGA. American Dairy Goat Association
Also, I have to stop shutting down. My wifi dongle is just horrid every time I boot up
 
1:52 AM
Folks, who's up to critique a bit of my scripting ?
0
A: Assign default keyboard language per-application

SergIntroduction The script bellow sets language for each program in the case structure, according to the position of that language in the language menu. For instance, if my order English (1),Chinese(2), and Russian(3), I can set firefox to have language 2, terminal to have language 1, and libreoff...

 
2:29 AM
halp, I'm flack overstowing xD
 
Lol.
 
> Go ahead and fix it yourself :)
that really made me lol.
> Scripts in the /etc/update-motd.d folder update the beginning of the answer.
xD
 
2:47 AM
wat ?
 
@Seth well, my flack is just a mess of a thing, nothing too funny there
 
> But so far I've no idea how your windows will look and feel.
that one was funny anyway --^
> This behavior isn't a security hole, but rather a "convenience feature" for "serious" tasks and no graphic interface
xD
> awk helps us to Ubuntu
> Alternatively, create the .desktop files. That's the second place I'd kill all my GUI sessions
hahaha
@Serg Given enough flack, everyone is funny ;)
> Be lightdm.
 
3:35 AM
awk helps us to ubuntu ! My new favorite quote !
 
I thought that one was awesome too!
well now the site is not working so well and it is late. I'm off to bed. G'night!
 
Good night !
may the George penguins guard your sleep
Top of the morning to you @A.B. !
 
\o
 
@Terrance o/
 
@Terrance welcome back
 
3:48 AM
@Serg Thank you! :)
I think I am getting to the point of not liking UEFI much. I don't have it on my system, but I seem to read a lot where people are having difficulties getting their systems to boot.
 
So who here has 3 input languages on their machine ?
 
@Serg I wish I did so I could help you.
I'm kind of good with Spanish, and that is about it.
 
@Terrance all I really need is someone to test a script that switches between input languages :)
UEFI seems to be more secure but more annoying as well :)
especially safe boot feature
 
Don't know if I really care much about the safe boot features.
More like they are trying to copy the Android secure boot, that becomes grounds for messing the system up more.
@Serg Let me reboot my system here, and I will install other languages and help you out.
Back. Let me install some languages now.
 
4:05 AM
Just go to settings and input languages. The script i need to have tested is here: askubuntu.com/q/655628/295286 Basically that guy sets input language for each program. So like gedit will have english, russian in firefox, chinese in terminal
 
@Serg what is the code for Chinese?
 
zh
@Terrance, i don't think you need to install languages,. Just chose from available inputs in the settings
 
THanks
I don't think it will let me till I do install something other than English.
OK, Russian is installed. Yay!! :)
Let me test it now.
@Serg it worked and set my Firefox to ru, however, I get this error message:
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 20 (X_GetProperty)
Resource id in failed request: 0x380000f
Serial number of failed request: 16
Current serial number in output stream: 16
And it keeps flickering, but I think that is due to your sleep thing
 
hmmm. that sounds like output from wmctrl
 
Maybe it is.
@Serg But, it does appear to be switching the language as needed based on the windows. :)
 
4:15 AM
yay , i guess ^_^ It kept flickering before, because I wasn't checking if the current language has been already switched, but now it shouldn't flicker . . . strange . . .
 
4:28 AM
@Serg +1. It works well. :)
 
:D thanks
 
No problem! =)
 
Morning @Serg @Terrance
 
@A.B. Gutten morgen :)
 
@A.B. Good morning!
 
4:38 AM
o/
 
@A.B. \o
 
Morning @GeorgetheDev :)
 
Watching Steve Jobs and Bill Gates interview
 
@Serg can you check this please, I'm on mobile
http://askubuntu.com/a/656697/367165
 
@A.B. couldn't find pbcopy. Is it in repositories ?
 
4:47 AM
Hmm, no idea. :(
 
the two strings seem to be the same tho
both with echo and printf
I think the problem is with base64
 
Ok, thx :)
Waiting for OP ... :)
 
brb, i need to reboot
 
alias pbcopy='xclip -selection clipboard'
 
Pbcopy isn't Ubuntu :) ok
 
4:56 AM
@A.B. nope, still has newline
$ printf '%s' 'Hello World' | openssl base64 > tester.txt

$ cat -A tester.txt
SGVsbG8gV29ybGQ=$
the $ at the end means newline
$ printf 'Hello World' | openssl base64 | awk 'BEGIN{ORS=" ";} {print}' > tester.txt

$ cat -A tester.txt
SGVsbG8gV29ybGQ=
@A.B. ^ awk
 
Great, write an answer :)
 
Better than mine. I tried to write a boot repair answer, but the host was UEFI. =(
 
UEFI :(
 
nah, it's too easy, plus it would be plagiarism of your answer
 
I have deleted my answer
 
5:01 AM
oh, the guy is a mac user ?
 
I am not liking UEFI at all. I have followed instructions to the "T", and I still cannot install Ubuntu on my Macbook pro
 
Mac o_O
 
@Terrance em . . . what exactly is happening there ? like does it hang during the installation or something ? I remember another guy here tried acpi=off as one of the boot parameters and it worked, so maybe you gotta do that during installation as well
And here's my rant: who installs Linux on Macbook ? It's already a *nix system for crying out loud !
 
@Serg I never get that far. It hangs on the first reboot after installing.
 
there . . . .now i feel better
 
5:03 AM
@Serg I hear ya.
 
@Terrance hangs on the first reboot . . .can you get to grub ?
 
Just seeing if I could really do it, but I can't
Doesn't matter to me anymore though. I will use the Mac OS and Windows 10 on it. :P
 
:D yup , besides there is always VMWare to run Ubuntu, right ?
 
My main system run Ubuntu GNOME 14.04.
@Serg Yep, there is always VM or VirtualBox
I spent 9 years as a Mac certified tech, and I really learned to dislike the Apple company. I will use their equipment, but I will not go out of my way to purchase their overpriced stuff.
 
@Serg ok, maybe Mac os. I have undeleted my answer, no risk no fun. But if you write an answer, I will delete my answer again.
@Terrance great words :)
 
5:09 AM
=)
 
Alright, I'll post it. I appreciate your support @A.B.. I owe you one
 
Goodnight guys. Gotta be up early in the morning! See ya tomorrow! :)
 
@Terrance See you later.
 
No :) the awk thing is yours ;)
@Terrance good night
 
@Terrance see you later buddy
Posted
 
5:13 AM
Upvoted
10,000 today @Serg?
 
No, probably tomorrow or day after tomorrow. I'm just gonna slowly transition into it. Besides I am waiting for a bounty
holy molly ! I am only 60 points away ?
 
:) bounty? Give me a link
 
[ SmokeDetector ] Manually reported question: You-can't truly identify one area of your system by user436555 on askubuntu.com
 
@A.B. you already visited it askubuntu.com/a/656671/295286
 
Hmmm, yes
 
5:33 AM
Yaaaay, 10k !
4
@A.B. Man, thank you !
 
@Serg You finally reached the big milestone?
\o/
 
Yas !
\o/ yaaaaaay
 
I wish I had an animated GIF of George celebrating right about now...
 
You know, that's actually a good idea ! Maybe there should be like gifs or chat messages for users who just turn to 10k or something
 
5:49 AM
wow . . .it kinda feels good, you know. Going from like failing C class twice to writing shell scripts here and getting to 10 k . Man . . . I love Ubuntu
 
6:28 AM
0
Q: How to enable nameserver recursion?

Gottlieb NotschnabelOn Ubuntu 14.04, when I'm performing a dig google.de on my machine, I get a REFUSED status (reducing to relevant lines): me@machine:~# dig google.de ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 26926 ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1 ;; WARNING: recursio...

 
7:13 AM
0
Q: How can I fork a PPA

lvellaThere is this PPA with lots of modified packages, but some are not of the version I need. How can I for that PPA, and update only the packages I need?

STICK A KNIFE IN IT! SPOON IT!
_O-
@Serg gratz! :D
 
@Rinzwind Thank you ^_^ I'm now also a cool guy like Fabby and A.B. and muru and you ! Wheeee
 
[ SmokeDetector ] Bad keyword in body, pattern-matching website in body: Penis exercises are very powerful if you know what by hogtito on askubuntu.com
 
7:37 AM
Waaah, got a downvote :)
6
A: Is there any Ubuntu 14.04 theme to make it look like Windows 10?

A.B.I would say, Numix is a good choice sudo add-apt-repository ppa:numix/ppa sudo apt-get update sudo apt-get install numix-gtk-theme

 
@Serg you do realize I am 10 times more cool than you >:-D In amount of rep that is :-D
@A.B. well technically numix is NOT a windows 10 theme/lookalike so the 6 upvotes are wrong :D
upvoted ;)
 
7:54 AM
@Rinzwind lol, wait and see, imma catch up with ya :D jk. The point is, with 10k officially I am not a n00b on the site anymore I got to a milestone
sleepy time
 
LOL
 
I have to wake up early to take the girl I like but who's gonna marry another dude anyway to school for employee training . . .sigh . . . .sweet torture again
@Rinzwind by the way, help me out testing a script plz. askubuntu.com/a/656671/295286
Ping me if you got errors or anything like that. If possible, plz trace (with set -x ) any source of those errors. Terrdon got one, which i think was from wmctrl but at least on my machine it works with no errors.
 
8:10 AM
[ SmokeDetector ] Bad keyword in body, pattern-matching website in body: The Way To Get Your Penis Larger Naturally by ignacioosborn on askubuntu.com
 
9:00 AM
0
Q: Running a custom kernel on qemu

bawejakunalI am trying to test some feature of Ubuntu 12.10 server edition with the kernel version 3.5.0. I am running the qemu as qemu-system-x86_64 -m 2G -hda ubuntu.img -kernel linux-3.5/arch/x86/boot/bzImage -s -append "root=/dev/sda" wherein ubuntu.img already has Ubuntu 12.10 server installed and the ...

 
9:13 AM
0
Q: How can I make more than edits show in my review notification?

mark kirbyMy review notification only shows suggested edits, however I have seen screenshots of other users desktops that have hundreds of notifications here. Can I add more queue's to my notifications, rather than just edits, or is it something that is based on my rep ?

 
9:25 AM
Aaaaaahhhhh! The Thunderbird update to version 40.0 killed my beautiful dark theme! :´-(
 
user136984
9:44 AM
@NathanOsman Thanks! :)
 
user136984
@Fabby Which message? Where...? I don't think I remember staring anything... Let me see...
 
user136984
Oh, the pumpkin thing? Yes, that was me! :D
 
user136984
@Fabby: By the way, I told my machine to shutdown yesterday, then much later on realised that it had restarted instead... Do you think that these issues I am facing are related?
 
apt-get update still broken! HELP?!?!?
1
Q: 'apt-get update' gets stuck at "100% [Working]"

Byte CommanderWhen I run sudo apt-get update on Ubuntu 15.04, I get the following (shortened) output: $ LANG=C sudo apt-get update [sudo] password for ipc-admin: Ign http://ftp.uni-stuttgart.de vivid InRelease Ign http://ftp.uni-stuttgart.de vivid-updates InRelease . . . Hit http://ftp.uni-stuttgart.de vivid...

 
user136984
10:34 AM
@NathanOsman: You know, your penguin is actually really photogenic! You should make lots of pictures of him and put them on your site, so people can get them as wallpaper! They are really cool! :D
 
user136984
@Fabby: I just tried closing the lid, and it suspended! :D And I haven't even changed anything... So that is very strange, but very good that it has started working again! Let's just hope that it hasn't been replaced with another problem, like my machine restarting when I tell it to shutdown... :P
 
user136984
Already done. :)
 
user136984
11:09 AM
VTC this as problem went away by itself. :)
 
user136984
Which I am very happy about!
 
user136984
Although just hoping that it hasn't been replaced with another problem... :P
 
12:35 PM
Some votes for another great script of the famous Jacob Vlijm! askubuntu.com/a/655791/367990
 
@NathanOsman Can you see what's causing this error:
 
@NathanOsman Question to recommend Nitroshare? askubuntu.com/q/656840/367990
 
Code:
void Query::run(sc::SearchReplyProxy const& reply) {
    try {
        // Start by getting information about the query
        const sc::CannedQuery &query(sc::SearchQueryBase::query());

        // Trim the query string of whitespace
        string query_string = alg::trim_copy(query.query_string());

        // the Client is the helper class that provides the results
        // without mixing APIs and scopes code.
        // Add your code to retreive xml, json, or any other kind of result
        // in the client.
 
12:47 PM
@Serg Update to my apt-get update problem: It hangs for hours at the tox repositories, but finally continues with Error and Warning after timeout and terminates. See edit: askubuntu.com/q/656581/367990
@blade19899 You might look at that ^ too, maybe you also experienced problems with the tox repository?
It seems like the whole tox.im server is down. Even wiki.tox.im does only show the cloudflare host-is-offline site.
 

« first day (1771 days earlier)      last day (1635 days later) »