« first day (2993 days earlier)      last day (36 days later) » 

1:54 AM
._.
Palm released a new phone. Which is actually pretty neat and I'll probably not buy.
New version of winamp
.... It suddenly feels like the 90s
 
Bob
Palm... makes phones?
Winamp... still exists?
WHAT YEAR IS IT?!
I still remember converting Mobi ebooks and something about trying to read a Palm-specific ebook on an emulator...
 
This is a fascinating read:
The Cuckoo’s Egg: Tracking a Spy Through the Maze of Computer Espionage is a 1989 book written by Clifford Stoll. It is his first-person account of the hunt for a computer hacker who broke into a computer at the Lawrence Berkeley National Laboratory (LBNL). == Summary == Author Clifford Stoll, PhD, an astronomer by training, managed computers at Lawrence Berkeley National Laboratory in California. One day in 1986 his supervisor, Dave Cleveland, asked him to resolve a US$0.75 accounting error in the computer usage accounts. Stoll traced the error to an unauthorized user who had apparently used 9...
 
2:09 AM
@Bob Its palm
so. its a long, complicated story
The brand is owned by TCL who licenced it out to some former samsung people who seem to have exclusively be selling it via verizon but you can't get the phone with its own line...
 
Bob
@JourneymanGeek That UI hasn't been updated in forever
 
@Bob the "Palm" ? ;p
 
Bob
@JourneymanGeek Winamp
 
I think you mean winamp
Ya
I think they tried updating it once and failed
 
Bob
> Palm is pitching the Palm as a "companion" device to your main smartphone, allowing you to leave your big phone behind and bring the Palm in a wallet, on a lanyard, or in any tiny pocket.
 
2:14 AM
.... wait
 
Bob
That's a honkin' big wallet.
 
@Bob which is dumb
You make a product, but you really need to let your customer decide how to use it.
@Bob it is
tbh, the perfect size for a backup phone is a coin pocket
(But I have a backup phone, and didn't cost that much. If the jelly didn't have such wierdly uneven battery life...)
 
Bob
omnomnom
that's the sound of my program eating the 35 MB xlsx
and hopefully dumping it into the DB
did I mention there's some 4 million+ entries in it?
and that it takes several minutes to open the sheets, never mind reading data out of it?
 
Bob
Unhandled Exception: Microsoft.EntityFrameworkCore.DbUpdateException: An error occurred while updating the entries. See the inner exception for details. ---> Npgsql.PostgresException: 42501: permission denied for relation story_details
weeeeeeeeeeeeeelp
I forgot to give the user permissions lol
 
2:25 AM
oops? ;)
 
Bob
let's try that again
 
Bob
2:38 AM
db=# select count(*) from story_details;
 count
-------
  2000
(1 row)

db=# select count(*) from story_matrix;
  count
---------
 3999490
(1 row)
\o/
 
 
1 hour later…
3:44 AM
c
Horn OK Please drives around city streets, a redoubt and omnipresent sign forged of steel, riveted to the back of an old bus. With undying devotion to his single function in life, he happily reminds himself that he assists in some small way in ensuring that drivers can safely pass buses on the crowded streets of India.
 
Bob
o_O
 
 
2 hours later…
5:28 AM
Oo
 
5:39 AM
@HornOKPlease tbh, that's not what horns are for ;)
They're meant for drivers to communicate!
In fact, scientific tests show many drivers will go catatonic if you disable their horn.
The average horn is used 200 times a minute.
99% of the horn facts you get from me are both true and completely made up!
 
6:10 AM
So quiet today
Everyone busy?
 
Does anyone else get an error at google.com/apps/mydevices/b/0?
 
@rahuldottech works for me
but I got an error 500 on google + (don't ask) so.... maybe they got issues
 
@JourneymanGeek huh, weird
@JourneymanGeek they're killing it off
 
I didn't think much of it cause no one uses google plus any more
ya ;p
 
did you see the legendary rant?
 
6:14 AM
on twitter?
the one with like 100+ tweets?
 
@JourneymanGeek Yeah, the one by the ex-dev
 
Ya
I think one of the SE employees I stalk linked it ;p
 
lol
btw
 
Probably Nick
 
Unlikely that I'll be online frequently here (or anywhere) for a few months
If anyone needs to contact me for whatever reason, DM on riot or telegram, same username
 
6:29 AM
@rahuldottech Bhutan?
 
7:20 AM
@JourneymanGeek nah, exams
 
Bob
7:38 AM
> In Japan you can't send SMS from one network to another, only from Softbank customer to Softbank customer (to message a customer from another network you have to use email).
whaaaaaaaaaaaaaaaaaaaaaaaaaaa?
(that was in 2010. still...)
 
@rahuldottech good luck, see you on the other side
 
8:16 AM
@djsmiley2k thx
 
8:46 AM
Y'all remember my mom's old phone?
Dug it up to repurpose it
Battery's... bloated.
.-.
ON THE OTHER HAND
my moto G seems dead
and my HTC one V? ... still runs...
 
9:38 AM
just seen a post on the HNQ on Aviation. It is sometimes terrifying that pilots miss the basic physics associated with flight...
2
Q: How can flying high minimize drag and provide a fuel efficiency?

Abdullas the plane go high, it means the engines have to work harder to compensate for the air density, therefore it will require more fuel in order provide the same power at lower altitudes. but, I always hear that flying high means less fuel burnet. please explain how.

 
10:15 AM
> Our tenants have some everlasting cups in reception if anybody would like one.

Made from recycled bamboo amongst other things
what makes them more everlasting than ceramics?
 
Man. There's this thread on Reddit about how for the first time in decades NYC went one whole weekend without a gun shooting
And people from other countries are like wtf gun shootings are so common in NYC?
And 'muricans are all like "NYC is the safest city in the US! It has a population of 8.6 million which is more than most countries! This is incredible!"
And I'm just here, sitting in India, staring at the screen and wondering what's wrong with the country
Just... Make it illegal for civilians to own firearms. It's really not that hard.
 
@Burgi The energy wasted in harvesting it.
 
@rahuldottech yes, yes it is
 
@rahuldottech but mah reichs!
 
10:30 AM
the correct solution here is to introduce mandatory checks on purchasing
 
It'd help
and get rid of the private sale stuff
Itr's funny, because there's places in america you can't buy booze
 
places like Switzerland and holland make it mandatory that you have to complete a gun safety course and have a secure storage locker for your firearms
you also need to apply to a government agency for a permit to own it
think of all the jobs that setting up a gun management agency would create
and the ancillary industry of providing certification around the gun safety course
instant economic boost while preserving the right to arm bears
 
11:08 AM
You also join the army.
;D
 
12:31 PM
@Bob Watch out, I'm writing clientside JS again and will need some suggestions so I can learn and maybe suck less at it :D
 
all JS sucks
 
1:27 PM
I'm writing python
and maybe the python tutorial doesn't work >_<
I need a telnet server which isn't a switch to test on
but it must 'stop' sending data too, so that star wars one is no good :P
Ah crap, internet access on the VM is borked again
 
Bob
@Burgi says the php dev :D
@HornOKPlease o/
 
1:56 PM
@rahuldottech As the NRA says, if you outlaw guns, only outlaws will have guns
 
I need to bind.... 2 nat ip's on my virtualbox vm
thius is getting complicated, fast xD
Fack it, I'm gonna ask for a testing VM instead.
 
2:10 PM
@Bob At the moment I'm trying to figure out how to make my repl.it code public (anonymously viewable), but not allowing people to actually host arbitrary code on my domain 0_0
 
Bob
@HornOKPlease Erm. Are you hosting the repl.it code directly on your domain?
> If anyone edits an embedded repl, it will automatically fork the repl for them and they will be editing their own version. If the user is logged into Repl.it in their browser, the forked repl will become theirs and show up on their repls dashboard. If the owner edits an embedded repl, those changes will be saved to the repl and become visible to others who view the embedded repl.
 
2:23 PM
> Top Geographies

> Russia 94%
Huh
Russians are watching muh vids?
Хорошо!
 
lol
 
Bob
2:52 PM
@bertieb Hi GCHQ!
 
HI ISD!
 
HI FSB
 
COMRADE! HOW IS SALISBURY CATHEDRAL! DID YOU ENJOY THE SPIRE?
 
COMRADE! IT WAS GOOD! WHY DO THE WEST THINK ARMY OFFICERS TOURISTS ARE UNCULTURED?????
 
(i didn't get that meme until this week's last week tonight)
 
3:01 PM
LOL
its been all over the uk media since the summer
survival tip for ex-russian spies: don't live in a city with a cathedral
 
Bob
uhh
linky?
oh
 
 
4 hours later…
6:35 PM
Was so deliberately botched.
In a thing about British train stations ...
'Interestingly (or not, you decide) none of them are as bad as the North of England's stations. Furthermore, all of the stations on the non-London list are in England. Make of that what you will.'
 
That's a new one...
> We will likely have an extinction-level event before an Optane SSD 905P hits the endurance limit during normal desktop PC usage.
May 8 at 3:39, by bwDraco
Also, 17,520 TBW write endurance.
May 8 at 3:51, by bwDraco
SSD endurance has become a joke.
Assuming typical power-user write volume (Astaroth's disks get a total of about 15-30 GB of writes a day), at 17,520 TBW, you're looking at 1,600 to 3,200 years of endurance. Optane is effectively immortal.
 
7:21 PM
 
Thing is... I remember when the first intel SSD's launched
and someone showed even if you constantly compiled against one, you'd not wear it out in any meaningful amount of time
 
Yeah. Endurance is a solved problem for the vast majority of use cases.
brb, applying a phone update.
 
8:17 PM
But do note that data retention degrades as you wear it down. The endurance rating is how much data you can write to the drive and still expect one year of data retention.
(for enterprise SSDs, the goal is 3 months of retention at EOL, since enterprise usage involves constant replacement of data)
 
8:29 PM
@JourneymanGeek, @Bob, @HornOKPlease, and anyone else interested: backblaze.com/blog/2018-hard-drive-failire-rates
 
8:55 PM
@bwDraco Ah, I always enjoy reading Backblaze's numbers
They make it interesting
 
 
2 hours later…
10:25 PM
Huh, Paul Allen died
Return of lymphoma
Still relatively young :-\
 
anyone have any idea how to change the prefix key for .tmux.conf to esc+shift?
I can't seem to find a question so maybe one should be asked.
 
@William most terminals can't tell the difference between esc and shift-esc, so you may not be able to
 
@ToxicFrog I meant option esc
on mac
not shift
iTerm2 let's me se this as a modifer
 
Oh. That I have absolutely no idea -- what control sequence does that send to?
 
10:40 PM
A: Go to Preferences > Profiles tab. Select your profile on the left, and then open the Keyboard tab. At the bottom is a set of buttons that lets you select the behavior of the Option key. For most users, Esc+ will be the best choice.
what is the xev equivalent for command line on mac
I don't no the answer to your question which is why I asked
 
Ok, I think based on that FAQ entry that when you set Option to "Esc+", it means that, e.g., option-A will send <esc><A>
shift on its own doesn't send anything, so there's no way to send <esc><shift>
 
why/how do you know the escape sequences
 
XEV (or some equivalent) won't help because that tells you keycodes/scancodes, which is not the same thing as what programs running in the terminal see.
 
yes the equivalent for terminal would be nice
 
E.g. if I press uparrow, xev sees <uparrow> but the terminal sees <esc><leftbracket><A>
Just running 'cat' and then typing some keys should do it.
 
10:44 PM
yes where is that last
list
 
There is no master list. It depends on what terminal emulator you're using, how it's configured and what mode the terminal is in (which can be changed at runtime by programs you run in it)
 
wow confusing
 
Try just running 'cat' and then typing option-A and see what shows up
 
almost like web browesrs
^[a
 
Ok, that's <esc><a>
So yeah, setting option to "esc+" means "when I press option-foo, behave as though I pressed ESC and then pressed foo"
 
10:47 PM
okay so how do I set it as the primary key in tmux
might fit well for unix.se
 
And yes, it is confusing. This is the result of decades of teletype and terminal companies developing terminal control protocols, and then decades more of terminal emulator developers programming in support for them
 
what keys can I use for a modifier
ctrl and esc for
sure
anything else
you just said it yourself shift doesn't work
 
Yeah, I'm not sure this is possible, at least not without wacky stuff using multiple keymaps and the switch-client tmux command
 
set-option -g prefix Escape
unbind-key C-b
bind-key Escape send-prefix
 
ESC is not a modifier, it's a key in its own right, so tmux won't let you bind (e.g.) Escape-A the way it lets you bind Ctrl-A
 
10:51 PM
trying this from the answer
 
Yeah, but that binds Esc on its own as the prefix key.
 
isn't that good enough
I mean the only problem I might have is what?
 
Which honestly I'd probably be a-ok with, since it means that I could type (e.g.) option-A instead of <prefix><a>, but it's not what you originally asked for.
 
yeah that isn't what I asked for nevermind
 
@William I can't think of any, it's just not what you were asking about.
 
10:53 PM
about that
 
If that works for you, awesome.
 
what is the keycode Ctrl+Shift+Tab should send?
because I can bind a value to it using iTerm2
 
Good question.
 
but I'm not sure what it should be
I have tried multiple values
 
On my machine ctrl-tab sends <esc><lbracket><Z> and shift doesn't make a difference one way or another
I think you have it backwards
That setting in iTerm2 is "when I press ctrl-shift-tab, what should it send to the terminal instead of whatever it would "normally" send"
 
10:55 PM
why can't I send ctrl+.
ahh okay
so the people who support it just made up a value
with and with out shift
 
Yeah, again, most (all?) of this is wacky historical stuff where companies making hardware terminals came up with special sequences to represent new keys and key-combos they added that weren't representable with a single character in ASCII.
And by the time terminals moved from hardware terminals to software pretending to be a hardware terminal, there were huge libraries of software using these conventions, so....
 
control backslash works
so I am trying to input ^o into iTerm2 what setting should I use
Send Escape Sequence
Send Hex Code
Send Text
@ToxicFrog last question for now
 
send hex code 0F, I think
Or send escape sequence ^O, assuming iTerm2 uses the same conventions for escape sequences terminal emulators on linux do
 
hex code worked
how did you figure it out
 
Oh wait no, "send escape sequence" is something different
(it means "send <esc> followed by whatever I put in the box")
I ran 'od -tx1 -c' and typed ctrl-O enter ctrl-D
 
11:04 PM
so 0a for
 
You can also figure it out by looking at an ASCII table, taking the capital letter you want the ctrl-version of, and subtracting 64
 
^e
 
0A is just the newline at the end, and is ^J
^E is 0x05
^A is 0x01 and it goes up from there through the alphabet
 
thank you I got it sort of working
I remapped ctrl+shift+tab to ctrl+o
essentially
I'll have to mess with tmux more later
I guess I could set left alt to + ^A
 
11:59 PM
ugh. @Bob What was that gif creator you recommended?
 

« first day (2993 days earlier)      last day (36 days later) »