« first day (852 days earlier)      last day (4154 days later) » 

4:00 PM
@ewwhite how you feel about getting your hands dirty ?
 
@NickM. ok.
 
If you're plugged into a working UPS, I would seriously say "fuck it, I prefer Dell servers anyway," or in your case, call up HP support and my HP rep and say that this crap with servers hanging at thermal and power calibration is jeopardizing a six-figure server order, so fix it, yesterday.
 
@HopelessN00b So they sent me a new unit.
it's exhibiting the same issue..
The ILO is fully responsive.
 
@ewwhite are both servers plugged to the same power strip ?
 
@ewwhite Right, but that didn't fix the issue.
 
4:03 PM
@HopelessN00b This is only happening during f12 restarts from the ESXi console...
from what I can see
I have not been able to reproduce it.
but it happens to my coworker.
 
@ewwhite Do you have a server like this that has never had the this prblem?
 
Yes... I own 5 personally, and have deployed about 200 of this model.
 
might be a setting in the bios with the virtualization options
 
I've had weird issues like this with a Dell server before, and they sent out a field engineer who was able to trace it to a firmware bug, and provided a workaround. I'd expect the same thing from HP, if I were throwing that much business their way.
 
Firmware is up-to-date.
In fact, the firmware for this model hasn't changed since 5/2011
 
4:05 PM
@HopelessN00b yeah same here, by updating the firmware it fixed my last problems with my crappy cheap dell
 
@ewwhite So was mine - I think you're well past normal SA-level troubleshooting here, and it's time to get the manufacturer to fix their shit, is what I'm saying.
 
I preach all the time about HP firmware on SF... so I had that base covered.
 
@ewwhite What are the chances it has something to do with the current?
 
@NickM. Could be... I mean, a sane check would be to plug into utility power.
But I can't reproduce this easily.
 
@ewwhite you mentioned you had another server having the same issue.. was it plugged to the same circuit?
 
4:07 PM
It looks bad because the one coworker who's doing the testing is being vocal about the issue.
 
@ewwhite Kinda like a woman.. some are more fussy than others
 
Which could be something as obscure as running an F12 reboot of ESXi from a Java ILO session from Linux...
 
I'll know I'm "old" when I argue with IT that I want my old monitor back because I "like it more" than the new one.
 
@ewwhite Oh, Java ILO... Jave version up to date?
 
I always come in from a Windows console... and I rarely reboot an ESXi server using F12.
so it could be that.
the build is also a kickstart ESXi build with some modules slipstreamed into the process.
 
4:09 PM
@ewwhite you say it hangs during post ?
 
@ewwhite and if you send a reboot command to the server when its at that state it reboots without a problem or does it happen that it still hangs?
 
install windows 2012 on one of them and reboot it constantly for a few days and see if it happens then?
 
it'll come up just fine.
 
it would be quite easy to set up.. task manager with shutdown /r
 
4:11 PM
the fix is simple... just issue a reboot or cold start
 
@ewwhite then it's ESXi
are there any updates
 
it COULD be esxi
like I said, test with windows..
 
try installing an older version of it and see if it still does that.. or if there are a newer version.. try installing the newer version
oh
I have an idea
@ewwhite Is there an option to shutdown the machine by this F12 ?
instead of reboot
Send a shutdown command and I bet you when you boot it back up it will come up without any problems even though it was done through the evil F12
 
@NickM. yes... you can F12 shutdown as well.
 
try the shutdown
if it comes back up after that
i mean after you manually power up the server
then it could be something with ESXi not clearing or releasing everything in cache or memory somewhere
anyway
im just yapping
 
4:18 PM
@NickM. Do you guys think it could be ILO-related at all?
 
@ewwhite I wouldn't know what to do to go about testing this
 
Or would you just ignore it as a fluke?
Since I haven't been able to make it happen.
 
i thought it happened everytime you used the F12
 
@MDMarra Well thank you for that... I'm more convinced than ever that I should just stick with my beloved LDAP Filters when mucking with Get-AD*. Get-Help about_Comparison_Operators indicates the following:
 
@NickM. nope... only sometimes.
 
4:26 PM
I wish there was a nicely organized website with a bunch of sample unattend.xml examples for various configs
 
And the reason my coworker sees it is that he's testing the machine and automated installations... e.g. rebooting a lot.
 
Fudge, message too long...
Well, regardless, looks like either use -LDAPFilter, or push the comparison out to a Where-Object:
(Get-ADUser -Filter * -Properties description | Measure-Object).Count
15514
Oh fucking markdown
(Get-ADUser -Filter * -Properties description | Where-Object { $_.description -eq "Network Technician" } | Measure-Object).Count
3
(Get-ADUser -Filter * -Properties description | Where-Object { $_.description -ne "Network Technician" } | Measure-Object).Count
15511
 
@jscott bleh. LDAP filters.
 
Outside of the -Filter block, the comparison of "som value" -ne $null returns $true.
Oh cool, @RyanRies is here.. He's a PS guy...
@RyanRies See above -- in the context of Get-ADUser -Filter { description -ne "somevalue" } it appears that -ne does not [not]equal when a description is $null....
 
hello all
 
4:36 PM
@jscott Yeah I'd take that straight to where-object as you have done
 
@jscott hahaha
 
@jscott What is actually the problem though?
 
@RyanRies Inside a -Filter the -ne will not return anything for $null attributes.
 
@RyanRies I broke get-aduser
 
Dan
@ewwhite Did they do a full machine swap?
And did it get new discs etc?
 
4:38 PM
@jscott @MDMarra Let me play with it for a few mins
 
@MDMarra Fix it and write about it! That PowerShell post of yours did great - I keep forgetting to tell you.
 
So something like Get-ADUser -Filter { description -ne "Network Technian" } will only return users which have a description that is not $null and is not equal to "Network Technician".
 
@RyanRies {-not (description -eq "something")} isn't evaluated the same as {description -ne "something"} when used as an ldap filter for get-aduser
the ugly -not one works correctly
 
For the simplest test:
 
Hey bastards, if I wanted to buy a rackmount roadie case suitable for +6U of servers, where should I look?
 
4:39 PM
@MikeyB A music store
 
Get-ADUser -Filter { description -ne "$null" } | Measure-Object

-vs-

Get-ADUser -Filter { description -eq "$null" } | Measure-Object
 
seriously
 
@Dan everything except disks.
@MikeyB I've answered this.
 
Dan
@ewwhite RAM, too? If so, might be worth swapping the disks
 
3
A: Transporting servers - need special rack/case

ewwhiteYes. For standalone servers, I've used standard wood/aluminum ATA-rated flight cases. That's nice for situations where the end-recipient will assemble the server and you're just looking for a nice reusable case. Shipping demo equipment is a good use-case for this. For portable installations like...

 
4:40 PM
@MDMarra They wouldn't sell them deep enough, would they?
 
5
A: Permanent case for shipping 2U servers?

ewwhiteYes, you can purchase an ATA-rated 4-post "flight case" for the 2U server. A nice example would be this 6U shock-mount case, especially if you need to ship anything along with the server (switches, power supply, etc.). Standard non-rackmount ATA cases would work well, too.

@Dan all new RAM, too.
 
@MikeyB Hm, not sure
 
@ewwhite Ooohhh that's sexy. That's bloody perfect, thanks.
 
Dan
@ewwhite I'd try disks or maybe different firmware. At the end of the day, the OS can't possibly be causing it and I highly doubt iLO is too
 
@WesleyDavid thanks man!
I need to write something on my own blog soon
 
4:41 PM
@Dan I only have two disks... should I split the array or install onto something new?
 
I started a "How to run a DR meeting and not suck at it" post, but got sidetracked
 
@dan can you see why this would make the people here skeptical?
 
Dan
@ewwhite Yeah, it's a total fucker and absolutely sods / murphy's law, eh?
 
@ewwhite Have you tried new power/network/anything else plugging into the server?
 
I don't think it's an issue since reboots should be controlled, infrequent and we'd be looking at the console anyway.
 
4:42 PM
Like, take it from the next server up in the rack that works fine?
 
@MDMarra I told coworker to find another disk and plug BOTH machines in and see what's up
 
Dan
@ewwhite To be fair, I wouldn't be too happy if I was deploying that server. I've never seen it though - I've not deployed that many machines, but more than most normal people
 
since I don't think the first system was actually bad
 
Dan
Does it EVER get any furhter?
 
@ewwhite you're still having HP problems?
 
Dan
4:43 PM
Like, perhaps recreate the issue and let it sit over night
 
. . . .
Stop hanging out with tech support, you're starting to think like them.
 
Dan
Right, home time. Good luck dude
 
@voretaq7 yes, same issue...
 
@ewwhite Have you tried HITTING IT?
 
Dan
@voretaq7 What? It's reasonable - he may come back to a super delayed error message
 
4:44 PM
@ewwhite another disk?
You've narrowed it down to a disk problem?
 
@Dan it's not reasonable - if the error message takes THAT long to appear someone needs to be beaten sensible :P
 
Dan
@voretaq7 Haha, you know what I mean though.
 
now you're sounding like Microsoft tech support! "Oh don't worry it will finish eventually"
"It's been at 99% FOR THREE WEEKS YOU FECKLESS TWITS!"
 
@Dan let it sit for an hour once.
 
@ewwhite an hour is about my upper bound for "reasonable" -- "I went to lunch and came back. It was still broken."
 
Dan
4:45 PM
@ewwhite Eh, probably long enough to prove the point. How weird - HP got any ideas?
 
HP has no ideas...
 
Dan
@voretaq7 Yeah, but he's passed reasonable -he's desperate!
@voretaq7 I'm not waiting for it to fix itself - just that a progress bar isn't a useful error
 
@ewwhite Have you tried taking 100% of the cabling from a working server in the same rack and plugging it into this one?
without moving the PDU outlet it's plugged into, the switch port, etc?
 
what if it's something silly like the Java console for ILO issuing a "Pause/Break" keycode?
 
It could be a really weird environment thing
 
4:46 PM
:)
 
Dan
@ewwhite Maybe - properly weird though. What Gen is the server?
 
@ewwhite Have you got any other machines with a Java iLO you could look at?
 
The coworker has both systems running... THe original one just hung after a reboot from Windows.
G7 ProLiants.
 
@Dan In that case he should go buy a whitebox because obviously HP has been infected by Compaq's suck :)
::hides devil horns and tail::
 
Dan
@ewwhite You'd think they'd have seen it before. Have you tried testing from the real console?
Anyway, home time kids
 
4:49 PM
0
Q: large iSCSI disk a good idea on an entry-level "unified" NAS?

AdamI am working on implementing a D2D backup solution for ~150 computers based on Crashplan ProE (no cloud storage). For the storage backend, I picked up an Overland Snapserver DX2 head unit and one expansion, with 12x2TB per cabinet and I'm planning on using RAID6 on a per-cabinet level. While the ...

what.the.fuck.is.this.guy.doing?
 
@Dan That, no... I suspect the console...
 
A quick question for server admins here
 
@MDMarra ew, SNAP servers.
 
whats that mean?
 
when a new entry is added to a DNS server, any machine trying to resolve the new hostname through the DNS should see it immediately, right?
 
4:51 PM
wow the guy is getting excited about backing up 150 machines, why the hell would you do that!
@NullUserException right
 
@NullUserException yes
 
@JoelESalas No problem!
 
@ColdT @MDMarra Thanks
 
@RyanRies Have you figured out why the ad filter in those powershell cmdlets is broken yet? ;)
I'm curious
 
@MDMarra Side note from the other side of the fence; we're considering doing workstation backup (actually do on half a dozen) because people are terrible about putting things on the network. Folder redirection and roaming profiles suck on laptops (which is all we use, except admin staff who are on a TermServer anyway)
 
4:52 PM
@ChrisS Offline files
 
@MDMarra AD Filter... It works great with -LDAPFilter
 
@jscott I don't know what you're talking about ;)
 
@MDMarra I've tried that dance before... it sucked on XP, sucked-less in W7, and seems to be the same in W8 so far.
 
The about_comparison_operator indicates:

When the input is a collection of values, the containment operators and the type operators return any matching values. If there are no matches in a collection, these operators do not return anything. The containment operators and type operators always return a Boolean value.
 
I've got my fingers crossed for SkyDrive Pro, but not expecting miracles.
 
4:53 PM
@MDMarra that has the same problem (initial/returning sync) plus it introduces other issues
 
:)
 
@ChrisS Oh, definitely bad on XP
 
But I would like to know how to do it using the AD Filter syntax as well...
 
I assumed you were off of that dino
 
@ChrisS We're actually thinking about similar (won't ever happen), but have a product that supports such ridiculous ambitions, and has a backup agent and the like. Rolling your own like this guy is doing, is just insanity.
 
4:54 PM
I now have two servers... the first one is having this problem more consistently... we installed Windows.
 
@jscott put a -not in front ;)
 
anyone know if NFS shares perform better on concurrent connections and throughput versus standard window shares?
 
@MDMarra Which I actually suspect is going to be the correct answer.
 
@HopelessN00b We use SCDPM, works quite well (other than some error related to client self restore, but that's been ripped out of Win8 anyway, so I'm not as concerned long term)
 
@ColdT NFS is satan's hoof.
 
4:55 PM
@ChrisS Really though, even without roaming profiles limited users with folder redirection should make it so that anywhere they can possibly save to is on a file server (or will sync with one)
@ColdT You want to use NFS on Windows?
If not, it's not really apples to apples
 
@MDMarra i found throughput being better using NFS rather then standard shares
 
On Windows?
 
but i haven't tried concurrent connections so not sure how performance would be
yep on Windows
 
@tombull89 Are Snapservers gross?
 
Does NFS on Windows support ACLs?
 
4:57 PM
@MDMarra I know... I've just never seen it work "right".
 
no but may not be required
 
@MDMarra Yes and no... Yes to the standard 3, it shows them as Everyone, the User, and the Primary Group. No to the ACLs you're probably thinking of.
 
not granular enough permission controls unfortunately, if they implemented that...
 
I've got Samba showing ZFS ACLs "correctly" though (Windows complains about the ACEs being out of order, but that doesn't seem to affect anything as best I can tell) =]
 
@ChrisS Right, it supports unix style permissions. not actual acls
 
5:00 PM
Right
 
@MDMarra can you not just simply allow all unmapped users with no server auth, then set standard security permissions at sub-folders levels?
 
I've not found any significant difference between Samba and NFS (over TCP) performance... when tuned for the server anyway (which takes 5 minutes)
 
@ColdT Does NFS on Windows support NTFS permissions?
I didn't think it did on any NFS mount
 
@r.tanner.f I'm not a fan. Used them in a previous job. They're supposed to work like hardware RAID - RAID1 in our case. We had one in the main IT office, and one in a far server room and they basically synced to one another. They used a horrible propriatry Linuxy-thing on them that wasn't terribly easy to manage and the School's DFS just about worked. I have a feeling the school was mis-sold them.
 
But I also never thought to use it ever
 
5:01 PM
once i mounted the nfs share, if i was to create sub-folders, it gives me options under the properties for the NTFS permissions
 
@MDMarra It definitely did not the last time I looked; but that was a while ago. I didn't think the Win7 or Win8 NFS clients were any different.
 
(tested on Win2k12)
 
Oh; maybe there is something new.
 
@ChrisS they did make big revisions to nfs on windows in 2008 and later
never fucked with it though
 
@MDMarra yeah, I played with the NFS client in Vista, same as 2008.
 
5:03 PM
I thought it was mostly on the client side not the nfs server for windows
 
lol
 
<--- shamelessly whores out his problem with Server 2012 IPAM
0
Q: Windows Server 2012 IPAM feature - "Unblock IPAM Access" error/recomended action

HopelessN00bSo, I'm in the process of setting up an IP Address Management server, using the built-in IPAM feature in Server 2012, and have run into a problem that I'm hoping someone else has successfully solved. Following the technet guide here, I've installed and configured IPAM, and have provisioned it vi...

 
it amuses me that the application class for Facebook's android app ends in facebook.katana because it quite often commits seppeku on my phone.
 
@jscott @MDMarra I'm not sure, I still don't have time to really look in to it, though in that example jscott gave, the "$null" with quotes makes me a little leery, as I'm not sure if an LDAP text filter is going to correctly handle a PSVariable like $null... maybe try -notlike "*" instead (not like anything)
 
5:08 PM
You guys seen this today? youtube.com/… I've gotten 6 emails alone on it. Funny stuff.
 
@RyanRies The actual problem itself is more complicated than that. I wasn't using $null when I stumbled on it
 
@ChrisS ...not for another hour :(
 
@RyanRies the actual issue is that

get-aduser -filter {-not (description -eq "auto")} | measure-object

and

get-aduser -filter {description -ne "auto"} | measure-object

return very different values with the first one being the correct value
 
The problem appears that inside a Get-ADUser -Filter the -ne comparison operator does not return $true for a comparison when the input value is $null.
 
0
Q: HP ProLiant DL360 G7 hangs at "Power and Thermal Calibration" screen

ewwhiteI have a new HP ProLiant DL360 G7 system that is exhibiting a difficult-to-reproduce issue. The server randomly hangs at the "Power and Thermal Calibration in Progress..." screen during the POST process. This typically follows a warm-boot/reboot from the installed operating system. The system...

 
5:17 PM
Hey @Zypher @PeterGrace have your new awesome PowerShell guy answer this for me. it's making me crazy :)
0
Q: What the heck is going on with this AD filter in PowerShell?

MDMarraI recently wrote this answer and stumbled on something interesting. get-aduser -filter {-not (description -eq "auto")} | measure-object and get-aduser -filter {description -ne "auto"} | measure-object return two very different things when run against the same data, with the first command ret...

 
@MDMarra SO users Keith Hill and Shay Levy could probably explain it quite succinctly.
I totally get the negation of the -eq, in your first example, returning the correct count... First it does the -eq collection, then gets the users which aren't in that collection.
 
Sorry I wasn't more help -- I really have my head buried in PKI stuff at work today
 
Anyone here know much about bounties ?
 
But why -ne doesn't not-equal when a value is not null inside a Filter is my sticking point. Inside a Where the -ne works.
 
@Iain Bounties??
 
5:25 PM
bountys then
 
@Iain bootys?
 
@voretaq7 no
 
All I know is you can't have more than one on a question. which kinda sucks.
@Iain Why can't booty be a bounty? Hater.
 
@voretaq7 I answered meta.stackoverflow.com/questions/160929/… yesterday not long before the bounty times out and it got 4 upvotes and 1 downvote so it meets (as far as I can tell) the criteria for it to be awarded but I didn't get any
@MichaelHampton can you check something on a Fedora box for me - did a fix for bugzilla.redhat.com/show_bug.cgi?id=719001 get pushed out ?
 
@Iain Did you get two upvotes before the bounty expired (not before the grace period ended)?
 
5:29 PM
@MichaelHampton all 4 upvotes were before the bounty period ended
 
Guy didn't like answer, therefore didn't award you the bounty.
 
@Iain I think you should write a question on mSO about it.
 
Is this a question for you guys?
2
Q: Cannot seem to disable ability to view temporary internet files via group policy

greggmcfgWindows XP Pro SP3, IE8 (8.0.6001.18702), within local gpedit.msc I did the below: User Config/Admin Temp/Windows Comp/IE enabled: disable changing temporary internet file settings User Config/Admin Temp/Windows Comp/IE/Delete Browsing History enabled all (11 items) However there is a loo...

 
@Iain The thingy says "This question has not received enough attention." -- not sure what that means
 
@OliverSalzburg Yup.
 
5:31 PM
@HopelessN00b Thanks
 
@Iain Yes, it works fine on my F17 box
 
@voretaq7 Default option for "why do you want to set a bounty on this question?"
 
Oh, but it's too old anyway :P
 
@voretaq7 yeah - I know the OP didn't like my suggestion so I'm trying to figure out if you can just not award a bounty even if something meets the criteria
 
@HopelessN00b ah, yeah I never paid much attention because every time I've wanted to award a bounty there was already a dinky 50-rep one
We should convert the VTC room into a bounty room
 
@MichaelHampton cheers - would you know if that is likely to be folded into RHEL any time ?
 
If you do not award the bounty within 24 hours of the bounty period ending, half the bounty value will be automatically awarded to the top voted answer posted after the bounty start, provided it has a score of at least 2. If no new answer matches this requirement, no reputation will be awarded at all, and the reputation used on the bounty will be lost forever.
 
@Iain Hm, broken on my 6.3 box.
 
@MichaelHampton yeah - that's how I found it
 
@Iain open a bug report against EL then?
 
5:37 PM
@MichaelHampton yep
 
Good luck!
 
@MichaelHampton that's kinda why I'm trying to find out if it will get fixed because of the upstream fedora fix
 
@Iain Maybe? You might have to wait for a point release for it, though.
 
@MichaelHampton It's present in 5.8 as well, EL 5.9 is out so I may wait and see if it's fixed in C5.9 when it's out
 
@Iain I doubt it. If you didn't find an existing bug report, it's not likely.
 
5:44 PM
@jscott right.
I mean, I assume it's a bug
But I can't be the first one to have found it
 
@HopelessN00b Should we merge those IPAM tags?
 
@MDMarra, didn't want this to be an answer on your question but did see this...even though it still doesn't really help
Here on technet: http://technet.microsoft.com/en-us/library/hh847759.aspx

you can see this:

> -ne
> Description: Not equal to. **Includes a different value**.

and this:

> When the input to an operator is a scalar value, comparison operators
> return a Boolean value. When the input is a collection of values, the
> comparison operators return any matching values. If there are no matches
> in a collection, comparison operators do not return anything.

So, maybe they "sometimes" require something besides NULL/blank/empty to actually return a result/TRUE for that operator?
 
New about paged coming our way
31
Q: We're rolling out a new "Quick Start" guide to help new users learn the basics

JaydlesHere's the first one, on Ask Different. We've been working hard on ways to help improve the experience of new users, and one of the best ways to do that is to help teach them the basics about how our sites work before they run afoul of them. This will improve their odds of having a good first e...

 
@Iain yeah ours isn't up yet
we're unloved.
 
@voretaq7 have we got a new one ?
 
5:54 PM
:kicks dirt:
:stomps on floor breaker:
@Iain I assume they'll get to us eventually
SuperUser got theirs
 
@TheCleaner You'd assume that null would be considered a different value than something not null
 
@voretaq7 NO! IPAM is one of those products that's named identically to the function it performs.
 
@HopelessN00b lies. I'm sure Microsoft's implementation is grossly inferior to a clipboard and pencil!
 
IPAM is Microsoft's IPAM product. :)
@voretaq7 Yeah, seems that way to me too, given that it *won't fucking work, but that's all the more reason not to taint the practice of IP address management with the MS implementation of it.
 
@TheCleaner Yeah, that's my working theory ;) chat.stackexchange.com/transcript/message/7615042#7615042
 
5:59 PM
I've now been trying for 30 minutes to get Java working on IE10 on Win8
 
@HopelessN00b there is no practice of IP address management
that's why we ran out.
 
fucking piece of shit!
2
 
@pauska Curse, get stars.
 
@pauska which IE 10?
BTW, metro IE 10 looks like an abortion
 
@MDMarra - true, but my understanding was that the "logic" fails itself. Since a null value is a non-value and 2 non-values can't equal each other. That could explain the difference in the output between your two queries, depending on who the "math sentence structure" works out.
 
6:01 PM
@MDMarra the classic one
 
@MDMarra That's an insult to abortion doctors all over the world.
 
the JVM loads 1 time after I install it
after that I get the piece of shit "The website is trying to run JVM bla bla"
 
@MDMarra Metro anything looks like an abortion. Even the CLI in Metro looks like shit.
 
tomorrow should be interesting, exchange server is being decommissioned and moving completely to Office 365
 
@Patrick don't worry, the cloud solves all problems
 
6:03 PM
@Patrick I'd start my two-week vacation in the Amish countryside tomorrow, if I were you.
 
it's not like amazon and 365 had more outages in 2012 than I've had in my entire career running stuff like Exchange
5
 
@TheCleaner ohhhhhhhhhhhhh. if that's the case it's fucking unintuitive
 
@MDMarra - my last comment might also explain why notlike doesn't work right either
 
@pauska Until it rains, then the cloud goes away.
 
wtf, the applet loads if I run IE as administrator
 
6:04 PM
@pauska HOORAY SECURITY!
 
Management is pushing for everything on our network to go to the cloud
 
@voretaq7 I'm trying to think of a funny analogy with old condoms and so on, but I think you get the point
 
@Patrick Well, you fucked up. Shoulda put everything on AWS. You'd be able to make enough to retire in 6 months, when they decide they want it all back.
 
I'm trying to hold onto somethings and leave them internal, but the exchange server never really worked well and I had no clue how to fix it so that was management first part of moving to the cloud
 
@pauska - you prompted a long forgotten memory. I always wondered how screwed (in terms of dealing with IT) the kid would be that was born to some geeky family that decided to name him "Administrator Johnson" or similar.
or a hippy family naming their kid "Root" :)
 
6:12 PM
@TheCleaner Don't onebox: xkcd.com/327
 
hah. forgot about that one. True. My favorite still is: xkcd.com/705 for it's conciseness and imagery.
 
had a meeting at work about my busted HP ProLiants.
 
@ewwhite bet that went well
 
Yeah, the only oddness is the low-voltage DIMMS
 
@TheCleaner Love that one. After listening to this podcast I don't think it's far from the truth: blog.stackoverflow.com/2012/11/…
 
6:18 PM
@ewwhite it works when you replace them with normal voltage?
 
I don't know. I just found some normal voltage RAM
so one server will run with that
 
huh
weird
and you're positive you're not going insane?
 
Good afternooner baby dolls
 
@Goatmale coin operated boy?
 
6:27 PM
Nothing like free lunch.
 
@Goatmale So, where is it?
 
3/4 days this week I've gotten free lunch.. I think we finna get free dinner tonight during our ipv6 training.
In my stomach.
 
My boss was like, "hey I found someone with exact same problem on Server Fault"
12
 
@Goatmale You ate my free lunch, bitch?
 
@ewwhite Was it you?
 
6:29 PM
yes
 
[ Disable your Java Now ] #Exploit Packs updated with New Java Zero-Day #vulnerability http://thehackernews.com/2013/01/exploit-packs-updated-with-new-java.html #Security
 
@ewwhite hahahaha
 
@Goatmale Yeah, obviously.
 
@ewwhite I hate when Google does that to me.
 
Stack Exchange's google optimization is excellent
 
6:30 PM
@ewwhite ?
 
@ewwhite they're really not doing anything special - Google just likes us
 
@ewwhite hahahahahaha thats great
So now he knows your user name
 
@Iain I can post a question and see it in google results 5 minutes later.
no worries... coworker is #2 on DBA.SE
 
@ewwhite ah - right - I think it's usually much quicker than that
 
@ewwhite valley
 
6:33 PM
@MDMarra THIS is priority.
 
I thought you were just going to buy supermicro
 
Can't do anything until my HP order is correct.
Canceling my flight home
 
What more needs to be done there though? I thought it was just have their IT guy see if it works
 
Nothing really.
he hasn't had time to looook
Us non-corporate folks get busy
 
sorry to hear that
 
6:39 PM
For Valley, sometimes a day is derailed by a someone falling off of a pallet jack...
or a truck hitting a telephone pole
 
@r.tanner.f - yeah, love the hurricane story
 
@ewwhite Yeah, I get it. Just trying to make sure it doesnt drag out
 
@ewwhite the pole jumped out and hit me!
 
Client is asking for new SQL server
he says MS charges by core
better to go with one X5680 CPU or two?
for a 64GB instance
 
@ewwhite I would generally recommend at least 2 cores/CPUs for any DB server
(one for the OS and one for the DB server)
 
6:46 PM
THe machine would be a DL380 G7... client is asking for only one CPU socket to be populated
which limits the # of RAM slots available
 
@ewwhite ohhh that's another concern
how big are their typical queries?
 
Licensing for SQL is per core on Enterprise, but you don't have to do per core on Standard. You can license server + cals instead and is usually a lot cheaper.
 
(including join space and such)
 
I'm trying to get their info now
 
@TheCleaner well that depends on the use for the server. Don't forget the CALs are per end user of the data not per connections
last time i did the math it works out to ~20-25 end users before the per core/socket becomes a better investmetn
 
6:49 PM
@Zypher @TheCleaner Yanno, I get around this whole thing by using Postgres :-)
 
so it's not a mistake to only buy a CPU with one socket?
in this licensing case
 
@ewwhite you don't need to license all the sockets in the server IIRC
 
@Zypher - from what my license purchasing helpdesk tells me, everything changed this year with SQL 2012, and now they actually charge per core, not just per socket. But yeah, you have to do the math to decide which licensing choice to go with
 
so you could buy a two CPUs and only license 2 cores
 
@Zypher what happens if you have a 12-core box?
just license what you need?
 
6:51 PM
@TheCleaner oh yea ... i know
@ewwhite exactally - you'll have to double check that with MS but that is what i recall last time i looked when they changed the licensing
 
@ewwhite Check with your license guy at MS to see if you can - IDK if/how they restrict that stuff...
IBM style Capacity-on-Demand could be pretty slick for SQL Server
 
See here's a jacked up PDF to "explain" the whole mess: download.microsoft.com/download/F/F/2/… including crap like "core factors" and other ways to confuse the hell out of someone just wanting to buy SQL
 
@voretaq7 actually on a NUMA box running a DB I'd always go for less sockets and more cores per socket (i.e. 1 x 10c) than two sockets with less cores (i.e. 2 x 4c) simply because it's one process with one memory allocation so there's less memory-path-locking required. This is in stark contrast to say a hypervisor where there are a discrete and tuned block of threads to more smaller memory blocks
 
@ewwhite - try here too: mla.microsoft.com/default.aspx
 
@Chopper3 Yeah, that makes sense for the Windows/SQL Server world. Postgres is a process per connection (some shared memory, but lots of local-to-the-process memory, so having "local" RAM & being able to spread the load is really beneficial)
 
6:57 PM
nevermind that was worthless for sql
 
@voretaq7 I. Did. Not. Know. That. - Oracle is like MSSQL like that though
 
Someone should benchmark that for Postgres actually - they've demonstrated the linear scaling when nPROC < nCORE, but I don't think anyone's ever seen what the impact of memory locality / path distance is
@Chopper3 yeah Oracle is threaded on Unix too.
The Postgres model is a little strange b/c it's from back when threads kinda sucked, but it actually works out pretty well - the buffer cache is shared (and it uses the OS buffer cache heavily too), and so is the locking, but everything else is in its own process.
 

« first day (852 days earlier)      last day (4154 days later) »