« first day (2035 days earlier)      last day (1184 days later) » 

4:00 PM
[^b]b+[^b] or [^b]b{m,n}[^b]?
 
Then bb => b+
 
Where m, n are integers.
 
That's more than one but any number of b
@TimmyD for any number of b but at least 1: [^b]b+[^b]
 
Yep, got all that, that works for the match portion. How about the replacement portion?
 
Replace with what?
Just remove the inner bit?
 
4:02 PM
I'm intending to turn, for example, bbbaabbab into bbbaaqqab.
 
Does your regex flavour have lookahead/lookbehind?
 
^
If not, it's impossible afaik
 
p=s=>((t=s.shift())=='<'||t=='>')?[t,p(s),p(s)]:t
f=a=>a[0]=='<'?a[1]:a[0]=='>'?a[2]:a[0]
s=>f(p([...s]))
@Lynn ES6, 105 bytes
 
Yeah, it's .NET
 
You'd need to find how many b are in the middle, idk how to do that.
Ask martin.
 
4:05 PM
Yeah. Regex is one of the areas I really struggle with.
 
oh nvm it's invalid
 
It's not hard except for lookaheads and lookbehinds.
 
Retina tells me this works: (?<=[^b].*?)b(?=.*?[^b]) => desired letter
 
valid, 111 bytes:
p=s=>((t=s.shift())=='<'||t=='>')?[t,p(s),p(s)]:t
f=a=>a[0]=='<'?f(a[1]):a[0]=='>'?f(a[2]):a[0]
s=>f(p([...s]))
 
@Lynn as one of the few other Vim-golfers, I'm curious: what do you think of V? I've been wondering if it's really cheap to throw a bunch of mappings on an already golfy language and call it a new language.
 
4:07 PM
CJam comes to mind
 
With convex?
 
Even shorter GolfScript
 
Oh. Isn't convex even shorter cjam?
 
I don't know anything about it
I suppose it is
Not a bad idea considering CJam has a bunch of 2-letter operators and has explicit input
 
@BusinessCat Awesome, I think that might do it. Let me play around with it a bit.
 
4:12 PM
And Convex has Regex?!
Why am I still using CJam
 
@DJMcMayhem I don’t think I would ever pick it over Vim
 
V need Neovim and Neovim dont work on windows :/
 
@TùxCräftîñg it sorta does, it's just a pain
 
what is divmod?
 
4:27 PM
You get the div and the mod
I think
 
Honestly, the only golf-y language I like to use anymore is Jelly, because it’s so ridiculously fun/novel/powerful. I otherwise prefer to use languages “most people” can appreciate
 
Yeah, the quick way to get the mod is to divide, and in the process of dividing, you often pretty much get the mod for free, so divmod is pretty efficient in most cases.
 
@Lynn You use Vim though...
 
Well, I like to annoy Emacs users a lot of people use Vim.
 
Who actually uses emacs
 
4:32 PM
@Lynn that's sad but I can't really blame you...
 
Who actually uses Vim
 
Some people do, oddly enough
 
@Fatalize sane people
 
@TùxCräftîñg You forgot to type in
 
4:34 PM
People who don't own a mouse
 
@Fatalize Lynn, me, doorknob, Alex, downgoat, easterly, others
 
in my first job that put me on a linux machine, they also used Emacs, so I did as well
 
ಠ_ಠ_ಠ
 
And tux
 
who uses emacs?
 
4:36 PM
@muddyfish there are dozens of people who use emacs!
Probably
I think
 
Well I was going to make a poll but strawpoll kept saying I needed a title when I put one in
 
@Fatalize I see a lot more Vim usage in here than Emacs. :P
 
0
A: Sandbox for Proposed Challenges

Wheat WizardMaking change Task Given a amount money you must find the fewest number of coins that make that value. Specifications As per normal you may choose a language to program in. However for this challenge you may also choose a currency. You may choose from any of the top 3 traded currencies. The...

 
Haha, I just got mortarboard on meta. I didn't think that was possible.
 
4:39 PM
Who actually uses Vim or Emacs
should be the question
 
^
My point exactly
 
@Fatalize I do.
 
@Fatalize sane people
 
They are both terrible editors
 
DJ does, Doorknob does, Lynn does, etc...
 
4:39 PM
@Fatalize you might as well just ask "who actually uses vim"
 
@BusinessCat ಠ_ಠ
 
<grabs popcorn>
 
I use Vim and it’s pretty terrible
I bet Emacs is also terrible!
Both are powerful though
 
@NathanMerrill Do you have time to test something (and download ~300MB)?
 
4:41 PM
Emacs is even more golfy sometimes
 
But I'm seriously wondering because I have never heard anybody actually say they use emacs
 
Uhh... why
 
2G<C-a>
 
When you combine the two sides, you get something that everyone hates
 
4:43 PM
I wish I could vote “meh” on this poll
 
Dangit, ninja'd
 
Probably the text editor I’m most excited about right now is Kakoune!
 
@Lynn Do you actually use it?
 
Which is just modal Sublime Text, kinda? And does away with most of Vim’s really weird crap
I started using it a couple of days ago :>
 
Best editor was GW-BASIC interpreter style. Everything since has been a letdown.
 
4:45 PM
Sublime is just SciTe with more bells and whistles. Not as bloated as Atom though.
 
IDEs that can actually reason about your code are also nice. I probably couldn’t program Java without IntelliJ
 
Well, IDEs that run on static analysis platforms, like JetBrain's Rider.
 
The problem IMO is that Vim and friends try to save time in naïve text “micro-management”. If you have smart IDE features, basically the rest of your text editor can be Notepad and it will still kick ass.
 
@Lynn vim has GREAT plugins
 
4:47 PM
@HelkaHomba That looks like a regular albeit active forum user. No indication that the reply is from Google.
 
True; I’ve never looked into those much. I got a Python plugin one and it annoyed me. ;-;
 
@Lynn that's why my favorite ide is vsvim. All the benefits of Vim mixed the features of an ide
 
Yeah, VsVim looks neat
 
*mixed with
It's not perfect though. Normal mode is great but the ex side is seriously lacking
 
@mınxomaτ sure
 
^ huh?
 
^ what you use on your desktop/laptop
 
@ReleasingHeliumNuclei I don't understand the options
 
ok, but the answers don't make any sense (ninja'd..)
 
Are you using a Window Manager, a Desktop Environment or standard Windows desktop?
 
4:57 PM
@ReleasingHeliumNuclei You can use a WM and a DE at the same time
 
@DJMcMayhem ;_;
 
s/can//
And some people can use neither
 
@ReleasingHeliumNuclei that's what I thought it might mean, but it's still confusing as hell
 
Right now I'm a MS peasant
And what do mac users answer?
 
4:59 PM
@DJMcMayhem if they don't, they can't be here. i can't log in on cli browsers
@DJMcMayhem mac haz a de and a wm can be installed
 
No choice is applicable to me since I'm not a peasant
 
All three apply to me, I guess. I’m on Windows, which has a perfectly fine window manager (dwm.exe), and a perfectly fine desktop environment (Aero).
 
let me try to make my first poll :p
 
Why not just do a poll that's Windows, Linux, or Mac
Or something
 
5:02 PM
@BusinessCat BSD!eleven
@DJMcMayhem isn't OS X macOS now
 
bah, too much work
 
@NathanMerrill You can try out alwsl. Clone the dev branch (or just download alwsl.bat). Running without arguments (from a console) will print usage infos. alwsl install will install (backup any files from your current WSL if you have to, because it'll be reset.)
 
Idk idc
 
Don’t you mean GNU/Linux—okay, okay, I can’t keep a straight face and say that.
 
@DJMcMayhem I duel boot
 
5:03 PM
@mınxomaτ I'm assuming I don't clone from within my WLS filesystem
 
I use Windows since it's far less annoying to emulate Linux for the things I use it for than the other way around
 
@NathanMerrill haha, no.
 
@BusinessCat I’m in the same boat
 
@Lynn I'd just like to intercept for a moment.
 
Aww, being on a boat sounds good right now. Nice day out.
 
5:04 PM
@NathanMerrill I tried it in a clean Win10 VM and it installed fine. That's the best testing I can do.
 
Who said OS X ಠ_ಠ
 
the most recent commit is dev 2 days ago?
 
Yep, that's ok.
I just didn't have time to test it on a clean system until now.
If you want to be on the safe side, run alwsl remove before alwsl install.
(if you get a checksum mismatch, just accept to force the install, that's a non-critical error)
 
I've been trying to pull the branch develop
till I double checked, and realized its called dev
-.-
 
Well, I said "dev" :-)
 
5:14 PM
I know. At work we use develop exclusively, so I'm used to that
 
I just did a query with TNBDE and it seems like Tux is the only one that uses emacs (exhibit A, exhibit B, query).
 
TNBDE > strawpoll
 
@El'endiaStarman I was wondering, has anyone written a query yet to get all the vandalised feed bot posts?
 
Hm, I usually use "unstable" as the dev branch. Dunno why I did "dev" here.
 
They're near impossible to search for with built-in chat search, but I'm sure I missed some good ones.
 
5:20 PM
@MartinEnder That's easy, actually.
 
@muddyfish you fight with your OS? Haha
 
@El'endiaStarman neat :)
 
@El'endiaStarman Could you sort those most starred first...?
 
> I am slow and I feel bad about myself
 
5:24 PM
Actually reading them in posted order is interesting...
 
Turns out my "Help I'm trapped" joke wasn't all that original...
(as far as feed bot post messages go...)
 
@El'endiaStarman Even better! :)
 
@mınxomaτ I ran the command without elevation, and I only knew something went wrong at the very end when it checked to see if Ubuntu was still installed
perhaps an elevation check?
 
5:26 PM
It should run without any elevation.
 
Can you post the log?
 
Error: 0x80070091
bash: apt-get: command not found
bash: apt-get: command not found
alwsl (info): Downloading alwsl rootfs (this might take a while)...
alwsl (info): Downloading checksum for this image.
alwsl (info): Checksums match :-)
alwsl (info): Copying rootfs to temporary extraction destination.
cp: cannot stat ‘/mnt/c/alwsl/alwsl.sfs’: No such file or directory
alwsl (info): Unsquashing rootfs.
timeout: invalid time interval ‘/t’
Try 'timeout --help' for more information.
alwsl (info): Transforming...
 
what are the most started posts, can you make a query for that?
 
you mean starred?
 
SE already provides that I think
 
@NathanMerrill Run alwsl install again. "0x80070091" means Microsoft fucked up.
 
Stupid autocorrect ;_;
 
Unfortunately, there's no way to really check for these pesky 0x800 "errors" yet.
 
5:28 PM
that's fine
 
@El'endiaStarman most starred one is so meta
 
@NathanMerrill They do provide a list of starred messages, but I don't see a way to sort them.
@ReleasingHeliumNuclei It's actually the most starred message in the SE chat network.
 
@El'endiaStarman just...wow
 
It's at 90 stars now too I think
it keeps going up
 
@BusinessCat 92
 
5:31 PM
Even better
 
Why is it still going up??
 
....aww crap, I just realized that my transcript parser didn't note the messages with one star as they don't have a "1" in the HTML.
 
@El'endiaStarman idea: disable the uid and mid tables from being queried. When name or content are queried, automatically include them, then hide them from the output (and link the name/content)
@mınxomaτ I made it further...currently unsquashing rootfs
 
@NathanMerrill Auto-linking name doesn't work since there are six pairs of users that have had the same name in the past.
 
@NathanMerrill yay
 
5:39 PM
brb
 
@El'endiaStarman it does work if you include the uid in the query
 
I'll try to come up with some way of checking the MS error things.
 
I don't even know that I can disable querying of uid and mid.
 
5:39 PM
</self-promotion>
 
basically, if you see SELECT name, you automatically put , uid in the query
 
(In all seriousness I am interested in seeing a discussion about that above linked topic, because I have seen it in multiple places (besides the sandbox)
 
@NathanMerrill I feel like that's fraught with danger though.
A fully correct solution would have to parse SQL.
 
you don't ?
 
5
Q: Legal to use Pokemon, etc as Themes for Challenges?

JustinIn the Golf/Puzzle Lab, I came up with an idea to create a Pokemon Emerald Battle Factory KotH. However, I had some concerns on the legality. The closest thing I could find from Nintendo is the IP Requests and Game Submission Ideas: We appreciate the interest in Nintendo and in all our video...

Worth a read
 
5:41 PM
I thought you prevented SQL abuses?
 
@NathanMerrill No, I just run it with a user that has only read-only access.
 
ah.
and since you don't have sensitive data, you don't need to parse selects
yeah, you'd need a SQL parser
 
@Geobits should I close my question as a dupe? It seems like that is similar, but it seems to be a much tighter question. Are they different enough? I think they are, but what is your opinion?
 
Unsure. I haven't voted on it either way yet.
 
@RohanJhunjhunwala the core "rules" to a game cannot be copyrighted.
 
5:44 PM
@NathanMerrill but can the name be copyrighted?
Like Stratego?
 
@RohanJhunjhunwala Yours is about playing the game rather than using the characters/themes, so although similar I'd be interested to see what people say about it.
 
Oh sure, the name is almost always protected.
 
aka, you could make a "monopoly" KoTH, but your property names had better be different, and possibly the property values as well
ideas cannot be copyrighted, but expressions of those ideas can
 
@NathanMerrill ok, thanks, that is what I would believe too. I feel like an Ai study of a game isn't violating copyright
 
Of course, that assumes that Company Y is going to care at all. They probably won't, or ever even hear of it. But if you want to be safe, then you should rename things at minimum.
 
5:45 PM
But it would be interestign t osee a policy of how to deal with it (i.e changing the name)
 
91
Q: How closely can a game legally resemble another?

FuuMost games build on other games' successes and many are downright clones. Where is the limit of imitation before legal issues come into play? Is it down to literary or graphic work like characters and storyline that cause legal problems, or can someone actually claim to own gameplay mechanics? T...

 
@Geobits yeah, that was one of my side questions.
I.E if a frisbee golf koth would have to be reffered to as "disc golf"
 
------------------------------------------------------------------------------------------------------------------------
                      ,                       _     _ _                    |  ___ ___ _______ ___
                     /#\        __ _ _ __ ___| |__ | (_)_ __  _   ___  __  | |   Y   |   _   |   |
                    /###\      / _` | '__/ __| '_ \| | | '_ \| | | \ \/ /  | |.  |   |   1___|.  |
                   /#####\    | (_| | | | (__| | | | | | | | | |_| |>  <   | |. / \  |____   |.  |___
 
\o/
 
@NathanMerrill Might be worth linking to that in a comment on the meta post
 
5:48 PM
@RohanJhunjhunwala I'm pretty sure most leagues/clubs use "disc golf" in the first place for that reason.
 
Or frolf
 
ls: cannot access 'hiberfil.sys': Permission denied
ls: cannot access 'pagefile.sys': Permission denied
ls: cannot access 'swapfile.sys': Permission denied
 
@BusinessCat Just wanted to thank you again for that regex assist. You saved me ~67 bytes.
 
@BusinessCat Please tell me nobody actually uses that :/
 
wtf is frolf?
 
5:49 PM
Frisbee golf
 
FRisbee gOLF
 
@TimmyD No problem :)
 
Oh I love frisbee golf
its quite fun
 
Hello from Mom's phone ;^;
 
@NathanMerrill Next step: Create a unix user, add them to sudoers. Then use alwsl user default USERNAME to set them as the bash user. Update the system using yaourt / pacman. And try out the backup features (alwsl snapshot).
 
5:49 PM
@Geobits Very common term where I live.
 
Huh, never heard it. Do you live near a bunch of hippies? :P
Ya know, near Alex.
 
@NathanMerrill Uhm, what directory did you run alwsl from? You didn't run it as admin, did you?
 
@Geobits No, but I live right next to several frolf fields
 
Frolf just seems terribly awkward to pronounce.
Maybe it's just me.
 
@mınxomaτ I did run it as admin
 
5:51 PM
What the frolf??
4
 
and I ran the bat file from /c/alwsl
 
@NathanMerrill Don't do that. It isn't required and exposes you to security risks (because running a bat as admin executes it in the systemroot.
 
Dammit, I take five seconds to answer a text and miss the deleted message :(
 
right, I got that, but I was already mid-install when you said it wasn't necessary
 
0
A: Sandbox for Proposed Challenges

wnnmawHow can I get To a RepDigit Rep? Heavily inspired by this challenge In the referenced challenge, Repdigits are defined as numbers composed of repeating single digits (1, 111, 88, 99999, etc). In this challenge, we will calculate the minimum number of Stack Exchange Q/A votes it takes to take a ...

 
5:52 PM
@NathanMerrill It shouldn't cause any problems, but that's where the ls error comes from.
 
@Geobits I can't tell you what you missed, but I can tell you you didn't miss anything you'd mind missing...
 
@mınxomaτ why would that cause permission denied errors?
 
@NathanMerrill Because bash itself wasn't elevated to SYSTEM. Only SYSTEM can access such high priority files as e.g. the hibernation state driver.
Even for reads.
 
ok, reinstalling then
 
@trichoplax Thanks, the tension was unbearable. My mind is at ease now.
 
5:55 PM
;)
 
@NathanMerrill Technically, there's nothing wrong with your installation.
 
The deleted bits are not always the best bits
 
@mınxomaτ I don't want warnings every time I ls
totally worth the time to reinstall
 
@trichoplax True, but sometimes you find a diamond in the rough ;)
 
@NathanMerrill That's what you get anyway, in any WSL system. You are currently in your system folder. cd somewhere else, like ~
 
5:56 PM
@Geobits Oh yes - it's always worth looking just in case...
 
:/
 
wait, why was my system folder in /c/alwsl?
 
Or just click the "archlinux" shortcut in the start menu.
 
is that where everything goes?
 
That's your home dir.
 
5:58 PM
oh, I think I understand. "executes it in the systemroot" means literally in the systemroot folder
 
But yeah, it would probably be a good idea to alwsl remove and then save alwsl somewhere safe, like in your Documents folder, or the User folder and run it again as a normal user.
I'm going to add that as an important note to the documentation to prevent confusion.
 

« first day (2035 days earlier)      last day (1184 days later) »