« first day (1931 days earlier)      last day (1337 days later) » 

3:12 AM
@terdon "egregious" is a fun word. People should use it more often.
 
 
2 hours later…
5:34 AM
@Pandya: sure
 
@Jackzz is your .desktop file has execution permission (chmod +x)?
 
Not yet..I missed to add it..
@Pandya Added execute permission..And could execute it from file manager.. But on reboot nothing happens
 
After adding, check whether works with double-clicking with file-manager or not?
 
works
@Pandya: My application creates two files and logs error messages to one and screenshot to the other. Doubleclicking on .desktop file generates both the files.
 
5:57 AM
@Jackzz putting other .desktop files at /etc/xdg/autostart works?
@Jackzz You can also try with Exec=bash -c '/home/anaswara/eclipse_agent/bin/Screenshot'
and check if it works on startup or not?
I've to leave chat-room now, I will be back within an hour
 
@Pandya: changing the value of EXEC as u told also didnt help.. at startup the application is not executed :(
 
6:30 AM
@Jackzz Hmm.. interesting problem. (how about this?) and can give some information about your file /home/anaswara/eclipse_agent/bin/Screenshot
I mean if it is a script then can you display the contents?
By the way, Also try putting your .desktop file at ~/.config/autostart/ @Jackzz
 
I is not a script..It is the executable generated from a cpp program
I tried that...I didnt have a autostart directory in .config. So created one and tried.. Still no hope...
 
FYI:you can find most of application's desktop file at /usr/share/applications/
make sure if your Screenshot application requires additional permission i.e root-user etc.
 
6:47 AM
I copied firefox.desktop from usr/share/applications to /etc/xdg/autostart and it worked.. Browser was opened at startup..
 
tested ok
 
@Pandya: Additional permission is not required.. and if it requires should I specify something more?
 
@Jackzz I think if .desktop working fine with double clicking with file-manager as normal user, then no necessity
 
@Pandya: yes..it works fine
 
@Jackzz sorry; I can't get solution to your problem... (just for clarification: at start-up you don't find generated file as mentioned here right?)
I mean file(s) are not generating?
 
6:54 AM
Yes...files are not generated
 
By the way where file(s) are generated?
 
@Pandya: at /home/anaswara/Desktop
 
If different drive/partition, then may it not be mounted
but not in your case. ok
 
@Pandya: So????What shall I do now
 
@Jackzz I can't help in problem with launching desktop file but try to add your command with gnome-session-properties:
The problem may be: The process/application on which your Screenshot depends or defined-with may not ready/start when your Screenshot auto-starts!
@Jackzz in order to work-around for above mentioned problem you can try something like Exec=bash -c 'sleep 10; /home/anaswara/eclipse_agent/bin/Screenshot'
where "sleep 10" will hold for 10seconds and then execute /home/anaswara/eclipse_agent/bin/Screenshot.
tip: no-need to reboot, you can just check with log-out and re log-in @Jackzz
lunch time for me (in India) good-bye!
 
 
2 hours later…
9:39 AM
@Pandya: I copied a .desktop file from the same folder and edited it to run my application. And it worked... Created a new .desktop file with the same entries.. But it failed.
 
@StéphaneChazelas I've just tried to make your post better if you don't mind
@Jackzz you can compare files with diff command
 
9:57 AM
@Pandya : no difference. Onlu Name differs. Is there some other propertied to be set?
 
@Jackzz I don't think. but make sure read permission
For me, all files under /etc/xdg/autostart/ have "-rw-r--r-- 1 root root"
 
10:27 AM
@Pandya Thanks.
 
@Pandya: All files except the one that does not run have same permission as yours. Taht file has -rwxr-xr-x 1
 
11:14 AM
Friends, I need help with running a bash file...

#!/bin/bash
# Delete JUNK temp folder

if [ -d JUNK/FOLDER/PATH ]
then
rm -rf JUNK/FOLDER/PATH
echo "Cleansed JUNK directory successfully!"
mail -s "JUNK folder deleted successfully" rabanerjee@gmail.com <<< "Success!"
else
mail -s "JUNK folder not found" example@gmail.com <<< "Success!"
fi
Is the bash file OK?
And how to also attach the server time in the email?
 
 
2 hours later…
1:10 PM
@derobert So, how's the weather looking?
 
 
2 hours later…
2:42 PM
@FaheemMitha app.ddot.dc.gov <-- you can watch for yourself. blizzard warning starts at 3 PM EST
> * ACCUMULATIONS...SNOW ACCUMULATION OF MORE THAN 2 FEET.
 
3:00 PM
@casey I'm looking for a eyewitness account. I.e. my car is stuck in a snowdrift and I can't find my freaking shovel.
Are those traffic cameras live, I wonder.
 
3:48 PM
@FaheemMitha So far, nothing. Supposed to start soon though.
 
@derobert Ok. Well, keep us posted. We want a snowflake-by-snowflake report.
 
Current conditions
 
@derobert Is that home?
 
@FaheemMitha yes, that's a shot out the door to the deck
 
@derobert Do you have a house or an apartment?
 
3:57 PM
@FaheemMitha town home
similar to the ones you can see in the background of that picture (they're part of the same neighborhood)
 
@derobert town house? Like, a vertical section of a building? I lived in one of those once.
 
@FaheemMitha yeah
 
Ok. It's a curious concept, but I suppose it must make some sort of sense.
Quiet neighborhood, hopefully.
I'm remembering the big ice storm in NC in 2002. The power was out for 10 days. It was a nightmare. Like being downgraded to the stone age.
 
Wow, that's bad. Longest power outage I've had here was 2–3 days.
 
@derobert Well, it was NC. They don't know how to cope with ice storm power outages, because it happens so seldom. Plus Carrboro isn't exactly the center of things.
And it came back for a bit and went off again the middle, for a few more days, which was quite upsetting.
And at some point the water went out. Possibly for an unrelated reason. At that point I gave up and went to stay at a friend's place. In Durham. Fortunately, he didn't lose power.
But it wasn't a fun couple of weeks.
 
4:13 PM
Probably the pumping station lost power...
 
This was December 2002, if I remember correctly.
 
But that's pretty bad. I guess ice must have kept taking out the power lines? Or crazy people crashing in to poles.
 
@derobert That complex had a lot of problems with water. I think the pipes were made of some kind of plastic that has started to deteriorate.
@derobert Yes, ice on trees and maybe on power lines.
But Duke Energy was very slow to fix things, I think. The downtown shopping in Chapel Hill was back very quickly, though.
 
I guess in the US, businesses always take precedence. Amazingly, people even defend it.
 
4:15 PM
It's currently 11:15 AM here
 
We need the restaurants open, otherwise where are we going to eat? Lunatics.
 
Hah, it was probably just easier to fix the downtown area.
 
@derobert Maybe.
Have you gone in to work then?
 
Nope. Working from home.
Let's see if this works:
Ok, cool, it'll load the image from my server.
I think I've got that set up to pull a new image every 10s.
 
@derobert In anticipation of the storm?
 
4:19 PM
Yep.
Once it starts, maybe I'll make a time lapse. At least until the camera's view is blocked.
 
@derobert Will that refresh in-place then?
 
I doubt it'll refresh in place... but if you go to the page and hit refresh it'll work. And I'll probably paste it in again when the snow starts...
 
@derobert ok
 
it can do video too... but I'm not going to figure out how to set that up to stream out
 
Current listening: Brahm's Fourth. I had forgotten how good it is.
 
4:26 PM
That is a nice symphony. Brahms wrote a lot of good music.
 
I wonder if there is some way to just stream the audio from Youtube.
@derobert Yes, he did.
 
@FaheemMitha there is on mobile, don't think so on computer
of course on a computer you could just switch tabs
 
@derobert That's discrimatory. :-)
@derobert Switch tabs?
 
@FaheemMitha switch to a different tab... then you can't see the video, even though it's still there.
 
@derobert Well, it's still using bandwidth, though. That's the point, in case, I wasn't clear.
My bandwidth allowance has gone way up in the last couple of years, but it's still limited.
I guess nobody in the US worries about that.
 
4:30 PM
well, depends. Comcast has bandwidth caps.
 
Was 16GB, now 60GB. A world of difference.
@derobert Naughty.
For regular broadband?
16GB was terrible.
 
@FaheemMitha yeah. Something like 300GB though.
 
@derobert That's more reasonable, though. How's it possible to get through 300GB?
 
Introducing it has proven that it was possible for people to hate Comcast even more than they already did.
 
That's 10GB a day.
 
4:33 PM
@FaheemMitha Netflix does that easily. Something like 7GB/hr for superhd.
 
I mean, you'd have to be streaming movies more or less continously.
@derobert Wow. Scary. What about non-hd?
 
@FaheemMitha those are live traffic cams, so you can see everyone get stuck later today
 
@FaheemMitha help.netflix.com/en/node/87 ... a lot less.
 
@casey Fun.
@derobert Good to know. Did I mention that Netflix has just arrived in India?
So my question is not entirely out of theoretical interest.
 
netflix just launched in a lot of countries
 
4:35 PM
@casey oh.
 
I'm surprised, it appears I only went through 100G in the last week.
 
Only? :-)
 
i think the announced it all at the CES keynote first week of jan
 
@FaheemMitha yeah, that's not much....
 
BTW, does anyone know what the hell "see shy jo" means? I've wondered about that so long. Maybe I'll write and ask him...
 
4:36 PM
@derobert i ocassionally transfer some research datasets from the supercomputer to my local machine. typically 3 TB over a few days at a constant 65Mbps. charter has uncapped internet but I always wonder if that'll get me a phone call about usage...
 
@casey Hmm? the who? Netflix? And what is CES?
@casey Wow, that's a lot.
 
CES, also known as the Consumer Electronics Show, is an internationally renowned electronics and technology trade show, attracting major companies and industry professionals worldwide. The annual show is held each January at the Las Vegas Convention Center in Las Vegas, Nevada, United States. Not open to the public, the Consumer Technology Association-sponsored show typically hosts previews of products and new product announcements. CES rose to prominence after a rival show, COMDEX, was canceled. In May 2015, CES Asia was held in Shanghai for the first time. For 2016, the name of the global...
 
@FaheemMitha CES is the Consumer Electronics Show, a big $$$ conference where tech companies show off their latest stuff. Netflix announced service expanding to 130 new countires.
 
@derobert @casey: I see. Thanks.
 
@casey Hah, I've pegged my 75mbps upload for hours sending backup data to Amazon...
Not multi-TB, but still...
 
4:39 PM
@derobert i wish I had that kind of upload :( I only get 5Mbit/s sustained
 
@casey yeah, FiOS is nice for actually having upload speed.
Hmmm... 10AM model run says 28" is most likely.
That's ~0.7m for the rest of the world.
 
@derobert ^^^ is the 09Z short range ensemble forecast. still a lot of spread between 12 and 33" and a mean of 21". Looks like the biggest uncertainty is where the heavy snow is going to line up. some ensemble members have it a bit north of DC and some over DC. in any case, its going to be a mess
 
@casey nice chart... where'd you get it from?
 
the second graphic is the total snow accumulation (10:1 snow:liquid equivalent ratio) from the 13Z HRRR
 
4:55 PM
Not sure which location you pulled that for (DCA?), I'm much closer to IAD
 
@derobert DCA
 
Almost on the Loudoun/Fairfax border. Fairly close to the Potomac
 
anybody used at command?
 
@derobert IAD is showing a mean of 27"
 
4:55 PM
@edwardtorvalds yes, but keep in mind questions go on the site.
@casey yep
... and it looks like a greater convergence than DCA
@casey it looks like there is a 15Z run? Which isn't there yet, I guess because 15Z must be when the run starts, not finishes.
 
@derobert yea, there is a 15Z SREF run that runs based on the 12Z models and observations (the 9Z SREF is based on the 6Z models/obs)
 
0
Q: Run at command when computer is sleeping

edward torvaldsI want to schedule a job using at command, but my laptop may have gone to sleep by that time. So the question is will that command will be executed? If yes, how? I mean will my computer will wake and than the command will run or something else?

 
and yea, the 15Z doesn't appear to be in yet but should probably up within the hour
 
Yeah, it's currently ~17Z. But I imagine they take a while.
 
mp1.met.psu.edu/~fxg1/ewall.html <--- lots of model data
 
5:02 PM
@casey hah, and a good deal of it which I have no idea what it means. As expected of scientific data when you're not in the field.
 
@derobert yea, i'm not too familiar with how they run the SREF ensemble members or how long they take. GFS, HRRR and RAP get much of the runtime allocation iirc.
@derobert true, that site is information overload even when you do know what most of it means
 
@casey Hah, it's nice that they have an "E-WALL TUTORIAL" link in the top left. Don't bother clicking it, it's conveniently 404-compliant.
 
5:59 PM
Snow has just started.
 
I usually check the Related questions for possible duplicates (then flag them) before answering a question. In this case, I strongly disagree that this is a duplicate since it focuses on commands being run in the background – not enclosed in parentheses. This question is informative, thought-provoking and offers a greater insight into an aspect of subshells not covered in the “duplicate”; IMO, this deserves more attention (and upvotes). BTW, I’ve extended and further clarified my answer to incorporate suggestions from the comments (and deleted my own comments to minimise the clutter). — Anthony Geoghegan yesterday
Thoughts? Are the Qs dupes?
@derobert?
 
@terdon haven't read them yet... because SNOW. Quickly setting up something to grab time-lapsed frames. BRB.
 
Damn it! I wan't snow too! Grrr, damn this balmy, wimpy weather.
 
Ok. I think I have an every-30s image grab now. Can feed it to ffmpeg later.
@terdon Wow, that is a long answer... I'm tempted to say rambling.
 
6:19 PM
Which is why I chickened out and asked for help deciding :)
 
It's—no offense intended—really not that good of an answer.
@terdon I'd suggest leaving it alone. If 5 people think it should be reopened, they can vote to reopen it.
That answer has some stuff that could be added to the other question, like some of the tricks to make processes stick around long enough to see them, but it needs so much cleanup.
 
@derobert Fair enough. Someone flagged it which is why I was checking.
 
The answerer could of course put the good parts of his answer into a post on the other question. Maybe even edit it a little to make it slightly broader.
 
 
1 hour later…
7:41 PM
@derobert 15Z SREF is up. IAD spread is 12-41" storm total with most of the models in the range 22-33" and a mean of 27" still.
 
 
2 hours later…
10:05 PM
Hi all
Whats wrong with the following?

#f!/bin/bash
# Delete w2-9 files
if [ "$(find -type f -name 'w[2-9]*n.php'" > 1 ]
then
find -type f -name 'w[2-9]*n.php' -delete
mailx -s "W9 files deleted" "rabanerjee@gmail.com"
fi
 
 
1 hour later…
11:28 PM
@Ramnath Many things, did you try running it? Didn't you get an error message?
i) You don't want the f in #f!/bin/bashii) you need to close the parenthesis in $(find ...; iii) even if you do, the output won't be numerical so you can't compare it to 1; iv) > doesn't do arithmetic comparison, it just redirects the output of find into a file called 1.
You meant to write something like:
#!/bin/bash
# Delete w2-9 files
if [ "$(find -type f -name 'w[2-9]*n.php | wc -l)" -gt 1 ]
then
  find -type f -name 'w[2-9]*n.php' -delete
  mailx -s "W9 files deleted" "rabanerjee@gmail.com"
fi
2
Or, more simply:
shopt -s globstar
rm **/w[2-9]*n.ph && mailx -s "W9 files deleted" "rabanerjee@gmail.com"
 

« first day (1931 days earlier)      last day (1337 days later) »