« first day (1932 days earlier)      last day (1496 days later) » 

1:27 AM
@terdon: please take a look and re-open this unix.stackexchange.com/q/257082/38906
2 hours later…
3:43 AM
@derobert Well, I see the snow is mounting up.
4:01 AM
@FaheemMitha Yeah
4:32 AM
@derobert So, you're pretty much snowed in for now? How does VA cope with snow/ice? NC doesn't, really. Everything shuts down.
5:05 AM
@FaheemMitha okay-ish. Things will be open again the day after the snow stops. Except for public schools, the kids may get quite a few days off.
@derobert And when do they think the snow will stop?
Saturday night, I think. Lemme check k the forecast
Ok. That could make for a boring weekend.
Yeah, Saturday night, sometime around 1am Sunday.
So I expect traveling Sunday night won't be a huge problem, at least on major roads. Monday morning government will probably be closed, but stores, restaurants, etc. will probably be open.
Time to elevate the camera...
Now back to watching Hulu.
2 hours later…
6:48 AM
Thanks, I got it what you said. But when I run your script with the find command, the job is not getting done.

It doesn't give any error message either. I am trying to delete w909n.php. Running the find command returns that file but running the bash script doesn't delete it!
7:46 AM
Ok @terdon I just made a small change and it works. It should be -gt 0 because if the number of file is 1, the then statement was not executing. Now it works!

Now, how do I also mail the file names that were deleted? Should I store the result of the find command in a variable and print the same in my mail?
8:28 AM
@terdon I'm also able to send the file names too:

# Delete w2-9 files & send mail with file names
if [ "$(find -type f -name 'w[0-9]*n.php' | wc -l)" -gt 0 ]
w9FileNames=$(find -type f -name 'w[0-9]*n.php')
find -type f -name 'w[0-9]*n.php' -delete
mailx -s "W9 files deleted" "rabanerjee@gmail.com" <<< "$w9FileNames"
2 hours later…
10:31 AM
Umm. OK. Good for you!
1 hour later…
11:52 AM
@BinaryZebra please don't add useless comments like "thanks for the downvote". And especially don't re-add them after a mod has deleted them! They're just noise.
1 hour later…
12:57 PM
@derobert I think you need to elevate your camera some more...
Your lawn chairs are almost hidden. And good morning.
2 hours later…
3:28 PM
@FaheemMitha wow, by the time I got up... it was just white...
Elevated it again.
... that pile of cans is looking a tad bit precarious...
4:19 PM
@derobert I noticed.
@derobert Can't you use something else?
@FaheemMitha going to have to if it keeps up... I started with one can...
That's a lot of snow. Must be cold out there.
Sidebar: some people seem to think that Ian Murdock was responsible for apt. As far as I know this is not true. I saw it mentioned in a few places, including an article. But I didn't attempt to correct them.
As far as I know Ian had nothing to do with apt. He was long gone by the time it started being developed. Though I don't know the story of how that happened.
Someone should tie Gunthorps up (or bribe him with beer) to get him to tell the tale.
ffplay -loglevel trace -framerate 10 -pattern_type glob  -i 'alhazen-*.jpg'
[image2 @ 0x7ff62c009240] Could not open file : alhazen-2016-01-22T13:14:51-0500.jpg
[image2 @ 0x7ff62c009240] 0: start_time: 0.000 duration: 0.003
[image2 @ 0x7ff62c009240] stream: start_time: 0.000 duration: 258.000 bitrate=0 kb/s
[image2 @ 0x7ff62c009240] Could not find codec parameters for stream 0 (Video: mjpeg, 1 reference frame, none(bt470bg/unknown/unknown, center)): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
turns out that can't open is the real error message, not all the stuff about unspecified size
I've never heard of ffplay before.
give it the full path as part of that glob, and it works. It must chdir or something silly
4:27 PM
Bug reporting time?
@FaheemMitha one of the ffmpeg utils
ffmpeg itself gave the same error, hopefully full path fixes there too
Has anyone ever taken one of those Meyer-Briggs test things?
I just looked at one. I wonder what the result of "too lazy to take a personality test" is.
4:52 PM
Oh noes, I'm now in the 30–36" region not the 24–30" region.
@derobert What is that?
@FaheemMitha total snow amount forecast
@derobert Oh.
2 hours later…
7:00 PM
@FaheemMitha added another can...
1 hour later…
8:08 PM
@terdon Yes I've made a bit of progress but stuck a bit.

# Header file check
if [ "$(grep -ilr 'se_referrer = encodeURIComponent(document.referrer)' | wc -l)" -gt 0 ]
SusHeaderFileNames=$(grep -ilr 'se_referrer = encodeURIComponent(document.referrer)')
mailx -s "Header files with referrer tag found" "rabanerjee@gmail.com" <<< "$SusHeaderFileNames"

When I manually run it, the scripts keeps on running OR sometimes return

myscripts/delheader.sh: fork: retry: Resource temporarily unavailable
@Ramnath "Fork: retry: Resource temporarily unavailable" sounds like you're short of memory
or file handles, or some other resource
@JennyD Here's what I get:

[~/public_html]# free
total used free shared buffers cached
Mem: 32805420 31144680 1660740 13512 3566820 15828588
-/+ buffers/cache: 11749272 21056148
Swap: 6139836 1950216 4189620
Check your ulimits
[~/public_html]# ps
101596 ? 00:00:00 bash
105477 ? 00:00:00 ps
@JennyD How? :-( (I'm on a shared server)
@Ramnath What OS?
linux, BSD...?
try ulimit -a
8:24 PM
@JennyD OS is linux yes
ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) 800000
scheduling priority (-e) 20
file size (blocks, -f) unlimited
pending signals (-i) 255696
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) 800000
open files (-n) 100
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 15240
That's the problem with being on a shared system, you're a lot more limited in what you can do. If you're running scripts from your webserver under your own uid, you could be running into the open files limit.
@JennyD Still not sure why my script isn't running! FYI I've set up 3 scripts previously which runs OK.
Probably @terdon or some of the other high-rep people here is better at debugging this
If you're on a shared server, I'd try contacting the server administrator and ask for help
they will be able to see logs and things that you can't.
@JennyD True. But opening tickets is scary. RT is too long!
@Ramnath That's another of the downsides to being on a shared system :-)
8:30 PM
@JennyD LOL yes. We're 'caged' :-)
I'm sorry to not be of more help... I'm more of a general sysadmin than a linux expert, and I feel very handicapped trying to figure things out without root powers
@JennyD Not a problem. You see I'm a learner and they says ask to learn more! So I prefer to do RnD and lastly ask :-)
@JennyD UX, Inbound marketing is my fav subject.
@Ramnath Yes, that's how I started learning, too... I got into unix in the mid-90's, got a lot of help from people on the internet back then. I hang out here on unix/linux and ServerFault to pay the favour forward.
@Ramnath I know very little about UX. I'm focusing mainly on security issues, especially public key infrastructure.
@JennyD Excellent. Ok you mean public key infrastructure like e-governance?
@JennyD I've almost no idea :-(
@Ramnath SSL certificates is the thing most people know about. I work with setting up and managing the infrastructure that creates and manages the certificates.
It's used in lots of other applications too; many companies have certificates on smartcards that people use to log in, and Tesla has them in their cars to authenticate, encrypt and secure data transmissions for upgrades, and so on.
8:47 PM
@JennyD Very interesting :-)
@Ramnath I think so, too :-)
2 hours later…
11:10 PM
@Braiam He seems to think everyone on SO is motivated by points. I don't think they are. He has some valid points, but something like Stack Exchange is in large part what you make of it. You are free to ignore the reputation/points system, and I imagine many people do.

« first day (1932 days earlier)      last day (1496 days later) »