« first day (1320 days earlier)      last day (2324 days later) » 

12:03 AM
Embedded Systems is now in private beta
and there's a Linux question that I don't know the answer to
 
I'm curious, but can't get in :-(
 
@Patrick you can if you go through the Area 51 page
 
ahh, ok
Well this would be confusing, there's already someone named Patrick who's commented
oh, it was asked by a Patrick
 
 
5 hours later…
5:05 AM
Bah, I accidentally retracted my close vote and can't put it back. Can someone mark this question as a dup of this one
 
@Patrick I don't see how it's a duplicate. Maybe the answer is there, but buried in many other considerations.
 
@Gilles he stated the space comes back after a reboot. That's deleted files still being held open
 
@Patrick maybe, or it could be that there were files shadowed by his mounts
 
then they'd still be there
 
his reporting is very shaky, he keeps mixing up du and df
I don't trust him not to have done other things on the side, like mounting/unmounting
 
5:12 AM
he has already proved he's mixing output from multiple boxes. The hostname in his prompt changes through the question.
 
Nonetheless, it isn't a duplicate. I'm hesitating between answering and closing as unclear.
 
I disagree, but thats why it takes more than 1 vote :-). Thanks for the consideration though
 
 
9 hours later…
slm
2:29 PM
The suspense is killing me on getting to 80k 8-)
 
heh
 
slm
@Patrick - got your email last night, I'll send a response tonight, thanks for all the good info. Already setup a EC2 instance and was playing w/ the tech.
@Patrick - checking out corosync and redis as well.
 
@slm there you go, 80k
 
slm
thanks!
 
@slm I wouldn't worry about corosync too much, it's one of the core technologies, but it's one of those ones that you don't really mess with once it's up and running. Plus we use it in a configuration that is rather uncommon
 
slm
2:34 PM
@Patrick - OK, focus on ruby/puppet then next?
 
we used to use pacemaker a lot for the databases, but we've moved most of our databases to RDS (amazon hosted postgres)
@slm yeah, puppet would be a big component
 
slm
I've actually used ruby in the past, I wrote a reporting application for our license server quorum
 
oh, ok. good head start then :-)
 
slm
We used it to track the data from a flexlm (globetrotter) license server quorum for all the engineering applications. The app was developed in RoR
it's been a couple years so I would need to go through a refresher
Are you the other architect then?
 
yes
 
slm
2:37 PM
Cool. Why was the other arch. leaving?
 
Personal reasons. I'd rather not elaborate.
nothing wrong with the group, he's leaving on good terms, just personal
 
@slm nice! 80k! I was trying to push you over yesterday but then got distracted. Well done!
 
slm
@Patrick - that's all I wanted to know
Thanks, that's a huge milestone to me mentally, don't know why just feels like one
all help is always appreciated 8-)
everyone at work is now rooting for me to get 100k just so they can say they know that guy
 
100k needs a celebration. It's like a graduation :-)
 
slm
they said they'd take me out to lunch. So far I've gotten lunches when I've received milestone at 10k 25k 50k and 75k
I could amend my cardboard sign about working for rep to include "work for food at rep milestones too" 8-)
 
2:49 PM
lol
@slm, dude, that's really not a good subject to raise in the middle of a discussion with someone thinking about hiring you. He might take it seriously :P
 
slm
8-)
 
pays in upvotes
 
@Patrick you just found yourself the cheapest dev EVAH!
 
@slm, congrats on 80 k :)
 
slm
@Ramesh - thanks
 
3:01 PM
@slm You ought to switch your chat association to Unix.SE. A tad bit more impressive than your SO account.
 
slm
@derobert - where's that?
 
Good question. Let me find it.
chat.stackexchange.com then click your username up top
it's your "parent user"
 
slm
cool, thanks
I wondered what was driving that, thought it was just the room you first came in through
 
3:18 PM
21
Q: What should I do if I think I'll fail a drug test?

John DoeI have recently finished my latest year of college and am planning on taking an entry level (minimum wage) job for the summer to build up some cash. At the end of finals I was offered a joint in celebration and elected to smoke some of it. My college is in a state where recreational marijuana u...

Is it true that even in states like colarado where this marijuana is legalized, you shouldn't smoke?
 
3:59 PM
Hah, nice, I just got awarded a popular question badge for this question on SO.
Popular, except with voters.
(No, I'm not asking anyone to vote on it. No need to troll for SO rep. I have enough.)
 
why in the hell would that be downvoted?
seems perfectly clear to me :-/
 
I have no idea. But its best to just ignore than random -1 you sometimes get.
Often seems to be the voter saying “-1, I'm an a—hole.”
 
I think -1 when the question has no comment shouldn't do anything
 
There are plenty of those on SO. One per non-sockpuppet user, even, if you ask the pedants.
@Patrick Downvotes don't really do anything rep wise. They count for so much less than upvotes.
 
true
Maybe I should downvote more then! :-)
 
4:06 PM
Downvotes on questions are free, now!
 
slm
4:23 PM
@derobert haven't they been free for a while now? They take no rep away just substract from your daily total vote allowance
 
@slm Yeah, it's been that way for a while.
 
slm
That's often where I use a DV or on the garbage A's
It's rare though, usually DV like 5/month
maybe 10
compared to the voting I do it's in the noise.
 
4:47 PM
Yeah. Downvotes are pretty rare.
@slm Appears 4% of my votes here are downvotes.
 
slm
seems high
 
Sorry, actually, 4.7%, the way it counts votes on the profile is confusing. up+down != all
 
@derobert my rule for downvotes on questions: -1 what you were smoking, -1 I hate you, -1 I do not want your questions here, -1 I had a vote that I didn't use
 
@slm you can check your percentage by looking at the votes tab in your profile, it'll tell you how many upvotes and downvotes you have. Don't divide by 'all', though, as that also counts close, delete, etc. votes, apparently.
 
I'm more critic, I have 2989/-4263 in AU, but only 2,234 of the downvotes are on non-deleted posts
 
5:00 PM
Hrm. I swear I saw this question 2 days ago, but now I can't find it.
 
@Braiam Well, that is AU. Where honestly a lot more downvotes are required.
@Patrick Yeah. That looks familiar...
 
@derobert There it is! yes, that's the one
 
Wow. Even the same user.
 
wow, i feel stupid for not checking that :-)
 
I didn't check either. I found it via search.
 
5:26 PM
@derobert meh, still, I have more upvotes than downvotes :P
 
slm
@derobert - 0.015357572
 
So, beware of @derobert voting on your post, he's thrice as likely as @slm to downvote. And run in terror if @Braiam stops by.
2
 
slm
braiams ratios are crazy
though it's AU so the quality in the content can be more suspect
 
Of course, that's not actually a statement supported (or supportable) by the stats we've posted.
Maybe I just seek out bad posts to vote down, for example.
 
slm
I don't mean that in a mean way just the gamete is wider
 
5:34 PM
I meant my 'thrice as likely' thing. That's not supportable by those percentages.
 
anyone knows where to get the man for the fstab entries of cifs?
 
man mount.cifs
 
nope, that doesn't include netdev option
 
@braiam netdev is a generic option, not specific to cifs
so it's in man mount
 
@Patrick what an idiot I'm
5
 
5:48 PM
Thats a downvote!
:-)
 
@Patrick can't downvote chat comments, unfortunately. So you're just left with staring people's confessions.
 
anyone knows just on earth happened that op had to do this? askubuntu.com/a/372159/169736
 
@Braiam probably a missing _netdev, so it tried to bring them up before the interface was up
n/m, read he tried that.
Anyway, surely what's happening is that its trying to mount the network fs before the appropriate filesystem is up.
 
AAAAAAAAaaaaaarrgghhhhh!
-2
Q: how to select specific range of line & count the specific occurence of the first charcter w.r.t. each unique second charcter?

yogendra singhHi I have a file like this : #0 0a 1b 1c 0d xe #4 0a 0b xc 0d 1e #8 0a 0b xc 0d xe #12 1b xc 0d 0e #16 xb 1c xe #20 1a xb xc 1d 1e #24 xa xb xc xe #28 0a 1b 0c xd 0e #29 0a 0b 1c xd xe #32 0a 1b Where #0 means at time 0 , #8 means at time 8 & so on. Now I want to print the portion of this file...

I just spent a half hour writing a nice little script for the guy and then he went and completely changed the input data. Fucking users.
 
The amount of pain and suffering I've had from having network filesystems over an OpenVPN connection is, well, one of many reasons I welcome our new systemd overlords.
 
5:56 PM
pats @terdon
 
snif
 
just ask another question with the same input/output ;)
 
@terdon Problem is you answered instead of just voting to close as too broad and/or off-topic, do your own work. ...
:-(
 
@slm Hrm, what you're getting yourself into working here, just had a developer come to me wondering why this binary he put in his project won't run on our jenkins server .
The binary was compiled on his Mac OS-X machine. Jenkins box is Linux...
 
slm
HA. You use a Linux box yourself for day to day or OSX?
 
5:59 PM
@derobert I know, I know. But I was intrigued by the problem and wanted to have a go at it. I had even added a disclaimer to my answer telling him that he shouldn't do this type of thing.
Grr: " in previous examples i want the output for a , b , c , d , e same logic here the only difference in original file is that "a" may be a string with special charcter"
Yes, just a teensy, tiny detail that.
 
@slm I actually have 2 machines. one linux, other osx. Though the one I use primarily is linux. The osx is just for the occasional tool where I need a more mainstream OS
 
slm
mainstream, ouch....
 
mainstream desktop OS
better? :-)
 
slm
gracias
I use Fedora every day
what hardware do you have for your linux laptop?
 
OS X is mainstream now?
 
6:02 PM
@derobert in the image and audio manipulation stuff, yeah
 
slm
according to this it's almost 10%
 
Depends on which estimate you use, somewhere between 5–10%.
 
@derobert many corproate software vendors write OSX versions of their software, so I'd say it is
 
slm
yeah free ice cream at work today, be right back
@Patrick do you get to pick?
 
6:06 PM
@slm you could. but most people go with either a macbook, or a samsung series 9. I don't think there's anyone with something different
 
@terdon if he did it after you posted the answer, revert. If he did it while you were writing it, consider reverting.
 
@Gilles It was after Gnouc posted his answer, while I was finishing mine.
I'll see if he gives anything useful. Ideally, I will modify my script to work for him and then close as too broad.
 
@terdon is Gnouc's answer about the original data or about the changed data?
 
@Gilles Original. That's why he deleted. Look at the comments, the OP fed him crumbs of information until he realized his answer was wrong for what the OP actually wanted.
 
@terdon so both of your answers were about the original data? Sorry, I don't feel like digging through the history. If both answers are about the original data, revert the edit.
 
6:12 PM
@Gilles Yes, both were for the original. It's OK, I'll deal with it. He just edited again. If this one is something that's answerable, I'll give him his answer and VTC.
 
@terdon then revert
there's a post somewhere on MSE about chameleon questions
 
Yeah. Fell bad though since I've already asked him to edit the thing and he is trying.
Dammit. I'll just see if I can answer quickly.
Nope, another crappy edit.
I'm sorry but you're just not understanding. I will vote to close this now. You keep editing with the wrong output. If you're not willing to put in the effort to even give a correct sample, why would we be willing to help you do it? Please read the help center to understand what this site is about. We're here to answer your questions about UNix & Linux, not to write scripts for you. Perhaps you could ask here: rentacoder.ws. — terdon 10 secs ago
 
Closing as too broad.
 
@terdon ugh, that's a trainwreck
 
6:20 PM
@Braiam Yup. Vote to close would you?
 
6:31 PM
@slm oh, it just got worse. That binary he distributed, is a compiled shell script.
 
@Patrick How can you do that?
 
@Patrick wat
 
seriously! I didn't knew that
 
He's trying to put this build script in his project's repo, and the script has credentials in it, so he was trying to obscure the credentials by creating a binary and sending that to the jenkins box
 
6:34 PM
@Patrick Ah, OK, I thought you meant it would actually compile and offer the speedup one would expect from a compiled binary. That's only useful for "protecting" your code right?
 
@terdon I wouldn't even say it's useful for that. 5 seconds and the strings command and I can find that password
 
Nah, I meant protecting the source, just to make it harder to read/copy it. Not impossible, obviously, but harder.
 
well if all it does is join the shell interpreter and the script in a binary, I'm betting that script is still just a cleartext chunk of data in the binary
But i haven't tried, so dunno
 
@Patrick Who knows, maybe it is protected with cutting-edge security, like rot13.
Anyway, past lunch time. BBL.
 
heh
ciao
 
6:47 PM
@terdon Oh, zsh does legitimately support compiling into bytecode :-)
 
@Patrick Not surprised. Apparently, zsh also makes the best coffee.
3
 
zsh is the emacs of shells
2
 
@terdon that's what I say everywhere :P
it points many of the things I say everyday
 
That combined with the unix philosophy are all you'll ever need
 
> The boot screen says that some important files are missing
nice Sherlock, now fix it!
 
6:59 PM
@Braiam Basically people who thought the Europeans were gods and if they built boats, they would attract them. Presumably, that was before they started killing everybody.
Used metaphorically for cases where people believe that replicating irrelevant circumstances will bring about the same outcome.
 
slm
7:26 PM
@Patrick Oh god it just keeps getting worse.
shc = bad
1
A: How can I either encrypt or render my shell script unreadable?

slmSHC You can try the steps outlined on this website, titled: How to Encrypt Your Bash Shell Script on Linux Using SHC. This article discusses the use of a tool called SHC - Shell script Compiler. URL resources the shc tar ball the man page This is an executable that you'll have to build usin...

 
@slm I just said "no, you're not doing that". Don't worry, we don't condone evil here :-)
 
slm
was he apologetic or like whatev?
 
I wouldn't be surprised if he googled that and found your answer. You are the source of my problem!
:-P
@slm reasonable about it. I presented him with an alternate solution and he accepted it.
 
slm
what did you give him?
 
@slm trouts ;)
 
7:31 PM
Created a local account on the service he was trying to access for the jenkins box. Put the credentials in the jenkins job, not his project repo
(its some reporting thing, so jenkins can upload a build report)
 
slm
@Patrick apparently that one is mine, searching for user:885 shc turned up nothing 8-)
 
 
2 hours later…
9:43 PM
c'mon y'all.... one more vote :) meta.unix.stackexchange.com/a/2907/2511
 
@mattdm if you tell me that is a picture of dmr's dog, I'll vote for it.
3
 
@derobert Yes. Yes it is.
*shifty eyes*
 
done
 
what's a drm dog?
 
Dog that bites you when you try to watch a movie.
 
9:49 PM
only bites? great, at least it doesn't bark!
 
mattdm assures us this is a picture of dmr's dog. Although he apparently held the shift key with his eyes while typing that, for some reason. At least I think that's what the next line meant. — derobert 27 secs ago
:-P ... time to go home
 
@derobert yes, clearly there is nothing more to be done here
:)
 
Shameless...
@Braiam Dennis MacAlistair Ritchie's dog presumably.
 
 
1 hour later…
10:58 PM
Any ideas chat room?
2
Q: Debian 7 ACL Mystery

ChristopherI have looked though the answers to similar questions and refreshed my memory on ACLs by reading tutorials on Linux ACLs. Yet, I am still stumped. What have I done wrong, or what do I not understand? I have a file system mounted with the acl option. user@host:/srv$ grep srv /etc/fstab UUID=xxxx...

 

« first day (1320 days earlier)      last day (2324 days later) »