« first day (3608 days earlier)      last day (75 days later) » 
06:00 - 18:0018:00 - 00:00

yo'
6:37 AM
Seen on the internet:
user image
8
 
6:57 AM
@yo' ooh
 
7:21 AM
Has there been any change in l3doc that causes previously building documentation not to build anymore? I get the following when doing l3build doc on a file that previously built:
! Use of \_ doesn't match its definition.
\l__codedoc_tmpa_tl ->\seq\_s
                             et\_split:Nno
l.307 % \end{macro}
 
7:48 AM
@TeXnician \seq\_set\_split:Nno looks really weird. Is it the correct \seq_set_split:Nno in your file?
 
@Skillmonlikestopanswers.xyz Yes, it was to expand \BODY from environ. The variant has always been generated and worked. It's building the documentation that does not work anymore. And \l__codedoc_tmpa_tl is not from my package but from l3doc
 
@TeXnician obviously, sorry. I only took a quick look and thought those \_ look odd :)
@TeXnician can you put a \show\_ in your documentation to take a look whether something weird happened to \_?
 
@Skillmonlikestopanswers.xyz It's a DTX file translated by l3doc. Where would it be appropriate? In the macrocode itself or the documentation part?
 
@TeXnician Since the issue appears during typesetting the documentation, in the documentation so that it gets executed.
 
> \_=macro:
_tcobox_index_environment: -> \iftcb@doc@toindex SpecialMainEnvIndex{\kvtcb@doc
@sortindex \idx@actual \tcbIndexPrintEnvC {\kvtcb@doc@index }} \fi .
l.300 %    \show\_
@Skillmonlikestopanswers.xyz Seems the tcb documentation library does some strange things…
Thanks for the hint.
 
8:00 AM
@TeXnician there seems to be an \ExplSyntaxOn missing during the definition of the macro \__tcobox_index_environment:.
 
@Skillmonlikestopanswers.xyz The file it comes from (github.com/T-F-S/tcolorbox/blob/…) looks quite strange. I don't get its explization :D
 
@TeXnician @PhelypeOleinik touched some code in that general area earlier this year, it may be that tcolorbox was relying on some weird internals? Author: PhelypeOleinik
Date: Thu Jul 16 10:15:43 2020 -0300

Fix usages of \seq_set_map:NNn in the kernel
 
@DavidCarlisle Ah, okay, last time I build this file was in April, so I might try with an older version of l3doc, just to bisect.
 
@TeXnician Found the issue
@TeXnician line 891 of the file tcbdocumentation.code.tex is screwing up.
 
@Skillmonlikestopanswers.xyz Oh my. I'll probably open an issue there.
 
8:08 AM
@TeXnician The \ExplSyntaxOn and \ExplSyntaxOff in lines 884 and 897 should be before and after that macro definition. As a quick fix, put the following in your documentations preamble:
\makeatletter
\ExplSyntaxOn
\def\tcb@doc@index@doc{%
  \def \__tcobox_index_command:
  {
    \iftcb@doc@toindex
      \SpecialMainIndex{\kvtcb@doc@sortindex\idx@actual\tcbIndexPrintComC{\kvtcb@doc@index}}
    \fi
  }
  \def \__tcobox_index_environment:
  {
    \iftcb@doc@toindex
      \SpecialMainEnvIndex{\kvtcb@doc@sortindex\idx@actual\tcbIndexPrintEnvC{\kvtcb@doc@index}}
    \fi
  }
  \tcbset{index german settings}%
  \EnableCrossrefs%
  \PageIndex%
}
\ExplSyntaxOff
\makeatother
@TeXnician Also line 894 looks like it contains an error as well, I guess it should be \SpecialMainEnvIndex (they forgot the backslash).
 
@Skillmonlikestopanswers.xyz Thanks for investigating. After expl3izing \tcbset{index german settings}% into \tcbset{index ~ german ~ settings}% I get a ! Too many }'s. with your fix. Probably I'll have to remove tcbdoc for now…
 
@Skillmonlikestopanswers.xyz so we can't blame @PhelypeOleinik ? shame.
 
I was tempted to make a joke about BJ's "oven ready" thingy, but this will surely backfire at me because... well, ducks and oven...
2
 
@TeXnician sorry, I didn't foresee this :) I have no idea where this issue comes from. What happens if you \let\tcb@doc@index@doc\relax?
 
Aug 22 at 9:32, by David Carlisle
breakfast
 
8:22 AM
@DavidCarlisle oh no
 
@Skillmonlikestopanswers.xyz You did not have to foresee it. Thanks, disabling it works :D
 
@TeXnician I have no idea which other side effects this might have :)
 
@Skillmonlikestopanswers.xyz Apparently, none. The docs look good :)
 
@TeXnician what about the index?
 
@Skillmonlikestopanswers.xyz Environmentsenvname@envname … hmmm … seems wrong for environment envname
 
8:29 AM
@TeXnician so, opening a ticket it is :) Already done that?
 
@Skillmonlikestopanswers.xyz No, I'll probably need to understand your analysis before doing that :D
 
@TeXnician The issue is that the \ExplSyntaxOn can't do its thing inside the macro definition as the contents then are already tokenized, hence \ExplSyntaxOn and \ExplSyntaxOff have to be put around the macro definition, not inside it, or else \def\__tcobox_index_command: and \def\__tcobox_index_environment: don't redefine those macros but the macro \_ (as that's then not of category code letter) and this will then have the required parameter text _tcobox_index_command:.
 
@Skillmonlikestopanswers.xyz Thanks for the wrap-up, I'll open the issue in a few minutes.
 
@TeXnician if you then use \_ without putting _tcobox_index_command: directly behind it you'll get the doesn't match its definition error.
@DavidCarlisle not this time, I'm afraid :)
 
@Skillmonlikestopanswers.xyz I have opened github.com/T-F-S/tcolorbox/issues/112#issue-702574797
Thank you for investigating the matter :)
 
8:46 AM
@TeXnician no problem. Have you yet found the issue with the unmatched braces?
 
@Skillmonlikestopanswers.xyz No, I did not do any further debugging because I currently do not have the time for this. But the package is small so an index is unnecessary for that release…
 
@TeXnician ok :) I shouldn't have the time doing this as well, tbh, just procrastinating really hard :(
 
9:40 AM
@faheemjan welcome to the tex chat:-)
 
@UlrikeFischer DeviceN basics checked in - works with dvips most conveniently
@AlexG For DeviceN support in dvips, I had to do a generic FunctionType 4 setup by creating the PostScript using expl3. For example, for two 2-in-4-out:
1.0 1.0 1.0 1.0 5 index 0.1 neg mul 1.0 add mul 4 -1 roll 5 index
0.2 neg mul 1.0 add mul 4 -1 roll 5 index 0.3 neg mul 1.0 add mul 4
-1 roll 5 index 0.4 neg mul 1.0 add mul 4 -1 roll 4 -1 roll 4 -1 roll
4 -1 roll 4 index 1 neg mul 1.0 add mul 4 -1 roll neg 1.0 add 4 -1
roll neg 1.0 add 4 -1 roll neg 1.0 add 4 -1 roll neg 1.0 add 4 -1 roll
6 4 roll pop pop
@AlexG (The formula here is 1 - \prod_{n} (1 - X_{n} D_{X_{n}}) where X_{n} is the input)
@DavidCarlisle Lots of fun with PostScript
 
@JosephWright so I see:-)
@JosephWright meanwhile on interactive "live" web tutorials have you seen this, I got asked to look at it at work, and it's not bad actually (starts off painfully basic but having a live git commandline to walk through the git bisect tutorial (number 7) works quite well I think) katacoda.com/courses/git (you need to sign up with something after the first lesson but I just gave it my github login)
 
9:57 AM
@DavidCarlisle Looks pretty good
@DavidCarlisle Nice and smooth
 
@JosephWright the nice thing (@PauloCereda will confirm) is that it warns you that you will be thrown into vim, but actually you get nano (I suspect that that is a ubuntu default editor change that happened at the ubuntu container level) nano is a bit weird but a lot friendlier than vim for a beginner tutorial...
@JosephWright how many postscript functions will you end up needing? if it is much more it may be better to have a standard header file?
 
@DavidCarlisle Nano is great
@DavidCarlisle It's one per DeviceN color space, so I suspect practically 'one'; the above one builds-in the conversion factors, so you'd still need to sort that aspect; you need the same PostScript in pdfTeX, there I can use an object if we really want but honestly I don't think it's worth it
 
@JosephWright ah OK
 
@DavidCarlisle If you run through with dvips, the PostScript stream gets compressed anyway
 
10:12 AM
@JosephWright sure a header file or inlining doesn't make much difference in the postscript, but the dvi file can be smaller if there is a lot (eg all the dvips colour names would have been a lot at the time)
 
@DavidCarlisle tnx alot david
 
@DavidCarlisle Ah right
 
@DavidCarlisle bah
 
10:33 AM
@JosephWright How do you embed this as a /FunctionType 4 dictionary into PostScript and will a PS viewer be able to render this?
 
@DavidCarlisle welcome to the chat, mr. Carlisle
 
@PauloCereda I have been here before, you may not have noticed.
@barbarabeeton on \if@measuring look in amstex.tex :-)
 
@DavidCarlisle really?
@DavidCarlisle I am a duck :)
 
@PauloCereda and it's getting close to lunchtime
 
@DavidCarlisle oh no
@DavidCarlisle so no dungeon for us this year?
 
10:41 AM
@PauloCereda we failed to wind up so I suppose we have to have a virtual dungeon
 
@DavidCarlisle I blame our secretary
 
@AlexG It goes into the tintTransformation part of a DeviceN color space; there, we are required to provide a PostScript trasformation, viz.
> The tintTransform procedure is called with n tint values on the operand stack
and must return the corresponding m color component values, where n is the
number of components needed to specify a color in the DeviceN color space
and m is the number required by the alternative color space.
@AlexG So it's equivalent to FunctionType 4 in the way it works
@AlexG And yes, it does work (it's easier to test than pdfTeX as I don't have to manually handle page resources in the PostScript route)
 
@JosephWright Thank you! That is, there is no occurrence of /FunctionType 4 in the PS code?
 
11:04 AM
@DavidCarlisle Of course you can't. I never break the entirety of LaTeX's package option system code :-)
 
 
1 hour later…
12:23 PM
oh more chocolate interactions
 
12:35 PM
@PauloCereda I could no longer resist this discussion and finally caved in and picked up chocolate bar on my way into the office
 
@samcarter_is_at_topanswers.xyz YES YES YEEEEES
@samcarter_is_at_topanswers.xyz that's the wisest decision ever made in the light of that series of posts. :D
 
@PauloCereda :D I wonder if people who drink alcohol have the same problems when using homebrew to install things....
 
@samcarter_is_at_topanswers.xyz LOL
 
12:53 PM
@samcarter_is_at_topanswers.xyz I have similar issues with cygwin and have to eat a swan duck.
 
@PauloCereda texdoc llmk siguiendo el estilo de arara ...pero en Lua :-)
 
@PabloGonzálezL :)
 
@DavidCarlisle :D ducks because hunting swans meant too much trouble with this nice lady and her corgis?
 
@samcarter_is_at_topanswers.xyz yes
 
@DavidCarlisle What a model citizen you are! She should give you a medal :)
 
1:01 PM
@DavidCarlisle oh no
@samcarter_is_at_topanswers.xyz Sir Carlisle, Knight of Longtable
 
@DavidCarlisle Since you are an expert in doing things using the `picture` environment, you can do some equivalent to:
\begin{tikzpicture}[remember picture, overlay]
% some extra trickery to ensure that the grid only has whole squares
\draw[step=20pt, gray!40, thin]
let \p1=(current page text area.south east),
\n1={20*int(\x1/20)},
\n2={20*int(\y1/20)}
in (0,0) grid (\n1,\n2);
\end{tikzpicture}%
(https://tex.stackexchange.com/a/562833/7832)
using `picture` environment?
 
is there a tool to remove or tell you what you can remove from your preamble?
 
@Anush Remove one line at a time and try to compile. If it fails, bring the line back. Rinse and repeat. :)
 
:) I guess that is linear time assuming none of them depend on each other
in which case, it isn't
 
Carlisle Castle is situated in Carlisle, in the English county of Cumbria, near the ruins of Hadrian's Wall. The castle is over 900 years old and has been the scene of many historical episodes in British history. Given the proximity of Carlisle to the border between England and Scotland, it has been the centre of many wars and invasions. During the Jacobite Rising of 1745-6, Carlisle became the last English fortress to undergo a siege. The castle was listed as a Scheduled Ancient Monument on 7 August 1996.Today the property is managed by English Heritage and is open to the public. Until recently...
@PauloCereda ^^^
 
1:07 PM
@samcarter_is_at_topanswers.xyz ooh a castle
 
@PauloCereda so no linters for latex?
 
@PauloCereda Probably with a very long room for the table
 
@samcarter_is_at_topanswers.xyz ooh perhaps the table is... long? :)
@Anush macro expansion languages are a bit different niche.
 
@PauloCereda true.. I see there is chktex and lacheck but they don't look maintained
@PauloCereda is there any reason why it would be more difficult than in a standard programming language?
 
@Anush Try to lint mirrors.ctan.org/macros/plain/contrib/xii/xii.tex which is valid TeX ;)
 
1:12 PM
@TeXnician a very practical solution, thank you :)
 
:55560663
\documentclass{article}

\begin{document}


zzz

zzz

\begin{center}
  \rule{3cm}{3cm}
\end{center}

\nobreak
\leaders\hbox{%
\begin{picture}(0,20)
\put(0,00){\line(1,0){360}}
\multiput(0,0)(20,0){19}{\line(0,1){20}}
\put(0,20){\line(1,0){360}}
\end{picture}%
}\vfill

\end{document}
@Anush if you started from some online "template" the best rule is remove everything and then just put back definitions you actually use.
 
@DavidCarlisle yes. I can see it is doable by hand although a little annoying
 
@TeXnician @Anush anyone should be able to tell by inspection that that is error free
 
@Anush There is a Q&A site that has a "code review" question type. In such a review, people could tell you which packages you need and which can be removed
 
1:23 PM
@Anush If you find you need to remove something then the real question is why did you add it in the first place ?
 
@DavidCarlisle Great, you should write a picture manual, some quick reading in the style of the 1318 pages of TikZ :)
 
@PabloGonzálezL read the source, Luke
 
@DavidCarlisle I always encouraged myself to use pstricks, but, the truth is that picture can do a lot of tasks in a much simpler way. I will read the sources in my free time (although I don't know if I understand them completely :_)
 
@DavidCarlisle I gave the same advice.
 
1:49 PM
@DavidCarlisle copy and paste from the previous talk in the series :)
 
@Anush don't do that: there really is no automatic way to check if a package is used. If you add it then you need to be responsible for removing it.
 
@DavidCarlisle it's not just packages. Also a great pile of definitions
 
@Anush even less chance of an automated way to check if a definition is used.
 
@DavidCarlisle well trivially if I define \E and then never use it that could be detected automatically
 
@Anush no. How do you (or any checker) know that \section does not use \E internally.
 
1:53 PM
@DavidCarlisle well...you can see that it is not used in the code that is being analysed can't you?
I mean grep would tell you
but I do accept that to do it properly needs the full renderer
this may be a situation where the best is the enemy of the good.
 
@Anush try redefining \' for example then see what happens to words like café
@Anush to get even close.
 
@DavidCarlisle nice example
luckily we have a full renderer :)
 
@Anush it happens all the time people define one letter shorthands like \c or \H or \r and break the latex character encoding mechansim
@Anush but it can not tell you if your definition is used.
 
@samcarter_is_at_topanswers.xyz Thx for placing a bounty! If you think you know an answer to tex.meta.stackexchange.com/questions/8662/… , please feel free...
 
@DavidCarlisle ok thanks
 
2:00 PM
@Anush random search on site shows up \patchcmd{\@caption}{\csname the#1\endcsname}{\csname fnum@#1\endcsname:}{}{} so, given that you need to know what \patchcmd` does (it isn't a standard command so that means knowing etoolbox in advance) then it needs to know that the internal command is used by \caption so (probably) this definition has an effect if the document uses \caption and does not have an effect otherwise
 
got you
I am more thinking of what a person would do. That is remove a line, run pdflatex, look at the output for errors
 
@Anush a misguided person might do that. A well behaved person would not have added it unless they wanted to change the caption processing.
 
@DavidCarlisle :)
 
@Anush I already told you what a person would do: Wipe out your entire preamble, run TeX in batch mode, check for all the errors thrown, go fix them by adding things back, rinse and repeat.
 
@Anush That wouldn't work either. Remember when you removed the pgfmathparse line and all your colours turned red? Code would still compile without error, but would not do what you want.
 
2:02 PM
@Anush you will not get errors just get different layout, how can you automatically check if a layout change is intended?
 
@Skillmonlikestopanswers.xyz right.. that's the same but the other way round
 
@Anush should be faster.
 
@DavidCarlisle I guess you could compare the outputs to the original
@Skillmonlikestopanswers.xyz cool. Sounds like a good idea
 
@Anush you could but that is not automatic and a log way from "grep"
 
@Anush oh, comparing the output might take some time...
 
2:04 PM
@DavidCarlisle I guess that could be automatic
 
@DavidCarlisle I agree, the logs might help :)
 
@GeekestGeek You're welcome!
 
@Skillmonlikestopanswers.xyz I am not sure how long though. I suppose it would be under --expensive in the options :)
 
@Anush we have l3build regression tests that can check normalized, uncompressed output but that is so far from basic user "clean up preamble" usage it is more accurate to say it is not possible.
 
@DavidCarlisle nice. does it just do a binary file comparison?
 
2:06 PM
@Anush The most useful approach would be to try to understand what your preamble does and then you know which packages/macros you still need for your document
 
@samcarter_is_at_topanswers.xyz that is true
 
@Anush text comparison of uncompressed pdf after some normalisation to ensure dates and unique ids and stuff are removed, but it doesn't make sense to do that on a thesis docuement it is designed for unit tests of specific features to check that @PhelypeOleinik doesn't break the format.
 
oh interesting. So no comparison of images
 
@DavidCarlisle Poor @PhelypeOleinik, what happened to @UlrikeFischer?
 
@Anush as I say regression testing is a completely different issue to cleaning up real documents from beginner user errors of cargo cult pasting code from previous docuements
 
2:09 PM
I am feeling suitably dissed
 
@Skillmonlikestopanswers.xyz she is having a holiday so I let her off for a day or two
3
@Anush :-)
 
@DavidCarlisle no offence taken :)
 
@Anush that's what you get for not believing us in the first place :)
 
I believe you! I just like to talk though ideas
even if they will probably be bad :)
 
@Anush actually my reply was to your original wording "now image comparison" I thought you were suggesting going further and doing image comparisons of the pdf views) (we have considered that but don't) it does read a bit harsh now you have changed "now" to "no" :-)
 
2:12 PM
:) typos are the bane of my life
made infinitely worse by my phone which tries really hard to make me text nonsense
 
@Anush as you can see above I never make typos, ask @barbarabeeton who has proofread several of my documents
 
:)
is image comparison not a realistic thing to do or is it just speed that is the problem with it?
 
@Anush it's hard and slow and hard to know what to do when it fails. If you change 100 lines in the latex source between release a and b and find that some pixels change in a test result document then in theory you might be able to work backwards and see what changed but 999 times out of 1000 it is more informative if your test had used \showoutput so the log has a text version of the output tree and then when you see a diff in that you know which character on which line changed position
 
@DavidCarlisle -- Can you point me to the question, please, I'm not totally surprised that I got the reason wrong, but when both the first and second lines were flush left, the first line started distinctly to the right of the second (although not very much). So, somehow, a thin space was getting inserted before var.
 
@DavidCarlisle I am surprised it is slow. Is this because of pdf compression (or the time to convert from a pdf to an image)? Comparison of raw images shouldn't take much longer than the time to read them in
 
2:20 PM
@barbarabeeton I was refering to a coment on topanswers (which just surfaces in a git bug report) but I noticed afterwards it is from a while ago. You have a comment saying to look when \ifmeasuring@ got added to amsmath, I just meant it was there from before the start. topanswers.xyz/tex?q=1126
@Anush well for log based tests we don't even make a pdf just run latex not dvips/ps2pdf etc,@Anush also we need to get the same results on all kinds of platforms
 
@DavidCarlisle -- Thanks.
 
@DavidCarlisle got you. I guess you have more need for speed than me as I can wait a few seconds for my one document
and only have one platform
 
@Anush the oberdiek collection (before we split it) took about two hours to build and test....
 
painful
 
2:41 PM
@Anush given the nature of a macro expansion, it might be impossible to predict things in an apriori fashion...
 
@PauloCereda got you but you can always run it through the renderer, right?
 
@Anush referential transparency might cause you problems.
 
@Anush Do you know C and the C macro preprocessor?
 
@PauloCereda almost seems like a project worth starting now :)
@TeXnician yes indeed
 
hi everyone, I have this error that I hope knows how to solve it.
 
2:45 PM
Unless you have some sort of macro expansion system relying on a good catamorphism algebra.
 
@PauloCereda if only anyone had ever finished a thesis on macro expansion systems
 
I upgraded my MacTex to 2020 and this is what I got when I compiled my file Error: Undefined control sequence. \beamer@endinputifotherversion
, any idea how to solve this
 
@DavidCarlisle \def\thesis{\thesis}
 
@PauloCereda tail recursion, must be worth a thesis any day.
 
@Anush Well, TeX is much more like the C macro preprocessor than a typical programming language compiler. And as with that one, the expansion is the hard part. Imagine having a compiler that would not separate the preprocessing step but translate the C and insert macro expansions when needed. So even the C macro preprocessor which makes debugging really hard, is much easier to grasp than a TeX compiler is…
 
2:47 PM
@DavidCarlisle LOL
 
@Diana show the actual error lines from the log (if you paste here hit the fixed text button so line endings are kept)
 
@TeXnician understood. I was thinking of something different. Imagine what a human might do. Start with an empty preamble and add one line at a time. Each time run pdflatex and look for errors and maybe look at the pdf produced and compare it to what they know it should look like
 
@Anush in a very well behaved scenario, it's possible to track things to an extent, which is probably what those tools assume.
@TeXnician oh no
 
so the idea is just to mimic what a human would do
 
2:48 PM
@Anush humans don't know what they want :)
5
 
nothing more (or less)
 
Humans would come to the TeX chat room here and starting asking questions nonstop. :)
 
@Diana Do you have a MWE?
 
@PauloCereda That could be bad if the bot does that :)
 
@Anush Yes, but a human could know what he has written. The computer does not know. And imagine packages doing \def\x{a} and another package doing \def\x{a\index{a}} but maybe the document does not print the index. You would miss that there's a difference of meaning…
 
2:49 PM
@Diana @samcarter_is_at_topanswers.xyz just arrived, she knows about beamer stuff...
 
@Anush :)
@TeXnician exactly!
 
@TeXnician we know what the final pdf is meant to look like in this use case
 
@Anush but you know how to fix it? :)
 
so it's easier than a programming task where you can't know if two pieces of code are equivalent
 
@Anush Okay, granted. But what if there's a difference in spacing which is just not apparent because TeX's glue caused the line to look exactly like it would without the difference. Or the aux files have a difference which would only become visually distinguishable in the next run? There are so many influences such a potential program would have to know about…
 
2:51 PM
You are assuming you just had to find the correct guess from a powerset of packages, but it does not work like that.
 
LOG FILE :
This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020) (preloaded format=pdflatex 2020.9.15) 16 SEP 2020 18:50
entering extended mode
restricted \write18 enabled.
%&-line parsing enabled.
**EMTH_250.tex
(./EMTH_250.tex
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-03-06>
(/usr/local/texlive/2020/texmf-dist/tex/latex/beamer/beamer.cls
Document Class: beamer 2019/09/29 v3.57 A class for typesetting presentations
(/usr/local/texlive/2020/texmf-dist/tex/latex/beamer/beamerbasemodes.sty
 
@Anush not really, knowing if some code does nothing and can be removed is the word problem and provably impossible, so that seems quite hard.
 
@PauloCereda it's potentially not just usepackage in the preamble
@DavidCarlisle Isn't that what I said?
 
@Anush That does not make it easier ;)
 
I'm getting the (file not found ) error
 
2:52 PM
@Anush it is worse then, how would you check inter-package dependency?
 
@PauloCereda you just literally run pdflatex
 
@Diana I meant post the part of the log with the error message
 
and look at the output
 
@TeXnician Can test this file in ConText
\usemodule[scontents]
\starttext

\startscontents[store-env=another]
Leaving:
\stoptext :D
\stopscontents

\startscontents[store-env=test]
\begingroup
\catcode`\|=0
|def|something{I am verbatim!}
|endgroup
\something
\stopscontents

\startscontents[store-env=test]
\hello :D
\stopscontents

\newenvsc{scnest}[store-env=nest]

\startscnest
\def\nested{A}
\startscnest
\def\nested{B}
\stopscnest
\stopscnest

\Scontents*{\abcde}
\Scontents*|\fghij|

\meaningsc[1]{contents}

\meaningsc[2]{contents}

\typestored[2]{test}
 
@Anush why do you want to remove stuff anyway, not adding it is good, but once it is there removing it has few advantages
 
2:54 PM
@DavidCarlisle I know! :)
I have to go... great chatting
 
@TeXnician I get tex error > tex error on line 99 in file /usr/local/texlive/2020/texmf-dist/tex/latex/l3kernel/expl3-generic.tex: ! I can't find file l3backend-luatex.def'.`
 
@Anush we used to have a bot here.
 
its the error of log file not found
 
@DavidCarlisle people want η-reduction. :)
 
@PauloCereda is that like lunch?
 
2:55 PM
@PabloGonzálezL Same here.
 
@DavidCarlisle oh no
 
@PabloGonzálezL that is a known issue. I could blame @JosephWright but that wouldn't be polite (actually perhaps I could blame @PhelypeOleinik) Not my fault anyway.
 
@Diana MWE or complete log file?
 
@TeXnician Thanks
@DavidCarlisle Okay, at least it's not my fault :)
 
O.k, it looks like I need to update my texmaker after I updated my Mactex? could that be the problem
 
3:00 PM
@Diana no, texmaker is just an editor
 
3:11 PM
@PabloGonzálezL actually it might be I may have misread your message, you should have that file at /usr/local/texlive/2020/texmf-dist/tex/latex/l3backend/l3backend-luatex.def
 
@DavidCarlisle Mmm
$ ls -l /usr/local/texlive/2020/texmf-dist/tex/latex/l3backend/l3backend-luatex.def
-rw-r--r--. 1 root root 22468 sep 11 17:56 /usr/local/texlive/2020/texmf-dist/tex/latex/l3backend/l3backend-luatex.def
 
in listings (using beamer) how would I set basicstyle=\linespread{0.9}\ttfamily for just one frame?
 
@Anush you could try a lot of lines from the code in the manual, taking them in and out and see if they match the output you want. :)
 
@Anush \begingroup\lstset{basicstyle=\linespread{0.9}\ttfamily}\begin{frame}<stuff>\end{frame}\endgroup.
 
@Skillmonlikestopanswers.xyz <3
 
3:16 PM
@Skillmonlikestopanswers.xyz oh that's quite ugly :( I just want to reduce line spacing for one instance of lstlistings
 
@Anush In that case \begin{lstlisting}[basicstyle=\linespread{0.9}\ttfamily] should do.
 
@Skillmonlikestopanswers.xyz oh that does work! I thought I tried it before. Thank you
 
@Anush You're welcome
@Anush note that there is a difference between one listing and one frame :)
 
@Skillmonlikestopanswers.xyz ooh a difference
 
@Skillmonlikestopanswers.xyz :)
 
3:19 PM
@PauloCereda that's just to push the ooh-counter!
 
@Skillmonlikestopanswers.xyz <3
 
@PauloCereda try running texdoc ooh a few times in a row (for me it opens a different documentation on each run)
@PauloCereda I feel like we should create a new package called ooh (not sure what it should do, or what that acronym should mean), which then has a counter called ooh, such that there is finally a good reason to use \value{ooh} in LaTeX.
 
@Skillmonlikestopanswers.xyz oh my
@Skillmonlikestopanswers.xyz ooh
@Skillmonlikestopanswers.xyz it should have \zzz too
 
@PauloCereda absolutely. Only so that @DavidCarlisle can't assume it being undefined anymore!
 
So thats the MWE and thats the error
 
3:30 PM
@Skillmonlikestopanswers.xyz Levenshtein distance
 
@Diana please don't post code as an image! It seems like your editor can't find the binary to start it.
 
@Diana The path might be wrong. I vaguely remember that new mactex had to use another default location because apple did some stupid things to user permissions
 
@PabloGonzálezL yes, I just think it's funny that it seems to pick a random one of those tied.
 
@Diana Can you open a terminal and try "which pdflatex"
 
I did the answer is (/Library/TeX/texbin/pdflatex)
 
3:33 PM
@Skillmonlikestopanswers.xyz I am entertained :) I have read a lot in this quarantine
 
@Skillmonlikestopanswers.xyz Sorry about that, but I had to show the error
 
@Diana no problem, the issue isn't the code after all :)
 
@DavidCarlisle what is it specifically about underset that is causing the problem with smashoperator?
 
@Diana Can you check this directory if this is indeed the location of the binary or a link to somewhere else?
 
@PabloGonzálezL I discover so many packages this way I haven't ever heard of. Did you know the ofs font selector?
 
3:35 PM
@Skillmonlikestopanswers.xyz I know its not the code since it was working very well before the update
 
@Diana Off-topic: you don't need to load graphicx, beamer already does that
@Diana that does not mean anything, the code in the distribution might have changed
 
I checked in the preferences its ("/library/TeX/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex)
 
@Skillmonlikestopanswers.xyz Interesting, you tried texdoc context
 
@PabloGonzálezL I get npp-context-manual
 
3:40 PM
@DavidCarlisle I read that but you don't mention underset do you?
 
@Skillmonlikestopanswers.xyz That's the fun part...you wait for one thing...and you get another :)
 
is that the only thing that will cause this problem?
 
@Diana Try 1) with Library 2) check in this folder if these are symlinks and if yes if they work 3) try "pdflatex" -synctex=1 -interaction=nonstopmode %.tex in the preferences --- I'll have to go, can look again tonight
 
@PauloCereda you should really take a look at texdoc duck, so that you can finally pay up!
 
@Skillmonlikestopanswers.xyz OH MY
 
3:43 PM
@Skillmonlikestopanswers.xyz Jjajjaj
 
@wtsnjp 'ello :)
 
@Anush why do you think its underset rather than the multiple box assignments that is the issue? (I haven't debugged the code examples at all yet)
 
Congrats for llmk being included in TL!
 
@PauloCereda Hi! Thank you!
 
@DavidCarlisle no reason other than a lack of other examples yet. It might be good to try to make some different examples
 
3:45 PM
@wtsnjp Entertainment for this afternoon, read what the hell is 'TOML' :-)
 
@PabloGonzálezL Thanks, good to know. I hope it was easy to get the idea, thanks to TOML's nice official website ;-)
 
@wtsnjp TOML is a nice format, we use it for TeXplate. :)
 
@DavidCarlisle imho the basic problem is sbox:
\documentclass[xcolor={rgb}]{beamer}
\setbeamercovered{transparent}
\setbeamertemplate{navigation symbols}{}
\usepackage{mathtools}
\newsavebox\testbox
\begin{document}
\begin{frame}[plain,t]
\begin{align*}
\onslide<2->{&xxxxx \sbox\testbox{abc}\usebox\testbox}
\end{align*}
\end{frame}
\end{document}
 
@UlrikeFischer I was rather hoping you would show up:-)
 
@wtsnjp It is super well explained ... @PauloCereda I think it will take less time than reading the documentation of arara :-)
 
3:51 PM
@DavidCarlisle you should have pinged me with a blame;-)
 
@UlrikeFischer see the comment on the right
 
@PabloGonzálezL you are mean
 
@UlrikeFischer oh I see \setbox\testbox\hbox{abc}\usebox\testbox works so it's the color save...
 
Today my results came back negative (I got tested for Corona)!
 
@DavidCarlisle yes, beamer calls it "transparent" but actually it is a gray color, and it is reset to black. Real opacity would probably work.
 
3:55 PM
@Skillmonlikestopanswers.xyz That's excellent... in the place where I live has us locked in stage 1 :(
 
@UlrikeFischer ah I never checked that I thought it was using the opacity settings, so it is setting a colour but not via the color stack?
 
@PabloGonzálezL well, I'm home sick anyways (that's why I wanted the test, seems like I catched a cold)
 
@Skillmonlikestopanswers.xyz Here we are in the middle of spring, the perfect days to go for a run...but you can't :(
 
@DavidCarlisle probably but I haven't yet traced everything. I only saw a \sbox and color and then could remove the mathtools stuff.
 
@PabloGonzálezL I'm sorry to hear!
 
4:00 PM
@Skillmonlikestopanswers.xyz We will have to continue like this for some more time...perhaps @PauloCereda will finish his thesis in this time :)
 
@UlrikeFischer that's a great example!
 
@wtsnjp If you have some time you could include this new utility in (tex.stackexchange.com/questions/64/… say that nobody reads the documentations :(
 
@PabloGonzálezL oi
 
@PauloCereda -_-
 
4:11 PM
ooh n
 
@UlrikeFischer you traced enough:-)
0
A: smashoperator seems to break beamer transparency

David CarlisleIt actually works if you add \everymath{\def\sbox#1#2{\setbox#1\hbox{{#2}}}} although that isn't a real fix. \sbox in addition to the \setbox primitive pushes and pops the current color but the light grey transparent effect isn't set up for that..... This takes a slightly sledgehammer approach a...

2
 
@PabloGonzálezL Thanks and I will think about it for some time. Let me see someone will find the tool useful (or not)
 
@DavidCarlisle I don't think that the problem is math, or the align two pass, but the tabular grouping due to the & inside the onslide:
\documentclass[xcolor={rgb}]{beamer}
\setbeamercovered{transparent}
\setbeamertemplate{navigation symbols}{}
\newsavebox\testbox
\begin{document}
\begin{frame}[plain,t]
\tracingmacros=1
\begin{tabular}{ll}
\onslide<2->{xxxxx\sbox\testbox{abc}\usebox\testbox}
\\
\onslide<2->{&xxxxx\sbox\testbox{abc}\usebox\testbox}
\end{tabular}
\end{frame}
\end{document}
 
@UlrikeFischer yes I just used everymath there as I started to change mathtools to swap some sbox to setbox and there were lots of them so I just wanted a global change and restricted it to math for safety
@UlrikeFischer hang on let me run that...
 
@Skillmonlikestopanswers.xyz Yes, currently Texdoc behaves randomly if multiple package names that have the same Levenshtein distance found.
 
4:22 PM
@UlrikeFischer hmm I suppose I should look at showoutput and see where the restores went, but the halign grouping is not generally messed up by having & in \onslide the alignments is OK, just the colour stack messed up?
 
@DavidCarlisle yes, \current@color is gray before and black after the &.
 
@UlrikeFischer so why is the xxxx grey (confused)
 
@DavidCarlisle that is the question ... ;-)
 
@Skillmonlikestopanswers.xyz I don't think the behavior of Texdoc is ideal, but I couldn't find a way to "evaluate" the most suitable package. Picking up the first one in alphabetic order is possible, but I could not find a good reason to prioritize packages whose names start with "A" ...
 
@UlrikeFischer I suppose current@color has got reset but not the backend color which is still grey
 
4:27 PM
@wtsnjp you could assign every package written by me highest priority :)
 
@Skillmonlikestopanswers.xyz Oh, good idea! lol
 
:55563665 that looks ok.
 
@UlrikeFischer did I say otherwise? :-)
 
@DavidCarlisle I saw nothing
 
@Skillmonlikestopanswers.xyz that would clearly be the wrong approach.
 
4:30 PM
@DavidCarlisle psk, should he favour your code instead?
 
@Skillmonlikestopanswers.xyz I assume that is already done
 
@DavidCarlisle but nobody wants to see the documentation of colortbl!
 
@Skillmonlikestopanswers.xyz why not? there are so many table questions here, having some good stylish example tables to copy would be a good thing.
 
@DavidCarlisle I fear it would harm there eyesight!
@DavidCarlisle you know, maybe their eyes will overflow from joy for all those good stylish example tables and that overflowing joy might then severely damage the eye.
 
Sep 7 '17 at 7:36, by Christian Hupfer
@Skillmon: You are mean ;-)
 
4:40 PM
Sep 7 '17 at 8:16, by Skillmon
@ChristianHupfer it's called honest.
 
5:03 PM
@PauloCereda -- sigh. My new laptop seems to have a will of its own. If I don't watch the keyboard constantly, to make sure my fingers are nowhere near it, it does peculiar things all by itself. (I'm still just too used to a keyboard without a touchpad. Old cats.)
 
@barbarabeeton ooh cats :)
 
@barbarabeeton you should be able to deactivate the touchpad if you don't like it.
 
5:21 PM
@Skillmonlikestopanswers.xyz -- Yes, I know, but until I get a reliable plugin mouse, I wouldn't be able to do anything at all, including login, since I'm not running as root and have to select the login account. That's not a real good idea.
 
@barbarabeeton some laptops support switching the touchpad off via a key-combination (usually it's among the Fn key functions)
 
@Skillmonlikestopanswers.xyz -- I guess that's worth a look. (I never learned to use function keys. Since I was a local support person when I was employed, that was a dangerous thing, since nearly everyone else had the function keys set up differently and I had to be able to attack problems in the most generic way. A failing, I know.)
 
@DavidCarlisle the problem is the grouping level. beamer has in beamerbasecolor code to "Allow mixins to survive groups", it works only for one group, not two:
\documentclass[]{beamer}
\setbeamercovered{transparent}
\setbeamertemplate{navigation symbols}{}
\newsavebox\testbox

\begin{document}
\begin{frame}[plain,t]
\begingroup\begingroup
 \onslide<2->{\sbox\testbox{111}\usebox\testbox\endgroup
              \sbox\testbox{222}\usebox\testbox\endgroup
              \sbox\testbox{333}\usebox\testbox}
\end{frame}
\end{document}
 
@barbarabeeton The key works on my laptop (it's Fn-F5 here, but it probably will be different in different laptop --- mine is a Samsung). The only problem is that my Linux resets it to "on" when the screensaver kicks in, so I often end up writing things in the wrong place...
 
5:35 PM
@UlrikeFischer ooh a duck
 
@PauloCereda ^^^^ This is why @egreg likes S. Francesco della Vigna (Detail from a painting by Negroponte, around 1470)
 
@UlrikeFischer -- Seems like @egreg should write a visitor's guide to Venice.
@Rmano -- Thanks. That's instructive. In other words, don't assume that such a change is trivial.
 
@UlrikeFischer ooh quack
Does Venice have ducks in its channels?
 
@barbarabeeton Nothing is trivial when computers are involved. I have a PC in one of the classrooms with a microphone that works only if I reboot, wait to be detected, disconnect it and reconnect (it's a windows one, but similar things happens with Linux too. My laptop lost the internal Radeon card one year ago and it is nowhere to be seen since then).
@PauloCereda it's salty water (and a bit filthy too, probably it's better now). I do not know if ducks like it...
Oh, seaducks exists... en.wikipedia.org/wiki/Mergini --- I don't remember having seen them in Venice, but I wasn't exactly looking for them two years ago when I went last time
 
@Rmano ooh
@Rmano ooh
@egreg when I visit you, can we go see ducks? :)
 
5:47 PM
@UlrikeFischer thanks
 
@AlanMunn I would say "o o h" but that would be cultural appropriation, I fear :-)
 
@Rmano :D
@Rmano Although your intuition there there aren't ducks is not wrong: people are saying that this is the first time they've seen ducks in Venice in more than 40 years!
 
@AlanMunn ooh I see Joseph taking a vacation in Italy
Is there a version of Santa Lucia being sung by ducks?
 
06:00 - 18:0018:00 - 00:00

« first day (3608 days earlier)      last day (75 days later) »