« first day (1857 days earlier)      last day (3115 days later) » 
00:00 - 21:0021:00 - 23:00

9:00 PM
I want to upgrade to the latest version of php...
 
What version of php5 do you want installed again?
Also, apt-cache policy, please.
 
latest over what I have now...? Whatever that gets php5-curl to install
Package files:
 100 /var/lib/dpkg/status
     release a=now
1100 debianbuild64.zdv.uni-mainz.de/debian ./ Packages
     release v=1.0,o=Uni-Mainz,a=zdv,l=Debian-Local,c=
     origin debianbuild64.zdv.uni-mainz.de
 500 ftp.de.debian.org/debian wheezy-backports-sloppy/non-free Translation-en
 500 ftp.de.debian.org/debian wheezy-backports-sloppy/main Translation-en
 500 ftp.de.debian.org/debian wheezy-backports-sloppy/contrib Translation-en
  90 ftp.de.debian.org/debian wheezy-backports-sloppy/non-free amd64 Packages
 
@TheQuantumPhysicist Wow, that's horrible.
Ok, so, quoting:
9 mins ago, by The Quantum Physicist
php5:
  Installed: 5.6.6-1~dotdeb.1
  Candidate: 5.6.6-1~dotdeb.1
  Version table:
     5.6.15-1~dotdeb+7.1 0
         80 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages
     5.6.14-1~dotdeb+7.1 0
         80 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages
     5.6.13-1~dotdeb+7.1 0
         80 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages
     5.6.12-1~dotdeb+7.1 0
         80 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages
     5.6.11-1~dotdeb+7.1 0
You have 5.6.6 currently installed, it looks like.
 
Yes... I need 5.6.15... apparently
because curl exists with that version
 
@TheQuantumPhysicist Ah, ok.
Do you realise this upgrade might break other stuff? Well, break it more, since PHP is pretty much intrinsically broken...
 
9:04 PM
really?
 
@FaheemMitha Yes, but I'm at the point where I need a gentle nudge before I can even write a question
 
I looked at other policies and they all seem to have the same new version, 5.6.15
 
I'm trying to trace a real time system call that will on occasion drop bytes in the buffer
I have strace logs of all the threads, and can point to the calls that represent the bad data
 
@TheQuantumPhysicist Ok, well, the first thing you can try to do is apt-get install php5=version_num_you_want. This will probably return an error, but that is Ok.
Just paste the error.
 
Tried that, gave errors...
 
9:06 PM
@TheQuantumPhysicist Ok, paste the errors.
 
The following packages have unmet dependencies:
 php5 : Depends: libapache2-mod-php5 (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed or
                 libapache2-mod-php5filter (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-cgi (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-fpm (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed
        Depends: php5-common (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed
Now if I try, e.g., this: apt-get -f install libapache2-mod-php5=5.6.15-1~dotdeb+7.1
 
@TheQuantumPhysicist Ah, well, that does not look so bad. Ok, add the packages mentioned to your install line, and specify the dependencies versions are desired versions.
 
I get this:
The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.6.15-1~dotdeb+7.1) but 5.6.6-1~dotdeb.1 is to be installed
E: Unable to correct problems, you have held broken packages.
like all in one line?
 
Ok, the conflict is dotdeb
 
apt-get install php5=5.6.15-1~dotdeb+7.1 libapache2-mod-php5=5.6.15-1~dotdeb+7.1~ ...
What does apt-cache policy libapache2-mod-php give?
 
9:09 PM
php5-common version dotdeb 5.6.15-1~detdeb+7.1 which is not the same as 5.6.6.1~dotdeb
 
Did that, got more errors:
The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-cli but it is not going to be installed
                       Conflicts: libapache2-mod-php5filter but 5.6.15-1~dotdeb+7.1 is to be installed
 libapache2-mod-php5filter : Depends: php5-cli but it is not going to be installed
                             Conflicts: libapache2-mod-php5 but 5.6.15-1~dotdeb+7.1 is to be installed
 php5-cgi : Depends: php5-cli but it is not going to be installed
 php5-fpm : Depends: php5-cli but it is not going to be installed
 
I have had this exact sequence of issues but with another library
 
apt-cache policy libapache2-mod-php5
libapache2-mod-php5:
  Installed: 5.6.6-1~dotdeb.1
  Candidate: 5.6.6-1~dotdeb.1
  Version table:
     5.6.15-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.14-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.13-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.12-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
 
somewhere there is a very low level package that has a forced version due to some other depednecies
@TheQuantumPhysicist php5-cli is the lock here, it is blocked for some reason
 
@TheQuantumPhysicist Ok, select 5.6.15-1~dotdeb+7.1.
@crasic Good point
 
9:12 PM
@FaheemMitha I disagree that this is a good fix, unless he has an explicit reason to pick a specific version (i.e. development), this is a dependency issue that can be resolved
 
I tried to install all of these packages together
didn't work...
 
You have tied a dependency knot
find the linchpin
 
@TheQuantumPhysicist What does apt-cache policy php5-cli give?
 
php5-cli:
  Installed: 5.6.6-1~dotdeb.1
  Candidate: 5.6.6-1~dotdeb.1
  Version table:
     5.6.15-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.14-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.13-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.12-1~dotdeb+7.1 0
         80 dotdeb.netmirror.org wheezy-php56/all amd64 Packages
     5.6.11-1~dotdeb+7.1 0
 
@crasic There isn't a good fix. This whole thing is a bad idea.
 
9:13 PM
I'm stuck with my university's pinning... that's why I'm doing all this...
 
@TheQuantumPhysicist apt-get install php5-cli=5.6.15-1~dotdeb+7.1
 
The following packages have unmet dependencies:
 php5 : Depends: libapache2-mod-php5 (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed or
                 libapache2-mod-php5filter (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-cgi (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-fpm (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed
        Depends: php5-common (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed
 
@TheQuantumPhysicist Sorry, I mistyped.
See above.
 
The following packages have unmet dependencies:
 php5-cli : Depends: php5-common (= 5.6.15-1~dotdeb+7.1) but 5.6.6-1~dotdeb.1 is to be installed
            Recommends: php5-readline but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
Try to install php5-cli.
@TheQuantumPhysicist Ok.
 
9:14 PM
look, I have no clue what the differences are, but it seems it thinks that 5.6.6-1~dotdeb.1 < 5.6.15-1~detdeb+7.1~
 
Yes it's smaller, and I don't understand why it's not being installed...
that was my original question
 
apt-get install php5-cli=5.6.15-1~dotdeb+7.1 php5-common=5.6.15-1~dotdeb+7.1
 
nvm
 
at this point I would unistall/downgrade every dotdeb package since they offer older than current testing tracker.debian.org/pkg/php5
 
shit... it says these will be removed:
libapache2-mod-php5 php5 php5-gd php5-intl php5-ldap php5-mcrypt php5-mysql php5-readline phpmyadmin
 
9:16 PM
@crasic Installation behavior is driven by the preferences.
@TheQuantumPhysicist That's normal. It's removing stuff that depends on the php version you are removing.
 
@FaheemMitha these are debian package dependencies, it is hitting a version check failure
 
That's OK. You can reinstall them later.
@crasic I'm not sure what you are talking about.
 
I'm afraid of losing information...
 
@TheQuantumPhysicist Post the complete output.
 
@FaheemMitha It is likely that the patch introduced from dotdeb.1 to dotdeb+7.1 is minor, but the package maker explicitly listed that version.
 
9:18 PM
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dbconfig-common libt1-5 libvpx1
Use 'apt-get autoremove' to remove them.
Suggested packages:
  php5-user-cache
The following packages will be REMOVED:
  libapache2-mod-php5 php5 php5-gd php5-intl php5-ldap php5-mcrypt php5-mysql php5-readline phpmyadmin
The following packages will be upgraded:
  php5-cli php5-common
2 upgraded, 0 newly installed, 9 to remove and 0 not upgraded.
I'll brb guys, sorry!
 
remove them all, dpkg don't remove files that weren't created by the packages
 
@TheQuantumPhysicist That looks Ok. You'll need to reinstall those packages later.
 
@Braiam I agree, standard procedure is remove everything
then build the tre back up
if you have the dependency tree it may be worthwhile going through it individually and seeing what breaks the instal
 
After you've run that command, install those package, but first only the php ones at your preferred version.
 
OK, I'll do it
 
9:21 PM
@TheQuantumPhysicist First, just run that command and report the output. Don't do anything else.
The trouble with this remote driving is that often people don't follow directions.
 
I installed them... the others are removed now
 
@TheQuantumPhysicist Ok, now try:
apt-get install php5=5.6.15-1~dotdeb+7.1
It will complain.
What is the error message?
 
The following packages have unmet dependencies:
 php5 : Depends: libapache2-mod-php5 (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 libapache2-mod-php5filter (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-cgi (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-fpm (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
Ok, check the versions of all those using apt-cache policy. Is 5.6.15-1~dotdeb+7.1 the top in all cases?
I'm not sure what is with the 5.6.15-1~dotdeb+7.1~ thing.
Oh, I see, that's the dependencies setting. Ignore that, it doesn't matter.
 
What do you mean with "all cases"?
 
9:24 PM
@TheQuantumPhysicist For all packages. Ok, example.
apt-cache policy libapache2-mod-php5
Is 5.6.15-1~dotdeb+7.1 at the top of the list?
 
Yes it's always on top
 
@TheQuantumPhysicist I suspect, and this is just me, that the dotdeb+7.1 has some dependency itself which is in conflict, causing the package manager to drop to dotdeb.1
 
@TheQuantumPhysicist Ok, just go through and check it for all the packages that were mentioned in that error messsage. Just to be on the safe side. You can pass multiple targets to apt-cache policy.
 
keep in mind that version changes at the end reflect, typically, distro specific patches or packaging changes (like dependencies)
 
9:26 PM
I can paste!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5 : Depends: libapache2-mod-php5 (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
 
You are asking to install the hgihest version of libapache2-mod-php5, which is dotdeb+7.1
however for whatever reason that version cannot be installed
that version of its dependency
 
meh, I say again, testing offers .14
 
apt-get install php5=5.6.15-1~dotdeb+7.1 libapache2-mod-php5=5.6.15-1~dotdeb+7.1 libapache2-mod-php5filter=5.6.15-1~dotdeb+7.1  php5-cgi=5.6.15-1~dotdeb+7.1 php5-fpm=5.6.15-1~dotdeb+7.1
Try that ^^
 
The following packages have unmet dependencies:
 libapache2-mod-php5 : Conflicts: libapache2-mod-php5filter but 5.6.15-1~dotdeb+7.1 is to be installed
 libapache2-mod-php5filter : Conflicts: libapache2-mod-php5 but 5.6.15-1~dotdeb+7.1 is to be installed
E: Unable to correct problems, you have held broken packages.
Looks somewhat circular...
 
@TheQuantumPhysicist Yes, looks like you can't install both. take one out
 
9:29 PM
I took the filter out
 
Ok, try again.
 
success...
 
@Braiam They aren't allowing him to upgrade.
 
chroot?
 
@Braiam Dunno
 
9:30 PM
@Braiam or LXC
 
It's a server side thing. He'd have to make it globally visible.
 
So now I should proceed and install php5-curl?
 
@crasic afaik you need root for that, no?
 
@Braiam To set them up... I beleive so
 
@TheQuantumPhysicist Just do a sanity check. apt-get -f install.
@Braiam What is that check involving dpkg?
 
9:31 PM
but they have unpriveleged container
 
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dbconfig-common libt1-5 libvpx1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
so you can run them non-root
 
@FaheemMitha --check?
 
@Braiam Yes, that one.
 
Does that look good?
 
9:32 PM
@TheQuantumPhysicist dpkg -C
 
@FaheemMitha no, it's --audit
 
nothing came out of that
 
@TheQuantumPhysicist Yes, that looks Ok. But what you are doing here isn't the best idea. I hope you realise that.
@TheQuantumPhysicist That's what you want to see.
Anything returned from that command would be bad news.
 
it didn't return anything
 
@TheQuantumPhysicist apt-get -s upgrade.
@TheQuantumPhysicist Good
 
9:34 PM
I tried to install php5-curl, didn't work
apt-get install php5-curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-curl : Depends: phpapi-20100525
             Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.15-1~dotdeb+7.1 is to be installed
 
@TheQuantumPhysicist Hold your horses.
First, apt-get -s upgrade.
 
did that
nothing significant
 
@TheQuantumPhysicist ??
What did you get? Post it.
 
apt-get -s upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
@TheQuantumPhysicist Ok, good.
Ok,
apt-get install php5-curl=5.6.15-1~dotdeb+7.1
 
9:36 PM
worked!
 
@TheQuantumPhysicist Ok. Did you need anything else?
 
Let's see what's missing now...
Seems to work perfectly! Thanks a lot!
Though I haven't tested curl yet, but I will
Does this look good now? What do you think happened?
 
several BNU on testing :(
 
@FaheemMitha
 
@TheQuantumPhysicist Happened with what?
@Braiam Hmm?
 
9:43 PM
I mean I'm trying to understand how bad this could be, what I did
What do you think?
 
@Braiam You weren't around for a while, but you seem to be back.
 
Btw Faheem where are you from?
@FaheemMitha
 
@TheQuantumPhysicist Well, bear in mind that upgrading PHP is intrinsically harmless. But if you other stuff running on your system which depended on that earlier version of PHP, it's broken.
@TheQuantumPhysicist India.
@TheQuantumPhysicist A couple of comments. (a) Consider using something less awful than PHP (b) Read man apt_preferences.
 
It's too late to change php
 
9:45 PM
(c) Try and persuade your admin to ugrade to Debian stable.
 
anyway dude
thanks a lot
I'm so grateful!!
Have a nice evening :)
 
@TheQuantumPhysicist No problem. But don't thank me yet, you don't know if it works.
 
The website is working...
 
@Braiam So, slacking off at work then?
 
@FaheemMitha nah
 
9:46 PM
oh shut
shit
 
today is holyday
 
I just saw that mysql plugin is missing
there we go :S
 
@Braiam Heh. Working hard or hardly working?
@TheQuantumPhysicist You're an experimental physicist?
What are you doing messing with PHP scripts? :-)
 
Well, for example we have data for our experiments which is like GB, and two days ago I wrote a script that would compress the data to ZIP and stream it to the user immediately
Yes I'm a physicist
I do mostly programming
 
@TheQuantumPhysicist Oh
 
9:48 PM
use Perl
 
@Braiam holy day?
 
I do python mostly... I tried django, but didn't like it
 
holiday
 
Agreed, Perl is better than PHP. But then, most things are.
@TheQuantumPhysicist I used Django. Didn't like it much either.
 
I also hate their licensing... I must keep "powered by django" down there
I find that stupid
 
9:50 PM
@TheQuantumPhysicist Next time, consider posting a question. Though these kinds of questions aren't really very useful for the site, so it's no big deal.
 
Actually I did post a question. No one even looked at it... and I was really desparate
I appreciate your help a lot!
So have a nice evening
I gotta go :)
 
@TheQuantumPhysicist Oh? You could have linked to it.
 
@TheQuantumPhysicist Take care.
@Braiam I don't actually know what you do. Sysadmin stuff?
 
Right now, university takes up all my week (saturday's included)
 
9:53 PM
@Braiam Oh, I didn't know you were still a student.
 
yeah... trying to get my title
 
@Braiam What title?
 
Economist
 
@Braiam Oh. So, it's an economics degree?
 
yeah
 
10:21 PM
Ok
 
00:00 - 21:0021:00 - 23:00

« first day (1857 days earlier)      last day (3115 days later) »