« first day (2807 days earlier)      last day (1328 days later) » 

12:49 AM
@AaronHall IIRC apt-get install manpage-posix for POSIX pages, and there's other manpages for libc and syscalls but don't recall the package of the top of my head. There's always online versions,too
3 hours later…
3:48 AM
@SergiyKolodyazhnyy thanks but you probably mean sudo apt install manpages-posix - but that didn't do it, I'll try the superuser one now...
superuser's no good either.
I type man whatever - nothing happens...
@SergiyKolodyazhnyy shruig I got my degree entirely cause it should have made me more employable ;)
4:07 AM
OK, the problem was that MANPAGER wasn't set. Why wouldn't it be set, and why wouldn't it use less or cat as a default?
4 hours later…
8:04 AM
@TheWanderer How bad is this ?
Me icon skillz no puedo. Despacito !
Meme on the same topic, news flash : Microsoft acquires Despacito 2 for 8.5B ! GitHub disappointed
1 hour later…
9:30 AM
@AaronHall MANPAGER is only the last resort, man uses /usr/bin/pager which normally links to /etc/alternatives/pager, i.e. the pager you set in the alternatives system. If pager is unset, man uses first $PAGER and only then $MANPAGER. I mentioned most of that here.
You can always specify a pager to use with the -P option though, e.g. for mv’s manpage opened in most:
> man -P most mv
@dessert Ok, okay, you convinced me. ;-)
@PerlDuck Especially as it comes directly with git, this script would make for a nice Q&A either way IMO – there’s a lot of rep in for you if you’re interested. ;)
10:18 AM
@PerlDuck beautiful, thank you very much!
this one deserves your UV:
A: script to show git branch in bash no longer works on ubuntu 18.04

PerlDuckAlthough you already solved the problem, I'd like to introduce the solution already shipped with git: Together with git the file /usr/lib/git-core/git-sh-prompt gets installed. Years ago it was in the contrib directory but meanwhile it made it into the official paths. The file isn't meant to be ...

10:29 AM
@dessert LOL, thank you.
11:18 AM
Q: De-suspend failure after 3.13.0-149

Charles LindseyI am still using 14.04 (which still seems to be maintained, to my surprise). Last week, it upgraded my kernel to Linux 3.13.0-149-generic. Since then I have the following problem: I normally Suspend when not using the machine, with a request to de-suspend at 0400 each morning to do various hous...

11:30 AM
@dessert /usr/bin/pager seems to be set to less, so it hasn't been using that.
Q: I cannot understand what -c parameter does in tr command in Ubuntu GNU/Linux even though I read the manual

Dimitrios DesyllasI try to understand what -c option does in tr command according to man tr command it says: -c, -C, --complement use the complement of SET1 But I cannot understad what the doc mean by "compmement" so I did the following example. I created the following file named trance.txt: ...

@AaronHall that’s odd – you’re on Ubuntu 18.04?
11:47 AM
Q: Installation and Partitioning of Ubuntu 16.04 LTS Server

Tim BremerI am a Linux beginner and was quite happy having successfully installed Ubuntu 16.04 LTS server to use it as a NAS. Yesterday I accidentally erased the SSD (256 GB) Ubuntu was installed on..... What do I have to do to get the original partitions back? I mean can I use during the installation ...

11:58 AM
@AskUbuntuMeta @mod can we get this moved from meta→main?
12:11 PM
Q: Getting started with ubuntu, as well as emails for Ubuntu

Lara StardustI ask these questions of you: I am not a newbie with ubuntu, that is to say, about 2 years ago I bought a ubuntu server[rented], and have been tinkering a bit ever since, I have a friend who does the major operations, but wish to learn more myself. Thus, question 1, what articles do you persona...

2 hours later…
2:20 PM
Q: Removing libz.so files from wine doesn't solve the problem of Wine configuration window showing nothing on Ubuntu 18.04

mfgabriel92Updating to Ubuntu 18.04, I felt like playing a game. I installed PlayOnLinux, Wine version 1.8, and I followed a step-by-step tutorial I had found months ago to make it work. What happened in both versions, 16.04 and 18.04, is that Wine configuration window is a very small window, with probably...

3:08 PM
Q: gnutls_handshake() failed - why?

cristobalI am running the following command: curl --tlsv1.2 -v --cacert ./mycert.crt --key ./key.pem --cert ./mycert.crt https://thirdparty.url I received the certificate from the third party I am working with after generating CSR and key files with openssl. My server IP is whitelisted on the third pa...

Q: Linux modules for PC speaker: pcspkr vs snd_pcsp

Evan CarrollWhat is the difference between these two modules pcspkr: PC-Speaker driver snd_pcsp: PC-Speaker driver different tutorials call for different ones

Q: How can I add a PPA with only Ubuntu releases to a Debian machine?

d3vidI know (thanks Jim Paris) that I can use add-apt-repository on Debian by first: sudo apt-get install software-properties-common However, I still can't simply run (for example): sudo add-apt-repository ppa:nextcloud-devs/client sudo apt-get update ...because the distro folder for that PPA on...

3:48 PM
Q: Help understanding why my question keeps getting deleted or put on hold

MusoukaThe question I reference below is here. Twice now I have asked a question on Ask Ubuntu, sincerely looking for help with a problem, only to have the first one marked as a duplicate to an unrelated thread and deleted, even after I edited it to explain how it was not a duplicate. And the second o...

4:01 PM
I know
4:58 PM
so where is $PAGER set in Ubuntu?
@AaronHall Is it set?
not for me
@AaronHall There you go then :)
Are you trying to set it for some reason?
facts: /usr/bin/pager uses less - $PAGER and $MANPAGER both are unset - man doesn't work for me, without setting either of those - the dots aren't connecting somewhere.
my guess is that either something unsets them, or they're just not being set.
where's the main repo for Ubuntu?
@AaronHall What do you set it to?
man should work fine with neither of those set, if you need to set it, I am guessing something's wrong with less
5:06 PM
When I set one of them to less it works.
What do you get for type less?
$ type less
less is /usr/bin/less
OK, that's definitely weird. Should work fine.
I just checked on an Ubuntu box and I have neither variable set, but man is fine. I don't remember ever needing to set it on any distribution unless I chose to use something other than less.
And I assume no error messages, right? Just nothing?
just nothing!
It's been like that for at least months I think.
You could always add export PAGER="/bin/less" to your ~/.profile as a workaround, but that is very odd.
Might want to post a question.
5:12 PM
I finally got tired of not having it.
Is there a main repo on like github (even a mirror) where I can look for the implementation details of this?
@AaronHall This isn't going to be an Ubuntu thing. It's most likely going to be a your machine thing. Very strange.
Try this, to be on the safe side:
grep PAGER ~/.bashrc ~/.profile ~/.bash_profile ~/bash.login ~/.bash_aliases /etc/bash.bashrc /etc/profile /etc/profile.d/* /etc/environment 2>/dev/null
See if it is being set anywhere for some reason.
Q: Who is able to see deleted questions?

UnbesiegbarkeitI've deleted a question,but the number of views is still changing. Who can see my deleted question? Aren't they permanently deleted?

5:55 PM
@terdon it's exiting with error code 1 after I remove the files that don't exist. Is grep supposed to do that if it doesn't find anything?
(exit code 1 seems to be the behavior on a miss.)
@terdon: Could you (or another mod) please review askubuntu.com/a/1043369/175814? I flagged it as LQ because the answer misses crucial parts that make it useless for people who didn't know the non-missing parts already, but it was declined because (paraphrased) LQ flags are not for dangerous or risky answers (see my comment below it).
crash-lands in the room at full speed
@ThomasWard: Should I call the fire fighters?
@AaronHall If you're ever looking for details/contents on a package, it's launchpad, head to the package-src page. You can check out the source with bzr or it'll point you to where you can <-- that's all from memory. It's not github, you have to use bzr or host it somewhere else and use a build-recipe.
6:05 PM
@ThomasWard: Can you please take a look at my message to terdon just before your arrival?
I just downloaded the source with apt source man-db
@DavidFoerster that depends on if the matter/antimatter power core of my aircraft explodes or not. If it doesn't, then yes you should before the fires breach the power core. If it does, well then it doesn't really matter either way, since everything in several kilometers will vaporize
where does it save the source?
@ThomasWard "doesn't really matter" :-D
oh, in my working dir
6:07 PM
@DavidFoerster I would, except I was the one who declined the flag to begin with.
but I'm happy to still throw that into a comment instead since it's not really an answer :P
@ThomasWard Great! Then I can explain to you why your counter-argument doesn't address the reason for my flag at all. ;-]
or just take the flamethrower.
@DavidFoerster because I was going to deal with the actual problem but got pulled to fix something at work?
and never got a chance to swing back to deal with the post itself
I also have a thing about VLQ being used improperly and I have a Twitter-like message-length typing space for a reply to flags with comments.
@ThomasWard Ah, that makes sense and I couldn't knwo about that.
Thanks for your comment then.
what's a .po file? NM Googling...
@DavidFoerster yep.
6:09 PM
@AaronHall A GNU Gettext translation database file (non-binary form).
@DavidFoerster First hit on Google says it's for drupal, so Google isn't always right I guess, (that was second hit though)
@AaronHall Well, there are only 36² two-character file extensions (incl. digits), so there are bound to be some collisions. Both may be correct in general and it depends on the context which one your file is. A look at the file header in a text editor should clear that up.
@AaronHall my google says "Drupal uses the .po (portable object) and .pot (portable object template) extensions for the translation files. These use the GNU Gettext format. "
This proves: Google is always right.
@PerlDuck It only proves it's right in this case, what if it's wrong every other hit? :P
yesterday, by Rinzwind
One small problem: this means Microsoft now owns Atom.
Also: from the very moment you google something, it exists.
6:18 PM
Microsoft will never own emacs.
@AaronHall I'm just kidding.
@PerlDuck aren't we all...
Maybe because our brains run hot these days.
I'm working on my CSA (Certified Smart Ass) designation...
2 hours later…
8:00 PM
That was like the easiest answer ever on AU:
@Fabby :D +1
Q: How do I resolve this VirtualBox PIT: speaker: cannot open

Evan CarrollInside of VBox.log, I have the following. PIT: speaker: cannot open "/dev/input/by-path/platform-pcspkr-event-spkr", errno=13 How do I resolve this error?

I’m still fighting with the csh guy in the meantime: askubuntu.com/a/1044085/507051
@dessert I mean: I thought it was going to be a nightmare figuring out the BAUD rate, give him AT commands...
@dessert Upgoated
@dessert Yes, just seen it. (askubuntu.com/questions/1044271/…)
1 hour later…
9:26 PM
@Fabby fun fact - cell modems still use AT commands too.
@RobotHumans :D
Never tried...
I only know because of my job.
2 hours later…
11:52 PM
@dessert There are only two things infinite, the universe and human stupidity (Albert Einstein)

« first day (2807 days earlier)      last day (1328 days later) »