« first day (2808 days earlier)      last day (1239 days later) » 

12:25 AM
Hi @all!
Can someone please flag askubuntu.com/a/1028807/175814 as NAA? I already spent mine due to a misclick. Explanation in the comments.
 
added
 
12:59 AM
@dessert It looks like man first uses the argv, then $MANPAGER, then $PAGER, then some function...
get_def_user ("pager", PAGER) <- whatever that is
 
1:50 AM
0
Q: Ubuntu: apt-get update help

smrk007I have been trying to update apt-get on Ubuntu, but am failing in spite of having viewed a variety of different solutions to similar problems. I am running the following command... sudo apt-get update I have received the following output... Get:9 http://apt.typesafe.com unicorn InRelease [7,...

 
hi can anyone help me i guess my server is being attacked :(
 
What makes you believe it is being attacked?
 
2:16 AM
0
Q: How to display directory

Rhym Uiel B. SurioHow can i display the directory before the $

 
 
3 hours later…
5:30 AM
0
Q: Custom /etc/init.d/puma script - What is being executed when invoked with start/stop/...?

GigaBassWas trying to build my own custom /etc/init.d/puma script for handling puma processes, but cannot get any of my actual script to be executed when any of the normal keywords are used: sudo service start sudo service stop sudo service restart What exactly is being executed when any of these is i...

 
 
1 hour later…
6:46 AM
Is anything going wrong with spam detection? askubuntu.com/questions/1044373/… is out there for 5 minutes already… :(
Finally got rid of it. :)
 
@Melebius next time go to chat.stackexchange.com/rooms/11540/charcoal-hq and type !!/report <link>
 
7:03 AM
@Videonauth Thank you for the tip!
 
you're welcome
I checked the link inside the post and im as well stunned why smokey did not catch it
 
 
2 hours later…
9:00 AM
@Videonauth Can anybody do that? I thought one had to be registered or something…
 
@dessert You are right, I tried it and failed. However, !!/scan worked.
 
 
1 hour later…
10:03 AM
@Videonauth Do you know what’s the difference between flagging a post as spam and reporting in Charcoal like you suggested?
That would make for a good meta question maybe…
 
0
Q: Ubuntu Telnet problem

Mireiai have a problem with Ubuntu 14.04. I am student of microcomputer systems and networks. I explain you my problem, as I mencioned above, i have a virtual machine of Ubuntu 14.04 and when try connect with localhost mediate Telnet, the next following error comes out. 'Connection closed with foreig...

 
10:37 AM
@dessert flagging as spam, is simply flagging it for the site the post is on, reporting it in charcoal is teaching smokey maybe something new
@Melebius the post you showed earlier, ?
 
@Videonauth ah, ok
 
@melebius sorry for that i thought report can be done by anyone
its a while since i have privileges on smokey commands
on the other side there is in almost any time someone online who can report it then
most of the time if smokey didnt catch a link scan is enough too
 
agreed, reporting there if a post is not catched automatically is a good thing either way
 
11:04 AM
@Videonauth No, another one. I met 3 of them during a half hour.
 
@Melebius ah ok
 
 
2 hours later…
12:55 PM
@AaronHall Thank you can activate the comments not for extended discussions trigger on
Shall I press ENTER? Thanks. It's green btw. — Nikos Stratigakis 1 hour ago
 
@L.D.James He’s not a mod on AU, but on SO – maybe ping Oli instead.
 
0
Q: Linux - net.ipv4.conf.all

rusty shacklefordI'm changing the default setting for arp_ignore on an ubuntu 16.04 server, from it's default value 0 to 1. My understanding of the /proc/sys/net/ipv4/conf/ directory is that files under all will affect all interfaces, and default will affect newly created interfaces. After changing the value of...

 
@dessert Thanks.
 
@L.D.James besides, in cases like this I think it’s fine to use the “in need of moderator intervention” flag on one of the comments and give a short explanation (e.g. “extended discussion in comments”)
that’s an easy way of reaching the mods in general without having to ping single ones
 
@dessert I did. Over an hour ago.
 
1:00 PM
@L.D.James well, it’s a workday…
 
Several Mods have asked me to ping them with the request.
 
they did? ok, in that case please kindly ignore what I said :)
 
I consider what you said very valuable. I'm anxious to have a very rounded understanding of others experiences in the ways that the protocols are working for them. Also, I'm not sure if the ones who have suggested that I ping them are an exception, and others may be distracted by the pings.
The ones who made comments, said, that was why they are here.
@Oli, @terdon Can one of you activate the comments, not for extended discussions here: askubuntu.com/questions/1044439/…
 
This always helps me a lot when in doubt:
33
Q: How do I flag correctly?

Byte CommanderAs there are many complaints about uncertainty of which flag to use for what post and even conflicting feedbacks from different moderators or established users, I would like to see some kind of official flagging checklist / decision helper / cheat sheet which can be followed by all flaggers and r...

 
@terdon Thanks!
@dessert Thanks for the link.
 
1:19 PM
@L.D.James you're welcome!
There was already a flag raised. The system raises an automatic flag after N comments (don't remember the exact number).
 
1:31 PM
0
Q: Mark all 'autoremovable' packages as manually-installed in one command

EmmaVI have many packages that are marked as 'autoremovable'. I want to mark them as manually-installed, so that they are no longer 'autoremovable'. I can do it one package at-a-time using sudo apt-mark manual <package name> But how can I do it for all of the packages in one go, without typing all...

 
1:53 PM
@terdon the exact number is N :=)
 
2:08 PM
afternoon
quick question
I'm trying to program something with python using the library pexpect
I'm trying to use the command eval
but when I'm running it, the lib says the command does not exist
and when I do a which eval, I have nothing
 
@AndyK type eval shows it’s a shell function
(at least in bash)
 
@dessert what should I do then...? (if you have any ideas...)
 
@AndyK I don’t really get what evalhas to do with your python script. What are you trying to do with it? Beware, I’m a raw beginner in python.
 
2:24 PM
@dessert I'm trying to do these lines through my python script
eval `ssh-agent -s`'
ssh-add /home/miaou/priv_keys
exec ssh-agent bash
this one does not want to run eval ssh-agent -s'through my python script
 
Wait, why would you run eval in your python script?
 
^- this ;)
 
and exec will not either
@terdon because if without it, this one won't run ssh-add /home/miaou/priv_keys
 
@AndyK Why eval, not why ssh-agent -s
 
2:28 PM
Can't you run ssh-agent -s; ssh-add /home/miaou/priv_keys; ssh-agent bash in a single os.system() call?
 
@terdon the aim is to run it on a different server than the current one
that's why I'm not using os lib
 
@AndyK I still don't see why you need eval, but why don't you ask a question on the site so you can give us all these background details (server? what server?)
@AndyK ???
 
@terdon because I thought it would be easier to do so here but it seems my question needs a real question on Ask Ubu. Sounds good? ;)
 
Yep
Also, note that there is a python eval and a shell eval and they are not the same thing.
 
3:09 PM
@terdon +1 for the help
 
@AndyK Did that work?
 
@terdon yes
but actually when thinking about it
I want to use pexpect for interaction
especially with child = pexpect.spawn('ftp test.rebex.net')
the ssh add was not a good example
 
3:27 PM
cya
 
3:39 PM
oops
 
3:57 PM
0
Q: On Ubuntu 18.04 OpenSSL 1.1.0g - can't decrypt files, even with md5

chrisputnam9Previously, I was encrypting with: openssl des3 -salt -in $INSECURE_CONFIG_FILE -out $CONFIG_FILE -pass pass:$PASSWORD and decrypting with: openssl des3 -d -salt -in $CONFIG_FILE -out $INSECURE_CONFIG_FILE -pass pass:$PASSWORD I've found lots of mention of specifying -md md5 since the new d...

 
 
2 hours later…
5:30 PM
So... does man work for anyone?
is PAGER or MANPAGER set somewhere by default in Ubuntu?
 
@AaronHall not on my (Lubuntu 16.04) system:
$ echo $PAGER $MANPAGER
$ file /usr/bin/pager
/usr/bin/pager: symbolic link to /etc/alternatives/pager
$ file /etc/alternatives/pager
/etc/alternatives/pager: symbolic link to /usr/bin/most
As you can see, I configured the alternatives system to use most as my pager, and man does that.
 
6:06 PM
@dessert Ok... so how does man know how to find /etc/alternatives/pager?
because mine isn't finding it.
 
-P pager, --pager=pager
          Specify  which  output  pager to use.  By default, man uses pager.  This
          option overrides the $MANPAGER environment variable, which in
          turn overrides the $PAGER environment variable.  It is not used in
          conjunction with -f or -k.
@AaronHall man should use /usr/bin/pager by default, which points to /etc/alternatives/pager… Does it do that on your system? What does file /usr/bin/pager and file /etc/alternatives/pager say?
If nothing helps, just set alias man='man -P less' :P
Or set PAGER=/usr/bin/less or MANPAGER=/usr/bin/less in your ~/.bashrc, of course.
 
6:26 PM
Is this a question or an an answer?
0
A: Graphical Server Management

محمد فرهادیi installed compiz in ubuntu 18 and have some graphical problem on it such laging when moving windows and watching moves!! sudo apt install compiz* after removing i back to ubuntu desktop but that was lagy!! sudo apt purge compiz* but in compiz was no problem i try to reinstall xorg serve...

 
6:38 PM
@dessert that's it - Anaconda is messing me up - pager is intercepted by anaconda.
@dessert where did you get that help?
 
@AaronHall man man :)
man -P less man, in your case
 
dessert is a huge fan of manpages.
 
I like them too. F is for Fabulous.
 
@AaronHall try a man after midnight once:
1521
Q: Why does man print "gimme gimme gimme" at 00:30?

Jaroslav KuceraWe've noticed that some of our automatic tests fail when they run at 00:30 but work fine the rest of the day. They fail with the message "gimme gimme gimme" in stderr, which wasn't expected. Why are we getting this output?

 
6:42 PM
Hey, I just tweeted that.
 
@PerlDuck well, they teach me everything…
 
Read The Fabulous Manpage
ok, time to file a bug report with Anaconda...
 
@dessert Oh, I like manpages as well. At least when they don't come up with that machine readable BNF junk stuff. But that ABBA thing is great \o/
 
man pages are great. The FreeBSD "THE MANUAL" is also pretty great.
 
6:49 PM
@PerlDuck manpage answers are often a daily max rep
 
@AaronHall FF for Fabulous Fabby...
:-) ;-) :-)
 
@dessert Exactly that. I hate it when I just want an example of how to call a tool and not wanting to write a compiler or something. I mean, manpages are for man not for machines, as the name already suggests.
 
@PerlDuck no, they are manuals
 
:-P
 
from latin manus “hand”
sorry, can’t take a joke when it comes to linguistics ;D
@PerlDuck you might want to have a look at these three:
@Nodon'tshownmyrealname Would you write an answer about tldr? You could also mention cheat and maybe cheat.sh. — dessert Jan 4 at 8:55
 
6:54 PM
Who's the practical joker that cast the first reopen vote on a question on Natty that was EOL even in 2014???
:D :D :D
 
@dessert That tldr thingy looks quite cool. Thanks for that.
 
@PerlDuck you’re welcome – I like long manpages much more than these examples, but each to their own. ;)
If you actually use it I’d be glad to receive an answer about it there as well (as the comment said).
We really should hold a conference: Get to know the power of the command line – with Oli and Sergiy Kolodyazhnyy talking about python, terdon and PerlDuck talking about perl and so on… I bet we could even make a ton of money with that.
@PerlDuck As you speak German I can also recommend wiki.ubuntuusers.de, e.g. wiki.ubuntuusers.de/tar – usually it has (only) the most important options and very useful examples. I started there. :)
 
7:11 PM
Yes, I know wiki.ubuntuusers.de. Very often Google directs me there – it's a really great site. But thanks for the pointer.
 
@PerlDuck @dessert :D :D :D
 
@Fabby well, he asked… ;P
 
He who asketh, shall receive answers...
 
@dessert Yes, that was a serious question at first. I really couldn't figure out what it is until I googled what compiz is suposed to do.
I've heard the name already but didn't remember what it was.
Sometimes I have some inhibitions to DV a first-time poster, though.
 
@Fabby there you go
 
:45038374 +20already!
@dessert +20 too!
 
@Fabby Hey, cool. I wasn't really asking, just telling. Either way: thank you! Especially for the rsyslog answer b/c I spent some effort in it and am afraid the OP doesn't care.
Hey, stop it. I start feeling embarassed.
 
@PerlDuck wasn't me!
 
That was probably me now, but don’t feel embarassed: I only upvote valuable posts.
 
8:06 PM
Only the +20
@dessert Yeah me too, that's why I didn't upvote your last post! :D
 
if I find a bunch of them in one person’s profile, so be it
 
@dessert Never give more than +30 per day otherwise it'll be reversed by the serial upvote logarithm.
@dessert BTW: this was meant as a joke..
 
@Fabby I’m pretty sure I gave more on multiple occasions, never got reversed – it’s a more complicated logarithm I believe.
 
@dessert Well, have a look at my rep: I used to be a 50000 rep user...
 
@Fabby i figured ;) I actually came back to that every two hours or so editing in some improvements… now it’s tldr :(
@Fabby :D
 
is there anything like „Wer’s glaubt wird selig!“ in English?
wait…
what the heck, how did you manage to do that? oO
 
@dessert Si non è vero, `ben trovato in Italian
If it's not true, it still a good story!
@dessert I didn't do anything!
Shog9 happened.
 
what happened?
 
They changed the rules on how you get rep
and took away the rep you got if you disobeyed the rules that did not exist in the past...
It stinks as they should have:
1. not taken away the rep
2. taken away the rep in the past, so that it looks like you never got it.
 
8:41 PM
Lemme check those
@dessert try cl-nexbox, Bytecommander and videonauth
 
@Fabby Wow, I’m speechless – cl-netbox lost 2/3 of his rep because of this. oO
 
@dessert Yup. Rules changed retroactively.
@dessert And the sad part of the story is that the guy who did this is actually a nice guy who's never realised until now what an impact this had on the friendship between a bunch of closely knot friends...
(I've just sent him an email that no one in our group will ever be able to use our Stack Exchange Flair again ever if we're looking for a job...)
@dessert we're on a pillory forever...
Hey, the silent minority is here too!
Hi @Benny
 
8:57 PM
Should I upgrade to Bionic Beaver?
 
@TheXed I advise to wait for the first point release.
 
@dessert when/what is that? Sorry I haven't been keeping close tabs on Ubuntu for the last 2-years...
Only boot into it when I need to...
Or when I don't catch it at the boot menu lol
 
Oh so it is just the next planned update...
 
@TheXed No
@dessert correct
 
9:03 PM
if you don’t need to upgrade, wait for this 18.04.1 – that’s what the GUI updater does :)
 
what does the gui updater do? wait?
 
there’s certainly a logic behind it, mostly that most bugs will be fixed by then I suppose (never questioned it)
 
@Fabby hey whats up, long time no see...
 
exactly, the GUI updater asks you to update only if .1 is already out
 
@TheXed Yeah, I'm still beautiful but man!
You've gotten ugly!
:D ;-) :D
@TheXed I'm OK, just sent a mail off to one of the SE mods on something that's been bothering me for 2 years now
How are you???
 
9:06 PM
@Fabby well my wife disagrees....I have been well....took a new job promotion three years ago and have been basically been working 60 hour weeks since...
@Fabby but...they finally let me hire an assistant so things haven gotten much easier the last 3 months or so...
 
:D :D :D
Ah you one of those too?
I don't mind working 12-16h / day every day for a month... or 3... or 6...
but not two years...
 
Right...
It was crazy...
 
And I'm sure your wife disagrees with me!
 
but we are past that...so...
 
That's why you married here and not me!
@TheXed For me it's still crazy...
 
9:09 PM
my wife hated....being in charge of the kids all the time...but it paid the bills I guess...
 
Yeah, but was it worth it?
Were you paid by the hour?
were you paid double for the overtime?
 
Salary (which is worse)
 
Yeah: me too: the more you work, the less you make an hour...
/shrug
 
I was supposed to get comp time...but never had time to use it...
 
Ah, I'm under a German contract.
I was sent home by HR for 3 weeks
 
9:11 PM
I am under modern US Slavery laws...work more for less!
 
to "use up my holidays that I didn't take in 2017"
Yeah, same here.
Working for a US company and the boss thinks I should be glad to have a job.
 
Nope... if we don't use our holiday we lose it.
 
@TheXed Yup... Same here, but the boss doesn't know...
 
They rather us not take it...they are under no obligation to make sure we do take it....
 
I lost my 2016 holidays
 
9:13 PM
So if we don't use it...it is just free labor for them...
 
The story is: I was just dead tired and was about to lose them and then I asked for one day off in Feb-Mar-Apr.
but then they got pushed out and pushed out and pushed out
and then I found this rule about that if the employee chooses to, he can start last years' holidays
no later than April 15
So I sent that to the boss (in german)
telling him I was contacted by HR
(it was another German colleague)
and that I was just taking them off and Hasta la vista baby.
Guess what?
I wasn't fired!
/shrug
 
Yeah two years ago....we had some major projects going on...and I was just dead exhausted...I ended up working the entire Christmas break 16-hr days....so later that spring I asked if I could take some time off to spend with my family because they where off from school...my boss was cool with it...but the board cried foul because their goals weren't being made...I ended up coming to work all five vacation days for some reason or another...
 
@TheXed Oh, that's illegal in Germany (invasion of privacy)
 
phh...ever since Trump took office here nothing is illegal...
 
Once the vacation is allowed, they're not allowed to call you during said vacation
@TheXed :D :D :D
 
9:19 PM
at least when it comes to worker's rights....
 
I'm pretty sure he didn't abolish the consitution...
...yet!
Did he????
:D :D :D
 
But yeah Germany does have stricter privacy laws...
 
@TheXed All of the EU citizens do now...
 
@Fabby yes he abolished it his second day of office....we where just slow on the uptake...
 
GDPR!!!
@TheXed Oh, I missed that!
 
9:20 PM
@Fabby oh that is right GDPR wanted me to stop checking email for 2 weeks lol...
 
Lemme look it up.
 
@Fabby whatever the internet says...its all lies...
 
Meh...
 
We now live in the United Socailist States of Donald Trump.
 
Wikipedia is pretty good on math ans science and IT...
@TheXed I used to live in a Socialist country...
You do not live in a socialist country!
In a socialist country, you do not get to decide what you do with your money...
 
9:22 PM
@Fabby I know...I am being over exaggerative...what country did you live in?
 
France...
BRB. I need a smoke!!!
 
Wait, France is Socialist? or it was?
 
9:34 PM
@TheXed Meh, it still is, even though it's got a right-wing majority now...
@TheXed Berny Sanders is a Socialist...
Trump is a Capitalist...
 
10:06 PM
0
Q: Run dhclient on startup

VitaI have this server that loses its network config on reboots, it's running Ubuntu Server 18.04, I tried the netplan commands but none generated a thing, maybe it's because the interface isn't even there until I run dhclient, only then the system brings the interface up and DHCP assigns it its stat...

 
10:48 PM
@Fabby well on my sheet you can only barely see it i only lost a few hundred or so
 
11:07 PM
@Fabby...yeah you are actually right...I just like to make fun of Trump any way I can, because it is what all the cool kids do...
 
@Fabby I don’t get what you guys did that John Skeet didn’t. Is there a meta post about this thing?
 

« first day (2808 days earlier)      last day (1239 days later) »