« first day (2801 days earlier)      last day (1104 days later) » 

12:14 AM
12:34 AM
Eww. Yeah that was a crap answer, but codeplex, the example in question, did in fact used to be a decent code-sharing/tutorial site for some topics. That said, I don't think it's unreasonable to diff all on-site links against the chrome "malicious site" list if that's publicly accessible on a weekly or monthly basis. @Fabby
:-) Did you upvote the Meta question?
Oli's answer still running on my PC...
for 1h now...
I just checked and yes I did.
Good man!!!
1:11 AM
@Terrance no shopping requests, please or we'll have a tons of spammers trolling the site promoting their products in no time...
2:05 AM
@Fabby it's gone now. =)
2:21 AM
Q: Extracting the contents of a tar folder into a target directory

OleI have a tar archive and I need to extract the contents of a directory into another directory. So for example the content may be located in /home/me/stuff/ and everything in the stuff folder should be extracted to /extract. Thoughts?

>.> that has to have been answered on the stack network before.
@UbuntuQuestionsonU&L tar -xC <directory> -f file.tar.gz
and if unsure type tar --help
2:36 AM
It surprised me, because normally UL has higher level questions unless someone is trolling tagging as Ubuntu, and the data recovery tag is completely misplaced.
yep and it has not much to do with ubuntu at all because ubuntus tar is the same as debians tar which is GNU tar
god, nearly 5 am O_o
I maybe should go to bed lol
4 hours later…
6:25 AM
Do we really close a user’s complaint tagged discussion as a duplicate of the unanswered feature announcement here? o_O — dessert 2 mins ago
^- That’s just terrible!
1 hour later…
7:33 AM
there @dessert :)
@Rinzwind all hail the king of workarounds ;)
7:49 AM
made it an answer.
8:03 AM
@Rinzwind upvoted and commented – this tag is not clear.
8:49 AM
The Federal Court for Administrative Affairs ruled that the German civil foreign intelligence service may continue its strategic bulk data collection at De-CIX. :-(
…though mostly due to a technicality. It didn't rule whether the data collection itself was legal, only that the operator must comply with the ministry's order for such data collection.
Police in Brandenburg didn't stop a football fan club's victory party because they didn't recognise the connection between the fans' hoods and those of the KKK:
"Aufstieg" means "rise". Its obvious reference is to the rise to a superior football league in the upcoming season, but the entire line "Rise of the Evil" is kind of incongruent with that.
1 hour later…
10:35 AM
Q: docker-compose run --rm slow startup

grongorI get that docker has some overhead and I wouldn't expect it to be as fast as local bin, but 2 seconds overhead? It seems too much ... Once the container is running, the execution itself seems the same. $ time docker-compose run --rm php-cli php -i > /dev/null docker-compose run --rm php-cli php...

10:54 AM
@Fabby Pushed the update. Chows through all our 1.6 million posts+comments in less than a minute now. Oh and uses stock python3.
11:05 AM
Ha. grep is faster. cat ../Posts.xml ../Comments.xml | tr '[:upper:]' '[:lower:]' | grep -Ff smokey/blacklisted_websites.txt. Doesn't do quite a much cleaning up after itself but 16 seconds is going to be hard to beat.
@Oli Why not grep -iFf [pattern file] Posts.xml Comments.xml? Is piping through tr actually faster than case-insensitive patterns and, if so, how did you measure?
@DavidFoerster case-insensitive is much slower. It's been running for a minute now without a single result. I'll leave it going but yeah...
Measured with time (and a stopwatch when I didn't believe it was that fast)
Nope, I think it's exploded.
First result.
tr+case-sensitve search returns first result within a tenth of a second.
Huh. How about something like grep 'https*//' ../Posts.xml ../Comments.xml | grep -iFf smokey/blacklisted_websites.txt?
cat|tr for all the posts takes 0.5s wall time, but obviously streams so starts returning much faster.
An open regex on 1.6 million lines is disastrously slow. That's what pushed me to Python in the first place.
ah, yeah. 1.6M is not trivial
11:16 AM
Okay, it's not that slow, but yeah, fixed strings is king if you can manage it
11:38 AM
@Oli Good to know. I didn't know that fixed case-insensitive strings are so slow in GNU grep considering that the Boyer-Moore algorithm used for fixed strings can be easily extended to work case-insensitively with little performance penalty.
@DavidFoerster please submit a patch! =)
I implemented faster "inexact" string matches like that as an exercise for a uni course.
Proper pattern analysis should give a big performance gain here since the "haystack" for the search is relatively large.
@dessert Considering that I did this as an exercise based on well-known published algorithms I'm sure that people with more experience in this stuff are already involved in the development of GNU Grep but decided against this specific change.
I'd imagine that it's out of scope for GNU Grep.
11:59 AM
@Oli Woohoo!
@DavidFoerster No one ever bothered submitting a patch because it does exactly what it needs to do for their use case, so if you have something better, submit a patch and then we'll be able to say in 20 years: *Remember when we used to call this dude David and now we have to call him "Herr Doktor Förster"???"
>:-) ;-) >:-)
@Fabby Yeah, I definitely won't go for a PhD. I may be a good engineer but I'll only ever be a mediocre scientist. :-D
@Fabby and the answer we receive is “Ich möchte doch bitten, ich bin Professor.” ;)
1:06 PM
Q: Different versions of `sync` tool

AntonioThere are two man pages about the sync tool: (1) http://man7.org/linux/man-pages/man1/sync.1.html NAME sync - Synchronize cached writes to persistent storage SYNOPSIS top sync [OPTION] [FILE]... DESCRIPTION top Synchronize cached writes to pers...

1:22 PM
Q: Trying to create a startup script

Switching SystemsI followed this guide (https://mobiarch.wordpress.com/2014/05/16/creating-an-init-script-in-ubuntu-14-04/) to create a startup script that mounts my shared windows folder and starts my vpn. However, the script is still not working on startup. I am currently using vm virtualbox to emulate Ubuntu 1...

2:06 PM
@Seth Good morning... can you trigger the chat not for discussion flag on here: askubuntu.com/a/1042178/29012
@L.D.James Done!
3 hours later…
4:38 PM
Which one is more efficient?
find . -type d -empty -delete
find . -empty -type d -delete
@dessert never the less if you happen to run this in / this might even be dangerous
Q: sameersbn/bind on ubuntu

Kevin RaddatzI am trying to run a docker dns server (sameersbn/bind) on ubuntu 18.04, but when starting the container it tells me that port 53 is already in use. docker: Error response from daemon: driver failed programming external connectivity on endpoint bind (5e620c3c1ac65fbfe28e7d558d10dc9400dd1298957df...

speaking of efficiency both should be equal in speed
all you do is giving find the parameters in a different order
5:02 PM
@dessert I would expect the first to be faster since it can skip all regular files.
Seem to be the same, actually. I guess it's also quick to skip non-empty files. Interesting.
5:26 PM
@Videonauth no, find processes every option individually, so -type d -empty first makes a list of every directory and then tests for empty ones while -empty -type d does the same the other way around
@Videonauth One should always think thrice before combining root permissions and find’s -delete option in general I suppose.
yes, just saying it, find has no failsave like rm has
stupid "We need to move people to their separate subnet now!" stuff taking all my time thus far >.>
@Videonauth failsafe? you mean the saferm wrapper?
@dessert yes the preserve-root
@dessert HELP I JUST DID CHMOD -R 777 / AND RM -RF / and now My JUBANTOO Sux. HOW 2 ficks?
5:33 PM
@Videonauth there's fairly trivial ways around that though
@PerlDuck u r screwd dud, no ficks tehre
and those failsafes don't protect against a find with a delete command attached to it
@PerlDuck "Tell me your location, I'll fix it for you" waits quietly for the response and preps the orbiting lasers
LOL! We have so many questions of this kind. I just wanted to ask one myself.
is the package search on packages.ubuntu.com still broken?
5:37 PM
@dessert Even better, never use -delete with -type d, use -exec rmdir {} + instead so you know you'll never delete non empty dirs.
A: How do I delete all empty directories in a directory from the command line?

waltinatorYou can take advantage of the rmdir command's refusal to delete non-empty directories, and thye find --depth option to traverse the directory tree bottom-up: find . -depth -exec rmdir {} \; (and ignore the errors), or append 2>/dev/null to really ignore them rm -rf will delete all the f...

needs -depth then!
And yeah, it does. But I admit that -depth and -prune always confuse me, so I tend to ignore them :P
@dessert define "broken"
@terdon you have a beautiful monospace font there, which one is that?
The packages website currently only lists packages for Cosmic. For example, https://packages.ubuntu.com/search?keywords=xserver-xorg-core shows results for Cosmic only: https://archive.is/v9q7q. When I click on Xenial, I get no results: https://archive.is/ZdtDd. The package xserver-xorg-core definitely exists in Xenial: xserver-xorg-core: Installed: (none) Candidate: 2:1.18.4-0ubuntu0.7 Version table: 2:1.18.4-0ubuntu0.7 500 500 http://mirror.atlantic.net/ubuntu xenial-updates/main amd64 Packages 500 http://mirror.atlantic.net/ubuntu xenial-security/main amd64 Packages 2:1.18.4-0ubuntu0.2 0 100 /var/lib/dpkg/status 2:1.18.3-1ubuntu2 500 500 http://mirror.atlantic.net/ubuntu xenial/main amd64 Packages
Undecided / New
but it’s fixed apparently, I just used the wrong package name ;)
@dessert yeah I think your system was doing a stupid, because it's working now :P
5:41 PM
@dessert Um. No idea, I haven't changed anything as far as I know.
@ThomasWard I wonder why nobody closes this bug then…
@dessert True. We should encourage SE to use Comic Sans for monospace. In comments, at least.
The site uses some sort of Ubuntu font by default, I think, but I don't use Ubuntu so it uses whatever I do have.
@dessert because only the LP team has access to close those bugs. And there's only like five people who have that level of access IIRC
no i'm sorry only the pkg-website management team has access to those bugs
@ThomasWard ok – it got fixed, that’s the important thing
5:43 PM
yep. actually there's only one person on that team lol
1 person.
@ThomasWard wow, poor girl
I get the impression that 50+ % of the active users answerers on AU are from Germany. Is that true or just a snapshot I faced?
@PerlDuck That's because once ByteCommander, Videonauth and @cl-netbox showed up, everyone else ran away screaming.
:-) :D :-)
Muro is in Japan, Oli is in UK, Thomas and Seth are in the US.
nice going misspelling my name :/
Ah, that explains things.
5:51 PM
throws salt at @Fabby
Old Thinkpad that needs replacing.
found it:
code {
    font-family: Consolas,Menlo,Monaco,Lucida Console,Liberation Mono,DejaVu Sans Mono,Bitstream Vera Sans Mono,Courier New,monospace,sans-serif;
    background-color: #eff0f1
@Fabby Here, let me help you with that... runs towards your computer with a sword, yelling out a battle cry
@ThomasWard I'm on my work PC
*switches to the laser cannons* Doesn't change the response :P
5:53 PM
I have approval to get a new one, but as we're part of Dell now, it'll be a ...
Yes, I know there are other nationalities. But why's not e.g. France? Don't they have computers as well?
There are quite a few people from France.
Well, just an observation I made that made me curious.
Though he's mostly lurking in the Frying Pan and /dev/chat
Most chat users are German from 18:00-22:00 CET
@Fabby Ahh, that might be a reason.
5:56 PM
Paranoid Panda is UK
and the time(s) when I'm online are... erratic.
Journeyman is Singapore
so I show up everywhere.
Zanna is UK
I love Zanna.
5:57 PM
@ThomasWard You show up when you're in need to give someone a good hollering and then go back to work.
Heather was California.
@Fabby Heather was real?
Most people think so and disagree with my subjective, irrational, personal assessment based on being in chat rooms since the 80s
I mean: People make up shit! You're a dessert that raises ducks,
Perlduck is a duck
Actually I'm a sheep and just didn't want to tell.
@PerlDuck Don't try to understand Fabby, there lies madness. Just go with the flow, fowl.
Dammit. Now I did.
6:02 PM
Thomas looks like Cyclops...
I'm a Vorlon.
Zanna is a cartoon character
Terdon is the only rational being in chat!!!
:-) :-) :-)
Finally. Someone noticed!
@Fabby … as indicated by the ♦.
Although Nathan is the most clearly human looking among us.
@terdon Well all scientists are or: absolutely rational people
But he's Canadian, so maybe he doesn't count.
6:04 PM
or stark, raving mad!
Or an intriguing combination of the two. That's what I'm going for.
I went mad, you were mad and became normal.
:D ;) :D
Anyway, time to shut down and drive home
See you guys in an hour or so on Ubuntu
Shutting down Windows now.
I like this so much. :>
@terdon I forgot I could just test it myself:
$ time find / -type d -empty &>/n

real    2m28.114s
user    0m1.040s
sys     0m4.984s
$ time find / -empty -type d &>/n

real    2m25.704s
user    0m1.004s
sys     0m3.376s
Hi @Oli.
I’m used to put -type first, but apparently there’s no difference in this case.
6:15 PM
@dessert Don't forget that caching might be involved when run a 2nd time.
@dessert Hi Used To Put. I'm Dad.
This askubuntu.com/q/1042378 is about Ouzo. Perhaps @terdon has an idea.
6:49 PM
@dessert yeah, it's basically the same. Those differences are well within the margin of error. Also note that running the same command again will be muuuuch faster.
@terdon That's in line with my personal experience. Just consider rm -rf. The 2nd time it returns quite instantaneous.
I have to apologize because I'm kidding all day long. Sorry for the noise. I'm just in good mood this week.
let’s see…
$ time find / -type d -empty &>/n

real    3m39.253s
user    0m1.028s
sys     0m4.764s
$ time find / -empty -type d &>/n

real    2m56.804s
user    0m1.144s
sys     0m4.260s
7:08 PM
8:16 PM
@Videonauth sorry, couldn’t resist ;P
@Videonauth tmpdir=$(mktemp -d) actually creates the directory and saves its path in the variable, no need for mkdir
ah ok
I m trying to write a shell script and assign the output of a command to a variable. Altough I have found quite some things online, nothing seems to work
could somebody tell me what I am doing wrong?

while true; do
    result = $(cat /proc/net/udp | grep 2348)

line 4: result: command not found
also, these tempdirs never contain spaces or anything weird, while it’s a good habit you actually don’t need to quote those
8:19 PM
For some reason it thinks result is a command...
@traducerad try result=$(cat /proc/net/udp | grep 2348) instead – no spaces allowed!
@dessert i always quote it because shellsheck is wrecking my nerves otherwise :p
@Videonauth ;)
@dessert Thanks!
The spaces were the issue
just tested my script and it works, as well i dont really care for the double extension, because i drop those files afterwards anyways
8:21 PM
@traducerad while true; equals while :; btw :>
@dessert the rest with subshell really confuses me can you make an example please from my script with your changes ?
@Videonauth ha, you’re right :D
i just move the files to /tmp because of the fact convert in my find produces the files in place of the found file
 find "$1" -type f -name "$2" -exec sh -c 'convert "$1" "$0/${1##*/}.pdf"' $tmpdir "{}" \;
try it this way, no need to strip the extension
well edited this approach as well into my answer
8:28 PM
that’s simply a sh shell which gets two arguments, the first being $tmpdir and the second being the filename, ${1##*/} is parameter expansion (substring removal) and removes everything to the last slash from the filename
but to be honest i myself get confused by the part within the subshell
never heard of pdfunite before – I always use pdftk for things like that.
i just typed pdf and doube tabbed ;)
and its a default installed tool
is the package poppler-utils installed by default? if not, maybe mention it in your answer… I have it installed, but I use pdfimages
ok :)
I think it is because evince is instaled by default and requires libpoppler too
for sure o not installed it knowingly
anyone here has a fresh installed 18.04 VM around to confirm if this tools are default installed?
^@ThomasWard maybe?
8:37 PM
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
$ sudo dpkg --configure -a
Setting up python3-apport (2.20.1-0ubuntu2.18) ...
dpkg: error processing package apport (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Errors were encountered while processing:
:O Never seen this one before...
Google time!
@Videonauth my wife’s Kubuntu 18.04 has it installed
Q: How to fix "Package is in a very bad inconsistent state" error?

Benjamin PillerI can't update my system because it freezes while installing a third-party update (zramswap-enabler)! Sometimes I get the following message in Update manager: Could not initialize the package information An unresolvable problem occurred while initializing the package information. Please...

@dessert whats with that?
ah for your fabby man :)
@dessert That's the one I was looking at
@Fabby you’re my fabby man :)
OK apport is for sending segfaults.
no biggie... (he said before crashing his system.
8:41 PM
you got it fixed @fabby ?
@Fabby so… none of the many upvoted answers helped? oO
No I'm reading first.
then executing
@Fabby oh, ok – Braiam recommends sudo apt-get --reinstall install here.
@Videonauth Define "default tools" and whether you mean "Minimal Installation" or "Complete Installation"
8:43 PM
@fabby go into the directory where the package are downloaded into, do apt download apport, then dpkg -i apport_xxxx.deb . done
@Videonauth because there's two options for installation in 18.04's live installer
@ThomasWard well the tool pdfunite, if you can confirm both fine but have a check if its there, i guess minimal is server install, lets talk about GUI
no not server
minimal is a GUI install option now
installs the DE and the 'core' utilities and leaves out all the optional office suites, games, etc.
@Videonauth It's fixed already
8:45 PM
literally minimal GUI
@ThomasWard ah ok good to know, i never see an installer, always use debootstrap
remove apport and apport-gtk
reinstall apport and apport-gtk comes back
sudo apt update && sudo apt dist-upgrade
Hit:1 ftp.belnet.be/ubuntu.com/ubuntu xenial InRelease
Hit:2 ftp.belnet.be/ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 ftp.belnet.be/ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 ftp.belnet.be/ubuntu.com/ubuntu xenial-security InRelease
Hit:5 ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease
Hit:6 ppa.launchpad.net/leolik/leolik/ubuntu xenial InRelease
Hit:7 ppa.launchpad.net/linrunner/tlp/ubuntu xenial InRelease
FWIW, the name of the VM was not my choice, it was a random-generated name...
teward@EVIL-bionic:~$ apt-cache search pdfunite
poppler-utils - PDF utilities (based on Poppler)
teward@EVIL-bionic:~$ apt-cache policy poppler-utils
  Installed: 0.62.0-2ubuntu2
  Candidate: 0.62.0-2ubuntu2.1
  Version table:
     0.62.0-2ubuntu2.1 500
        500 us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
 *** 0.62.0-2ubuntu2 500
        500 us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
lucifer-bioonic was random-generated?
bionic part was not. i have a very large list of names I pulled from 'behindthename' website and that's apparently on the list
i didn't do any type of filtering on the list of randomly available 'names'
8:47 PM
what the hell? which generator produces this?
there now lay off. grubles something about no coffee, 4 hours sleep, and not needing berated on the insanity that is a random name generator
i'll go create a new VM just to make sure, though...
... once I'm home.
okidoky :) would be nice if you can hit me with a ping then
want to know it for sure because if not i ned to change my answer here: askubuntu.com/a/1042330
Already upvoted
@dessert tr -dc 'A-Z0-9' < /dev/urandom | head -c12
Random hostname generator
@dessert a very complex python script that does insanity underneath the hood
@ThomasWard and worships satan above the hood apparently – I like it
8:53 PM
well it also worships me and sends me the energy from the souls of the condemned certain sources so that I gain more and more power in a more and more evil way every day
but it's pain :/
and i really didn't filter the lists too well, it literally is just a namedump from behind the name .com
and the new VM that was just created was given the name 'sveta-bionic' so I mean i really don't control it :/
it even calculates future death dates: behindthename.com/random/random.php?showextra=yes
@ThomasWard Star bait!
LOL the installer crashed xD
seems i have to install 18.04 in a VM with the installer, so at least i have seen it once ;)
debootstrap is just so much more convenient
@ThomasWard I want some!
9:00 PM
@Fabby some... what? coffee? sleep? beratement? Suffering? Insanity? An orbital laser beam slicing your computer in half? What?
The weird shit you and Dessert are smoking!
(random name generators coming up with weirs host names.)
9:16 PM
now we have 12 runner ducks oO
@ThomasWard and a rubber duck – just for you :)
the red light is an infrared heater
@oli :
/usr/bin/python3 linkcheck.py /tmp
File "linkcheck.py", line 45
@Fabby should be printf('… I suppose?
Yup... just letting him know is all
@oli I don't know what happened, but the current one has a few bugs?
@dessert I want one when it's grown up.
(ready to eat)
together with the quinces? ;)
could make for a nice joint…
:D You actually remembered?
You're a foodie too, right?
9:31 PM
@dessert nope its print
@Fabby fabby what is your python version?
which 3.x ? 3.5 or 3.6 ?
@Fabby er… no, I don’t think so, just that I like to grow and possibly slaughter my own food
here's the blurb:
There are a few syntax errors
@Videonauth now I’m curious: what’s the f for?
9:34 PM
@Fabby what is the output on your system for python3 version?
@dessert formatted strings, new format introduced in python 3.6.x
@Videonauth I tried running it on the Unix.se but it craps out and I don't like positional programming languages like COBOL and python.
@Fabby nevertheless you need to run it with python 3.6, not 3.5 or anything ;D
> This script requires Python 3.6 (because I'm lazy and like new things) and the requests and tqdm libraries. On Ubuntu 18.04, getting up and running is as simple as:
Comes from here:
I'm done for today anyway.
9:36 PM
Oli should remove the syntax error and the logical error

change to
I already did that.
ok and what logical error do you get?
then it just prints endless
https://unix.stackexchange.com.com/q/{post_id}/ {bad_domain}
https://unix.stackexchange.com.com/q/{post_id}/ {bad_domain}
https://unix.stackexchange.com.com/q/{post_id}/ {bad_domain}
(running this on the unix export)
I'm going to smoke, drink and watch a movie
(same movie I've been trying to watch for the last 3 days.)
ok wil have a look later on the script. on the other side installing python 3.6beside 3.5 should not be as much of a problem
9:39 PM
Let Oli have a look tomorrow when he's fresh.
@Fabby have fun!
9:58 PM
Q: Connect Wifi on cli inside nodejs

CoffeAbuseri have a server that receive information about a network, ssid, psw, WPA,...,ip, subnetmask gateway DNS. My problem is i don't know how to tell ti Ubuntu to take infos to trying to connect to network. Something like exec(mcli dev ssid psw WPA ip subnet gateway DNS). Someone Can help me? Code exa...

10:21 PM
@Fabby well on my side it works perfectly, would help if you could post me the whole error glob
10:35 PM
and with the change it does exactly what it did before properly
it does however not properly format the output it keeps starting a new progress bar after each find
11:18 PM
Q: Ubuntu 16 Sudo SU Incorrect Password Attempts

DarylI am using Ubuntu 16 LTS Server. I have a user with sudo privileges on it. When I attempt to switch from my current user to root, it asks for my password. I enter the correct password and it refuses my password. username@server:/# sudo su [sudo] password for username: Sorry, try again. [sudo] pa...


« first day (2801 days earlier)      last day (1104 days later) »