« first day (2800 days earlier)      last day (476 days later) » 

5:20 AM
Getting speaker fill working in Windows 10 is proving a nightmare.
The driver supplied by the motherboard manufacturer is missing the feature. The generic HD audio drivers supplied by Windows 10 support speaker fill but there's this weird delay between front and rear channels and the audio is distorted in the rear channels.
Now trying the generic drivers from Realtek's website...
 
5:45 AM
im trying to figure out how to start postgresql on boot.
it looks like all i need is enable & start postgresql.service right?
But threre is one problem.
user@server:/etc/systemd/system$ pg_ctl status
pg_ctl: server is running (PID: 19670)
/home/user/postgresql/bin/postgres

user@server:/etc/systemd/system$ sudo systemctl status postgresql.service
● postgresql.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)
Whats going on ? =P
 
Does pg_ctl just check for the pidfile or does it actively communicate with the server to verify it is running?
If systemd is reporting the service as masked, it is disabled and will not start.
 
6:18 AM
@NathanOsman I have never seen a process do more than just check a pidfile.
 
6:30 AM
@Fabby I get 1/2 of it but I live near the Belgium/German border so I have heard some of them (flikken=politie=police)
Belgium always makes new words when they adapt something from english. We Dutch just adopt the english word (sometimes altering 1 or 2 letters due to rules on syllables)
 
0
Q: while call python script from php. how to run python script in background (Asynchronous)

Sammu SundarI am using ubuntu . i run python script from php function.I want to run the python in background (Asynchronous) . I try following codes. the codes are working but the control is waiting for full python script to completed. After that only moves to next line in php file. shell_exec("nohup python...

 
 
2 hours later…
8:32 AM
Hey guys!
I just got my new PC yesterday and I think I did a big mistake, I continue ubuntu installation as UEFI, Do you know how can I fix this, please? Do I need to fix it by installing the original motherboard UEFI? I don't understand what really happen when I install ubuntu as UEFI
 
What's wrong with that?
If it works it works.
There's nothing to fix
 
no works, my PC is not loading up
 
407
Q: My computer boots to a black screen, what options do I have to fix it?

Jorge CastroI am trying to boot Ubuntu on my computer. When I boot Ubuntu, it boots to a black screen. How can I fix this? Table of Contents: If you are trying to install Ubuntu If you have a dual boot system If an update or something else caused your problem

 
@Benny I would assume nowadays UEFI is the default to install to. Not legacy.
 
I don't really understand what is and what happen ;(
 
8:38 AM
I’d start troubleshooting with the question above.
 
thanks
 
9:42 AM
Can I roll back to original UEFI ? I got usb disk with the motherboard, can I the original UEFI from the usb disk? please help me understand how to roll back please!
 
@benny how is the hard disk partitioned? gpt or msd-dos?
 
SSD
 
can you boot at least into the root prompt for fixing?
or do you have an usb stick to boot from?
 
I can enter into bios and then change the boot order
 
give me a second to get some coffee and feed the cat before i get eaten alive, just stood up :)
check if you can boot into a live usb meanwhile, you need some working system for a fix, also you can describe exactly what happens when you try to boot your system right now
 
9:47 AM
I am getting some kernel error message, I will share when I arrive home, thanks
 
ok do that but then pin g me i might not be always in front of my screen today :)
 
it's ok =) thanks!
 
10:35 AM
@Rinzwind thank you for your comment, fixed my answer
 
@Videonauth :) thank pomsky
 
@Rinzwind why? what did i miss? :)
 
ah
see ->
5
Q: Ask for username and password on 18's login screen

lonixI'm using the latest Ubuntu 18.04 LTS bionic. When I login it shows my username and I just need to type a password. I don't want usernames to be shown. I want to be forced to type a username and password. How do I do that? All I found is info for old versions or lightdm (18 uses gdm).

I answered that before I knew about yours ;')
 
ah ok :D
well happens in most cases im someone who answers first if i know the answer and dupe close then so be my guest :)
you know who reported this bug? ;)
 
@Videonauth is that your name?
 
10:43 AM
I think I need to do something like this in order to roll back to the original:
 
lets say it so i can edit the bug description straight away :)
 
I got some flash drive with the motherboard box
 
ah no wasnt me but i guess second or so was me to suscribe to it
im on launchpad the same as here
@rinzwind if gdm crashes you cannot use tty3
tty's are only created on demand
by gdm3
so only way to fix this is using root prompt from grub
 
@Benny original of what? BIOS? doubt it... BIOS update is always "old" BIOS + bugfixes. It hardly ever includes new content since your board does not have new features.
@Videonauth eew. That's bad design in my opinion
 
@Rinzwind yes it is i only tell you because you wrote it in your answer :)
 
10:51 AM
edited it in
so much work for a closed topic :(
 
indeed :)
and yes its a very bad design in my opinion too
only other way beside a root prompt is to have SSH configured properly and ssh in from another machine
 
live session :P
lunch! bbl
 
 
4 hours later…
3:28 PM
0
Q: Reopen this question

PantherI installed kali linux with the dual boot on ubuntu 16.04 It is not a question about Kail linux, it is a question about recovering Ubuntu I agree we do not support Kali I agree the op should have made backup We do, however, support Ubuntu data recovery after I stalling other os windows speci...

 
 
1 hour later…
4:32 PM
Anyone here who might be able to help me out? I try the following, I have in a game which I modded a list of missing assets and now i would like to printout in terminal their asset number behind a given link to the steam workshop, so that I can open the links in browser and suscribe to the assets without copy and pasting to much
$ cat Player.log | grep 'Asset not found'
[LSM] Asset not found: 763472782.dong_Data
[LSM] Asset not found: 775509816.Yellow Line 01_Data
[LSM] Asset not found: 1098938808.R69 Tamurakoma Sign_Data
is how it looks basically, applying awk to print the 5th element gives me what i want but it still has a dot. and useless information
$ cat Player.log | grep 'Asset not found' | awk '{print $5;}'
763472782.dong_Data
775509816.Yellow
1098938808.R69
1098938808.R69
904028991.ra64_SatelliteDish01_Data
904028991.ra64_SatelliteDish03_Data
904028991.ra64_SatelliteDish04_Data
all i need now is a way to get those numbers in front in an echo "https://steamcommunity.com/sharedfiles/filedetails/?id=<NUMBER_HERE>" for all numbers
anyone? @dessert?
$ grep 'Asset not found' Player.log | awk '{print $5;}' | grep -oE '^[0-9]+'
763472782
775509816
1098938808
1098938808
904028991
904028991
this is how far i got but now no clue how to get it into the output
NVM figured it out
for number in $(grep 'Asset not found' Player.log | awk '{print $5;}' | grep -oE '^[0-9]+'); do echo "https://steamcommunity.com/sharedfiles/filedetails/?id=$number"; done
 
5:01 PM
What's up?
 
my irritability towards the bank I use?
my blood pressure?
my likelihood to hurl thunder down at people who're breaking the "Be Nice" rule?
other than that not much, what's up with you @AaronHall
 
I'm seeing successful crowd-funded linux phones and laptops (Purism). Why didn't the Ubuntu phone raise the money it needed? Market not mature enough?
I wanted to pledge money, but my wife wouldn't let me.
 
ask Canonical?
 
Maybe the amounts were too low?
 
I don't think there was specific announcements or stating of the support for it, etc. or exactly why they cut support
 
5:04 PM
I want my convergence device now, darnit.
 
I think the closest you can find is this:
notably this bit that Mark Shuttleworth said in the post:
> I took the view that, if convergence was the future and we could deliver it as free software, that would be widely appreciated both in the free software community and in the technology industry, where there is substantial frustration with the existing, closed, alternatives available to manufacturers. I was wrong on both counts.
>
> In the community, our efforts were seen fragmentation not innovation. And industry has not rallied to the possibility, instead taking a ‘better the devil you know’ approach to those form factors, or investing in home-grown platforms. What the Unity8 team has de
so in reality the person to ask is SABDFL - Mark Shuttleworth :p
 
@ThomasWard I meant the "Edge" which was going to be crowd-funded: indiegogo.com/projects/ubuntu-edge#
 
oh well "crowd funded"
hadn't met its goals :P
 
I forgot they were going for 32 million.
 
oops can't read
 
5:10 PM
made me look
No wonder lots of crowd-funded things came after... say you want 1.5 million, get 3...
 
This is fun and weird, even i have now suscribed to about 200 assets more i use less memory with my game O_o
 
@AskUbuntuMeta I never thought I'd disagree with Oli, but...
 
5:31 PM
@Videonauth for i in $(grep -oP '.*Asset not found: \K\d*' <test); do echo "https://steamcommunity.com/sharedfiles/filedetails/?id="$i; done
or with parallel:
parallel echo "https://steamcommunity.com/sharedfiles/filedetails/?id="{} ::: $(grep -oP '.*Asset not found: \K\d*' <test)
provided the file name is “test”, needless to say ;P
 
nice a shorter version of what i produced there :)
but wouln't that as well print the asset not found part?
 
@Videonauth that's what sed is for:
You might also want to pipe through uniq though:
Well, sort -u anyway
By the way, @dessert the .* at the beginning of your regex doesn't change anything. You're ignoring everything before the match anyway, so you could just do grep -oP 'Asset not found: \K\d*
Although \d+ would be safer since \d* also matches 0 digits.
</nitpicking>
 
ok have to take those apart, need to understand :)
 
5:46 PM
The basic thing is sed -n which means "don't print unless I tell you to". Then you have a substitution s|old|new|p. The p means "print if the substitution works". So it will only print on lines it managed to run the substitution on.
 
ok and youre using | as delimiter instead of / to prevent the mountain building right?
 
yep
And -E gives us the + for "one or more" and allows the use of parentheses to capture stuff without needing to escape them.
 
question is sed -E option the same as grep -E ?
 
Basically, yes.
$ man sed | grep -A2 -- -E,
       -E, -r, --regexp-extended

              use extended regular expressions in the script (for portability use POSIX -E).
$ man grep | grep -A2 -- -E,
       -E, --extended-regexp
              Interpret PATTERN as an extended regular expression (ERE, see below).
 
ah ok
 
6:12 PM
Hey,
The error message I am getting is the same as here
61
Q: Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Jeffrywith1eUpon trying to upgrade from 10.10 to 11.04 all seemed to go well until the restart. This error message is what comes up: Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) How do we fix that?

I cannot write the commands, how to load grub menu? I try to enter advance option > recovery mode > and it's just print trace
oh sorry, press C for command line.
 
@Benny the grub menu you get by holding/pressing shift as soon the BIOS selftest is through, is a bit tricky if you not have enabled it by default you need to get the right moment
left shift <--
 
i am in the grub menu, i am about to write
update-initramfs -u -k version
but which version?
do you know please?
 
just start the kernel you had before ?
 
@Rinzwind I already knew you were good, just not that good!
;) >:) ;)
 
ubuntu keeps natural serveral versions of kernels in stock (at least two)
 
6:20 PM
anyway the command not found
 
@Benny start the previous kernel...
 
how? from the menu?
 
hold [Shift] while booting...
@Benny yup
 
wow
it load to login screen, and after enter, i get blue screen
 
bluescreen? that isnt windows isn't it?
3
 
6:25 PM
with a mouse I can move
seems like graphic card
issue
I switch into tty2, and now updating the system, about 600+ updates
 
@terdon Right, I trusted this wouldn’t happen. ;)
I wanted to give a sed solution as well (quite basic actually), but I was in a hurry.
<\apologizing>
 
@desert i loved to see your approach, i mean after i had solved mine i was wondering if this could be done better, so thank you and @terdon
 
@Videonauth do you know rosettacode.org/wiki/Rosetta_Code?
 
6:40 PM
@dessert no is new to me, bookmarked it
 
0
Q: How to refresh an alias each time it is executed

jt.jI have this alias to check the temperature of my Raspberry Pi: gpu=$(/opt/vc/bin/vcgencmd measure_temp | awk -F "[= \']" '{print $2}') cpu=$(</sys/class/thermal/thermal_zone0/temp) cpu=$(echo "$cpu / 100 * 0.1" | bc) cpuf=$(echo "(1.8 * $cpu) + 32" | bc) gpuf=$(echo "(1.8 * $gpu) + 32" | bc)...

 
Anyone else as lost as me? askubuntu.com/questions/1042036/… I have already VTC on unclear. I guess I might be missing something from the question.
 
Reading...
@Terrance AFAIU, he's wanting to change the standard file-open dialog...
will ask hime/her/it
 
But none of them have a file open dialog that I am aware of.
 
@Terrance That's the DE, which OP might be confusing with the File Manager...
 
6:53 PM
Thunar has control + O, but it is grayed out.
I think that you are right.
 
@Videonauth have a weird awk way:
<test awk '{ if (match($0,/Asset not found: [0-9]+/,m)) {sub("Asset not found: ","https://steamcommunity.com/sharedfiles/filedetails/?id=",m[0]); print m[0]} }'
 
oh ouch ....
 
want explanations?
 
uhm only if you like to: not necessarily needed right now im happy that i understand regex at least a little bit :)
 
ok – it’s definitely not the best awk way anyway
 
7:03 PM
ok then leave it be, better not to confuse m with that right now
saved it in a text file for analyzing on a later date
 
@Videonauth too late :D
<test awk '/Asset not found/{print gensub(/.*: ([0-9]+)\..*/,"https://steamcommunity.com/sharedfiles/filedetails/?id=\\1","g")}'
that’s much better: only for the lines with Asset not found save the number in group 1, replace the whole line with the url followed by the content of group 1 and print the resulting line.
"g" to replace globally is actually useless, could be simply 1 to only replace the first occurence
 
7:23 PM
:P
 
8:06 PM
@Videonauth sorry, can’t let it be although doing unrelated stuff – the printf approach deserves to be mentioned, it’s an easy one:
printf "https://steamcommunity.com/sharedfiles/filedetails/?id=%s\n" $(grep -oP 'Asset not found: \K\d+' <test)
 
@Terrance I was wrong: voted unclear
 
@Fabby I am completely lost as to what is being asked. =)
 
Yeah, so am I...
@Terrance Oh, I'm sorry, sir. I'm anus-peptic, phrasmotic, even compunctious to have caused you such pericombobulation....
 
@Fabby LOL!!!!
 
8:25 PM
Quoi?
 
> EDMOND: Oh, I'm sorry, sir. I'm anus-peptic, phrasmotic, even compunctious to have caused you such pericombobulation.
 
lol
I've never seen this before
 
@ByteCommander Blackadder can be found on-line
You need to watch it with subtitles though...
Difficult for a non-English speaker.
 
Yeah, I only understood half of it
but...
 
8:38 PM
 
9:26 PM
Discovered lkml.org today
 
9:41 PM
@ByteCommander Shall I have you banned from chat for a week? Lots of free time!
;-) :-) ;-)
 
9:57 PM
@ByteCommander Please answer nine of those 1,043 questions: askubuntu.com/…
 
@Oli How can I retract my flags?
@Seth ?
I think I was a bit too enthusiastic in flagging spam from this source
 
0
Q: Launching an X application on a remote server works when SSH'd but not as an inline command

Brian RI have a remote server that I want to launch an X application on. I don't need to see the GUI myself (no x-forwarding), I just need to launch the app. This works: $ ssh <remotehost> $ xapplicationname -params This does not work: $ ssh <remotehost> 'xapplicationname -params' (xapplicationname...

 
@Fabby click “flag” and the button “retract flag”, no?
 
OK, I thought there was a queue I could go to.
 
@Fabby that is my smallest problem...
 
10:07 PM
wait, what?
oh, of course – only you can access it
@Fabby there is your flag summary: askubuntu.com/users/flag-summary/344926
https://askubuntu.com/users/flag-summary/YOUR_ID
 
@Fabby You click flag again and the button changes to retract
 
you can access this summary from your user page, on the right in the IMPACT section click the “billions 1,080 helpful flags” link
 
@Seth Yup, that's what I did
thanks!
 
10:36 PM
anyone any delete votes left?
 
@Fabby voted. =)
 
Thanks!
 
10:53 PM
@Oli
pypy3 -m pip --user install requests tqdm

Usage:
  /snap/pypy3/2/bin/pypy3 -m pip <command> [options]

no such option: --user
fab-root@fab-ux-predator:~
$ pypy3 -m pip install requests tqdm --user
Collecting requests
  Downloading
 
11:33 PM
Finally fixed, my new PC is running well now! thanks for the help!
 
New PC?
Screaming monster?
@Benny ---^
 

« first day (2800 days earlier)      last day (476 days later) »