« first day (2377 days earlier)      last day (986 days later) » 

12:33 AM
0
Q: Notice: askubuntu recent questions RSS feed change!

heynnemaHaving problems with your RSS News reader app? Seems that somebody is changing the RSS feed address from: http://askubuntu.com/feeds (only shows questions up until 09:00 4/1/2017) to https://askubuntu.com/feeds (shows questions after 09:00 4/1/2017)

nuke please ^
 
sigh . . . over the course of the last 25 years of internet boom we still haven't learned to protect people from those f*ckin adds that claim "your computer has virus" and that's one of the biggest reasons why I hate JavaScript. This needs to die in a fiery pits of hell, and JavaScript developers right along with it.
 
wat
 
And a happy wat to you too.
 
happy watday to you
happy watday to youuu
 
12:45 AM
Happy wat day dear weird-wanderer-person
Happy wat day tooooo youuuuuuu
 
@NathanOsman hmm, i just had an awesome idea: make a game, call it hacker simulator multiplayer, where there's disguised "raids" have real IP addresses, and people unbeknownst to them will be ddos puppets attacking real targets. That'll sell well
 
And get you in jail.
 
@NathanOsman obviously
 
point being, that type of thing might not be too far from truth. People are easily fooled
which also makes me mad,too
 
12:51 AM
@TheWanderer Don't you really mean Happy Hueday to yoouuuu
 
that was yesterday
 
seemed so far away....
 
@TheWanderer never gonna hue you up, never gonna hue you down, never gonna hue around, and hue you
 
hue
 
/bans Zach
mmmmm, so . . . .to coffee or not to coffee ?
 
1:01 AM
always coffee
 
but it's 7 pm . . .
 
Did I stutter?
 
Ok, mr. wolf boss
although you fired me earlier anyway
er nawt my bass meow
 
TNB is no fun
 
Snoke identity revealed by star wars
 
1:10 AM
dun dun dun
TNB is no fun
 
@TheWanderer what the hue is TBN
 
codegolf chat
 
@SergiyKolodyazhnyy I dunno if this is funny or not, but it made me think to show you: devrant.io/rants/507738
 
@Seth hehe, seen this joke somewhere already. Second comment is accurate though
 
1:32 AM
@SergiyKolodyazhnyy mind explaining it to me?
 
I'm going to go attend a lecture given by the fellow that invented MRI.
 
@Seth The Interнет part is simple - the нет part which reads like net in English is basically "no", "there isn't" , or "have not". So that's inter-lingual pun basically, if you will. The second comment - cука - is basically the b word, which is applied as intended sometimes, but for the most part's is loosely used in the same way as sht, carp, and fck in english as a common conversation filler when you want to express frustration or disappointment.
Also in the similar fashion is used блять or бля (shortened form, like f*ck or faaah)
And that concludes the short course on the Russian curse words. That'll be 3.50$, phank yew phuery mush
I can teach chinese curse words if necesssary
 
No thanks :)
 
OK . . . closes the textbook
 
@SergiyKolodyazhnyy thanks! I didn't expect it to be so colorful, but I probably should have lol
 
1:42 AM
@Seth well, Russian language is complex, vast, and totally makes no sense. At least now you can totally understand what the Russian gamers are saying in LoL or DOTA :)
so I just watched sort of review of season 2 of attack on titan's first episode, and now I wanna go back to listening Wagakki's "Hageki No Yaiba"
 
@NathanOsman ooh that sounds really interesting
 
I am always excited when there are guest speakers who can talk about their expertise and experience, but at the same time there's always a certain amount of shyness and anxiety lurking inside my mind that there's this great person, up close and real, and there's me - light years apart and completely incompetent
That's frankly how I felt when I joined Ask Ubuntu: "I'm never going to get anywhere close to where those guys are"
@TheWanderer did you see it ?youtube.com/watch?v=C_wBkoWKsVY
Jack got 15 mln button
 
hue
 
@TheWanderer sorry i couldn't understand you through your thick brazillian accent
 
wat
 
1:56 AM
Oh, I^2*R ?
Because . . . P=VI, and V=IR, therefore . . . P=I^2R
 
Which is really cool if you think about it
 
See ? I am a terrible electrical engineer, i can't remember my wat formula
thinks about electrical engineering . . .has flashbacks to terrible exams and lab partners, and professor's evil laugh
Jack's AAAAAAAH!!! video is so beautiful
Majestic even
 
2:12 AM
@terdon Perl is really valuable ^
 
2:32 AM
@NathanOsman @Seth so you guys have done some SQL right ?
 
I haven't done any, really, but I'm familiar with the basics
 
Well, what I am more interested is this: are databases mostly for web stuff ? Like querying info on web server , or is it common to have databases for something like desktop apps ?
 
@SergiyKolodyazhnyy lots of things use databases. Just not always full sized ones.
 
2:48 AM
@JourneymanGeek well, for example ?
I know firefox uses it for some things, but it's like the only thing I've seen ever to use sql in a desktop application
 
Veem uses a lightweight mssql varient for storing file metadata.
If you were writing a rss feed client, a simple database would be a great place to store data.
Essentially any place you need to retrieve structured data quickly
 
See, that's the problem with SQL. I kind of wanna learn it, but so far I just . . . don't see much purpose in it for myself
I'm lacking context to learn it
 
3:41 AM
@Seth it was really interesting. They're doing "live" MRIs now showing the flow of spinal fluid in realtime. Absolutely fascinating.
 
@SergiyKolodyazhnyy They are used in desktop applications too, it just depends on the use case.
Off the top of my head browsers and Rosetta Stone both use databases regularly. I'm sure others do but I'm not familiar with it off the top of my head.
Mobile apps also use databases quite regularly.
 
3:56 AM
hello everyone, can somebody help me out with my question : askubuntu.com/q/899136/584869
 
4:10 AM
@Zanna didn't we decide hardware compatibility was on-topic? askubuntu.com/questions/899230/…
pretty that's always been the case, but I've been out of things for a while now (as many of you know) and I honestly can't remember. Pretty sure we talked about this though
@Anwar ;)
 
4:44 AM
@Seth I think they should be, certainly. We could be getting confused between compatibility & shopping recommendations. Questions like that one more likely get closed as too broad/pob or dupes of "how do I tell if Ubuntu is compatible with my hardware" or the one about minimum requirements for each flavor. But I think those questions should be OK... meta time maybe
 
5:04 AM
is ViVARD a good tool to use for secure erasing hard drives.
or is dban better
 
@SergiyKolodyazhnyy databases are useful anywhere you want to store large amounts of structured information.
or if you're using nosql, non-structured information.
Lots of desktop apps (mobile apps too) use SQLite for data storage.
@Neil I like DBAN more, but shred is also pretty powerful.
 
Well, yeah, that's what firefox uses
@Neil I somehow doubt anyone here is familiar with those two tools
OK, one user
 
i do a lot of hard drive shredding for no reason, okay?
Totally no reason at all.
 
@KazWolfe why dban
 
@KazWolfe mmmhmmmm, I do too, totally for no reason of deleting all the p0rn that I didn't download, and all the private data that I don't have
 
5:13 AM
@SergiyKolodyazhnyy secure erasing hard drives is reqired if you want to sell you HDD to some one
 
@KazWolfe there's a dban port you can run on a regular system
 
i like ViVARD it seems to do the job like any other program.
 
@Neil Depends on state, local law, and context. So "required" is a stretch
 
@SergiyKolodyazhnyy its a bloody good idea!
 
@JourneymanGeek Bloody good idea, but again - depends on the local law
 
5:15 AM
@Neil quick, mostly.
They all do more or less the same thing, but dban is just quick and i'm familiar with it.
 
@SergiyKolodyazhnyy A simple one pass wipe is fast and good enough
 
@JourneymanGeek for most cases
 
Also hides any bad sectors on the drive ;p
@KazWolfe If you trot out guttman....
Anything more is checkbox ticking.
 
If there's something actually really sensitive on that drive that might encourage heavier inspection...
Guttman is insane. For really secure data, I use three-pass (random, random, zero) and that's overkill imo
 
@KazWolfe so.. a few passes of zeros?
and of course, if its an SD, secure erase.
 
5:17 AM
i think i'm going to swap to zero/random/zero though.
 
Oh thats fine
 
@JourneymanGeek You're preaching to the choir. I know that it's easy and such. And I know it's good idea if you don't want your data to end up in wrong hands ( and I know because I've had situations like that ), but again - it's wild west right now really, there is no consensus on what is required
Good idea is good, but something being mandatory is another question
 
or, actually, maybe random/zero/random is better if you plan on encrypting the drive later.
 
@KazWolfe im working for a computer recycle place just wondering if dban is better. used ViVARD on a hard drive and tried doing a recovery no data to recover. dose it really matter what i use ?
 
@SergiyKolodyazhnyy I would like to introduce you to the work of one James Mickens
@Neil typically no
 
5:19 AM
@Neil Honestly, no. Just write zeros to the drive.
You want to be careful with SSDs, but for regular magnetic drives, any tool that writes zeros (so even dd) is just fine.
 
@k thought so, just wanted to check
 
@KazWolfe the literature on how to wipe SSDs is infuriating
I'd just do FDE with a key elsewhere and nuke the key if I wanted to securely dispose of a SSD
 
yeah... SSDs are always encrypted if I work on them.
easier than doing cleanup later.
in fact, infinitely easier as SSDs can't really be completely cleaned up iirc.
But yeah, @JourneymanGeek, three pass is probably overkill but I don't want to risk it when private keys are on the line.
 
@KazWolfe and theyr'e fast enough to make things worth it
 
I still use a magnetic drive actually for things that need to be actually secure.
My university library lets me use their demagnetizer to actually blow them into oblivion.
 
5:35 AM
@JourneymanGeek again - preaching to the choir here
 
legasp
 
That face looks familiar . . . and evil . . .
 
@TheWanderer totally wouldn't recognize that cranky boy
 
5:46 AM
hue
 
hey @ThomasWard
can you tell me how to fix my fonts? ubuntu mono is fugly on intellij
ok, got it slightly better. still feels slightly... off.
 
0
Q: Multiple Attempts at Compiling Tmux

justinmnoorI've been telling myself that I need to learn compiling. I decided to give it a shot with tmux. The goal was to clone and build the latest version of tmux from version control. I'm using Xenial 16.04 LTS. I cloned tmux, installed its dependencies, and ran: cd tmux sh autogen.sh ./configure && m...

 
You know what else is off ?My sense of humor . . . I couldn't come up with anything in the last 5 minutes
 
hey @TheWanderer, what's your default font size on intellij?
 
idk
 
5:53 AM
@TheWanderer it's likely "hue" size
 
can you check pls?
 
monospaced font?
 
idk
yes
 
what about your general font?
Settings > Appearance in IntelliJ
 
6:01 AM
Segoe UI
 
ty
 
there we go. fonts aren't looking like garbage. awesome.
 
SUGOOOOOI YEW AYE!
 
Totally kawaii desu af
 
 
1 hour later…
7:15 AM
@Zanna why mindepth ? askubuntu.com/a/899356/295286 And why iterate with for then use find ? Just use find from the beginning and filter what it returns
 
7:26 AM
Oh, nevermind, I see. You're excluding '.' dir
 
my thinking with the loop was to be able to write to $i/list
but expensive I guess
 
Meh, just find -type d that stuff. If OP wants, I'll probably write what I originally had in mind
 
yeah then you can write to {}/list, makes sense
 
@Zanna what do you think of my solution ? I kind of feel it became slightly too bloated for a one-liner
 
7:46 AM
@Serg it seems you understand what he means by remove it through the code ... Que?
 
@SergiyKolodyazhnyy I upvoted it
it's acually longer than mine
but shrug Shell Loops Are Slow
even slower than find I think
it works well... need to learn awk
the python way is most elegant though I guess
 
python scripters are lazy. We have libraries for everything :)
 
s/lazy/smart/ why do work when you don't have to? :)
 
Shell can be elegant,too, but it takes a lot of knowledge and tricks to achieve it. Just look at some of Gilles's or Stephane Chazellaz's answers. Heck even terdon's
 
Oh I wouldn't say it cannot be elegant. There are lots of pretty shell scripts around... I am even quite proud of the little script I made for the IP conversion or something, whatever it was. But in this case, the python answer is the cleanest-looking
 
8:00 AM
user image
2
French flag
 
hahaha
 
@Zanna looks aren't everything
 
for sure!
 
@SergiyKolodyazhnyy We should "flag" it :)
 
HNQ (unsurprisingly)
 
8:12 AM
Really??
 
yup
\o @Hizqeel how's it going?
 
@Zanna o/... Everything fine :) what about you? How are you? and Sorry I am late Happy Birthday :D
 
haha that was just @jokerdino joking around; my birthday is in October (and so is his IIRC)
 
@JacobVlijm Probably because of lots of views in short time, 44 already, and 3 answers already
 
it's also the total rep of the answerers ^
 
8:18 AM
@Zanna :-|
 
@Zanna @JacobVlijm I realized it only later in the day. I was seriously going to play you guys a happy birthday song on my hulu flute
6
 
@Hizqeel I'm very well and happy that it's not my birthday yet (so I can stay a little younger a little longer) haha. glad to hear all is fine with you :)
@SergiyKolodyazhnyy LOL
 
Haha, still waiting for it :)
 
Well, maybe some day. Not at 2:21 in the morning
 
@Zanna :D
 
8:21 AM
Ai, you should be sleeping!
 
^
 
@JacobVlijm by the way, that syntax isn't odd, x for x in sequence creates iterable if I remember correctly, and then [] simply "casts" it or modifies it to list. But .join() only requires iterable, which the list comprehension already provides.
Ah, it's generator object
>>> (x for x in [1,2,3])
< generator object <genexpr> at 0x7f5c2fc080a0 >
 
@SergiyKolodyazhnyy yeah, you are obviously right, but I need a minute to get used to it haha.
 
@Zanna general shell scripting. Doesn't exactly matter. Although your comment is proper
 
8:39 AM
I don't agree that it doesn't matter in this case, given the comment on heemayl's answer (no prename!)
 
8:50 AM
Hmm, let me see what I can do about it . . . booting CentOS VM
 
should still not be here if Ubuntu answers won't work imo
 
Ubuntu answers work for Ubuntu users, no ? OP's problem that they didn't ask in the right place
Ok, answered with Python2. That'll work regardless of CentOS or Ubuntu. Especially since CentOS doesn't have Python3 and still uses Python2
 
9:08 AM
yeah of course, and I used to take that approach always, BUT it was pointed out to me that OP can have a lot of influence over the question
for example, if OP is running a different OS, they may accept an answer that works on that OS even if it does NOT work on Ubuntu
they may even downvote, or cause others to downvote (with comments) answers that do work on Ubuntu
to avoid such risks, better to migrate, imho
 
OK, well, I should go sleep before I answer all CentOS questions here. Voted to close although I feel like this is still acceptable post for Ubuntu.
 
9:43 AM
Hi guys and girls, i am trying to install LXQt on ubuntu server 16.04 (all from scratch) and i installed xinit and lxqt-core....i can get into gui by typing sudo startx but there is no taskbar with start button....what do i need to install to get that...i used to have LXDE before and i installed lxdm for it...is there an alternative for LXQt
?
 
I never used LXQt, but I also think you are missing a display manager (like lightdm for Unity)
Or try systemctl start graphical.target instead of startx once.
 
i get this @ByteCommander
yes i am missing display manager
which one to install for lxqt
can i install lxdm
 
I don't know
 
10:06 AM
i have installed lxdm but it's the same
 
 
3 hours later…
12:44 PM
@KazWolfe in a string, what does this mean? 0xFFFFFF & color
 
F = 1111 & clolor => color
what i try to say is:
(0xFFFFFF & color) = color
 
1:27 PM
So much fun
trying to upgrade an EOL trusty box to xenial. Something's stuffing up and I don't know what
 
2:19 PM
Does sed have a limit of ~2,200 characters?
 
@WinEunuuchs2Unix Of what? File size? Line length? Script size?
And I don't think so.
 
bash array size....
Here was the code:
ListArr=$(sed 's/ /\|/g;' <<< "${ListArr[@]}")
it worked for first 2,203 characters
 
Huh. I doubt that will be sed though.
Possible workarounds:
ListArr=$(echo "${ListArr[@]}" | sed 's/ /\|/g;')
In case there's a limit to the size of a herestring. Although that would seem strange.
 
I'll rerun it from the command line.... it was a weird day today where gedit interpreted this and only this bash script as chinese... I had to open this bash script with nano and resave it for gedit to see it properly.
 
Also worth trying would be a loop
 
2:22 PM
@terdon your example code is exactly how I did it at the command line last time it worked for the full array :)
 
LOOOP
 
How bad an idea would it be to upgrade from 14.04 to 16.04 by editing sources, and hitting it with dist-upgrade?
 
Interesting. I wonder if there's a limit for herestrings then,.
 
I'm getting hit by a bug, and all the suggested answers fail. And I haz a backup.
 
@SergiyKolodyazhnyy have you had whitefish salad?
 
2:27 PM
do we need a tag for that? askubuntu.com/questions/tagged/tape
 
@terdon It's not herestrings because using your code sed stopped replacing at the same place shrugs. I'm going to just use the terminal and run it on the file instead of within that bash script. Can't trust the script after gedit converted it to Chinese and nano had to be used to open and save it in english again.
 
Something very strange is going on in your system. . .
Is this your Ubuntu box or something else?
 
It's my laptop running Ubuntu 16.04 it's been working fine except last few weeks ethernet doesn't wake up from suspend and wifi takes over. I've had to force it to restart r8169 driver but even that has broken last couple days and DNS can't be found until reboot.
So this works fine: sed -i -- 's/ /\|/g' .websync.new
 
Yes, sed shouldn't have any limit. I am curious about what limit you were hitting though. Some bash thing, presumably, but I can't figure out what yet.
 
I don't know sed very well but the broken code had a semi-colon (;) behind the "g" but the terminal version I copy and pasted didn't.
BTW @terdon that yad progress bar I upvoted and complimented you on yesterday?... where you pipe echo output with "tee" between file and yad? I had to spawn the progress bar to a separate bash script because I had 100's of lines of code with many echos inside the while loop that was piped to yad.
 
2:39 PM
@WinEunuuchs2Unix Shouldn't make a difference. GNU sed (probably others) uses ; to separate different commands, and while it isn't needed for a single one, it shouldn't hurt either.
 
@terdon I didn't think the ; made any difference just throwing it out there as the only difference I noticed.
 
@WinEunuuchs2Unix Not sure what you mean. I remember the answer you are referring to, but I don't really know anything about yad either.
 
For a yad progress bar, all echo's within a while loop are piped at the end of the loop to yad... ie ( while do a bunch of echos done ) | yad --progress ....
 
ok
 
sorry it's very obscure for this room :D But thanks for your help with sed :)
 
2:43 PM
yay I have a bloody nose in my other nostril now
 
@WinEunuuchs2Unix Not at all. This sort of thing is perfectly on topic, I am just no expert on yad. The question you upvoted was only tangentially related to yad, the issue was bash-related.
 
@terdon Yes it was definitely bash related... Here I thought I found a yad expert :/
 
Nope, sorry :)
 
Is there something better you use to turn bash into a GUI?
 
@terdon faker
 
2:45 PM
@WinEunuuchs2Unix Perl.
Or python.
 
ew
perl
 
Oh hey, ignorance rears its ugly head!
:P
 
@terdon Everyone keeps recommending Python and Perl sigh
 
@WinEunuuchs2Unix Shell languages are not designed for actual programming and are very bad at it.
Bash can't even do floating point arithmetic FFS!
 
@WinEunuuchs2Unix Python is sensible for non C person. Perl is traditional
 
2:48 PM
in /dev/chat, Jun 25 '15 at 14:34, by terdon
If you're writing data parsers in shell, and are not forced to because of a limited toolset, you deserve what you get.
 
the yad command is only 200K. I'd like to stick to calling a command from Bash not a 10MB language interpreter like Python or Perl (I don't know how large they are though). Calling them would be a lot slower.
 
OK, I think I found the problem @WinEunuuchs2Unix. Sed does have a limit to line length, not line number.
What you were passing there was a single line since the array is printed as a single line.
 
Yes I read some place it used to be 256 characters but was expanded, I guess the new limit is 2K?
 
Sed has a limit of 4k bytes per line, and you were exceeding that.
4k bytes
 
@WinEunuuchs2Unix every ubuntu box has python and perl installed
 
2:51 PM
So, what you want is this:
ListArr=( $(printf "%s\n" "${ListArr[@]}" | sed 's/ /\|/g;') )
 
@JourneymanGeek But a bash program calling python or perl all the time to pop up a progress bar 100 times will be slower than calling yad...
 
Assuming you want to save as an array again (your original version was converting to a string).
 
Everyone keeps recommending perl or python because it's the right answer. I'ld lean to python. Perl's strength was always it's brevity/unreadability/kingoftheregex.
 
@WinEunuuchs2Unix No, it would be a perl or python program, no bash.
 
Yes I know you can write apps in Perl or Python, but I'm writing a GUI app in bash...
 
2:53 PM
Bash shouldn't be thought of as a programming language. It's a shell that can be used to write simple scripts, yes, but it was never designed for writing arbitrary programs.
Hell, it didn't even have arrays or data structure other than simple variables until relatively recently.
 
Yes the array's in bash are key to maintaining the database of files and answers posted in AU. It's the only way you can insert/delete records in yad --itemlist
 
Yeah, well, bash is very much the wrong tool for the job if that's what you're doing.
You can probably manage it, if you try hard enough, but that's kinda like saying you can use a screwdriver to hammer a nail in: you can, but it is much harder than necessary.
 
haha yeah I know :p But the point is it's pretty much all done... I do need to setup test data using other people's Q&A in AU rather than my own real data (which nobody cares about) before publishing.
The 3 second progress bar whilst anaylyzing AU answers was the last big hurtle.
 
Wait, what's the point of having a progress bar for something that takes 3 seconds?
 
In mainframe programming classes (in college) they said anything that takes longer than 1 second requires a message.
Otherwise people thing machine is broken or something like that.
 

« first day (2377 days earlier)      last day (986 days later) »