« first day (2355 days earlier)      last day (1550 days later) » 
00:00 - 16:0016:00 - 00:00

4:14 PM
@Serg need more script help
anyone have a time or desire to review a resume? my typical review person is being sluggish...
@Zacharee1 ask and you shall receive
@Serg I have a path that I know will be /data/app/com.zacharee1.modcontrol-<something>/base.apk
how can I account for that wildcard in a cp statement?
oh that easy?
4:17 PM
that could be sufficient if you expect only to have single path like that under /data/app
@Serg should only be one yeah
Well, that should work then
@Serg easy things mostly work best ! :) Hi Sergiy ! :)
@RobotHumans I don't think I am the best person to advice you in that. Whenever I write one, it is usually rewritten 100% after having it reviewed :)
@cl-netbox Not always true. Hello again !
4:19 PM
@Serg I know ... that's why I said : mostly ! :D
@JacobVlijm np. thanks for responding anyway...
Oha. That kitty...
user image
could have just put a cucumber in front of the pipe, and the cat would have backed out
and this is why i'm not a fireman
4:35 PM
I need a clipboard manager for my brain . . . Because every time I have a thought today, it's gone within 30 seconds, and I cannot recall what the heck I wanted to look up in that new chrome tab I opened and was staring at for 15 minutes
4:46 PM
sounds like you need more sleep.
^ Definitely
4:58 PM
It's one of those things I always need, but can never get
also . . .the vending machine for coffee is out of paper cups, so I cannot get coffee today
@Serg you might want to request an image- replacement here: omgubuntu.co.uk/2016/09/… it says assing profiles :). Somehow I have the feeling it should be Assign profiles :)
... but this one might to better on Google :)
@Zanna @muru did the image/link converter script run before Marco added HTTPS to hostmar.co and thus miss all of them or did it just not catch them all?
5:28 PM
Q: Why is php not sending mails to local domain?

Jan MiękinaI am running Ubuntu Server 16.04.2. My domain.pl A record leads to this server IP. On this server I installed LAMP via tasksel command. After installing wordpress (I used letsencrypt as well) I noticed, that any mails sent by php (I guess that's sendmail(), can't really tell as I have only basic ...

5:42 PM
Q: sign_and_send_pubkey: signing failed: agent refused operation

strudelj nudeljRunning xubuntu 16.04, with xfce im trying to use ssh keys with passphrases. I would like to add my passphrased key to my ssh-agent but i dont know why i cant add it. I dont have gnome keyring enabled or anything alike in my startup. ssh-add privatekey, adds the key but when i try to ssh again it...

5:57 PM
@JacobVlijm No, that's a spelling mistake in my original code. Thanks for spotting
6:15 PM
@Seth it seems that it just failed to catch the inlined ones
@Zanna did it fix any?
seems like Marco deployed HTTPS the same day the script ran so it's a matter of when exactly it ran
Let me check...
Um.... it looks like no
This is going to take a long time >_<
@Zanna no to what?
oh, no to fixed any. @Zanna let me ask SE to rerun it.
Yeah not fixed. Sorry my connection seems to be really bad, I'll be back in about an hour.
Rerun would be great haha
6:31 PM
@Zanna I think chat is being spotty today. my chat tabs keep reloading and reloading.
Nothing like that with mine
Can I ask you to rerun it on Ask Ubuntu? We had a bunch of images hosted on our own server that didn't support HTTPS yet. Support was added literally hours after you run it (our bad) and now we have hundreds of these to update. Feel free to pop into AU chat if you have any questions: chat.stackexchange.com/rooms/201/ask-ubuntu-general-roomɥʇǝS 4 mins ago
hi @m0sa!
hi @Seth
what image hosting domain are we talking about?
@m0sa hostmar.co/software-small and hostmar.co/software-large are the image URLs in question
6:36 PM
Q: Search not indexing groups of URLs

SethThere are a couple of images used on Ask Ubuntu a lot (namely bit.ly/software-[large, small] and hostmar.co/software-[large, small]). All of the bit.ly images are outdated and need to be updated to the hostmar.co links, however when I search using url:bit.ly/software-large or url:bit.ly/so...

@m0sa so AU has a special use case where we link those images and a special URI to allow easy one click installation of software mentioned in a post. Example here: askubuntu.com/a/409977/44179. If you're running ubuntu and click the image it will open the software store on Ubuntu and direct you to the software in question
We're using a custom domain because the icon for the software center changes every few years and then the images become outdated. So one of our moderators runs hostmar.co and updates the imgur redirect any time that happens. Not the perfect solution, but it works.
Until late on the 9th it didn't support HTTPS though.
I hope it's not too much work to rerun it. I understand if that's not possible though :)
I only see 7 remaining posts
@m0sa oh really? Either we're faster at this than I think or search is still bugged. No worries then, we'll just fix the rest :)
6:42 PM
that's probably because the elastic index is out of date
@m0sa would that explain this bug I just reported?
we had a bug, where we didn't index image urls for a long time
ohhh. That explains a lot of things.
I'll answer in more detail there
Thank you!
6:44 PM
@m0sa awesome, thank you!
don't tell anyone, but iirc there was a bug in the regex parsing the generated html for urls :P
Would that explain why Shog's script was broken too?
something like (a|img) href="(...)"
@jokerdino yeah, that's what he said. It only looked in the search index.
guys, when he says don't tell anyone it means don't star it :P
we planed on using the elastic index for the rebake initially too :)
6:47 PM
How long before it is fixed? Because we are itching to get started on the cleanup project :)
I feel a star purge coming on...
7:06 PM
@jokerdino muru forked the query to exclude bit.ly and hostmar.co links, so we have >900 to do without any of that anyway ;)
@Zanna link?
@Zanna easy peasy
oh, wait, nvm.
@muru Just wanted to let you know your accepted answers from me have resulted in a Q&A that others will hopefully benefit from: askubuntu.com/questions/892076/…
He also checked the revision history to exclude items updated by community mod when the script was run...
That must have been done not through SEDE because the data is too old
So I'm not sure what he did
@jokerdino yeah we are on it :D
Oh he used curl
I didn't get the ping because of a typo
7:11 PM
@Zanna I was using curl to get sunrise and sunset times from www.dateandtime.com and it was taking 12 seconds. I replaced curl with wget and it only took about 2 seconds.... sorry for butting into conv :/
But he said inline links were not caught...
~2000 posts with that URL updated
10 hours ago, by muru
@Zanna I think the script they used doesn't check inlined links, (like ![](...))
should be showing images again
@m0sa Over 9 thousand?
Thank you @m0sa.
7:12 PM
Thank you
Nice that this came before the data dump tomorrow too :D
Our queries will be clean
Not so far
Looks interesting.
I won't bother with cleaning that up just yet, then
... on another note.. I wonder why the search index hasn't picked them up yet
it should, on the next run, since that replace was a post edit
7:21 PM
The indexer must have been out for the weekend..?
or we still have a bug
yeah, who's working on Saturday night? (except us, trying to fix our site lol)
will double check on Monday
yeah, good idea. Have a happy weekend @m0sa!
glad I could help
7:24 PM
8:05 PM
Oh, Google Play's max APK size is 100MB?
thought it was 50
Me after watching a video on idiomatic python ----> @_@
Amazed at how some of the things in python can be simplified
8:39 PM
seems to be dead and gone askubuntu.com/a/11498/527764
looks to me like not what it's supposed to be anyway
@Zacharee1 So did I. They must have changed it.
BTW, I heard you published an app?
well it makes things easier for me
@NathanOsman yeah :D
Link plz?
8:49 PM
Only rooted V20s
@Zacharee1 is this the one where you left my selfie or something , lol ?
@Serg it's not in the app
it's in the flashable ZIP
but I removed it :p
Awww, I thought the derp wolf shall spread across the world to infect all de endroidz width de derpness
well it's in the older version
I could probably also easter-egg it in
8:56 PM
gosh, it's quiet in the labs . . .
I cannot study when it's super quiet. I cannot study when it's too loud. In general, I cannot study ever . . .
This comment would benefit from an upvote so people don't vote dupe instead askubuntu.com/questions/891858/…
@Serg turn on some fans or something
thanks :)
so glad I don't need to learn the Expansion API to make this Android app
@Zacharee1 there's actually 60 Hz hum coming from laps above and i think there's ventilation hum as well
8:58 PM
that's not enough?
for my psyche, it's not enough . . .
I watched a documentary on the last emperor of China, Puyi. Then watched a couple of videos on coding I bookmarked. Just finished watching Jack's new Subnautica video . . .
9:14 PM
Q: Steam Not Loading On XCFE

crossedminotaurI am new to Linux and XCFE, and I used crouton to load ubuntu onto my asus chromebook. Anyway, I decided to get Steam, but when I try to lauch steam, I get the error "Fatal Error: Failed to load steamui.so." Can anyone help me?

9:52 PM
@Serg I'm still struggling how to find if script launched by cron reboot is running and what the program ID is to kill: askubuntu.com/questions/891074/… Therefore I haven't accepted your answer yet (or implemented the code)
Hi @ParanoidPanda I wrote a Q&A on CIA's Vault7 spying but not getting much support for the question: askubuntu.com/questions/891611/… Also not getting any answers :(
"Wonder which page load popup is gonna win the z-index war?" - websites in 2017.
@WinEunuuchs2Unix: It sounds interesting. :)
+1 from me.
Thanks for +1 ofc but I was hoping you might have read some details on Vault7
@WinEunuuchs2Unix: I haven't read a huge amount into it... But if I get some free time, I will have a better look at your question and maybe I will have something. :)
9:59 PM
@ParanoidPanda Event comments supporting the concept of resisting CIA spying would be helpful! I feel all alone on that thread resisting the man.
@WinEunuuchs2Unix "Besides a simple 10 second power off would erase all RAM." - No.
@ByteCommander Oops... blush
The time needed for modern RAM modules to lose their data completely is highly underestimated.
It depends on temperature, if you cool the bricks they conserver most information for hours
Also they don't lose information all at once but gradually, like a picture with slowly fading colors.
See "cold boot attack" and such stuff
OK... so how can you ask for a password and then erase the ram location where the password was entered? Surely it's not impossible...
Anyway, have a +1 for paranoia so far @WinEunuuchs2Unix, but could you please add references to external resources with more information about the threat you describe?
10:12 PM
Surely everyone has heard about CIA Vault7 by now @ByteCommander?
Sometimes I feel like living behind some kind of moon...
this Windows 8 install is so buggy. Now the taskbar refuses to autohide.
@Seth I just installed Windows 8.1 a couple months ago... there were a few hiccups to fix but I don't remember if taskbar was one of them... just google, fix, google, fix, repeat.
aha. stupid Windows. Action center was keeping it open.
Of course there's no way to actually tell that unless you check it..
Sounds vaguely familiar.... only used Windows 8.1 to play one game a couple months ago but I'll be rebooting on March 21 with new game. Let me know if you install Oracle Virtual Box in Windows and if you have any tips :)
10:18 PM
I've used Virtualbox lots of times.
No general tips though. It tends to work fine.
Is it simple download and install with no configuration then?
I'll be running Ubuntu 16.04 of course.
Let's all grow our beards down to our shoes and install Linux From Scratch exclusively.
whoa the YT onebox changed
looks the same to me.
10:33 PM
@Zacharee1 it seems only you changed...
the name card doesn't scroll out of view when I mouse over anymore
VTC as duplicate... @ByteCommander just listed that answer video to revolution ^^^
@WinEunuuchs2Unix try clicking it
@Zacharee1 does for me
@WinEunuuchs2Unix it's a screenshot because he claims its onebox appearance changed
10:36 PM
@Seth weird
I tried refreshing
it's actually playing in-frame!
oh...haha I watch the video earlier and thought it was dup :p
that's how it looks for me
and it does not play embedded
how the heck did you make that?
wat is this
freaking buggy windows
now I remember why I tried to get a Mac.
10:40 PM
CIA is giving you embedded youtube as candy so that you don't ask questions
Bets CIA gives away free anti-virus software that actually installs their spy-ware
sounds like McAfee...
I remember that one time when I almost accidentally installed them as part of Adobe Flash player...
McAfee has been on Russia Today TV shows lately bashing the CIA's Vault 7 software... figure he's a double agent as it were and really on CIA side???
He was also acused of murdering his neighbour in Belize over a dog so maybe he's been blackmailed to avoid extradition?
what was that OSS SE chat clone called? I thought it was something like miaou.
10:53 PM
@ByteCommander Changing the subject I wrote set of scripts to automatically get sunrise and sunset times then adjust display brightness over transition periods to full bright and full dim based on user configuration file. Should that be added onto your question Serg answered with Python or become a new Q&A do you think?
aha, found it. dystroy.org/miaou
@WinEunuuchs2Unix better post a new qa, maybe linking the old. IMHO
I'll also be linking many other solutions already published plus Gnomes forthcoming color scale adjuster to more red at night in Gnome 3.2 I think it is.
I'm also still looking for an informative and trustworthy resource about your Vault7. Any links for me here?
@Seth that's what I just started reading 1min ago
Goodnight folks! :)
I would have thought everyone on the planet with a computer, cellphone or TV would have heard about CIA's Vault 7 by now
Geez 4 pm and still in pajama's all day... have to shower and buy stuff before close store at 5pm...bbl
Hello All. VTC this as unclear but after a comment from the OP it`s a dupe. regardless it should be deleted as it's not even a good signpost.... askubuntu.com/questions/892119/wired-ubuntu-problem
11:20 PM
Q: Both apt and yum will try to install a kernel upgrade when there is not enough space, and fail, leaving the latest kernel unbootable

marathonI've encountered this with apt on ubuntu and yum on centos 7. Coupled with many linux install guides stating "you only need a few hundred Mb for the /boot partition", this is a minor disaster. It's recoverable if you know what you're doing, but for someone who doesn't know which files in /b...

11:33 PM
Q: Removing Mac Partition After Installing Linux And Deleting Mac OS X

SIeighRight now Linux Ubuntu is on 21.4 GB of my 110 GB disk space according to Disk Usage Analyzer. While downloading Linux I clicked the option that, I thought, would put Linux on my entire disk space and not just a small partition. How is the simple way to put the remaining 90 GB of disk space into...

11:46 PM
I think I'm somewhat . . . ok , maybe a lot . . . limited in my degree
@Serg Why?
Hi @Rinzwind How are you?
@ElderGeek Well, you know that I'm electrical engineering student, right ? I was looking at job postings on linkedin just now and just making lists of things that is required form some jobs. PCI-e, USB, NAND flash , power supply design. And it hit me that I don't know anything about these. We touched on USB bus briefly in my microcontroller class, but . . . that's it . . .
So basically . . . I feel like I'm behind the curve
@Serg eh, a lot of job postings are stupid. HR departments don't know what they're talking about and basically ask for a miracle man in 50 different things.
so don't make a few job postings get you down.
11:56 PM
@Serg There will always be new technology that they didn't cover in class and @Seth is right about job postings being a wish list for a miracle man. If you know what you don't kow and know how to find out you know more than most. Keep your chin up!
@Seth I've heard about that, basically what is on the requirements is often an 'ideal' candidate. Just the closer I get to completing my degree the more it seems I've no idea about my major actually.
@ElderGeek Will do ! At least , I'm re-examining what I don't know, right ?
00:00 - 16:0016:00 - 00:00

« first day (2355 days earlier)      last day (1550 days later) »