« first day (420 days earlier)      last day (2155 days later) » 

5:00 PM
yikes, juju install 142 packages
among them x11-common. that can't be right
it's probably java or something. oh well.
I have 50 minutes
ubuntu@ip-10-12-15-185:~$ mkdir .juju
mkdir: cannot create directory `.juju': File exists
ubuntu@ip-10-12-15-185:~$ rm -rf .juju/u
ubuntu@ip-10-12-15-185:~$ juju bootstrap
2011-11-23 17:07:53,389 INFO Bootstrapping environment 'local' (type: local)...
2011-11-23 17:07:53,390 INFO Checking for required packages...
2011-11-23 17:07:54,030 INFO Starting networking...
Network default defined from /tmp/tmpYygdX9

error: Failed to start network default
error: internal error Network is already in use by interface virbr0
Oh, It doesent work there too?
It worked for me.
sudo add-apt-repository ppa:juju/pkgs
sudo apt-get update && sudo apt-get install juju charm-tools apt-cacher-ng zookeeper libvirt-bin lxc
This is important!
@OctavianDamiean Did that!
This is impossible. The bug fix for just that problem is in that PPA.
I'm getting the same error
5:14 PM
says "Network is already in use by interface virbr0"
could that have something to do with it running inside a virtual machine?
Log out and log back in.
right, forgot about that
I'll reboot for good measure
No need to.
amith@amith-desktop:~$ sudo apt-get install juju charm-tools apt-cacher-ng zookeeper libvirt-bin lxc
Reading package lists... Done
Building dependency tree
Reading state information... Done
apt-cacher-ng is already the newest version.
zookeeper is already the newest version.
libvirt-bin is already the newest version.
lxc is already the newest version.
charm-tools is already the newest version.
juju is already the newest version.
The following packages were automatically installed and are no longer required:
5:17 PM
the last message was this:
SSH authorized/public key not found.
2011-11-23 18:16:47,716 ERROR SSH authorized/public key not found.
it was very quick, about 20 seconds. now it says "environment is already bootstrapped"
@StefanoPalazzo That means you don't have an id_rsa.pub file
am I good to go ?
It works there....
@MarcoCeppi I do now
ran "ssh-keygen" after the (failed?) bootstrap
@OctavianDamiean Still doesent work
Run a juju destroy-environment
Then bootstrap again.
Still the same error?
@AmithKK Well you have a problem with your apt repositories apparently.
Try to fix that.
great, thanks marco & octavian
5:20 PM
@JorgeCastro cool thanks
just got a half day at work
actually, that was our editing frenzy iirc
5:22 PM
yeah, during the MythTV Import
Anyone familiar with gitweb here?
I'm trying to set it up, but it wont identify my repos.
Just told my LoCo about the charm school.
Hopefully I can get them to join.
Disregard-- problem solved. Apache permissions.
5:26 PM
Ads are much easier when you use inkscape, heh
I need someone to make an ubuntu app developer week one if someone is looking for something to do
what do I type after juju deploy --repository?
you need a charm
install charm tools
sorry, charm-tools
I think I've got all of that
juju deploy --repository=charms/oneiric/mysql/ mysql
gives me this error:
@StefanoPalazzo the repository is the charms/ folder
5:34 PM
DNS lookup failed: address 'store.juju.ubuntu.com' not found: [Errno -2] Name or service not known.
2011-11-23 18:33:20,549 ERROR DNS lookup failed: address 'store.juju.ubuntu.com' not found: [Errno -2] Name or service not known.
it'll pick distro and folder based on the charm name
juju deploy --repository . local:mysql
and you need to use local:mysql :)
from your charms dir.
5:34 PM
for 12.04 it will just be
so juju deploy --repository=charms/ local:mysql
juju deploy cs:mysql
that worked, thanks :)
ERROR Ambiguous relation 'mediawiki mysql'; could refer to: ...
this is really helpful
mediawiki mysql:db
Q: Ubuntu - My /var/wiki folder has gone missing. Is this a Linux issue?

hamlin11I implemented a few installations of mediawiki in a parent folder called: /var/wiki I was alerted this morning that the wikis are no longer working. Upon a little research, the /var/wiki folder is gone. Is there any Linux-based reason why this folder would be removed? If not, I'll look at ho...

5:37 PM
@MarcoCeppi hey, I got that same ambiguous relation error yesterday
yeah, it's because MySQL charm has two mysql interfaces, db and db-admin
So you need to tell it which interface to use, admin-db or just db
Dude, juju is so awesome.
sorry to keep asking these questions guys
status now says "pending", what do I need to do next?
@StefanoPalazzo You're done :)
It's waiting on provider to boot up the machines
then it'll run the charms
after a few minutes the status will change to either error out, or completion
if you have a big enough screen you could do this: watch -n 15 "juju status"
Can you answer this? Cannot move Screenlets in GNOME Shell http://askubuntu.com/questions/81184/cannot-move-screenlets-in-gnome-shell #gnomeshell
5:40 PM
how nice is that
thanks again
@MarcoCeppi ok so on the two interfaces, I wonder why I was getting those errors
(terminator -> ctrl+-, if you don't have a large screen)
[MySQL Charm]
        interface: mysql
        interface: mysql
So it doesn know which one you want to create a relationship for
Really what should happen, juju should see which interfaces the charm is requesting. Since mediawiki and thinkup don't have a db-admin interface requirement it should just use db and only show that message when there are two requirement interfaces with the same names
So everything works now?
5:45 PM
Stupid question. How long can it take until the status changes from pending?
I was about to ask that too :)
It depends on the provider
if it's ec2 it can take a little bit of time
For local?
A lot of time.
Oh, that's probably
5:46 PM
Q: How do I configure juju for local usage?

Jorge CastroI'm too cheap to pay for EC2, and I don't have enough servers to set up my own openstack, how do I configure juju to use Linux Containers (LXC) on something like my laptop?

local will be alot the first time
Dont know if anybody saw this yet, but its really neat. Graphical representation of sorting algorithms cs.uwaterloo.ca/~bwbecker/sortingDemo/index.html
this answers all my previous questions doh
5:46 PM
after it caches the stuff it'll be faster the 2nd time
How did I miss that question?
okay, in that case I'll have some dinner while juju is thinking. like a real sysadmin ;-)
status started!
New to chat and have a dumb question. I would to give a point for a good answer. How do I do that?
5:55 PM
If you have enough reputation you can up-vote an answer.
If it is your own question then you can also accept the correct answer.
Welcome to the chat by the way!
Thanks! It is my question which was edited.
Did I miss Ask Mark???
you have 41 rep, you should be able to vote up
@GeorgeEdison yeah this morning, I posted the logs
it's on there somewhere
Aw... I wanted to ask him about Wayland.
what do you want to know?
that one is easy
5:59 PM
If there will be a tech preview in 12.04.
yes 41 rep, but how to "vote up", I usually am not this dense...
you click the up arrow above the number
@GeorgeEdison there will be a tech preview
ok so am I the only one getting the relation error with thinkup/mysql?
@JorgeCastro What are you typing?
6:02 PM
juju add-relation thinkup mysql
try juju add-relation thinkup:db mysql:db
+1 @OctavianDamiean, though only juju add-relation thinkup mysql:db is needed
that did it
ugh, that's confusing
but it's working!
21 mins ago, by Marco Ceppi
Really what should happen, juju should see which interfaces the charm is requesting. Since mediawiki and thinkup don't have a db-admin interface requirement it should just use db and only show that message when there are two requirement interfaces with the same names
I think I may lodge that as a bug
@JorgeCastro Which one?
6:05 PM
the one octavian said to do
@MarcoCeppi You should. :)
but now I get an error with the mysql one
@AmithKK your email got hijacked too
I got alot farther this time!
@JorgeCastro Weird, it's saying the table already exists, as if the db-relation changed was triggered twice
Can you expose/try to visit the thinkup app?
6:12 PM
@StefanoPalazzo At which step are you right now?
@MarcoCeppi WORKS!
@JorgeCastro yeah, if you look db-relation-changed got executed twice
2011-11-23 18:03:37,209: hook.output@DEBUG: hook db-relation-changed exited, exit code 0.
2011-11-23 18:03:37,249: hook.executor@DEBUG: Hook complete: /var/lib/juju/units/thinkup-0/charm/hooks/db-relation-changed
2011-11-23 18:03:37,249: hook.scheduler@DEBUG: executing hook for mysql/0:modified
2011-11-23 18:03:37,250: unit.relation.lifecycle@DEBUG: Executing hook db-relation-changed
2011-11-23 18:03:37,250: hook.executor@DEBUG: Running hook: /var/lib/juju/units/thinkup-0/charm/hooks/db-relation-changed
Not really sure why.
It didn't do that for me though
Maybe it's because you got the ambiguity message, but something went through anyways?
It's a half day! Heading home
or I did the relation twice?
waiting on the mail from it now
@GeorgeEdison the postfix log shows it sent
so that looks good to go!
@JorgeCastro Did you deploy it locally?
6:22 PM
And you could just load it up in your browser?
Guys, another SSH problem! (sorry) ... I still have the two identical boxes - after changing the IP, SSH failed... I tried /etc/init.d/ssh stop then start, which didn't do a thing... I restarted the box and it fixed it. However, I am not just trying to get it to work, I am trying to learn Linux! So, for the other box, I would really like to fix it without turning it off and on again! Anyone know what I need to do?
@OctavianDamiean yep, just waiting on the account email
I wish upgrading a production server wasn't as hairy as it inevitably is.
On the plus side, it just downloaded 192MB of packages in like three seconds.
6:27 PM
And it's a shame I have to do it four times. I've neglected this 9.10 install long enough.
I guess if I leave it on 10.04 and wait another five months, I could LTS-hop...
@WilliamHilsum why use IPs? No DNS?
Nah, where's the fun in that. do-release-upgrade has a busy night ahead of it.
@JorgeCastro There may be DNS in the end, but, this is just a test server and I don't feel it is worth the trouble of setting something up whilst I am making so many changes... all it would mean is that if I need to change the IP in the future, I would have to also update a DNS record....
/me nods
I /think/ what you can do in this case
is ssh in
change the ip but keep the ssh session open
and then try to ssh in with the new ip
if that doesn't work then just restart ssh from within the session you kept open
Uhm, why don't you just use avahi for the hostname.local feature?
Wouldn't that make thing easier?
@WilliamHilsum Or is that a remote server?
6:38 PM
@JorgeCastro the moment I changed the IP, the session dropped - I can only connect in via esxi console
@OctavianDamiean If talking to me, I am not sure/never heard of that - but, this is a test server directly linked to a router that has uplink to the internet (in a DC) no DNS or any other machines on the network.. I am currently connecting in via ESX's console, but, I would rather use putty/ssh, but, that is giving me the issues! I know if I restart, it will work (as it did with the other machine) but, I am keen to get it working without restarting/learning how to fix it.
@MarcoCeppi: ok I set up ssh want to discuss webserver before setting it up, r u bit free?
Sorry, if talking to me about the avahi thing - no idea!.... the rest is about the other question about the server!
Never mind avahi wouldn't help you in that case.
6:56 PM
hello. I have an .iso file that I'd like to create in a usb driver. I trying to use the startup disk creator, but when I select the file it doesnt show in the source screen. I've also tryied UNetbootin, but looks like it writes the ubuntu partition, not the iso file I choosed.
any idea please?
hmm maybe a screenshot will help?
UNetbootin writes whatever ISO you select to the drive you select.
Octavian it wrote debian in my usb driver. I didnt choosed it. I've tested making the boot via usb and a debian screen showed up.

« first day (420 days earlier)      last day (2155 days later) »