« first day (3054 days earlier)      last day (2035 days later) » 

12:00 AM
@forest I've played around with stuff like caching, but not garbage collection.
GC helps reduce memory usage when done frequently but also eats up CPU.
Machine had 4 GB of RAM. I did not observe any real exhaustion of memory.
I assume you tried reinstalling the OS? Since naturally it can get slower.
(it was upgraded to Windows 10 from a retail license with a clean install, so there was very little in the way of junk)
I mean I only use Linux so I don't have gradual slowdowns.
12:02 AM
FWIW, that system may have been acceptable under Linux.
That's one reason I like Linux so much.
Works on pretty much anything, and so snappy.
I run openSUSE Leap 15.0 with KDE Plasma on a $230 netbook with an Apollo Lake Celeron and 2 GB of RAM.
I've run uCLinux on a Nintendo DS with 4 MiB RAM. :D
And despite this being one of the heaviest Linux base installs (both KDE Plasma and openSUSE itself are considered to be quite large), the system uses only about 500 MB on an empty desktop.
12:09 AM
!!/xkcd 327
@rahuldottech ROFL
12:40 AM
btw @Bob, the OVH rescue-64 image based on Debian jessie has built-in ZoL now :) and it's a reasonably modern version (probably 2018)
ZoL is pretty nice!
@JourneymanGeek what dumb things?
I've sortaaaa been considering one for college
(if I get into a decent college, that is)
The Fn-Ctrl key placement is still a deal breaker for me tho
1:07 AM
@rahuldottech superfish type things
Also I miss the old, sculpted keyboards
@allquixotic :D makes life much easier
1:27 AM
Stumbled upon this:
Aug 18 '17 at 16:44, by allquixotic
:D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D
1:50 AM
@allquixotic: The Matrix server just went down.
I rebooted my SP-128 instead of the MG-512
@forest Please do not abuse flags!
@bwDraco I thought the f-word was not permitted here. I got flagged when I said it.
I guess that was just a fluke? Or hypocrisy?
We're adults. We try to use common sense here. There was no reason to flag that.
We need a mod right now.
So... it's just me who is told off by ROs not to use the f-word, flagged, and kicked for it?
1:54 AM
No rush, I'm here
@bwDraco I don't think it's that urgent lol
@BenN, can you remove @allquixotic's suspension? That was clearly not flaggable.
@bwDraco Dude, I asked the same thing when I got auto-suspended...
I was told that the f-word was not permitted here. I think by Journey.
Yup, context is the thing here
1:55 AM
Was it directed at a specific person?
One moment please
If it was just an "oh crap" reaction not directed at a particular person, it's not really flaggable, unless the user was doing it in a gratuitous manner.
No, it was not. I said something like "f--- that, that's not fun".
I guess some are just too overreactive to curse words.
Well I was told by both a RO and Journey not to use the f-word, and that this room culture is such that you should flag it when you see it.
So then I flag it, and I get told, in bold letters, that I am abusing flags.
Is it just a certain time of day or when certain mods are on?
1:58 AM
I realize that there are mixed messages here regarding this issue. Our standard here is if it's not directed at a particular person or otherwise abusive, we don't flag it. We use common sense.
@allquixotic Unsuspended
It's more a thing of "please don't" but I think instant suspension for it is a little excessive
@BenN Thanks, though I've learned my lesson. The message is awfully clear. See you guys in Matrix.
Pattern and context and attitude are more important
@bwDraco So if I say "fuck that" or something similar without directing it at someone (or being rude, period), I should not be suspended again? Because it was irritating.
TBH, you should not have been suspended for that, either.
But I've been seeing a growing trend towards the misuse of spam/offensive flags lately...
1:59 AM
This was the very first time I've ever used the flag here.
And on a comment which I was told should be flagged.
I mean if it was really a misunderstanding, I get that.
I have never been flagged for the (few) times I've used the F-word here.
@JourneymanGeek tl;dr someone said fuck, me and apparently others flagged them, they got auto-suspended, then I was told I was abusing flags. Basically exactly what happened when I said "fuck", except I wasn't unsuspended nor was my flagger told off. So I'm just a little bitter at how it turned out.
@forest erm. You have been here long enough to know how we deal with things
@JourneymanGeek By flagging curse words is what I've seen.
2:01 AM
Then I suppose I was wrong. I'll keep in mind that curses are fine as long as they're not directed at someone in particular or otherwise rude.
4 mins ago, by bwDraco
I realize that there are mixed messages here regarding this issue. Our standard here is if it's not directed at a particular person or otherwise abusive, we don't flag it. We use common sense.
You have certainly seen people go Language!
It also doesn't mean we should just use profanity gratuitously.
@JourneymanGeek Well I saw myself get kicked for it and told curses are disallowed which is why I came to that conclusion. It must have just been a mistake.
2:03 AM
We give people a heads-up, and they correct it.
We deal with it the way adults do.
How many flaggers are required to auto-suspend?
1,462 results as of now. Most of these are not flaggable.
Well thanks for clearing it up anyway. Glad to know I misunderstood.
@forest see. If you're here primarily to cause trouble and swear because you got suspended once, we have a problem
If you slip up, a gentle reminder is how we do things
@JourneymanGeek I'm not here to cause trouble, nor am I here specifically to swear. I haven't been here for very long anyway.
2:08 AM
I'm not going to kick you for swearing. I'm going to kick you for causing too much drama on a Sunday morning.
Then I will clean up the un needed swearing
@allquixotic not sure what that was about but...
@JourneymanGeek I was just writing an apology when I was kicked. :(
Oh well. I'll try to avoid causing drama. I was just upset and overreacted.
Thank you
I am currently at the dog run and covered in mud to my knees so I apologise for the lack of nuace
Folks, just check your language. While we'd prefer that we not be so restrictive, unfortunately, there's been a shift in what other communities and SEI itself consider to be flaggable material, so some may overreact to innocuous use of profanity.
Yeah I understand. I'll keep unnecessary curses to a minimum.
(And will never direct it at anyone to cause offense)
Regardless, we try to deal with issues like adults. If a gentle reminder solves the problem, then that's all that's necessary. We do not use flags unless someone is actually being abusive and has not responded to lesser interventions.
2:16 AM
Got it. Thanks.
@allquixotic, it's still down.
The ground rules here have always been to deal with things like grown ups we deal with problems and we move on.
Moving on is important
Thanks for lending a hand, @JourneymanGeek and @BenN.
2:47 AM
...lol at the name:
Dec 6 at 8:07, by rahuldottech
@CanadianLuke lol, porkchat has a dark theme for chat which I use
(FYI, the first result returned from a Google search for "porkchat" is NSFW)
Jul 1 '17 at 12:55, by djsmiley2k
I just use porkchat (DO NOT GOOGLE IT, Ask @fredley for the link in bridge.)
Hmm... Porkchat contains functionality for the Teachers' Lounge room, which is restricted to moderators. Why is it enabled by default?
Oh, and @allquixotic, still having trouble with the Matrix server?
3:12 AM
(just testing Porkchat emoji functionality)
also, I'm glad to report we finally got all the mud off
@bwDraco ah - I switched to dark reader. Its not as shiny but a bit more universal
And yet it's still all hex to me :(
(trying to get @fredley's attention on The Bridge due to a bug I identified in the dark theme script)
in The Bridge, 54 secs ago, by bwDraco
@fredley, you're using an old version of jQuery which contains a known XSS vulnerability. As such, I'm going to have to disable the Porkchat extension for the time being.
While I did buy RGB add-ons for my desktop, I'm not the kind of person who demands total perfection when it to comes to aesthetics. It just needs to look reasonably good.
(read: Phanteks RGB light strips)
Perfect is dark unless you want it to be ;p
4:02 AM
I do actually like the idea of having dummy modules for memory to keep dust out tho
@allquixotic, something wrong with your server?
5 hours later…
9:09 AM
roota.cc down again (briefly-ish) while OVH's router migrates my IP subnets
Ah, that's why.
I was hoping it would be seamless, but it's taking in excess of several minutes... I have to assume it's automated, but some kind of script runs on their core routers
I have my full server migrated and booting and getting networked on its own on the new box, just waiting for my IPs and I can start to bring up containers!
lol. if this takes more than an hour I will ask them if they are physically mailing my /27 subnets from one datacenter to another :D
Louis has so much fun saying "Touchbar." in a friendly way, and then makes fun of the touchbar over and over
I'd give it a 3 out of 5. if I could buy the same computer with a physical Fn key row, I would, but in a few apps they use it really well /shrug
"Duke" is Louis's mentor who taught him what he needed to know to be really good at diagnostics
one of the subnets moved :)
9:25 AM
@allquixotic I guess the problem is they removed something people use for something 'different'
@JourneymanGeek I agree. I try really hard to like the system, and there's a lot to like about it. But if I'm being honest, it's just not great. But I'm one of those people who presses the FnLock key (on laptops that have it) and permanently keeps my F-keys in F1-F12 mode.
@allquixotic more or less
I'd rather Fn+F5/Fn+F7 to access brightness controls, for instance
my dream Macbook:
- change nothing about the screen
- add another 1 lb of GPU + cooling for GPU + required thickness, and go Nvidia (probably could get to a 1070 Max-Q)
- hardware F1-F12 keys
- Home/End/Insert/PgUp/PgDn in place of the huge speaker grills
- at least IP67 for the keyboard, and a little splash resistance for ingress from the fan grills
have Razer license the Force Touch Trackpad from Apple and put it (same size and feel and functionality) on an updated Razer Blade 15
same result, really, except I definitely prefer macOS and its lack of factory-issued spyware and Candy Crush bloatware (which now is part of the default Win10 experience except for Win10 Enterprise)
like seriously, Pay2Win Candy Crush mobile app style games being in your start menu out of the box on a Windows laptop that, depending on the config, you could pay $4k or $5k or more for? like the top end Surface Book 2, or a Clevo?!
I almost got myself suspended again but I think I'll just say it in Matrix once I bring up roota.cc
9:41 AM
@allquixotic i'm.kinda drooling over the new stealths
roota.cc Synapse server is up
And bigger screen on the same frame as my 11
9:58 AM
I'm having a brain fart. I forgot the cavil invocation prefix. it's !! right?
10:20 AM
@allquixotic I awoke on Sun, 16 Dec 2018 10:20:17 GMT (that's about 3 seconds ago), teleported 15 goats
@allquixotic help, afk, awsm, ban, color, convert, define, die, doge, domain, eval, export, findcommand, forget, forgetseen, github, google, hang, imdb, import, info, inhistory, jquery, learn, listcommands, listen, live, mdn, meme, moustache, mustache, norris, nudge, parse, refresh, spec, stat, stats, tell, timer, todo, unban, undo, unonebox, user, weather, wiki, xkcd, youtube, zalgo, !!!!!!!!!!!!!!!!!!!!!!!!!!!!!, 65wat, ;), ;p, \/s*, adminspotting, after5, ahh, ahhfire, apumpkin
areyoukidding, baaaaat, bababababat, bankerror, bankey, baroo, bearhello, beatingbloodoutofarockwithahalberd, b
that's what I get for migrating Cavil at 5 am
wtf Java exits
it's supposed to - I'm so dumb, I forgot
I read that as java exists
and nearly agreed heartily
10:23 AM
@allquixotic I awoke on Sun, 16 Dec 2018 10:23:26 GMT (that's about 21 seconds ago), teleported 92 goats
ok, good, so basically I only have a geckodriver process running (a native process) and a headless Firefox running, and the "host" Java process ends when it's done setting up the geckodriver by injecting the bot and logging in
and that's completely fine - one less thing to hog memory
geckodriver is written in Rust so it's pretty crazy efficient and (in theory) shouldn't memleak; it just serves as a parent process for FF and it isn't actually doing anything. then FF itself is pretty decent with only one tab open (especially since it's headless)
ok, so Cavil is up, roota.cc Matrix is up, my other stuff is up... I think we're good \o/
@allquixotic bit trickier but I really need to work out how to do systemd units for all that things.
@allquixotic iirc we kept the driver open before to give you a js repl
Probably might end up being some rep if I can ask the questions ;p
(for example how to get a systemd unit for my matrix install... unless I decide to risk taking it down, doing a package based install and hook it into the existing db, certs etc)
10:32 AM
@JourneymanGeek I need to figure out how to do systemd integration for my docker-compose file
(I mean, I've written a few simple units - my ttrss updater runs on one, as does a slightly dodgy service I need to keep running and will cough a lot of I mention)
one of these days I want to migrate to podman but idk if it supports docker-compose
need to learn RHEL8 things
I need to find an excuse/use case for docker at some point ._.
I have a few things that might be nice for but nothing essential
oh, it works perfect for Synapse
ya, but I have a perfectly good synapse install ;p
10:38 AM
I just created this, https://paste.fedoraproject.org/paste/Ht7cyEqVERYd6RHGf6cYcg then run `docker-compose up -d` to run/update. Then I have nginx set up separately (not inside Docker) with
proxy_pass http://localhost:8008;
proxy_read_timeout 90;
proxy_redirect http://localhost:8008 https://roota.cc;
omg, this guy has spent a ridiculous amount of effort getting virt-manager to compile/work on macOS -- unsung heroes of the community... github.com/jeffreywildman/homebrew-virt-manager -- seems to be compiling well so far
the problem with virt-manager is that it basically depends on Gnome to work (not literally Gnome, I don't think, but the platform it's built on - GDK/GTK3, dbus, libglib2, gobject, python3, gstreamer, spice, libvirt, sqlite, etc.)
@allquixotic I blame RH for that
they seem a bit overfond of tight integration
11:05 AM
@JourneymanGeek systemd is easy :P
muuuuuuuuuuch easier than init scripts
@Bob yeah but virtualenv and all that
for simple stuff, its a breeze
11:16 AM
@JourneymanGeek your first mistake was using virtualenv :P
but even that's not exactly hard
@Bob well, yeah, but its not annoying to restart manually
@JourneymanGeek eh I'd rather not have to manually restart some 20 odd services across different containers every time the host restarts
ya, hence me throwing things into systemd ;p
though I don't run containers.
12:16 PM
@Bob Hmm. After migrating my IPs and such, my LXD containers using macvlan work fine unmodified, but my KVM guests using macvtap (a different adapter) don't work. Hmmmm. Something with promiscuous mode? No idea
@JourneymanGeek If you've been getting upvotes on the swedish chef answer, this is why :P
@allquixotic o.O
I don't think I use macvlan nor macvtap
both my kvm and lxd guests are bridged
> (I use it every year with my computing class)
this is the most horrifying thing I have read about one of my answers
oh the question
then its fine lol
no upvotes there though
gah, no luck messing with network settings
12:24 PM
@allquixotic could be NIC-related
iirc macvlan is iffy that way
user image
12:37 PM
anyone here?
we're sleepiung
i should be sleeping too, but since we're both sleeping, computer question for you, or anyone
have this bizarre thing that happens to my computer, and maybe i'm just paranoid, but now it's getting annoying
and it's getting more frequent
when I'm on my computer doing random things, or not, kind of all over the place, my CPU will kick up into freak mode. sounds like it's calculating all the mysteries of the universe. then i'll open command prompt, and it will almost suddenly stop
12:41 PM
any ideas what's going on here?
all the percentage is coming from Chrome, I can see that in the brief moment before it all of the sudden dies out
souinds like a bitcoin miner on a page
@dm__ Vote to close"too broad"
very broad, I know. but it's evading me, I can't pin whatever the thing is down. got a tip to freeze the activity? why is it stopping once I open command?
Q: Tracking CPU and Memory usage per process

Eli BenderskyI suspect that one of my applications eats more CPU cycles than I want it to. The problem is - it happens in bursts, and just looking at the task manager doesn't help me as it shows immediate usage only. Is there a way (on Windows) to track the history of CPU & Memory usage for some process. E.g...

No idea.
12:51 PM
seems a good starting point
i'll run with it, thanks!
1:12 PM
Oh hai!
@rahuldottech Hmm.
> An HAI is an infection that develops as a result of medical care. This may occur in a hospital, outpatient surgery center, nursing home, rehabilitation facility, or while receiving wound care services. In order to develop an infection while receiving these services, bacteria must enter your body.
> A weird way of saying 'hi' in English.
It's from LOLCODE
@rahuldottech I don't want to learn lol code or leet speak or txt speak. I want people to type in a language that is understandable without consulting random dictionaries or performing google searches.
@DavidPostill so .. something other than English?
@DavidPostill It's that hard to realize that it's a greeting?
1:26 PM
@JourneymanGeek Most people in this room can understand English as written by the Queen :)
FWIW, I've been using it as a greeting in this room irregularly for a long time chat.stackexchange.com/search?q=hai&room=118
look at this stupid shit! i'm onto it now...
@rahuldottech Well I understand a little Japanese. So I got confused. I though you were saying yes for no obvious reason. Or maybe you were saying 2 or eldest brother/sister in Vietnamese?
@DavidPostill or... it was just a greeting
2:33 PM
@dm__ All you can really do is use the chrome task manager and/or close tabs until you isolate the one causing it.
Since it's internal to chrome you can only work with the tools chrome gives you
2:47 PM
thanks Bob, I'll try that. as you say, can only see the CPU spike like a bat outta hell, but nothing more
1 hour later…
4:29 PM
@rahuldottech with Synaptics trackpad technology from 2001 :/
Hello, deaf manufacturers! Trackpads have gotten better! ((((STEAL FROM APPLE!!!!))))
4:44 PM
@allquixotic I've actually never had any problems with modern synaptic touchpads
> Intel explained its approach in its technical note about Spectre mitigation, titled Speculative Execution Side Channel Mitigations. Instead of treating Spectre as a bug, the chip maker is offering Spectre protection as a feature.
5:02 PM
Q: macvtap libvirt guests have no network connectivity after server migration

allquixoticI have two dedicated servers hosted by OVH, an SP-128 and an MG-512. The hardware is similar (they are both Supermicro-based builds) but the SP-128 has a Xeon E5 Ivy Bridge and 1 Gbps Ethernet; the MG-512 has dual Xeon E5 Haswell and 10 Gbps Ethernet. I'm in the process of migrating everything f...

Help the cat! You know you want to help the cat!
5:21 PM
Beyond my knowledge of virtualisation networking
I'm sure the friendly and welcome folks at SF will keep you right tho
5:38 PM
packet captures outside/inside the vm's ?
@allquixotic IIRC the gateway for all guests on ovh is actually dependent on the server's main IP, not the failover IPs
so you'd need to update the gateway
@Bob I've tried updating the gateway to the server's main IP gateway to no avail; and that doesn't explain why the /27's .254 gateway still works for my LXD guests
at least that's the case for bridged networking
> To configure your virtual machines for internet access, you will need to know the gateway of your host machine (i.e. your Dedicated Server). The gateway address is made up of the first three octets of your server’s main IP address, with 254 as the last octect. For example, if your server’s main IP address is:


Your gateway address would therefore be:

yeah, I know, I adjusted the default gateway of the host, but in the LXD containers I'm using the /27 subnet's .254 as the default gateway, and it works
@allquixotic Also check the gateway config actually took, with ip add... IIRC on one server I had to use a post-up command to add the gateway rather than the raw interfaces config
5:46 PM
I tried the host's main IP's .254 for giggles in the Windows guest and it didn't help
@allquixotic ...I've never tried/been able to do that, but I think I only have a /28
I don't think you're ever supposed to use the failover's range for the gateway
all docs I've seen say to derive it from the host's IP
well it's the same failover range, just different IPs in the range, with LXD macvlan claiming, say,, netmask, gateway, and the KVM macvtap claiming, say, 1.2.3.**5**, netmask, gateway
worked that way on my old server!
can't think of a reason it would stop now after the IP ranges have been migrated
I changed the default gw before but just for giggles I'm rebooting after changing it now
yeah still can't ping the default gateway from the guest
also the macvtap devices are both bridged variety (not VEPA, passthru or private) on the old & new box
I think I'm just going to grep my entire rootfs for eno1 on the new box
1 hour later…
7:17 PM
@allquixotic Can't you set it so that you press Fn to access the media controls and other system controls? All of the Windows laptops I've had have this option.
@bwDraco the touchbar? pressing Fn brings up the function keys, yeah
Can this be configured somewhere in the system settings? On Windows systems, the F-keys are typically configured in the BIOS/UEFI setup; on your MacBook Pro, is there a similar setting in the system settings app?
seems to be in settings yea
I wonder if you can take a screenshot of the touchbar LOL
yep, it's literally a second monitor
7:54 PM
@allquixotic well what's the distro, lots of them have that /etc/networks ...
thanks redhat >_<
8:34 PM
@djsmiley2k Ubuntu 18.04; it's /etc/network/interfaces and I don't think it's from Red Hat, it's from Debian
on RHEL it's /etc/sysconfig/network-scripts or something
Some idiot in Manchester is ordering stuff online and has given my email address (he does have the same name as me). Now I have his address and phone number...
using his own card but your email?
I got an email receipt from someone once who ordered (using their own card) at Nordstrom
@allquixotic Yes.
I sent them an email:
>Hi There,

This is the real David Postill and the owner of the email address ██████████@gmail.com

This order is not mine. The address is not mine. The phone number is not mine.

You have just broken data protection regulations by sending me this other person's personal identifying information.

I suggest you change your account creation procedure to verify email addresses like most reputable businesses do so you don't make this mistake again.

8:57 PM
@allquixotic ah yeah that was the one I was directly thinking of.
9:25 PM
And they've opened a cat cafe near us
how long before someoen tries to nick a cat
Yeah, I saw that from Linus Media and was like wtf?
Nah, just the weekly news one
(welp, that was about the Surface Studio)
9:46 PM
@djsmiley2k its quite hard
you have to go through an airlock type thing
10:08 PM
oh, good
@DavidPostill someone did that with my email
k i'm still hungry :/
My PERSONAL email on my OWN domain
How do you manage to typo the whole thing? Or do you not care?
Welp. I have to survive till 19th evening on 500mb
10:15 PM
is that really thatr hartd?
10:38 PM
@djsmiley2k yes :p
11:14 PM
this is the most British thing I've watched in years @DavidPostill (and it involves an air drama @Bob)

« first day (3054 days earlier)      last day (2035 days later) »