« first day (1728 days earlier)      last day (852 days later) » 

1:12 AM
Is it just me or @wipet is trying to pretend to be popeye?
in the picture I mean :)
 
 
2 hours later…
2:57 AM
Would any of you lovely people happen to know why fc-match monospace would return a sans-serif font?
1
Q: Why are my monospace fonts behaving erratically?

Sean AllredI'm setting up an Arch box and I've installed Plasma 5 as my desktop environment. However, monospace fonts are behaving very erratically: Listed in the 'Fonts' prefpane, it displays fine. As part of a terminal emulator, it's fine. Firefox slants them something awful in some cases (see forum), ...

@ChristianHupfer Center right looks a little suspect to me…like he's hiding something…
 
 
5 hours later…
8:28 AM
Morning all
 
yo'
@JosephWright hi there!
 
@SeanAllred The great Bee Duck has always something to hide ;-)
3
 
 
1 hour later…
9:50 AM
Can somebody check page 98 of LaTeX for complete novices (v. 1.4 2012-09-25)? The codeblock to get the bib to the toc seems to be wrong.
 
@Johannes_B I don't know that book, I've no copy of it
 
@ChristianHupfer texdoc novices
 
@Johannes_B Ah, I thought, it's a non-free-book
\addcontentsline{toc}{chapter}{\bibname}
\begin{bibliography}{1}
@Johannes_B: You mean that \addcontentsline stuff?
 
@ChristianHupfer Yes. Shouldn't it be \begin{thebibliography}{1}?
 
@Johannes_B Unless there is bibliography as environment too, you're right
 
10:02 AM
@ChristianHupfer \bibliography{<nameOfDatabase>} I think there would be a clash here.
 
@Johannes_B Yes, I've forgotten the old bibtex style of \bibliography. However, \begin{bibliography} itself would be possible. But the error will follow later on, of course, when 1.bib is to opened ;-)
 
@ChristianHupfer I'll drop Nicola a note.
 
@Johannes_B Yes, do so.
 
@ChristianHupfer I got on the web site, to the bug tracker which lead me to the Report Typo interface where i could select the book, give the page and leave the note. That was a run :-)
 
10:19 AM
I'm considering awarding a bounty on this question. Can anyone think of a reason I shouldn't? Like, for example, that the question is unintelligible.
1
Q: Embedding version control information returns error when file is not under version control

Faheem MithaIn the following MWE, I am embedding version control information. For background on this, see Embedding Mercurial version control information in a TeX document. If the file in question is not under version control, then I get the following error. Foldmarks: no Head of first page (/usr/share/tex...

 
10:42 AM
@FaheemMitha I have tried the example, but as i don't know Mercurial i couldn't really handle the stuff. I can't remember, is this really related to scrlttr2 and works with article? If not, you can alter the MWE to draw some attention. Why would anybody need version control on a letter?
 
11:11 AM
The following is getting me a lot of Non-PDF special ignored messages in the terminal. I think this would be quite confusing for starters. Was it always like that?
\documentclass{article}
\usepackage{blindtext}
\usepackage{xcolor}%loads dvips.def
%\input{pdftex.def}
\begin{document}
\blinddocument
\end{document}
 
@Johannes_B why is it loading dvips with pdftex?
 
@DavidCarlisle So, this is not normal? Now idea.
 
@Johannes_B doesn't here
(/usr/local/texlive/2015/texmf-dist/tex/latex/pdftex-def/pdftex.def
 
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex 2015.7.10)  25 JUL 2015 13:13
entering extended mode
 restricted \write18 enabled.
 %&-line parsing enabled.
**drivertest.tex
(./drivertest.tex
LaTeX2e <2015/01/01> patch level 2
Babel <3.9l> and hyphenation patterns for 79 languages loaded.
(./article.cls
Document Class: article 1995/11/30 v1.3p Standard LaTeX document class
(./size10.clo
File: size10.clo 1995/11/30 v1.3p Standard LaTeX file (size option)
 
@Johannes_B ^^^^
 
11:14 AM
Wait, why is documenclass that old?
 
@Johannes_B ` (./color.cfg)` <<<<<<<<<<<<<<<<<<<<<<<<
 
I think i am in the matrix
 
@Johannes_B scrlttr2 is not really required, that is true. At least, I don't think so. Would using article make a difference? And why wouldn't one use version control on a letter?
 
@Johannes_B why have you got a color.cfg in the current directory...
@Johannes_B because you are using tl 2013 not tl 2015
 
@DavidCarlisle Stuff like that happens, when somebody attaches an MWE instead of just posting the code, which will get to my Downloads folder which is full of crap like that, including and old article.cls and an old color package.
@DavidCarlisle I am running 2015, see LaTeX2e <2015/01/01> patch level 2
 
11:18 AM
@Johannes_B not really, your input tree has 2013 first: see /usr/local/texlive/2013/texmf-dist/tex/latex/tools/xspace.sty
 
Moved the file to the freaking place where it belongs and it works just fine. I didn't notice on my own, thanks @DavidCarlisle
@DavidCarlisle I updated instead of doing a fresh install.
 
@Johannes_B you can't update from one year to the next
 
Jun 13 at 20:26, by Johannes_B
Guys, i just did tlmgr update --self and i am now updating 284 package of my TL2014, which i guess will be a TL 2015. Can anybody confirm that this really works?
Feb 19 at 22:03, by Johannes_B
Ehem, did i miss something? Running xii.tex i noticed, that the log says i am running TL 2014. Did the tlmgr update of TL2013, which was strange anyway, upgrade to 2014? Is this possible now? Did i miss some note?
 
@Johannes_B odd, I thought updating in an old tl just gave you an error saying updates no longer possible, you mean if you use --self it switches to an in place update?
 
@DavidCarlisle I was confused as well. I used the update with TL 13 to get the KOMA-updates from an extra repo. One day, tlmgr said it wanted to update itself and doing an update again, it updated about 500 packages and i suddenly had TL14.
@Werner You sometimes need an extra pair of eyes. See my similar problem above. :-)
 
11:34 AM
I used code from this answer tex.stackexchange.com/questions/73104/… (because I want that numbering of section be 1, 2, 3 and not 1.1, 1.2, 1.3 (for first chapter, for example)), but now I have problem with spacing (it's too much white space aroun 1, 2, ...). See picture
Also, I use egreg code from here tex.stackexchange.com/a/39158/26374 (for that Глава 1, ... (=Chapter (eng))
 
12:13 PM
@JosephWright A question regarding l3keys, paths and subgroups. I was playing a bit with the idea of redirecting all keys on a subgroup of one module to setting the keys of another module (not sure that in itself is good idea, but…). I found two ways where with both of which setting \keys_set:nn {moduleA/moduleB} { test = xxx } works while \keys_set:nn {moduleA} { moduleB/test = xxx } fails. Is this expected?
\documentclass{article}
\usepackage{expl3}

\begin{document}

\ExplSyntaxOn
% idea 1:
\keys_define:nn {moduleA}
  {
    moduleB .choice: ,
    moduleB / unknown .code:n =
      \keys_set:no {moduleB} { \l_keys_key_tl = #1 }
  }

\keys_define:nn {moduleB} { test .code:n = `#1' }

% test:
\keys_set:nn {moduleA/moduleB} { test = xxx } \par %% OK

\keys_set:nn {moduleA} { moduleB/test = xxx } \par %% error key-unknown

\hrulefill \par

% idea 2:
\keys_define:nn {moduleC/moduleB}
  { unknown .code:n = \keys_set:no {moduleB} { \l_keys_key_tl = #1 } }
 
 
2 hours later…
1:51 PM
@ChristianHupfer we do? :) I haven't heard this before…
 
2:24 PM
lalalalalalalalalalala
 
Whistle whistle whistle Meine Oma fährt im Hühnerstall Motorrad! Whistle whistle whistle
 
just put on Supertramp's Crime Of The Century. I haven't listened to this album for ages!
 
2:46 PM
I am a bee. :)
 
@PauloCereda ducks, bees, walruses – this chat room is a whole zoo :p
 
 
1 hour later…
3:59 PM
@clemens :)
 
@clemens I'll take a look
 
4:27 PM
@JosephWright as far as I can see lualatex doesn't honour %&luatex on first line, I wonder if that's a bug or if the filename quoting callback is interfereing
 
@DavidCarlisle I'd noticed that (been out cycling but did a quick test before we went)
@DavidCarlisle LuaTeX has that weird behaviour/bug with trying to treat a command line argument (file name) as macros too: may be related
@DavidCarlisle Report?
 
@JosephWright I was just reading the luatex manual, I don't think it says it works, and only thing that does describe it is web2c manual which doesn't really apply. so it might be feature request rather than bug report.
 
@DavidCarlisle luatex --help and lualatex --help on TL'15 do list it, so ...
@DavidCarlisle LuaTeX manual page 30
 
4:46 PM
@JosephWright that has commandline switches but not first line of file does it?
 
@DavidCarlisle No but it says it works as in pdfTeX and moreover if the option is there then presumably it should then read the line!
 
@JosephWright ah the parse-first-line one OK, agreed.
@JosephWright I'll mail the list:-)
 
@DavidCarlisle Hans must love us
 
@JosephWright he should be glad to have more users:-)
 
5:08 PM
@DavidCarlisle :)
 
5:41 PM
@clemens I think I see what might be up
 
@JosephWright Aliens?
 
@PauloCereda :-)
 
@JosephWright :)
@Joseph: I'm getting involved in a lot of things recently. Help!
 
Joseph Wright has added an event to this room's schedule.
 
@PauloCereda Welcome to my world
 
5:52 PM
@JosephWright :)
@Joseph: oh I was gonna tell you some insider news, but you are offline. :P
 
@PauloCereda 30 seconds
 
@JosephWright <3
 
 
3 hours later…
yo'
8:43 PM
@egreg may not be rep capped today! :) @David it's your opportunity! :D
 
9:21 PM
@yo' I may not be also tomorrow, because I'll be traveling. By the way, walking in Prague is even more fun than answering questions at TeX.SX!
 
yo'
@egreg indeed!
 
9:45 PM
Can anyone suggest what to do here?
\documentclass{article}
\usepackage{polynomial}

\begin{document}

\def \a{-3}
\def\b{-2}
\def \c{-4}
\[
\polynomial{\a,\b,\c}\quad\polynomial{-3,-2,-4}
\]
\end{document}
In the first case, the result appears as -3+-2x+-4x^2 (additional plus signs in fron ot negative values) instead of -3-2x-4x^2 produced with the second \polynomial. It's an expansion problem, but I couldn't fix it.
 
10:06 PM
@GonzaloMedina Easy :-)
 
What about \edef\next{\noexpand\polynomial{\a,\b,\c}}\next?
 
@StephanLehmke Exactly
@StephanLehmke Of course, assumes that \a, \b and \c are fully expandable
 
It seems \polynomial would assume this anyway, otherwise use \protected@edef.
 
@StephanLehmke Yes, in this case a pretty safe assumption
 
@JosephWright I swear I tried what you suggested in your answer, but maybe I wasn't doing things in the right order. Thanks! Green tick for you :-)
@StephanLehmke Thanks also!
@JosephWright @StephanLehmke I forgot to mention that this will go inside \caption, so using just this won't work. Somethings need now to be protected and I am lost in a sea of \expandafters. Perhaps there's a simpler approach in this case?
 
10:36 PM
@JosephWright Apparently I talked too soon about the green tick going to you :( I'll wait some more time to see what other solutions appear.
 

« first day (1728 days earlier)      last day (852 days later) »