« first day (1419 days earlier)      last day (2485 days later) » 

8:34 AM
@Braiam maybe, but still surprising.
But i don't pay much attention to contrib.
 
Hello All
I am new to linux
and installing soa on rhel 5
64 bit for that I need to install glibc-devel-2.5-49.x86_64.rpm and glibc-devel-2.5-24.i386.rpm
but while installing both rpms are conflicting with each other
can you tell me a command or something using which I can install both the rpms?
please help me on this
 
@Chaitanya Of course they do. They're slightly different versions of the same package. Why do you want to install both of them?
 
Hi Faheem thanks for reply actually both of them are required in order to continue the installation of SOA
:(
please check the image and the failure issue
it says that both of them are required
I tried uninstalling one and installing the other one in that case the prerequisites satisfies for the installed one but fails for the uninstalled rpm.
I also have tried force installation but it is not getting installed
 
9:24 AM
@Chaitanya Oh, I see. They are for different archs. This seems like a reasonably concrete question. Ask this as a question on the site.
I don't use RPM based systems, so have no idea, sorry.
Oh, and if you want someone to be notified of your comment, prefix the persons name/nick with @.
 
@Faheem thanks for the same :) I have posted the same on the site but still not got any answer for the same :)
 
 
4 hours later…
1:50 PM
@derobert version of letter online: wiki.debian.org/DebianIndia/MiniDebConfHostLetter
 
gcc 4.9 is so... colorful.
 
slm
@casey - it only took 20 years
 
2:16 PM
but boy does it make compiler output piped into a logfile ugly
-fno-diagnostics-color is now added to my system-wide build config just for that reason
for building out of gentoo's portage that is
my next glorious bit of time wasting is going to be turning on LTO and recompiling the whole system.
 
slm
@casey - I think the term you're looking for is called progress 8-)
 
and Charter has just sent me another AUP violation, this time claiming "port scanning" has violated their "no hacking" clause. Lets see if this time they can provide me with any shred of evidence to back assertion that up.
 
slm
I have Time Warner which is like the wild west
which is fine by me
waiting to see if comcast merger goes through.
 
@slm It is progress only if it works :) I made a run at that when I first installed GCC 4.7 but the results were not great. Not everything would build with LTO and it was a hassle flagging those packages to not use LTO and I was getting some intermittent segfaults all over the place. I reverted to everything not using LTO
but it must work better in 4.9.1? right? :)
 
slm
It just has-ta
You know why we say that, right?
 
2:28 PM
@slm last time I called them they said "Oh, we just send this notices to let you know to take a look at your stuff. We can't provide any examples or information that might help you understand what we detected, and no we can't tell you what we detected. You should just, maybe, download a virus scanner."
 
slm
The rest of that phrase is this. It just has to work better in X, right? ... Because if it didn't I"m going to kill someone..
 
:)
 
slm
what a load of crap
 
Just switching to gcc 4.9 was a pain. I had to upgrade to the unstable version of some packages just to get them to compile
 
slm
sounds about right
 
2:30 PM
@slm yea, and I'm not anticipating any better on my next call I'm about to make
 
slm
At my previous job we dealt a lot with code that was compiled on Visual Studio and had to work around both
 
I bet that was fun...
 
slm
it was fun...after you figured the problem(s out
 
My fun in that regard usually is trying to get gfortran and ifort to agree that some bit of Fortran is compilable.
ifort is very particular and sticks much closer the the standard than gfortran does
 
slm
my last run it w/ fortran was helping a mechanical engineer use the intel compiler (I can't remember for sure now).
 
2:33 PM
@slm If you want real fun, find some C code that uses C99 language features and try to get MSVC to take it
 
slm
We were dealing with that too at my old job
gave up
 
iirc MSVC only speaks C89 and basically abandoned updating the C compiler in favor of the c++ compiler
 
slm
the good thing in the C world is that there are many choices so you can choose your own adventure with mixing and matching libraries to solve X
 
my favorite issues with taking code someone wrote in MSVC and trying to port it is the littering of stdecl, fastcall, dllimport, dllexport and all of the other junk that compiler accepts :)
 
slm
The dev I worked with was very adept at moving around these sorts of issues, he wasn't as aware of using gcc so that's where I fit in
 
2:44 PM
My last dev job was porting code from VMS to Windows while surrounded by c# people who were mystified by my use of unmanged code.
 
slm
2:54 PM
Guess this stackathlon says everything you need to know about Gilles
See all the ppl on that list?
 
@casey how so?
 
3:11 PM
@casey Is link time optimization new in 4.9?
 
@derobert Oh, that one. Thought you were talking about a different comment.
 
@FaheemMitha LTO has been in since 4.6 or 4.7
 
No apparently lto was around earlier.
@casey Reading the entry now, but still unclear what it is good for.
 
@FaheemMitha color diagnostic messages
 
3:13 PM
And the color thing, what is that for? Error?
@casey Ah, do you add a flag to enable that? Was going to look into it.
@derobert I'm also peeved about not getting to go to the Mercurial Sprint. Happening now in Munich.
@casey unmanged?
 
@casey it should detect whenever it's writing to a log file
 
@casey Helpful. Did you tell them that you run a sane operating system, i.e. Linux, and don't need no stinking virus scanner?
 
@FaheemMitha You don't get to complain unless @strugee is going to that one too... Simultaneously with debconf.
 
@derobert That would be quite a trick for a 15 year old. Flying cross-continent solo. Even Mozart didn't manage that.
 
@FaheemMitha Nah, Mozart probably did it at 8. Well, would have, had he not been so busy with the piano that he didn't have time to invent airplanes.
 
3:19 PM
Plus @strugee might need superpowers to be in two continents simultaneously. Not sure exactly when Debconf is, but it is like now, afaik.
@derobert :-)
 
@FaheemMitha Aug 23-31 debconf14.debconf.org
 
@Braiam the output from gentoo's portage is tee'd normally as it goes to screen and a log, and the leg definitely gets the color escapes. Even when I suppress the screen output the log gets color, but I'm not sure how portage is calling the compiler in that specific case
 
A teleport could attend Debconf and the mercurial sprint simultaneously, no sweat.
 
@FaheemMitha that violates the space-time rule: the same object can't be at two places at the same time
 
@derobert Right, so now. So, the only person who could attend both would be Nightcrawler or someone like that. Though I think Nightcrawler can only teleport short distances.
 
3:21 PM
@FaheemMitha lto is just an optimizer step at link time. Normal optimization is done in the compile step but the linker can do additional things like eliminate dead code and various other things that aren't known at compile time
 
@FaheemMitha in OldWOD, that was a mere Correspondence 4 effect.
I think. Maybe it was 5.
 
@Braiam Well, not exactly simultaneously. He'd have to jump back and forth. Might get a little confusing.
@derobert huh?
 
But I think 5 was to make DebConf and Mercurial in the same place.
 
@derobert Not following. At all.
 
@FaheemMitha World of Darkness, tabletop roleplaying system
 
3:22 PM
@derobert Oh, I thought it might be a RPG.
When people start talking apparent gibberish here, it is often a RPG.
2
@casey does this have any speed advantage? and if so, would be just at the linker step?
 
s/a RPG/an RPG/ ... or do you actually have some weird way of saying RPG, other than saying each letter?
 
@derobert Dunno. It's a reflex. I don't really know English. I just intuit it.
I assume "a" is correct. "An" before a vowel, right?
And no, I just say each letter.
It's English that's weird, not me.
 
@FaheemMitha not sure on speed, but there is a size advantage. My newest attempt at turning it on is to see what, if any, difference it makes and what breaks. I'm always looking for ways to break my system :) I survived the transitions to systemd and KF5/plasma5, so this is a logical next step.
 
/me disawows all responsibility for the weirdness of the English language.
 
@FaheemMitha A vowel sound.
@FaheemMitha English is definitely weird.
 
3:26 PM
@casey You were enabling it to build your system? Are you nuts? :-)
 
R sounds like ARE (ARRRR if you are a pirate), so it gets the "an"
 
@casey Ok, so "an" was correct, then.
 
@FaheemMitha add the linker flags to my build conf and run "emerge -e world" which rebuilds everything
I already did one recently when I setup gcc 4.9.1
 
My instincts usually are, but then I think about it, and correct it to something wrong.
 
Yep. You get weird ones. "A SQL database" is correct if you say it see-quel. "An SQL database" if you say it "ess-que-ell"
 
3:27 PM
mostly because my various fortran bindings really don't appreciate a mix of versions (fortran mod files are not ABI compatible across .x releases)
 
@casey Yes, I'm familar with how Gentoo works. Still a bit, um, brave.
 
@FaheemMitha nah, juts time consuming. But I let it run overnight and its done in the morning
 
Debian sensibly does the safe think. I don't appreciate broken systems. Life is hard enough.
@casey So you enabled LTO and your system is still running?
 
Nothing will stop working as a result. If something fails to build it isn't merged into the system and so the old installation is still there to use.
@FaheemMitha it is not enabled currently. I'll tackle that tonight
 
@casey But then you get a mix of things with different compiler flags, and that doesn't cause any problems?
@casey Oh
 
3:30 PM
@FaheemMitha nope.
 
@casey so, to enable color error messages in gcc, what do you do?
 
Fortran mod files are the one thing that suffers, but object code is ABI compatible for all of 4.x iirc
@FaheemMitha nothing? I had to to add a flag to turn them off
 
@casey Huh. Don't see it here (with 4.9.0). Will check again.
stackathlon.com/superprogrammers.html <- Further evidence that Gilles is a bot. Is that really a one entry list?
 
@FaheemMitha 1 out 5 for me :(
 
@Braiam Only 4 to go. You still want to be a gilles when you grow up?
 
3:55 PM
Charter was a bit more helpful this time. They gave me a time and date that caused the flag and in my logs I found a massive brute force attempt at my mail server and via ssh (nothing successful of course) so I told them their "portscan" detection was me being attacked and they closed the ticket.
 
@casey Charter is some ISP?
 
@casey fail...
 
@Braiam yep, but at least that suggests they are only inspecting IP headers and not doing deeper scans
and probably only detecting my responses and not the incoming connections
as the TCP SYN/ACK outgoing to a handful of IPs on 100's of ports (because of the 100's of connections with random source ports) might look like a portscan
I basically just told them "I can't stop people from trying to connect, but they aren't getting anywhere by trying" and that satisfied them as long as "I can maintain my security"
 
...
 
4:23 PM
@casey Sounds like you might want to move ssh to a different port. If only to save on CPU time...
 
@derobert That worked for me here. Moving to 33 drops brute force ssh attempts down to zero.
 
@derobert most of the attempts were on smtp and that box does nothing but exchange my mail most of the time so I won't miss the cycles.
 
i think since i reinstalled i'm using 22 again, though. maybe i should switch it back.
 
bad @casey, bad! Think about all that energy wasted in those wasted cycles
 
The real fun is on my workstation logs, which I should change. I forward 23 into my workstation and ssh listens there and on 22, so I get a lot of ssh connection errors when telnet sessions are attempted :)
 
4:33 PM
Is running on port 33 for ssh a good idea? Opinions?
 
slm
usually you'll see ppl move it to 2022. I don't think it's worth the trouble, IMO
a port scanner in 10seconds can tell you what's there though
obscurity != security
 
fail2ban FTW!
 
slm
exactly!!!
 
cc @casey
 
@slm Are you replying to me?
 
slm
4:36 PM
fail2ban is like putting a meter on a water pipe
@FaheemMitha - yes sorry forgot to @ you
 
@slm exactly. I didn't move it to for either, just so I could forward ssh into my server and my workstation
 
Actually, I don't seem to be seeing any port attacks right now.
So I think maybe my router is blocking the port.
I guess I could check by trying to ssh from outside, or just doing a portscan. nmap does a port scan, right?
 
slm
@FaheemMitha - yup
 
ssh password attacks, that is
@slm yup to the nmap doing a port scan?
 
slm
@FaheemMitha - if you only allow key auth then password attacks aren't your prob
@FaheemMitha - yup nmap. It can fairly accurately tell you the OS, so hiding stuff on different ports is a fools errand
 
4:37 PM
@slm I allow ssh auth, but I don't typically ssh into this box
password auth, sorry
 
slm
I would just shut off password auth, esp. if you control all the devices that will be coming and going over that SSH, why leave it open?
 
@Braiam can Fail2ban handle updating iptables rules on a machine that isn't the one running the servers?
The server with smtp/ssh isn't internet facing, it just has ports forwarded from a router and if I'm going to block addresses, I'd rather do it there
if so, that'll be a project when I replace the crappy netgear router with my utilite ARM box. someday... someday
 
slm
one of the A's shows how to do service detection w/ nmap here
4
Q: Figure out non standard ssh port

user40089I have this server that is configured to use another port instead of 22 for ssh, How may I figure out which port number it is? Thanks for any ideas!

 
0
Q: Have fail2ban client and server on different machines

Martin BeydonI was wondering if it was possible to have fail2ban clients on different machines and have a server on one machine communicating with all the clients? Here's my situation: I have 4 servers and I'm using fail2ban to protect them. For now I have one client and one server installed per machine. I w...

 
@slm is there an easy way to switch of ssh auth?
 
4:52 PM
@FaheemMitha yeah, you take password auth and pam auth out of sshd_config
 
@derobert do you need to take both out?
 
PasswordAuthentication no
ChallengeResponseAuthentication no
I think that's the two you need
Or you can do AuthenticationMethods publickey in newer versions, I think.
 
5:07 PM
hi
How to delete some matched lines through perl?
and also how to use DOTALL modifier in the perl one-liner command?
 
@derobert ok, thanks. And you agree with slm that that is a reasonable thing to do?
 
@derobert Debian already appears to default to ChallengeResponseAuthentication no
@derobert I don't see this in my sshd_config.
OpenSSH_6.0p1 Debian-4+deb7u2, OpenSSL 1.0.1e 11 Feb 2013
 
@FaheemMitha I have password auth turned off on all my Internet-facing systems.
 
@derobert ok. see followup comments as well.
changed to PasswordAuthentication no
Don't see what else I need to do.
 
5:20 PM
@FaheemMitha That's probably all, then.
Well, you have to restart/reload sshd of course. And then test.
 
5:58 PM
@derobert Pretty much everything is turned off at the router level, I just checked.
 
6:57 PM
@StéphaneChazelas: Are you there?
 
7:20 PM
@Gnouc I'm not far
 
G-man said that in early version of csh
( "==" == "" ) causes a syntax error
Can you confirm that?
I only have bsd-csh and tcsh to check
both seems work
 
Don't know.
if ( "$a" == "" ) won't work if $a contain newline characters though
you'd need if ( $a:q == "" )
 
I remember you have said that before, but "$a" works in both bsd-csh and tcsh
I'm going to update my answer :)
 
7:43 PM
Try a=$'a\nb' csh -c 'if ( $a == "" ) echo yes'
On Solaris 10:
$ a=== csh -c 'if ( $a == "" ) echo yes'
if: Expression syntax
$ a=== csh -c 'if ( $a:q == "" ) echo yes'
$
$ a=== csh -c 'if ( "$a" == "" ) echo yes'
$
(same with csh and tcsh on Debian)
 
I also use Debian, got this after testing.
 
BTW:
$ a=' ' tcsh -c 'if ( $a == "" ) echo yes'
yes
 
Yes, I also mention in my answer about this
 
 
2 hours later…
9:40 PM
Three duplicates. Which one to keep?
3
Q: Meaning of different tokens in a font config string

Khaja MinhajuddinI have seen lines like the one below, in a number of config files (xmobar has one of these and dmenu too has this) '-*-fixed-*-*-*-*-18-*-*-*-*-*-*-*' What is the meaning of each token which is seperated by a hyphen ('-')? Where can I see a list of fonts which I can use in these configs? Th...

1
Q: .Xresources font names

user001Many references describing the manipulation of bitmap font face and size for xterm via the ~/.Xresources config file suggest the use of an entry like XTerm.VT100.font: -*-fixed-*-*-*-100-*-*-*-*-*-*-*. I have wondered what is the purpose of the -* characters and whether there is any logic to thei...

2
Q: what does *-*-c-*-*-* mean in a font-setting

sineI often see Fonts being set like this: (e.g. in dmenu or bar-ain't-recursive) -*-terminus-medium-r-normal-*-14-*-*-*-c-*-*-* what does these *-c*-* sign mean? I really don't get it...

 
 
2 hours later…
11:41 PM
@Gilles I like that title
 
agreed
 

« first day (1419 days earlier)      last day (2485 days later) »