« first day (1350 days earlier)      last day (2729 days later) » 
00:00 - 20:0020:00 - 00:00

12:00 AM
@Gilles for extra credit, do it without editing any message
Hey people. Some basic command to display an input field and send it to standard output when you press Enter?
echo | ?
@Rojo what do you mean by “display an input field”? Do you want to show a GUI window?
Or a prompt “what is your name? ” in a terminal?
To send input to stdout, cat will do. Or head -n 1 if you only want one line.
If you want to read the input in a shell variable, though, that's IFS= read -r line; printf 'You entered: %s\n' "$line"
@Gilles A GUI window
@Rojo zenity
12:03 AM
@Gilles The most basic input field. Just a rectangle
@Rojo zenity
@Braiam Greeaat!
@Gilles Thanks! :)
Zenity is free software and a cross-platform program that allows the execution of GTK+ dialog boxes in command-line and shell scripts. Description Like tools such as whiptail and dialog, zenity allows for easy creation of GUIs, though it has fewer features than more complex GUI creation tools. Cross-platform compatibility , Zenity is available for Linux, BSD and Windows. GTK+, the library on which Zenity is based, is also available for Mac OS X, so it should be possible to port Zenity to this platform. Zenity does not possess any built-in scripting capabilities and it must, there...
@Gilles - it's unfortunate that it's escalated to this for you.
@Gilles Worked perfectly
Now this next one is probably worth a question on the site. I am trying to run a program (pidgin) as another user from a terminal. It works if I use su and then run it, but it doesn't if I sudo -u theuser pidgin
I am trying to find out what could be the difference between the two. Adding -H doesn't help. Am I missing anything obvious?
(I am checking if the environment variables are different now. They seem to be)
(yes. using -E fixed that, but still doesn't work. I get "No protocol specified" and some "cannot find display" errors
12:19 AM
@Rojo - sounds like the other user doesn't have permissions to display to the user that owns the desktop
@slm, you might be doing the same job in near future :)
I mean calming down people and stuffs :)
@Ramesh 8-)
@slm Ohh, that makes sense
A user owns the display. Makes sense
@Rojo - to get around it as the user that owns the desktop, xhost +
there are better ways to do it but that should fix it, temporarily
If the led in external HDD is not blinking, does that mean the transfer is not happening?
12:32 AM
@slm I owe you one. xhost +local:otherUser fixed it
@Rojo - no prob. glad to help.
WTH is "Craft CMS"?
@Braiam one of several CMS whose existence I learned when they launched an SE site
1:03 AM
@Gilles you are in the same boat, huh
Is there any advantage of rsync rather than copy pasting the folder?
I mean if we just copy paste folders, will there be issues with permissions later?
1:37 AM
depends what is the final goal @Ramesh
and the context of the situation
@Braiam, I copy data from external HDD to the newly installed machine.
I was lazy to modify the script and just copy pasted from GUI. After starting the process, I realized there may be permission issues later on.
So in this case, will the permissions be preserved?
@Ramesh did you preserved them in first place?
@Braiam, yeah. I did it.
@Ramesh how?
@Braiam, using rsync script.
1:43 AM
using rsync or using an script that uses rsync?
well, a script that uses rsync.
I generally always just use rsync
6 hours later…
7:31 AM
unix.stackexchange.com/questions/138214/… ... wow, probably should be closed as too broad, less than 20m old, already several incorrect answers.
Found a duplicate for it instead.
8:11 AM
8:38 AM
Is there a better question than unix.stackexchange.com/questions/49299/… to explain the difference between a file and a name?
9:17 AM
@derobert inodes can't be deleted or created unless you create a new filesystem right? It is only the links to the inodes that can be deleted and the inode that can be marked as available or free or whatever so it can be reused to store new data.
@terdon Yeah. At least on ext2/3/4, inodes aren't actually deleted, just marked free
OK, that's what I thought. I was wondering about one of the answers in the Q you posted earlier. Apart from stating that inodes are deleted and created it seems correct to me now.
Yeah. I was hoping there is a good conceptual explanation of it somewhere on the site, but couldn't find anything better than the minecraft jars question
2 hours later…
11:08 AM
@terdon - While I don't know about here, the following explains that the inode is actually the file whereas the name is the listing in a dentry - a directory entry. The purpose is to facilitate hardlinks.
11:30 AM
@mikeserv Yeah, exactly.
11:48 AM
@terdon - I was just awarded my first bounty. I actually didn't think it was possible because I wikied the answer, but I guess the bounty is still mine. Didn't care for the points - but actually the milestone is kinda cool.
A: explanation on chown(1) POSIX spec

mikeservThe Microsoft Interix Unix subsystem (now retired) for its NT kernel dealt a little differently with user and group permissions than some others do: User and group information is stored in the Security Access database. Both users and groups are stored in the same database, but group and user ...

@mikeserv Nice, well done!
It was kind of cool to include a decade-old Stephane link in answer to a Stephane question, too. That guy is going down in history.
I just posted a wrong answer and was correctly called out on it on AU. The user who corrected me cited my own bleedin answer (another one) as evidence. sigh.
Oh what tangled webs we weave when first we conspire to achieve...
@derobert does
A: How is it possible to do a live update while a program is running?

psimonThe upgrade can be run while the program runs, but the running program you see is actually the old version of it. The old binary remains on the disk until you close the program. Explanation: on Linux systems, a file is just an inode, which can have several links to it. Eg. the /bin/bash you see ...

merit an upvote? I see you've commented extensively on it, hence asking.
11:59 AM
merited mine...
12:12 PM
@mikeserv Hmm?
@FaheemMitha - it merited my upvote.
@mikeserv The answer I linked to? Ok.
Yes, I thought so.
@mikeserv I'll wait for @derobert's approval. :-)
@Gilles what do you think of mk-sbuild in ubuntu-dev-tools, if anything?
12:33 PM
1st thing I will bother a moderator with: poke him with a sharp stick so they get this done
@Braiam Careful, you might have to poke yourself!
@terdon well, I will have the satisfaction of having poked a moderator with a sharp stick at least once
12:50 PM
@Braiam nothing wrong with having please in a question. It's not the typical useless noise of "Please help" or "Thanks" etc. Having it in the flow of a sentence seems fine. Also, removing it makes the question quite aggressive and rude.
@terdon but it adds anything of value to the question?
Yes. Politeness.
"Provide a script" is really kind of rude.
Consider the difference between "How can I?" and "Tell me how to"
Rephrasing it as a question would be fine but if it stays as an imperative, it comes across as very rude.
@terdon I consider more rude that he doesn't show the command he tried nor the error
That's annoying, yes.
I have a laptop to which I have lost UEFI and boot media menu access.I can only get to it by removing my internal HD.I was wondering if I wanted to install linux/windows to my laptop hd.Can I remove it, connect it as an external drive(using a converter on the internal) and install stuff to if from the live usb?
1:04 PM
@marti Yes but make sure to use the UUID and not the /dev/sdXN name. You're probably better off fixing the original issue though.
@FaheemMitha never heard of it
In fact, that sounds like a great topic for a question on the main site.
@terdon The original issue is touch to solve...It involve NVRAM corruption thanks to uefibootmgr
Q: Unable to access UEFI settings on Lenovo

martiI have a Lenovo G580 on which I installed Windows 8 and several Linux distros which have messed with my booting. The last I used was boot-repair tool. I have an EFI partition on sda2. The Grub load and I can boot to windows or Linux Mint or Mageia. It seems now I cannot access UEFI by my regular...

@marti Ah.
@tendon You know any way to reset the NVRAM/UEFI . Will flashing do?
1:10 PM
Q: Review queue edit posts mouse doesn't work

Ashley MedwayBasically when reviewing a low quality post, if I choose to edit the item, I cannot move the cursor by clicking in the textarea. The keyboard is working fine, but any mouse interaction appears to be disabled. The issue only appears if you review one item first, then the next item is loaded in. E...

I did have a chat with derobert and decided to leave things as it is...however little poking around shouldnt do harm
@marti Ah, if derobert can't help I certainly can't. He knows a hell of a lot more than I do about this sort of thing (and most other sorts too)
@terdon I see.anyways..what about a Windows install.Would the installer detect my (now) External hdd and allow installation to it.
I would expect it to but I'm not sure. What I can tell you is that it's perfectly possible to install to an external drive. You should even be able to put it back in and use it normally if you use the UUID to set it up.
1:19 PM
I meant install Linux to an external drive.
@terdon..Okay I guess I could connect HD to another pc, install it and then sysprep it.Or I could put installer files directly on HD and install it.
I'm really not the person to ask. I've never had to deal with EFI so far. You'd be better off asking the guys in Super User chat for Windows strangeness.
@Gilles any idea why £ would need to be escaped in a sed command?
2:04 PM
@terdon, I do not find £ in my keyboard. So if I have to replace, the only option is to copy the character in the command?
Yes. Or, if you have a layout with dead keys, you'll probably find it with AltGR+ some key
AltGR+Shift+4 for me
2:20 PM
Or if you have a Compose Key enabled it is usually <Compose> - l (dash then "l" in sequence not together)
@terdon, @Caleb, thanks for letting me know.
­This actually worked for me in laptop. Hold down the Alt key, on the numerical keypad press 0163, then release the Alt key. £
It will depend on your layout.
@Ramesh Ya there is often a way to enter character codes by hand that way although linux implementations vary (what you just described is the standard Windows entry method).
This led me thinking what if I were to work without an internet connection. Wow, I think I won't be able to make it without internet :)
2:58 PM
What do people think about this @Caleb @terdon @Ramesh:
Q: Execute a line of commands with one sudo

rubo77For example if I want to create a file and enter text in one line I can redirect the output into a file with the use of the > operator: echo "something" > /path/foobar but if I don't have access to the folder /path/ and need sudo priviledges, How can I achieve this same command as a normal use...

See my second comment. I mention it because I think it should be reopened (once it gets closed), but I have to head out soon and can't attend to that.
@goldilocks he's looking for sudo sh -c "!!"
@goldilocks Seems like a reasonable question.
Ah, actually no, I was thinking of his other one
@Braiam Okay, there's an answer. The question was originally more explicitly about redirection, but it is broader now.
I think he's posted the new issue as a separate Q so we may as well close this one. That's just asking about redirection and tee basically.
@terdon Seems related. @terdon : Either way. Just though I'd mention it.
3:05 PM
Good call.
@terdon Actually I'm not sure if it is just about redirection, although that's the example.
Yeah, reading it again I think you're right.
Lets keep an eye on it and reopen as needed.
@goldilocks there
wait... what question should I put my answer?
Who's on first? ;D
Q: Execute a line of commands with one sudo

rubo77For example if I want to create a file and enter text in one line I can redirect the output into a file with the use of the > operator: echo "something" > /path/foobar but if I don't have access to the folder /path/ and need sudo priviledges, How can I achieve this same command as a normal use...

@Gilles ok
3:10 PM
@Braiam That was going to be my answer, but I think that blows up if you have quotes in the history command. I think this is going to have to be a wrapper function.
I started one but food showed up so I got distracted.
what's the alternative for grep -P option in osx?
@AvinashRaj perl? Sorry couldn't help it, but you con use o perl one liner to grep. You can also get install a GNU grep on OSX.
i tried to answer for this unix.stackexchange.com/questions/138288/… question. And i got this command working,
$ grep -P '^(?!.*Prototypes).*(?=\.plist$)' file
but this comment
N.B. grep on OSX >= 10.8 doesn't include -P. — Kevin 21 mins ago
block me to post the answer.
Alternative? perl -ne '/^(?!.*Prototypes).*(?=\.plist$)/ && print' < file
3:27 PM
@Gilles after following your instructions in unix.stackexchange.com/a/12957/4671, when running df I get df: cannot read table of mounted file systems. Is this normal?
This is strictly OT, but is the beginning scene in The Desolation of Smaug based on that LOTR appendix, you know, the one containing the words
> Yet things might have gone far otherwise and far worse. When you think of the Battle of Pelennor, do not forget the battles in Dale and the valor of Durin's Folk. Think of what might have been. Dragon-fire and savage swords in Eriador, night in Rivendell. There might be no Queen in Gondor.
> We might now hope to return from the victory here to ruin and ash. But that has been adverted — because I met Thorin Oakenshield one evening on the edge of spring in Bree. A chance-meeting, as we say in Middle-earth.
@FaheemMitha you need to have /proc mounted
@Gilles I somehow got the impression that schroot does that. It doesn't mount stuff for you?
@FaheemMitha it does (if configured the way I show in my answer)
@Gilles I followed your instructions. I'll review them again.
Hmm, maybe it reads /etc/mtab. Make the symlink /etc/mtab -> /proc/mounts
3:35 PM
@Gilles Inside the chroot?
> But do create a good-enough /etc/mtab to make commands such as df work reasonably.

> ln -s /proc/mounts /32/etc/mtab
yup, I had that covered
@Gilles ok, checking.
Yes, sorry, I didn't do that.
Are the previous cp stuff before, it that on a "if you feel like it" basis?
@Gilles The /etc/mtab exists in the chroot and is empty. Should I delete it?
Also, the equivalent of schroot -c /32 didn't work for me. I had to pass the name of the chroot as an argument, not the path of the chroot.
4:02 PM
@FaheemMitha Well, AFAIK its currently correct. Whether it merits an upvote or not is a harder question, as mostly the person who's name is next to it didn't write it... terdon and I did. I would have just put my own answer in, except as you can see I've voted to close it.
@derobert I see. I'm surprised you didn't just write your own answer then.
@FaheemMitha yes
@FaheemMitha oh, that one's a bug in my answer. Yes, you need the schroot name (the part in the brackets in the config file).
weird that nobody's noticed it in all that time (and I've used this answer as a reference several times)
@Gilles After doing the linking as you suggested, df in the chroot shows the results in the parent system, which doesn't seem right either.
Which makes sense, since after all it is being linked against a file in the parent system.
@FaheemMitha hmm, no, df shows paths in the chroot. The amount of disk free is tied to a filesystem, chroot doesn't affect that.
@FaheemMitha I voted to close the question. And that stuff about unlink is already covered in the answer to the question I suggested it was a duplicate of.
4:07 PM
@Gilles Not here it doesn't. And I don't see why it should, either.
One sec.
@Gilles Ok, maybe I'm misunderstanding something.
I have
root@orwell:/home/faheem# ls -lah /mnt/wheezychroot/etc/mtab
lrwxrwxrwx 1 root root 12 Jun 20 21:34 /mnt/wheezychroot/etc/mtab -> /proc/mounts
This is in the "host system". Now, /proc/mounts shows the mounts in the host system, therefore so does /mnt/wheezychroot/etc/mtab, i.e. /etc/mtab in the chroot. What am I missing if anything?
Now of course @Gilles has written an essay answering the question...
@FaheemMitha try in again when chrooted
@Gilles I get similar stuff. The chroot mounts are missing, otherwise it is basically the same list of mounts.
@derobert would you care to weigh in here?
@derobert I've now lost track of what question we were talking about. :-)
@FaheemMitha no, actually, what you see is only the mount points overlapping the chroot (i.e. the one containing the chroot plus the ones whose mount points are under the chroot)
@FaheemMitha The update a program while running question
@FaheemMitha I'm not sure what you all are talking about. Haven't read the chat log yet.
4:12 PM
@Gilles That might be true, I'd have to check. So, is that normal then?
@FaheemMitha what you've shown so far looks normal
continue your end-user test and I'll update my answer tonight
@Gilles Hmm, I don't think the mount points here are under the chroot.
I get
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 20642428 1173236 18420616 6% /
udev 10240 0 10240 0% /dev
tmpfs 20642428 1173236 18420616 6% /run
/dev/mapper/debian-root 20642428 1173236 18420616 6% /
tmpfs 20642428 1173236 18420616 6% /run/lock
tmpfs 20642428 1173236 18420616 6% /run/shm
/dev/mapper/debian-boot 20642428 1173236 18420616 6% /boot
The chroot is mounted on /mnt/wheezychroot
Why am I seeing eg /home/faheem/video?
@FaheemMitha and is /dev/mapper/debian-wheezy? It looks like df is getting confused, and stat'ing that mount repeatedly
@derobert One sec.
Yes, /dev/mapper/debian-wheezy is the chroot itself.
which is mounted on /mnt/wheezychroot as stated before.
I can't do any more live support now. I'll be around later tonight
4:17 PM
It doesn't seem reasonable to me to be seeing all these other slices that have nothing to do with the chroot.
@Gilles Ok. Thanks for your assistance.
@derobert does the ln -s /proc/mounts /32/etc/mtab step look reasonable to you? I can't remember what I've done before - it has been a while since I used chroots.
@FaheemMitha well, /proc/mounts is going to show all the mounts, even if you're in a chroot. That's why df is seeing them.
@derobert Ok. So, what is the right thing to do here, then?
I'm surprised it can stat /home/faheem/video, if that's not part of the chroot (possibly via bind mount)
@FaheemMitha I don't think weird df output is much to worry about.
@derobert well, no. but it is good to have that information available.
I see that at top level I now have
/dev/mapper/debian-wheezy 20G 1.2G 18G 6% /var/lib/schroot/mount/wheezychroot-7e8541db-dbe7-43ea-99a1-af74474a85a6
proc 0 0 0 - /var/lib/schroot/mount/wheezychroot-7e8541db-dbe7-43ea-99a1-af74474a85a6/proc
sysfs 0 0 0 - /var/lib/schroot/mount/wheezychroot-7e8541db-dbe7-43ea-99a1-af74474a85a6/sys
udev 10M 0 10M 0% /var/lib/schroot/mount/wheezychroot-7e8541db-dbe7-43ea-99a1-af74474a85a6/dev
I guess this is schroot doing its thing.
I'm not sure what is with the 7e8541db-dbe7-43ea-99a1-af74474a85a6.
@FaheemMitha Good question. Clearly a UUID, but not sure why its doing that.
4:22 PM
@derobert well, I don't know if it is that surprising. it is in /proc/mounts in the host. and the /etc/mtab is linking to that. Should it be filtering it out or what?
@FaheemMitha Well, turns out /home is bind-mounted, so that explains why. I was expecting it to wind up statfs'ing /dev/mapper/debian-wheezy again
@derobert I don't understand what difference that makes.
Oh, you mean it will show everything under /home?
I wonder if doing that bind mount is really a good thing. that means i have access to /home inside the chroot I guess.
@FaheemMitha yep. Whether you want it or not, depends on if you want to be able to access /home. I'd err on the side of fewer bind mounts.
Yes, it is bind-mounting home and root.
Ok, this is strange
/dev/mapper/debian-root 46G 14G 31G 31% /var/lib/schroot/mount/wheezychroot-7e8541db-dbe7-43ea-99a1-af74474a85a6/tmp
what on earth? it is bind-mounting debian-root to /tmp?
The /tmp in the chroot looks like the one outside. it is just bind mounting the /tmp portion of the root device in the host system? And how would it know how to do that?
@FaheemMitha Well, it probably did mount --bind /tmp /path/to/chroot/tmp
4:30 PM
@derobert Ok. Yes, I can't see what instructions were issued.
so it looks like it is bind mounting /home and /tmp from outside to inside the chroot. i guess that is ok. what do you think?
@FaheemMitha Its probably needed easily access your files inside the chroot.
@derobert right.
@derobert needed "to" easily access, right?
You'll have to be a little careful with the /home one, as e.g., if you run a newer version of some utility inside the chroot, it may try to upgrade your dotfiles.
Or alternatively an older one inside the chroot may complain about your dotfiles
@derobert true. but mostly I'm just going to try to check that latex/emacs/auctex/preview issue to start with. the one I was complaining about earlier
Hmm, how do I get X to work from inside the chroot? I chrooted in as root and then su'd to faheem. Should I do it differently?
BTW: you can better see the bind mounts by cat /proc/self/mountinfo ... that shows both directories
@FaheemMitha you need to make sure your XAUTHORITY is set right, if it's not ~/.Xauthority
And of course, it needs to be readable inside the chroot.
4:36 PM
It is /home/faheem/.Xauthority both in and out of the chroot.
Why the people in SO migrate this unix.stackexchange.com/questions/138291/…?
(wheezychroot)faheem@orwell:~$ ls -lah .Xauthority
-rw------- 1 faheem faheem 161 Jun 19 17:36 .Xauthority
we already have a question like this posted by the same user.
@AvinashRaj Because a lot of people over there don't know the rule "don't migrate junk"
I mentioned in the comment as crossposting.
4:37 PM
@AvinashRaj if you have the rep here, vote to close it as a dup
I donno whether they saw that or not.
@derobert Done
@FaheemMitha if you're looking for some voting to do, there are a bunch of things in the close review queue.
@derobert I usually don't know what decisons to make, but Ok, what is the link?
Apparently the Chromium chat extension mangles PRIMARY when you use its keyboard reply shortcut. How nice.
4:44 PM
Oops. Stephane voted to leave open unix.stackexchange.com/review/close/50800
I saw this after I voted to close. Did I miss something?
This is why I tend not to vote on these things.
@FaheemMitha He probably thinks the question is looking for a way other than chroot. A way which, honestly, may just not exist.
Personally, I wasn't sure, so I just skipped that one.
@derobert Ok. For the record, is there some way to reverse a close vote?
@FaheemMitha yes, you can go to the question, and click close again. You can retract your vote there.
@derobert ok
@derobert retracted. It isn't really a dupe, I guess.
5:04 PM
Funny, I'm not a member of the users group.
@FaheemMitha Apparently, they just haven't told you yet that you're fired...
@derobert :-)
I'm schrooting directly into the chroot, but X is still not working.
Actually, that's the default on Debian. That group isn't really used by default.
@derobert any ideas?
@derobert Yes, I added a comment to @Gilles post.
@FaheemMitha error message?
5:11 PM
I suggest adding a line like users=faheem to your example. By default, for me at least, I'm not a member of the users group. I would have expected to be, however. — Faheem Mitha 2 mins ago
@derobert There isn't one. I try to start up emacs, I get the console version. Maybe I should try xterm.
(Also, a link to Gilles post? I don't know where it is...)
@FaheemMitha That sounds like you forgot to set DISPLAY.
@derobert See above.
@derobert Yes, it is not set. Do I have to set it manually?
@FaheemMitha Apparently you do. It probably got lost when you did sudo, or something.
@derobert I schrooted directly into the chroot. No sudo.
@derobert setting display does fix it. But I don't see that is necesary.
Ah, then maybe schroot gets rid of some environment variables. Not sure.
DISPLAY is definitely needed if you want X clients to work.
5:14 PM
Though it complained about dbus.
(emacs:8725): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally without any error message
GConf Error: No D-BUS daemon running

(emacs:8725): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally without any error message
I'm guessing this is harmless.
@derobert sure. I'll add another comment to gilles post.
@derobert Even if it was preserved, DBUS is accessed via a named socket, which won't be inside the chroot unless mount bound
I guess you could do an env > /tmp/outside outside and env > /tmp/inside inside, and then diff (etc.) to see which environment variables were lost
@derobert ok
5:16 PM
@Patrick /tmp and /home are bind-mounted
ahh, ok
@FaheemMitha I wouldn't be surprised if there is a schroot config file somewhere where you can tell it to keep those env vars
@derobert Ok. all the DBUS env variables as well as DISPLAY get taken out.
There are several DBUS variables. Don't know what they do, of course.
Hi all, anyone aware of ldap configuration here?
@FaheemMitha Hmm. I only have one DBUS variable. Google can probably tell you what they're for.
@Ramesh Yes...
5:20 PM
@derobert, thanks. is this even a good solution?
@Ramesh I have no idea. Apparently you can't just scroll down on the hyphen site to see the answers anymore
And that looks like a Windows question...
@derobert, from Nessus scan report I have this from security team. Configure the service to disallow NULL BINDs.
I was trying to google out and the solution that I saw in that link seems somewhat not good to me.
it looks like Eric Cartman is impersonating Ramesh.
5:24 PM
Links to the hyphen site are never good :-P
@mikeserv, Respect my authoritah.
@mikeserv I haven't refreshed my chat window, so I still have the generic autogenerated icon
Is the Nessus tool good in scanning?
@derobert - that's how he gets you. Don't believe it's him.
@mikeserv If its Cartman, he's required now to sing his cover of "Poker Face". Much better than the original.
5:26 PM
And ride around on Cthulhu, sung to the Totoro theme.
I need cheesy poofs.
Wait. Cartman and Cthulu ... together? That is a horror beyond even Lovecraft.
@derobert, sounds reasonable. serverfault.com/questions/63916/…
@mikeserv southparkstudios.com/clips/360459/… ... you've apparently not seen that one :-P
5:34 PM
Did you know I even gave the site the name as Awesome - o.
Wow. Now I have seen that one... yeah... fuck all you
@mikeserv Hah, I showed that episode to someone right after he watched My Neighbor Totoro. Had him falling out of his chair.
@Ramesh Serverfault is usually a pretty reasonable place.
It's pretty good. I need to show my son that movie - the Totoro one though.
I hooked up a projector in the living room recently. He's been digging movie night since.
Afterward I asked my dad why he never did such a simple thing. He reminded me of the pbj in the vcr and asked me how long I thought reel-to-reel would have lasted.
6:12 PM
Is the tortoro film good? Is that the same person who filmed Howl's Moving Castle?
@derobert The schroot man page says
By default, the environment is not preserved, and the following environment variables are defined: HOME, LOGNAME, PATH, SHELL, TERM (preserved if
already defined), and USER. The environment variables SCHROOT_COMMAND, SCHROOT_USER, SCHROOT_GROUP, SCHROOT_UID and SCHROOT_GID are set inside the
chroot specifying the command being run, the user name, group name, user ID and group ID, respectively. Additionally, the environment variables
SCHROOT_SESSION_ID, SCHROOT_CHROOT_NAME and SCHROOT_ALIAS_NAME specify the session ID, the original chroot name prior to session creation,
I don't see DISPLAY listed there.
@FaheemMitha - in response to your first line - yes and yes.
@mikeserv There is that reply thingy. Learn it. Love it.
Oh, and thanks for the reply. I didn't really like Howl's Moving Castle that much. But then, as a long-standing DWJ fan, I guess I'm kinda picky.
But how do I reply to a single line? Also, is it really necessary when the response comes directly after the question? Can it not be implied?
I don't think DWJ really works as Japanese anime. If that is what it was.
@mikeserv Right click. Assuming you aren't using a portable device. I seem to remember you couldn't use a mouse easily in your setup or something?
I don't know dwj. I know pbj and gwb and dmoney.
6:25 PM
@mikeserv :-) Diana Wynne Jones. The author of Howl's Moving Castle.
The reply thingy is handy. And not an option in IRC.
Ahh. There are others from the same studio. You and I both discussed the leguinn adaptation once - that was the same studio, but not representative of their best work.
I remember someone here was a fan. Possibly @terdon.
@mikeserv The Le Guin was by Studio Ghibli?
The adaptation, yeah.
Ah, tales from earthsea. Ok, did not know that.
Right. But My Neighbor Totoro is among their best. That and Spirited Away and Princess Mononoke.
And one more...
6:28 PM
@mikeserv I see. I'll put it on my things to watch list.
I forget its name. Big pillbug creatures and gasmasks...
DWJ is sadly deceased. We (her fans) hoped she would live (and keep writing) forever. Unfortunately, that didn't happen.
I'm guessing you haven't read her stuff, then.
This the first of her I'd ever heard. I'll have to look into it. She's gotta be better than dmoney.
@mikeserv dmoney?
Don't bother.
6:31 PM
@mikeserv ok
@mikeserv Children's fantasy. Pretty famous. Particularly in her home country - England.
Whether she is to your taste or not, can't say of course.
She is one of those authors who readers feel a personal relationship to. As you could see by reading her obits on the web.
As did I, indeed.
1 hour later…
7:39 PM
@mikeserv I'm not sure about giant pillbug creatures, but are you thinking of the On Your Mark music video?
debian has giant pillbugs?
@mikeserv And I'd add Porco Rosso. Over Spirited Away, at least.
I was thinking of Nausicaa of the Valley of the Wind
7:48 PM
Ah! Yeah. I'd watch Porco Rosso again over that again as well.
A moustachioed porcine pilot is a sure winner every time.
@mikeserv no. just bugs.
When I saw that movie I kept thinking of TaleSpin.
@mikeserv Been a long time since I've seen that!
@polym - hi back at you.
@derobert - ditto that. But I used to tune it in on UHF 30 everyday instead of practicing my penmanship.
7:53 PM
But I don't recall it featuring an hour long aerial fistfight... :-P
There's only so much you can do with 30 minutes of after-school tv.
Anyway, I think my time was better spent.
@mikeserv Indeed, penmanship is a waste of time. Why wouldn't you type it if someone else was supposed to read it? :-P
@mikeserv what does practising penmanship mean?
00:00 - 20:0020:00 - 00:00

« first day (1350 days earlier)      last day (2729 days later) »