« first day (3536 days earlier)      last day (79 days later) » 

6:44 AM
@PhelypeOleinik any comment about github.com/ho-tex/letltxmacro/issues/1?
2 hours later…
9:03 AM
@AlanMunn oh :(
1 hour later…
10:33 AM
@wipet Ahoj! :)
Hi all!
@yo' ahoj <3
Also pivo prosím. :)
11:00 AM
@DavidCarlisle, @barbarabeeton New lesson 15 looks OK to me: go for it?
@PauloCereda when will you come to need this phrase? :)
@yo' hopefully soon. :)
@PauloCereda yeah. Remember, only the tickets, the rest will not be an issue :-)
@yo' Ack. <3
11:27 AM
@UlrikeFischer Not worth it, I think. \NewCommandCopy \LetLtxMacro is really meant for document-level commands, so weird names should not be needed. If OP's use-case is not document-level, then it's not hard to make the \csname by themselves (or use \exp_args:Ncc ;-)
@PhelypeOleinik ooh \pneumonoultramicroscopicsilicovolcanoconiosis
I will shut up now. :)
@PauloCereda \Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch
@PhelypeOleinik ooh that's even better
@PhelypeOleinik this could be a L3 prefix
@PhelypeOleinik the use case is probably for the lwarp package (in view of the prefix used), so I would say "package level". But when I saw the question I wondered about an expl3 interface, say \cs_new_ltxcommand_copy:cc ;-).
@PauloCereda :-)
11:33 AM
@PhelypeOleinik will you move the new code in the next days into develop?
@UlrikeFischer Oh, right, OP is the author of Lwarp, indeed. Well, now that we're loading expl3 at the beginning, I could port the whole code to expl3 and make a 2e interface (that seems to be the way of things now :-)
@UlrikeFischer The code is mostly done, but I'm waiting for the “discussion needed” part. I think Frank wants to take a look when he gets the time
@UlrikeFischer But it's supposed to go into the next dev release
RIP Ennio Morricone
@PhelypeOleinik which one was that?
@UlrikeFischer Sorry, which what?
@PhelypeOleinik the "discussion part", what was open?
11:37 AM
@UlrikeFischer I'm not sure myself I think it's about the text composites: the whole thing is a rabbit hole, and there was a few options about the implementation, none really good
@DavidCarlisle the example in lesson-15 is missing braces: \newcommand\mycommand\textbold{hmmm}
1 hour later…
12:48 PM
@PauloCereda In his memory I think this afternoon will be a "spaghetti western" marathon...Her music is incomparable, and many films would not be the same without her :(
An existential question (I've had it for years), when is TeX's official birthday?
1:12 PM
@PabloGonzálezL hmmm... ¿her? ;-)
@Rmano Mala traducción para decir "Su música es incomparable" :)
1:28 PM
@PabloGonzálezL ;-) that's a very nasty thing to get used to. In Italian is like in Spanish...
@Rmano Yes, the blessed translator does not always express what I want, I am used to using synonyms and the structure of English is not my thing :(
2:03 PM
@UlrikeFischer ah I was experimenting to get teh colour in, will put them back
@UlrikeFischer It was getting late and I couldn't quite make your restructure suggestion fit the format so I left lesson-15 much as it was before and added some additional more-15 rather than making lesson-15 shorter. Feel free to comment on the issue #57 if you think it should be restructured more.
@DavidCarlisle I will look in the evening.
Oh a spotcolor question ;-)
3:03 PM
@PabloGonzálezL oh
@UlrikeFischer ooh
3:21 PM
@UlrikeFischer it should first test whether #2 is a defined macro and not create two control sequences with meaning \relax.
4:05 PM
@PauloCereda I had the opportunity to see him with the orchestra of the Universidad de Concepción here in my country (Chile) some years ago... I still remember the "Imperial March" plus all the classics of the films I watched with my father.
@PabloGonzálezL How nice!
@PauloCereda It was great :)
Kanye West wants to run for president?!
1 hour later…
5:37 PM
@ FontForge

Could sb. give me a tip?

What is the correct way to erase the part A.
(Erasing part B is no problem.)
6:02 PM
I want to add a new prefix to expkv-def, called also, which can be used to add a specific action to an already defined key. The big question is, should also behave like a p prefix, so that it can alter other prefixes (so, e.g., a syntax like choice foo = {<choices>}, also store foo = \myfoo is valid and will set up a choice key which's choice will also be stored in a macro \myfoo, or is it enough if also adds code and the user would have to use [...]
[...] choice foo = {<choices>}, also foo = \def\myfoo{#1}.
6:14 PM
@samcarter_is_at_topanswers.xyz I think @UlrikeFischer might want to test Zoom stuff too...
@cis You can use the cut tool to cut once across the stroke, then remove all points until the corner and then reconnect the open lines by dragging one point over the other
@UlrikeFischer If you like to make a zoom test, I could offer Wednesday afternoon, Thursday or Friday afternoon.
(The Bär is of course also welcome to test :) )
6:36 PM
@samcarter_is_at_topanswers.xyz ooh a Bär test
@PauloCereda :) I hope it does not have the same result like the moose tests en.wikipedia.org/wiki/Moose_test
@samcarter_is_at_topanswers.xyz ooh
@samcarter_is_at_topanswers.xyz would be all fine with me (and the Bär is there too). Do I need to install something first?
@UlrikeFischer I'll sent you mail
@samcarter_is_at_topanswers.xyz and Bär mail :)
7:01 PM
@samcarter_is_at_topanswers.xyz Yes, that seems to help: the cut tool. And a few times change of the direction. Puhh. I am near at the first goal.
@samcarter_is_at_topanswers.xyz cutting a pretzel. :)
@PauloCereda Yeah, just upside down :)
7:18 PM
@samcarter_is_at_topanswers.xyz ooh pretzel physics :)
@PauloCereda There used to be an TV advertisement for Bärenmarke which featured a life sized teddy bear. In one of the spots, the bear was dressed as postman.
@PauloCereda If you combine with the physics of spagettification, you'll have a full meal
@samcarter_is_at_topanswers.xyz ooh success
@JosephWright we need a better color system ;-). I tried to figure out why this fails with beamer and tikz and colorspace and it is a mess: tex.stackexchange.com/questions/552508/…
@samcarter_is_at_topanswers.xyz ooh
2 hours later…
9:14 PM
***** The stroke-order-tutor makes Spaghetti Bolognese now.....
9:33 PM
@UlrikeFischer Hello very kind Ulrike Fischer: this morning I updated MikTeX but in the console in Connecting servers does not provide me with a server to my liking as before. Are you informed of any problems that are being solved?
There were a few problems the last days. I had to use this work-around github.com/MiKTeX/miktex/issues/580 github.com/MiKTeX/miktex/issues/571 to be able to update again.
@UlrikeFischer For example I not can choose a my preferite server. I can only select a random repository. If I click on change I have only a proxer server.
@UlrikeFischer Yes I have seen before into a question on the main site of your links. In my previous question you can see that I have asked a problem that I see always: The following issues were detected:
1: major issue: User/administrator updates are out-of-sync.
@Sebastiano make the window larger. The change button is probably hidden at the right.
@UlrikeFischer With lot of sincerity into this pc that I'm using there is not MikTeX and I have taken an image on internet.
@Sebastiano well then try to run updates as user and as admin. But I can't help you here much - I have installed miktex in single user mode and so don't have an admin mode.
9:42 PM
@UlrikeFischer I have understood your solution.
@UlrikeFischer However clicking on Change repository I not can change the server in admin mode.
@Sebastiano then leave it for now and first try to update.
@UlrikeFischer how many users is a lot?
Mon Jul  6 21:11:14 UTC 2020
  Number of distinct users:     6
  Number of document requests:  15
  Number of documents returned: 10
  Number of unique user agents: 4
Sun Jul  5 23:56:04 UTC 2020
  Number of distinct users:     5
  Number of document requests:  68
  Number of documents returned: 66
  Number of unique user agents: 7
Sat Jul  4 23:57:43 UTC 2020
  Number of distinct users:     9
  Number of document requests:  82
  Number of documents returned: 33
  Number of unique user agents: 10
@UlrikeFischer This morning I have download all with admin mode and MikTeX run perfectly. The compilation is perfect.
@DavidCarlisle My best regards from Sicily David.
@UlrikeFischer Right now everything works for me: the only anomaly is that you can't change the server from where you want to downloaded. I send you my sincerest regards and a good rest to everyone in chat. Best regards.
@Sebastiano I have no problems. I can change.
@DavidCarlisle hm, no idea but at least today I wasn't one of the users ;-). Btw: I just tried the "mismatch braces" example and it compiles ...
@UlrikeFischer oh did I lose another brace? (I had some arguments with markdown getting those examples look like i wanted, perhaps it won the argument)
9:54 PM
@DavidCarlisle no, I think an open group doesn't let the compilation fail. You probably need something that looks for an argument.
@UlrikeFischer oh no of course, hmm ### simple group (level 1) entered at line 5 ({) isn't an error
@UlrikeFischer @JosephWright I could make a log containing a (\end occurred inside a group at level ... message show the log rather than the pdf ?
or I could just strengthen the wording a bit and say ... a PDF is generated but....
@DavidCarlisle you could use \begin{quote) that gives a rather dramatic error ...
@UlrikeFischer \begin{the rest of my document if it were not for that pesky \long check
@DavidCarlisle ? I don't get a \long check error, it reads all 30000 lines of junk of my test file and stop only at an invalid char somewhere at the end.
@UlrikeFischer But as a user but not as an administrator?
10:06 PM
@Sebastiano I don't have an admin installation, I do everything as user.
@UlrikeFischer When I turn on the computer where I installed MikTeX I'll try to see if as a user I can change the server. However as admin if I use a random server everything works perfectly. I will inform you if as user I can change the server. A warm greeting.
10:31 PM
@UlrikeFischer should we blame you or Frank?
$ /usr/local/texlive/2017/bin/x86_64-cygwin/pdflatex bq1
This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2018-04-01> patch level 3
Babel <3.18> and hyphenation patterns for 84 language(s) loaded.
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2017/texmf-dist/tex/latex/base/size10.clo)) (./bq1.aux)
$ pdflatex bq1
This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-06-18>
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
spot the difference
@DavidCarlisle well I never touched the begin code, so one can safely blame me ;-)
@DavidCarlisle -- That ### simple group entered ... is one of the things I covered in my talk on debugging. But indeed, it isn't reported as an error. (Maybe that should be considered.) You might consider "matching" \cs{...]{...}`, which is less likely, but should get a reported error.
@DavidCarlisle -- Oh, bother. I meant \cs[...}{...} (or am I just going around in circles?)
@barbarabeeton well I have \usepackage[leqno}{amsmath} I think having a non-error error is OK in the lesson, only thing is if it returns a PDF as now it needs a few more words of description.
10:49 PM
@DavidCarlisle -- Once you get into situations that don't trigger error messages you're into non-elementary territory. Something like {\Large ...) ... will likely produce a pdf file, but it will (should) be immediately obvious that something is wrong ... I offer my TUGboat article as a possible reference to cite for details beyond the scope of the tutorial.
phelype@phelype ~/d/l/base> git blame ltmiscen.dtx -L530,530
58ad19dc (Frank Mittelbach 2019-08-29 15:19:33 +0200 530) \DeclareRobustCommand\begin[1]{%
@UlrikeFischer @DavidCarlisle ^^^
A * missing after \DeclareRobustCommand
But @UlrikeFischer is misspelled ;-)
11:10 PM
A: why there is a "Text line contains an invalid character" after "Undefined control sequence" and why "Q" required further input?

Karl Berry Original poster: can you please email me at karl at tug.org? You've discovered a bug in the original TeX and DEK will surely want to transfer a hefty balance to you in the Bank of San Seriffe :). the "further input after Q" and "segmentation fault" have the same underlying cause: TeX's data was...

Someone will get a check :-)
11:48 PM
@PhelypeOleinik -- Only if he answers and identifies himself. :(
@barbarabeeton Oh, it would be a pity if he didn't. And it seems that the same person found two (tex.stackexchange.com/q/552113/134574)!
I wish I had spent more time playing with interactive mode ;-)
@PhelypeOleinik -- Thanks for fixing the code formatting. Even playing with interactive mode might not be enough. I'm sure I've done something like this (I always use interactive mode), but "knew enough" to know it was user error. I think the other report is in web2c as opposed to TeX itself. Even so, it's pretty remarkable, and he surely deserves recognition -- even if he keeps the check, frames it, and hangs it on the wall. (That's actually the fate of many checks.)

« first day (3536 days earlier)      last day (79 days later) »