« first day (4924 days earlier)      last day (30 days later) » 

6:28 AM
@Skillmon I guess my starting point is 'What input and output do you expect?' It can't work the same as the = modifier, as that looks 'early' for a surrounding set of braces - as a built-in, it can do that. So ... do you expect to parse into braced pairs perhaps?
 
@JosephWright exactly that, such that >{\SplitKeyval{keyA=defaultA, keyB=defaultB}} O{} would result in {defaultA}{defaultB} if the optional argument is unused.
(and with "I had the idea" I mean I'd try to write that in L3 and open a PR on ltcmd.dtx)
 
@Skillmon I guess the issue there is with a longer list of keys starts to look a bit unwieldy - lots of arguments to remember the order for
 
6:54 AM
@Skillmon oopsie sorry
 
7:09 AM
Meanwhile
2
Q: Automatically determine all ctan packages necessary to compile

davidlowrydudaI keep a relatively lean texlive and install individual packages as necessary through tlmgr. Sometimes I begin to work with a colleague and have to compile a new paper. Right now, my process is to attempt to compile (typically with pdflatex). If the compiler complains, for example, saying File 'c...

is an interesting challenge - I see the IoT have looked at it (@PauloCereda)
 
@JosephWright quack <3
 
@PauloCereda Quack :)
 
7:29 AM
@TeXnician ^^ one for us :)
 
8:26 AM
@JosephWright for longer lists of keys you use \keys_define:nn/\keys_set:nn, this is meant for simple macros with few keys.
 
 
1 hour later…
9:37 AM
@JasperHabicht I was awake at 4AM browsing my Twitter timeline when I saw the CTAN announcement: Jasper Habicht submitted an update to the jsonparse package. My brain malfunctioned and I read jsonhorse instead. :) I was like, ooh horses — apologies. :)
 
9:49 AM
@PauloCereda Haha, why not ... maybe an idea for a future package (whatever it will do ...)
 
@JasperHabicht been there, done that. :) I pester @TeXnician all the time with wacky names for tools. "— What does it do?", "— No idea, we will figure it out later". :)
2
 
@PauloCereda should've named my package pufferfishkv instead of expkv... :)
2
 
@PauloCereda My break read that as jasonhorse, so some long haired hourses?
@Skillmon because it is leathal if not handled correctly?
 
10:04 AM
@JosephWright you probably would need some online service that gives back a list. Locally I don't really see how it should work, while you can suppress an error if a package is not found it would be difficult to suppress follow up errors from the missing package.
 
@daleif because it expands.
 
Hooray, after hours of trial and error (mostly error of course ...) my testing document compiles fine again. Now I need to check whether the output is fine and then v0.8 is ready =)
 
10:44 AM
@Skillmon ooh yes please! :)
@daleif oh no :)
 
@Skillmon In the end we should use long names for expl3 modules ... so this maybe the solution ...
@PauloCereda I could use a horse (named Jason) as mascot for the package ... =)
 
@JasperHabicht ooh
 
 
2 hours later…
cis
12:27 PM
Is there anything I can do if Fontforge moves parts of an svg graphic incorrectly (everything is correct when opened with Inkscape).
 
12:55 PM
Jack in the box, hearts outside the box ...
Strange, why are these paths shifted but the rest is not?
 
cis
1:42 PM
No, problem I go the way
svg (original) --> pdf ---> svg (and back again)

But I have a gerneral problem:
Does anyone happen to know how I can change (invert?) black <---> white in FontForge?
 
@cis Path typically are clockwise or counterclockwise and a counterclockwise path will be subtracted from a clockwise path. You should be able to switch the "clockwiseness" of a path in FontForge. But the above looks as if the outermost path is missing, so that there is no frame but a filled path.
 
cis
2:03 PM
@JasperHabicht Yes, I will try the direction-change.
 
Has anybody ever noted that footnote markers can come awfully close to the preceding letters? texlive.net/…
I'm looking through the main site but I can't find anything
 
@JasperHabicht I provided the prompt "a horse with a nametag written JASON on it" to one of those AI image generator thingies and got this:
 
2:19 PM
@PauloCereda I like the third one from the last row =D
 
@PauloCereda I hope Jason will cause less chaos than bbc.com/news/live/uk-england-london-68888725
 
@campa Yes, also (f) in lists and so on. :(
@campa iirc, it is so that even the upright f (in cm) has italic correction.
 
2:36 PM
@samcarter Oh no!
 
@samcarter oh no
@JasperHabicht ooh :)
 
Just because I do not quite understand it myself: A math font for a particular text font, I'm guessing the spacing around the letters are different? Virtual font? I've playing with replacing the letters in a math setup with the letters from a text font, in the naïve manner., This means that $math$ ends up looking like $\mathit{math}$ (tighter together). Not sure if there is something one can do about that.
 
2:53 PM
@daleif ^ CM/LM is extreme in this sense. Maybe you have noticed in Theorems or other environments that are typically set in italics, that the left marginal is not really "straight".
 
@mickep Here I'm using kpfonts-sans as the basis, it there is still a big difference between $lim$ and $\mathit{lim}$ in that font. It is this readability I'd like to keep if possible,
Note the diference on line two between number 2 lim and number 4 lim.
And there is if I replace the letters in math with the ones from the text font
It is usable like this. I think peoploe will mostly jut be happy to have a suitable math font. It does not need to be perfect.
 
@daleif I see it. Do you want to use italic lim or is that just to show how it looks?
 
I'm going to make the letter sub optional. And only sub the numbers as there is a noticiable size difference.
@mickep just to show how it looks. To show to me that I have remembered to switch all I need.
The fact that one needs to use OT1 for operators eluded me for a while. Even with TLC3pI right in front of me. But works with OT1. Haven't tested with lualatex yet.
 
@daleif OK, I see.
 
:65551966 The lim line runs
\textup{lim}\, lim\, \mathrm{lim}\, \mathit{lim}\, \mathsf{lim} \lim
Regarding OT1 I kept getting * instead of \bar x when I used \defaultencoding
Uhh, very nasty under lualatex. Need more work. For another day
 
cis
3:11 PM
@JasperHabicht I came closer:
 
what on earth, I did not know numbers where oprators. ok that works
 
3:36 PM
@daleif numbers are operators?
 
3:51 PM
@JosephWright @DavidCarlisle I know 14/30: twitter.com/SoVeryBritish/status/1783127617551433735 :)
 
cis
Is there a way for pagewise-output for an environment in standalone?
---> Like in `\documentclass[tikz]{standalone}` for the tikzpictures.

This will not work:
I would like to have "AAA, BBB, CCC" in own standalone-pages.
\documentclass[preview]{standalone}
\usepackage{tikz}
\begin{document}
\foreach \nnn in {AAA, BBB, CCC}{
\begin{preview}
\nnn
\end{preview}}
\end{document}
 
cis
4:12 PM
Aha....
\documentclass[multi=my]{standalone}
\usepackage{tikz}
\begin{document}
\foreach \nnn in {AAA, BBB, CCC}{%
\begin{my}%
{\nnn}%
\end{my}}
\end{document}
 
@campa \setcounter{footnote}{5} auf\/\footnote{}
@PauloCereda some are more common than others
 
4:55 PM
@JasperHabicht expkv isn't written in L3
 
5:24 PM
@Skillmon Oh no! But the rule is also a fine with other packages ... =) puff@rfishkv
 
6:13 PM
@DavidCarlisle Can you give me the output of echo $PATH under cygwin?
 
cis
Why can't I svg that pdf?
Is this to complex?

Allways the last cárd!!!
 
@cis Do you use a pattern?
 
cis
The original file is

`1B.svg` ----> from here: https://www.me.uk/cards/makeadeck.cgi?zero=on&one=on&eleven=on

but if I import in FontForge the pattern is lost; only the outer frame stays.
 
@PabloGonzálezL well it's whatever I set in my .profile then following that whatever was in my windows path (expressed as /cygdrive/c/users/davidc/Appdata... etc)
@Skillmon you are so old fashioned
 
@DavidCarlisle Mmm...I am installing TL24 (vanilla) under cygwin to do some tests...but it doesn't work as such...I have problems loading epstopdf which with scheme-medium, but not install this script :(
 
6:29 PM
@cis Hum, I don't know, but I know that patterns can be difficult ... =( Often, the only way to solve this is really to use single paths instead of a pattern, but looking at your drawing, this will be ... tedious
 
cis
@JasperHabicht Yes I realized the "pattern-problems" last days. I will improve.
 
@DavidCarlisle Is your Tl24 installation under cygwin complete?
 
@PabloGonzálezL yes I have tl24 in cygwin and wsl2
 
@DavidCarlisle Mmm...install using sheme-medium using .iso downloaded from CTAN...but it does not install epstopdf (although it does install epstopdf-pkg)...I will try again
 
@PabloGonzálezL I always install the full version, but of the dependcies are wrong you should raise on tl list, but you should be able to do tlmgr install epstopdf now anyway
@PabloGonzálezL do you have ghostscript installed in cygwin
 
6:45 PM
:65552885 $ tlmgr update --all

/usr/local/bin/tlmgr: TLPDB::from_file could not initialize from: ctan.dcc.uchile.cl/systems/texlive/tlnet/tlpkg/texlive.tlpdb
/usr/local/bin/tlmgr: Maybe the repository setting should be changed.
/usr/local/bin/tlmgr: More info: tug.org/texlive/acquire.html

pablg@RayzenTeX ~
$ gs --version
10.01.2
 
@PabloGonzálezL Maybe the repository setting should be changed.
 
@DavidCarlisle I tried to install the full version from .iso but it returned errors with contex-legacy....
@DavidCarlisle That repo is active and is the one with which I updated from my Win11 version.
 
@PabloGonzálezL yes there were issues with context in the initial version they got fixed but maybe after the iso was cut, I can't remember exactly
@PabloGonzálezL well it's not working there (maybe just syncing its mirror but it didn't serve you any files)
 
@DavidCarlisle OK, I will try everything again and do an installation from the network (not using the iso)
@DavidCarlisle Jhon has written a patch for epstopdf and wanted to test with TL under cygwin :(
 
@PabloGonzálezL doesn't epstopdf work? what does the patch do? (I vaguely remember there was some discussion previously)
 
6:55 PM
@DavidCarlisle It works, but not under terminals that are based on MSYS2 like git-bash ...also the restricted mode was having problems under windows when using perl esptopdf ...but not under MSYS2 based terminals like git-bash ...moreover the restricted mode was having problems under windows when using perl esptopdf ...
 
@PabloGonzálezL the secret to working on windows is to be in denial that it is a windows machine, just use cygwin or wsl2 never a windows commandline:-)
4
 
@DavidCarlisle Hehehehe..it would be great, but every year more and more TL users join and my students hopefully know how to turn on a notebook :D
@DavidCarlisle Do you have any mirror to download that is working ...I'm running in sandbox and I can't install TL
./install-tl
Loading ctan.dcc.uchile.cl/systems/texlive/tlnet/tlpkg/texlive.tlpdb

./install-tl: TLPDB::from_file could not initialize from: ctan.dcc.uchile.cl/systems/texlive/tlnet/tlpkg/texlive.tlpdb
./install-tl: Maybe the repository setting should be changed.
./install-tl: More info: tug.org/texlive/acquire.html
 
$ tlmgr update --all

tlmgr: package repository anorien.csc.warwick.ac.uk/mirrors/CTAN/systems/texlive/tlnet (verified)
tlmgr: saving backups to /usr/local/texlive/2024/tlpkg/backups
tlmgr: no updates available
@PabloGonzálezL ^^
warwick is a bit nearer to me than you, but @PauloCereda always seems to manage with European mirrors:-)
 
$ ./install-tl -repository https://anorien.csc.warwick.ac.uk/mirrors/CTAN/systems/texlive/tlnet
Loading https://anorien.csc.warwick.ac.uk/mirrors/CTAN/systems/texlive/tlnet/tlpkg/texlive.tlpdb

./install-tl: TLPDB::from_file could not initialize from: https://anorien.csc.warwick.ac.uk/mirrors/CTAN/systems/texlive/tlnet/tlpkg/texlive.tlpdb
./install-tl: Maybe the repository setting should be changed.
./install-tl: More info: https://tug.org/texlive/acquire.html
 
looks like a problem at your end?
do you need a full install, haven't you already got most of it?
 
7:07 PM
@DavidCarlisle Mmm...I have tried it by installing direct in win11 and now using the sandbox feature of windows 11 and I get the same thing :(
@DavidCarlisle I would like to do that from .iso but it gives me back problems with ConTeXt
 
7:45 PM
@PabloGonzálezL I wonder why they added ConTeXt mkii back again, if that is what they did.
And did nobody test it before release?
 
@mickep I think the only cygwin user I know has no problems with the installation :D (@DavidCarlisle ^^)
I will ask a question on the TL list to see if any of the users can report my problem with cygwin (maybe I have something wrong...although I doubt that .iso and the network install fail at the same time).
 
@mickep tug.org/pipermail/tex-live/2023-December/049775.html but that is months before the release so shouldn't be the issue in @PabloGonzálezL's iso file
 
@DavidCarlisle The thing is that I can't install using install-tl either :(
@DavidCarlisle Could I be missing a perl module?
 
8:00 PM
@PabloGonzálezL looks like you are missing internet access from perl (or https access or ...) as I say it looks like a problem on your side not a problem on the ctan mirror
 
cis
@DavidCarlisle

You said you wanted regular "poker playing card faces"?

So, be my guest...
 
:65553225 $ tlmgr repository add texlive.info/tlnet-archive/2024/04/24/tlnet
tlmgr: added repository: texlive.info/tlnet-archive/2024/04/24/tlnet

pablg@RayzenTeX ~
$ tlmgr option repository texlive.info/tlnet-archive/2024/04/24/tlnet
tlmgr: setting default package repository to texlive.info/tlnet-archive/2024/04/24/tlnet
tlmgr: updating /usr/local/texlive/2024/tlpkg/texlive.tlpdb

pablg@RayzenTeX ~
$ tlmgr --verify-repo=none install epstopdf

/usr/local/bin/tlmgr: TLPDB::from_file could not initialize from: texlive.info/tlnet-archive/2024/04/24/tlnet
 
@DavidCarlisle go FAU! (@samcarter) :)
 
8:50 PM
@JasperHabicht well, when I create a new package (that's not written in L3) I search through TeXLive whether the prefix I want to use is already taken or not (as I did with expkv, which resulted in the three letter prefix ekv, so all commands start with \ekv).
@PauloCereda I fear it's too late for that :(
 
9:24 PM
@Skillmon next package, maybe a IoT one :)
 
9:42 PM
@PabloGonzálezL Karl just repeated what I said above, the error you show is a connection error not anything specific to any package. If you wanted to report a problem with epstopdf install you'd need to demonstrate it after fixing the connection issues
 
9:54 PM
@PabloGonzálezL ah what does type wget;type curl show ?
 
10:07 PM
Is Latin Modern now the default font, having replaced Computer Modern?
 
@LaTeXereXeTaL no, cm is the default in (pdf)latex opentype latin modern is the default in lualatex and xelatex
although even in (pdf)tex it's usually best to use T1 encoding so that's really the ec fonts not computer modern, although latex classifies them as T1 encoded cm
 
Ahhhhhh that explains why I've not seen CM in a very long time. I've used LuaLaTeX for a long time now.
 
@LaTeXereXeTaL since 2016:-)
2016-12-03  David Carlisle  <[email protected]>

	* ltluatex.dtx, fontdef.dtx: Add support for defaulting to TU encoding
 
@DavidCarlisle I didn't start using LuaLaTeX until 2020.
 
@LaTeXereXeTaL that's not "a long time" :-)
 
10:25 PM
@DavidCarlisle Seems like an eternity to me. I'm still a young'un.
 

« first day (4924 days earlier)      last day (30 days later) »