« first day (3625 days earlier)      last day (427 days later) » 

1:45 AM
@MagisterAdest not true
 
 
4 hours later…
5:22 AM
Hello everyone.
MikTeX has not been updated since September 6th. Is Christian Schenk experiencing a problem?
 
 
3 hours later…
8:27 AM
\documentclass{revtex4-2}
\begin{document}
\end{document}
Is this supposed to compile? ^^^
I get this right now
! Extra \endgroup.
\document ->\endgroup
                      \document@inithook \true@sw {}\UseOneTimeHook {begindo...
l.2 \begin{document}
@JosephWright @DavidCarlisle @UlrikeFischer
 
@HenriMenke do you already have the new revtex @PhelypeOleinik uploaded yesterday?
 
@UlrikeFischer I don't know. I just ran tlmgr update --self --all and there were no updates.
$ tlmgr info revtex | grep revision
revision:    49751
That doesn't look very new though.
I think TeXLive is currently in the 54000s.
The new hook management is nice but as far as I can see it broke way too much stuff.
 
@HenriMenke hi, mind if I ask you a LuaTeX-related question?
 
@PauloCereda I'm not an expert but sure.
 
@HenriMenke thanks, here it goes. :)
 
8:36 AM
@HenriMenke I can't check directly. But the error is known to happen with the new latex, and Phelype has worked with them to correct the class and uploaded yesterday.
 
@HenriMenke Context: tug.org/pipermail/tex-live/2020-September/046111.html we are investigating the possibility of getting runscript.tlu which uses texlua to kill subprocesses. Do you know if texlua ships with any library that could be used for this purpose? And speaking of which, I was wondering how could one find the list if libraries loaded with texlua. I only know lfs...
 
@PauloCereda The list of loaded Lua libraries is here: github.com/TeX-Live/luatex/blob/…
 
@HenriMenke ace! Thank you very much, Henri!
 
@HenriMenke a new revtex went to ctan, may just be a timing error in the update
 
@AndréC I don't know, why there are no updates currently. You could ask in the github issue tracker.
 
8:47 AM
@PauloCereda Regarding the process interface, I have no idea. If there is something it's definitely not built-in. Python has psutil which could serve as an inspiration.
 
@HenriMenke thanks, that is surely useful!
 
@PauloCereda I guess you could use ffi to call standard library functions in the Windows Standard C Library but that will require --shell-escape and is of course platform-dependent.
 
@HenriMenke hm interesting. We were inspecting teratronik.org/core4/Core4Event/event/spawn.html for inspiration...
 
@PauloCereda “GenerateConsoleCtrlEvent sends a specified signal to a console process group that shares the console associated with the calling process.”
@PauloCereda But honestly, I'm just bullshitting here. I have never coded anything for Windows.
 
@HenriMenke cool, we will check. :)
 
8:52 AM
@PhelypeOleinik revtex didn't go to ctan??
 
@HenriMenke we are in the same boat. The best option is to show a big modal dialogue with a "Get a better OS" banner. :)
 
@PauloCereda just wait until the wsl becomes the main OS backing up the Windows UI and you can use the linux version
 
@DavidCarlisle :)
 
@HenriMenke oh it seems the new revtex didn't go to ctan....
@PauloCereda if Apple can swap in a BSD unix based kernel without Mac users complaining. MS should be able to swap in linux
 
@DavidCarlisle ooh Darwin
 
8:56 AM
@PauloCereda they already have edge ...
 
@DavidCarlisle they could have Marmite
 
@PauloCereda I prefer duck to marmite in sandwiches
 
@DavidCarlisle @UlrikeFischer @HenriMenke The updated RevTeX did get to CTAN yesterday... I'm not sure why it didn't get to TeXLive
 
@DavidCarlisle oh no
 
@DavidCarlisle Let's see how long until they ship the coreutils.
 
8:58 AM
@PhelypeOleinik it does not show at ctan.org/pkg/revtex (last update 2019-01-19)
 
@DavidCarlisle Strange, because the version number is 4.2d (it was 4.2c before I updated)
 
@PhelypeOleinik oh but the actual filedates at ctan.org/tex-archive/macros/latex/contrib/revtex are newer, strange...
 
@PhelypeOleinik Karl forgot?
 
@PhelypeOleinik can you alert ctan, Karl, Mark and check, otherwise there are going to be lots of cross physicists mailing bug reports:-) (we could get @JosephWright to tell them to do chemistry instead)
 
@PauloCereda I'd say so... I'll write an angry mail :-)
 
9:01 AM
@UlrikeFischer I just did and I hope my question is not too awkward. github.com/MiKTeX/miktex-packaging/issues/194
 
@PhelypeOleinik It looks like there was no announcement for 4.2d/
 
@DavidCarlisle nah they are too busy doing physics stuff
 
@DavidCarlisle No need to blame @UlrikeFischer this time?
 
@PhelypeOleinik it is not essential, but usually that is recommended.
 
@HenriMenke Indeed. Though I did get the usual “thanks for this upload ... I've installed the new version and updated the catalogue repository”, so I didn't worry
 
9:22 AM
@JosephWright did you make any changes to the build scripts or l3build recently-ish?
 
9:32 AM
@PhelypeOleinik well it is on ctan, but perhaps Karl was too busy with latex and did overlook it. Should be sorted out tomorrow. People that get errors today should use the backup to get the older latex.
 
@UlrikeFischer The backup?
 
@PhelypeOleinik tlmgr has a backup system which allows you to revert a package installation. So they can deinstall the new latex.
@JosephWright @DavidCarlisle @PhelypeOleinik I must say I hadn't expected that skeyval would be the first package of this bundle to fail, my bet was on xwatermark or menukeys ...
 
@UlrikeFischer Oh, nice! I didn't know that
 
@PhelypeOleinik But I did see it in incoming.
 
9:47 AM
@UlrikeFischer Indeed! Not sure why the author insisted on reinventing the wheel if they could just use etoolbox's hooks...
@Skillmonlikestopanswers.xyz Me too, but apparently something got lost in the way
 
@Skillmonlikestopanswers.xyz No
 
10:04 AM
@JosephWright Then I'm really puzzled why l3build check in l3kernel doesn't work anymore for me :(
 
> Pringles had to use a supercomputer to engineer their chips with optimal aerodynamic properties. They're produced so quickly; they would fly off the conveyor belt if they weren't shaped just the right way.
ooh Pringles
 
10:19 AM
@PauloCereda source?
 
@PhelypeOleinik that's the "I can do it much better so let's rewrite and patch everything" virus. People getting this tend not to care about (future) compability.
 
Hey all =)
 
@UlrikeFischer do they just chop everything up with a sword and leave it in pieces?
 
@UlrikeFischer Ah, yes, this one:
tlmgr option autobackup 0
;-)
living dangerously
 
Btw Ulrike I was reading about xfp, and it seems it uses system time as a seed. I tried to google, and read the documentation. But how does one set a manual seed for xfp? =p
 
10:27 AM
@Skillmonlikestopanswers.xyz some twitter account. :)
 
@N3buchadnezzar why btw? I don't understand the context, but you should be able to set the seed with \sys_gset_rand_seed:n see interface3.pdf.
 
user image
2
@PauloCereda Some are into the real stuff ^^^
 
@UlrikeFischer oooooooh
 
@UlrikeFischer Thanks, that worked. I was able to find the documentation =)
I am generating exams for my students where the variables are somewhat randomly generated. I also calculate the answer using these variables. Thus, when grading I want to input the students seed to see if they have obtained the correct answer.
 
10:40 AM
user image
2
@UlrikeFischer ^^
 
Dont feed those after midnight btw.. ^^
 
@N3buchadnezzar ooh midnight snacks
 
11:04 AM
@PauloCereda thanks, marked for reading later :)
 
@PauloCereda aaaaaaah
 
@Skillmonlikestopanswers.xyz quack <3
@UlrikeFischer ooh
 
11:39 AM
@PauloCereda Cute selfie :)
 
@PhelypeOleinik I've pushed the changes because I'm a bit lost to be honest. Checks fail for github.com/latex3/latex3/pull/789, if I run l3build doc locally on my machine I get an exit code 1, but no error gets reported....
 
@samcarter_is_at_topanswers.xyz <3
 
@UlrikeFischer, @DavidCarlisle, @PhelypeOleinik tex.stackexchange.com/questions/565206/… :)
 
12:11 PM
I've been just bitten by the ! space-behavior of xparse with trailing optional argument --- didn't know it changed default somewhere between TL17 and TL19 ;-)
 
@Rmano yes, I had the same unpleasant experience a while back, when I collaboratively wrote some text with someone with an out of date TeX Live.
 
@Rmano ooops
@Rmano We had a reason
 
@JosephWright The reason was "users using xparse deserve no sympathy!"?
 
@Skillmonlikestopanswers.xyz It was tricky getting that behaviour right (conceptually): I think we did in the end, as for the e-type argument, but it did cause a few issues
 
@JosephWright Yes, I imagine (the new syntax is nice)
 
12:13 PM
@Skillmonlikestopanswers.xyz Well xparse is no more, really: it's just \NewDocumentCommand now
 
I just had a trailing d<> that worked ok in math when I remember to add a space before a <, and when I upgraded my Ubuntu yesterday started failing. It was just a matter of adding a !...
 
@JosephWright \NewDocumentCommand \foo { g u| } { ... }
 
12:33 PM
@Skillmonlikestopanswers.xyz I'll look in a bit
 
is token.create("float@count").mode really the best way to get the numeric value of \float@count (which is a \chardef defined token)
@Skillmonlikestopanswers.xyz g is evil and reserved for vim users
@UlrikeFischer where did we get to on lualatex-math? are we supposed to be updating the package to be a legacy stub now the patches are already in amsmath?
 
12:50 PM
@DavidCarlisle no the author wanted to do it. Did someone complain about the warnings?
 
@UlrikeFischer Denis, I just saw you are not watching that repo:-) github.com/phst/lualatex-math/issues/22
 
The new LaTeX format also broke the tex4ht build of the PGF manual: github.com/pgf-tikz/pgf/pull/931#issuecomment-703095360
 
@HenriMenke that a tex4ht general issue or specific to pgf, or not clear yet?
 
@DavidCarlisle Not clear yet, but the timely correlation with the LaTeX update is striking.
@DavidCarlisle The new LaTeX seems to be the next generation of the oberdiek chaos.
4
 
@HenriMenke oh I expect its the latex release but I just wondered if it is something in that document or a general tex4ht thing.
@HenriMenke You could have used the -dev release any time in last few months, not find out the day after the full release (and the oberdiek split went well and achieved its objectives so if this is the same then fine)
@HenriMenke we can not test against every third party package but we can and do make the -dev releases available as soon as possible to allow people to test against them and except for absolutely show stopping bugs we don't make functionality changes after the last -dev release before the full release.
 
1:16 PM
@DavidCarlisle So @JosephWright and @samcarter_is_at_topanswers.xyz are VIM users?
@PhelypeOleinik thank you :)
 
@Skillmonlikestopanswers.xyz dunno, but I am (a vim user)... ;-)
 
@Rmano hey, a sane person!
 
@Rmano ooh
 
@PhelypeOleinik Im sure ctan will want you to increase the version letter they really don't like updates at same version.
 
@Skillmonlikestopanswers.xyz Never :)
 
1:23 PM
@DavidCarlisle I had my hopes :-) <sigh>
@DavidCarlisle expl3 requires the pdfTeX primitives (\pdfstrcmp and such), and these don't seem to be available in Aleph. I think it needs the primitive catching-up update that was done in XeTeX
 
@samcarter_is_at_topanswers.xyz I'm sorry for you :)
 
@PhelypeOleinik but why does it appear now? didn't we use them previously?
 
@UlrikeFischer I think the 2020-02-02 release had expl3 conditionally loaded
 
1:47 PM
And the first angry physicist has arrived to tex.sx...
 
@PhelypeOleinik I added a comment.
 
@UlrikeFischer I saw. Thanks :-)
@UlrikeFischer It's surprising the amount of people with an up-to-date TL...
 
@PhelypeOleinik it is only one for now ;-). Handle you the update so that it is in texlive tomorrow and we handle the angry physicists.
 
@UlrikeFischer :-)
@UlrikeFischer Trying to convince l3build to make a bibtex TDS directory...
 
@PhelypeOleinik the oberdiek bundle ho-tex creates a bibtex. It has a long list of tds-locations in the build lua:
tdslocations={
"bibtex/bib/oberdiek/oberdiek-bundle.bib",
"bibtex/bib/oberdiek/oberdiek-source.bib",
"doc/latex/oberdiek/aliascnt.pdf",
 
1:57 PM
@UlrikeFischer Thanks, I'll look at that
 
@PhelypeOleinik yes except its dead code no one uses it, I think that it should build with --etex and we add some guards (or lambda.ini patches them in) just so expl3 stuff gets skipped, it only has to act like a latex format from circa 2000 if new fearures done work they dont work
 
@DavidCarlisle I think it has e-TeX, but not the pdfTeX stuff. It should be doable to have it pretend to work, but not much more than that with the hooks in place
 
@PhelypeOleinik it has it in the engine but as far as iI understand what the texlive 2019 fmtutil-sys is saying it didn't use it. Oh sorry it doesn't use --etex it uses the older * prefix so Ok it was built with etex.
@PhelypeOleinik hmm hooks. OK better take this back to team list I guess.
@PhelypeOleinik ctan as predicted:-)
 
@DavidCarlisle Ah, the * thingy. It would have been broken years earlier without e-TeX
@DavidCarlisle Your crystal ball is working great :-)
 
@PhelypeOleinik so long as it built it wouldn't matter if it didn't work as no one uses it
 
2:06 PM
@DavidCarlisle :-)
 
@PhelypeOleinik I may possibly have needed to do uploads of packages in the past... Possibly (if I had allowed @UlrikeFischer to add a typo at the last moment)
 
@DavidCarlisle you mean "redo" yes?
 
@UlrikeFischer yes
 
2:47 PM
@DavidCarlisle quack
 
3:04 PM
@PauloCereda tea time?
 
@UlrikeFischer ooh tea
 
I get so depressing spam currently - they are all offering help against snoring and crooked toes ;-(
 
@UlrikeFischer although most of my tea likings might not be considered tea after all. :)
@UlrikeFischer oh no
@UlrikeFischer I get academic boosting thingies
 
@PauloCereda I was recently awarded $20 million. Should I reply?
 
https://github.com/pgf-tikz/pgf/pull/931

\documentclass{article}
\begin{document}
The scope's contents is stroked\,/\penalty0\,filled
\end{document}

using `htlatex` with LaTeX2e 2020-10-01

! TeX capacity exceeded, sorry [input stack size=5000].

latexbug.sty complains about `tex4ht.sty` and `article.4ht`, but why does this break on new LaTeX2e?
 
3:19 PM
@egreg ooh yes
 
@HironobuYAMASHITA we add expl3, add xparse, completely re-define \begin and \end. So what is the incompatible change? making \, work as it has always worked in amsmath, TeX is weird sometimes...
@HironobuYAMASHITA I suspect that it is the usual issue with protected commands if you patch them saving the old copy with \let then you do not save what you think you saved. But I haven't traced yet,,,
@HironobuYAMASHITA bingo:
\,  ->\ifx \EndPicture \:UnDef \expandafter \n:, : \else \expandafter \o:, : \f
i

\n:, : ->\relax \ifmmode \csname a:,\endcsname \else \thinspace \fi

\thinspace ->\ifx \EndPicture \:UnDef \expandafter \n:thinspace: \else \expanda
fter \o:thinspace: \fi

\n:thinspace: ->\relax \ifmmode \csname a:,\endcsname \expandafter \:gobble \fi
 \o:thinspace:

\o:thinspace: ->\x@protect \,\protect \,

\x@protect #1->\ifx \protect \@typeset@protect \else \@x@protect #1\fi
#1<-\,

\,  ->\ifx \EndPicture \:UnDef \expandafter \n:, : \else \expandafter \o:, : \f
 
@HironobuYAMASHITA Apparently, the internal version of \, becomes \o:thinspace, which expands to the internal version of \,. Infiinite loop.
 
@DavidCarlisle ooh bingo
 
@DavidCarlisle I guess that this has to do with the change in the definition of \, that is not taken care of in TeX4Ht
@HironobuYAMASHITA The new kernel has adopted the definition of \, of amsmath. And this is the cause of the trouble.
 
3:37 PM
Oh thanks. it seems that reported to tex4ht ml: tug.org/pipermail/tex4ht/2020q4/002735.html
 
4:03 PM
A commentary by the authors of Learning LaTeX has been published by SIAM News. It ends with "our predictions for future LaTeX breakthroughs, leading up to the release of LaTeX3 in 2051." @yo' -- take a look at what is predicted for 2029.
7
 
user image
2
A visual representation of LaTeX guards? :)
 
@PauloCereda -- Looks like a good candidate for a little later. Now, I'm working on my next TUGboat column. (You should read the item I just posted about "Learning LaTeX". You might get some ideas about things that can be sabotaged.)
 
4:24 PM
@PauloCereda Hola don cuak, como va tu día?
 
@PabloGonzálezL olá señor Pablo! Muy bien, gracias. E tu dia? :)
 
@PauloCereda Actualizando TeX Live :-)
 
@PabloGonzálezL ooh risky
 
@PauloCereda Y fedora :-)
 
@PabloGonzálezL ooh usando sombreros :)
 
4:27 PM
@PauloCereda Jejje, now that I'm in the process of updating, .... arara 6.0 will come out this 2020?
 
@PhelypeOleinik somehow there seems to be an error while the formats are generated (but no visible error is thrown). l3build skips building all the format except for the pdfTeX one, and that one seems to not be fully generated (it seems to be too fast).
@PhelypeOleinik the error is somewhere in the code of \@@_act:NNNnn, but I haven't found it yet.
 
@PabloGonzálezL probably TL 2021. :) We are making some drastic changes. This will be more of a transition version for something new we plan for 7.0 and 8.0, hopefully.
 
@Skillmonlikestopanswers.xyz Ah, errors during format generation are tricky :-)
 
@PhelypeOleinik yes, I'm currently digging through it :)
 
@Skillmonlikestopanswers.xyz Sorry, couldn't look yet. Trying to get RevTeX right
 
4:29 PM
@PhelypeOleinik no problem, that one has priority. I was on a long walk and haven't looked much myself yet.
 
@PauloCereda Great ... to all this, on the way you'll get some rule updates?
@PhelypeOleinik Hola :-)
 
@Skillmonlikestopanswers.xyz And then @HironobuYAMASHITA found out that I broke BibTeX :-)
 
@PabloGonzálezL Yes, definitely. Any suggestions?
 
@PabloGonzálezL Hello :-)
 
@HironobuYAMASHITA :( I feel a patch level release
 
4:29 PM
@PhelypeOleinik ooh.
 
@Skillmonlikestopanswers.xyz ooh
 
@PauloCereda dvisvgm and .xdv suport
 
@PauloCereda notice the period, I'm still unique :)
 
@PauloCereda That matt bloke would be impressed :-)
 
@PauloCereda And a rule for pdfcrop :)
 
4:32 PM
@PhelypeOleinik I think I've found the issue, it is strikingly stupid... :) I'm trying to pre-expand \tl_if_head_is_group:nTF to save that one expansion step, 500 lines before it is defined.
 
@PhelypeOleinik How are you, I'm trying to reinvent the wheel using expl3 and \list
 
@DavidCarlisle we could add a patch to firstaid ;-). Removing the quotes work (they look quite unneeded, and I thought we had discussed that they shouldn't be there). But bibtex will not work if the filename contains spaces.
\documentclass{book}
\usepackage{etoolbox}
\makeatletter
\patchcmd\@include{\@input{"#1.aux"}}{\@input{#1.aux}}{}{\fail}
\makeatletter
 
@PhelypeOleinik but instead of printing that undefined cs error during format creation, LaTeX aborts it and boom my issue strikes, testing new l3debug against the old format.
 
@Skillmonlikestopanswers.xyz Most are stupid. I know the feeling :-)
@Skillmonlikestopanswers.xyz But is one step really worth it?
@PabloGonzálezL I'm trying to fix the wheels that I broke
 
4:35 PM
@PhelypeOleinik depends on the length of the token list being processed. That one expansion step has to be done for every item in the token list (except if the head is a space).
 
@PhelypeOleinik :D
 
@PhelypeOleinik Nothing like an afternoon at 'git' for fun :-)
@PauloCereda Great :) I tried to "automate" the compilation of some nice examples in the forum using 'arara+dvisvgm'
 
@UlrikeFischer Hm... You're right, they do look useless there. BibTeX not coping with spaces is a shame (and understandable :-)
 
@PabloGonzálezL ooh
 
@Skillmonlikestopanswers.xyz Ah, well, quite often then...
@PabloGonzálezL Oh, I see what you did there ;-)
 
4:39 PM
@UlrikeFischer spaces...
 
@PhelypeOleinik I had two other such errors... \group_align_safe_begin: and ...end: are also undefined when l3tl is run (they are in l3prg which comes later in the list).
 
Here we go
Jan 21 '14 at 12:33, by David Carlisle
@NicolaTalbot people who put spaces in filenames deserve no sympathy.
 
@PauloCereda To that I would add those who use "paths with spaces "
 
Jul 18 '19 at 22:37, by David Carlisle
@UlrikeFischer but if we remove them, space-less filenames like cat work again and filenames with spaces deserve no sympathy can be fixed as needed.
We can go on and on :)
 
@Skillmonlikestopanswers.xyz Ah. Yes, at the beginning of expl3 timing is tight. I had to do some weird gymnastics to get l3quark before l3tl. l3tl is used everywhere
 
4:43 PM
@PhelypeOleinik drat, I read quack
 
@PauloCereda They are a problem, whether you use TeX or another language...I blame windows for allowing them and generating this habit
 
@PauloCereda \quack_loudly: :-)
 
@PhelypeOleinik ooh noises
@PabloGonzálezL :)
 
5:01 PM
@UlrikeFischer see also email
 
@DavidCarlisle ooh
 
@PabloGonzálezL like Program Files
 
@DavidCarlisle What I hate in Windows more than spaces in file names, is that it likes to translate folders, for whatever reason. It shows you Arquivos de Programas, but the folder is actually called Program Files
People who use translated software deserve no sympathy
 
@DavidCarlisle exactly! No sympathy for people using things in Program Files!
 
@PhelypeOleinik Linux does that as well (well, window managers)...
 
5:05 PM
@PauloCereda you have mail
 
@PauloCereda not mine.
 
@DavidCarlisle oh no
 
@PauloCereda if you forward it to me we have chainmail!
 
@PhelypeOleinik for some reason it never does that for me.
 
@Skillmonlikestopanswers.xyz ooh
 
5:06 PM
@PauloCereda Ouch!
 
@DavidCarlisle I think the space outside is okay. It only matters that there is a space isn't it?
 
@Skillmonlikestopanswers.xyz done
 
@DavidCarlisle If I were english I wouldn't have that problem :-)
 
@UlrikeFischer yes I'd not considered that the {...} would then be dropped by tex's argument parser so not cause issues
 
@PhelypeOleinik Mac behaves like Windows. Thankfully the command line shows the English names... :)
 
5:07 PM
@DavidCarlisle wouldn't is translate a folder "color"?
 
@PauloCereda Ugh... That's an awful (and useless) design choice, if you ask me. Changing the name of 8 folders in the OS is just an awful lot more of programming just to confuse the user
 
@PhelypeOleinik Agreed. At least, in Linux, the names are properly localised, not just "symlinked". In Linux, my Downloads folder is referenced as /home/paulo/Downloads which is fine. In my Mac, /Users/paulo/Downloads goes as Transferências, which is annoying.
Ouch, Linux, not Windows. :)
 
@PauloCereda thanks, had a good laugh because of the important contents.
 
@Skillmonlikestopanswers.xyz <3
 
@PauloCereda Ugh. I wonder, nowadays, how many people here in Brazil would recognize “Downloads” better as “Transferências”. Maybe a decade or so ago, but not now
 
5:16 PM
@PhelypeOleinik People don't use computers anymore, just phones. :)
 
@PauloCereda There's that :-)
@PauloCereda But phones have “Download” written somewhere, don't they? Or is it just mine that is Portuguese allergic?
 
@PhelypeOleinik Downloads, alright. It's the Android default folder. :)
@PhelypeOleinik it boils down to your primary linguistic source: Houaiss/Aurélio or dicionarioinformal.com. :D
 
@PauloCereda Bah :-)
 
@PhelypeOleinik :D
 
@PauloCereda that's never been a problem for me as I always have an X server running on the machine anyway:-)
 
@DavidCarlisle :)
 
@PauloCereda not quite same thing though, like running X on Macs isn't really the full experience
 
@DavidCarlisle fan of cygwin detected :-)
 
@PauloCereda anyway I don't want X I say bring back NEWS that was a fun windowsystem, you could specify the shapes of windows using PostScript
did anyone else use NeWS ?
 
6:14 PM
Still failing checks :( This time it fails in contrib at test ctex002 due to some font loading (travis-ci.org/github/latex3/latex3/jobs/732553397#L1753)
 
6:38 PM
@Skillmonlikestopanswers.xyz for me it failed first, because luaotfload had to create a cache file, the second time it worked fine. I wonder how to setup this correctly on travis. I think one should check checkruns.
 
@JosephWright \q__tl_act_stop must not be part of the 5th argument to \__tl_act:NNNnn. The current implementation might gracefully ignore if it is as long as there is no \q__tl_act_mark contained in the argument before it (as that is currently used as the end-of-recursion mark). My faster implementation instead uses {\q__tl_act_stop} as the end marker. However, if I can assume that it is never part of the argument, I could pre-expand the first loop iteration. [...]
[...] this would only be less robust if \q__tl_act_stop followed by a space is part of the 5th argument.
@UlrikeFischer so what should I do to get my current commit marked as fine? :)
 
6:54 PM
@JosephWright just took another look, and no, both would result in undefined behaviour as soon as \q__tl_act_stop is part of the argument. So I guess it is fine to just result in different undefined behaviour... :)
 
7:28 PM
@Skillmonlikestopanswers.xyz try to add checkruns=2 to the build.lua of the config folder.
 
@UlrikeFischer or just push another commit... :)
 
@Skillmonlikestopanswers.xyz hm, I don't know how the luatex cache is handled on travis, try it out.
 
@UlrikeFischer Currently doing, have to wait for the test suite to run.
@UlrikeFischer and it works and hopefully breaks upon someone else next time :)
 
 
2 hours later…
9:11 PM
@DavidCarlisle Wasn't that the one in the NeXT workstation? When I was a slave PhD student there were rumors that somebody got one in the department...
 
@Rmano no (I think they used Display Postscript) NeWS was on Suns (mostly)
 
hello!
I'm having a hard time with MikTex. I'm trying to create my own package (i.e., a package.sty file) and I'm trying to make TexStudio include my package definitions since the commands are all in red (even if it compiles)
 
@LucasHenrique that is not a miktex but a texstudio problem.
 
Apparently I have to make my own TEXMF directory to then add my package and, after that, update the MikTex database to finally get TexStudio working
@UlrikeFischer oh.
Do you have any idea on how I can get TexStudio to work?
 
9:28 PM
@LucasHenrique i don't use it much, perhaps this tex.stackexchange.com/questions/534403/…
@DavidCarlisle I guess the tikz problem is the same as here tex.stackexchange.com/a/492987/2388
 
thank you!
 
 
1 hour later…
raf
10:52 PM
I want to add vector graphic image in latex file. According to graphic quality which format is better to use as a figure? PDF or PDF_TEX?
 
@raf ? PDF is fine. What's PDF_TEX?
 
raf
@AlanMunn Check here: almost everyone is telling there to convert SVG to PDF_TEX. But I think the PDF file itself is giving me a satisfying output. That's why I want to know which one is best in the graphic quality. tex.stackexchange.com/questions/2099/…
562
Q: How to include SVG diagrams in LaTeX?

Martin TapankovI'm making all my diagrams in SVG format using Inkscape and then I export them to some other format (e.g. PDF, EPS or PNG). I wrote a short script that does this for me automatically, but I'd like to avoid this step, if possible --- sometimes the conversion from SVG converts the text labels into ...

 
@raf I see. That method generates TeX code which is then \input into the source document. I don't see that there would be any substantial differences, (and one question points to some downsides). I would just use PDF directly.
@raf But that question is specifically about SVG to PDF. If you can already generate PDF directly then use that.
 
raf
I have used Geogebra to generate the SVG. then convert it to PDF using Inkscape.
I can directly generate the PDF in Geogebra. When I do so, it's giving an unwanted extended view in PDF. That's why I am using Inkscape to convert SVG to PDF.
But, I wonder why is there no simple way to insert SVG directly in latex as we can do with PNG, PDF etc.?
 
11:15 PM
@raf Have you tried the second answer there: use the svg package and import directly?
@raf Although it's not really directly, it just does conversion behind the scenes.
 
raf
@AlanMunn I haven't tried it. But it seems a bit problematic to a Miktex Windows user like me.
@AlanMunn Yes. You are right.
 
@raf Maybe so. I use TeXLive on a Mac, so don't have such problems. :) But both of those answers are very old, and the svg package is still maintained. It has extensive documentation. texdoc.net/pkg/svg
@raf So maybe things have gotten better for Windows users.
 
11:34 PM
@AlanMunn @raf and texdoc.org/pkg/svg - that one is testing a newer texdoc online engine and is running the latest TL, so with svg 2020/06/23
 
raf
I am trying to run the Example code of section 4 page 11:  texdoc.net/pkg/svg
It's showing this error:
 ! Package svg Error: File `fig1_svg-tex.pdf' is missing.See the svg package documentation for explanation.Type H <return> for immediate help.... \includesvg[width=\linewidth]{fig1}
here, fig1 is SVG file.
 

« first day (3625 days earlier)      last day (427 days later) »