« first day (3372 days earlier)      last day (29 days later) » 

2:26 AM
@DavidCarlisle If you are still awake ... I have sent a PR to the hyperref repository :)
 
 
5 hours later…
7:05 AM
Yay, expkv is now part of TeX Live and MikTeX.
@JosephWright how'd you work on that TUGboat article?
 
7:56 AM
> Mars Rover Is Frozen In Place Following Software Error
@DavidCarlisle ooh
@DavidCarlisle ooh
 
8:24 AM
@PauloCereda Rover Over? ;)
@Skillmon I'm getting some notes sorted, once that's done, I'm flexible on approach
 
@JosephWright ooh :)
 
8:37 AM
user image
4
 
@JosephWright the empty ctan announcement diff looked OK to me but I pushed it to a branch rather than master
 
9:28 AM
@Skillmon Dropbox, Overleaf, OneDrive, by email ...
 
circuitikz 1.0.0-pre2 is on CTAN. I'd like to release 1.0.0 on 20200204, so if somebody uses it, please test...
It is considered "strange" to add a dedication in the manual for a release like that one?
 
 
4 hours later…
1:57 PM
Hello @PauloCereda ,

In my question https://tex.stackexchange.com/q/525428/2288, is it possible to use the method "changed" for looping over the files returned by listFilesByExtensions?
@PauloCereda
The error I get probably shows that I need to embed listFilesByExtensions in a rule instead of using it explicitly.
However, if I can use it explicitly as I proposed without creating a new rule, it would be much better for me.
 
2:47 PM
Stupid week. Three people I knew have died this week. Presumably all to cancer. Two of them 10 years younger than me. Unfair world
 
yo'
@daleif :-(
also several public figures :-(
 
@yo' In case I'm not up to date, which?
 
yo'
@daleif Terry Jones, and then a good Czech politician (a guy you need not agree with, but you'd respect him for who he is and what he achieved)
 
@yo' ahh yes, I forgot about Terry
 
yo'
and a very good Czech pastor and university professor, one of world's biggest brains on the Old Testament
 
3:19 PM
Quick question for the TeXperts on LaTeX conditionals: I'd like to be able to call a particular command I'm making with a "string" as the second argument, \foo{text}{default}, or \foo{text}{extended}, and have some content conditionally expanded based on the value of that argument, e.g. \if #2 is "default" \then { code1 } \else { code2 }. Does anyone know if there's a nice, non-deprecated way to do this? For example, in etoolbox?
 
@COTO loads of ways but etoolbox has \ifstrequal see the "string tests" section of the manual.
 
Would that be \ifstrequal{#2}{default} for "default", etc.?
I guess I ought to dig up the manual.
 
@COTO \ifstrequal{#2}{default}{yes}{no}
 
Thanks. You guys are a great help. :)
 
@COTO texdoc etoolbox is a useful command:-)
 
3:24 PM
Never heard of texdoc. I'll try it out. Thanks.
 
@DavidCarlisle But that brings up the... documentation. Didn't you mean kpsewhich? ;-)
 
@COTO now you would have known about it if you had done texdoc texdoc to read its documentation:-)
@PhelypeOleinik er well that's what I did first but that's a secret
 
@DavidCarlisle Oh :-)
 
3:48 PM
any miktex users around? where is epstopdf-sys.cfg ?
 
@DavidCarlisle Hmm. can't spot one
 
@JosephWright I'll update epstopdf-base.sty not to require a cfg it shouldn't be mandatory anyway.
 
@DavidCarlisle we are still an hour away from home
 
@UlrikeFischer OK I will just post an answer blaming you.
 
@DavidCarlisle which question?
 
4:00 PM
0
A: Undefined control sequence in TeXstudio even after bugfix

David Carlisleepstopdf-base currently assumes the presence of a file epstopdf-sys.cfg which sets up a system command to to the external conversion of the EPS files to PDF. In texlive this is /usr/local/texlive/2019/texmf-dist/tex/latex/latexconfig/epstopdf-sys.cfg but apparently miktex does not set this de...

 
@DavidCarlisle just found it. I can look when I'm home.
 
@UlrikeFischer the package is bad anyway, it should not leave the command undefined if there is no cfg file, the cfg should only be optional customisation
 
@DavidCarlisle yes, but I would like to check if the problem in MiKTeX is new.
 
@UlrikeFischer yes I'll update at github but not do anything about pushing to ctan until you've had time to get home and cook a duck or whatever for dinner
 
4:15 PM
@DavidCarlisle we are coming from Switzerland. Sobrought cheese with us and will have a fondue and harm no duck. ;-)
 
@PauloCereda -- That's like "if you're in a group running from a bear, you just need to run faster than everybody else."
 
@DavidCarlisle: Me again. I'm using code \draw [...] (0,0) -- {\ifstrequal{#2}{forward}{(0.5,0.5)}{(0.6,0.4)}} -- (1,1); and TiKz is complaining that it can't parse the coordinate. In actuality, the (0.5,0.5) and (0.6,0.4) are more complex expressions such as \constA*\constB+\constC, etc., but the error occurs even when the coordinates are hard-coded. Any ideas? Do I have to move the conditional inside the ( and ) and use two identical conditions?
To clarify, I mean: Do I have to write (\ifstrequal...{0.5}{0.6},\ifstrequal...{0.5}{0.4}) as a coordinate?
 
@COTO ifstrequal doesn't work by expansion, you could pull it outside the draw or if tikz allows expandable macros there (I'm not sure) then you could use an expandable test like \ifnum\pdfstrcmp{#2}{default}=0 yes \else no\fi instead
 
By "pulling it outside the draw", do you mean something like \let{\mycoordinate}{(coordinate expression)} before \begin{tikzpicture} and then using \mycoordinate as a stand-in for the coordinate inside the tizkpicture environment?
 
4:39 PM
@COTO you could define a named coordinate in your test and use that in the draw command.
 
Ah. Remind me again, is the syntax coordinate [coordinate_name] <definition> and then the use is (coordinate_name)?
 
4:52 PM
Hm. Still no luck. I'm using \coordinate (mycoord) at \defmycoord{#1}{default}; and have a macro defined \newcommand{\defmycoord}[2]{\ifstrequal ...}. No errors, but TiKz doesn't render the lines at all. Likewise with \newcommand{\defmycoord}[2]{\ifnum\pdfstrcmp...}. I'll keep trying.
 
@COTO you should probably make your own question on the site instead. It is not clear at all what you are trying to do and might even not be worth the trouble.
 
@daleif: I'll do that.
 
5:22 PM
@UlrikeFischer I do wonder if it got deleted along with hyperref.cfg, they are in the same directory in texlive....
 
5:41 PM
@COTO I'm in a car (not driving!) now on a phone, but I think that no \if works in a path-like command. You have to resolve it before, probably with an edef, and then use the resulting macro.
 
6:11 PM
@UlrikeFischer I'm going to hit the slopes for the weekend - crossing!
 
6:48 PM
@DavidCarlisle I don't think so, I get the error too and I haven't updated miktex in the last two weeks, so it got lost earlier, perhaps when epstopdf was splitted. Curious that nobody reported it until now. But your fix \makeatletter \def\epstopdf@sys@cmd{repstopdf} \makeatother doesn't work for me. I need epstopdf instead of repstopdf. So probably an issue for miktex is needed.
 
7:10 PM
Just an update for all parties: It turns out that the combination of: 1) wrapping the conditional coordinate in an \edef, 2) using the \ifnum\pdfstrcmp... version of the condition, and 3) using the edef'd macro inside the TikZ path (defining a coordinate and then using the coordinate doesn't work), everything works out.
However, I also realized that a better way to do this was to define separate macros for the conditional coordinate, e.g. \mycoorddefault, \mycoordforward, and then use \edef\mycoord{\csname mycoord#2\endcsname{#1}}, which not only eliminates the need for the condition, it allows the second argument to function like a switch statement rather than a simple if-else, which is much better from an abstraction standpoint. Hence issue solved and thank you all once again for your help. :)
 
7:27 PM
@UlrikeFischer also nothing sets repstopdf at all (in epstopdf or epstopdf-base) , so I couldn't really see why epstopdf works and -base not.
 
7:46 PM
@DavidCarlisle epstopdf-base does program@epstopdf=epstopdf but only if keys can be set (so if kvoptions is loaded, actually loading kvoptions somewhere is enough to get miktex working again).
 
8:31 PM
@UlrikeFischer yes but why doesn't setting the command directly work, im confused
 
@DavidCarlisle because you are setting it to repstopdf, but miktex only has epstopdf.
 
8:54 PM
@UlrikeFischer ah... so we need a site wide customisation I suppose I can invert it, set it to epstopdf before calling the cfg files so the texlive one can set it to repstopdf
@UlrikeFischer has something changed at miktex or has this not worked for a while?
 
9:11 PM
@UlrikeFischer OK I have set it to epstopdf, so now relies on the texlive cfg to make it default to repstopdf there.
 
@DavidCarlisle I suspect that removing the dependency on kvoptions is the change. Before MiKTeX simply got the default epstopdf and was happy with it.
 
@UlrikeFischer the last checkin should restore the default being epstopdf in the absence of a cfg so hopefully that fixes things
 
9:35 PM
seems to work fine. But with miktex I get a warning `PDF
inclusion: found PDF version <1.7>, but at most version <1.5> allowed`, it looks as if its epstopdf is creating a higher version than the default settings.
 
@UlrikeFischer well that's a miktex consistency thing, if it is shipping an epstopdf defaulting to 1.7 then it ought to set 1.7 as the level in pdftex.cfg man epstopdf in texlive's version says it makes 1.5
@UlrikeFischer is what I say true? tex.stackexchange.com/questions/525546/…
 
9:50 PM
@DavidCarlisle yes I think too that this requires an actualtext.
 
@UlrikeFischer thanks
@UlrikeFischer should I push the epstopdf change to ctan or is there more to check?
 
@JosephWright do you think I should've done a \detokenize on the key-names in expkv? For performance reasons I just \csname them currently.
 
@DavidCarlisle It looks ok to me. I just compared the two branches (the one with the keyval and the other and appart from the command setting I don't see another difference that could matter. Why did you put the default after the \InputIfFileExists? Why not simply \def\epstopdf@sys@cmd{epstopdf} before loading the cfg?
 
10:06 PM
@UlrikeFischer I did that first but worried if a user epstopdf.cfg has \newcommand\... which would fail, it was set after prevously (via the kv interface) as far as I can see
@UlrikeFischer never actually tried accsupp before but...
\documentclass{article}

\usepackage{accsupp}

\begin{document}


a \BeginAccSupp{method=hex,unicode,ActualText={021A}}Ț\EndAccSupp\ b



\end{document}
 
@DavidCarlisle \EndAccsupp has an argument (don't ask me why). If I use \EndAccSupp{} then with Adobe Reader the copy and paste is as expected:a Ț b. Sumatra seems to ignore it
 
@UlrikeFischer thanks
 
11:06 PM
@UlrikeFischer Ina's installed epstopdf-pkg
 
@DavidCarlisle ;-). And I just got the luaotfload tests to pass again (travis doesn't like font calls by name).
 
@UlrikeFischer that's cheating (removing failing cases from tests:-) you should be able to set up fontconfig (oh does harfbuzz still use fontconfig in its luatex version or is it using the normal luaotfload lua font data? I suppose I ought to know these things....
 
@DavidCarlisle The tests didn't fail, but the documentation didn't compile - one of the example didn't find a font.
 
@DavidCarlisle luaotfload always uses it's own system for finding fonts, fontconfig is only used with XeTeX.
 
@MarcelKrüger hmm so why doesn't name lookup work?
@UlrikeFischer who reads documentation anyway:-)
 
11:15 PM
@MarcelKrüger but somehow on travis is works differently. The builds were failing all the time, it only worked after I switched to file name for the noto sans bengali.
@MarcelKrüger and before I forget it: I try to setup a multiscript example with uppercase letters (CyrlGrekBeng) and the code didn't like it. (I try to avoid underscore as they seem to be active and sometimes breaks the examples).
@DavidCarlisle one doesn't write docu so that someone can read it, but so that one can say that it is in the documentation ;-)
4
 
@UlrikeFischer Are you trying to use Cyrl etc. as keys in the dictionary defining the multiscript fonts or somewhere else?
 
11:33 PM
@MarcelKrüger no if I remember correctly the name CyrlGrekBeng for the multiscript was the problem. I will try to make an example tomorrow.
 

« first day (3372 days earlier)      last day (29 days later) »