« first day (3183 days earlier)      last day (62 days later) » 

zhk
5:37 AM
Hi everyone
How to input this in latex?
 
6:35 AM
@zhk to replicate that exact picture you could do
\[\def\arraystretch{1.8}
  \left(\begin{array}{c}
    \text{rate of mass}\\
    \text{accumulation}
  \end{array}\right) =
  \left(\begin{array}{c}
    \text{rate of}\\
    \text{mass in}
  \end{array}\right) -
  \left(\begin{array}{c}
    \text{rate of}\\
    \text{mass out}
  \end{array}\right)\tag{2.7}
\]
with \usepackage{amsmath} for the \text command
 
zhk
6:53 AM
@texdr.aft Thx
 
You're welcome
In the "breaking paragraphs into lines" paper, a book called "the art of spacing" is mentioned and described as having "probably the most beautiful spacing ever achieved in any typeset book"
Here is the first page of that book:
and the second:
 
zhk
ok thx
 
@zhk i'm sharing this with everyone; I didn't mean it as a response to you
anyway, as one can see, there isn't a hyphen in sight (and not just on the first two pages but in the entire book) and there are no loose lines (this is also consistent throughout)
 
zhk
@texdr.aft I want to have a continue equation numbers
tag is not a solution for my problem here
 
@zhk then use \begin{equation} instead of \[
 
zhk
7:04 AM
OK Thx
 
@zhk it's helpful if you use the reply feature so people can see the various threads in chat (use the menu on the left, or the arrow thing at the far right of the comment that you are replying to)
 
7:42 AM
@DavidCarlisle Hmm
 
@JosephWright more generally how do we plan to manage the ctan dev area, will we upload modified versions of packages if modifications are needed so they end up in the texlive latex-dev tree?
 
@DavidCarlisle This is a tricky one
@DavidCarlisle We are back with the problem that as LaTeX2e stayed unchanged for a long time, things are not 'all in one place' (contrast L3 code, which starts off knowing about spaces-in-filenames, so everything 'just works')
@DavidCarlisle I guess we have little option for this case
@DavidCarlisle, @UlrikeFischer At present I'm trying to solve the 'use an upated format' issue without having to re-write everything
 
8:04 AM
@DavidCarlisle in the specific case of epstopdf it would be probably the best if it moves from oberdiek to tools or graphics or some other "latex" folder. In general I would say that it should be handled as every other package writer has to handle code depending on the latex version: with latexrelease and similar switches.
 
@DavidCarlisle, @UlrikeFischer Hmm, kpswhich -engine=pdftex pdflatex doesn't respect TEXINPUTS ...
 
@UlrikeFischer That has occurred to me before as well...
 
@UlrikeFischer Sounds like a plan: should go into graphics
 
@JosephWright looking for the format file?
 
@DavidCarlisle Yes
 
8:09 AM
@JosephWright @UlrikeFischer I looked at this before, it would be good if latex/graphics was more or less self contained and didn't rely on contrib (as it was originally:-) but epstopdf, even epstopdfbase isn't really like that
\RequirePackage{infwarerr}[2007/09/09]
\RequirePackage{grfext}\relax
\RequirePackage{kvoptions}[2007/10/02]
\RequirePackage{pdftexcmds}[2007/11/11]
 
@DavidCarlisle I'm trying to set up the dev branch so it uses the 'live' latex.ltx-based format
@DavidCarlisle Ah, right, of course
 
It pulls in the full stack, of course if we pulled in expl3 hasd a secret plan, we wouldn't need any of those, so it's a matter of how many times we want to do major structural changes....
 
@DavidCarlisle Good point
 
@DavidCarlisle yes, that's the old problem ... we should switch to l3graphics (or is it l3image now?).
 
@DavidCarlisle OK, plan B it is
@UlrikeFischer 'Yes': really, I am serious
 
8:11 AM
@JosephWright team mail?
 
@DavidCarlisle Sounds like a plan
@DavidCarlisle Probably then we just 'force' past this, using a locally-installed fixed version to build the docs
@UlrikeFischer, @DavidCarlisle, @egreg, @PhelypeOleinik Have you seen river-valley.com? Comments on L3 in particular?
@PhelypeOleinik This is new .. like @PauloCereda said, we could do with a team ping ;)
@UlrikeFischer, @DavidCarlisle Back to my fmt problem: is there a variable for this you know of? Or is this one for the TL list?
 
@JosephWright I would do this, but the epstopdf problem is not only about the doc, it breaks in normal documents, so it must be fixed somehow too.
 
@UlrikeFischer Yeah, but we can do a dev release of the oberdiek bundle, no?
@UlrikeFischer Plan C: yank epstopdf out of the oberdiek bundle, release it on it's own?
 
@JosephWright TEXFORMATS ? TEXFORMATS = $TEXMFDOTDIR;$TEXMF/web2c{/$engine,}
@JosephWright yes (actually I have a branch under oberdiek that I never dared release that split the whole thing up into a dozen different bundles
 
@DavidCarlisle Looks good
@DavidCarlisle Getting there ...
 
8:17 AM
@JosephWright if needed we can certainly release an oberdiek version, but the first step is to correct the code.
@JosephWright that was my suggestion not Paulo's ;-)
 
@DavidCarlisle, @UlrikeFischer I think I can solve all of the other issues without a complete reworking of l3build typesetting: I'm pretty sure a few config adjustments will let me create and find pdflatex.fmt. So then we just have the epstopdf issue
@UlrikeFischer Ah, right
@DavidCarlisle, @UlrikeFischer Ooh, think it might be working :)
 
@JosephWright It works for me if I do
\def\ETE@Gin@setfile#1#2#3{%
  \edef\Gin@base{\expandafter\unquote@name\expandafter{\expanded{\Gin@base}}}%
@JosephWright to remove the quotes (in general it would need putting quotes back later but as theer are no spaces in filenames in core distrib that nit needed immediately)
@JosephWright which means actually we could do that more or less anywhere and so not need to uodate epstopdf to build rotex.pdf
 
@JosephWright I'm holding my breath ;-)
 
@UlrikeFischer Running the CTAN target in graphics ...
@UlrikeFischer Right, fixed
@DavidCarlisle, @UlrikeFischer, @egreg, @PhelypeOleinik Will build LaTeX2e dev for CTAN now ... just have to force past the UTF-8 command line business
 
8:48 AM
@DavidCarlisle it works for me too, also in the current latex, (if I provide a definition for \unquote@name). But the change must be either in the sty or in \AtBeginDocument.
 
 
1 hour later…
10:10 AM
@UlrikeFischer, @DavidCarlisle Mumble, luaotfload changes showing up in tests, have to fix that ...
 
@JosephWright changes in missing chars?
 
@UlrikeFischer Yup
 
@JosephWright sorry ;-)
 
@UlrikeFischer It's OK
@UlrikeFischer Waiting to see if Travis-CI is happy before I even bother to try a full build run
 
@JosephWright uff. Which reminds me that I should check if the reversion in pgf repaired the broken test in expl3.
 
11:12 AM
@UlrikeFischer Huh?
 
@JosephWright my commit (where I changed a typo) in the expl3 master didn't pass on travis, and I think it was because pgf broke xetex just on this day. But I can't simply restart the build, I think I'm not yet correctly logged in for this.
 
11:29 AM
@UlrikeFischer Ah
 
Someone posting illegal things in my room: https://chat.stackexchange.com/rooms/87082/holy-secret-room-no-entry.

Is it ok?
 
@GoldDiggingProgrammer Flag them
 
@JosephWright: I did. And another admin already deleted the prev links. But he posted new ones again. Thank you!
 
@GoldDiggingProgrammer Keep flagging: builds up data on a pattern of behaviour
 
@JosephWright: OK.
 
11:41 AM
@JosephWright hmmmmmmmmmmm
 
12:02 PM
@PauloCereda h\romannumeral14000
4
 
@DavidCarlisle ooh
 
@PauloCereda ooh would have been more fitting in the context of patterns.;-)
 
@UlrikeFischer indeed :)
 
1:00 PM
I wonder if Tom Rokicki will answer the last message in texhax?
 
@DavidCarlisle :)
 
@DavidCarlisle ;-). I just read in the context list "Cygwin is not really supported, ...".
 
@UlrikeFischer :)
 
@UlrikeFischer ooh
Moon landing
 
@UlrikeFischer Luigi and I did some trials of ffi a while back without a lot of success but actually I expect Ken Brown will get things working as I got some libraries to link via ffi, and some just didn't so I expect that someone who knew whet they were doing could get it working (I assume ffi is the issue, can't think of many other system specific bits)
@PauloCereda this has been running on the screen at work last few days apolloinrealtime.org/11
 
1:15 PM
@DavidCarlisle ooh awesome
 
@PauloCereda most of the communication seems to be like this, which just scrolled past
Mission Control Apollo 11, this is Houston. I think we have COMM again. We heard you calling. Over.
 
@PauloCereda you will perhaps like youtube.com/watch?v=ptuEi-dVQYY (that's from a quite nice book).
 
@PauloCereda one suspects that communications were not that reliable:-)
 
1:32 PM
@DavidCarlisle ooh
@UlrikeFischer ooh
 
@PauloCereda \def\z#1{\if m#1o\expandafter\z\else#1\fi}\immediate\write20{\expandafter\z\romannumeral3000h}
 
@DavidCarlisle oh my
 
@DavidCarlisle is this not one o too much?
 
@UlrikeFischer no I decided to out oooh him.
 
@DavidCarlisle ooooh.
 
1:45 PM
@DavidCarlisle ooh
@UlrikeFischer ooh
 
2:03 PM
@UlrikeFischer, @DavidCarlisle Fingers crossed I've solved all of the issues ...
 
2:13 PM
@JosephWright ooh
 
2:28 PM
Building LaTeX2e ... lots of tests ... CPU flat-out :)
 
@JosephWright ooh
 
@PauloCereda Miss the i7 ...
 
@JosephWright I can relate
 
@JosephWright we could get travis to do it:-)
 
@DavidCarlisle Yeah, has occurred to me
 
2:35 PM
@JosephWright it's deploy target thing lets you push to a dedicated branch over-writing the history so you can make the zips available without enlarging the repository each time
 
@DavidCarlisle ooh
 
@DavidCarlisle I've not looked in detail, but I'm sure you are right (using this for work?)
 
@JosephWright no but I use the deploy target for some w3c spec builds and I have to turn off the "overwrite history" part the sources were also on the same branch (gh-pages) for historical reasons, so I end up with
deploy:
  provider: pages
  skip-cleanup: true
  github-token: $ghtok  # Set in the settings page of your repository, as a secure variable
  keep-history: true
  on:
    branch: gh-pages
 
@DavidCarlisle Ah right, so we could have a 'release' or whatever branch to hold the zips? Would need to get Travis-CI to do a full build, but that would be scriptable
 
@JosephWright yes that's my understanding
@JosephWright gitlab's CI always makes all the artefacts of the last build available as a separate zip url not checked in, which seems quite a sensible idea, but I have not used gitlab CI much
 
2:45 PM
@DavidCarlisle Hmm, would still need to add an addition l3build ctan, but could do that for pushed tags, so normally it would be skipped over
 
@JosephWright or you could get the project to buy you a machine with 48cores and a Tb of memory. and a big SSD :-)
 
@DavidCarlisle Hmm ... tempting ;)
 
@DavidCarlisle the UK-TUG money we could create a Kickstarter campaign. :)
@JosephWright oi
 
@PauloCereda Don't
 
@JosephWright just teasing. :)
@JosephWright which one sounds scarier? :)
 
2:55 PM
@PauloCereda Er ...
 
@DavidCarlisle Don't you need a space after \romannumeral?
 
@FaheemMitha Catcode-12 token comes next ;)
 
@JosephWright Oh, right. Meaning 3?
 
@FaheemMitha yup :)
 
3:05 PM
Personally, I'd still use a space. Though I realise TeX doesn't care.
 
3:24 PM
@FaheemMitha no
@FaheemMitha if I had been writing it in a form to be easy to read for humans I could simply have written oooh
 
@DavidCarlisle oooh
 
@DavidCarlisle I think there are enough of those here already.
 
@FaheemMitha do you also wirte \count 0 not \count0 or \write 18 not \write18 ?
 
@DavidCarlisle I don't really write any of those. I just copy.
I believe the term cargo cult programming is sometimes used.
For all I know, some of that might be a spell to summon Lucifer.
 
@FaheemMitha that's Perl code. :)
 
3:28 PM
Lol.
 
3:45 PM
@DavidCarlisle, @UlrikeFischer Oh bugger ... the problem with building a format is that latex.ltx doesn't put pdfTeX into PDF mode ... need the dratted .ini file too ... drat
 
@JosephWright why doesn't it find and use the one in the main tree. Is the build so sandboxed?
 
@UlrikeFischer Erm ... it's a bit complicated ...
 
@JosephWright ;-)
 
@UlrikeFischer Typesetting isn't sandboxed but unpacking and checking is for base, and that's where format-building has to happen ... I'm working on it!
@UlrikeFischer Think I can solve it, which takes us back to epstopdf ...
 
@JosephWright @DavidCarlisle's code seems to work. So we only need to decide where/how to add it. Making an update for oberdiek wouldn't be bad anyway, there are still two fixed bug in the queue.
 
4:05 PM
@UlrikeFischer Yeah: I guess I need to add a patched epstopdf to my local set up to get the release out ...
 
@JosephWright you could also add the code to the one test file.
 
 
1 hour later…
5:09 PM
Does LuaTeX currently handle Hindi as well as XeLaTeX, or would I need to wait for the HarfBuzz integration, or whatever it's called?
 
@FaheemMitha For Devanagari you do not want to use the default (ConTeXt) fontloader, so you need one of the HarfBuzz versions.
 
@MarcelKrüger Does this apply to LuaTeX only, or to both LuaTeX and XeTeX?
 
@FaheemMitha xetex is always harfbuzz
 
@DavidCarlisle Ok, but I'm getting confused over terminology.
What is the default (ConTeXt) fontloader, and what part does it play in all this?
 
@FaheemMitha Marcel's comment was luatex-only
 
5:24 PM
@DavidCarlisle Ok. So I need to specially invoke HarfBuzz, in some form? Is this currently possible?
 
@FaheemMitha the core font loading code in lulatex (and plain luatex) is derived from the code in context.
 
@DavidCarlisle I see. The current loading code? But that will change?
 
@FaheemMitha for luatex you need a harftex (or luahbtex) neither are in the default distributions yet but binaries are available
 
Does LuaTeX currently by default handle Devanagari?
@DavidCarlisle Not in TeX Live?
 
@FaheemMitha not well, no
 
5:25 PM
@DavidCarlisle Ok.
 
@FaheemMitha no. Possibly in texlive 2020
 
Would it compile, though?
@DavidCarlisle Ok.
I used XeLaTeX last year. It worked quite well.
The bugs I found were in Emacs.
 
@FaheemMitha sure I have compiled harftex on this machine, or as i say there are compatible binaries available.
 
Probably I should have reported them, but didn't.
@DavidCarlisle No, I meant would a Devanagari file compile with current/default LuaTeX?
Presumably the rendering would not be great.
 
@FaheemMitha yes but people who read the script say the result is not that readable as the combining things don't combine. I can not take a view on how bad it is as I can not distinguish the letters anyway.
 
5:28 PM
Ok.
Well hopefully better support is on the way.
 
@FaheemMitha certainly
@FaheemMitha an answer comparing xelatex against lualatex for various indic scripts, harftex will be similar to xetex :
3
A: examples for broken rendering of scripts in lualatex

ShreevatsaRExtending the other answer here are examples for all of the scripts in the question (and deva, which as the question says is already fixed in the development branch, but not yet on my computer). For most of the Indic scripts I combined the failure modes in the other answer into the single word “k...

 
@DavidCarlisle I think I've seen that answer before. But there are no Devanagari examples.
Of course, I could just experiment myself.
Hmm, getting errors with LuaLateX. And with XeLaTeX too. The latter complains about missing fonts.
 
@FaheemMitha well the first one \newfontfamily\deva[Script=Devanagari]{NotoSansDevanagari-Regular.ttf} is using the Devanagari settings even if it's not a real word?
@FaheemMitha yes you'd need to get the noto sans fonts (they are big but free) :-)
 
(/usr/share/texlive/texmf-dist/tex/generic/ifxetex/ifxetex.sty))kpathsea:make_tex: Invalid filename `[xits-regular.otf]/OT', contains '['

! Package fontspec Error: The font "xits-regular" cannot be found.
This worked last year.
 
@FaheemMitha xits is in texlive you should have that
 
5:39 PM
> \newfontfamily\devanagarifont[Script=Devanagari]{Nakula}
I have fonts-deva installed.
root@orwell:/home/faheem# dlocate xits
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits/XITS-Bold.otf
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits/XITS-BoldItalic.otf
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits/XITS-Italic.otf
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits/XITS-Regular.otf
texlive-fonts-extra: /usr/share/texlive/texmf-dist/fonts/opentype/public/xits/XITSMath-Bold.otf
Are these the ones?
 
@FaheemMitha im confused, the document I link to above doesn't use xits or nakula,
@FaheemMitha yes
 
@DavidCarlisle It's my Devanagari file from last year.
 
@FaheemMitha oh OK
 
@DavidCarlisle Perhaps some setting is wrong, then.
 
@JosephWright Not really online today. I’m waiting for some Wurst between the Danube and the Inn
 
5:50 PM
@egreg do you want to guess the output of this here:
\documentclass{article}
\usepackage{mathfont}
\setmainfont{DejaVu Sans}
\mathfont{DejaVu Sans}
\begin{document}
\&2 \%4 \#1 \$3
\end{document}
 
@UlrikeFischer nice
@UlrikeFischer so mathfont is sort of like unicode-math and mathspec but different?
 
@DavidCarlisle isn't it? Someone was complaining that \& eats the following space and I looked in the code and found this ...
10
A: Are `mathfont` and `mathspec` intended for same purpose?

Ulrike Fischermathfont and mathspec have similar purpose, but mathfont works not only with xelatex but also with lualatex. Both packages allow to change the font of various math symbols and math alphabets. Both packages have in my view the same deficiency: they care only about the look of the math and not ab...

 
6:08 PM
@UlrikeFischer are you only supposed to have math and no text? :-)
 
@DavidCarlisle ?
 
@UlrikeFischer Not in front of a real Bavarian beer and a couple of Weißwurst
 
@UlrikeFischer the symbols redefined to only work in math:
 
@egreg ;-). I prefer cider -- and I now found Bulmers in a supermarket here ;-)
 
\documentclass{article}

\usepackage{mathfont}

\setmainfont{DejaVu Sans}
\mathfont{DejaVu Sans}
\begin{document}
\&2 \%4 \#1 \$3

$\&2 \%4 \#1 \$3$

\end{document}
 
6:16 PM
@DavidCarlisle ah yes. It is naturally unfair if the user adds numbers without spaces. How could a package author expect this?
 
3 hours ago, by Faheem Mitha
Personally, I'd still use a space. Though I realise TeX doesn't care.
 
@DavidCarlisle ;-)
 
7:17 PM
ooh cake
 
Somebody that use TikZ Feymann could to help this user?
I've read it indeed, I didn't notice anything that could help me here :/ , I've seen many examples on internet with the same syntax than me and their codes were working — Lloyy 7 hours ago
1
Q: Error using TikzFeynman, fermion loop never close

LloyyThis is my first time writing here (and also I'm not native speaker) so please be indulgent. I'm new to LateX so if you could also keep your answer as simple as possible, it would be very nice. So here is mmy problem: I'm tiping my report and I need to draw lots of feynman diagrams. I read the ...

Thank you very much.
 
 
1 hour later…
8:45 PM
@UlrikeFischer, @DavidCarlisle Right .. I think I've finally tracked down everything bar the epstopdf issue!
 
9:11 PM
@JosephWright I can change epstopdf (I already did locally). it works okay - it doesn't like spaces but utf8 is okay. But I don't think that I can build for an upload. oberdiek has some curious setup, we need @DavidCarlisle here.
 
9:34 PM
@UlrikeFischer we should be able to get it working just from graphics and graphics-def I think. let me update nd see where we are.... (@JosephWright)
 
@DavidCarlisle no problem. I only tested in a local branch.
 
9:49 PM
@DavidCarlisle Hopefully, I've made everything work in the dev branch without weird format set ups: it's only stuff in the system tree that makes life 'fun'
 
@JosephWright so does the doc build now for you?
 
@DavidCarlisle Work right up the point it gets to rotex
At least I think it does ...
 
depends how we want to handle that, it for example would work I think to have an epstopdf.cfg that looks like
\def\Gin@setfile{%
  \edef\Gin@base{\expandafter\unquote@name\expandafter{\expanded{\Gin@base}}}%
 \ETE@Gin@setfile
 }
in the local tree, rather than synchronising a public release of oberdeik that works with both formats
@JosephWright oh I have some local changes to pdftex.def that I should check into develop branch on graphics-dev ?
 
@DavidCarlisle That would work
@DavidCarlisle Sounds good, yes
 
10:05 PM
@DavidCarlisle don't you need a dummy definition of \unquote@name somewhere?
 
@UlrikeFischer not if this version is only going into a latex-dev tree as it will be defined in the format
@JosephWright I pushed to grahics-def
 
@DavidCarlisle I'll take a look
 
@JosephWright I want to change graphics not to put quotes into Gin@base but I can't do that this evening and it would require matching changes in all the def files to add quotes back
 
@DavidCarlisle hm. I have no epstopdf.cfg, so wouldn't a version in latex-dev be found in the end also by the "normal" format?
 
@DavidCarlisle Fine, I'm not going to do a release now ...
 
10:10 PM
@UlrikeFischer blurg it would be better if latex-dev wasn't in the default TEXINPUTS
@JosephWright OK I'll try to look tomorrow
 
@DavidCarlisle I don't think that we can really avoid that latex-dev is below /tex and so in the end also always in the tex search path. But imho with a \providecommand\unquote@name[1]{#1} it should work fine.
 
@UlrikeFischer yes I guess we'd better do that then :(
@UlrikeFischer actually that means better to get the change into a copy of epstopdf-base.sty (or one of the def files) and not use a .cfg that will be picked up by the main branch
 
@DavidCarlisle Just checked: doc target is now using the 'matching' latex.ltx and getting though to rotex.tex, so it is just the epstopdf issue to sort
 
@DavidCarlisle well unless you want a epstopdf development version in latex-dev too, it should be better done in pdftex.def - (and this means that graphics-def must be also included in latex-dev)
 
@UlrikeFischer I think the graphics-def development files have to be there otherwise graphics doesn't work at all does it? (@JosephWright?)
 
10:23 PM
@DavidCarlisle yes, sounds right.
 
@DavidCarlisle Well, at present the only 'test' I have is rotex, which out-and-out fails but which is an issue with epstopdf ...
 
If we change graphics so \gin@base ends up being cat then epstopdf won't need (immediate) updates (tomorrow:-)
 
 
1 hour later…
11:38 PM
is there something like the tabbing environment where one can set tabstops in any line (i.e. not just the first line)?
i'm interested in typesetting common lisp code, which is more picky about indentation than other languages
here's an example of a manually formatted piece of code
it was achieved through an absolute mess of tabbing and hphantoms but i'm sure there's a better way
 
@texdr.aft you can reset tabs in tabbing (but I never really like using tabbing) if you don't need page breaking you could simply nest parboxes to match the nested s expressions
 
@DavidCarlisle alright thanks
 

« first day (3183 days earlier)      last day (62 days later) »