« first day (3271 days earlier)      last day (53 days later) » 

12:25 AM
How do you write the string "\textit{w} \in \textit{L} and |\textit{w}|"
So that there are spaces between the elements?
Right now I'm getting "Land|w|"
When I want "L and |w|"
How do you force a space?
 
12:40 AM
@JohnnyApplesauce In math-mode spaces are ignored, but you usually don't have to force them. To write some text in a math formula use the convenintly-named \text macro from amsmath. Also \textit, as the name says, is for text. In math you don't use it. Try this: $w \in L\text{ and }\lvert w\rvert$
 
By the way, why does this line run together:
If we compose y so that it is only a's, letting y = \[ a^k \] for some k > 0,
It just turns into one (italic, even though there's no \textit{}) line.
 
@JohnnyApplesauce Because somewhere you started math-mode, and in math-mode the default font is italic and spaces are ignored. Look at where the text begins to be all-italic and space-less and you'll find where the math-mode is started.
 
It starts after some \in
I put a \text after \in
It didn't work
I also tried putting the \text before the \in just in case
Also didn't work
 
@JohnnyApplesauce \in is a math symbol, so it must appear in math-mode (or TeX will throw an error and start it for you). Make sure you put math things between $...$ (or other appropriate math environment)
@JohnnyApplesauce I highly suggest you read some guide for basic LaTeX concepts, such as math-mode. This one is (not thorough, but) simple for beginners: overleaf.com/learn/latex/Mathematical_expressions
 
Very helpful. Thank you, Phelype.
 
12:50 AM
@JohnnyApplesauce You're welcome! Any problems you find along the way feel free to ask a question in the main site.
 
Thanks.
 
 
3 hours later…
3:41 AM
How do you have an entire expression exponentiated?
Like 3^((3/4)*n)
 
 
1 hour later…
4:50 AM
@JohnnyApplesauce $3^{((3/4)*n)}$
 
 
4 hours later…
9:12 AM
Friends, today in Brazil we celebrate Teachers' day. For all of our fantastic professors/teachers, thanks for sharing and spreading knowledge and love to the students!
@JosephWright Google is mean. I asked it tell me the formula for nitric oxide and it replied NO. Google is mean!
5
 
@JosephWright can you please help me here? tex.stackexchange.com/questions/511259/…
@JosephWright I don't know what the syntax of embellishments was in the past or whether they existed in that form.
 
@Skillmon The older syntax was not the same, (we had k-type arguments), but really I'd go with 'sorry, this was not supported by xparse in TL'16'
 
 
1 hour later…
10:31 AM
@JosephWright first Japanese, now Tibetan. :)
 
@JosephWright ok, thanks.
 
11:31 AM
 
11:53 AM
There is a new incompatibility between acro and hyperref for acronyms in headings.
\documentclass[]{report}

\usepackage{xparse}

\usepackage{acro}
\DeclareAcronym{nn1}
  {%
    ,short=NN
    ,long=neuronales Netzwerk
    ,long-plural-form=neuronale Netzwerke
  }
\DeclareAcronym{nn}
  {%
    ,short=NN
    ,long=neuronale\acAdjEnd{s} Netzwerk
    ,long-plural-form=neuronale\acAdjEnd{} Netzwerke
  }

\newcommand\acAdjEnd[1]{#1}
\NewDocumentCommand\acAdj{O{ac} s m m}
  {%
    \begingroup
    \def\acAdjEnd##1{#4}%
    \IfBooleanTF{#2}
      {\csname #1\endcsname*}
      {\csname #1\endcsname}%
First one, which is hidden inside a \NewDocumentCommand works, direct usage of \aclp* in a chapter title fails. Used to work before the last update.
 
 
3 hours later…
2:59 PM
@PauloCereda theuselessweb.com
 
@JohnnyApplesauce you should never have y= \[ that is starting display math half way through an equation.
 
@Skillmon ooh
 
user image
2
@PauloCereda @Skillmon 12th century ornament on a wooden chest (Norman, strong Arab influence; seen at Palermo).
 
@UlrikeFischer ooh!
 
3:40 PM
@JosephWright ^^ ooh spooky chemistry
 
3:50 PM
@MarcelKrüger just trying to keep track with the new harf-code. How do one use it? Do I still need the harflatex code?
 
@AlanMunn, @barbarabeeton ^^ Microsoft is terrible at puns
 
@UlrikeFischer -- Whenever I find something like this at a museum, I look in the gift shop to see if they have an embroidery or needlework kit. If they do, it's usually small enough to pack into my traveling handbag, to work on when I'm away from home.
@PauloCereda -- aaaarrrgghh.
 
@barbarabeeton I should flag as a spam. :)
Hm spicy ham taco...
 
4:10 PM
@PauloCereda :)
 
4:26 PM
@UlrikeFischer The current (harfnode-dev) code automatically detects if harfbuzz is available. If it is, then it loads the harf mode and you can specify mode=harf. Beside luaotfload and a compatible engine, no other components are required. Especially no format changes are needed.
 
@MarcelKrüger Yay!
@MarcelKrüger, @UlrikeFischer I'm guessing your take on the Tibetian question is that LuaHBTeX will be able to do it
 
@MarcelKrüger didn't work for me. I get ...exmf/tex/latex-dev/luaotfload/luaotfload-harf-define.lua:333: attempt to index a nil value (global 'harf'). with This is LuaHBTeX, Version 1.11.1 and 2019-08-11 3.006-dev.
 
@UlrikeFischer Compiled yourself? Or W32TeX?
 
@JosephWright w32tex. Not the latest imho, but rather new.
 
@UlrikeFischer You got an old version, take the one I pushed some minutes ago.
 
4:30 PM
@UlrikeFischer Guess I should grab that
 
@JosephWright I have quite some faith in harfbuzz here. There could be stuff wrong, but e.g. for xetex I would then at first assume that a newer harfbuzz library should be tried.
 
@JosephWright LuaHBTeX will be able to do it, but it needs sufficiently well-behaved fonts. I get the impression that this might be the issue, that current fonts often do not implement all corner cases. At least with older Noto fonts that seemed to be the issue.
 
@MarcelKrüger The error is gone but the output doesn't look right.
 
@UlrikeFischer Me too: I think it's all workable in LuaHBTeX, no need to specialist engines (even Japanese, eventually)
@MarcelKrüger Right, yes, so manual fudges make it look OK as they simply ignore those problems
@MarcelKrüger Norbert says the Noto font is bust in LibreOffice but others work, so I agree: font bug
 
@MarcelKrüger I don't think that harf-mode is used. I tried with a bengali example from the main site and I get the "luatex" output. (The callback seems to be inserted, I see messages in the log).
 
4:52 PM
@UlrikeFischer Can you send me a link to the example?
 
@MarcelKrüger I used this here tex.stackexchange.com/a/493185/2388 (and also the tibetan which looks wrong too).
 
@JosephWright you really cause havoc :)
 
@UlrikeFischer Can you try passing the right Script option? fontspec default to Latin I think. harf basically ignored the option, the version in luaotfload respects it and therefore renders the wrong Script wrong.
 
@MarcelKrüger Script=Bengali didn't work (this gives script=bng2), but script=beng did. And for the tibetan example script=tibt helped too.
 
5:38 PM
@UlrikeFischer Do the luaotfload tests cover the luaotfload.aux. functions?
 
@MarcelKrüger probably not. At least not systematically. Perhaps some are there by accident.
 
 
1 hour later…
6:52 PM
Hello everyone!
 
@SalchiPapa Hi!
 
Is this the correct place to ask about pdflatex? :O
I am a completely new to latex, and some examples are not working for me with Kile editor and pdflatex command.
I didn't n know stack had chat rooms!
 
@SalchiPapa If you want something quick and simple, ask here; 'real' questions belong on the site proper
 
Thank you @JosephWright, Got it
this setup
but it seems that the \makeatletter... macro?
Is being completely ignored
 
681
Q: What do \makeatletter and \makeatother do?

CaramdirMany LaTeX “hacks” begin with \makeatletter and end with \makeatother. What do these commands do?

 
7:01 PM
The path of the image is completely right, using includegraphics in other places work.
Thank you @PhelypeOleinik! I just red that question's answer too.
 
@SalchiPapa The book class doesn't use \@maketitle
 
If you see the snippet above, do you see anything wrong, I understand what makeatletter is doing, just don't know if you call it command or macro.
@JosephWright if I comment te line with \maketitle, the output returns No pages of output.
ohhh if I use article it works!
Do you know if book class has a way to do this?
 
@SalchiPapa You have to change \maketitle instead
 
I've been following this answer
10
Q: Logo and picture on titlepage

Elie GénardI need to make a title page with a logo on the top left corner, the title and the author centered and another picture under this. I tried this code but the problem is that the second image is right under the logo and the title and the author are on another page. %%!TEX encoding = UTF-8 Unicode ...

As you made me notice, the example code also use article
However I already have a setup that uses book, I'm trying to find more information about the semantics of these commands
 
@SalchiPapa Try this:
\renewcommand\maketitle{\begin{titlepage}%
  \let\footnotesize\small
  \let\footnoterule\relax
  \let \footnote \thanks
  \null\vfil
  \vskip 60\p@
  \begin{center}%
    {\Huge \bfseries \sffamily \@title }\\[4ex]
    {\Large  \@author}\\[4ex]
    \@date\\[8ex]
    \includegraphics[width = 40mm]{../assets/images/indexing_on_lists.png}
  \end{center}\par
  \@thanks
  \vfil\null
  \end{titlepage}%
  \setcounter{footnote}{0}%
  \global\let\thanks\relax
  \global\let\maketitle\relax
  \global\let\@thanks\@empty
 
7:20 PM
@DavidCarlisle twitter.com/OpenAI/status/1184145789754335232 I wonder if the L3 tests would include a stuffed giraffe...
 
I get undefined control sequence \maketitile following many errors about missing or extra inserted symbols
Thank you @PhelypeOleinik, I don't know what I am doing wrong
 
@SalchiPapa In your sample document that code works, so it must be something in your complete document.
@SalchiPapa Try to isolate the problem to a minimal example and/or ask a question at the main site
 
@PhelypeOleinik I keep reading salsicha. Make it stop!
 
@PauloCereda LOL
@PauloCereda At least you're not seeing salsicha. That would be evil
 
@PhelypeOleinik Got it, I have an minimal example that reproduces this issue, please just a moment
 
7:28 PM
@PhelypeOleinik LOL
 
@PauloCereda stuffed duck
 
@DavidCarlisle a plushie, right?
 
@PauloCereda you?
 
@DavidCarlisle oh no
 
@PauloCereda lol
 
7:32 PM
/quacks in despair
 
7:45 PM
 
@MarcelKrüger Oooh, tag created :)
 
In that link you can see 3 files, baz.tex, baz.log and baz.aux.
 
@SalchiPapa You still need \makeatletter before the \renewcommand.
 
There is no baz.pdf output created :(
ah let me try, thank you.
 
@SalchiPapa Note that tracing can help. I've been doing it more recently. See the trace package, for example. With tracing, you can at least see where/how the error occurred, which often isn't obvious in the default logs.
 
7:50 PM
@JosephWright ?
 
@JosephWright ooh
 
@DavidCarlisle ducks are rare in Sicily, even on the menu ;-)
 
@UlrikeFischer luaotfload
 
@UlrikeFischer that's... good
 
@PauloCereda only the second part ;-)
 
7:52 PM
@UlrikeFischer :)
 
@JosephWright ah, the latex project machine ;-)
 
@UlrikeFischer Yes, that one
 
8:13 PM
Reading TUGBoat
Interesting few lines about XeTeX ...
 
@JosephWright has paper one arrived recently?
 
@DavidCarlisle Not yet: looking at the online version
 
@FaheemMitha thank you I'll look into that
@PhelypeOleinik thanks again, I made it work, you've been of great help :)
Have a great day everyone!
 
@SalchiPapa You're welcome!
 

« first day (3271 days earlier)      last day (53 days later) »