« first day (2124 days earlier)      last day (1620 days later) » 

12:15 AM
@Natty tp
@Natty tp
1:38 AM
Spam (see comment). They probably intend to edit a URL in.
1:52 AM
@Zanna The OOF 1 compilation question got closed by but only needs one more vote to be reopened.
Also I've commented.
I don't want to rush to close these as too broad, and I do think they have some value (though less so for the .tar.gz installation one)... but it seems to me that we allow questions of extraordinary breadth provided that they aren't phrased like software recommendation requests... even when they are software recommendation requests, like with the general file-renaming question.
Both that question and the .tar.gz installation question are much broader than the recently locked video editing question, which was being interpreted more narrowly than the actual question's wording required (for example, people didn't post answers about VLC for its limited video editing capabilities). To clarify, these are the questions I'm talking about:
Q: How to easily rename files using command line?

Jiew MengOne of the ways I quickly rename files in Windows is F2 > Rename > Tab (to next file) > Rename ... But in Ubuntu/Nautilus, I can't tab to next file. But being on Linux, I think there must be a command line alternative. However, sometimes, I may want more control over how to rename specific f...

Q: How do I install a .tar.gz (or .tar.bz2) file?

SilambarasanI have downloaded tar.gz files. But I don't know how to install it. How do I install this kind of file?

Q: Video editing software options?

GödelWhat video editing software would you recommend on Ubuntu (or Linux in general) and why? It can be for either beginners or experienced users. Please only place one piece of software per response and include details to what makes it great!

A historical lock is actually the resolution to the discussion there and there for that video editing question that I prefer.
I think we could also have just edited the question to narrow its scope to approximately the way it was already being interpreted, by making it ask for video editing software that is "fully featured" for some explicitly clarified meaning thereof (listing a few common features, perhaps). That's why I voted to reopen it. But I'm not sure it would really do us all that much good that way, and a historical lock is totally fine with me.
I wish it were effectively so broad it couldn't be fixed, because that would mean there are way, way more reasonable choices for video editing programs on Ubuntu than there actually are or have ever been. As it is, the topics of installing software from a compressed archive and bulk file renaming (even choosing a utility to perform bulk file renaming) are considerably broader, but nobody, with the possible exception of me right now, seems ever to have expressed any objection.
3:19 AM
Unclear (but probably not off-topic)
@Natty tp
Unclear (The OP probably means gksudo, and once that's corrected, they may or may not still have a question.)
4:02 AM
Is this NAA? I'm not really sure.
Also, do we have another Chrome and Chromium backup question that this one can reasonably be duped to?
5:36 AM
@EliahKagan I started the reopen, so can't help :( thanks for commenting!
5:48 AM
@EliahKagan The OP added information in a comment and the question was edited with this additional information. Also this question is probably clear enough now that your CV can be retracted, see my answer to it for more information.
@Natty borderline because this answer could help the OP to narrow down the possible causes of the problem
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, blacklisted website in body, link at end of body: keto tone diet new suplement review by bdggdse on askubuntu.com
@EliahKagan The only reason why I posted an answer to the otherwise silly gxsudo question is that gksudo has been dropped from the default 18.04 repositories for security reasons and it would be nice to post an alternative to using gksudo when it is no longer available.
6:19 AM
[ SmokeDetector | MS ] Bad NS for domain in body, bad keyword in body, bad keyword in title, blacklisted website in body, link at end of body, +1 more: Only eat when weight loss Hunger and stop by proprietativalc on askubuntu.com
6:36 AM
OT 12.04
@Natty tp
7:43 AM
[ SmokeDetector | MS ] Bad NS for domain in body, blacklisted website in body, link at end of body, pattern-matching website in body, repeated URL at end of long post: however, anything your goal Testogr by jluv on askubuntu.com
8:18 AM
[ SmokeDetector | MS ] Link at end of body: Fix wifi connection 17.01 by HuỳnH KhanH TuấN on askubuntu.com
8:54 AM
[ SmokeDetector | MS ] URL-only title, bad NS for domain in body, bad NS for domain in title, blacklisted website in body, blacklisted website in title, +4 more: www.healthdietalert.com/actionpro/ by justinpeter on askubuntu.com
1 hour later…
10:17 AM
Why is this answer getting downvoted?
@Natty tp
@pomsky I don't know. Seems a reasonable answer
@pomsky It also seems to me like it's a reasonable answer.
10:57 AM
@karel Makes sense.
Why redirect the output of pkexec thunar to /dev/null?
pkexec thunar in an Xubuntu 18.04 system doesn't write anything to the terminal, for me.
@pomsky I haven't downvoted it but it says, "Based on a cursory google search it would appear..." and doesn't link to, quote, or say anything about what sources were found.
@Natty tp
@karel Do you think the information added to the printing question is sufficient that it could be answered?
@EliahKagan it might dump all kinds of gui warnings to the terminal...
E.g. Nautilus prints this for me, dunno about Thunar:
$ nautilus

(nautilus:15712): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:15712): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:15712): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:15712): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:15712): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
Sorry, I misread the answer I was asking about! (It does redirect both standard output and standard error.)
Still, though. I did actually try running thunar in a terminal in Xubuntu 18.04, as root, with pkexec thunar. It didn't print warnings. If it did, I am not sure they wouldn't include anything of interest. Unlike some graphical programs, Thunar seems intended to be run as root sometimes. Its UI changes to warn the user that it is running as root.
I'm not a big fan of suppressing warnings by default because some applications print useless information.
11:16 AM
I used to get lots of useful info running firefox in a terminal... now it doesn't print anything :(
Yeah, firefox doesn't seem to have an option for verbose messages, either.
(Hopefully you were not running firefox as root, though... :)
@EliahKagan I don't have an 18.04 system to test yet, so I tested my commands on 17.10. As soon as Ubuntu 18.04 is officially released a week from now, I'm going to install it and test my replacement for gksu command(s) on 18.04.
You were able to run thunar as root on 17.10 with pkexec, and it printed useless messages when you did so?
@EliahKagan oh no, certainly not, but I was giving outrageous and unreasonable permissions to a stupid Java applet I have to use for work...
@karel (Either way, you obviously don't have to remove or change the redirection. It's up to you! The reason I'm mentioning this -- even though I don't comment on every needless redirection to /dev/null that I see on the site -- is that it seems you intend the answer as a general resource for users who are trying to run graphical applications as root on 18.04. This is something we should have, especially since 18.04 defaults to Xorg instead of Wayland so running GUI programs as root works.)
11:22 AM
Yes I did, but I reasoned that if I test it on a pre-release Ubuntu 18.04, I maybe will have to revise it anyway after Ubuntu 18.04 is officially released so why not wait a week. Next week I'm going to test every instance of gksu in all my answers on Ubuntu 18.04 and revise whatever needs to be revised. Not much I think because I almost always posted about sudo nano instead of sudo gedit.
Yes, that's true. There may be changes. For example, if you had tested it a few days ago, then gksu would still have been available (though not installed by default). :)
Personally I prefer to say, "You may see some warning messages like..." (and then an example) "These are typically unimportant." I see why you might choose to put in the redirection if you observed the warnings on 17.10, though.
I thought about the possibility too, but it occurred to me that sooner of later Canonical is going to fix the issue with warning messages when running some pkexec commands, and we'll finally have a nice replacement option for insecure gksu. Personally I always use only the terminal with sudo anyway so I don't have any problem with it no matter what happens.
Maybe they have fixed it? I know you may not want to change any posts based on this -- especially since I haven't updated my Xubuntu 18.04 system for over 24 hours! -- but I'm curious to see what I get when I try running some other graphical programs as root.
Well, some continue to have no Polkit profile and attempting to run them as root with pkexec fails.
It doesn't effect me either way because the only app that I ever run from the terminal is nano anyway.
You have to test every app with pkexec individually.
Running them with sudo -H still works, and it does not seem to show those kinds of GTK+ warnings. Running xfce4-terminal as root with sudo -H shows a "Failed to connect to session manager" warning but it's the sort of warning I think users would probably want to see.
11:48 AM
the question is a dupe, although my answer doesn't exactly solve the issue, I believe this is the best one can achieve right now.
Typo, would close as "went away/not helpful for future readers" askubuntu.com/q/1026670/367990
11:59 AM
@pomsky VTC'd
@ByteCommander I don't think that is our policy, though that kind of closure sometimes happens... besides, it's hard to tell a typo (an error you wouldn't make if you were paying attention/not letting your cat help you with package management) from a mistake you made because you lack knowledge others take for granted
I'm not sure what we should do with that question, and I haven't CV'd or reviewed CVs on it. But yeah, we do not have a policy that typos make a question no repro. Unix & Linux has such a policy... and in my view, they either shouldn't have it or they are interpreting their own policy badly.
Very often typos are related to conceptual misunderstandings; perhaps as often, conceptual misunderstandings about syntax that don't actually involve typos (in the sense of mistaken typing) are wrongly seen as being about typos and closed.
[ SmokeDetector | MS ] Username similar to website in answer: How can I get the command log of a particular user on Ubuntu Server? by Technowise on askubuntu.com
yeah seems pretty spammy. Is that link really related to the question?
@EliahKagan I've seen the same confusions come up again and again on Unix & Linux and get closed. Searching for typo in /dev/chat (the Unix & Linux main chat) reveals numerous arguments over whether or not something involved an actual conceptual question, in which an extremely strong presumption that anything that involves wrong syntax is a typo has to be overcome.
@Zanna I've commented, even though the post is old. I don't really want to say, "We didn't catch this when you posted it, but..." because I don't want to be advertising areas where the system hasn't caught spam. I also believe we can regard that as spam. Either way, I think it can certainly be deleted. Spam, VLQ, or NAA would all be fine for it, IMO.
12:19 PM
don't think this answer adds anything new or useful
"You did mistake."
12:34 PM
@pomsky Yeah, it doesn't. It's not very clear either. I've VTD'd it. Here on AU (but not on some other sites, like SO), I think we consider it reasonable to flag such answers as NAA, too. Not just because it covers the same ground as another answer, but because it does so in a way that either (a) differs not at all, or (b) as in this case, is just an unclear version of a previous answer. I don't have a meta post to site for this, though; it might not be a correct statement of our policy.
@EliahKagan Yeah, I did flag as NAA.
Did the top bar change to not show rep for either of you guys?
I'm wondering if I need to post a bug report on meta
In the past minute or so, it showed a rep increase for me.
No, I mean like not showing your total rep next to your avatar
@AndroidDev when I view the full site on mobile, reputation and badges are missing, but that's been the case for a few weeks I think.
12:44 PM
I have not noticed any problems with it recently. This doesn't mean there isn't some bug that you're seeing, though. Was your cumulative rep change since you last clicked the achievewardaccoladements menu positive? It only shows changes when they add up to a positive value. So like, if you bountied something for 200 and then received a whole bunch of answer upvotes, it would take until the 21st upvote to show you rep change.
@AndroidDev yep, that's what I get in Firefox on my phone. But it works fine on my laptop
@AndroidDev Sorry, I glossed right over your having said the rep wasn't shown at all. I'm having reading comprehension problems today, apparently.
@Zanna Is there a bug reported for the problem you're having on the mobile app?
I have not checked shame. I have so much trouble getting browsers to serve me the full site instead of the mobile site on my phone I'm just grateful when they do it at all
1:09 PM
Is this new?
> Welcome back! If you found this question useful,
don't forget to vote both the question and the answers up.
I just got that on English Language & Usage.
@AndroidDev Anyway, I do definitely recommend posting a bug report on Meta Stack Exchange if there isn't one already.
The problem is on all SE sites, not just Ask Ubuntu, right?
Why is this recent surge of answers (this for example) suggesting restarting network-manager out of context as a fix for network issues?!
I do that too sometimes
is that recent? I think we have a lot of useless posts like that
1:30 PM
This comment is excellent. I wish we had a question specifically about the issue of what is responsible for assigning meaning to -- when it's passed to a shell builtin, with the contents of that comment as the answer.
@EliahKagan lol XD
(Huh. Editing a chat message, making no actual changes, but submitting the edit, causes the pencil icon to appear, just as if an actual change had been made. I think...let me test it again.)
1:46 PM
So I just pushed a bunch of questions to the homepage by only fixing a tag (people mistakenly used [cd] when they meant [cd-command]). Seeing how easy it is to make this mistake, I'm thinking of adding "For questions about the command cd, please use the [cd-command] tag." (in bold font) to the "Usage guidance (excerpt)" section of the cd tag. Does that make sense?
I've even done that myself, so yes!
@pomsky Yes. Usage guidance is an important (and often missing!) part of any tag wiki. Please do add it.
@Zanna and @EliahKagan It seems the "excerpt" section allows only plain text, no Markdown formatting. Could you suggest a way to "decorate" the sentence to make it more "eye-catching" (but not over-the-top)?
put it at the beginning?
Or we could (this would require discussion on Ask Ubuntu Meta) get rid of the , or deprecate it like we did with , and have for questions about CDs.
2:00 PM
good idea
But whether or not we do that, I still recommend applying your edit to the tag wiki excerpt. @pomsky
because when I made that mistake, I was working on mobile and never saw the tooltip
I wonder if people would go for that, though. After all, we still haven't managed to remove from all the questions that have it. It's currently on 7,155 questions!
@pomsky Maybe:
> Compact discs are a form of removable media. (For questions about the cd command, use [cd-command] instead.) CDs can hold files (as well as audio tracks) and many computers have an optical drive for reading and writing data on a CD.
> Compact discs are a form of removable media. For questions about the cd command, use [cd-command], not this tag. CDs can hold files (as well as audio tracks) and many computers have an optical drive for reading and writing data on a CD.
Though the point about not using it for questions about the cd command is the most important thing to add, the tag wiki and especially the tag wiki excerpt for are also outdated. I don't think most new computers today have an optical drive, and (relating to the full tag wiki) I'm pretty sure CDs are no longer a common installation medium for Ubuntu, considering that even the more lightweight derivatives' ISOs are too big to burn to a CD.
Anyway, I think it's definitely fine if you only change it to mention how people should use for questions about the cd command. Other changes can be made subsequently, by you or someone else. Or if they are not made, your edit will still have made things better.
This is one of the (rare?) situations where the saying that "the perfect is the enemy of the good" actually applies. :)
2:32 PM
@EliahKagan suggested an edit: askubuntu.com/review/suggested-edits/828675
I considered posting something like this as an answer but I think we should probably just close the question as a duplicate.
@pomsky Reviewed. One more approval needed.
Perhaps the full tag wiki should also mention when should be used instead. It could also mention the tag and the tag.
@EliahKagan I didn't know we were meant to be doing that. I have intermittently made efforts in that direction, but feeling like I was doing something naughty
@Zanna That we were meant to be retagging questions? If people want to keep questions tagged , then I think there is something wrong with its current tag wiki excerpt.
hahaha yes
We have a number of questions on meta about what to do with . A new question about whether or not we should undertake retagging efforts should probably cite them and synthesize the history so far. I don't have the time or, uh, inclination to post such a meta question now. It is possible that I will get to it eventually.
If someone else wants to do so, then they can definitely feel free to use (or not use) the title, "Can we escape the enemy [installation] as it crumbles to the ground?"
2:44 PM
@EliahKagan I've VTC'd that question as a duplicate of the general bug-reporting question.
@pomsky Is that question actually no repro? You said that you believe rebooting or restarting Nautilus should fix it. If that can be discerned based on a technical understanding of what is happening, then it's not no repro.
No repro means the problem can't be understood well enough to give an answer that is potentially useful to others. If you understand the problem and know that rebooting is a specific solution, then the question should be open and it should have an answer explaining that (and, preferably, also why).
Sometimes people reboot (or reinstall, etc.) Ubuntu and their problem goes away but nobody knows why or even of rebooting or reinstalling is a reasonable solution. If someone has a problem where rebooting is known to be a reasonable solution, then that's not no repro.
The only reason I haven't yet voted to reopen that question is in case I am misunderstanding your comment (and messages here).
(unrelated) This question still needs one more OT EoL close vote... unless we have some way of knowing that the problem really isn't specific to 17.04, in which case I think we could keep it open but that should be explained. (I've added my close vote.)
3:01 PM
is this question a dupe of something?
I would guess so, but cursory attempts to find an original for it have failed me. :(
me too :(
Is this comment clear? Also, I am thinking that, at this point, the OP should be advised to edit the question to include the information from the comment, whereupon it could be reopened and I (or anybody) can post an answer. The information in my comments, taken together, is really an answer.
yeah, if they think they can't report a bug in that case, other people might think the same...
I'll wait a bit for their reply before I suggest that they edit the question so I can answer. (I'll eventually suggest it even if they don't reply, though.) They might have other questions. They might be attempting to use ubuntu-bug and getting rebuffed (though... that does support reporting bugs in -dev packages, doesn't it)?
ubuntu-bug unixodbc-dev seems to work just fine.
3:23 PM
@EliahKagan Sadly I cannot provide any technical justifications for my claim, I just noticed many times changes made to window decoration and theming etc. don't immediately apply to a window of a running instance. Simply closing and restarting the application (or for a nuclear solution rebooting) usually fixes it.
Since there was not much info from the OP I hypothesised that OP posted as soon as they didn't see the change in a already running instance. I would have added this as answer had OP replied.
@pomsky I think your observations are sufficient for an answer, even though you don't have an explanation. Personal experience is relevant and useful. In my view, the key question is, can you describe the specific conditions under which you have observed that the proposed solution works? Since you can, I think it's better that the question be opened and answered (unless it is a duplicate) than closed as no repro.
I don't know how much others would agree with me on this, but if you're comfortable posting an answer then I'll definitely vote to reopen.
@EliahKagan If it's reopened I'll post that as answer.
hmm... old answer needs editing?
@pomsky I've voted to reopen it, and also commented (for the benefit of reviewers--my comment is not actually telling you anything you haven't heard from me here :). If you agree then you could also cast a reopen vote, but this is totally your choice, of course.
I think this one should be reopened as per the edit made by OP.
They seem to be saying it's not specific to 18.04. But isn't it still a bug? Bug reports are off-topic on Ask Ubuntu even when they apply to releases we support.
@Zanna I've gone ahead and posted another comment about how they can use ubuntu-bug and how they should edit their question so it can be reopened and answered.
@EliahKagan Ah, yes, right! Sorry, I didn't read the original question carefully again, just got overwhelmed by OP's edit. (Thankfully I didn't VTR before bringing it up here.)
3:51 PM
@EliahKagan thanks, I hope they will edit
@pomsky I've commented.
@Zanna We (or anyone) can edit it ourselves and vote to reopen. But I'd rather wait for their edit because maybe there's some other important aspect of the question that they haven't stated. In particular, I'm not sure why they thought they couldn't report bugs against -dev packages. Typing the name of a -dev package into the Ubuntu packages search box on Launchpad typically brings up the appropriate source package, and unixodbc-dev is no exception.
4:12 PM
@EliahKagan looks like someone already cast a VTR :-(
Shouldn't this be closed as a bug?
@Zanna (and everyone interested) Regarding that question, I definitely don't mind if someone else posts the answer, especially if I'm not available if/when it is edited and reopened. I'm about to go afk, probably for hours, and possibly longer.
As usual, but with extra special approval from me in this case :), anyone may feel free to use the text of my comments, the images linked to in my comment, and that image in an answer.
@pomsky Yeah, I had noticed that. It was cast before I posted my comment.
@pomsky Yes, or as unclear. I've just VTC'd it as OT bug.
4:27 PM
4:38 PM
@pomsky The OP is not sure if their problem really is a bug so maybe the question is worth another look. I commented, mainly to address their question about whether or not they ought to delete the post (I suggested that they not do so), but I don't have time right not to carefully reread the post to figure out if there's a way it could be a non-bug problem. Ttyl.
* right now
@Natty tp
1 hour later…
7:12 PM
@Zanna Why so? It's an XY-ish problem asking how to choose between ; and &&, right? So it can be answered compactly by explaining the difference between the two, with one or maybe two examples. I can post an answer. But maybe it's a duplicate of something?
("XY-ish" because they're not asking about how to achieve their planned solution, so it's not strictly an XY problem. But they are conceptualizing their question as being about better and worse, which doesn't apply in this case, and allowing that to affect the way the question is asked.)
7:31 PM
@EliahKagan yes ok (I don't know if it is a duplicate)
I've posted an answer.
@EliahKagan It's reopened and I posted that as an answer, comment clean-up?
@EliahKagan sorry for trying to close such an answerable question
7:48 PM
Well I suspect it's a duplicate. I recall we have something related to this and targeted toward users of a similar (i.e., novice) technical level in shell scripting. I don't remember if it's the same, though, and I didn't find it in a cursory search, and the question was about to be closed, so I posted an answer. Since my answer and subsequent comment, I've noticed the close votes decreased from 4 to 2. :)
There's another perspective from which an answer to that question question could be written. I didn't bother including it in my answer, and I'm not sure it would benefit my answer, which I think is already complicated enough for someone who is just starting with shell scripting, in spite of my efforts to keep it simple. && is pronounced "and," and it and ; correspond to two meanings of the word "and."
; means to do both things: "Brush the dog and take out the trash." Admittedly is sort of a stretch, because ; specifies sequence and that "and" often doesn't.
&& means to condition one thing on the other: "Send me a bill, and I'll make sure to pay you back."
So if somebody wants to write an answer about that, maybe connecting the ideas to "or" and "if"...
8:28 PM
This one looks very XY-ish.
8:45 PM
@pomsky Well they say what their actual goal is: they want to "to install IBM MQ." It would be nice if they included more information about the errors directly in their question, though.
1 hour later…
1 hour later…
11:10 PM
I've voted to undelete this answer which, though flawed (but not more so than the other answer to which it is similar), actually states a rationale for the commands it recommends, as well as suggesting an approach in the event that one of them were inadequate. Since I believe service names do actually change across releases sometimes, I don't think that second point (though it's not my main reason for wanting to undelete) is pedantic or minor.
11:28 PM
@Natty tp
@Natty tp
OT Ubuntu+1 ? It seems like it to me but I guess check the comments adding your VTCs.
This answer appears to be attempting to suggest a specific course of action. Should it be edited and undeleted? In this particular case I am not sure.
I think this question is unclear. Given it's vagueness, I don't think I would've voted to delete the answer there -- for all we know, it may really address the OP's problem -- but I think it's probably not necessary to undelete it, given that the question should be put on hold and there's essentially no basis with which to evaluate if anything does or does not answer it.
11:51 PM
I'm finding this one very hard to deal with.
How so?
1. This one is about Ubuntu GNOME 14.04 which, being a community flavour, is eol after 3 years (not 5). So potentially off-topic here.
2. But one may claim they have installed gnome-desktop on Ubuntu 14.04 (I think that's possible) and hence on topic!
In fact OP didn't use the combo "Ubuntu GNOME" in body, they wrote "Ubuntu:14.04 lts Gnome".
But then again it seems they posted a machine-translated version .
3. I think it's very much answerable. The issue is that those themes are designed for GTK3 version >= 3.20, in Trusty the default version must be lower than that.
@pomsky I'm not sure I follow. Are you saying Ubuntu GNOME 14.04 is not an LTS? I know that some flavors have not been LTS, but is that true of Ubuntu GNOME 14.04?
I think that if they are using an Ubuntu system and all its packages (or at least whatever packages are potentially relevant to their question) are supported then it's supported. That's what we did, or tried to do, with Ubuntu 10.04 LTS's weird extended support situation for a small fraction of the server packages.

« first day (2124 days earlier)      last day (1620 days later) »