« first day (1181 days earlier)      last day (2891 days later) » 

12:00 AM
@Gilles I realize this discussion is so last year, but perpetual beta is a thing on SE?
 
@strugee not really, but neither is guaranteed graduation
I expect policies to evolve faster than codegolf can become ready to graduate
 
ah
 
12:19 AM
and happy new year, everyone!
 
happy year 44
2
 
slm
year 44?
 
@slm UNIX time
1971 if my memory is correct
 
@strugee off by 1
@slm since the start of Unix time
 
blast. '72?
nope, it was '70
oh right. didn't think about just doing the math...
 
12:31 AM
date -d @0 (Linux only)
 
12:43 AM
@Gilles thanks for commenting on my question, I'm still having probs though
 
12:54 AM
At this point I'm trying to get it to work with just the expect script, because having the two scripts is hurting my brain
so my expect script does the initial spawn ssh, sends the password, then spawn scp upload the file, then spawn ssh root@192.168.1.1 "/etc/init.d/dnsmasq restart" which doesn't seem to work
Also tried send /etc/init.d/dnsmasq restart which doesn't work either
 
@davidkennedy85 I recommend doing the opposite, since you aren't familiar with tcl
treat the expect script as a black box that runs one ssh command, using a password for authentication
run ssh -N from expect, and when that returns (so the expect script returns), you know the connection is in place
 
@Gilles Linux only or GNU only?
 
@strugee GNU/BusyBox only
 
ah. I'm surprised it made it into BusyBox but not anything else
 
1:19 AM
Bah, this whole day has been frustrating
Need a break
Thanks for your help
 
@davidkennedy85 good luck!
 
slm
2:10 AM
Can anyone else confirm that the update to GNOME 3.8.4 has disabled their screenlocking & screensaver?
 
@slm yep, that's public knowledge.
GNOME Screensaver is dead, all the actual screensaver code was ripped it out, so it was just a black screen for a while. I believe there is now no gnome-screensaver module at all, the relevant code for the lock screen has been folded into either gdm or gnome-shell; I forget which
that'd probably be a nice self-answered question
 
slm
i see it's in gdm
this will trigger the locking of my screen now
dbus-send --type=method_call --dest=org.gnome.ScreenSaver /org/gnome/ScreenSaver org.gnome.ScreenSaver.Lock
this was working fine, but there was a recent update to Fedora that appears to broken it? I'll have to do a reboot to make sure it isn't just borked
We have this Q which seems to be the one: unix.stackexchange.com/questions/86221/…
 
2:27 AM
ah. someone seems to have beaten me to it
which reminds me, the "What is Wayland" question needs to be updated. things have changed a lot since 2011.
I'll do it when I get around to it but if someone wants to do it before then it's fine by me
 
slm
2:51 AM
@strugee - figured it out, they switched the setting under Power -> Blank Screen to never. Changing this got my locking working again.. This shows the actual value too: gsettings get org.gnome.desktop.session idle-delay
 
huh. I would have thought you'd still be able to manually trigger a lock
 
slm
I was able to trigger the lock with the dbus command too
 
oh so the dbus command worked, it just didn't automatically trigger?
as a (related) aside: as of a couple days ago, kernel dbus is complete (including userspace tools) except for policy enforcement! \o/
 
slm
3:10 AM
Right no automatic, but an update must have unset my setting there.
have they provided current docs for the tools yet? I see so many times the refs. to udevinfo still
good docs would be huge for that
 
which tools?
 
3:44 AM
I personally find the GNOME documentation to be a bit lacking. at least the developer documentation
 
 
1 hour later…
slm
4:48 AM
@strugee - the udev tools
 
oh. no idea
 
slm
I added the info we discussed about locking the screen and such to the Q&A you edited earlier too, in case the links go away, now we have it in a single spot here
 
yeah, I saw. thanks
 
 
2 hours later…
6:39 AM
am I the only one who's kind of weirded out by all the little "'13" suffixes on everything? (that's a single quote inside the double quotes, btw)
 
 
4 hours later…
10:20 AM
will someone with 15k rep lock unix.stackexchange.com/questions/238/…? seems way too opinion-based
 
 
2 hours later…
12:09 PM
@strugee lock it? It's already closed, it can't get new answers AFAIK
I assume you mean 'protect', which is the thing 15k (or is it 20k) users can do, which prevents answers from no-rep users.
Actually locking it (so no one can do anything to it, except flag, I think) can only be done by diamond-mods.
@strugee nevermind my previous comments, I got confused as to which tab I was looking at!
 
@strugee there seems to be no debate there at the moment. 2013 saw a grand total of 2 comments and one answer and there's been nothing in the last 6 months. Why bother protecting it? There's no undue activity.
 
@Gilles BTW, I'm not sure if you know, but when you made a trivial edit to unix.stackexchange.com/questions/106920/… it got thrown in the re-open queue
Or maybe not. That's what it looked like here, but looking at the history it seems like maybe the site was fibbing :-(
 
12:35 PM
@derobert what's worse, for some reason it got 3 reopen votes...
 
apparently, when done through the queue, you can see who!
 
@derobert I actually edited it from the reopen queue
I don't know why this question was closed, it can be answered for a default setup
answered as in, where do you set the default gateway
of course there may be a myriad reasons why something isn't working that are peculiar to the OP's setup, but if he doesn't provide feedback, too bad for him
 
@Gilles he's not telling us the VM OS or of he has root access to it.
 
@terdon
 
Is that host or guest?
 
12:48 PM
Nor has OP been to the site since asking the Q...
 
I assumed guest, why would the host matter?
 
But if you have a good answer for the question, I guess I'll lend my re-open vote so you can post it. Assuming the site will still let me.
 
@derobert I don't, I could do the equivalent for debian but I'm not familiar with centos (thankfully)
@strugee should it be edited to “what was wayland”, or is it too soon?
 
I have a feeling it'd be a duplicate then, but I'm having a hard time finding the other question...
(the "how do I set the default gateway" thing)
2
A: Changing Redhat Network Settings From DHCP to STATIC IP Via Configuration Files

Prof FalkenYou may also need to set a default route (often known as your default gateway) in /etc/sysconfig/network-scripts/route-eth0 as follows: default via 1.2.3.4 Just make sure you substitute the correct Default Gateway for 1.2.3.4 otherwise Bad Things Will Happen... ;)

there we go!
 
Shocking!
 
slm
@Gilles My RH ears are burning!
 
yeah, I checked out the manuals and everything points to "emacs can't do this (yet)"
 
slm
@derobert That was why I voted to close that Q. The OP didn't put enough info in for starters and so that Q would just become us debugging his particular setup and having to prod him a lot to get particulars about it, wasting our time for something that if you went through the official docs is already well covered.
 
@Braiam You ought to post it as an answer...
BTW! I found a quick way to log out of your local session
ssh -O ForwardX11Timeout=5w -X any-user@any-host
once you log in, you'll be logged out!
I'm not sure if the X bug has been properly reported or not. There is xquartz.macosforge.org/trac/ticket/739 and bugs.freedesktop.org/show_bug.cgi?id=47053 ... but it links to a bug that is secret.
 
2:01 PM
/me wonders WTF the xorg folks are doing with secret bugs. Easy enough to find mailing list archives about that bug, and also bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/519049 ...
 
༼ຈل͜ຈ༽
@derobert err, isn't that bug "fixed"?
 
@Braiam Ubuntu has apparently carried a patch around since 2010.
Xorg folks apparently ignored it. Possibly clicking the 'make this secret' box in Bugzilla is easier that actually applying a patch </sarcasm>
 
@derobert how to reproduce?
 
That ssh line did it for me...
 
(hoping debian fixed it too)
remote or local Xorg?
 
2:11 PM
Given, I had not restarted X in a long time, so I'm not sure what version I was actually running
local
I had that option in my .ssh/config, not on the command line, and I think I tried 52w. But it should work...
I get to reboot this machine soon to track down if that weird xterm issue is nvidia or not, guess I'll try crashing X.
 
just me or koding.com is dead?
 
site loads, not sure what else to check (haven't used it before)
 
slm
@Braiam I've used it before, it's fine.
 
then my internet sucks... or chromium for what matters
 
2:41 PM
Well, I just tested using that ssh line. (Well, it's -o instead of -O, of course). Result: X crashed.
X.Org X Server 1.14.5
Release Date: 2013-12-12
[ 40.617] Build Date: 13 December 2013 10:12:53AM
[ 40.617] xorg-server 2:1.14.5-1 (Maarten Lankhorst <maarten.lankhorst@ubuntu.com>)
so it was a pretty recent Debian package.
 
@Braiam there's nothing really that can't be done in emacs. You just have to know enough lisp to hack it (which I don't)
 
@terdon heh, found this stackoverflow.com/a/7136851/792066 which leads me to thise emacswiki.org/emacs/Dedicated_Minibuffer_Frame and seems promising
 
slm
3:22 PM
Don't we have this Q&A already?
1
Q: Add ssh user with minimum rights for backup

user4811I have a small server running Debian and I want to add an account with SSH access for backups. The user of this account should have no console access. He can only transfer (backup) data via SCP to/from one directory on the server, nothing more. How can I do this?

 
 
1 hour later…
slm
4:24 PM
Ah took a while, found the dup
0
A: Adding a user who can only execute scripts remotely

ArcegeTry this as the login shell for the user: #!/bin/sh basedir=/local/remote_only_scripts while read -p '$ ' prog args; do if [ ! -x "$basedir/$prog" ]; then echo "Invalid program: $prog" else case "$prog $args" in *\**|*\?*|*\^*|*\&*|*\<*|*\>*|*\|*|*\;*|*\`*|*\[...

 
 
1 hour later…
 
2 hours later…
7:51 PM
@Gilles heh. do we have a Mir proponent here?
 
8:26 PM
@strugee No, rather the opposite
Those who don't understand X are convemned to reinvent it, poorly (after Henry Spencer)
 
slm
8:44 PM
Can anyone confirm how you'd start x11vnc on debian + GDM + XFCE?
1
A: LAN only VNC help

slmMethod #1 - VNC from ComputerA -> B where a user is already logged in on B You don't specify what VNC client you're using but one of the more popular ones is Vinagre. It's typically included with GNOME desktop based distros, which should cover most of the larger distros. Installation First yo...

I provided directions for Ubuntu but assuming Debian doesn't use lightdm.
 
@slm debian uses whatever you install
but probably gdm if you follow the path of least resistance
that question is confusing. Which of A and B is the server?
what debian doesn't use unless you install it explicitly is upstart. Debian defaults to sysvinit
 
slm
@Gilles - after the entire day I found out Debian is the server, and Ubuntu is the client
to confirm things are working I told him to run x11vnc via command line and then connect to make sure it works first, if it does we can worry about making it a startup service afterwards.
@Gilles from time to time we get ppl answering these Q's which already have acceptable answers, should we protect these?
-1
A: What is the difference between `grep`, `egrep`, and `fgrep`?

kumaregrep support "regular expression".but fgrep does not support it.

This is the A that seems unnecessary.
-1
A: What is the difference between `grep`, `egrep`, and `fgrep`?

kumaregrep support "regular expression".but fgrep does not support it.

 
9:08 PM
@slm this one is redundant, the other is technically wrong but so devoid of information I'm flagging it as VLQ. Neither answer serves any purpose.
the question will be automatically protected if these two answers are deleted, I think
Ah, Michael sniped me
and no, no protection. I thought three deleted answers from users who would have been stopped by protection would have done it
I see, the twist is that Kumar's two answers only count once
 
slm
I marked it as protected any way
@Gilles - Also if you DV a answer such as that, a delete option is revealed. Why not just vote to delete it instead?
 
@slm you can only vote to delete if the score is negative
 
slm
@Gilles - right so if you DV it I believe the delete link then shows up. Unless this is considered a loophole.
 
yes
well, you have to reload the page
 
slm
I didn't have a problem in doing it, I was just checking if my logic was OK.
 
9:17 PM
why would it be bad form?
 
slm
I didn't have a problem in doing it, I was just checking if my logic was OK.
 
10:17 PM
@Gilles you mean you're an X11 proponent? what?
 
@strugee how could you have any doubt?
it's far from perfect, but I have no confidence in anyone doing better
 
@Gilles I don't really understand the reasons that people support X11
 
for a long time the Wayland people refused remote access as a use case. I use it almost daily.
 
I mean, if you can name actual technical problems with Wayland then I'll buy it but no one really has any arguments that hold water. WRT to the remote access thing, that was a problem but they have a solution for that now
 
10:45 PM
Is wayland actually mature/stable enough to compete with X11?
 
@terdon Wayland is the protocol. Wayland support is becoming fairly mature
 
@strugee I really haven't been following this, I know it is set to replace X eventually but as far as I know, it hasn't done so yet. Are you using it? Will I be able to ssh -Y and export DISPLAY to my local machine?
 
11:04 PM
GNOME 3.10 shipped with a GNOME Shell that can act as the Wayland compositor and mostly complete toolkit support
the port is almost complete but there are patches where support is still missing
 
Yeah, I've been staying WELL away from that horrible mess that is gnome3
Tried it briefly, got annoyed and discovered mate => xfce => cinnamon
Gnome2 managed to convince me to use a DE instead of the wonderful WindowMaker I'd been using for years. And then they went and screwed it up...
 
Cool, thanks
 
yeah I got really angry at gnome for a while, which is why I switched to awesomewm
but it's actually pretty nice nowadays so I just switched back
 
> Nvidia binary drivers do not work currently
potential reason...
nvidia being the partypooper... as always :(
 
11:10 PM
@Braiam yeah, just saw
 
false. the reference Wayland compositor implementation, Weston, doesn't do Nvidia
 
However, note that the party pooper has been consistently offering drivers to the Linux community for more than a decade
 
because the Nvidia driver doesn't support kernel stuff like DRM and KMS
 
also that the only decent docs on how to configure X (as in xorg.conf) I've ever found came from nvidia
 
> Canonical has recently announced that they were abandoning their earlier plans to use Wayland, and instead are developing their own display server called Mir now.
but.... why??!?
@terdon I'm not saying they are bad, just that when they screw up, they screw it up
 
11:14 PM
yeah.. I've just had so much pain trying to use ATI cards with Linux over the years that I've grown to like nvidia. Despite their horrible name
 
there's nothing in the Wayland protocol that doesn't work with Nvidia. or the BSDs. or display over the network. that's just Weston that doesn't implement support for those things
 
well, I just think that Mir without Intel will be a serious mess...
 
@Braiam yeah Mir is my number one problem with Canonical. see ramblingsfromalex.blogspot.com/2013/07/goings-on.html for the reasoning (it's around the second paragraph)
 
@strugee canonical has been going down that road for years. They lost me the second they came out with unity and I had moved away from my brief stint with Ubuntu before that.
 
yeah it's bad
 
11:20 PM
On the other hand, they have brought a lot of new users to GNU/Linux and that''s a good thing.
 
upstart is also terrible, IMHO
 
I'm just damned if I know why anyone who actually knows how to use a Linux system would go for Ubuntu.
I'm happy canonical are out there, I just wish they'd stop bugging me
 
@strugee wait, upstart seems like a good thing, a bit weird, but when you figure it out gets the job done
 
@Braiam By the way that was a great emacs answer for a guy who does not (I think) use emacs! Well done!
Any tmux or screen people around? This should be possible using screen right?
1
Q: How do I retain my shells and SSH connections on my laptop after I leave work?

barrristaI have a laptop I bring to work and back home. At work, I often set up a lot of shells and open ssh connections. When I go back home, I have to restart all these connections, after logging into my home network, and then the VPN. It's a bit of a hassle to set up everything if I have a lot of shell...

 
@terdon he could use a ssh proxy, no? to keep the sessions and just log in the ssh proxy
 
11:28 PM
Don't think that's possible on different networks is it? The master connection would still be closed when he left work.
I was thinking of setting everything up through screen or tmux sessions, then going home and reconnecting to the running screen sessions.
 
@terdon generally Upstart is OK but its event system is really weird
for example the sytemd way of doing things is to say: "oh, you want to start apache? in order to that, I need to bring up the network, so I'll do that for you." the Upstart way is: "I've just brought up the network. I might as well bring up Apache now that that's done."
 
@strugee you can set the network to be bring up when you start a service ;)
with upstart too
 
right, I know. I just find the events system to be backwards
in that example, the end result is the same. but the mentality that everything that can be brought up should be brought up seems like not a good idea
 
Ummm, I'd rather bring the network up myself. If I start apache locally, it is to access things on my machine. If I want to bring up the network, I'll do so.
@strugee both systems you described seem to be bringing up everything that can be brought up.
 
@terdon the point is that systemd will normally bring up the network, as it is a dependency of the default target (which is the equivalent of the default runlevel). but it will not bring up apache unless apache is explicitly enabled
and besides, I find systemd unit files to be way easier to understand than Upstart's sh scripts
0pointer.de/blog/projects/systemd.html is a nice talk. search for "on upstart" in the page
 
11:37 PM
this is the problem (?) with cheap cellphones: the date reads 58.247.201
 
@strugee I admit that I prefer .sh scripts since I speak sh and can modify them if needed.
 
oh well, apparently the new years confused the poor thing
 
@terdon yeah, I can understand that. personally I'm not comfortable writing really complex scripts yet (e.g. I don't quite know how to parse arguments yet)
 
Oh, neither am I, not in bash or sh anyway (Perl is another matter). However, I understand enough of the syntax to be able to hack it if needed.
Actually, @strugee do you have a nice reference comparing upstart and systemd?
 
hmm
 
11:41 PM
Also, what's a reliable and simple way of finding out which system a particular machine is currently using?
@Braiam awww poor beastie :)
 
yeah the link above is a fairly good comparison, IMHO. for full disclosure, it is written by Lennard Poettering, but it's pretty fair
 
reading it now
 
@terdon for systemd, check for the existence of /usr/bin/systemctl. for Upstart I believe you can check for the existence of /etc/init.d but don't quote me on that
 
I think init.d is WAY older than upstart
 
I believe /etc/inittab is gone in Upstart too so you can use that as a sysvinit check although it may fail if the user had upgraded to Upstart
 
11:44 PM
At least, it's been around for as long as I've been using Linux and I started in '99 or so
 
oh nevermind I meant /etc/init
without the .d suffix
 
ah, that one maybe
@strugee no it's not, I have it on my Debian and I'm using upstart
Think so at least. The only time I've seen sysctl was on arch
 
ah. nevermind then. maybe init --version will help, but I don't know enough about it
sysctl sets kernel parameters, IIRC. systemctl controls systemd
 
I think the absence of systemctl is a good indication of upstart, at any rate, it suggests you are at least not using systemd
@strugee yeah, meant to write systemctl
 
oh. and yeah that's a good indication
 
11:50 PM
Hmmm, I might make this into a question
 
yeah I was just thinking that
 
@terdon you mean absence of systemctl is an indication of not-systemd
 
@Gilles yes, that's what I said: "... at any rate, it suggests you are at least not using systemd"
 
@terdon yes. Why single out upstart?
 
Because most modern Linux distros are using one or the other and because I was wondering how to distinguish between them.
 
11:52 PM
@terdon no
 
no? Haven't most switched to one of the two?
 
some are still using sysvinit
 
Yes, I think Debian still is actually, but I thought most had gone with one of those two.
 
@terdon debian, slackware, gentoo
 
Debian is only just finishing the debate of which one to switch to. it's looking like it's gonna be systemd though
 
11:54 PM
:(
well, it could be worse, I guess: it could be upstart
upstart isn't production-ready, its documentation sucks big time
 
@Gilles are all using sysvinit?
 
@terdon gentoo's doing its own stuff
 
@terdon Gentoo is on OpenRC
Upstart's a mess
@Gilles I take it you're not a systemd fan?
 
@strugee if it ain't broke, don't fix it
 
@terdon upstart is "optional" in debian
 
11:56 PM
but it is broke
 
I have no experience of systemd
I've used Ubuntu, and upstart sucks
 
sysv initscripts are broken :-(
I come to that conclusion every time I try to actually get OpenVPN to start/stop in the right order
 
sysvinit doesn't have the kitchen sink, but it works
 
systemd doesn't have the kitchen sink either, really
 
@Braiam That's the thing. I know I played with both systemd and sysvinit on my system but I really am not sure which one I am using right now... /me blushes
 
11:58 PM
O:
 
Or whenever I make a /etc/init.d script, the amount of copy & paste boilerplate is pretty high.
 
initctl
zsh: command not found: initctl
The program 'initctl' is currently not installed.  To run 'initctl' please ask your administrator to install the package 'upstart'
initctl: command not found
 
@terdon what distro?
oh that's a good heuristic
 

« first day (1181 days earlier)      last day (2891 days later) »