« first day (3874 days earlier)      last day (133 days later) » 

9:21 AM
can someone help me with sysctl ? been struggling all night... is this allowedhere ?
 
@Freedo what are you struggling with?
 
I tweaked TCP to improve speeds and it worked. But then I started seeing weird ffmpeg segment fault and "tcp out of memory consider tuning tcp_mem" in dmesg logs. I tried ridiculous large and small values but nothing fixes it
I can reproduce the issue easily by just restarting the server - when it starts everything at once it really creates a lot of load
I know it's not a hardware issue because this start happening with all my servers at once, and I even asked my hosting provider to do all the checks in 1 server
and never at any point my system lacks ram at all, i always have 60gb+ free
this is my current sysctl, the last try I just did pastebin.com/R63TGiVh
 
ah, this is
0
Q: Is there any side effect of setting rmem_max and wmem_max very high?

FreedoI have high traffic load balance servers and I tweaked TCP to get more performance. It worked but now I'm getting kernel messages like "tcp out of memory" I have very high RAM >32GB and barely uses it so I'm not concerned about hardware usage, only max performance. This is my settings right now: ...

right?
 
I'm trying to optimize TCP for fat long pipes, my clients are 250-350 ms from my servers and the default linux settings were very bad
yeah it is
I did get a lot of speed improvements tho...like 100% or more in some networks but then I have this weird issues now :(
 
250-350ms? that’s really high latency
 
9:31 AM
yeah but due to cost i can't get closer to them :( but it does work well
 
you’re not tuning tcp_mem itself though, have you tried that?
 
what do you mean ? net.ipv4.tcp_rmem = 67108864 67108864 67108864 I have this right now
oh I see
 
tcp_mem, without r or w
 
my values right now are 1540443 2053927 3080886 for this variable
what values do you suggest ?
If those man pages told us a formula or math to calculate the values it would make life so much easier
 
you could try 67108864, same as your rmem settings
 
9:37 AM
like I have no idea if it should be the same as rmem settings, double, etc
 
I’m not sure how well things work when all three values are equal though
 
I made all the values equal because I want tcp to send as much as possible as fast as possible due to the high latency. Don't want to waste time starting slow and then increasing...makes sense?
 
yes, I’m talking about tcp_mem
 
yeah, this is my reasoning for making the values equal for some settings. Don't know if it's ok but doesn't seem to do harm
i'm going to try tcp_mem now thanks!!
but i'm open to any suggestion too :)
for further improvements i mean
it seems 67108864 did not stop the ffmpeg segmentation fault errors will try bigger
net.ipv4.tcp_mem = 134217728 and 268435456 didn't work either. I keep seing the message in my dmesg logs :( don't know what else to do
[ 3611.668801] ffmpeg[292213]: segfault at 19 ip 00000000011597b5 sp 00007ffc82c40490 error 4 in ffmpeg[400000+2704000]
[ 3611.668812] Code: 00 00 00 48 8b 07 c7 44 24 08 18 00 00 00 48 89 4c 24 10 48 8d 4c 24 20 c7 44 24 0c 30 00 00 00 48 85 c0 48 89 4c 24 18 74 1b <81> 78 18 01 0f 32 00 7e 12 83 fe 07 48 63 40 1c 7e 09 85 c0 74 05
I'm getting those errors
 
10:01 AM
you’d need to figure out why ffmpeg is segfaulting; run it under gdb and look at the output of bt
you might need to install debugging symbols for ffmpeg and any libraries involved
 
it's weird because this only started happening after I made the sysctl changes. so I thought it was that
 
@Freedo I just left a comment under your question. It would really help if you could add some detail, there's no explanation there at all.
 
will do
 
Please edit your question and add some more detail. What operating system are you using? If Linux, which one and which kernel version? What is the file you are showing us? How are your servers "asking for more RAM"? What symptoms are you seeing? — terdon ♦ 1 min ago
Sorry. I had fixed a typo in the comment and it wasn't showing up!
 
I edited the question. I'm on ubuntu 18.04 and kernel 5.6.4
I just restarted the server with an empty sysctl and it seems the ffmpeg issues continues so I don't even know anymore what could be! Could just be a weird coincidence that this started happening in all my servers after I only changed sysctl
 
10:15 AM
@Freedo Thanks, but you still don't tell us what the file you are showing is. And you also give the segfault but don't explain what command you're running. I mean, you never know, maybe the issue is specific to the command you are running, the formats you are giving ffmpeg or whatever. For instance, you don't tell us if this happens only with one specific ffmpeg command or all of them.
 
there are hundred of ffmpeg commands running, so I can't tell
 
(note that I don't have the faintest idea what the problem is, I don't know the first thing about this sort of issue, I just figure the more info you give, the better your chances of someone knowing)
 
I'm using dmesg to see the errors
 
@Freedo OK, so you see that in dmesg or some other log file? That's relevant information. Basically, don't ever show output or file contents without explaining what output/file you are showing cause otherwise people can't understand what they are reading.
 
I just thought that the tcp memory messages + segfaults were all memory related so the cause would be sysctl
only in dmesg @terdon
 
10:19 AM
@Freedo It could well be. Stephen knows a hell of a lot more about that than I do (not hard, I don't know anything about it, as mentioned above). So please edit and i) tell us what file your settings are set in, for all we know you're looking at the wrong file (unlikely, but that's why we need to know) and ii) clarify what your server is doing, why ffmpeg is running. Something like "the server is used to convert media files and is constantly running different ffmpeg commands"
That said, the first thing I would do is to try and reproduce the error by running the ffmpeg command manually so you know exactly where it is coming from.
> [ 3611.668801] ffmpeg[292213]: segfault at 19 ip 00000000011597b5 sp 00007ffc82c40490 error 4 in ffmpeg[400000+2704000]
I think the 292213 is the PID, right? So if you keep track of the PIDs used by the various ffmpeg processes, you should be able to figure out which command is causing the errors. That could help.
 
yes I thought about that, but doing a ps ax | grep ID doesn't give me any results
and yes the server is used to process media so there is a lot of ffmpeg commands running to a tmpfs folder
I can't predict which ffmpeg process will give an error so it's hard to debug...i'm totally lost here and running out of time :(
 
@Freedo by that time it has crashed. You would need to monitor the PIDs either as you launch each process or if that isn't possible by running something like this in a loop:
> ffmpeg.pids; while :; do ( cat ffmpeg.pids; ps -ao pid,args ) | sort | uniq > temp.file && mv temp.file ffmpeg.pids; done
Obvious race condition there, so you might miss one or two but that should get most of them. All of them even, in most cases.
 
Or you could rename the ffmpeg binary, and replace it with a shell script which logs its arguments, tries to run the renamed ffmpeg, and records the exit status (so you can find runs which segfaulted).
 
ok will run that and restart my services, thanks a lot
it's saying ffmpeg pids doesn't exist? the loop doesn't seem to be doing anything
 
@Freedo If it says the file doesn't exist, you didn't include the > ffmpeg.pids in the start. But that's fine, it will exist after the first iteration. And it won't print any output, to see if it's working, run tail -f ffmpeg.pids
But Stephen's suggestion is much better.
You would do something like this:
sudo mv /sbin/ffmpeg /sbin/ffmpeg.orig
cat <<EoF > /sbin/ffmpeg
#!/bin/sh
/sbin/ffmpeg.orig "$@" &
echo $! >> /tmp/ffmpeg.pids
EoF
sudo chmod a+x /sbin/ffmpeg
1. rename the existing binary
2. create a simple script named ffmpeg that calls the binary with the arguments you give it and also logs the PID
3. make the script executable
 
10:33 AM
echo $! : $* >> /tmp/ffmpeg.log would allow matching pids with command-line arguments
 
will try now, it would help a lot to see full ffmpeg command yeah
you guys have the best ideas
 
@StephenKitt yes, even better indeed
sudo mv /sbin/ffmpeg /sbin/ffmpeg.orig
cat <<EoF > /sbin/ffmpeg
#!/bin/sh
/sbin/ffmpeg.orig "$@" &
printf 'PID: %s COMMAND: /sbin/ffmpeg.orig %s\n" "$!" "$*" >> /tmp/ffmpeg.pids
EoF
sudo chmod a+x /sbin/ffmpeg
 
a wait might be helpful too, to avoid increasing load by accidentally parallelising ffmpeg runs
 
I struggled a bit to replace the ffmpeg file because it was in use but got it now. Will run the script now and hopefully will be able to locate the source of the issues
hmm I'm getting unterminated quoted string. think a syntax error somewhere?
my file look like this
cat <<EoF > /usr/bin/ffmpeg
#!/bin/sh
/usr/bin/ffmpeg.bak "$@" &
printf 'PID: %s COMMAND: /usr/bin/ffmpeg.bak %s\n" "$!" "$*" >> /root/ffmpeg.pids
EoF
 
It should be:
printf 'PID: %s COMMAND: /usr/bin/ffmpeg.bak %s\n' "$!" "$*" >> /root/ffmpeg.pids
@Freedo I think.
 
10:45 AM
I'm running that now...waiting for services restart
well this is weird, now it seems like my services are refusing to run ffmpeg? it's not logging anything but if i call ffmpeg -i it's logged correctly.. i'll research what could be happening
 
Whoops, yes, sorry @Freedo and thanks @fra-san.
 
my software is calling ffmpeg from another path, will try to log again now
and np terdon lol! i have been a (shitty) linux sys admin for like 2 years now and i'm not even close to your guys lol
 
In my defense, I am a biologist! :P
 
@terdon the script mutated twixt brain and chat
 
If anything I say contradicts what Stephen or fra-san say, believe them, they will probably be right.
About *nix stuff anyway. Not about beers. They don't know crap about beer! :P
 
10:54 AM
mknod /dev/beer — oh wait I need to allocate some numbers
 
well my software was refusing to run ffmpeg because obviously it can't log to /root lol
so dumb
 
log to /tmp that's easier
 
ok i got it to run without issues as my non privileged user, but it's not logging the PID? or anything after /usr/bin/ffmpeg.bak
i ran ffmpeg -i to test
 
@terdon Actually, I love IPAs...
And I'm not a professional sysadmin nor I have a CS background. So, to summarize, if what terdon says contradicts what I say... believe what Stephen says :-)
 
my log is only repeating those lines
PID:  COMMAND: /usr/bin/ffmpeg.bak
" "" ""PID:  COMMAND: /usr/bin/ffmpeg.bak
" "" ""PID:  COMMAND: /usr/bin/ffmpeg.bak
" "" ""PID:  COMMAND: /usr/bin/ffmpeg.bak
" "" ""PID:  COMMAND: /usr/bin/ffmpeg.bak
shouldn't it appear my ffmpeg -i there?
well i'm not professional either or studied this...I use google a lot and usually it's enough lol
 
11:06 AM
what does cat /usr/bin/ffmpeg show?
 
it seems for some reason when i created the file with cat it ate the @
:facepalm:
 
@Cbhihe by the way your "about you" commnad should be updated
any characters within bracket expression is just a literal character except some exceptionally
 
@αғsнιη Cbhihe doesn’t frequent chat and therefore is unlikely to see this
 
@StephenKitt but I ping him/her with @, still xe will not get the ping?
that's not working in chat?
 
@fra-san I knew I liked you for a reason! :P
 
11:16 AM
wait amomnet
 
I made sure the ffmpeg is like you guys said but is still not logging/executing right
 
@αғsнιη It only works for the limited number of "pingable" users.
 
#!/bin/sh
/usr/bin/ffmpeg.bak "$@" &
printf 'PID: %s COMMAND: /usr/bin/ffmpeg.bak %s\n" "$!" "$*"' >> /tmp/ffmpeg.pids
 
Those that have been seen in chat recently, whose name "tab-completes" after you type "@" in a chat message.
 
@fra-san 🙄
hmmm, didn't know that. I remember one time I think he was @terdon I'm not sure, he used some power of his Mod and pinged someone
 
11:19 AM
my log is only this now:
PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
" "$!" "$*"PID:  COMMAND: /usr/bin/ffmpeg.bak
 
@Freedo your quoting is still wrong
printf 'PID: %s COMMAND: /usr/bin/ffmpeg.bak %s\n' "$!" "$*" >> /tmp/ffmpeg.pids
 
5 double quotes in a string are always suspicious
 
My fault, sorry. I previously posted a wrongly quoted line, immediately deleted the message and re-posted a fixed one.
 
oh yeah now i see the ffmpeg commands flowing
 
@αғsнιη yes, mods can ping any user but non-mods can only ping the ones who have been in the room in the past 2 or 3 weeks.
 
11:22 AM
@StephenKitt test
 
@αғsнιη that works because I’m pingable
Cbhihe isn’t
 
sorry, I was testing something else
 
@terdon directed replies always work.
oh that was terdon
 
I want to know how can I reply on my own replies here
 
edited :P
 
11:23 AM
@AndrasDeak “directed replies always work” — even on ancient messages whose authors are no longer pingable?
 
@StephenKitt my point exactly, yes
 
@αғsнιη you need to find your message id and start your message with it, prefixed with a colon
 
@αғsнιη you need to grab the message ID yourself
 
I see the pids in my dmesg log, but when I grep the log file it doesn't give any results?
 
@Freedo buffering?
or what do you mean by "the log file"?
your grep might be broken too
 
11:25 AM
@terdon got it, I was thinking for something like pinging using SE global profile Id, with that we can ping? or still no way for us?
 
copy a few lines that you want to find into a regular file and then practice grep on that
@αғsнιη that's the mod superping
 
I think i got it now
you guys are the best
now I can at least know which ffmpeg proccess is crashing
 
@StephenKitt yes, I did like that but it brought your message id after I hit enter
 
@αғsнιη no, you can only ping those who have been in the room recently
 
11:27 AM
Ah yes, hurrah for hidden features!
 
yes, understood, thanks
@StephenKitt but where to find my message Id? after some grace period there is no way to find the Id seemz
 
ok so now that i can find the problematic commands, how do I debug the segfault? strace?
 
@αғsнιη context menu -> permalink
 
ahhh, much difficult
 
yes
it's manual ;)
 
11:30 AM
why would ffmpeg have a segfault ? with files that never caused a issue before?
 
@AndrasDeak thanks
 
@Freedo run the command with gdb (gdb --args ffmpeg ...), then run, and after it crashes, bt to see where it’s crashing
@Freedo usually it’s a bug, which might have appeared because of updated libraries
 
everytime it was harming me that cannot continue reply on my comments 😂
 
weird. because the only thing i really did to those servers recently was sysctl, and apt upgrade
 
apt upgrade sounds like "updated libraries"
Have you checked if there's a newer ffmpeg version out since?
apt policy ffmpeg for instance can tell you
 
11:33 AM
my software uses it's own ffmpeg version, so it's pretty old yeah
 
@Freedo ah, you probably need to rebuild it then, if that’s possible
 
@Freedo can you not rely on ffmpeg as an external dependency?
 
do you guys think i should just try to do that instead of debugging further ?
lol the server load is at 1700, this never happened before the ffmpeg wrapper
 
@αғsнιη you can also use a userscript to reply. Unfortunately, it isn't maintained anymore but this is the code you can add with tampermonkey or equivalent:
/** @preserve
// ==UserScript==
// @name           Chat Reply Helper for Stack Exchange sites
// @namespace      oliversalzburg.github.com
// @version        2.6.2
// @description    Handle structured conversations more conveniently
// @homepage       github.com/oliversalzburg/se-chat-reply-highlight
// @grant          none
// @include /^https?:\/\/chat\.stackexchange\.com/.*$/
// @include /^https?:\/\/chat\.stackoverflow\.com/.*$/
// @include /^https?:\/\/chat\.meta\.stackexchange\.com/.*$/
 
@Freedo that’s because the wrapper starts ffmpeg in the background and finishes immediately
see my wait comment a while ago
 
11:41 AM
@terdon ahh, god, what are these codes!
 
@αғsнιη partially minified JS
 
I'm going to try to download latest stable ffmpeg and replace my binary and hope for the best, but probably won't work
 
it hacks your browser to inject new functionality on certain webpages
Userscripts can also do harm so make sure you trust the person who's giving it to you. In this case it's terdon. Ummm...
 
@AndrasDeak I would prefer manual copy'n'paste way
😜
 
@αғsнιη so...?
8 mins ago, by Andras Deak
@Freedo can you not rely on ffmpeg as an external dependency?
@αғsнιη when you say "manual copy'n'paste" do you mean "manual rather than copy'n'paste"? Otherwise I have no idea what you're saying, sorry.
 
11:44 AM
BTW the second draft of the 202x revision of POSIX is out for review, see opengroup.org/austin for details
 
@AndrasDeak I mean coping from Permlink
@αғsнιη test
 
aaah, OK
yeah, I prefer that too
 
@AndrasDeak fair point. I can tell you that the script was originally written by this guy:
And that I've been using it for several years and never had a problem. It was also, at the time, available in the chrome store.
 
I'd still grep the code for rm -rf. You know, just to be safe.
 
@AndrasDeak what do you mean you don't like the thrill of running code from strangers on the internet ? :P
 
11:50 AM
$ rm -rf /
rm: it is dangerous to pull a terdon
rm: use --no-terdon-involved to override this failsafe
2
 
@Freedo strangers are one thing. But we're talking about terdon.
 
I was joking lol
 
Freedo might not be aware of the meme
23
Q: Are there any memes on Ask Ubuntu?

AkivaJust curious. After reading about the infamous "Boat Programming" question, I wondered if anything like that has existed on Ask Ubuntu.

 
I'm not!!
ooh lmao
 
seniority as a sysadmin is measured in how many systems one can destroy inadvertently
 
11:53 AM
it happens to the best
but anyone who spends like 10min in linux should know what rm does lol
 
@StephenKitt go drink an IPA or something.
:P
 
IPA, the lego of beers
 
@terdon I’m sure a PPA with a patched version of coreutils would achieve a decent level of popularity on AU
 
heh, I still can't see the original question
 
11:55 AM
I compiled a new ffmpeg version and i'm running it now
crossing my fingers
 
I guess we'll never know why you have to vendor ffmpeg yourself
 
and the segfaults continues :(
 
in Ask Ubuntu General Room, Jun 23 '15 at 16:43, by Mudit Kapil
@Fabby How can Linux be cruel? I read it somewhere.
 
I'm testing ffmpeg static 4.4 from john now
 
what’s wrong with your distribution’s ffmpeg?
 
12:03 PM
@terdon huh, so I could see the original question
 
idk, i never uses it? must be ancient too probably
 
So you answer Stephen just like that? I'm hurt.
 
oh i mean no offense
 
but that's also a terrible answer so I'll just phase out :P
 
@Freedo it might just work though ;-)
 
12:06 PM
with ffmpeg 4.4 it doesn't even run :(
it seems my software uses some ffmpeg flags that are not present in newer versions
 
@Freedo so perhaps version 3.4.8 as provided in 18.04 would work
 
yeah will try that too
 
I haven't finished reading this, and it should probably hit our Meta at some point, but FYI:
2
Q: The future of Community Promotion, Open Source, and Hot Network Questions Ads

JNatIt's now May, and if Community Promotion or Open Source Ads are something you care about, you may have noticed that there hasn't been a 2021 refresh yet. In case you missed this post, please check it out for some details about why the refresh was pushed back, and why a project around the rethinki...

 
yeah no luck with ffmpeg 3.4.8
I think i give up for now, i will probably hire a professional to fix this
thanks for all the info guys I learned a lot
if anyone wants to take it pm me if this is possible here, or leave some form of contact...
 
The funny thing about the word "disinfectant", and the M-W definition is that even if it says "especially: a chemical agent that is used especially on hard surfaces", the whole definition of "disinfect" there refers to cleaning non-living things: "1. disinfect: to cleanse (a surface, a device, a supply of water, etc.) ...". All the examples are about cleaning objects or purifying water.
 
12:22 PM
I think it may be a bit like that gray dress thing; you can interpret comments positively or negatively based on some pre-existing bias. Are they rambling off ideas to help stop a virus? Are they earnestly suggesting that people go off and drink bleach? Again, I'm not in the habit of taking medical advice from politicans (or actors, lawyers, military leaders, etc), so I don't have a dog in this fight.
 
Blah, I thought I saw some definition for "disinfect" which basically excluded use on living things, but it was the other way around, Wiktionary says of "antiseptic": "Generally includes only those that are used on living objects (as opposed to disinfectants) and aren't transported by the lymphatic system to destroy bacteria in the body (as opposed to antibiotics)."
but yeah, maybe I should go to English.SE
"some stuff he had heard about and didn't understand"
That part is the/a problem in itself.
 
or history.SE ;)
 
hehe
 
@ilkkachu I never said there wasn't a problem simply that the problem wasn't nearly as bad as the media made it out to be.
Also I got notified like 25 times as you edited that >.>
 
@jesse_b oops, sorry! :D I forgot it pings for edits too. also I hate how the formatting works differently in chat vs. elsewhere
 
12:32 PM
And really when looking at it I think he is talking about bleach/misc household cleaners when he says disinfectant but then he goes on to say "Is there a way we can do something like that...". Which is just some sort of wishful thinking. Essentially: "Disinfectant works so well on surfaces, can't we just make something like that for humans?"
important things to look at: "Is there a way" (asking) "Something like that" (explicitly not exactly that)
 
@AndrasDeak yeah. I only deleted my answer with the dangerous command. I posted the screenshot because it can be seen there (mod thang).
 
@ilkkachu My problem with it is these things actually give him support. If they had just reported that Trump thinks we should try to make human safe bleach, or that Trump thinks we should just invent a miracle cure all drug (like that hasn't already been tried a million times), etc it would be no issue. But what they did was say "Trump suggests taking bleach for covid" which is just clearly not true. A lot of people just support him more when they see any lie about him.
 
12:51 PM
@jesse_b yeah, esp. in cases where reporting only on what was actually said and done would be damning enough. "Trump draws inspiration from household cleaning agents, wonders if medical professionals could develop a cure for Covid" :P
 
@ilkkachu That's actually perfect lol
 
@terdon it was just a peculiar reply to that first message.
 
then again, someone would think him saying that means actual professionals never thought about even trying ;D
but yeah, reminds me of the way the media sometimes treats the True Finns up here, and of the latest RMS fiasco.
 
filibuster party
 
1:36 PM
hi, what would you say to a new raku tag for perl6? i could retag a few old posts for a start if you introduce this tag
 
@Tomasz My initial reaction would be to alias it to
sorry, "synonym" is the right word
 
that's exactly the opposite of my intention
i wonder what's raku's place in U&L today and in the future
this might help in research and anyhow - doesn't it deserve a separate tag?
 
well, reading about Raku, I see that backwards compatibility is not a goal, so perhaps there's merit to a separate tag.
 
for a comparison - from what i see python3 is not linked to python
 
could really use an excerpt and wiki!
 
1:46 PM
defo
 
@JeffSchaller yes, Raku is not Perl
 
I thought raku was perl 6
@JeffSchaller that's just python
 
@AndrasDeak right, but IIRC it was decided to drop all semblance of backwards compatibility, hence the change of name, and continue maintaining Perl 5
 
from what i know pyhon3 is more python than perl6 is perl
 
Yes, python 3 is all python
 
1:53 PM
@AndrasDeak well, perhaps something to make it even more obvious that it's v3? shrug I'm ever the optimist that tag excerpts & wikis will be helpful.
 
@JeffSchaller synonym of just python? :P Mind you I haven't checked your questions on the topic.
 
@AndrasDeak I think we missed a step somewhere. The python3 tag is distinct from the python tag because it's not backwards compatible. The python tag has an excerpt & wiki, but the python3 one does not.
(I was lazily hoping to find out why we had a python3 tag by reading its excerpt & wiki here)
 
python has very scant tag info too, so in case it's merged with p3 someones might win a double reward
 
2:08 PM
will someone create the raku tag for my librarian frenzy then, or should i check tomorrow?
 
2:21 PM
@JeffSchaller on the contrary. Python 2 is not compatible with python :P
 
@AndrasDeak sometimes grep also don't save you from a danger, see for example this basic encrypted script
-4
Q: What does this bash script do?

Archisman PanigrahiI found a bash script in the Andronix website, for enabling sound in GNU/Linux rootfs running in Termux. However, the contents of the script seem to be cryptic, and I want to know what commands I am running before I run them. How to decode such a bash script, and what all commands does it run? z=" "

 
@αғsнιη well we were talking about JS so JSF**k applies
 
2:38 PM
Is rm -fv * .* | grep \^removed | wc -l a valid answer to question 1 in
0
Q: a couple unix questions I could use help with

selectsnasher61 I need a UNIX command that counts and outputs the number of ordinary files (hidden as well as non-hidden) under your current working directory. The command may involve two pipes and should simply output one number. I need two Unix commands. The first one should copy the file passwd under /bin ...

 
Question is how careful their TA is
 
@StephenKitt step 0: switch to the root user and cd /bin
 
@JeffSchaller which would also serve to show that processes in a pipeline can start in parallel!
 
3:20 PM
Experience is what you get after you need it. We're all about educating our users :)
 
@JeffSchaller that could be our slogan — “Increase your experience. You might not like everything you’ll learn along the way, but you’ll definitely learn!”
 
3:42 PM
https://fs.blog/2021/05/advice-for-young-scientists/ -- "Medawar believes it’s unnecessary for scientists to spend an enormous amount of time learning techniques and supporting disciplines before beginning research:

*“As there is no knowing in advance where a research enterprise may lead and what kind of skills it will require as it unfolds, this process of ‘equipping oneself’ has no predeterminable limits and is bad psychological policy….The great incentive to learning a new skill or supporting discipline is needing to use it.”*"
Ironic timing for that blog post :)
 
Stephen, slayer of worlds and king of all things docker. Do you know why dell's racadm command would fail when I use the default bridged network mode but work when I use host network mode?
I can ping the host and telnet to the host in either network mode but I am going over a vpn
 
@jesse_b not off the top of my head...
 
I recently reimaged my mac and that is when this started, prior to that it worked in the default mode and it works in default mode for my other teammates. I thought networking was broken over the vpn altogether but it seems that isn't the case
 
I have a big problem that I don't like a line start with uppercase letters except some, like these are OK if they come at the beginning, I don't know the reason yet
 
@jesse_b there's the problem: your Mac is now thinking different :)
@αғsнιη you and every person writing on the Internet! I'm grumpy about it because I learned that English sentences are capitalized.
 
3:58 PM
@αғsнιη these characters only are fine to me I, U, Z, V to start the line
that's why I chose my name first letter lowercase
all uppercase is also fine
most of the times I write my answers first letter lowercase but it gets edited often by editors
that is also fine, I myself really don't like to start with uppercase
except those 4 letters above said, it's a big issue to me I think?
I even don't like even numbers 😂😂
except some
 
It isn't really a question of opinion that one. Sentences need to start with a capital letter and end with either a . or a ! or a ?
That's just the rules of the language.
 
but I feel uncomfortable when using the thing that I don't like
:/
 
@terdon shame about the grammar :-P
 
4:13 PM
even we have a capslock day for that
🤦🏻‍♀️
@terdon and semicolon? 😝
 
What is the difference.
```
awk '{if($1==x){i=i" "$2}else{if(NR>1){print i};i=$0};x=$1;y=$2}' test.cov <(echo)
awk '{if($1==x){i=i" "$2}else{if(NR>1){print i};i=$0};x=$1;y=$2}' test.cov; echo
```
 
@αғsнιη Strictly speaking, no. A semicolon doesn't end a sentence.
 
@terdon If writing two commands in single line?
 
@PrabhjotSingh first one is single command, second is two separate commands
@terdon hmm.
 
What @αғsнιη said. The first is using the output of echo (an empty line) as the second input file for your awk command. The second is running your awk on the file test.cov only, and then as a completely separate command, it runs "echo".
> In the English language, a semicolon is most commonly used to link (in a single sentence) two independent clauses that are closely related in thought. When a semicolon joins two or more ideas in one sentence, those ideas are then given equal rank.[2] Semicolons can also be used in place of commas to separate the items in a list, particularly when the elements of that list contain commas.[3]
 
4:19 PM
@αғsнιη Thanks. Shukriya
 
A semicolon doesn't end a sentence. Usually, it ends a part of a sentence; but allows the sentence to continue until the full stop.
(and that was a bad example of semicolon use, it doesn't make much sense there, it is just to illustrate the point)
 
@terdon I also using semicolons a lot in my answers, I don't know if you noticed it or not.
 
I haven't, no.
Here's a better quote:
> Although terminal marks (i.e. full stops, exclamation marks, and question marks) indicate the end of a sentence, the comma, semicolon, and colon are normally sentence-internal, making them secondary boundary marks. The semicolon falls between terminal marks and the comma; its strength is equal to that of the colon.[10]
The semicolon or semi-colon ; is a symbol commonly used as orthographic punctuation. In the English language, a semicolon is most commonly used to link (in a single sentence) two independent clauses that are closely related in thought. When a semicolon joins two or more ideas in one sentence, those ideas are then given equal rank. Semicolons can also be used in place of commas to separate the items in a list, particularly when the elements of that list contain commas.The semicolon is likely the least understood of the standard marks, and so it is not used by many English speakers.In the QWERTY...
 
good to know! thanks
 
4:34 PM
@terdon unless it's a Greek question
>>> '\N{greek question mark}'
';'
 
A semicolon may not end the sentence but it does end the conversation; good day sir!
 
@AndrasDeak Ah well, then I'd be writing έτσι βρε φίλε, σωστά;
 
φίλε as in file? :D
 
4:51 PM
heh, no. φίλε means friend. "Βρε φίλε" (vre file) is a colloquial way of saying something like "come on, dude".
 
5:14 PM
I can read the letters, I just don't know what they mean.
Oh, file as in -phile. Nice.
 
Yes, exactly.
 
 
1 hour later…
6:37 PM
@terdon can i hire you ?
 
6:58 PM
Disinfectant in Tabers dictionary.
 
7:28 PM
@Freedo lol. I take it you found a solution?
 
Terdon for hire
Will work for IPA
 
7:45 PM
@terdon no luck yet :(
 
@jesse_b ha! :P
@Freedo :(
 
It seems to be happening randomly and not specific to any ffmpeg source files, and it seems to be happening only when the load is very high on the tmpfs folder now
 
 
2 hours later…
10:04 PM
Is my docker question really that bad? :(
 
10:24 PM
more data, less rant, obvs
 
Also my reputation has nothing to do with how stupid I still am ;)
 
10:48 PM
I'm so ignorant on the subject that I can't even tell if your question contains enough information, but there's nothing ranty about it.
 
That seems like a pretty typical interaction on the site.
 
11:19 PM
@AndrasDeak Well he made that comment before I made an edit in which I tried to rewrite the question to have less fluff but in my opinion it wasn't really ranty before either. It had a slight amount of potentially extra information but I don't think it's even extra just I don't know of a good way to word it in a concise manner.
 
11:34 PM
@JeffSchaller: You camp?
 
@jesse_b yeah, it was fine
it's not like you pecked their chimney or anything
 
@AndrasDeak The animals are conspiring against me. This morning there was a rabbit outside the window right behind my monitor and it was actively taunting my cat and my cat was going crazy almost knocking my stuff over
 
11:50 PM
awww, bunny
the only things taunting my pet here are doves, which are just pigeons in formal attire as far as I'm concerned
 
@AndrasDeak There are some pigeons that are incredibly ornate. One of my previous neighbors used to raise and "fly" pigeons and he had some crazy ones that were worth several thousand dollars each
 
We only get the "avian sewer rat" kind here
 

« first day (3874 days earlier)      last day (133 days later) »