« first day (2759 days earlier)      last day (431 days later) » 

12:13 AM
Oh right. We never did finish that.
Life got crazy busy for me.
 
 
1 hour later…
1:19 AM
wow LibreOffice is really unstable
failed to save and then just locked up
 
one time?
 
it also likes to crash randomly when editing larger documents
I can't even save
General I/O error
 
@fossfreedom: Could you please explain this comment of yours and to which repository it refers that supposedly doesn't contain Skype any longer? Last time I checked (10 minutes ago) it was still there.
Since other answers to the same question that suggest roughly the same thing weren't deleted, did you, by any chance, delete all answers that (also) contain a reference to the old partner repository? If that is the case please read the linked answer and reconsider its deletion.
 
1:35 AM
why is it that when I zoom out YouTube to 90%, the content gets bigger?
the video frame is huge now
 
it is responsive to your wishes.
Or what it perceives as your wishes. Since it can't mind read. Although that feature is coming soon once better ad integration happens.
 
 
5 hours later…
6:36 AM
@DavidFoerster Starred so any mod can see it when they drop in. (looks like fossfreedom did this when he was just tired....)
 
-2
Q: E: Unable to locate the package

Si Thuwhile I try to to install openswan on ubuntu 14.04, I faced this unable to locate problem. The command I typed is: sudo apt-get install openswan xl2tpd ppp lsof Can anyone help me ?

 
 
2 hours later…
8:49 AM
@Fabby Thanks!
 
 
2 hours later…
10:51 AM
0
Q: ssh_exchange_identification: read: Connection reset by peer ( unable to access the remote server for restarting the SSH service )

SANITHI'm facing this issue. i know there are so many topics regarding this. Actually I was unable to access the remote server for restarting the SSH service and removing the host key. Any help on this. debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-O...

 
@Fabby :D :D :D a simple reinstallation of GRUB via Live medium would have done the repair ... I'm astonished that you (still) recommend and (try to) use this (more or less buggy) boot-repair thingy and running the efibootmgr tool (instead of Rod's tool) could have done it as well ... for the next time when you "frickle" something in your BIOS and UEFI settings, here is the command : sudo efibootmgr -c -w -d /dev/sda1 -p 1 -L "ubuntu" -l '\EFI\ubuntu\shimx64.efi' ! :)
 
11:30 AM
@DavidFoerster I double checked this morning and the skype linux package was no longer in the partners repo ... but I'll triple check later today
 
 
1 hour later…
12:57 PM
@fossfreedom Maybe there's a misunderstanding; @DavidFoerster's answer states exactly that and recommends to use repo.skype.com/latest/skypeforlinux-64.deb instead.
$ LANG=C wget -S --spider repo.skype.com/latest/skypeforlinux-64.deb |& tail -2
Remote file exists.
 
@dessert ... looking
indeed
 
;P
 
comments need cleaning up though ... tidying
... and done. Nice tidy Q&A
 
@fossfreedom beautiful, thanks!
 
1:16 PM
@fossfreedom Thanks!
 
1:30 PM
@cl-netbox :-) I like that I can go into an EFI shell and don't need any OS to fiddle with things. pure EFI will help me professionally with Windows, *nix, VMWare, and it's knowledge that very little people have Always good to be able too cook up stuff others can't...
Black Magic---^ :D :D :D
 
2:02 PM
@fabby help! :=)
is there an easy method to remove <br> from lots of files? :X
 
You are asking me?
sed? awk?
@Rinzwind I don't get it... Is this a joke?
(do I use too many <br>s in my answers?)
 
<br>Now<br>Why<br>Would<br>You<br>Say<br>That<br>?<br>
:P
 
@ThomasWard sed 's/<hr>/<br>/' :P
 
@ByteCommander …/g
 
aggreed
 
2:11 PM
now shush.
 
hides
 
salts @ByteCommander
:P
 
2:27 PM
Someone with 15k around? I think this one could use protecting...
Argh, linked answer instead of question.
Is general policy on AU to flag those, or what?
 
@anonymous2 no general policy
let me look
 
@Fabby tsk
 
Of course, I can't see if it's getting worse than just the quasi-answers that are still on it. If that's all it's getting it might not be worth it.
 
well they are "answers" ... not great
 
find . -name \*.xml -exec sed -i 's/<br>//g' {} \;
 
2:34 PM
deserving of peoples voting power
 
Gotcha.
 
0
Q: HPE Zbook 15 G3 w/ Ubuntu 17.10 no audio through analog ports

Rick BeldinThe Zbook 15 G3 is currently running: kernel: 4.13.0-38-generic nvidia: 384.111-0ubuntu0.17.10.1 lspci | grep -i nvi 01:00.0 VGA compatible controller: NVIDIA Corporation GM107GLM [Quadro M1000M] (rev a2) 01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1) I can't get any output at...

 
2:55 PM
@anonymous2 looking.
 
Lol.
 
@anonymous2 OMG! Protected!
@fossfreedom Oops... Just protected it, was going to read all answers and downvote and cast delete votes.
@anonymous2 Medical assistance? How come?
 
'Cause foss had already looked at it.
 
Yeah, dunno if that needs protecting. All of the answers seem to be bona fide answers in good faith, some might even be helpful and there's only one answer that would have been blocked by the protection.
 
Well, I don't have a gold badge in any of those tags, so it's just a delete vote.
 
3:00 PM
Sorry. Speaking through my hat, specially since I can't see if there are any deleted answers. On IoT, if we had that many low quality answers, we could almost guarantee at least as many spam / NAA answers.
But that only occurred to me after I brought it up, so I thought, hey, see what community thinks of it.
 
Never anything wrong with asking!
In this case, there weren't many answers (for AU), no deleted ones and only one answer from a <10 rep user, so I wouldn't have said it needed protecting.
 
So dear mod, remove protection?
 
Up to you. You have the rep to make the call and I don't have any more information than you do. So it's completely up to you. I just said I wouldn't have protected it, but that's just me. If you think the protection is helpful, leave it. This isn't a modly thing, it's a user thing :)
 
:D The mods are generally more experienced users.
:-) ;-) :-)
 
It's really not a big deal one way or the other.
 
3:07 PM
yeah... I prefer to avoid risks than to have to sort them out later...
(That comes with the job)
 
3:28 PM
0
Q: Ubuntu crashed while installing xv6 (lib: gxx package)

Suhas HEWhile I was installing xv6 operating system today following this link : http://namangt68.github.io/xv6/os/ubuntu/2016/05/08/quick-install-xv6.html At some point of time I typed "Yes , do as I say! " without reading what it said and it was the worst decision ever . For some reason it started remo...

 
4:11 PM
0
Q: How did I get 35 reputation from 2 votes?

NerdOfLinuxOn https://askubuntu.com/a/1026404/711310, I got two upvotes and zero downvotes, but I gained 35 reputation from it. How did this happen?

 
 
2 hours later…
6:32 PM
0
Q: Max 32-bit num reached on SUB_UID_MAX

SheldawgthewizardI am running into an error trying to run useradd: useradd: Can't get unique secondary GID range useradd: can't find subordinate group range Currently the settings in login.defs are: SUB_UID_MAX 4294967295 SUB_UID_MIN 100 SUB_GID_COUNT 65536 SUB_GID_COUNT ...

 
6:48 PM
>:-) >:-) >:-)
 
@Fabby You know that's already an option, right?
 
Yup.
 
Just checking :)
 
I'll add that.
@terdon updated
 
0
Q: Isn't it time to review the algorithm for letting good answers flow to the top?

FabbyI'm pretty sure that back in 2008 when StackOverflow was created it made perfect sense to have an answer be "accepted" as that was the way forums were (and some still are) run: you ask the OP to change the title of the post to [Solved] when your solution worked for them, but: nowadays this does...

 
7:48 PM
Can I get your suggestions on askubuntu.com/a/1026501/507051 please?
Is xwininfo -root|sed '/Height/!d;s/.* //' a proper and stable (enough) way to get the display height? The only alternative I found is xdpyinfo|sed '/dimensions/!d;s/ p.*//;s/.*x//'
 
fab-user@fab-ux-predator:~
$ xwininfo -root|sed '/Height/!d;s/.* //'
1080
@dessert and a +1
 
 
1 hour later…
8:59 PM
@Fabby thanks!
 
-1
Q: Recovering lost information

JeremieI installed a LVM storage on my computer and I had very important information inside /HFT. Here is the way I installed that LVM storage: sudo pvcreate /dev/sdb1 /dev/sdc1 sudo vgcreate VG /dev/sdb1 /dev/sdc1 sudo lvcreate -n LV -L 3T VG sudo mkfs .ext3 /dev/VG/LG (could be .ext4) mkdir /HFT s...

 
 
2 hours later…
10:53 PM
0
Q: How can we easily revert the changes made by experiements with unfamiliar commands?

TimSometimes I would like to experiment with some commands which I am unfamiliar with (e.g. xmodmap), and also have the ability to revert the changes very easily without knowing much about the commands yet. Do I need some kind of light-weight virtualization or container or sandbox, which I am also ...

 
Hello everyone. I need some help with some basic ubuntu terminal commands: github.com/pulver22/QLAB in the line that says echo "source <your_catkin_ws_directory>/devel/setup.bash" >> ~/.bashrc I don't know what to do to make it work
 
@Unnamed It means to replace the <your_catkin_ws_directory> part, including the < and >, with the path to your catkin ws directory. Do you know what that path is?
 
yes, I did that
I mean, in my home folder I have qlab_ws and catkin_ws @EliahKagan
 
Can you show the complete current contents of your ~/.bashrc file?
I don't know if you want to just add that to your question there (as it seems relevant) but if you want to provide it in chat then you can paste it into a chat message, so that it is the complete text of the message (i.e., no other text), and click the fixed font button, which appears to the right of the upload... button whenever your message contains more than one line.
(If the fixed font button doesn't appear, then type a space and then delete it or something; it seems to be a bug, with some browsers.)
Or, if you prefer, you can use a pastebin somewhere, such as paste.ubuntu.com.
If your question were here on Ask Ubuntu then I'd definitely say you should include the contents of ~/.bashrc in it, though. I haven't read the FAQ yet for answers.ros.org (where you posted your question) but I suspect they would welcome it there, too. After all, the error is from ~/.bashrc, so examining ~/.bashrc to ensure it contains the expected commands and no other commands that might cause those messages is a good first troubleshooting step.
 
11:14 PM
ok
I'm going to post it here
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
*i*) ;;
*) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
in <your_catkin_ws_directory>, do I have to write the catkin_ws file or the qlab_ws @EliahKagan?
ok, I think I did it
but I still don't know if catkin_ws or qlab_ws is in <your_catkin_ws_directory>
:S @EliahKagan
 
Sorry, I was afk for a few minutes. You solved the problem?
 
no
I don't know if in <your_catkin_ws_directory> I have to put catkin_ws or qlab_ws
 
I think the instructions are telling you to write the path of your catkin workspace directory for <your_catkin_ws_directory>, so that would be catkin_ws rather than qlab_ws.
 
this is the website: github.com/pulver22/QLAB
yes, me too
but why did I create the qlab_ws?
I mean, it has no sense
 
Well, the instructions say to run:
mkdir qlab_ws
cd qlab_ws
mkdir src
cd src
catkin_init_workspace
 
11:25 PM
yes, but then I don't use that folder anymore
 
So I think the idea, in the instructions, is that you would create your catkin workspace directory inside your qlab workspace directory?
I am not sure though.
 
mmmm
i don't know
fuck
 
Are you just trying to figure out what the qlab_ws directory is for? Or is it not working?
 
I'm just trying to figure out what the qlab_ws directory is for
 
How did you create your catkin workspace directory?
Did you run catkin_init_workspace? And if so, did you run it while in your home directory (~)?
 
11:29 PM
the catkin_ws was created when I downloaded ROS
(ROS: Robot Operating System)
@EliahKagan yes
 
I'm not sure it's a problem that your directory hierarchy is different from the ones the instructions assume. The instructions say, "If you don't have it already, create a catkin workspace folder..." So if you already had one -- which you did -- then I think it's fine that you adapted the paths to use the one you had. That seems totally consistent with the instructions.
 
ok
i am going to try
thanks
 
I mean, I think you might be fine as things are. If everything is working.
If you end up doing something that requires your catkin workspace directory to be accessible as though it were created inside the qlab_ws directory, I suspect that you could just make a symlink inside qlab_ws to it. (Or if nothing else is relying on its location, then you could move it.)
 
Hi all! Can you please flag a duplicate on my behalf since I used my vote on that question already?
 
thanks @EliahKagan
 
11:34 PM
Based on that guide‌​, I think at least the value of the ROS_PACKAGE_PATH environment variable will usually depend on that. But you should be able to just check that it is set to what you have. I don't think that this creates a problem when your catkin workspace directory is directly located in your home directory. That guide (linked to from the instructions you linked to here) puts in in your home directory, after all.
 
@EliahKagan what is the difference between catkin_make and catkin_make_isolated?
 
@DavidFoerster Aren't those the same question?
 
@EliahKagan Huh? Oh yeah… copy-pasta mistake. Thanks for the catch! Fixed now.
 
@Unnamed I don't know. I found this, but I don't know how relevant it is to you.
 

« first day (2759 days earlier)      last day (431 days later) »