« first day (2526 days earlier)      last day (2220 days later) » 
00:00 - 22:0022:00 - 00:00

12:46 AM
Q: Adding a repository to apt-mirror

AlexI set up apt-mirror with the following config: GNU nano 2.5.3 File: /etc/apt/mirror.list ############# config ################## # # set base_path /var/spool/apt-mirror # # set mirror_path $base_path/mirror # se...

2 hours later…
2:42 AM
2:59 AM
A wild Kaz appears
i broke things
and need help
so... i hard-unmounted a drive because i am moron
and now i can't remount because an entry exists in /proc/fs
i know a reboot would fix but i'd rather not do that if i can avoid it.
you could do shutdown -h like that person
3:01 AM
without reboot
shutdown -h isn't reboot
why not just delete the entry?
└──> /proc/fs/ext4 # rm -rf mmcblk0p1
rm: cannot remove 'mmcblk0p1/options': Operation not permitted
rm: cannot remove 'mmcblk0p1/mb_groups': Operation not permitted
rm: cannot remove 'mmcblk0p1/es_shrinker_info': Operation not permitted
ro bit?
this isn't Telegram
3:03 AM
it's procfs
so mount with new block?
ok.... how
magicmount xxl?
this was.... helpful.
3:24 AM
oh cool
David Tennant is the villain in this TV series
David Tennant is a good actor.
@KazWolfe This would make a great onsite question if you figure it out. Or if you don't.
I don't know the answer but you got me curious.
I'm addicted to this series
3:42 AM
what series
bunch of Marvel series
Jessica Jones, Defenders
good stories for comic book movies and Disney
[ SmokeDetector | MS ] Bad keyword in body, blacklisted website in body, link at end of body: To get a complete raise with the by reanne on askubuntu.com
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, link at end of body, pattern-matching website in body: alpha-muscle-complex by linewart on askubuntu.com
4:20 AM
@Seth I think the only solution is to reboot
sorta like a zombie process
also, which brand should I look at for laptops?
my MSI is literally falling apart
Acer, MSI (obviously), Toshiba are out to start
thinking Lenovo right now, but maybe ASUS?
@KazWolfe you should know about this stuff
[ SmokeDetector | MS ] URL-only title, bad keyword in body, bad keyword in title, blacklisted website in body, blacklisted website in title, +4 more: testosteronesboosterweb.com/nitragenix-180/ by user730631 on askubuntu.com
OK guys, need opinion
For $936 from Lenovo I can get:
 - i7-7700HQ
 - Win10 Pro
 - 16GB DDR4 RAM
 - GTX 1050 Ti
 - FHD 15.6"
 - 1TB HDD
4:41 AM
I remember why I stopped coming here.
I'm flattered
There is a mute feature.
@KazWolfe That's lame. Maybe ask a question anyway?
5:02 AM
Oh my!
I didn't realize I bought my Radeon card way back in March 2014.
I am definitely overdue an upgrade for that :P
5:21 AM
Why on earth doesn't ffmpeg default to YUV 4:2:0 for pixel format?
I can never remember the correct switch and without it, the video won't play anywhere.
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, blacklisted website in body, link at end of body, pattern-matching website in body: An Important Nutrient To Enhance Brain Power by Rosemaravoiey on askubuntu.com
[ SmokeDetector | MS ] URL-only title, blacklisted website in body, blacklisted website in title, link at end of body, pattern-matching website in body, +2 more: freesupplementrial.com/tharlax-rx/ by saab on askubuntu.com
[ SmokeDetector | MS ] Bad keyword in body, blacklisted website in body, link at end of body, repeated URL at end of long post: prevent dying the locks. This by bordtshumna on askubuntu.com
[ SmokeDetector | MS ] Bad keyword in body, link at end of body, pattern-matching website in body: increase in energy levels, and feel better by saxxshjw on askubuntu.com
[ SmokeDetector | MS ] URL-only title, blacklisted website in body, blacklisted website in title, link at end of body, pattern-matching website in body, +2 more: top10sideeffects.com/divine-cbd-oil/ by Bain1943 on askubuntu.com
5:59 AM
@Seth I can answer that.
Normally, what happened should usually never happen. You can't delete procfs things because it's procfs and doesn't really exist. Instead, the system is tasked with cleaning things up and apparently when you do a really really sloppy eject (like I did), things don't get cleaned up. At all.
and as a result you have a ton of different records that are all disagreeing which cause things to not work
Rebooting does the same thing it does to zombie processes -- just forcefully kills them the one way possible.
6:17 AM
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, blacklisted website in body, link at end of body, pattern-matching product name in body, +1 more: Penis Enlargement That Books by deeyamirzah on askubuntu.com
6:27 AM
[ SmokeDetector | MS ] Blacklisted website in body, blacklisted website in title, link at end of body, repeated URL at end of long post: health-forall.com/tharlax-rx/ by funafaisal on askubuntu.com
[ SmokeDetector | MS ] URL-only title, bad keyword in body, bad keyword in title, blacklisted website in body, blacklisted website in title, +4 more: supplementlab.org/nouvelle-beaute-serum/ by ceslotodoc on askubuntu.com
[ SmokeDetector | MS ] Blacklisted website in answer, pattern-matching website in answer, blacklisted user: How to disable "This document has embedded..." pop-ups in Okular? by AZSFSDFASF on askubuntu.com
6:50 AM
smokey's been busy :P
7:15 AM
Grr... 195 points yesterday. Just 5 too few to finally get the Epic badge
@edwinksl then why didn't you flag?
because i had already flagged it as NAA
then i noticed there is a spam link
[ SmokeDetector | MS ] URL-only title, bad keyword in body, bad keyword in title, blacklisted website in body, blacklisted website in title, +4 more: supplementlab.org/nouvelle-beaute-serum/ by nanodido on askubuntu.com
ah, ok
there you have a chance to do it instead ^^
7:53 AM
[ SmokeDetector | MS ] Blacklisted website in body, link at end of body, pattern-matching website in body: Close to that, the plenitude by Arron1945 on askubuntu.com
I m writing some code which activates my virtualenv
but I am not sure how to interprete this:
$ top|grep python
24877 yalisha+  20   0 1057644 164760  62552 R  50,0  2,7   0:02.69 python2
24877 yalisha+  20   0 1095616 204564  64628 R  32,1  3,4   0:03.66 python2
24877 yalisha+  20   0 1095616 204724  64628 S   7,0  3,4   0:03.87 python2
24877 yalisha+  20   0 1095616 204724  64628 R   0,7  3,4   0:03.89 python2
24877 yalisha+  20   0 1095616 204724  64628 R   8,6  3,4   0:04.15 python2
24877 yalisha+  20   0 1095616 204724  64628 S   3,3  3,4   0:04.25 python2
24877 yalisha+  20   0 1095616 204724  64628 R   4,3  3,4   0:04.38 python2
this is what appears while running my code, I would think it looks like it is starting waay to many python virtualenv's but they all have the same pid
So why am I seeing so many entries?
Many things use python, including system components
@ByteCommander no this only appears when I am running my code
Maybe try pgrep -fa python to see more detail
8:11 AM
let s try
that also shows the arguments with which the commands were started
no no, just pgrep. no top
$ pgrep -fa python
5359 gedit /home/yalishanda/Desktop/python.log
25111 script -f -c python2 /home/yalishanda/Desktop/python.log
25112 python2
25120 /home/yalishanda/torch/install/bin/luajit -e package.path="/home/yalishanda/.luarocks/share/lua/5.1/?.lua;/home/yalishanda/.luarocks/share/lua/5.1/?/init.lua;/home/yalishanda/torch/install/share/lua/5.1/?.lua;/home/yalishanda/torch/install/share/lua/5.1/?/init.lua;"..package.path; package.cpath="/home/yalishanda/.luarocks/lib/lua/5.1/?.so;/home/yalishanda/torch/install/lib/lua/5.1/?.so;"..package.cpath -e local k,l,_=pcall(require,"luarocks.loa
@ByteCommander ^
yes... so?
@ByteCommander I don't see anything suspicious here, or is it just me?
not really, what are you looking for?
8:15 AM
@ByteCommander Why I have so many entries when executing top
This only happens when I run my code
Maybe top also lists child threads or so?
Not sure, also can't test right now.
but if the first column of top is actually the PID, then it would make sense that it lists threads separately.
maybe top has an argument to not show threads
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, link at end of body, pattern-matching website in body, repeated URL at end of long post: httpmaleenhancementdirectcom/envy-rx/ by user730707 on askubuntu.com
this code even returns
malloc(): memory corruption (fast): 0x0000000000fe8d8f ***
after a while
8:33 AM
Q: bash: messed up display for long lines

BananachI am using the GNU bash, version 4.4.0(1) on Ubuntu 16.04. When I enter long lines in my bash, its display is messed up. For example, assuming I am in ~/test/test/test/test/test/test/test and I enter echo "The quick brown fox jumps over the lazy doggo" it looks like this: This is still okay, ...

8:45 AM
@LandonZeKepitelOfGreytBritn that happens when you write in C... :-(
@ByteCommander C++ actually
I guess it is some library that does C calls
almost the same
both allow you to mess up memory allocation
Wait, you write your python virtualenv management tool in C++? o.O
Why? That would be much simpler in a scripting language like Bash or Python itself.
@ByteCommander my GUI (frontend) is in C++ and the backend is in python. The backend uses a library written in python, cpp and lua. The interface to that library has to be in Python.
so complex for a venv?
I'd probably be lazy and go for Python+Tk or Bash+Zenity (if any GUI at all)
@ByteCommander I am not a python expert. So I decided to go for cpp. it allows me to do multithreading and implement everything I needed like TCP/IP functionnality for streaming etc...
Which are all things I had never in python, but have already done in cpp
8:59 AM
wait... you're no longer talking about venvs, right?
Also there is nothing Python can't do.
And most stuff is already built in ("batteries included")
@ByteCommander no the cpp does tcp/ip and much more, the python code does only 1 or 2 very specific things
kk. Still would surely be much simpler in Python, but use whatever floats your goat ;)
I am not a python expert, so I'd rather use what I am most familiar with.
also python is a scripting language. My code should run on an embedded device later and the GUI will be used for a touchscreen
too many parameters...
idk i ll just go for cpp to avoid unexpected things
9:29 AM
^^ me and my office fan
9:51 AM
Hello :)
@cl-netbox hello there
@LandonZeKepitelOfGreytBritn Hi ! :)
@ByteCommander Did you transform yourself into a cat ? :D
not yet
but being able to lazily lay around all day seems desirable
yes ... at >30 C understandable :D
cool user name you are having @LandonZeKepitelOfGreytBritn ... :D
@cl-netbox thanks, I am sure "LandonZeKepitelOfGreytBritn2" is still available :p
10:04 AM
@LandonZeKepitelOfGreytBritn What about "LandonZeKepitelOfBraxit" ? :D
@cl-netbox hahahah good one :)
@LandonZeKepitelOfGreytBritn :D :D :D
at least if the Scots will decide to part away
LandonZeKepitelOfZeNotSoGreytAnyMorBritnOnZeWayToMeikItEvenWorse :D :D :D
10:46 AM
Q: linux choose network interface depending on port

maziphaOn my linux desktop (ubuntu 17.04), my local network is on eth0 and my internet connection is through usb via an android phone (tethering). I would like to find a way to select where the network traffic will go depending on the port. For example, I would like to direct all traffic on port 80 thro...

2 hours later…
1:07 PM
The following question is being closed as OT since OP mentioned Debian. https://askubuntu.com/questions/950815/how-do-you-set-up-ssl-certificates-for-additional-ports-in-apache
is it OK to remove "Debian" from the question just to make it on topic again? IMO, the question and answers are completely valid on Ubuntu
@Dan Yes
As long as you're sure the solutions (and issue) are valid on Ubuntu
Alright, thanks
@TheWanderer Can you change the keyboard?
Oh. You like that?
RGB backlight?
I can just make it white
I would hate this guy popping out of the screen ;)
1:35 PM
@TheWanderer Oh. OK. I thought you had to have that garish multicolor thing.
lol no
it's just showing off that it has RGB
brain, can I please type RGB correctly?
oh good
it's a generic laptop
easy to find parts
@TheWanderer The specs look fine but my limited experience of no-brand hardware tells me they usually fall down in the detail. Cases might not be moulded as well, bit of play in the hinges, etc. Batteries might be from cheaper stock...
I don't care about battery life, but the build quality is important, since I'd like it to last more than 2 years, unlike this MSI
And the same rider as before, I'd rather buy it without the SSD and stick my own in.
1:39 PM
@Oli actually, that SSD is pretty good value. $50 for 128GB. Amazon's lowest is ~$60
but this laptop (from two different generic brands) was recommended to me on the laptop subreddit
Just because it's an M.2 doesn't mean it's any good.
well I can always get it without
Well, the comments seem to claim high build quality, for what that's worth.
I would try and get a bit more ram though. Either now or later when you can afford it.
the seller responses in the Q&A section also seem to be a good sign
no broken English
@terdon oh yeah, I need 16GB
I was thinking after I get it, depending on what's cheaper
problem is they're charging $150 for 8GB more
@TheWanderer Well, bad English, but that's not necessarily a bad sign.
@TheWanderer Aye. Probably best to get it later.
1:42 PM
actually, the English is pretty good IMO
I see some missing pronouns and some pluralization, but their CS reps have better English than MSI's website
@TheWanderer it also has a larger SSD.
@Takkat for 16GB RAM + No SSD + 1TB HDD, it's $1050 vs. $900 for 8GB
but the higher end doesn't have a discount so that might be why
Mostly issue with gaming laptops come from insufficient cooling and throttling of the CPU...
that may or may not be the case here - we don't know.
it has 2 fans apparently
Yeah. My beast came with a high end CPU but it throttles often.
1:45 PM
I'm rocking 1 right now, and it loves to break
I'm on like my 5th fan this year
is Crucial still good for RAM?
last I used them was DDR for a 2004 Optiplex
M2 SSD should be in PCIe mode for high speed (not SATA mode)... they don't say
M.2 can do PCIe and SATA?
it can - depends on BIOS and on the SSD you plug in.
1:48 PM
well here's the same laptop from a different brand amazon.com/Eluktronics-N850HK1-Premium-Gaming-Laptop/dp/…
I don't like that one, though, since the buying options don't give me just HDD
Newer PCIe SSDs are at > 3 GB/s at present - SATA is 550 MB/s or so.
so mSATA is still OK?
or is that not actually PCIe, even though it uses PCIe?
M2 can be set up in SATA mode to allow the much slower SATA SSDs
not M.2, mSATA
mSATA is the same but it can not take the PCIe SSDs
You want one of those :)
1:51 PM
but mSATA is PCIe, isn't it?
or at least it uses the interface
oooh FHD camera lol
@TheWanderer it does.
I'm pretty sure I could put a WAN card in my mSATA slot and have it work if I wanted..
hmm 5.5lbs...
but mSATA is SATA is limited to <600 MB/s
meh, I'm sure my MSI is heavier than that by noew
@Takkat ahhhhh
this thing not only has 3 display outputs, but it can actually drive all three at once!
I just need to mDP adapters
imma get it if I can convince my parents... I do have the money, and I am past my arranged due date (2 years). Either MSI is really bad value or technology has gone really far in 2 years
@TheWanderer good machine ... equals SCHENKER XMG A707 .. same vendor as my main machine (XMG A704) and I am very happy with performance and quality ! :)
1:57 PM
I'm convinced then
I'm upgrading my display capabilities, which is nice
amazon.com/s/… this or similar... if that is too expensive today I'd go for it tomorrow but you need hardware that can take them.
wayy too much
@TheWanderer I bought it without any system preinstalled ... so no Windows - nothing ! :)
well I can't do that from Amazon, and I need Windows lol
You never want to boot from another SSD after that. Imagine Windows to reboot as fast as Ubuntu.
1:59 PM
I don't need something super fast
my Kingston mSATA does fine for me
@TheWanderer one of only two who do manufacturing ... great choice ... I have it as well ! :)
if I get the computer, I think I'll wait until I can see what RAM it comes with, so I can try to match it
Hi @Takkat ! :) Good afternoon ! :)
Hi o/
@TheWanderer there are a bit slower variants for less - search for NVME SSDs
it needs to fit the M.2 interface though
Look at this imgur.com/a/QIpQD
2:28 PM
+1 for the parrot
WHITE CLOUD, Mich. - A jury has convicted a western Michigan woman of first-degree murder in the shooting death of her husband in a crime apparently witnessed by the man’s pet parrot.
African Greys are the best
2:57 PM
Q: boot server despite wrong fstab

LarsI have a kubernetes cluster running on baremetal ubuntu server 16.04 with glusterfs and heketi. Heketi will automatically add volume groups and add those to fstab. Due to $reasons, that volume group might not exist on boot. If the initramfs encounters a non-existant volume group in the fstab, it...

3:30 PM
Q: When to add another answer instead of updating current one?

pomskyIf I click on the Add Another Answer button, a warning pops up: Are you sure you want to add another answer? You could use the edit link to refine and improve your existing answer, instead. When should I add a second answer instead of editing the current one?

Tennant makes a good villain
3:46 PM
@TheWanderer ?
David Tennant?
Yes, I thought you mean him.
But the rest.
why villain?
he's the villain in this series
I should not have checked the option to let schools email and mail me...
1 hour later…
5:13 PM
Create React Native App doesn't work with npm 5 yet, unfortunately. We
recommend using npm 4 or yarn until some bugs are resolved.
can you knit an app?
Now I have to downgrade NPM.
5:34 PM
Q: How can I move a file from a linux computer to my mac laptop?

user8290579I have a file in my Linux work computer that I need on my personal Mac laptop and I wanted to know how I could get that to my mac computer. I can't email it to myself because it's a dmg file and it's too large via email. How can I send this file to myself using terminal commands? Also I have no a...

Q: How to turn off wifi-hotspot of ubuntu using terminal. I am beginner

user701811Because I want to connect to a WiFi. I am in tty mode. Also how can I connect to a WiFi using terminal.

5:46 PM
6:20 PM
Q: How to stop ubuntu wifi-hotspot using terminal? Please help

user701811I can only use terminal right now. After starting the laptop it always creates wifi-hotspot so I need to stop it then connect to my home WiFi using terminal. My home WiFi is saved. How can I stop the hotspot and connect to WiFi using nmcli I have tried command nmcli connection down uuid Error: ...

6:57 PM
npm WARN react-redux@5.0.6 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none was installed.
That doesn't sound good.
Imma try this on Arch.
7:14 PM
@TheWanderer what series?
7:26 PM
Q: Can not login Ubuntu. Stuck in loop

GIRISH KUMARFirst I downloaded gnome shell. During installation process I selected gdm. But gnome was giving problems while login. So I did this after saw something from net (this was my big mistake) sudo chage -E -l gdm Now I can not even go to login page so i removed gnome shell ubuntu-gnome-desktop Now ...

Q: `find` very slow when I'm at home

Ccile(Ubuntu 16.04) I use my computer at three places : at home and at work (lab 1 and lab 2). At work (lab 1, I didn't try at lab 2) the following command is not immediat and takes I think less than 5 minutes but when I am at home, after 15 minutes, I still don't have results. Is it normal ? The on...

7:37 PM
I guess I gotta reboot to Windows.
@ByteCommander Marvel's Jessica Jones; Netflix Original
never heard of that so far...
watching forest of the dead now btw, also with Tennant.
7:59 PM
How do I make this stupid thing stop?
It's sucking all the network bandwidth.
And I don't want it to.
8:10 PM
@NathanOsman Assuming that's Windows Update Delivery Optimization sending downloaded updates to other Windows machines, you should be able to turn it off or set it to only send to other machines on your LAN in Settings > Update & security > Windows Update → Advanced Options → Choose how updates are delivered → Delivery Optimization.
I checked that and it's already off... :|
Gotta love Windows.
Hmm. I don't know then.
8:24 PM
@NathanOsman shutdown -sf
Q: How to fix held broken packages?

Sam HealeyTrying to install libssl-dev on ubuntu 14.04.2 $ make fatal error: openssl/sha.h: No such file or directory compilation terminated. $ sudo apt-get install libssl-dev The following packages have unmet dependencies: libssl-dev : Depends: zlib1g-dev but it is not going to be installed E: Unable ...

8:40 PM
Hello. Someone asked a question about installing Waterfox on Lubuntu 17.04. The OP expressed concern about installing from tarballs (because he didn't know there was a repo available
The question is closed and marked as duplicate, referencing other questions that deal with tarballs.
But they were too quick to close that question. There is a way to install with a repo. That is not something that is mentioned in other questions, certainly not in the question they reference.
Can the question be reopened so that I can answer it?
9:01 PM
Q: concatenation to previous line in bash

user7175478I am trying to add an alias to my .bashrc so that running the following command > push 123 will add the line 2017-08-29/push/123 (with current date) to the end of a file. adding the alias: alias push='date +%F/push/ >> log.txt ; echo $1 >> log.txt' almos does the trick, this adds two rows as fol...

@gracious1 1 reopen vote cast, 4 more to go...
@ByteCommander Okay, how can I vote for this?
not at all
Cats are not allowed to vote, unfortunately...
9:13 PM
Gotta organize and sign a petition.
Meh, you merely need 2874 more reputation points on AU...
Then we might ignore the cat fact :P
AH, okay. Now I have something to shoot for. ;-)
It's too bad, because I could help that user if we could unlock that question askubuntu.com/questions/935466/…
9:30 PM
Yeah, that question is an XY problem, it's not really about compiling from source (which is what the question it's duped to is about). Even if that were the only way to install Waterfox, I doubt those generic instructions would be sufficient, since building something like Firefox or other fully-featured modern browsers usually requires additional steps, and can take quite some time.
I think we actually have separate questions for compiling Firefox, because people who've tried to use generic "Run .configure, then make, then sudo make install" advice need further help, unless they are already experienced at compiling stuff.
I don't know if the Waterfox .tar.bz2 file actually is source code, but if it's not then those instructions don't answer it, and if it is then the instructions... still don't answer it, especially if I understand you correctly and there actually is a repo or downloadable .deb file for it that the OP would probably prefer to use.
.tar.bz2 likely contains binaries etc that should be extracted to /opt/
9:52 PM
rip Essential
probably gonna die
@EliahKagan you and I really need to have a chat about "proper flag usage"
at some time.
TL;DR, there's already a "no longer needed" flag for comments, we don't need custom ones ;P
Do moderator see the surrounding flags in the interface for handling comment flags? Sometimes I worry that a "no longer needed" flag will not make the situation clear.
00:00 - 22:0022:00 - 00:00

« first day (2526 days earlier)      last day (2220 days later) »