« first day (2527 days earlier)      last day (725 days later) » 

12:01 AM
@gracious1 It would be a bug in the PPA version, if not the upstream version, if it didn't.
For Ubuntu systems with a GUI installed I mainly use Lubuntu and I've never had any problem with applications appearing in the menu. Not with graphical software installed from .deb packages.
 
All right, then.
 
Which Ubuntu releases does that unofficial repository support?
 
I believe everything from Trusty to the most recent.
The two dependencies I mentioned in the answer are apparently from the Yakkety repository.
So Trusty to Zesty?.
 
 
1 hour later…
1:26 AM
@gracious1 don't do 17.04
bugs galore
> Latest 7th Generation Inter Core Processor
hmmm
huh it comes with USB-C
 
2:18 AM
@NathanOsman you'd know this. Is Mini-DP what Macs used to use?
 
@TheWanderer yes
 
@TheWanderer not all macs use minidp but most have a minidp port
 
used the same jack as thunderbolt
 
thanks, Nates
 
or rather vice versa
 
2:22 AM
so if I need to, I can just use the Mac adapters we have lying around for this laptop, if I get it
I mean, it's only $9 to get a full on mDP to HDMI cable from Amazon, but still
 
Thinkpad?
Those often have miniDP too
 
a generic laptop...?
 
it has three outputs, which I really like
 
That doesn't raise red flags..
 
2:24 AM
@Seth it's a brand, but it's custom built. Two brands sell the same model.
idrk how that works
but looking at the Q&A and reviews, CS seems super responsive
wait a minute...
@DᴀʀᴛʜVᴀᴅᴇʀ Aren't you a room 240 person >_>
 
@TheWanderer huh??
 
TNB
guess not lol
 
I am an all powerful mod
 
oh great, another @ThomasWard
:p
maybe you are @ThomasWard c_C
@Seth how's this one:
I keep thinking that stick in the bottom left is a watermark..
 
Better, still really soft though.
I don't think that's something you can fix in post.
 
2:30 AM
soft?
like NR?
this is my V20 btw, not my DSLR
 
@TheWanderer I guess
it just looks like all the colors kind of bleed near the center
 
well it is just the JPG the phone produced
 
what lighting conditions was this taken in?
 
clouds
 
@TheWanderer ah. I thought you shot RAW and were processing.
 
2:33 AM
nope
 
@TheWanderer I wonder if you bumped the exposure up a notch..
half a stop maybe
 
that's why I shared this, because it's completely unedited
 
idk, phone cameras don't handle red well
 
nope
 
@TheWanderer I mean, I think it's still a great photo
 
2:35 AM
ooh
(obviously edited)
 
3:02 AM
Aww yeah
 
jelly
 
@LandonZeKepitelOfGreytBritn so ubuntu delivers updates through update channels. Each of those checkboxes in the "Updates" tab of software-properties-gtk controls one. They're coded release-channel so in this case xenial is the release and updates and security were the channels we needed. I thought these were enabled by default but I guess I was wrong. You can learn more about update channels here.
When you tried to install teamviewer apt knew some of those packages existed, but it didn't know where to find them, hence the problem.
 
3:26 AM
yet another cool problem.
can't ping out or anything
my system is now deciding to stop connecting to new websites after a while... old connections work fine, but new things just... refuse to work
 
@Seth jealousy intensifies
 
4:18 AM
Wow, first time I've been seriously dissatisfied with an Android update.
If it wasn't such a pain to do I might go back to nougat.
 
4:45 AM
Any problems?
 
4:58 AM
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, blacklisted website in body, link at end of body, link following arrow in body, +1 more: Can Male Enhancements Like Extenze Use By All Men by Leslieaverx on askubuntu.com
[ SmokeDetector | MS ] Bad keyword in body, blacklisted website in body, link at end of body: On account that there ar by heatherj on askubuntu.com
[ SmokeDetector | MS ] URL-only title, blacklisted website in body, blacklisted website in title, link at end of body, pattern-matching website in body, +2 more: getnutritionshelp.com/vigotrex/ by yvvr on askubuntu.com
 
 
4 hours later…
9:01 AM
[ SmokeDetector | MS ] Pattern-matching website in body: THINGS NEED TO PREPARE WHEN DECIDE RUN A MASCOT PROGRAM by snowyliu on askubuntu.com
 
 
2 hours later…
11:08 AM
That moment when you logon to AskUbuntu and the first thing you see is a post about about canned sardines :I
 
Was an ad
got removed
Most likely by @SmokeDetector
 
11:26 AM
=)
 
 
4 hours later…
3:23 PM
Hello ! :) Is there anybody around here ? Well, most probably @ByteCommander seems to be right -> chat.stackexchange.com/transcript/message/39428457#39428457 Looks as if Smokey takes over ... :(
 
@NathanOsman No problems per se, but they made several bad choices IMO. e.g. apps can no longer draw over system UI, which makes sense, except they pulled nightlight so there's no way to change the color temperature, meaning the lockscreen, notification bar and shade, as well as the volume controls, etc are all extremely bright at night. Then there's now a persistent system notification anytime an app is running in the background. No way to dismiss it.
I always have at least 1 app running in the background.
Oh and they made the notification shade completely white, which compounds the nighttime issue.
 
Hey @Seth ! :) Nice to see you ! :) How are you doing ?
 
3:57 PM
Hmmm ... no response @Seth ? Seems I've seen a ghost ...
Okay ... I'm going to leave the house ... goodbye everybody ... whoever may read this. :)
 
4:31 PM
0
Q: Multichain xx -daemon - then what happens on reboot?

NealWaltersThe blockchain program Multichain has a command: multichaind chainname -daemon https://www.multichain.com/getting-started/ My question is whether this will survive a reboot (specifically on Ubuntu, but more in general just trying to learn). In other words, do we need to create a script to...

 
5:01 PM
0
Q: Forward email but change the FROM address

SammayeI have a postfix server running on an EC2 instance. I want to forward all email, via SES, to my personal inbox. The problem: AWS only allows a FROM address that is verified in the AWS console and the FROM address in this case could be anything, for example: twitter.com. I cannot white-list my se...

 
5:16 PM
Anyone have thoughts on Lenovo?
 
no more Suprfish, and they're the only well-known name I trust anymore by POE
 
Does anyone know if you could install Ubuntu on this?
I get the feeling ChromeOS tries pretty hard to prevent that sort of thing.
 
16GB SSD?
literally no room lol
 
That's enough for a bare-bones install.
 
why do you need it
 
5:19 PM
This would be used as a thin client.
Documents and whatnot would be accessed over SMB.
 
Crouton looks like a hassle
just get one of those cheap $150 desktops
 
It needs to be portable.
And I don't mean this:
 
xD
how do you feel about an old-ish HP Pavilion?
 
Erm... maybe not.
 
6:01 PM
well that's dumb
MSI screwed the hinges into the soft plastic back of the screen
 
lel
 
6:23 PM
Yes.
This is me.
 
I like black hat's throne. :>
“Faced with someone even more obsessive and bureaucratic than they were, the [Institutional Review Board] backed down and gave us preliminary permission to start our study.” xD
 
appears, yells "AAAAAAAAAAAAAAAAAAA", then disappears again
5
 
6:48 PM
wow
@Seth CS for Prostar is super responsive. I sent them a message on Amazon to see if I could get a version with 16GB RAM and a 128GB SSD, and they got back to me in like 15 minutes
 
 
1 hour later…
7:57 PM
oooooh
YouTube has an actual dark mode now
 
orly
 
8:31 PM
it's had that for a while
 
I only got the new layout today
 
Google (and other companies) has been known to roll out to new features to parts of its user first, leaving the rest out, as a sort of public beta test.
 
I've had a sort-of-new layout for a while, that was sort of halfway between old and new
 
8:56 PM
@TheWanderer and the Android app has been ruined.
It's all white now.
And ugly.
 
the YT app looks like it's from 2001
what did they think they were doing?
 
"material design"
 
it's not Material
 
But they think it is.
 
irony
GNATSSS
 
9:21 PM
@Seth thank you very much for your answer! Clarifies quite a lot
 
@TheWanderer I've had it for months and I keep clicking "I don't like the new design" :P
and then it goes away for ~1 week
@NathanOsman and MS ruined the Skype app
 
Yes.
 
9:39 PM
Wat
That would be so stressful for the interviewee
Yup others agree --^
 
@AndroidDev: I think it has some low-stress use cases, e. g. "spot the mistakes in and fix this code fragment" accompanied by oral or written explanation of what's wrong and why and how it can be fixed.
 
@DavidFoerster hmm yeah fair point
 
…basically just-in-time code review.
 
Hmm, speaking of JIT... I wonder if Google has fixed most of the bugs in ART yet
I would hope so, seeing as we're now 4 releases since it's introduction
(Well technically it was introduced in KK but you had to enable it in Dev Options)
 
I could think of some egghead managers who think "but we want to see how the candidates work under stress". Dude, if your software developers need to work under stress you're not qualified to lead them.
 
9:46 PM
lol
true though
 
… or your business has poor work conditions which will inevitably lead to poor products.
 
and spaghetti code
 
yum, spaghetti...
 
on that note..... I'm going to have some dinner :D
 
9:52 PM
@DavidFoerster that's r/a
 
@ByteCommander What does "r/a" mean?
 
rude/abusive
the other red flag
 
Oh, right. Sorry.
 
[ SmokeDetector | MS ] Manually reported answer: Restart Xfce panel in Xubuntu by meme on askubuntu.com
 
9:55 PM
@SmokeDetector Sorry to you too, Smokey.
 
@ByteCommander: I think my mistaken spam flag made Smokey pick it up. Afaik it doesn't post notices about r/a flags.
 
it does
and I reported it
it only picks up your flags if you have the userscript installed though
 
10:33 PM
Oh.
 
Crazy Dave
 
@TheWanderer: Pot head.
 
well?
 
guess he just had no tinfoil around and took the next best thing
 
to be fair, he lives in a world where zombies attack from either yard in rows and then you use plants to kill them
how do I define a variable in BASH?
oh just has to be at the beginning lol
guys
is there some regex I could use in BASH to do this:
find the line that contains:
# LG RCT(Rooting Check Tool)
then comment every line until it hits an empty line
ie:
...

# LG RCT(Rooting Check Tool)
#service rctd /sbin/rctd
#    class late_start
#    user root
#    group root
#    seclabel u:r:rctd:s0

...
there's text above and below, but I need to make sure just that block is commented or removed
 
10:51 PM
@TheWanderer: sed -e '/^# LG RCT(Rooting Check Tool)$/,/^$/s/^/#/'
 
wow, pretty easy
how can adapt that to edit a file though?
(name is init.lge.rc)
 
Do you mean, edit the file in-place?
 
sure
cat?
and >?
 
Use sed's -i option.
 
thanks
so sed -ie '/^# LG RCT(Rooting Check Tool)$/,/^$/s/^/#/' init.lge.rc
 
10:54 PM
No, -i accepts an optional argument for the file name suffix of the back-up file. You need to use sed -i -e ... if you want no backup file.
With sed -ie ... you get a back-up file with the suffix e.
 
oh lol
hmm is it possible not to comment the blank line? doesn't really matter
 
Yes, I'm working on that already.^^
 
I can also prevent "double" comments.
 
oh nice
 
11:00 PM
I'm testing with paste.ubuntu.com/25434952
The sed command /^# LG RCT(Rooting Check Tool)$/,/^$/{/^\(#\|$\)/!s/^/#/} works on that and results in output like in your example.
 
nice
 
You can tell that it's not just line noise because the parentheses and braces are properly grouped. ;-D
 
lel
oh
what's the if statement to check if the command returned an error?
specifically file-not-found
 
If I run sed on a non-existing file it exits with a non-zero status code (2 to be precise).
 
no I need it to check in a cp command not sed
 
11:12 PM
There are multiple ways to check for (non-)zero exit codes in shell scripts.
 
because this is all inside an Android kernel, and if it doesn't exist, then there's an issue lol
just need a simple one
 
Same. Most commands will return non-zero status codes when they fail.
You're writing shell script to be executed from within an operating system kernel? Ó.Ò
 
no
it's extracting LG's kernel, modifying some stuff and repacking
so I need to make sure the boot.img is actually there
 
You may also find the -e option of the set built-in command useful.
 
I just used if [ ! -f boot.img]
 
11:28 PM
[ SmokeDetector | MS ] Offensive answer detected: Spell checker not working in Libre Office 5.2 by user731374 on askubuntu.com
 
11:45 PM
how can I check to see if the output of a command contains a certain string, using an if block?
 
how do I do the || condition in BASH?
 
Isn't that how you do it?
 
i dunno
I have this echo 'adb get-state' | grep -q "error"
but I need grep to match error or unknown
 
That's a pipe.
Ah.
 
11:56 PM
I know it's a pipe lol
phoneman
 
Try using a regular expression in grep.
error|unknown
That will match either.
 
Hey, it's hard to type backtick on a phone. :P
 
wat
tilde?
 
I meant backtick.
It's just hard to type. Period.
:D
 
11:58 PM
wait a second
do I remove the quotes?
 
Swipe isn't cut out for coding on the go.
@TheWanderer no
 
it doesn't work then
 
Put that in the quotes.
 

« first day (2527 days earlier)      last day (725 days later) »