« first day (2376 days earlier)      last day (979 days later) » 
00:00 - 15:0015:00 - 00:00

12:01 AM
@NathanOsman And then the errors become more and more frequent, to one in every ~400 by the bottom of that file
 
Analyzing...
 
:)
Thanks for taking time to help a random person on the 'net debug their code :)
 
Here's the offsets between problem bytes:
They appear to be multiples.
What are the image dimensions?
 
Just a sec, I'll let you know!
 
408 * 2 = 816
408 * 3 = 1224
So that explains the numbers you're seeing.
We need to determine the significance of 408.
 
12:06 AM
3264 x 2448 pixels
 
Both numbers divide evenly by 408.
Interesting.
Could it be an off-by-one error somewhere?
 
thumbs up to@NathanOsman
 
But if it were an off by one error, then wouldn't it thow an ArrayOutOfBounds Exception?
 
(or: why Nathan is a kick-arse developer)
 
@AndroidDev Do you have the code for looping over the bytes anywhere?
 
12:09 AM
Development is more like magic then science!
 
I've got to disappear for a few minutes to eat supper.
(Pizza!)
 
Ooooh, count me in :D
 
ooh no april fools
 
@NathanOsman What kind of?
 
Hawaiian.
 
12:10 AM
Which looping code did you want to look at?
 
hoi
 
hio
 
it's april fools
>>>>:::::(((
 
@Edity Which TZ are you in?
 
@Fabby nz timezone
 
12:13 AM
Ah, yes... day time for you already!
 
:D
 
I'm going to sleep....
02:14
 
gnight
 
Good night all!!!!
 
night
 
12:15 AM
I liked the "gnight" better! ;-)
 
@NathanOsman - Here's the loop for ORing/ANDing the payload with the cover image: paste.ubuntu.com/24290992
 
lol
 
@NathanOsman - And here's the loop for retrieving the embedded payload: paste.ubuntu.com/24291002
 
afk
 
sigh . . . i should be charging for tutoring python
but since it's my good friend, i guess my conscience doesn't let me
My character is not dicky enough
 
12:23 AM
hm... i wonder that guy with alts did that...
i mean, you get much more rep from just writing high-quality answers.
 
# mount -o rw,remount /dev/sda4 /media/root -v
mount: /media/root not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
why do I keep on getting this?
and yes hello :P
 
Because remount doesn't like having a mountpoint.
If you want to remount /dev/sda4, do mount -o remount,rw /dev/sda4 or mount -o remount,rw /media/root
 
also incorrect syntax, you shouldn't put -v at the end
 
# mount -o remount,rw /media/root
mount: /media/root not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
# mount -o remount,rw /dev/sda4
mount: /dev/sda4 not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
 
so . . . i've had a shot of this french brandy just now . . . i don't think i'll be producing any answers tonight . . .
 
12:26 AM
same thing :(
 
Then, it's not mounted. So you can't remount it. mount -o rw /dev/sda4 /media/root.
 
@KazWolfe oh this worked thanks
 
np
 
12:39 AM
now... what should i use pgp for...
 
@KazWolfe send me encrypted love letters ?
 
Lol!
 
@KazWolfe I would say try this, askubuntu.com/questions/745907/… but looks like you already tried it
 
@AndroidDev I did. It jumps right back to R/O
 
12:51 AM
@KazWolfe it's likely that USB is a toast
 
@SergiyKolodyazhnyy see link
there's a way to do it, but in windows only.
 
I bought a bottle of champagne (first in my life) three weeks ago and I didn't know why until now... I'll open it when I hit 10K in AU :D... Happy Friday everyone :)
@SergiyKolodyazhnyy You are using your real name? I thought it was spelled a little differently on github when I saw it 2 months ago.
 
@WinEunuuchs2Unix Happy Friday ! I'll have my second shot of whiskey for your 10k
 
@NathanOsman - Since the entire program is only 194 lines, here's it is in its entirety: paste.ubuntu.com/24291145
 
@WinEunuuchs2Unix it is spelled differently on github. But this is full name
 
12:53 AM
Well I hope you want to be a tea-tottler (sp?) because my 10k is going very very slow.
You know I would have had 500 more points if Jorge Castro accepted my answers on his bounties but he procrastinated (or didn't care!) and I only got 1/2 points based on votes.
ie I would be 10K already.
 
take your time
 
Good advice I will
 
@Fabby That dirty dog... ;p
 
I used to be very keen on getting points too much such that I would rush to write poor answers on my cell phone and have to delete them when I got on my computer.
 
@SergiyKolodyazhnyy What about the ballmer peak?
 
12:56 AM
Now new points are like "meh" I'd rather be writing new applications.
 
@WinEunuuchs2Unix Its all about quality not quantity
 
@JourneymanGeek Ballmer Peak.... on beer number four :)
Yes I concur on quality.
 
(or you HNQ on a crappy answer ><)
which I find embarassing
 
@JourneymanGeek I'm yet to see its effect on me
 
Plus it's about self-fulfillment... I'd rather spend 2 weeks writing code I love that only gets 2 votes than 10 minutes answering a question that gets 20 votes.
 
12:58 AM
@AndroidDev wait, so it's using an int for the RGB value?
 
Don't you need three integers?...lol
 
RGB is only 24-bit - where is the additional channel coming from?
@WinEunuuchs2Unix A four-byte integer can store four 8-bit values.
The fourth channel is usually either ignored or used for alpha.
 
yes... 255,255,255
 
well, it's much more complex than that
there's 32 bit ones now, i think
 
@NathanOsman Yeah
 
1:00 AM
when I was C coding an integer was 2 bytes and a long integer was 4 bytes.
 
For example unity launcher requires numbers like 0000ffff
so 4 bytes
 
I kind of miss C :(
 
@SergiyKolodyazhnyy Well, I know there are other color encodings.
 
@WinEunuuchs2Unix In Java, a short is 2 bytes and an int is 4 bytes
 
But we're dealing with a BMP here.
 
1:01 AM
@AndroidDev I began coding when 20 bit addresses were the max... 8086
 
I don't know anything about BMP anyway
 
@WinEunuuchs2Unix In C++ (not sure about C) the standard doesn't actually state how much space each type occupies, only the minimum and the range of values it must support.
 
i just blah what i know
 
@NathanOsman Originally, I had it exporting PNG, but I switched to BMP to see if it would fix the incorrect bits.. which it didn't :(
 
@SergiyKolodyazhnyy It has a few different encodings, but the most common is 24-bit - 8-bits for each channel.
 
1:03 AM
@NathanOsman yeah, there's standards in C. So atomic types have specific bit size, but it can vary by dialect. For example in standard C char is like what . . . a byte , 2 bytes ? In PIC microcontrollers chars are 1 byte specifically
 
My grub boot is 1920x1080 - 32 bit according to vbeinfo but I can only max out splash screens at 1600x900 for some reason.
 
@JourneymanGeek :D :D :D
 
0
Q: cron @reboot doing nothing

chowRunning Mint 18.1 Serena, but I am sshing into the box vs. using the gui. I've tried everything. Here's my cron entry: @reboot sleep 60;/bin/sh /home/test/Applications/scripts/startup.sh This is in user test's crontab -l. folder permissions: File: 'scripts/' Size: 4096 Blocks: 8 ...

 
Hey @Fabby heck of a long time no see... How is Germany or Brussels or whereever you are hanging your hat today?
 
@WinEunuuchs2Unix 1680x945 by any chance?
 
1:05 AM
@NathanOsman - It's a really simple program; I don't see where I went wrong
 
@WinEunuuchs2Unix Brussels today, Cork, Ireland until this morning....
¯\_(ツ)_/¯
 
@Fabby I haven't tried a 1680x945 picture yet.... If 1600x900 works is it worth the effort?
@Fabby UK wants guarrantee the Northern Ireland will not separate under rule 50.
Or something like that.
 
No, but 1680x945 is a VESA resolution, so your card might boot up in hardware like that....
 
@WinEunuuchs2Unix you Irish???
 
1:08 AM
No my card boots up in 1920x1080 just fine... It's just grub splash screen doesn't show the images at that resoulution
 
But I'm not sure I see anything wrong there either.
 
@Fabby I'm Irish one day a year March 17th.
 
@WinEunuuchs2Unix :D
 
Aha!
 
@WinEunuuchs2Unix Lemme look that up....
 
1:09 AM
Thanks but you don't have to waste your time on me... it's not even a high priority for myself.
Today's challenge is YAD progress bars
 
@AndroidDev I have an idea... You are reading each pixel as a 32-bit integer, but when you create the bitmap, you are specifying BufferedImage.TYPE_INT_RGB
So maybe some of the information is being lost...
I'll have to look further...
 
@WinEunuuchs2Unix OK... I'm very good at doing nothing! >:-)
 
@Fabby You should be Junker president of EU then.
 
@NathanOsman - Just for grins here's the output when using a 1920x1200 image: paste.ubuntu.com/24291237
 
mmmm, second shot might not go through
im quite sleepy
 
1:12 AM
@AndroidDev That looks like Plymouth debug....
I know I said "splash screen" I meant grub background image!
My splash screen is "Space Sunrise" and it works great in Plymouth, but I wish I could make it start in init-top and end later.
 
@WinEunuuchs2Unix :-)
Sleep!!!!
gnight all
 
Yeah it's like 4am his time or something.
@AndroidDev just reread your pastebin definitely not Plymouth Debug but it is dated for "April Fools' Day" :p
 
:)

You wouldn't happen to see the bug in my code, would you? http://paste.ubuntu.com/24291145/
 
didn't feel the second shot
probably because i chased it with some barbecue
well, at least i might sleep well tonight
 
1:32 AM
@AndroidDev The only bug I see is 8 tab stops instead of 4 like I use :/ Sorry I'm very rusty at C in the first place and flunked out of graphics in the second place.... All my coding is limited to information management / accounting, etc.
 
@WinEunuuchs2Unix that's Java
 
@SergiyKolodyazhnyy I saw the Java imports at top of file, but it looked like C to me with // comments and what not.
 
@WinEunuuchs2Unix yeah, because Java uses some C-style syntax
 
Guys
 
@AndroidDev any particular error ?
@TheWanderer yeah ?
 
1:34 AM
I derped again
 
@TheWanderer how derpy did you derp ?
 
I decided to use a switch statement
 
But I forgot to break
 
Let me guess @TheWanderer is really old Zach?
 
1:34 AM
And I spent an hour changes things
Changing
 
Oh . . . so it was falling through to other cases
 
0
Q: Does anyone know of a way to display thumbnails for contact / vcf / vcard files in Nautilus or another file browser in Ubuntu 14.04?

Lili GatesDoes anyone know of a way to display thumbnails for contact / vcf / vcard files in Nautilus or another file browser in Ubuntu 14.04? We were trying to put this together but were unsuccessful but received dozens of "I want this too" comments from other users and friends. Would be a simple way t...

 
@SergiyKolodyazhnyy yerpy derpy
 
Happens to the best of us. No worries
 
At least I'll be able to individually color my quick toggles after this
@WinEunuuchs2Unix mayyyyyyyybeeeeeeeeee
Sergiy Wergiy
@SergiyKolodyazhnyy next name? ^
 
1:39 AM
@TheWanderer nah, Sergius Maximus
 
Lol
I like sergiy wergiy better
 
@TheWanderer I was thinking of a name change today too... WindowsUnix.
 
Hue
 
The "Hue" definitely smells of Zacharee1
 
Hue?
 
1:41 AM
who?
 
Hua
 
@WinEunuuchs2Unix just go with Rick . . . it already shows up in your prompt when you copy paste your terminal text into questions/answers. Why not make it simpler
 
RollingRick
 
@SergiyKolodyazhnyy It shows up in my bug reports too.
 
@TheWanderer hua is chinese word for flower if pronounced with high tone
 
1:42 AM
Ooh
 
Which in Japanese is Hana
 
SSO uses your email address (which has my name) on things you post.
 
My friend's dad's name is Hui and he greets him on the phone with "Hue Hui"
 
Ever seen this symbol ? 花 ?
 
I love Mandarin
@SergiyKolodyazhnyy nop
@SergiyKolodyazhnyy so the name Hannah is flower?
 
1:43 AM
That's hua or hana in Japanese
 
@TheWanderer Hannah might be completely different
 
Yeah it's Hebrew for grace
 
Anywho . . .I've been smarting enough for tonight. I should go finish watching jack's video and sleep
I basically slept like 2-3 hours at work
 
Good job
Literally lol
 
1:45 AM
ikr . . . All because i was pissed last night because of my digital circuits 3 exam, and couldn't sleep
 
Hue
 
@TheWanderer 50 shades of :p
 
Lol
50 Hues of Hue
 
well played, Zach, well played
 
Ikr
 
1:48 AM
I know left, basic, cobol and assembler, I hope to learn right next month. (ikr...get it?)
 
@WinEunuuchs2Unix best advice : there's 3 languages you should know on any *nix system: Python, Perl, and bash . . . optionally posix-complicant shell scripting, awk, and basic sed maybe
@WinEunuuchs2Unix oooooooh, i get it . . . .
clever, clever . . . .maybe i need another shot ?
 
@SergiyKolodyazhnyy I'm sure you are probably right about learning Python and Perl... but my mind is stuck in the gutter to learn Bash and then relearn C within Unix/Linux environment. Of course I have to learn GTK and Gnome too.
 
Well, you're doing an OK just learning Bash. Keep it up
 
@SergiyKolodyazhnyy Yeah. For some reason, after extracting the payload from the cover image, a very small fraction of the bits are zero when they should be 1. See the output from running the program here: paste.ubuntu.com/24291237
About 250 of the like 400,000 to be more precise
@WinEunuuchs2Unix Are you sure you wouldn't rather learn C++ instead?
Instead of C that is
 
@AndroidDev I have a million lines of DOS C code I was hoping to port.
 
 
1 hour later…
4:07 AM
That's terrible.
 
4:24 AM
3
Q: Burning vs Melting - when applied to cooking chocolate

Perry MonschauI'm aware melting is simply heat causing molecules to go from solid to liquid, and burning is a chemical reaction, normally with oxygen; but I don't understand how this applies to cooking chocolate. See, when you cook chocolate naked on a pan, the chocolate will burn. However, if you cook a bowl...

 
@Fabby what's that?
Yum chocolate
 
I thought it was a very interesting question myself
 
4:48 AM
When I was a young teen, I used to have sleepovers with my friends, and an essential part of it was melting a large quantity of chocolate in the microwave and dipping marshmallows in it and eating them
Once we burned the chocolate that way. It was so tragic
 
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, link at end of body, pattern-matching website in body: Boost Your Testosterone And Slow Down Your Death By Rust by dfsd dfsx on askubuntu.com
 
These days I tell my students to measure the wavelength of the microwaves in the microwave by removing the turntable, putting a large chocolate bar inside, and measuring the distance between the melt zones (the waves are about 12cm long, so melt zones occur every 6cm)
Everything is better with chocolate, especially physics...
3
 
5:06 AM
Someone suggested edit to remove the link which I "improved", but the answer is not needed given the other answers and possibly it's spam revisions
 
5:46 AM
@Zanna Same thought I had yesterday, but I was on my tablet and the link didn't work, couldn't check for sure.
 
0
Q: udev not working in ubuntu 16.04 and 14.04

basilI Am Try to Setting udev rule in /etc/udev/rules.d/5-usb-lab.rules 5-usb-lab.rules Rule is SUBSYSTEM=="tty",ACTION=="add", KERNELS=="3-2:1.0", NAME="ttyUSB99", MODE="0777" . This Rule is Work Well in ubuntu 12.04 32 bit but This Rules Setting Not Working in ubuntu 14.04 32 bit and ubuntu 16.04 3...

 
6:31 AM
@JacobVlijm link seems pretty random... I don't know!
 
7:22 AM
Hello.. I am working in a project where pendrive need to format itself. For that I tried to use autorun.sh...but its not working
Is there anyother way to do iti?
 
7:54 AM
@Zanna Yeah, I think it is one of those "why does my Ubuntu not use the latest version" -kind of questions. askubuntu.com/questions/151283/…
 
hmm maybe
 
You don't agree?
 
I think you are most likely right
 
Th alliteration is lost in translation :)
 
8:10 AM
Oh?
 
It is her birthday? Ah, waitwaitwait...
 
Yeah wait. o.O
 
You are bad :)
 
I should have expected this from someone named "jokerdino".
 
:D
 
8:11 AM
o.O
I missed it
 
That creates the idea, let's write totally silly answers today :)
 
He wished you a happy birthday.
@JacobVlijm we already get a few of those.
Like the guy who told another user he could clean his PC with soap and water.
 
@NathanOsman ....But he was kidding doesn't sound good :)
@NathanOsman where? wait, not you too?
 
@JacobVlijm it wasn't me.
I think you can find it on Gems somewhere.
 
I remember someone asked me in high school if I knew when the birthday of her crush was, and I told her it was February 31st
she believed me :/
 
8:13 AM
:|
 
I did tell her later that I was pranking...
but still :(
 
@Zanna Haha, but: Soap not loaded error even after installing in Ubuntu gets another meaning now: askubuntu.com/questions/887723/…
 
sounds like an error thrown by a "smart" washing machine
@jokerdino how do you know it's NOT my birthday today?
 
Maybe we should just pin a Happy birthday message haha.
 
8:17 AM
...We should!
 
hahahaha
 
Volonteers?
 
Happy birthday @Zanna! Have fun~
9
 
or better a Happy Unbirthday message - that would be valid almost every day
@jokerdino roflmao you are in big trouble
 
Coincidentally, this is not my birthday as well.
 
8:19 AM
that's so strange
 
Happy birthday @JacobVlijm too~
9
 
Haha, to you too @jokerdino
 
OK, we are setup now.
Just need to chat this transcript away ;)
 
Many questions are potentially funny though: Unity Launcher and Top Panel disappeared in 14.04
....Now we only need to find 14.04 to get it back
 
@JacobVlijm that would be a cruel joke haha.
Weirdly enough, it happens to people all the time.
 
8:28 AM
:)
 
@JacobVlijm it is one of those days
 
Yeah, it is! @Zanna
 
9:02 AM
oops hammer
didn't notice the tag!
 
9:40 AM
Voted
 
Thanks :)
 
Thank you for catching :)
 
@Zanna A silly joke!
@JacobVlijm voted
 
Hey Fabby! Thanks :)
 
@Zanna starred!
 
9:55 AM
@Fabby haha thanks :D
 
@JacobVlijm seems like clever spam.
 
[ SmokeDetector | MS ] URL-only title, bad keyword in body, bad keyword in title, link at end of body, link following arrow in body, +2 more: newmusclesupplements.com/endovex/ by sidneygi on askubuntu.com
 
@jokerdino smart man!!!
 
@jokerdino WOW, I even didn't think of it for a second. Sharp!
 
@Fabby Not getting fooled today ;)
 
10:04 AM
:D
 
^ obviously.
@jokerdino Interesting strategy: post the link in the title. Too big to notice.
 
10:24 AM
Hah! I just came up with a new acronym: FQDNWP
 
grr, let me flag pl0x
 
10:49 AM
another grrr, people editing questions after answer has been posted. askubuntu.com/questions/899118/add-icons-in-unity-quicklist/… (image of..)
 
@JacobVlijm upgoated
(did you read the FQDNWP answer??? (good for a laugh)
 
11:08 AM
Wow, thanks!
Haha :)
 
:)
 
11:24 AM
@JacobVlijm I deleted an answer (with 2 upvotes) on U&L because of same this morning :/
Yessss flagged it
 
I flagged an answer for deletion because it just said "you should use jquery for that".
(and pointed out it'll be 2 April tomorrow!)
 
11:43 AM
I just VTC the question, couldn't bring myself to VTD that one
We can delete the question later
 
11:59 AM
Can I ask what are your 'Evdev Scrolling Distance'? xinput list then xinput list-props 10 if 10 is the mouse
mine are at 1 1 1, the minimum, but it scrolls too slow
 
 
1 hour later…
1:11 PM
@caub for my ALPS Glidepoint:
Class originated from: 12. Type: XIScrollClass
Scroll info for Valuator 2
type: 2 (horizontal)
increment: 25.000000
flags: 0x0
Class originated from: 12. Type: XIScrollClass
Scroll info for Valuator 3
type: 1 (vertical)
increment: 25.000000
flags: 0x0
 
1:34 PM
deeeeeeerp
 
good morning
 
Good morning
 
Did you get your 200 dollar gate array?
 
sigh . . . i hate public transportation on weekends. Was waiting for light rail to arrive 20 minutes almost, basically I'll be late to work again
this week hasn't been the luckiest for me
@WinEunuuchs2Unix it's on the way, should be here by April 4th
 
@SergiyKolodyazhnyy Cool. It looks like that thing will keep you busy for a while.
 
1:40 PM
just in time to start working on the project #1
@WinEunuuchs2Unix it probably will. Professor said the project is new, different from what they did in previous semesters so he doesn't know how will that go. He is basically testing things on our class, which I'm not exactly happy about
i don't wanna be a test rabbit at expense of my grades
 
Your class will be guinea pigs
 
unfortunately yes
Well at least i am going to finally get my board and start messing with it and hopefully learn it well enough to the point where i can apply for a job
FPGA jobs are still in demand
 
@SergiyKolodyazhnyy depends. If he takes it into account you might get some free points ;-)
 
Yeah FREE POINTS!!!!
 
@Rinzwind unlikely but we shall see.
 
1:45 PM
:D
 
I am working by myself , so at least i dont have to worry about my partner's grade and can focus solely on the project
 
I have 4 installs from Iran o_O
 
@TheWanderer itz de hackorz. Or nsa
 
hue
 
Oh say can you hue . . .by the dawns early lights
 
1:48 PM
hues
 
Hues back
anyway . . . once i am done with this class i might get Xilinx fpga board just for the heck of it
The one we are using now is Altera Cyclone V
at least the cool thing is that i could be at least slightly employable after passing this class
 
2:12 PM
Anyway, I'm at work already. Late, but there. . .
 
2:24 PM
Lol
 
@TheWanderer he must be an Xfinity user
or she
 
2:47 PM
We don't have Xfinity here lol
Just CenturyLink and Service Electric
And CenturyLink is pretty bad
 
00:00 - 15:0015:00 - 00:00

« first day (2376 days earlier)      last day (979 days later) »