« first day (3211 days earlier)      last day (36 days later) » 

1:31 AM
0
Q: chmod equal sign isn't working appropriately

Amjad AbdullahDoes the equal sign in chmod command revokes unmentioned permissions? for example, the command chmod u+r file1.txt does it yield a permission -r-------- ? or it keeps the u and g permissions as they were before executing the command? I am confused because the man page says: The operator ...

 
 
6 hours later…
7:10 AM
0
Q: Why target id 0 cannot be created

JmirYI'm trying to set up iSCSI network, I can't create target with id 0. Host OS is Ubuntu 18.04.2 LTS .

 
2 reopen votes needed askubuntu.com/q/1157882/816190
 
7:44 AM
1
ehhhhhhhhhhhhhhhh
 
8:04 AM
how should I interpret this comment:
1
A: at command Option Code

RinzwindUnix is NOT Linux. "at" is optional on Linux machines.

 
8:37 AM
@Rinzwind By repeating GNU's not Unix?
 
8:50 AM
Hi o/
Can I put in my custom service something like this under [Service]:
`ExecStart=python /var/www/sample/api/test.py --ini sample.ini` ?
 
askubuntu.com/questions/1158026/… - Why on earth would anyone want network mananger to execute javascript? :S
 
With that change it is throwing below error:
[/etc/systemd/system/sample.service:10] Executable path is not absolute, ignoring: python /var/www/sample/api/test.py --ini sample.ini
sample.service: Service lacks both ExecStart= and ExecStop= setting. Refusing.
 
Set it to /usr/bin/python /var/www/... maybe?
 
I am running it on python virtual environment
So shall I give the path of virtual env instead ?
 
56
Q: How to enable a virtualenv in a systemd service unit?

guettliI want to "activate" a virtualenv in a systemd service file. I would like avoid to have a shell process between the systemd process and the python interpreter. My current solution looks like this: [Unit] Description=fooservice After=syslog.target network.target [Service] Type=simple User=foos...

 
9:00 AM
btw I have this as well in service:
Environment="PATH=/var/www/sample/sample_env/bin"
@ByteCommander checking
@ByteCommander +1
 
9:20 AM
Now I am getting an import error since the module I am importing is not present in current virtual environment. So to solve this; I tried installing the module via pip command; like this: pip install flask . After downloading the module, it is throwing error ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/var/www/sample/sample_env/lib/python3.5/site-packages/werkzeug'
using "sudo" is not recommended for installing packages
I tried with --user and easy-install option. Both of them not working
Is there anything else which I can try ?
Even if I use "sudo" with pip command; it is installing the package in global python lib not in current virtual env
 
10:03 AM
eh why would you install packages in /var/www/? aint that where you have your website? I would always install those in the system itself.
 
@Rinzwind Yeah website with own python virtual environment
 
The user executing "pip" seems to not own /var/www/ or any of the dirs under that :P
Seems logical: /var/www/ is probably owned by the webserver (as it should be) and your user is not the webserver user (as it should not be).
 
Yeah had to switch to root user
Which is certainly is not a good choice
Now it's all good.
 
10:38 AM
Linux time line is a lot more messy @terdon :D
 
?
It is, yes. But why are you mentioning it now?
For that POSIX Q?
 
oh you already forgot about the "at" question? :=)
sorry I skipped steps there >:) found that image on the wikipedia page
-3
Q: How can I get back my previous data?

Rosa WaltonIf you have any suggestion please help me. I need a best data recovery software for recovery my previous file. Advance Thanks Rosa Walton

see the comments. can you kill that user? >:)
 
Your eyes reminds me of Elfen lied's Lucy. @Rinzwind
@Rinzwind I read that as "my previous life.."
 
11:02 AM
@Rinzwind No, but I'm still trying to understand why the image is relevant.
I mean, sure, Linux isn't POSIX and doesn't try to be, but that list of tools isn't mandatory for POSIX anyway. It just needs to support them, which doesn't suggest they absolutely have to be installed by default.
 
@TheLittleNaruto That it is from >:)
@terdon I am not allowed to share a picture with you? :(
 
11:19 AM
@Rinzwind Of course you are! I thought you were making a point that I was being too stupid to get.
 
@terdon well I aint qualified to make that assesment >:) But there was no point except for my comment it looks less messy :=)
 
This one has been dealt with. Quite a sneaky one. I had flagged a previous question by the same person based on the presence of links but today's question was devoid of links. Fortunately, two more experienced people came along and I learned of "spam seeding". So something good came out of it all, at least for me.
 
11:34 AM
@DKBose Same here.
 
@DKBose cool. feel free to nuke the comments.
 
Yeah, Rinz mentioned that and I destroyed the user.
 
I haven't noticed anyone closing raspberry pi as off-topic yet?
 
@terdon <3 <3
 
11:51 AM
@WinEunuuchs2Unix No, why? They're using Ubuntu.
 
@terdon Raspberry Pi is a different kind of beast is all...
 
@WinEunuuchs2Unix Sure, but we don't consider any hardware off topic as long as it is running an official Ubuntu flavor, so I don't see why the pi would be any different.
 
It would condition them though because new Raspberry Pi will be running Debian Buster on Kernel 4.19 LTS and not Ubuntu Mate.
Anyway I didn't VTC, simply tried to help the guy... ciao
 
@WinEunuuchs2Unix Then it would be off topic, yes. But if they're running Ubuntu, I don't see why we would consider it off topic. We have quite a few questions about the Rpi.
I agree that the OP would likely get better answers on Raspberry Pi though.
 
12:11 PM
@Rinzwind I can't delete even my comments there. Even in a normal situation, deleting comments is not one of my privileges :)
 
@DKBose looks at @terdon :-)
 
The whole question has been deleted, there's not much point in deleting the comments.
 
 
6 hours later…
5:49 PM
0
Q: Ubuntu machine time issue

RK3New to ubuntu. I see that my machine has wrong time set in the system. Can some one help how to correct the system time. timedatectl shows Local time: Tue 2019-07-16 03:53:00 IST Universal time: Mon 2019-07-15 22:23:00 UTC RTC time: Mon 2019-07-15 22:23:00 Time zone: Asia/...

 
6:09 PM
0
Q: Permissions Not preperly set Ubuntu Samba 4

Elcid_91I am in the middle of permissions chaos setting up my samba server and shares. This is not a complicated setup but I cannot get the permissions to work: Scenario: Samba 4 on Ubuntu 19.04 5 users in the same group (company) need to access a Samba Share and have the ability to read, write, edit ...

 
 
1 hour later…
7:17 PM
Oh boy, I reached 70k today \o/
 
7:46 PM
@ByteCommander congrats
 
Quick question: Would you consider "Please help" a good thing in question title?
Does it need to edited out?
 
8:04 PM
It's one of those things that you can remove if you're editing anyway, but editing only that is probably not really worth the effort.
Just like salutation lines etc
unless it's really annoying, i.e. "PLZ HALPP!!" and the likes
 
@Kulfy looking...
 
@ByteCommander Indeed
@ByteCommander What about plzzzzz?
 
@Kulfy Huh...
Is is dismissive? Unfriendly?
 
ಠ_ಠ
 
8:13 PM
@Fabby It seems they created an account just to reply you :P
 
@Kulfy edited it to point user in the right direction in the answer...
 
@Fabby system+sister=syster?
TIL
 
@Kulfy Huh?
 
@Fabby but still on-topic over on superuser.com, a syster site to Ask Ubuntu.
 
@Kulfy Missed that!
Next time feel free to edit stuff like that!
@Kulfy corrected.
Thanks for pointing that out!
 
8:25 PM
@Fabby I thought you might edit it in grace period and nobody else would notice. So, I stepped back.
 
@Kulfy :-)
I cannot be insulted!
(one of my disadvantages)
>:-)
 
@Fabby Did you mean you don't take things personally? If yes, that's a good thing IMO.
 
>:-) ;-) :D
 
@Fabby -_-
 
@Kulfy (I wanted to make you :-), not :-| )
 
8:39 PM
@Fabby In my college placements, I was about to put this point as my weakness.
:P
 
You've lost me now... Honesty?
 
Yeah
 
@Kulfy Honesty is a disadvantage though...
... I cannot remember what I lied to whom, so I just tell the truth.
 
9:34 PM
Honestly though, I'm an honest man mostly.
@Fabby ^^
 
@RobotHumans Good one... Now link it
 
Too late for edits
 
(as pics interrupt the flow of the posts and it's so easy)
@RobotHumans Next time!
(also if you star them, you don't get a link, but a description)
 
fair enough. had a fellow on fedbook complaining about the MTA being jammed up on his first day at a new job in NY. I just shook my head. It's jammed up every day. You either leave early and get there way early, leave on time and are late, or leave late and get there a little late.
 
10:13 PM
@RobotHumans I read MTA as "Mail Transfer Agent" so I was wondering:
Can't you autostart this shit?
But I suppose it's some kind of public transport like "the tube"?
 
I put my money on "Metro Transit Authority"
 

« first day (3211 days earlier)      last day (36 days later) »