« first day (2624 days earlier)      last day (2385 days later) » 
00:00 - 20:0020:00 - 00:00

12:00 AM
I'm off to bed! :)
1:08 AM
@Fabby fixed the script , committed all changes to github and into the answer, verified with set -x that everything works, and changed couple parts. Let me know if there's any issues. Cheerios ! Thanks for Czeching out my script :D
hmm, also I think I've advanced a bit since the time I wrote that script. I think I'd probably approach this task quite differently if I had to do it now. Maybe could reduce it to a command or two only
1:27 AM
wtf CW
@dessert There's two parts actually. One is virtualenv, but the other one is pyenv (which is more or less deprecated now)
I use pyenv to create local Python virtual environments as 'stock' versions of the given version, and then create a virtualenv for a given program with virtualenv and refer to the Python version installed by pyenv.
1:48 AM
Let the memes begin
you're welcome :)
what, nobody's gonna match me up with another meme ? tsk
Not even a Unix pun anywhere. I should rm myself from here maybe
Hey guys. Guess what? Apple hasn't messed anything up this we— oh, never mind.
another one?
To be fair, this issue is a few weeks old.
But it doesn't appear to be fixed yet.
2:02 AM
"there's no obvious way to kill an entire sandbox, for example" ... wait, does that mean that if there's malware in the sandbox, one can't technically nuke it from the orbit ?
Also . . . kill syscall ? Really ? Didn't Apple grab base system from like early BSD release ? Does that also mean BSD's syscall implementation is affected ?
macOS is based on Darwin.
Darwin kernel, but what's that based on ?
2:06 AM
Q: How closely are Mac OS X and BSD related?

BooleanI read that Mac OS X and bsd are related. How closely are they related. Can Mac OS X software be tweaked and installed on BSD?

^--- more details here
finally fixed
also, Linux Journal is shutting down :(
Such a pity. I wasn't reading Linux Journal regularly, but I did learn a few things from it here and there
@Seth :(
Also . . . inb4 systemd, adding word processors, unnecessary features, etc.
That reminds me...
2:09 AM
@SergiyKolodyazhnyy same
@SergiyKolodyazhnyy "SystemD adds Windows"
shudders That's the real horror
^--- lol
Soon in theaters near you "SystemD'ing", "Attack of SystemD clones", "SystemD'ception"
2:13 AM
Make. This. Happen.
George is willing to lend his talents for this.
Hey wait a second. We already have a "SystemD Day". It's April 1.
I'm so tweeting that.
Do it.
Make sure you use sytemd's twitter client
2:22 AM
oh dear
if anyone has Netflix watch The Flash S3E9 from around 14:40
that's probably the worst CG scene I've seen
2:56 AM
Here's a riddle for you guys
dammit, links
hang on
what the
net-tools uninstalled itself
What did you break already ?
I was going to make a nice riddle with a bin and Bash from Reigns
I didn't break it
17.10 is a hot mess
Well, at least it's artful ... advark
@TheWanderer yes it's annoying, net-tools isn't part of the standard image anymore :p
still exists though
3:00 AM
no no no
I had ifconfig working
and suddenly it wasn't installed
don't touch autoremove :p
autoremove didn't do it
IIRC ifconfig is slowly being phased out in favor of ip utils
ip addr, ip route
how do you disable interfaces with ip?
ip link set wlan0 down
it's got a lot of options
There's man ip-link on that
3:05 AM
why is it so complex
@andrew.46 Giving slack another go
@TheWanderer Because complex is the new simple, and simple is the new complex. Just look at systemd
But granted, ip commands give a bit nicer output ( IMHO ) than ifconfig and iwconfig
$ ip -o -4 addr show wlan7 | awk '{print $4}'
much easier to parse with awk
blasts epic evil music and laughs evilly as he does some Pythonic black magic
Ooooo, magic and snakes ! that's my jam
I actually want to keep a pet snake someday
yay now the alt_f2 menu froze
3:09 AM
@SergiyKolodyazhnyy i've got three.
they're all under the porch.
@ThomasWard nice ! Can I take one ? I'm sure they'll become friends with my garden snakes
good luck, they're quite comfy under the porch where they can snag all the rodents that try and get into my apartment :P
Anyway, smoke and then back to studying. I've still 3 modules to complete in my class before taking final assessment and then final exam.
What's cool about AskUbuntu is that there's no final exams (therefore less stress). It's just perpetual answer posting cycle with occasional upvotes and downvotes and badges
well there are exams
especially if you do something wrong, you incur the wrath of Diamonds.
so you're constantly self-checking your conduct :P
Conduct is one thing, I'm OK on ethics. But I like that I can answer what I know. If a question isn't in my league, I just leave it
1 hour later…
4:41 AM
BIOS Self Test; Bootup ; yawns
good morning everybody
@Videonauth The Darkness compels you to be stuck in a boot loop for eternity.
You know you're a developer when someone asks you a question and your response is worded like an RFC with perfect terminology and every possible corner case covered.
@NathanOsman No then you're Richard Stallman, a developer just hands you a piece of paper, on which is printed upon the magic word ...."MANUAL"
5:40 AM
I wonder when the winter bash will start this year
6:03 AM
one of the mods around?
@Seth are you're still around?
actually yes
ok have here an impossible situation : askubuntu.com/questions/642991/… this is going to be close voted agains this askubuntu.com/review/close/782842
and vice versa
would mean in the end none of them would be open for new answers
can you kick one of them off the queue
luckily i got both in one review session, or this might would have gone un-noticed
they are both having a good share of answers accumulated tho, not checked them yet for queslity, might make a good merge candidate
The questions major issue is the Xfce Desktop and the use of Chrome/Chromium browser, the problem exists in any Ubuntu/Linux distro with Xfce. Either you have an answer, and answer the question or waste peoples patience and time. Way to go. — Gjohncoe 6 hours ago
should I flag that?
6:18 AM
done so
First i was half way through writing a response comment to that, but then i found this would be rude as well and not the way I roll :)
6:48 AM
I don't know if I'm a developer, but it feels sweet when I wake up, look at a comment by user, find a solution like "yep, I can rewrite my script as so", and go back to sleep
tbh, I probably fit more to be a sysadmin
i would not even know where i would fit :) since I'm sorta jack of all trades but master of none
7:07 AM
@Videonauth I commented about your "impossible situation" in Raiders of the Lost Downboat before reading your comment here. The real duplicate question is this one: askubuntu.com/questions/656744/… which needs one more CV to close it. Closed already.
@karel well this is now closed but the other one remains in the CV queue
oh its done already, good then i can close those tabs
@Videonauth The question passed the preliminary stage of the review, and it was voted to remain open.
Well good then :) because i initially CVed the one which is now left open
@Videonauth All OK now, the CVs on the open question have been automatically erased.
7:33 AM
It's always dangerous to read Wikipedia late at night. One never knows where one might end up.
I learned what Botox is. It's basically a small quantity of botulinum A toxin.
Wikipedia has this to say in the same article:
"Botulinum is the most acutely lethal toxin known, with an estimated human median lethal dose (LD50) of 1.3–2.1 ng/kg intravenously or intramuscularly and 10–13 ng/kg when inhaled."
yep ;P and woman use this to look younger and more sexy ;)
no wonder were are where we are demographically
Where is the puking emoji...
that's the way to greet on a thursday morn'…
8:13 AM
@SergiyKolodyazhnyy now only an answer from @desert is missing :D
8:30 AM
@dessert I am curious what you can come up with for this one ;) askubuntu.com/q/983324/295286
@Videonauth good answer btw, lots of reference to manuals. I like that
yep thats my new way of saying RTFM ;) i reference where i can
well to be honest some people wight not even be aware that a bash manual exists, so pointing to it maybe makes em read it
@SergiyKolodyazhnyy Is this a test? :)
A competition kind of thing?
code golf?
@dessert answer golf :p
longest most explainign answer wins :P
or so
@dessert no , this is a [
Sorry, have no better pun tonight
oh so its not a [[ ?
nnow we just need one sed answer and one using awk to blow the OPs mind to nirvana
8:38 AM
Well, at least according to bash's manual, [[ is a compound command apparently :)
ah and and and perl
That's probably gonna bit a bit too much for OP. "Guys, I only tagged my question with bash, slow your horses"
I too wondered why you guys stuck to bash, but OP asks about that…
> So I am new to bash scripting
Nathan could do golang, of course
have a full-blown awk script nobody gets :D
8:41 AM
8:57 AM
not sure whether this is actually a good way, but how about we store the file content in a variable instead?
i=$(cat 1)
mv 2 1
echo $i >2
might work, but what if it's a gigabyte size file
yes, what if? we'll be clogging the ram, so what? ^^
@dessert Very bad idea for large files.
Not just clogging, the file could easily be greater than the available RAM. That could bring the whole machine to its knees.
9:02 AM
Oh, so that's a candidate for
Q: How to make my Ubuntu lock up?

Sergiy KolodyazhnyyWARNING!!!: The question asks for temporarily breaking Ubuntu. There shall be no safe answers. If you have important services running, important documents/files being edited, please note that you might not be able to recover/save your work. Please note that trying these answers is not recommende...

I wonder, is cat inside a script a good idea at all?
I feel like I always advise against it…
cat inside a script is bad idea, you have a stray feline in your filesystem
@terdon so . . . ${1%/*} fails. Parameter expansion doesn't work with positional parameters ?
@terdon nevermind, apparently that's just mksh. It apparently works in bash
Nope, it actually isn't bash
$ bash  check_temp.txt  input.txt
+ dir1=input.txt
++ mktemp -p input.txt
mktemp: failed to create file via template ‘input.txt/tmp.XXXXXXXXXX’: Not a directory
+ tmpfile=
+ echo ''
Try a directory name, not a file
@SergiyKolodyazhnyy I often tried that and never got it to work – seems like it doesn't. :(
9:14 AM
@terdon well, from your comment it's supposed to be dir1="${file1%/*}"; but even if I store $1 to file1 variable it still breaks, what if "file1" contains filename from current working directory ? Also, directory name such as /etc/ would work because there's slashes, but there's to remove if it's in cwd
Q: How can I create an ISO of a VPS server and run it locally into VmWare\VirtualBox?

AndreaNobiliI am not so into Linux and I have the following doubt: I have a VPS server based on Ubuntu 16.04 in the cloud. I have the root access. I want to know if it is possible do something like this (by the shell, I have no desktop environment): can I create an ISO of the entire system that can be run i...

Q: Can i switch to windows cmd in ubuntu for windows?

Peter verlegIf i want to start ubuntu from windows terminal i can start and exit the ubuntu commandline: I was wondering can i start cmd from ubuntu too?:

I like this question: How do you run Windows cmd.exe stuff in Ubuntu?
Q: CMD.exe Emulator in Ubuntu to run .cmd/.bat file

Shiplu Mokaddim Possible Duplicate: Executing .bat file The title says it all. I need to create batch files and run and test them. I dont have any Windows machine. If there was any cmd.exe emulator in Ubuntu I would have worked on it. So do you know emulator that can run .bat/.cmd files? I know I ...

Q: Windows CMD for Linux?

bugmagnetLet us assume that I am not in my right mind, as no one who has used a good shell like bash, fish or oh (or any of the other shells listed here) would want this. Nevertheless, seeing as one can have bash on Windows, has anyone tried to create CMD.EXE for Linux? If so, where can I get it from, an...

@SergiyKolodyazhnyy What is the output of cat image.png? --> Of course a cat !
@Videonauth output of a cat ? looks at cat litterbox Emmm . . . I probably shouldn't mention that in chat
Also, awwwww, that's adorable
yes she is adorable but sometimes she drives me crazy
especially when im really working on something she tends to lay down on my hand on the keyboard
but if you have a computer mouse you as well need a computer cat
9:31 AM
Yeah, my cat used to come and lay down my laptop's keyboard
And still does that occasionally ,but not as much. I now spend more time sitting in front of my dual monitor setup
anway, gtg
bye folks
bye :)
@SergiyKolodyazhnyy Chazelas hits again – thanks!
@SergiyKolodyazhnyy Yes, good point. That assumes absolute paths. I'm just thinking that if one of the files is on another filesystem, copying it to /tmp can take a long time. OK, how about:
Ah no. I was about to use readlink to get the full path but that would break on symlinks. It would copy the target, not the link.
I guess you have to use dirname.
Ah, but you'll still get problems if you don't have write access to the directory (that's why you're getting that error with mktemp). Damn.
9:51 AM
@terdon well i edited my answer already , I solved it with just hardcoding "." there
Ok, now i am out for sure
@SergiyKolodyazhnyy What if the disk runs out of space? askubuntu.com/questions/983324/…
@dessert well i don't know if this would not already be overkill, might as well have a protection for sky is falling events or such ;) and question [ -e $TMP/tempfile ] is true so wouldnt it then run rm with the files still rpesent in the tmp directory?
@Videonauth oops ;P
so turning around the following logic :)
and yes the $1 and $2 was agood catch, happens when i try to make my life easy and do a copy and paste ;)
10:12 AM
@Videonauth I figured, happens to me all the time.
weird weather outside, dark, rainy simply depressing, and im again already tired
@Videonauth I'd be tired too if I slept just five hours (or even less) – how about sleeping? :P
@dessert would be nice if, i not even slept, my medical condition prevents me from sleeping, but i not want to take those hardcore pills every day
so I'm mostly 3-4 days awake
then sleeping due to medication and agin awake
@Videonauth My sympathy, now I get why you're here nearly 24/7…
10:23 AM
@Videonauth Ouch :(
sounds worse than it is, but its enough to being pensioned at age of 45
@Videonauth Every cloud has a silver lining, eh?
there is no way you have enough power to do actual work
Of course not. :(
@terdon Its simply lifes rule, adapt or go down
10:24 AM
And at least you're in Germany, so probably have a reasonable pension.
and since i cant change it i chosen to adapt
@terdon 378 euros ...
i call that just enough to not die, i still have to get subsidies for the rest
Oh. That's uhm, almost as low as Greece!
yep its almost nothing if you take the high prices for living in account
together with subsidies i have 806 euros, but 389 are rent, aournd 60 for electricity and about 60 for phone/mobile/internet
and then medicine which is not fully covered by health insurance
and every two years i have to get reevaluated for being pensioned, which costs them around 5-50k euros for the evaluation, that is far more than i get in the same time
makes sense or, does it?
Good evening ... this place vs IRC -- any thoughts?
You can forget about pension in Germany, it's merely a joke…
10:31 AM
@DBinJP IRC runs in terminal if you want it :) but here the climate is better :P
@DBinJP There are real people here.
... I suppose it was a dumb question, because my IRC port is blocked on wifianyway.
(at university)
/me wonders if /me works.
There are no stupid questions :)
/e wonders if /e works.
/emote wonders if /emote should give up already.
@DBinJP None of the IRC things work. This is a completely different system.
10:32 AM
\me wonders too.
@terdon -- except tab complete, apparently :P
See here for what little fancy stuff you can do. And that's only for formatting.
` inline code for single lines * = italic ** = bold ***= italic bold
@DBinJP Oh wow, IRC does that now? Last time I used IRC was in the late 90ies so. . .
... there are too many ways for me to procrastinate. >_<;;
10:33 AM
But you can paste any question/answer/comment link from the SE network and it will get nicely formatted. :)
@terdon actually client-dependent i think
@DBinJP QUite possibly. Has to be, now that you mention it.
"i am smart. smrt. i mean s m a r t" -- homer simpson('s voice actor)
no enter/leave notices here either, eh?
to quote @GeorgetheDev it now is called smartctl:P
10:35 AM
@DBinJP there's something way better: You can see how active the chat users are!
smartmontools huh
Apr 29 '14 at 23:31, by terdon
S.M.A.R.T. is the new S.T.U.P.I.D.
@dessert whatchu talkin'bout willis
@DBinJP On the right you see the avatars, they turn pale when the users doesn't write anything.
oh snap
ain't that the shizzlet
(can we say shizzlet in here?)
10:38 AM
@DBinJP systemd (service) systemctl etc.
Idea for a Twitter bot: every time someone uses the name of a Unix command in a tweet, the bot replies with "the correct command is now [name]-ctl". #systemd
@Videonauth starred!
Ah, another great feature!
take a look at the right side of the chat, thats the star board
10:40 AM
You can star a post!
computer cat ... indeed.
... ... ... (searches Internet)
TIL the person who named it a mouse had never before seen a mouse.
... I guess it's better than "clicker" though.
if you click on the time mentioned on the star board it will take you to the apropiate places in th ranscript
"Cooker, toaster, blender, just say what the thing does, and then you add -er. Kitchen Appliance Naming Institute [...]" -- Mitch Hedberg
O: oh my that's cute
@DBinJP there starred it :+
also i didn't know this was logged D: alt+f4!!
D: that was like ... wasted star power. don't play mario kart bro, you would lose >_>
10:45 AM
good afternoon :=)
it'w wicked early morning here, but hello. UGT morning.
good wake time :) (I do not count hours)
lol @Videonauth
Fair point. I was criticized once for saying the whole world should run on UTC + 0. No timezone differences, and it's just dark during the day some places.
@RobotHumans China does that. 1 TZ for the whole country.
10:51 AM
$ fortune | cowsay -f tux
/ Don't speak about Time, until you have \
\ spoken to him.                         /
       |o_o |
       |:_/ |
      //   \ \
     (|     | )
    /'\_   _/`\
It's not a bad idea. Imagine how irritating it is if you live in one timezone and work in another. So, during your commute, your wake up alarm on your phone goes off again. If it doesn't happen to you every day for a month, you have no idea how valuable setting the alarm/clock application to unadjusted UTC values is.
Also, I did NOT know there was a cowsay for that.
cowsay can do a lot of different ones
Alternate thought, I was time traveling every day for a month ;)
so are you now actually 30 days younger or older as your passport shows? Or didn't you reach the speed of light?
Nah. I went back in the other direction every time and never broke the speed of light. It was just a commuter train. Hopefully Elon will come up with something for that ;)
11:10 AM
not computer related but still funny: The comments below the question↓↓↓↓↓
Q: Why didn't Sauron go looking for other dragons after Smaug died?

JamesDAnother question here mentioned that there are more dragons in Middle-earth than just Smaug. Why did Sauron not search them out, if Gandalf thought that Smaug was important enough to create a quest to get rid of the dragon, because of the danger that he posed?

11:20 AM
Well, the dragons were created by Morgoth, so they kind of had to obey Sauron. However, we all know that Sauron isn't very good at finding things. — void_ptr 17 hours ago
I like this one most
@DRF I think it was more of a Nazgul thing: "I can hear the Ring's calling nearby... But I can't see a damn thing in this stupid hood! Screw it, Saurie can go look for it himself, I'm going home". — Darth Hunterix 44 mins ago
11:44 AM
nice, I could find an answer to write on SO :D
except the question is 2 years old, but it's still useful additional information
4 hours later…
3:32 PM
Has anyone noticed that Google now supports Stack Exchange for showing multiple answers in their search results? For example, google.com.lb/… would show this i.sstatic.net/hcYFg.png
Q: Google special SERP entry for Stack Overflow

kjhughesWow, have you seen the new search engine result page entry for Stack Overflow hits in Google: And when there are multiple answers: I am not sure if this has been rolled-out globally or if this is just an A-B test, but I think this is an excellent improvement for the UI to our favorite Q/A s...

This is really cool though, I think this helps when people still unfamiliar with how SE works. As they can see there may be more than one answer.
Yeah, it's a nifty idea.
I've seen a few colleagues who would just leave a certain question just because the answer on the top didn't work for them
3 hours later…
6:24 PM
I think I'm just going to try 18.04 again
I have a 17.10 image and I know how to dd so that should work if I need it
7:01 PM
Facebook for Android is broken. Don't update if it isn't too late.
App won't even start after clearing all app data.
Imma see if logcat shows me anything interesting.
Maybe it's this error? I dunno...
Continues reading...
I just don't use it
problem solved
@NathanOsman that's just a W though
7:16 PM
This might be it: paste.ubuntu.com/26120400
I know Facebook does some black magic with the class loader to make everything fit in their app.
they must be compiling without a lint
because that's a pretty big error
also, why is do-release-upgrade stuck on Reading Caches?
Man, they really messed that up.
there's no way that APK was even tested
just compile-->upload
I'll try switching to beta to see if that helps.
can you help me?
7:24 PM
With... what?
the do-release-upgrade
it just hangs on reading cache
When trying to install `steam-devices`:

sudo apt-get install steam-devices
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package steam-devices

I tried `sudo apt-add-repository multiverse && sudo apt-get update` but that doesn't work. Anyone have any ideas on how to get this package to install?
@TheWanderer You could try clearing the cache.
sudo rm -rf /var/lib/cache/apt
I think that's right.
7:28 PM
doesn't exist
sudo apt-get clean
Try that?
did that already
@user1770201 enable multiverse in software-properties-gtk
(or your DE's GUI)
under /var/cache/apt/
but still no effect
7:33 PM
@user1770201 or with e.g. sudo add-apt-repository 'deb http://archive.ubuntu.com/ubuntu artful multiverse' – replace “artful” with your release!
Argh. Have to reboot my Pi after 50 days of uptime over Docker issues.
It shows that I have multiverse added already
I also ran sudo apt-get update
I'm running xenial
00:00 - 20:0020:00 - 00:00

« first day (2624 days earlier)      last day (2385 days later) »