« first day (2192 days earlier)      last day (1516 days later) » 

12:00 AM
@ByteCommander could you please tell me why ?
 
Imagine a command like echo $text.
 
@SeverusTux i think the arch linux forums have a higher standard in terms of amount of prior research one needs to do
 
And now, someone manages to set text='you are screwed ; sudo rm -rf /'
Or something less severe:
 
@ByteCommander Oh.. okay
 
@SeverusTux like BC said , it's for security but also to prevent word splitting. Google word splitting in bash
 
12:03 AM
filename='/path/to/file with spaces.txt'
nano $filename
 
That ^
 
@edwinksl Or.. they simply say "Read the Wiki" for everything
 
is word splitting
 
That will fail because nano would get "/path/to/file", "with" and "spaces.txt" as separate arguments.
And if you use a variable as positional argument, you might even consider placing -- in front of it to protect it from arguments starting with -.
The downside is, sometimes quoting can become messy.
 
@ByteCommander well that clears it.
no... messy is okay as long as its the only right way
 
12:07 AM
@Seth yup, we were talking about it yesterday.
I like the fact that it's compact.
 
@ByteCommander echoing that doesn't actually remove files and directories
 
Huh, of right.
Why doesn't it execute...?
(I mean, --no-preserve-root would be missing anyway, I'm not that evil, but still)
 
@ByteCommander because you want backticks there
 
@Serg Oh wow, that was fast. You're OMGubuntu's shooting star. They could make a weekly column just for your indicators.
4
@Serg How?
 
Hahaha , this is .... aghraaa..... (but he is right)
wait a sec, where is my screen shot ?
 
12:14 AM
@ByteCommander well, would be awesome, but i don't have weekly indicator ideas, plus that would be difficult to maintain , but i do like the attention :D
 
@Serg This is definitely the start of a career in open source.
 
They definitely have you on their watchlist.
 
@ByteCommander i believe it should be file='rm -rf /*' but not 100% positive
em . . . dammit chat forma
formatting
 
Let's try it with something safe to test... like uname.
 
12:16 AM
@edwinksl see ? Its just .. not democracy , Mods rule the place
 
$ text=uname
$ echo $text
uname
nope
 
@chaskes I hope so. It's definitely something to put on resume
 
@Serg Before much longer I think you can find a paid position on some project (or canonical?), especially once you finish the EE.
 
@SeverusTux what? they can't seem to handle criticism
 
@ByteCommander well, Joey, the owner of omgubuntu has my repository starreed, so i gues he checks sometimes what stuff i upload, but also, I'm sure they surf AskUbuntu for hot network questions. I know Andrei, the owner of webupd8 is on AskUbuntu , he has an account, so that's how he found me.
 
12:20 AM
nice :)
You're becoming a little Ubuntu celeb.
 
^^ yep
 
Nah, not a celeb. Just a guy who enjoys coding stuff
 
@Serg is awesome
8
 
And also enjoy competing. A lot of my progress is because I always pushed myself to compete with Jacob and kos, and others.
 
@Serg I might need an extra day to get packaging for your indicator together - unexpected work came up.
Sorry about that.
 
12:24 AM
@NathanOsman it's alright, no rush :)
 
good evening
 
Hey, Ian
how's life ?
 
all fine :)
and you? how's the work in the indicator going?
 
@IanC petty much im working condition, version 1.0 released, was featured on omgubuntu. Gonna work on some improvements i future. So far , I'm happy with how it is
 
DO YOUR CVS
 
12:29 AM
nice, another feat on omgubuntu!
 
@Zacharee1 CVS? Yuck, the 90s called and they want their version control back.
 
@NathanOsman srsli
 
Yes, srsli.
 
CVs
 
actually . . . it's not
DVCS
that's what git is
distributed version control system
same as bazaar
 
12:41 AM
@Serg speaking of Jacob and kos, have you heard anything of them recently?
Or what happened to them?
 
@ByteCommander Jacob is alright, putting out answers. He also made disk usage indicator. kos has disappeared. I've never had any of his personal contact so no idea what happened. I know he has github account so i probably will try contacting him there
also, Yay, i got my first critical comment on the indicator. On the article page i mean.
 
Done with my CVs for today, twice
 
Lol, inspiration != cloning
 
No reviews for me now, I should head to bed...
 
@ByteCommander NAO
PLS
 
12:56 AM
bye :) should go to college
 
My Stevia question made it into HNQ! :O
 
link?
 
@ByteCommander what about stevia
 
I like stevia. It's better than aspartame
 
@Zacharee1 what CVS? i prefer walgreens...
 
1:05 AM
sigh
@onebree lolz
 
We go to rite aid
 
sigh
 
17
Q: Can one be "taste blind" to the sweetness of stevia?

Byte CommanderI bought some stevia powder today and tried to make waffles with it, replacing the sugar. However, no matter how much stevia I poured into the dough (carefully adding tea spoon by tea spoon, tasting it each time), I couldn't really taste any sweetness. Other family members said the dough was alr...

 
@edwinksl But is it at the corner of Happy and Healthy?
 
Okay, good night folks. My battery is falling asleep as well...
 
1:07 AM
@Zacharee1 the hell is that
 
@edwinksl their slogan..
 
Walgreens does have generic Allegra D 12 hour for cheaper though
 
@Zacharee1 lmao really? i never paid attention to slogans
 
sigh
 
Sigh
 
1:12 AM
hgis
 
euheuheuh?
 
Don't make me paste the huehuehue baby...
 
hwat
 
Thank you for reviewing 20 close votes today; come back in 22 hours to continue reviewing.
@Zacharee1 CVS = pwned
 
yayz
 
1:18 AM
@NathanOsman don't you dare..
 
1:40 AM
0
Q: Iptables questions

Pyloueverybody! I'm pretty rusted about *NIX systems and just inherited the task of managing a dedicated server. This box is running Ubuntu 14.04b and was almost unconfigured. I thought it would be a good idea to bring at least a firewall, and iptables was my choice. IMHO, it will be better to lo...

0
Q: infinite activating state for custom build openssh-hpn-sshd on ubuntu 16

Stranger04Really weird problem, spent a lot of time trying to figure out what's wrong... Nothing in google, no errors in debug. I've compiled hpn version of openssh(OpenSSH_7.2p2-hpn14v11), sshd itself is working just fine. The problem is that every 2-3 minutes systemd restarting sshd as it doesn't get tha...

 
@NathanOsman Do you dare
 
le anticipation
 
@JourneymanGeek is this a decent question for Super User? askubuntu.com/questions/829865/…
 
@Seth If it was up to me about that question, I would say yes for Super User.
 
that's what I'm thinking myself.
 
1:53 AM
It almost sounds like a homework question as well, but it could also be requirements from a job. Don't know on that part. But RAIDs get really in depth.
 
haha, I was thinking the exact same things :)
 
But for what OP is asking, they will also have to look into hardware to support the online expansion of RAID as well as software. So, the question really goes deeper. Definitely Super User in my opinion.
 
Gah! The Snappy documentation is awful!
 
I seem to recall ranting about that previously..
@NathanOsman I actually complained about it on twitter and was DM'd by sabdfl himself about how it could be improved.
 
I actually don't care for Snappy yet.
 
2:06 AM
@Mateo Hectane's snap is updated.
 
2:18 AM
 
meanwhile . . . our professor told us we can have a cheatsheet on the exam but we can't put examples on it and he'll give F for the course if he finds anything that can suggest us an answer
so basically, we can have a piece of paper but can't put anything useful on it
 
I'm getting sort of tired of this carp fishing
 
what's the point of a cheatsheet then?
 
exactly - no point
we can put formulas but not mention how to use them
 
2:32 AM
Gah. I give up.
> "Review the commands, daemons and assets section for some more explicit examples on how to define commands, daemons or config declarations."
There is no such "config" section on that page.
The word "config" isn't even in the page.
 
haha, I just realized you can figure out how someone pronounces SQL by what article they put before it xD
 
Yeah, I can't imagine someone saying "an sequel query".
 
exactly
 
WOW! askubuntu.com/q/830970/231142 If you change from IDE to AHCI, if you don't patch the Registry in Windows first, you will have to reinstall. It corrupts Windows, and I have first hand experience with this.
 
@Seth how do you pronounce it? :p
 
2:38 AM
@edwinksl sequel :p
 
OH NOOOOOO
 
It's a matter of preference. english.stackexchange.com/a/7234
 
i always spell it out
 
I must needs restart. brb
 
S.Q.L
 
2:42 AM
I too pronounce it sequel since it doesn't matter anyway.
I guess it will forever be the same argument as JIF and GIF
 
just saying, the official way is S Q L
 
The history en.wikipedia.org/wiki/SQL#History has it the other way.
 
fedora wouldn't boot right with my latest kernel :( had to select older kernel in GRUB. it would go to software rendering mode with no wifi and extreme CPU usage and no graphic drivers loaded.
 
It must be Monday again. My fingers are not working. :P
 
@NathanOsman git into your room pls
 
2:53 AM
> "The acronym SEQUEL was later changed to SQL because "SEQUEL" was a trademark of the UK-based Hawker Siddeley aircraft company."
 
Right.....
 
plus S Q L sounds sexier.
 
I prefer S.Q.L. only because "Sequel" is nearly almost used with MSSQL.
 
You know, these are never winning arguments
 
so.. some of my homework is asking how an attacker could use an HTTP referal forgery in a header attack, but it doesn't seem that useful if you are dealing with a properly configured server. What am I missing?
 
2:55 AM
Lol. "Properly configured server".
As rare as the albino elephant.
:P
 
Fair enough.
 
@NathanOsman tell that to a good sysadmin
 
But I mean, who is doing some kind of referer check to protect sensitive information/as a form of authentication?
 
ideally, nobody.
 
right.
 
2:57 AM
referrals are one of, if not the most insecure authentication methods.
the only way I can see that working, though, is if you can't store cookies
 
as in, entirely useless ;p
 
So SIDs are stored in the URL.
 
Django used to be vulnerable to something like this.
It would trust the HTTP host header and whenever an absolute link was generated, that value was used.
 
If that's the case though, then, you should be checking the current url.
 
3:14 AM
 
Wow, that was fast.
 
Spammers drive me crazy!
 
3:39 AM
@Seth question... may I create an "askubuntu" organization on Docker Hub?
 
@Terrance me too
 
I need somewhere to push the Docker container to.
 
@NathanOsman woah AU getting fancy. is there a github account for AU?
 
heh, only 2 persons
 
3:43 AM
They wouldn't even add me :D
I did get admin access to tbot though.
 
@NathanOsman I don't see why not?
 
considering going to Trump rally in New Hamshire
 
@NathanOsman that seems over protectionist of Marco, seeing as he isn't even around anymore?
 
be a 2 hour drive
 
3:46 AM
@Seth It's not my call, I just take what I get and be thankful.
 
give all AU mods owner over repo.
problem solved
 
@KazWolfe But I'm not a mod.
I'm sure any real mod that asked would be granted.
 
@NathanOsman then we give you peasant rank
 
@NathanOsman well yeah
I'm just being critical.
 
11% of Americans think HTML is a type of STD.
@NathanOsman Is there any open land in Canada?
 
3:51 AM
^--- any mods will be added upon request
@KazWolfe Uhm... yes. We're the second largest country in the world when it comes to land mass.
 
@NathanOsman k i need 1250 secluded acres with power and fiber lines.
 
For your igloo? :D
 
that and a datacenter
 
It would be easy to keep it cooled.
"Let's run protein-folding simulations on our massive cluster!"
"Dude, we just single-handedly melted two glaciers."
 
i approve of this.
actually that would be one badass water cooling loop.
have a giant radiator just going into the nearest body of water...
Hey guys, there's something called a 301!
 
3:59 AM
0
Q: Moving a large directory from one hard drive to another

Peter AI have a home file server that I use Ubuntu on. Recently, one of my drives filled up so I got another and threw it in there. I have a very large folder, the directory is about 1.7T in size and contains a decent amount of files. I used GCP to COPY the files from the old drive to the new one and...

0
Q: Printing from the command-line returns "aborting from (stdin)" in an infinite cycle

SahibPrimePre-post: Even though my system is Ubuntu, I posted it here because I feel like the problem isn't related to my distribution. This is pretty strange. I've hooked up an HP printer to my computer via Wi-Fi. Its name is SahibPrinter. I learned about the lp and lpr commands, and so I decided...

 
@KazWolfe That seems like the kind of company that paid $1k for a fancy EV certificate and they want you to know it.
 
No. Just a standard one.
 
They must really be broke.
 
they're a community college
who, fun fact, serve session cookies over plain HTTP
Their login form is in HTTPS, and then it falls back to HTTP because reasons.
 
4:27 AM
VTC off topic?
 
@Terrance think so
 
Probably from Kali? But it also sounds dangerous to support something like that to begin with.
 
5:16 AM
gah. selling a gen-old iPhone for a decent price is hard
 
@Serg I fixed my problem
you can't have an empty __init__() method
if you are using init() then you should define it
otherwise you get an indentation error
 
I'm getting pretty annoyed with Docker and the "filesystem layer verification failed" error.
Apparently the only fix is to rebuild the image cache.
Which means stopping EVERY CONTAINER ON THIS SERVER, deleting the images, then pulling them again.
I'm not amused.
 
wanna play with ios stupidity instead?
i'd gladly trade, @NathanOsman.
 
@KazWolfe combine for star :)
 
too late for combine
 
5:30 AM
gah
DO NOT STAR THIS POST
 
k
if you want to star farm, @Windows3.1, just say @Zanna is awesome.
6
 
lol
 
@Windows3.1 is awesome
:P :P :P :P :P
wHo ReTrAcTeD?
 
you've exhausted your use of that meme.
which is probably why everyone retracted
 
5:39 AM
i want to make a meta post that just says ZANNA IS AWESOME over and over again.
but that would be abuse :(
 
haha
 
way to farm rep in MSE
 
huh.
 
@KazWolfe is awesome
I promise I won't change that ^
 
@edwinksl UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME UNICORNS ARE AWESOME
@Windows3.1 preach!
 
5:41 AM
ez MSE rep, go for it
 
REPENT FOR THE KINGDOM OF GOD IS AT HAND
:P
 
bible pentagram time!
 
@KazWolfe All scripture is given by inspiration of God, and is profitable for reproof, for correction, and for instruction of righteousness.
 
5:43 AM
@edwinksl hahaha "please clarify your specific problem"
 
lolol
 
But they are cute.
:D
There is only one hedgehog. We could vote to close as "cannot reproduce" >:)
6
 
yesterday, by Serg
so somebody has built a pentagram out of new testament books
 
.........and the bot is up!
“That doesn't preclude me from making bad puns though. I can be unfunny in 14.7 languages.” — terdon http://chat.stackexchange.com/transcript/201?m=32599418#32599418
 
5:46 AM
First tweet in its glorious automated-ness.
@KazWolfe Thanks ever so much for sticking that between my two messages ಠ_ಠ
 
@NathanOsman you're welcome
 
@NathanOsman so, what's the algorithm to get on the list for the day?
 
It's not an algorithm.
The app automatically selects messages and then an admin selects ones to add to the queue.
Once they are added to the queue, they are tweeted at regular intervals.
 
so... how does the app select messages?
 
5:48 AM
I have to object to the bacon...
 
Currently, 4 stars or mention of "bacon" :D
@Zanna ...that was timely :P
 
is there a clause in there that blocks the post from even reaching the list if it's made by me?
 
haha I love the background image
 
@KazWolfe No. Not yet at least.
 
also.. My god. I only want to sell this crap iPhone and get a OP3. Why is nobody buying ;-;
@NathanOsman That should have been part of the initial spec lol
because i'll do this.
WHATEVER YOU DO, DON'T POST THIS TO TWITTER OR THERE WILL BE NO MORE BACON
 
5:51 AM
@AAHS is awesome. @AALS is awesome. @ABAC is awesome. @ABAS is awesome. @ABBA is awesome. @ABBE is awesome. @ABBS is awesome. @ABED is awesome. @ABET is awesome. @ABID is awesome. @ABLE is awesome. @ABLY is awesome. @ABOS is awesome. @ABRI is awesome. @ABUT is awesome. @ABYE is awesome. @ABYS is awesome. @ACAI is awesome. @ACCA is awesome. @ACED is awesome. @ACER is awesome. @ACES is awesome. @ACHE is awesome. @ACHY is awesome. @ACID is awesome. @ACME is awesome. @ACNE is awesome. @ACRE is awesome. @ACTA is awesome. @ACTS is awesome. @ACYL is awesome. @ADAW is awesome. @ADDS is awesome. @AD
 
Want a screenshot of the Super ChronoWarping Tweet-o-matic Multi-Collider™ interface?
Or what we call the queue page?
 
i want root access.
i have sandwiches
 
took ten million lockups on 16 gb ram to get that :P
 
You think you can find a way in?
Ha. Bring it.
^-- famous last words of a sysadmin
 
5:52 AM
hey, nobody got into wolfbot yet
and i bet there are at least a few good security holes.
 
There probably are if we're honest. But the easy ones are taken care of.
 
let's make a little deal, Nathan.
First person to break into the other's bot gets +500 on one of their answers.
 
No thanks. I am way too busy for that.
Here's the screenshot, BTW.
 
but that would have been an easy +500 for you
you can throw arbitrary exceptions.
so what's under Settings and Users?
 
If this were C++, I would totally create an Up class for exceptions.
throw Up();
Get it? Ba-dum-tshhh...
 
5:55 AM
i mean, you'd get that +500 in no time because you have complete admin over wolfbot.
meaning, you're practically unlimited in what you can do.
 
@KazWolfe Settings isn't built yet and users just shows registered users who can log in.
 
oh well.
so, how do i get on the users list?
 
Wait until I properly implement permissions.
Right now there is only one type of user - the super-admin.
 
this gives me an idea.
you mind if i try something?
 
6:06 AM
@Windows3.1 acai is actually awesome. I wish I had some of that right now
 
@Zanna :D :P :) (: (-: :-) ;D ;) (; ;-) (-; :~
 
you know @NathanOsman, I think your code is actually pretty on the secure side
I can't send any request to the server without having valid credentials, and I know of no way to escape or force Go to break out of a variable or similar.
 
@KazWolfe Thanks.
 
hate
google
 
6:12 AM
@KazWolfe You found the URL?
 
chrome
 
@NathanOsman yep.
 
!!!!!!!!!!!
 
i'm a good guesser
@NathanOsman The only security problem that could be potentially bad is if the config file was somehow exposed.
I can't do that through the URL though, because it demands I have access, so I'd need to pull it from somewhere else. And I'd assume it's in docker?
 
user image
2
apparently that was titled Chatty Capybara imgur.com/gallery/Sj5n56h
 
6:17 AM
so, there you go @NathanOsman. +1 from my very hasty security audit
 
time to go get breakfast...
 
and your login thing passed the poop test.
 
@KazWolfe no config file. Settings are passed to Docker as environment variables.
 
@NathanOsman then there really isn't a way to dump that, unless i can possibly grab your history
 
You can't get history from the container.
It's isolated from the host.
 
6:25 AM
well then, i can think of no way in.
(no, i mean use directory traversal or an NGINX bug on some other domain not dockerized, but i can't think of any good ones)
and your Flack Overstow just generated a great one against me:
but it's too long for the chatbox for some reason
> Make sure the highlighted checkbox is selected: I've gone ahead and made a really bad idea), a guide is available.
> (Don't ever interrupt an I/O error)
(good advice, that one)
> After you're sure that if you're running KDE, use the ubuntu-desktop package
> In all seriousness, there's no "one" way to master an operating system and "clean up" your package cache.
goddamn some of these make sense!
 
The singularity is here >:)
 
@NathanOsman all thanks to tbot
 
yeah nathan get better URLs :P
 
nathan@nathan-desktop:~/Documents/repositories/[...]$ git log
commit d2981dd33e875d516dca1e5a233899c6d16fe55d
Author: Nathan Osman <nathan@quickmediasolutions.com>
Date:   Wed Sep 28 23:36:03 2016 -0700

    Not sure what I changed here but here's a commit anyway.
I love descriptive commit messages.
I made some changes about a month ago.
Can't remember what the changes do anymore.
But the thing works, so off it goes into Git.
 
how to write descriptive commit messages:
have your lead dev bang it into your head.
 
6:38 AM
...on commit messages.
 
Fleshed out ChatChannel into a hopefully usable prototype.
===================================
- Added CommandChannel (/ch <channel>) to allow users to switch active channels.
- Added a method to ChatChannel to allow passing of a specific default
- Added methods to ChatListener and PlayerListener to handle channels a bit better.
- Added CoreDefaultChatUtil, to auto-register defaults until I find a better way.
- Added CDCU to CompetitiveCore, so things are actually registered on load.
and a good commit message --^
 
fun fact: these are typical for my projects :D
Documentation, code improvements, more documentation, some cleanup.
- Added documentation! Again.
- Added new features to the Ban class, specifically BanType management
- Made minor tweaks to chat events, refactored. Update other programs accordingly.
- Added even more documentation.
- Deprecated some useless and annoying code.
- Refactored everything touching the chat event class. `commandResponse` was a bad name.
- Added bugs
- Fixed a bug where there were no ToDos.
     - I'd put them in the bug tracker. IF WE HAD ONE!
 
[ SmokeDetector | MS ] Bad keyword in body, bad keyword in title, blacklisted user: When the final whistle journeyed though buy fifa 17 coins by bobgull on askubuntu.com
 
Sigh - which would I rather: pay Comodo for another wildcard cert or switch nearly two dozen domains to Let's Encrypt?
What a pain-and-a-half.
Anyway, enough for now. Bedtime for me.
 
6:53 AM
LE
le is pretty easy
 
goodnight @NathanOsman
 
Have a good rest, everyone.
 
pce\
 
7:13 AM
hi
dose any one know what might be the cause of ERR_SSL_OBSOLETE_CIPHER
 
what's the context? when did you get the error?
 
i have a web site and payment gate way . so when i redirect from my web site to payment gate way server . this is the error whihc i am geting
both of my website and pg are ubuntu server
 
Why not ask a question on the site?
 
7:31 AM
0
Q: Gdb pretty printer is not working in Ubuntu 16.04

AjithI have debugged C++ codes using gdb in Ubuntu 14.04. When I pass a stl container to the print command, it used to print the contents of the container. But then I upgraded to Ubuntu 16.04 LTS a week back. Now those pretty printers are not working. When I print them I get those raw container output...

 
7:42 AM
1. Send a ClientHello without DHE.

2. If that fails, add DHE back in and retry. If this retry uses a DHE-based cipher, reject the connection with ERR_SSL_OBSOLETE_CIPHER.
Is what I found when we do this.
DHE is en.wikipedia.org/wiki/Diffie%E2%80%93Hellman_key_exchange the key exchange. It seems to fail when that happens.
 
8:15 AM
[ SmokeDetector | MS ] Bad keyword in body, pattern-matching website in body, blacklisted user: Where to buy cheap and safe SWTOR credits? by swtorcredits11 on askubuntu.com
 
@Zanna Please check your Low Quality Posts history for one hour ago.
 
8:40 AM
Another user who deleted his valid (but duplicate --> post might be helpful as signpost) question: askubuntu.com/q/830966/367990
 

« first day (2192 days earlier)      last day (1516 days later) »