« first day (1960 days earlier)      last day (55 days later) » 

12:01 AM
[rubberduck-vba/Rubberduck] 9 issue comments.
[Zomis/Server2] 4 commits. 273 additions. 102 deletions.
[Minesweeper] Games Played: 52, Bombs Used: 43, Moves Performed: 7397, New Users: 10
4 hours later…
3:34 AM
@IvenBach Just logged in to say sorry about your mom.
4:15 AM
Enhance MemberAttibutesRecoverer to deal with properties

Now, the key used to identify members is (memberName, memberType) instead od just memberName. This is necessary because Get, Let and Set properties share the same name.
Merge pull request #5224 from MDoerner/FixAttributesRecovery

Fix member attributes recovery for properties
1 hour later…
6:05 AM
Oh sorry @IvenBach
My thoughts from me also
6:16 AM
Thanks. Most paperwork has been found and respective parties called. Still trying to get the apartment cleared out. Very tired of continually clearing the apartment out.
Night pond. Keep up the work.
1 hour later…
2 hours later…
9:18 AM
> Hello, me again! I'd like to work on this issue please.
1 hour later…
10:21 AM
I have a curious test failure.

A test, which has been passing for month and months has suddenly started failing. Its a simple test which compares two strings to see if they are the same.  The specific comparison is to see if both string comprise three vbCrLf.

Public Sub GetFormattingReplaceString_01_nl3()

Dim myExpected                     As String
Dim myTest                         As String

    On Error GoTo TestFail

    myExpected = vbCrLf & vbCrLf & vbCrLf  'Passes if I substitute String$(3,vbcrlf)
1 hour later…
11:42 AM
[rubberduck-vba/Rubberduck] bclothier pushed commit db52bdbb to next: Create VariantConverter to enable us to do comparisons just like VBA/VB6
[rubberduck-vba/Rubberduck] bclothier pushed commit 67e205e5 to next: Unignore tests and provide a COM objects to support tests.
[rubberduck-vba/Rubberduck] bclothier pushed commit a6ac1477 to next: Merge branch 'next' of github.com/rubberduck-vba/Rubberduck into MiscBugFixes2
[rubberduck-vba/Rubberduck] bclothier pushed commit 137d68a4 to next: Remove the superficial localization from a test that did not actually use it.
[rubberduck-vba/Rubberduck] bclothier pushed commit a3a642cd to next: Merge branch 'next' of github.com/rubberduck-vba/Rubberduck into MiscBugFixes2
[rubberduck-vba/Rubberduck] bclothier pushed commit 4646c49d to next: Revert the en-US locale and add additional localized tests around US-formatted dates as string in different locales to document the behavior of changing from strings to dates usi
Merge pull request #5207 from bclothier/MiscBugFixes2

Make PermissiveAssertClass more permissive
12:29 PM
@M.Doerner I've been getting this fairly regularly of late, too.
Yesterday blew my mind :-D
Did you know that BASH has Dictionary form of container type? :-D I surely didn't for the past 4 years... :-D
Something like in python:
dc={'name': 'pikachu'}
print(f"What is this pokemon. It's {dc['name']}")
In bash:
declare -A dc=( ["name"]="pikachu")
echo "What is this pokemon. It's ${dc['name']}"
My IT superior (which codes in bash for 25 years) didn't know about that either :-)
howdy, @SonGokussj4! That's actually pretty handy. If only I had reason to do any bash scripting these days...
12:48 PM
> Couldn't using resx = Rubberduck.Resources.Inspections.InspectionResults; fix the naming clash with UnreachableCaseInspectionTests?
[rubberduck-vba/Rubberduck] Unrecognized author pushed commit 4d0c038c to next
Enabled Vertical scrollbar to auto.
Added Min height/
Merge pull request #5227 from saurabhrajguru/feature/srajguru/EncapsulateFieldUIImprovement

"Encapsulate Field" Enable Vertical scrollbar and Set Min Height
> @glowingrunes awesome! feel free to ask any questions here, and submit a PR with closes #5135 in the description of one of the commits (or in the body of the PR itself) when you're ready for review!
[rubberduck-vba/Rubberduck] BZngr pushed commit 180d9a15 to next: Safer cast
Merge pull request #5229 from BZngr/EmptyMethos_InvalidCast

Avoid Invalid Cast exception in EmptyMethodInspection
1:10 PM
[rubberduck-vba/Rubberduck] build for commit 255c6bf7 on next: AppVeyor build succeeded
Stop including enclosing brackets into the name of enum elements

The VBE ignores the outermost enclosing brackets both for references and declarations.
Return the identifier name of the declaration from reference.IdentifierName

Returning a bracketed expression instead makes querying the references base on identifier name complicated and surprising.
Merge pull request #5230 from MDoerner/FixEnumMemberResolution

Fix enum member resolution
Easy up there, releaseduck, that's 3 installs already this morning!
[rubberduck-vba/Rubberduck] build for commit d5c9b77a on next: AppVeyor build succeeded
hrm... I finally got Task Scheduler to launch my Access project so I can test my command line parameter code.
> Enabled a horizontal scrollbar to appear automatically in the Code Inspection window when the window size is decreased enough.

Closes #5135.
Had to launch the .accdb directly as the "task" to start, then put /cmd "myparam" in the command line parameters field.
Didn't work when I tried to start msaccess.exe as the application to start with the .accdb and the /cmd in the parameters field.
Now, it says that the "task is currently running" for the last 35+ minutes, but there's no msaccess.exe in the task manager, and the log file that it generates indicated that my code exited and closed out.
@this - You'd recommended a replacement task scheduler, but I didn't bookmark it & I lost the open tab in a browser update incident. mind reposting?
Even more worrying, though the log indicates my code exited with no errors, it also doesn't indicate that it actually did anything... :/
well... Access didn't exit because the Application.Quit was commented out... But why din't it do anything???
thank you kind sir! Bookmarked this time
blarg! it's not finding the parameter, that's why it din't do nuttin
Luuuucy! You got some s'plainin' to dooo...
I'm calling it from the Run command with this: /cmd "ApptPlusAPI" tacked on to the end.
in my log, I get this: Command line parameter (from 'Command'): ApptPlusAPI "
Yeah... all those extra spaces at the end. But wait, are they spaces?
UBound(Split(Command)): 6"
[rubberduck-vba/Rubberduck] build for commit a9611a1c on unknown branch: AppVeyor build succeeded
2:29 PM
"Command line parameter (from 'Command'): ApptPlusAPI      "
"Command line parameter (from 'Trim(Command)'): ApptPlusAPI"
"UBound(Split(Command)): 6"
"Split(Command))(0): ApptPlusAPI"
Which is the recommended way of accessing the command line parameters? via Command or via Split(Command) then picking the desired one?
Yer the captain of the fate here.
this msdn doc page is specifically for Access (2003!) and indicates using Command. this doc page says it's for VBA, but is a general "language reference" page and has a VB example of parsing through Command one character at a time shudder.
I usually just use one big word and switch via Select Case Trim(Command)
I don't trust spaces or whatever
so stuff like DoThisStuff|ParameterA|ParameterB then Split on | seems preferable.
I'll trim 'er up and see what happens.
and avoid exotic characters, too. You need to have it be compatible with the command line environment, too
don't want to go down the double-escape hellhole
2:39 PM
but I like exotic characters. They're... exotic!
sometimes, they're even unsavory, too!
Ok, have fun in the hell, then! See ya!
winner winner chicken dinner! My log is now filling up with all the things it should be filling up with, and... Access closed and I've got my email!!!! :D
PeTA does not appreciate the wanton slaughter of chickens.
People Eating Tasty Animals most certainly do approve of such thing!
windoze task scheduler, however, does not seem to like my workings... It claims to have started the task and that it's currently running, however, I see no msaccess.exe process in Task Manager and I have no new log file. :/
trundles off to download System Scheduler to see if that'll do better
Task scheduler is like that.
It may deign to work.... or not.
2:57 PM
yeah. Trying the 30-day pro eval. for $30 I'm pretty sure I can convince the powers that be to pop for it if it's suitable for purpose...
wow... looks like it uses Win95 dialog boxes, icons and fonts!
showing its age...
it works though!
which should make Microsoft feel ashamed, TBF
I dunno, MS is pretty resource bound...
they're busy changing things because they can
it takes a lot of effort to write standards then willfully ignore them.
They must have massive departments of QA people to ensure their software violates their own standards!!!
schweet! Thanks for that System Scheduler tip. I like the fact that it can run the task as System if I'm not logged in. Handy for when IT decides to reboot my machine in the middle of the night...
Now, to push to Prod on a Friday!! :D
lives on the edge
@FreeMan Today's a good day to fry!
3:12 PM
mmmm.... wanton fried chicken wonton....
oh my... I'm hitting a lot of those new The expression {x} contains a default member access to... inspections!
thankful for the Fix all in procedure option at a minimum!!
learns where they need to be made explicit that way
3:34 PM
Did a quick look through RD and didn't see anything for ease of context menus. Have you lot taken a look at some of the ease of writing aspects, e.g., for a context menu i need A) the menu to affect, B) the code to add a button to the context menu, and C) the code to be executed when the context menu button is selected

If i missed a tie-in to ThisWorkbook Module and Standard Modules, sue me, though that's what i wasn't seeing. I did see some hand-holding related to Change_Events, seemingly linking the Sheet modules and the Standard Modules
not sure if that would be better to tag vogel, mat, or ben... or even duga, but i thought duga was a bot to post updates from RD to this channel
Yes, Duga's pings are, apparently, only checked by Simon about once a year so she can earn her Christmas hat(s). She's really only referenced so comments don't appear to be random blathering, but have some context.
@Cyril Sorry I don't follow --- do you meant you want RD to help with building menus?
@this I noticed that a few items in RD help you go back and forth, checking that you have appropriate references in each Module (Class, thisworkbook, sheet, standard). i didn't see one for ThisWorkbook
> **Rubberduck version information**
The info below can be copy-paste-completed from the first lines of Rubberduck's log or the About box:

OS: Microsoft Windows NT 10.0.18362.0, x64
Host Product: Microsoft Office x64
Host Version: 16.0.12130.20184
Host Executable: WINWORD.EXE

Two code inspection errors have emerged in my project with 5097. These Code inspections are incorrect and did not appear with 5096 or 5086

1. EmptyMethodInspection

Warning: Library funct
> **Rubberduck version information**
OS: Microsoft Windows NT 10.0.15063.0, x64
Host Product: Microsoft Office 2016 x64
Host Version: 16.0.4873.1000
Host Executable: MSACCESS.EXE

I'm told to replace `Right` with `Right$`, but the code clearly contains a `Right$`.

**To Reproduce**
Steps to reproduce the behavior:
1. write code:
Private Property Let IWebDownloader_DestinationPath(ByVal inValue As String)
If Right$(inValue, 1) = "\
3:48 PM
@Cyril hm. I'm even more confused now. Go back and forth how?
@Duga I'd suggest removing the 2nd portion of this report since I just created an issue for the exact same thing. Makes it cleaner if there's just one (related) report per issue, I'd think
I guess the resolver need more tests still
4:23 PM
> I submitted #5233 on the false positive UntypedFunctionUsage inspection at almost the exact same time as Steve submitted this one.
5:01 PM
mkay... I can fire off my accdb in my DEV environment, pass it a parameter, and have it do its automagic processing.
When I change the path to point to the PROD environment (yes, after having moved the code to PROD) and leaving the exact same parameter string, it's not detecting that there's a parameter there.
and now... it finds it. hrm... wonder if it was missing a space between .accdb" and /cmd...
that's the only possibly reasonable thing...
how would it parse the /cmd without a space?
well, I guess it wouldn't...
you'd think, though that "\\server\path\file.accdb"/cmd "param" would work with or without a space before the /, but I guess maybe it doesn't
either that or, nonsensically, it didn't want to run it because I also had another Access db open at the same time?
^ skeptical, but this is Microsoft we're talking about...
nobody does command line parsing consistently AFAIK
I am aware there are cases where you could get away with not having a space
but as a general rule, just don't invite troubles like this.
most *nix programs will parse parameters pretty robustly
notice hedge words there...
Yeah, I'm not 100% if it was missing that space, but I'm thinking that may have been it.
*nix ≠ Windows
Windows as a rule is ..... less than stellar ... when it comes to command line programs
5:14 PM
I don't think it was a missing space - I only have 1 "Prod" command in my Run history and it's got a space in it.
sigh... now I ran it from the scheduler, to ensure that would work and I got ActiveX component can't create object when trying to put together an email to send out with results...
We're having network issues here today, so I'm going to chalk it up to that.
@Duga That bug is probably on me.
However, I would have expected a test to exist for this.
TBH I was surprised, too. I thought we already had tests for the untyped functions.
Yup, there's the problem! I opened my DEV .accdb file, then launched the task to run the PROD version. The PROD version reports no command line parameter. Close both .accdb files, launch the PROD version from System Scheduler and bingo, it sees the parameter.
Gonna be tough getting used to ensuring that I've got the dev version closed on my machine at the end of the day to ensure it runs.
@M.Doerner nobody expects the Inquisition!
♫The Inquisition, what a show...♪
now that sounds familiar.
5:24 PM
I recall a MVP commenting about that oddity
oh, wait, what sounds familiar?
the parameter thing or the little ditty?
and he resorted to using VBScript rather than batch files to work around that.
the parameter thing.
or the little ditty.
Take your pick. ;)
I'm not using a batch file, though. I directly launch the .accdb from either the Run command or from the scheduler.
also, just realized that if I can get our server access to the appropriate network locations, I can have the scheduler running over there and not have to worry about my machine being up.
> Found this old issue via SO link. The issue seems to be more about adding a command and the subsequent discussion is that we'd rather remove it. However, that would make for a terrible UX because if you provide a command to remove line numbers, people will understandably wonder where is the command to do the opposite.

Here's a better UX -- this should be an inspection, with a quickfix to remove the line number.

For the cases where we might cause code to break (e.g. a line label as a ta
6:22 PM
> @bclothier don't we already have a "label not used" inspection? it should be trivial to make it work with line numbers that aren't referenced. Only thing is.. it would spawn an awful lot of results in a large project that uses line numbers everywhere.
> I don't think that's the best use of that particular inspection. Besides, we'd want the "Gratuitous Use of Line Number" inspection to run per-procedure scope, not per-line scope, right?
> That does make sense. No more than one warning per scope for unwarranted line numbering, and the quickfix would leave used/referenced line numbers alone (while another inspection would recommend turning them to line labels instead)
6:47 PM
Oh, why didn"t I see that in my code review? The ! in the EmptyMethodInspection is at the wrong spot.
1 hour later…
7:59 PM
uggh, look at all the Select in this MS documentation - yikes
8:10 PM
eh... the crash on exit isn't limited to Excel. Outlook just puked on me and I have zero code running against it. I would say definitely not an RD issue.
8:39 PM
> Closes #5232 Closes #5233 This PR puts the ! in the condition in EmptyMethodInspection at the right spot with the effect that declared external functiona are out of scope. Moreover, it fixes a test for UntypedFunctionUsageInspection and changes how the IdentifierName on references is derived to make it pass. Instead of the previous change to always use the IdentifierName of the declaration, now only the outermost enclosing brackets get removed, which is in line with how the VBE...
interprets the references.
@BigBen The examples in the Excel object model documentation are abysmal.
@Duga I messed it up, so you get a fix from me.
We should sic ducky on all the VBA examples in ms docs. Here’s your 30,000 results that ducky is not happy with.
8:56 PM
[rubberduck-vba/Rubberduck] build for commit d7ee4790 on unknown branch: AppVeyor build succeeded
1 hour later…
10:09 PM
At work, with my Office 2017, when I "unfold" one of the Code Inspections, only one is unfolded.....
But at home (Office 2019), when I unfold the same thing (I've got the same version of RD], it unfolds ALL of them. Not just one.
11:03 PM
[rubberduck-vba/Rubberduck] MDoerner pushed commit 20607965 to next: Stop considering declare statements for EmptyMethodInspection
[rubberduck-vba/Rubberduck] MDoerner pushed commit d7ee4790 to next: Only strip enclosing square brackets from the identifierName of references
Merge pull request #5234 from MDoerner/FixUntypedFunctionInspection

Fix untyped function inspection
Can someone kindly remind me what is the preferred way to instantiate a logger class?
11:50 PM
#FunFact: today we closed the 2,500th issue with #5233
[rubberduck-vba/Rubberduck] build for commit 01867d65 on unknown branch: AppVeyor build succeeded

« first day (1960 days earlier)      last day (55 days later) »